20:01:33 <ttx> #startmeeting tc
20:01:34 <openstack> Meeting started Tue Nov 20 20:01:33 2012 UTC. The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:01:35 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:01:36 <openstack> The meeting name has been set to 'tc'
20:01:43 <ttx> Agenda for today is:
20:01:49 <ttx> #link http://wiki.openstack.org/Governance/TechnicalCommittee
20:02:00 <ttx> #topic Vote on direction for Incubator/Core process update
20:02:16 <ttx> This is about selecting a vision for how to handle incubation and core inclusion in a world where the TC coexists with the BoD
20:02:26 <ttx> This vision will be defended by 2 or 3 TC members in a joint committee with BoD representatives, starting next week
20:02:32 <ttx> We had a lengthy thread at:
20:02:36 <ttx> #link http://lists.openstack.org/pipermail/openstack-dev/2012-November/thread.html#2387
20:02:45 <ttx> Three visions emerged, which I would summarize like this:
20:03:01 <ttx> * (markmc) Separate the trademark question from the "developed under OpenStack umbrella" question, have incubation be the process by which you become supported
20:03:16 <ttx> (please add more to that description if you think it's unfair or incomplete)
20:03:33 <ttx> * (annegentle) Same as markmc, but separate the "developed under OpenStack umbrella" projects into two categories with different associated resources attached to them
20:03:50 <ttx> * (notmyname) Keep core co-defined by TC and BoD, restrict core to IaaS projects, incubation is the road to core, keep other projects out of OpenStack infrastructure and focus
20:04:12 <ttx> As far as the discussion with the BoD is concerned, it just looks like two options to me
20:04:26 <ttx> One of them with two variants on how the TC would internally organize the resources associated to projects
20:04:47 <ttx> So as a first step I propose we vote between:
20:04:55 <ttx> * (annemark) Separate the trademark question from the "developed under OpenStack umbrella" question, have incubation be the process by which you become supported, potentially with multiple categories as far as associated resources are concerned
20:05:07 <ttx> * (notmyname) Keep core co-defined by TC and BoD, restrict core to IaaS projects, incubation is the road to core, keep other projects out of OpenStack infrastructure and focus
20:05:14 <ttx> * (abstain) None of the above, we need to discuss this for one more week
20:05:26 <ttx> Any question/discussion needed before we start voting ?
20:05:45 <gabrielhurley> are we voting numerically, by name, etc?
20:05:49 <russellb> can we give options a number so the vote results don't look like a popularity contest? heh
20:05:59 <annegentle__> heh
20:06:11 <ttx> russellb: i can do that
20:06:22 <markmc> this annemark person sounds awesome
20:06:23 <annegentle__> I won't get my feelings hurt, really
20:06:24 <ttx> gabrielhurley: you'll see when I start the vote process
20:06:33 * annegentle__ snorts
20:06:43 <ttx> everyone cool with voting on this now ?
20:07:04 <notmyname> wait
20:07:19 * ttx freezes
20:07:27 <notmyname> what's the criteria? majority? plurality? supermajority? unanimous?
20:07:54 <ttx> notmyname: same as usual. We'll have optionA, optionB, abstain
20:08:00 <annegentle__> is the vote for "this is what we tell the board we agree to?"
20:08:05 <ttx> to win, optionA needs more votes than optionB
20:08:17 <ttx> and at least 5 votes
20:08:27 <ttx> (same as a yes/no motion)
20:08:41 <notmyname> ok, thanks
20:09:07 <ttx> notmyname: that would make it a majority with affirmative voting threshold.
20:09:49 <ttx> OK, so option1 = annemark, option2 = notmyname, abstain = abstain
20:10:07 <ttx> #startvote Which vision for incubation process should we defend in the BoD/TC joint committee? option1, option2, abstain
20:10:07 <openstack> Begin voting on: Which vision for incubation process should we defend in the BoD/TC joint committee? Valid vote options are option1, option2, abstain.
20:10:08 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
20:10:15 <russellb> #vote option1
20:10:20 <markmc> #vote option1
20:10:21 <gabrielhurley> #vote option1
20:10:23 <annegentle__> #vote option1
20:10:26 <bcwaldon> #vote option1
20:10:28 <ttx> #vote option1
20:10:30 <notmyname> #vote option2
20:10:38 <danwent> #vote abstain
20:10:43 <jgriffith> #vote option1
20:10:51 <heckj> #vote option1
20:11:12 <ttx> 30 more seconds
20:11:42 <mordred> #vote option1
20:11:54 <ttx> #endvote
20:11:55 <openstack> Voted on "Which vision for incubation process should we defend in the BoD/TC joint committee?" Results are
20:11:56 <openstack> abstain (1): danwent
20:11:57 <openstack> option2 (1): notmyname
20:11:58 <openstack> option1 (9): markmc, bcwaldon, ttx, heckj, russellb, jgriffith, mordred, gabrielhurley, annegentle__
20:12:09 <ttx> #agreed option1 (annemark) vision will be defended on the BoD/TC joint committee on the future of incubation/core
20:12:25 <ttx> danwent: does your abstain mean you'd have love to have time to propose another option ?
20:12:38 <heckj> no love for danwent!
20:12:46 <vishy> #vote option1
20:12:53 <ttx> Do we want to vote today on which of the two variants should be preferred ? Or leave that for a future discussion if our vision ends up prevailing in the joint committee ?
20:12:53 <vishy> btw :)
20:12:56 <markmc> heh
20:12:57 <danwent> ttx: no, it means I am sorry to say I didn't have time to read the whole thread, and therefore am not properly informed
20:12:59 <ttx> vishy: too late :P
20:13:07 <ttx> danwent: ok
20:13:30 <annegentle__> at least you're honest danwent :)
20:13:57 <markmc> ttx, it might be useful info to help those on the sub-committee, maybe a "testing the water" vote ?
20:14:18 <markmc> ttx, it might be all need to be revisited after first sub-committee discussions
20:14:21 <markmc> who knows
20:14:32 <russellb> is it a final declaration, or a "this is how i feel right now, but would abstain if this were a final decision"
20:14:38 <ttx> markmc: I'm fine with a non-binding vote between the two variants, to serve as indicator... if everyone is fine with that
20:15:02 <russellb> i could do that. there hasn't been enough discussion on that topic specifically on the list to do a final vote IMO
20:15:08 <annegentle__> I'd like the extra info as well
20:15:21 <markmc> maybe a vote would no abstain option would be the way to do that
20:15:25 <ttx> maybe we can informally state our preference rather than use the vote
20:15:43 * ttx isn't convinced either way yet (abstain)
20:15:49 <annegentle__> I like informal rather than a vote
20:16:00 <markmc> annegentle__, good point
20:16:04 <markmc> what's people's thinking?
20:16:04 <russellb> ok, so informally ... i really don't like the idea of categories because it seems like putting projects in tiers, and having "second class citizens"
20:16:20 <russellb> and we just need to figure out how to scale the whole project
20:16:29 <gabrielhurley> +1 to russellb
20:16:35 <bcwaldon> +1 to gabrielhurley
20:16:36 <russellb> growing pains be damned, we're going to grow
20:16:47 <jgriffith> personally I'm on the opposite end of that spectrum
20:16:54 <zaneb> fwiw I think it's great that annegentle__ is looking at what the barriers to scaling are and trying to find ways to grow the project without taking resources from existing projects
20:17:03 * ttx thinks it might end up being necessary to have multiple tiers, though I'd prefer if we didn't have to...
20:17:10 <zaneb> I can't comment on the specifics because I'm not familiar enough with them
20:17:29 <annegentle__> I thought of another scenario we're seeing, and that's projects that are open source like StachTach that have no (stated) desire to be subject to OpenStack processes -- is this the other direction we'll see depending on how we have incubation work?
20:17:49 <russellb> if docs are a scaling pain point, then *all* projects need to step up and help fill that gap
20:17:49 <jgriffith> russellb: growing is good, growing to an unmanageable collage of projects is not so good IMO
20:18:15 <russellb> sure, need to have standards.
20:18:33 <markmc> annegentle__, if projects don't want to be in, they're just not in imho
20:18:38 <russellb> jgriffith: but with categories, i'm afraid the second tier will become that unmanageable collage
20:18:41 <vishy> I like the simplicity of no categories but I really think we should keep projects in incubation for longer in that case
20:18:53 <markmc> I imagine for stuff like docs, we'll have "informal tiers" anyway
20:18:53 <jgriffith> russellb: fair point
20:19:00 <markmc> but they're just gaps where we need folks to step up
20:19:07 <vishy> as in there should be some form of quality control for moving out of incubation
20:19:12 <markmc> we have "good at bug triaging and sucky at bug triaging" tiers now
20:19:16 <annegentle__> yeah we do have informal tiers already for various reasons
20:19:16 <markmc> i.e. nova vs the rest
20:19:18 <gabrielhurley> +1 to more rigorous incubation
20:19:19 <ttx> markmc: yeah
20:19:50 <jgriffith> I could see the more rigorous incubation as a good compromise
20:19:52 <russellb> sure, +1 from me too
20:20:07 <ttx> ok, anyone else wanting to voice their opinion on this, before we talk about WHO we send to that joint committee ?
20:20:24 <ttx> (we can come back to this, time permitting, at the end of the meeting
20:20:25 <ttx> )
20:20:33 <jaypipes> for the record I vote option1
20:20:38 <jaypipes> sorry I'm late
20:20:59 * mordred punches jaypipes
20:21:27 <markmc> settle down kids
20:21:32 <ttx> #topic Choice of TC members to represent that direction on the BoD/TC joint committee
20:21:45 <ttx> So... we need to pick two or three TC members to represent that chosen vision
20:21:53 * jaypipes votes annegentle__ and markmc
20:21:54 <ttx> The obvious choice is markmc and annegentle, as the original proposers, but they may not volunteer
20:22:07 <markmc> probably obvious I'm happy to represent
20:22:15 <markmc> annegentle__ and ttx would be other obvious choices
20:22:16 <ttx> Anyone else who wants to defend this to the joint committee ?
20:22:19 <gabrielhurley> when/where is the meeting?
20:22:23 * mordred can/will be around
20:22:28 <ttx> gabrielhurley: I have NO idea
20:22:31 <vishy> it seems like there is more to it than just what we present
20:22:31 <gabrielhurley> lol
20:22:35 <mordred> but also can represent from the other side :)
20:22:37 <ttx> they asjked us to come up with names by the end of the week
20:22:41 <annegentle__> I think I can make the commitment but if I pick up an intern that may change
20:22:53 <annegentle__> I won't know until next month
20:22:56 <ttx> mordred: that's smarter to try to get into that committee from the other side
20:22:58 <vishy> We are saying that the TC is giving responsibility for "CORE" to the BoD
20:23:02 <ttx> I can volunteer as a substitute, if one ends up being needed.
20:23:02 <mordred> ttx: k
20:23:06 <vishy> but they still may want input from us
20:23:20 <markmc> vishy, where "CORE" == "list of projects for trademark"
20:23:31 <vishy> markmc: correct
20:23:38 <markmc> (just being clear :)
20:23:47 <ttx> vishy: we have no idea how that discussion is going to go anyway, I expect the chosen ones to come back and report to the TC
20:24:02 <zaneb> markmc: what if the board is more interested in controlling the scope of OpenStack, rather than the trademark?
20:24:17 <vishy> :)
20:24:31 <markmc> zaneb, I don't think we need to get into hypotheticals
20:24:35 <ttx> so... markmc+annegentle, with me as substitute if one is needed ? anyone else wanting to play ?
20:24:36 <gabrielhurley> that's why you take the baseball bats
20:24:42 <markmc> the TC representatives clearly don't have a mandate to agree to that
20:25:01 <zaneb> fair enough
20:25:06 <annegentle__> russellb: are you interested?
20:25:08 <russellb> i could substitute if needed as well, sounds like a fun time.
20:25:11 <russellb> ha
20:25:15 * annegentle__ can read minds
20:25:47 <markmc> annegentle__, ok smarty pants, what are the board people going to say? :)
20:25:55 * markmc tests annegentle__ skillz
20:26:09 <annegentle__> magic 8 ball says "Future cloudy"
20:26:13 <markmc> heh
20:26:17 <russellb> i see what you did there.
20:26:37 <ttx> do we need a vote on that or is anyone fine with markmc+annegentle with russellb+ttx as substitutes if need be
20:26:48 <ttx> s/anyone/.everyone
20:26:52 <annegentle__> sounds good
20:26:53 <bcwaldon> +1
20:26:56 <heckj> +1
20:27:07 <danwent> +1
20:27:12 <jgriffith> +1
20:27:17 <jaypipes> +1
20:27:42 <markmc> cool
20:27:44 <ttx> #agreed TC members to represent in the BoD joint committee on incubation/core: markmc+annegentle (russellb+ttx to serve as substitutes if needed)
20:28:19 * ttx is happy we came up with something in the limited time that was given to us to organize this
20:28:22 <ttx> #topic Ongoing discussion: Distro & Python 2.6/3.x support policy
20:28:31 <ttx> mordred: you were supposed to push a thread on the ML on that topic
20:28:48 <ttx> Are we waiting on that ML thread to start, or should we use part of the remaining time in the meeting to continue the preliminary discussion on that ?
20:29:22 <mordred> ttx: yes. we are waiting on the ML thread to start - my bad
20:29:28 <markmc> What's the pressing thing here?
20:29:31 <markmc> what to do CI on?
20:29:51 <markmc> e.g. are there 3.x patches waiting for be merged but can't because it would kill 2.6 support?
20:29:58 <markmc> for be merged
20:30:47 <ttx> mordred: ? ^
20:30:49 <mordred> markmc: there's a thread that needs to be started
20:31:04 <mordred> markmc: I could write it all here, but it would be better if I just write the email
20:31:09 <russellb> I'd like to see a good documented list of all the 3.x blockers, as I suspect 2.6 support isn't the only one (dependencies)
20:31:15 <markmc> mordred, ok
20:31:19 * russellb retracts and waits for ML thread
20:31:24 <ttx> #topic Open discussion
20:31:28 <mordred> markmc: the tl;dr is "what do we as a project care about" - but the definitions of that get intricate
20:31:36 <ttx> Then we are back to the open discussion on incubation/core
20:32:19 <ttx> I think we'll still have to build up guidelines for inclusion/exclusion, and those will define how inclusive we end up being
20:33:07 <markmc> totally
20:33:13 <markmc> what did folks think of my starting point
20:33:14 <markmc> ?
20:33:17 * markmc digs up the link
20:33:20 <ttx> even if markmc's vision included a tendancy to be inclusive
20:33:42 <markmc> footnote of
20:33:43 <markmc> #link http://lists.openstack.org/pipermail/openstack-dev/2012-November/002470.html
20:34:08 <markmc> probably the scope part needs most debate
20:34:12 <ttx> In particular, I think we need to limit the rhythm of growth to something we can handle
20:34:59 <markmc> "measured growth"
20:35:02 <ttx> i.e. not doubling the number of projects every 6 months
20:36:04 * markmc cracks open a beer, passes one to ttx and puts his feet up in front of the fire
20:36:35 <ttx> I'm fine with ending the meeting now, unless someone has something else to say
20:36:50 * mordred enjoes beer
20:36:54 <markmc> yeah, sounds like the topic has us all a bit drained
20:36:56 * mordred wishes markmc had given him one
20:36:58 * russellb is jealous he didn't get a beer :(
20:37:03 <heckj> markmc: I generally liked it, with a heavy preference to anything in the bundle of "OpenStack projects' having a very high score on integration
20:37:20 <markmc> heckj, cool
20:37:40 <heckj> markmc: I personally think interop is the hardest linkage to maintain, and where we're still somewhat shakey - even with current core projects.
20:37:48 <heckj> It's where I'm spending all of my time
20:38:25 <ttx> there will be some floating period until we hear back from the joint committee anyway...
20:38:36 <heckj> markmc: I took your first three footnotes as a prerequisite and given to be even thought of
20:38:39 <ttx> no need to get too far if that vision is shot down early
20:38:44 * jgriffith is saving his energy until then...
20:38:51 <heckj> heh
20:39:11 <mordred> yeah. I'm also saving energy until committee feedback time
20:39:36 <markmc> mordred, hey, I assume you'll be a board rep on this thing? :)
20:39:54 <russellb> so mordred, what will the board say? :)
20:40:13 * markmc watches mordred juggle hats
20:41:23 <russellb> *crickets*
20:42:03 <ttx> ok, I can do with one short TC meeting, let's end this
20:42:10 <markmc> yay
20:42:24 <ttx> next week we should have Monty's stuff to discuss, if he gets around to posting this
20:42:31 <ttx> thanks everyone!
20:42:36 <ttx> #endmeeting