20:02:11 <ttx> #startmeeting tc
20:02:12 <openstack> Meeting started Tue Feb  5 20:02:11 2013 UTC.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:02:13 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:02:15 <openstack> The meeting name has been set to 'tc'
20:02:18 <ttx> Agenda for today is:
20:02:21 <jaypipes> o/
20:02:42 <ttx> #link http://wiki.openstack.org/Governance/TechnicalCommittee
20:02:48 <ttx> #topic Schedule for Spring 2013 PTL/TC elections
20:02:55 <ttx> Our charter actually defines the timing for elections, based on the date for the Summit
20:03:02 <ttx> Now that we know the summit date, the timing is:
20:03:09 <ttx> March 1-7: Nominations for PTL
20:03:13 <ttx> March 8-14: Vote for PTLMarch 8-14: Vote for PTL
20:03:16 <ttx> oops
20:03:20 <ttx> March 15-21: Nominations for direct seats
20:03:24 <ttx> March 22-28: Vote for direct seats
20:03:43 <ttx> This is coming fast
20:03:45 <ttx> We need people that are not running for any position to organize those. I can't do that since I need to run for reelection myself.
20:03:53 <ttx> annegentle, mordred: one of you interested in spearheading that effort ?
20:03:57 <markmc> ttx, do we run PTL elections for (still) incubating projects?
20:04:07 <markmc> ttx, or only do that when projects graduate?
20:04:14 <annegentle> wow are we the only two eligible?
20:04:17 <ttx> markmc: no, we have to decide if they graduate /before/ the elections
20:04:26 <annegentle> or can other community members organize them
20:04:37 <ttx> annegentle: you're the only two I /think/ won't run
20:04:38 <mordred> mordred: I can do it if I can start working on it tomorrow
20:05:02 <ttx> annegentle: oh, you can have election officials that are from elsewhere
20:05:14 <ttx> just kinda want someone from the TC to own the process and see it to completion
20:05:23 <annegentle> mordred: awesome because I really can't
20:05:42 <markmc> vuntz and jeblair help with the foundation elections, they might be interested?
20:05:57 <ttx> mordred: we can hook jeblair in, can help with the election lists
20:06:13 <ttx> #info mordred to set up elections
20:06:20 <ttx> mordred: You can start with a copy of http://wiki.openstack.org/Governance/TCElectionsFall2012
20:06:33 <ttx> ask me if you have questions
20:06:51 <ttx> questions on that ?
20:06:57 <mordred> excited
20:07:07 <markmc> good luck mordred
20:07:25 * ttx is happy to offload some of his so exciting tasks to someone else :)
20:07:55 <ttx> ok, no questions I see
20:08:01 <ttx> next topic then
20:08:03 <ttx> #topic Update on the "Future of Incubation / core" joint committee
20:08:16 <ttx> So... we needed to propose a way forward to projects currently in incubation, before it's too late to add them to the integrated release cycle for Havana
20:08:30 <ttx> (we need to decide which projects are "integrated", and therefore have PTLs, before we start the PTL election process, i.e. before March 1st)
20:08:44 <ttx> To that effect we summarized the current position of the Incubation/Core joint committee and that was presented to the Board
20:08:57 <ttx> My understanding was that this being a TC process and no red flag being waved, we should go ahead with that process for the currently-incubated projects
20:09:02 <ttx> markmc, mordred: comments ?
20:09:09 <markmc> so, I summarised stuff here:
20:09:10 <markmc> http://lists.openstack.org/pipermail/openstack-tc/2013-January/000113.html
20:09:27 <markmc> the slightly messy thing is that the committee hasn't finished its work completely
20:09:35 <mordred> ttx: my only comment/concern is what markmc said
20:09:40 <markmc> and we said the TC would go ahead based on the discussions to date
20:09:45 <markmc> after running it by the board
20:09:54 <ttx> right, I expect the committee to continue working until May tbh
20:09:59 <markmc> seeing as this shouldn't need approval by anyone but the TC
20:10:12 <markmc> I presented to the board (as a TC rep) last week
20:10:23 <ttx> The idea would be to have in the remaining weeks of February a "end of cycle incubation graduation review" where we look into the state of the currently-incubated projects
20:10:24 <markmc> but seems like mordred understands what happened a little differently
20:10:37 <ttx> and either accept them as part of the integrated release for havana, or ask them to continue maturing during the next cycle
20:10:48 <ttx> Does this fly for everyone, and if not what would be your alternate suggestion ?
20:11:12 <jgriffith> works for me
20:11:16 <annegentle> markmc: did the board say "do what you have to?"
20:11:35 <Daviey> (As long as these don't suddenly become mandatory (unlikely) for Grizzly, i am a happy bunny :)
20:11:39 <ttx> note that we can start the process based on our understanding, and stand corrected if needed
20:11:49 <mordred> markmc: yeah, that sounds find. for some reason I thought ttx was suggesting we vote to ratify the work in progress state :)
20:11:54 <annegentle> markmc: (Your list message just said something about red flags)
20:12:13 <markmc> annegentle, there was some discussion about process, some support of the progress we made and no objections raised
20:12:21 <markmc> annegentle, but there was no vote on anything
20:12:22 <ttx> mordred: no, just want to tell the incubated project when they will be eaten and with what sauce
20:12:35 <markmc> annegentle, and disclaimer: the official minutes would be the official "what the board said" record
20:13:01 <markmc> annegentle, right, there were no red flags raised
20:13:15 <annegentle> markmc: just looking for the big gotchas is all, sounds like there are none
20:13:19 <ttx> OK, so everyone is fine with us looking into graduation in February, in time to meet PTL elections deadlines on March 1st ?
20:13:21 <markmc> ttx, mordred, would we e.g. do s/Core/Integrated/ in our charter before we consider Heat/Ceilometer?
20:13:38 <ttx> markmc: yes that's my next question actually
20:13:42 <ttx> This new "integrated" concept triggers an interesting related question. As far as our "Charter" is concerned, we have two interpretation options:
20:13:51 <ttx> 1. Consider that what we technically called "core" is now renamed to "integrated" -- and grant all (current and future) integrated projects a seat on the TC
20:13:58 <ttx> 2. Consider that what is called "core" in the Charter still means "core" (although the joint committee did not define that term yet) -- and only grant "core" projects a seat on the TC
20:14:08 <ttx> I much prefer interpretation 1 since otherwise we would basically give the BoD the right to choose which projects have guaranteed seats on the TC
20:14:10 <markmc> personally, I had assumed (1)
20:14:13 <ttx> but since that touches our Charter I figured I should ask the committee first :)
20:14:15 <markmc> (2) hadn't even occurred to me
20:14:20 <Daviey> Silly question .. There isn't intention to couple Ceilometer or Heat as a mandatory component in a deployment, rught?
20:14:38 <ttx> Daviey: there is nothing mandatory.
20:14:42 <mordred> Daviey: the only curently mandatory components are nova and swift
20:14:52 <mordred> Daviey: and that's only if you want to use the trademark
20:15:17 <markmc> the problem with (2) is it involves the Foundation Board in the question of "who gets a seat on the TC"
20:15:21 <markmc> which seems strange
20:15:25 <ttx> markmc: yep
20:15:29 <mordred> yep
20:15:29 <Daviey> sure, but i think most people would consider keystone & glance practically required
20:15:55 <markmc> Daviey, nothing which is in the release currently would depend (even optionally) on Heat or Ceilometer
20:16:06 <notmyname> ttx: while I agree with the spirit of (1), I'd prefer to wait until the committee finishes before redifining things. and choosing (2) does put some pressure on people to come up with the right definitions :-)
20:16:08 <mordred> Daviey: sure. it's just that if you want to talk about _required_ - the only thing you guys are required to implement to call your thing openstack is nova and swift as things are currently written
20:16:33 <ttx> notmyname: the problem is that I don't expect the committee to decide on that before the end of the month
20:16:44 <ttx> *we can defer that decision until then
20:16:46 <mordred> ttx: related to what notmyname said...
20:16:55 <markmc> if we don't decide on (1) vs (2) before PTL elections
20:17:08 <markmc> it would mean the new PTLs wouldn't know whether they will sit on the TC
20:17:21 <annegentle> does heat or ceiliometer have stand-in PTLs now? We're not preventing their technical progress right?
20:17:21 <mordred> what if we did (3) move forward as currently chartered, since it doesn't particularly conflict with the committee direction
20:17:22 <markmc> (new PTLs, if any)
20:17:23 <Daviey> mordred: I'm talking on a pure technical basis.  I think markmc got what i was trying to convey, and confirmed my question perfectly.
20:17:30 <mordred> Daviey: great
20:17:30 <ttx> markmc: yeah, we kinda need to know before the election setup
20:17:34 <ttx> otherwise it will get messy
20:17:49 <ttx> but we could decide that on Feb 28, I guess
20:18:01 * ttx doesn't mind, he doesn't organize the elections this time around
20:18:20 <markmc> I'm starting to think the committee should just wrap up the incubation side of things this week
20:18:32 <mordred> markmc: I agree
20:18:38 <markmc> so the TC can move on without this debate over process
20:18:40 <markmc> but ...
20:18:47 <mordred> how about this?
20:18:47 <markmc> does that mean we need a joint TC/Board meeting?
20:18:50 <annegentle> markmc: yes some time pressure there seems appropriate
20:19:16 <mordred> how about this week we see if we can get a motion out of the committee?
20:19:25 <markmc> I'm sure we can
20:19:29 <mordred> that can be taken to the all-day-in-person board meeting on tuesday
20:19:41 <mordred> if that goes well, then we don't hav ea bunch of things to tap dance around on our side
20:19:46 <markmc> but wasn't the idea the TC and Board would jointly discuss recommendations from the committee
20:19:47 <ttx> mordred: I'm a bit concerned with the timing for the end of cycle graduation review
20:19:49 <mordred> if it doesn't, then we make contingency plans
20:19:52 <ttx> we have three meetings left: Feb 12, Feb 19, Feb 26 to consider Ceilometer and Heat
20:20:09 <markmc> mordred, one thing, though - what is proposed doesn't *need* board sign-off IMHO
20:20:12 <mordred> markmc: I might have been, but I cannot imagine a situation where that's productive
20:20:13 <ttx> that's why we need a decision this week... but not necessarily today
20:20:28 <mordred> markmc: not saying it needs sign-off
20:20:39 <markmc> mordred, right, we just need to be careful about terminology here
20:20:40 <mordred> markmc: but _something_ needs to be _something_ before we start changing our charter
20:20:58 <ttx> OK, how about this...
20:21:21 <ttx> We schedule the graduation review for the meeting of next weeks of February
20:21:52 <ttx> We try to get the committee to wrap up that first part of the process (incubation)
20:22:19 <ttx> And hopefully next week we are all set /and/ don't lose a week in scheduling
20:22:37 <mordred> I think that sounds great
20:22:42 <markmc> so, next week ...
20:22:43 <ttx> my only concern here is that we should start that review asap
20:22:49 <ttx> It's a bit tight. Feb 12, mordred and markmc might be caught into the board meeting and I'm not sure where i'll be myself. Feb 26 I'm skiing and probably won't be around
20:22:58 <markmc> both the TC and board vote on the committee's motion ?
20:23:07 <ttx> (though I can miss meetings alright :)
20:23:18 <markmc> maybe we have a vote now, that the TC is happy to not have a joint meeting with the board to discuss it
20:23:25 <markmc> that we're happy with how things have gone?
20:23:26 <markmc> meh
20:23:50 <mordred> ttx: feb 12 when the TC is supposed to meet might be an opportune time to join the meetings...
20:24:18 <ttx> mordred: now I'm confused
20:24:25 <jgriffith> ttx: ditto
20:24:38 <markmc> he's suggesting the TC join the board meeting next week
20:24:39 <markmc> at this time
20:24:45 * ttx hates process in the way of progress, especially when 99% of people agree on the way forward
20:24:48 <markmc> not sure how we'd work the logistics for that
20:24:56 <markmc> but maybe there isn't a better opportunity
20:25:07 <markmc> ttx, agree massively, this feels like a tonne of busy work
20:25:07 <mordred> I mena, we're going to be there anyway
20:25:11 <mordred> ++
20:25:44 <mordred> otoh, I _do_ think there is nothing stopping us from assessing heat/ceilometer over feb
20:25:46 <ttx> i somehow doubt we'll have quorum on the phone/webex/whatever thing for other TC members
20:26:03 <ttx> I'm physically present, I don't mind
20:26:13 <markmc> mordred, there is - clarity on what graduation means
20:26:28 <mordred> speaking of - if the next two weeks are iffy because of conflicts, what difference in action related to heat/ceilometer are you suggesting?
20:26:28 <markmc> we can begin assessing for sure
20:26:31 <markmc> gathering data
20:27:02 <mordred> markmc: the only difference in what graduation means is whether their ptl gets a seat on the tC
20:27:13 <annegentle> So there's a need for a deadline for graduation assessment, that should coincide with the TC makeup of PTLs, right?
20:27:21 <annegentle> Can we convince the board these deadlines need to be the same date?
20:27:27 <markmc> mordred, currently, graduation means becoming core
20:27:28 <mordred> which should not make a difference to our assessment, based on the conversatoins about not changing TC elections
20:27:33 <markmc> mordred, it obviously doesn't mean that anymore
20:27:46 <markmc> mordred, but does it mean the TC recommends the project for core?
20:28:05 <markmc> mordred, we have a consensus on what it means, but for some reason we're stalling on implementing that
20:28:31 <ttx> I'd prefer to have the clear go-ahead on the process (which I thought we had) before we start it
20:28:59 <mordred> ok. I'm not making myself clear, and I'm sorry for that ... let me try again
20:29:35 <mordred> a) we have consensus, but right now we have consensus on something that a committee discussed, which means that I don't think that we need to amend our charter this instant
20:30:18 <mordred> b) the effective actual steps of action we will take in the next two weeks do not change whether we implement the committee's recommendations or not
20:30:33 <mordred> so - I think we are free to move ahead as usual
20:30:42 <mordred> and then push for reslution from the committee
20:30:45 <ttx> works for me
20:30:50 <mordred> unless I'm just WAY off base
20:31:12 <ttx> mordred/markmc: do  you think we can have the TC meeting next week ?
20:31:23 <annegentle> yeah I don't think the two items (graduation and TC makeup) HAVE to coincide
20:31:26 <markmc> so long as we have the TC charter accurate before the discussion about ceilometer/heat graduation, fine
20:31:42 <mordred> ttx: tough to say - I haven't seen the schedule - but I'm game to try to do both meetings at once :)
20:31:42 <markmc> ttx, it'd be lunch time, we could probably join. mordred?
20:31:56 <mordred> markmc: let's just tell jbryce that that's the way it has to be
20:32:06 <markmc> so
20:32:07 <ttx> annegentle: theydon't have to coincide, but one must finish before the other ;)
20:32:16 <markmc> when does our discussion about ceilometer/heat graduation start?
20:32:17 <annegentle> ttx: dependencies
20:32:27 <ttx> markmc: next week
20:32:46 * markmc sighs
20:32:54 <markmc> are we going to have that discussion with e.g.
20:32:59 <markmc> "should ceilometer be core?"
20:33:09 <markmc> confusing the whole thing again
20:33:12 <mordred> markmc: does it matter?
20:33:22 <annegentle> mordred: yes I think it does
20:33:25 <markmc> yes, I think confusion will make the discussion difficult
20:33:33 <mordred> hrm. weird. ok
20:33:42 <ttx> markmc: ideally by then we should have the clear mandate to only discuss integration
20:33:46 <markmc> mordred, "are we recommending ceilometer to the board for core inclusion?"
20:33:53 <mordred> markmc: OH!
20:34:00 <mordred> markmc: I understand something you said before now
20:34:02 <mordred> ok
20:34:23 <markmc> ok, between the committee and board
20:34:31 <markmc> let's try and get this better wrapped up for next week
20:34:38 <mordred> sorry, I let my viewpoint cloud my process-view
20:34:40 <markmc> for next week's TC meeting
20:34:41 <ttx> So let's proceed as if we'll get that
20:34:50 <jgriffith> +1
20:34:58 <mordred> ttx: ++
20:35:02 <jgriffith> please, let's move forward one way or another!
20:35:13 <ttx> jgriffith: yay, action
20:35:18 <markmc> jgriffith, that's the thing - we could vote on this right now :)
20:35:26 <markmc> jgriffith, the TC can change its own charter
20:35:39 <markmc> jgriffith, within the bounds of its mandate under the bylaws
20:35:45 <jgriffith> markmc: I have no objection to that TBH
20:35:51 <ttx> me neither
20:35:57 <ttx> but I think mordred had
20:35:59 <mordred> I do
20:36:06 * notmyname hasn't seen anything in the last 10 minutes (router issues)
20:36:07 <markmc> mordred, what exactly is the objection?
20:36:12 <mordred> changing ourside of hte charter unilaterally
20:36:30 <markmc> you could hardly call the last weeks and weeks of discussion on "unilaterally"
20:36:32 <ttx> notmyname: you didn't miss anything useful. Just back on forth on the need to be extra careful on stuff everyone agrees about
20:36:40 <notmyname> ttx: k, thanks
20:36:43 <mordred> means that we would be voting projects into a structure that we do not know that the board will finally accept
20:36:44 <markmc> mordred, I object to the notion that we can't do it without board approval
20:36:50 <mordred> I agree
20:36:53 <mordred> we can totally do it
20:36:58 <mordred> I just don't think it gets us anywhere
20:37:06 <annegentle> I'd rather not give incoming projects whiplash :)
20:37:11 <ttx> notmyname: http://eavesdrop.openstack.org/irclogs/%23openstack-meeting/%23openstack-meeting.2013-02-05.log
20:37:23 <jgriffith> mordred: I understand but on the other hand I'd rather make progress
20:37:29 <jgriffith> if we have to adjust after the fact so be-it
20:37:45 <markmc> mordred, so, process-wise - you think the TC might change its charter and later find the board has objections and the TC would then need to change again?
20:37:47 <jgriffith> The other thing is maybe we can influence the board this way
20:37:50 <markmc> mordred, seems pretty far fetched
20:38:09 * jgriffith likes to drive the bus, not ride it
20:38:43 <markmc> mordred, far fetched, given the level of discussion we've had to date openly, in the committee and with the board last week
20:39:09 <mordred> markmc: sure. but you know what we didn't do last week? we didn't make a motion with the board?
20:39:14 <mordred> s/?$//
20:39:23 <jgriffith> markmc: mordred I guess my question is whether this seems to be controversial from the boards perspective anyway?
20:39:37 * mordred is PURELY being a process wonk
20:39:43 <jgriffith> hehe
20:39:44 <markmc> mordred, me too :)
20:39:48 <ttx> mordred: you're being a wrong process monk
20:39:50 <markmc> mordred, I don't see that a board motion is required
20:39:57 <markmc> mordred, what would they be approving?
20:39:57 <ttx> on that matter, the TC is self-sufficient
20:40:13 <jgriffith> ttx: +1
20:40:15 <markmc> this is important
20:40:23 <markmc> when we want to change things we have a mandate to change
20:40:25 <mordred> markmc: I don't know - what the hell is the point of the committee if there is not an official actual outcome?
20:40:31 * ttx happens to have written that charter and large parts of the bylaws whee they touch the tC
20:40:32 <markmc> will we always stall while we wait for board approval?
20:40:42 <mordred> ON THIS, yes
20:40:56 <mordred> this is the only thing where the board and the TC overlap
20:40:57 <ttx> I can tell that we can move without the BoD formal approval.
20:40:57 <markmc> mordred, to jointly discuss stuff and bring motions back to the appropriate board/tc that need to vote on the changes recommended
20:40:59 <mordred> the only thing
20:41:22 <markmc> mordred, I think the board would vote on the core side of the thing and the TC would vote on the incubation side of things
20:41:32 <ttx> mordred: core inclusion yes. incubation no.
20:41:50 <markmc> how about this?
20:42:01 <markmc> me or ttx draft a TC motion for us to vote on next week
20:42:04 <markmc> after discussion on list
20:42:05 <mordred> ttx: but the only reason we're talking about this right now is that the question of whether we are going to recommend these for core inclusion is up for debate
20:42:11 <markmc> we'll discuss it with the committee on thursday
20:42:16 <markmc> and the board next week
20:42:21 <mordred> markmc: heh. actually, that's required, now you mention it :)
20:42:26 <markmc> and give everyone an opportunity to say
20:42:42 <markmc> "we don't think you're following the right process, you need board approval before you can do this"
20:42:46 <markmc> or whatever they might say
20:42:47 <mordred> markmc: maybe that's the thing that was tripping my weird meter
20:42:53 <mordred> markmc: ++
20:42:58 <ttx> markmc: that sounds like a great way to lose one of our 3 precious weeks. But why not
20:43:05 <mordred> ttx: you have no choice
20:43:18 <mordred> the rule is that a TC motion needs to be proposed a week before a vote
20:43:27 <mordred> for adequate mailing list discussion
20:43:28 <ttx> mordred: there is the choice to act now and ask for forgiveness later
20:43:44 <jgriffith> ttx: a motto to live by :)
20:43:58 <markmc> ttx, I think he's right on the week-to-discuss-a-motion thing
20:44:03 <ttx> mordred: I went back and forth on the need for a motion
20:44:20 <ttx> but with the propsoed motion being exactly what we were mlandated by the TC to push to the committee...
20:44:29 <annegentle> ttx: Do the incoming projects want to know the whole story or just if they graduate to "integrated?"
20:44:29 <ttx> we actually already voted on that
20:44:48 <annegentle> whole story=TC makeup
20:44:54 <ttx> mordred: I'm fine with voting twice on the same thing if you feel that's necessary
20:44:54 <mordred> I'm very fuzzy on many things on this - I'll be the first to admit that
20:45:14 <mordred> ttx: you want to change our charter without a specific motion and vote?
20:45:15 <ttx> mordred: but then I'd say that the BoD tainted you
20:45:19 <markmc> ttx, that was before e.g. the choice of the Integrated name and that we'd s/Core/Integrated/ in the charter
20:45:22 <jgriffith> I can't help but wonder what the point of this TC is if we can't make decisions like this without approval etc
20:45:23 * markmc would prefer a motion
20:45:27 <ttx> mordred: we don't change the charter
20:45:38 <mordred> oh. we don't?
20:45:42 <ttx> mordred: we update the incubation process
20:45:44 <mordred> see, this is why motions are helpful
20:45:49 <jgriffith> hehe
20:45:53 <mordred> they make it clear what we're deciding
20:46:00 <markmc> heh
20:46:07 <ttx> the only fuzzy points is that the charter uses the "core" word
20:46:13 <ttx> as mentioned earlier
20:46:14 <markmc> we change the process without changing the charter, heh
20:46:18 <markmc> hadn't thought of that
20:46:26 <markmc> think I'd prefer to do both together
20:46:27 <ttx> the charter doesn't mention incubation.
20:46:29 <ttx> At all.
20:46:48 <mordred> so, it's possible that you and I have been saying the same thing the whole time
20:47:26 <markmc> (don't feel strongly against just changing the process now and charter next week, though)
20:47:41 <ttx> mordred: we might need to update the charter this month to account for the "integrated" concept
20:47:52 <ttx> but that doesn't prevent us from looking into heat /ceilometer graduation
20:48:01 <mordred> just so I'm clear - the rush is because we might need to include the projects in the ptl election, right?
20:48:21 <ttx> Well, and also in things like summit preparation but yes
20:48:28 <mordred> k. just making sure
20:48:43 * mordred will enjoy watching the second heat ptl election in two months
20:48:45 <ttx> we need to know which projects are in the next release cycle' before we start it, basically
20:49:26 <ttx> markmc: you summarize, or should I ?
20:49:46 <markmc> heh
20:49:54 <markmc> go for it
20:49:58 <ttx> argh :)
20:50:00 <ttx> ok so:
20:50:02 * markmc doesn't know how to summarize all that quickly
20:50:39 <ttx> - we prepare a motion/whatever describing the process, and present it to incup, board and TC
20:51:07 <ttx> - at the same time, we schedule the graduation review to start at next week meeting
20:51:17 <ttx> so that we don't lose another week
20:51:37 <markmc> (and to be clear, only the TC vote is an "approval" vote ... the others would be "expression of support" votes)
20:51:47 <ttx> yes
20:51:57 <markmc> sounds good to me
20:52:18 <ttx> objections ?
20:52:23 <annegentle> and for the graduation review, are us TC members reviewing based on graduation to integrated or core or no graduation?
20:52:34 * markmc assumes most everyone has gone asleep ... this is boring
20:52:53 <ttx> annegentle: the motion will say "graduation to integrated", and hopefully should be all set by then*
20:53:01 <annegentle> ttx: sounds good
20:53:09 <ttx> annegentle: if shit happens we revisit
20:53:20 <markmc> ttx, the left hands side of this: https://docs.google.com/drawings/d/1oLo1ETnRpNSgDj_m7p6o6tF7HHA2a-3XeKa-QLMBcRc/edit
20:53:22 <ttx> if shit hits the fan, I'll blame mordred
20:53:33 <markmc> I'll throw him into the harbour
20:53:33 <ttx> markmc: yes
20:53:34 <mordred> ttx: you always do :)
20:53:45 <ttx> or the harbor
20:54:15 <ttx> #action markmc/ttx to prepare a motion/whatever describing the process, and present it FYI to incup, board and for vote on TC
20:54:40 <ttx> #action ttx to schedule, at the same time, graduation review to start at next week meeting
20:55:06 <ttx> question: do you think we should call projects one at a time or all together ?
20:55:28 <markmc> a quick status update from both next week
20:55:32 <markmc> might be a good way to start
20:55:33 <mordred> ++
20:55:36 <markmc> "why we think we're ready"
20:55:44 <ttx> sounds good
20:56:28 <ttx> #topic Discussion: OpenStack compatibility test suite
20:56:33 <ttx> Since we have a few minutes left...
20:56:38 <ttx> The Foundation asked me to raise the topic of an openStack compatibility test suite to the TC
20:56:54 <heckj> any more detail there?
20:56:57 <markmc> oh dear
20:57:02 <markmc> because that's not a rathole
20:57:06 <jgriffith> hehe
20:57:27 <annegentle> hee
20:57:28 <ttx> A blackbox tool that can be used to assess support for the OpenStack API, and that could be used as part of the certification/labelling by the BoD
20:57:32 <ttx> Good idea, bad idea ?
20:57:40 <jgriffith> bad idea IMO
20:57:43 <mordred> I think it's a great idea. I think it's hard
20:57:46 <mordred> heh
20:57:46 <ttx> Any hint how we could trigger more interest in the community around that ?
20:57:51 <jgriffith> but I would entertain a version of that
20:57:51 <danwent> i think its valuable, if done right.
20:58:00 <ttx> ML posts, design summit session ?
20:58:12 <markmc> reasonable idea, potential for disastrous implementation of said idea
20:58:25 <ttx> It's one of those "sounds like a good idea, but nobody will have time to spend on doing it
20:58:33 <jgriffith> So... are we going back to "The API is OpenStack"
20:58:33 <mordred> I think it should be kind of like some other things ... if someone thinks it's a good idea, they can implement it and then point us at it
20:58:44 <mordred> I don't think we're going back to that at all
20:58:54 <ttx> mordred: problem is that the ones that think it's a good idea are not really technical
20:58:56 <jgriffith> So I've had similar ideas at a smaller scale
20:59:00 <jgriffith> IE drivers for cinder
20:59:03 <mordred> ttx: I disagree with that
20:59:11 <markmc> jgriffith, from discussions so far, I doubt API compliance would be enough - also needs to use the implementation released by us
20:59:22 <gabrielhurley> If a third-party implementation can pass the same tests (exercise.sh and tempest) our code review gating goes through, that's compatible, right? ;-)
20:59:26 <ttx> mordred: putting it differently, the ones who cared enough to ask me to raise that issue are not technical
20:59:28 <mordred> ttx: I know brian aker brings up how helpful it was for them to have an API complliance checking tool for memcached all the time
20:59:35 <jgriffith> but on an overall project level I'm not quite getting what this proposal means exactly
20:59:41 <mordred> thing is - I think that's tempest
21:00:03 <mordred> and if someone thinks it isn't tempest, they should add more features to tempest - it's already black-box
21:00:06 <jgriffith> mordred: +1
21:00:08 <mordred> and we use it to validate our own cloud
21:00:12 <markmc> there's also the potential the board could invest and hire someone to implement it
21:00:18 <markmc> with our guidance
21:00:20 <mordred> s/cloud/code/
21:00:23 <ttx> gabrielhurley: I think they want to have the tool so that they can use it in rules, but they kinda want the tool available before discussing that :)
21:00:25 <markmc> not sure if that's what anyone is proposing
21:00:30 <mordred> markmc: can we hire someone to add it to tempest?
21:00:31 <jgriffith> but but but....
21:00:45 <jgriffith> hold on folks... for the benefit of us slower people
21:00:47 <ttx> anyway, just throwing the idea out there, just think about it
21:00:56 <ttx> as time is over
21:00:57 <jgriffith> I'm not really sure what this even accomplishes?
21:01:09 <markmc> stricter trademark rules
21:01:11 <jgriffith> ttx: sure... drop a chaos grenade and run
21:01:15 <markmc> or a new trademark program
21:01:15 <mordred> ttx: seriously - can we clarify how what is being asked for is different from tempest?
21:01:15 <heckj> jgriffith: stirring up the pot before another meeting, of coure
21:01:22 <markmc> i.e. "OpenStack Certified"
21:01:24 <jgriffith> heckj: go figure :)
21:01:25 <markmc> who knows
21:01:38 <markwash> jgriffith: doing blackbox testing for drivers is a fantastic idea btw
21:01:42 <ttx> mordred: let's talk when we meet
21:01:43 <heckj> mordred: ttx please - they seem to be the same to me too
21:01:46 <jgriffith> markmc: Yeah, I get that but I think a def of "openstack-cert" would be prudent first
21:01:58 <mordred> heckj: ++
21:01:58 <jgriffith> markwash: I have a dream :)
21:02:04 <mordred> heckj: ttx and I will jump on them next week
21:02:14 <markmc> jgriffith, I'd like a def of "core" before anything else :)
21:02:16 <markwash> jgriffith: since I bet most companies really want to implement drivers and not wholesale replacements (though I wouldn't be surprised if I were wrong on that measure)
21:02:26 <jgriffith> markwash: TRUE DAT!!!
21:02:31 <mordred> speaking of - any of your bay area folks, ttx, markmc and I will be in san fran on tuesday
21:02:31 <ttx> ok moving on to next meeting
21:02:32 <jgriffith> errr...mark
21:02:35 <jgriffith> markmc!!!!
21:02:37 <ttx> #endmeeting