20:03:01 <ttx> #startmeeting tc
20:03:02 <openstack> Meeting started Tue Jun  4 20:03:01 2013 UTC.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:03:03 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:03:05 <openstack> The meeting name has been set to 'tc'
20:03:14 <ttx> On the agenda today, mostly open discussion on governance topics
20:03:20 <ttx> #link https://wiki.openstack.org/wiki/Governance/TechnicalCommittee
20:03:24 <mordred> ttx: sup!
20:03:28 <ttx> #topic Open discussion: TC membership evolution, take 2
20:03:35 <ttx> #link https://wiki.openstack.org/wiki/TC_Membership_Models
20:03:44 <ttx> We have been looking into various models to evolve the Technical Committee membership
20:03:50 <ttx> The discussion on the -dev ML is at:
20:03:55 <ttx> #link http://lists.openstack.org/pipermail/openstack-dev/2013-May/009578.html
20:04:14 <ttx> For today I'd like us to come down to one or two models, discuss further this week and vote next week at the earliest
20:04:37 <ttx> So far two models emerged from the discussion: the "All-directly-elected 11" model and the "6 categorized PTLs + 7 directly-elected" model
20:04:48 <ttx> Choice between the two all boils down to simplicity (simple direct election) vs. diversity (enforced by the categorized PTLs seats)
20:05:08 <ttx> Most opinions expressed on the thread were "I prefer All-directly-elected 11, but I could live with 6 categorized PTLs + 7"
20:05:18 <ttx> Any other opinion ? Anyone strongly against one model or the other ?
20:05:22 <markmc> good summary
20:05:25 <markwash> I must have misread the category support somehow
20:05:44 <markmc> what happened to the best PTLs model?
20:05:44 <russellb> i really, really want to just try directly-elected and see that it's a problem somehow before making it so darn complicated
20:05:49 <markmc> that was my second preference
20:06:06 <russellb> i don't like the categories approach very much at all, personally
20:06:07 <jd__> russellb: sounds reasonable to me too
20:06:11 <markmc> russellb, these three marks agrees
20:06:29 <ttx> markmc: so you prefer all-directed 11 but would pick "best 7 PTLs + 6" as your second preferred option ?
20:06:43 <russellb> i'd pick that over categories, as well
20:06:44 <gabrielhurley> I'm still wary of an all-directly-elected, but I'm willing to be proven wrong
20:06:57 <dolphm> ttx: does the +6 guarantee 6 seats for non-PTL's?
20:06:59 <markmc> ttx, right
20:07:03 <ttx> dolphm: no
20:07:04 <markmcclain> I'm wary too of an all 11 election
20:07:10 <zaneb> are there figures somewhere on which projects have how many ATCs?
20:07:12 <markwash> (not that it matters as much, but) my second is categories + directly elected, but not "PTL" categories
20:07:40 <ttx> markmcclain: why ?
20:07:47 <ttx> markmcclain: diversity ?
20:08:16 <ttx> would like to make sure we capture your wariness accurately :)
20:08:22 <markmcclain> yeah… I think that there needs to a be a certain level of enforced diversity
20:08:23 <russellb> i'm expecting we'd elect 11 smart folks who deeply care about cross-project success, and would consult the right people depending on the issue
20:09:20 <vishy> o/
20:09:20 <vishy> sorry i'm late
20:09:28 <ttx> It's difficult to enforce diversity and stay simple, so you have to pick one or the other. Personally I care more about representativity and size, so both models would be acceptable for me
20:09:29 <notmyname> russellb: I'd expect that too, but isn't a point of setting up these rules to protect against the situation when our expectations aren't met?
20:09:30 <markwash> ping
20:09:50 <russellb> notmyname: i'd just like to see an actual problem before making it overly complex
20:10:36 <ttx> notmyname: some see simplicity as a key goal... so creating complex rules to prevent inexistant problems is seen as a net negative
20:10:56 <notmyname> russellb: I agree, but I'd also like to avoid awkward situations before they happen. eg "no company may have more than 2 seats"
20:11:34 <russellb> do you feel people represent company interests on the TC as opposed to how they personally feel for broad success of OpenStack?
20:11:35 <russellb> I do not
20:11:38 <ttx> notmyname: which model(s) do you prefer ?
20:12:30 <russellb> i think if anyone is seen to be representing their company, they should not be re-elected
20:12:35 <ttx> markmcclain: same question -- would the "categories + directly elected" model have your preference ?
20:12:37 <russellb> someone said that on the ML, and I agree
20:12:47 <notmyname> ttx: I think I could go either way. I have more concerns over the "all directly elected" model, and those have to do with project representation (especially if the "PTL can override" rule still exists)
20:12:59 <ttx> russellb: yeah, that should be seen as a bug, not a feature
20:13:27 <notmyname> russellb: ok, a "no more than 2 ATCs from a single project" ;-)
20:13:29 <markwash_> ack :-/ got caught on the wrong side of a netsplit
20:13:29 <markmcclain> ttx: yeah I like the cat+direct elect mix
20:13:59 <markmc> notmyname, I'd like to see more people contributing across projects, that rule would discourage it
20:14:02 <russellb> notmyname: what if you're an ATC across many/most projects?
20:14:18 <notmyname> note the winking ;-)
20:14:22 <russellb> ah.
20:14:44 <ttx> notmyname: the only "control" the TC has over projects is about making them part of "OpenStack" or not. We don't have +2 on the repos.
20:14:44 <notmyname> point being, I think some simplicity is worth sacrificing for better representation
20:15:30 <ttx> so there is a nuclear option, but otherwise PTLs and core people have control over their project
20:15:32 <notmyname> ttx: and that's my point there. if the TC doesn't have representation from a particular subgroup, then it hurts the overall group (ie encourages divisions)
20:16:09 <jgriffit1> notmyname: I'm mixed TBH, I don't know how often the TC steps in on a project
20:16:26 <ttx> jgriffit1: never happened.
20:16:29 <notmyname> it's noble to hope for more cross-project contributions, but I don't think it's realistic.
20:16:33 <dolphm> jgriffit1: good point
20:16:49 <jgriffit1> ttx: well then it a non-issue for sure
20:17:04 <russellb> notmyname: certainly for all the projects that are using oslo, it's very common to work cross project
20:17:36 <russellb> notmyname: i actually feel like swift is the exception in that area, unfortunately
20:17:36 <bcwaldon> markwash: pong
20:17:41 <markwash_> I'm a little meh oh categories being project-oriented, can somebody speak to the sense of that?
20:17:53 <dolphm> russellb: +1
20:18:03 <notmyname> markwash_: it's a hash function to lower the total number of members
20:18:36 <ttx> So, if we except markmc... does everyone put "All-directly 11" and "categorized+6" at the top two spots of their preference list ?
20:18:42 <ttx> Trying to reduce the options
20:18:48 <markwash> did we bisect?
20:18:59 <russellb> ttx: i'm with markmc on my option #2
20:19:04 <markmc> do we have a proposed category list?
20:19:05 <markwash> ttx: I'd have to know the categories first
20:19:06 <dolphm> ttx: yes
20:19:11 <jgriffit1> ttx: I'm fine with either, think I prefer #2
20:19:39 <jgriffit1> markwash: people with blonde hair versus red
20:19:48 <markwash> I'm in both categories!
20:19:52 <jgriffit1> :)
20:19:53 <markwash> everything is true of the null set :-)
20:19:58 <annegentle-web> I'm fine with either "best ptl" or "categories"
20:20:05 <zaneb> the best 7 PTLs seems marginally better than categorised to me
20:20:10 * annegentle-web read eavesdrop but might not be caught up
20:20:16 <zaneb> although I'm not sure it's helpful to have a hard link between being a PTL and being on the TC - they seem like very different jobs
20:20:23 <ttx> ok, so "best ptls+5" has supporters
20:20:29 <zaneb> PTL seems to be more about project management
20:20:30 <markwash> zaneb: +10 very different it seems
20:20:31 <markmcclain> I'd be fine with best PTLs too
20:20:36 <ttx> zaneb: +10
20:20:48 <zaneb> TC should be technical
20:20:54 <annegentle-web> Categories got up to 12 first draft...
20:20:56 <annegentle-web> #link http://lists.openstack.org/pipermail/openstack-dev/2013-January/004539.html
20:20:57 <bcwaldon_> zaneb: ttx and I were just talking about that - I wanted to suggest we actually drop the T from PTL
20:21:07 <russellb> bcwaldon_: i've wondered that myself, as well
20:21:09 <bcwaldon_> but that's might be a conversation for a different time
20:21:23 <russellb> my PTL work is much more about project management than technical work
20:21:28 <jgriffit1> bcwaldon_: throws the chaos grenade and runs
20:21:48 <jgriffit1> can we save that discussion for another day maybe :)
20:21:52 * russellb nods
20:21:53 <jgriffit1> we could rat hole I think
20:21:59 <dolphm> +1 for saving
20:22:25 <zaneb> I think having any representative from core on a project > having the PTL from a project on the TC
20:22:45 <markwash> I really like cross-cutting concerns for categories, rather than projects for categories
20:22:51 <ttx> Well that's the benefit of the direct election... you don't draw so many lines implying other rules
20:23:08 <annegentle-web> mordred: how does programs/projects work well in either election system?
20:23:19 <zaneb> markwash: those seem really complex to manage in comparison though :/
20:23:37 <markmc> annegentle-web, programs would have PTLs
20:23:39 <vishy> russellb: but how are you going to convince someone else to do the work if you remove the T?
20:23:42 <russellb> the amount of time spent in this round of discussion, as well as the last one, discussing the idea of categories should be telling
20:23:43 <vishy> :o
20:23:44 <dolphm> so, in a all-directly elected 11, all ATC's across all projects would be able to vote on all TC members?
20:23:46 <mordred> annegentle-web: what markmc said
20:23:48 <annegentle-web> markmc: ok tx
20:23:54 <annegentle-web> thx even
20:23:55 <ttx> dolphm: yes
20:23:58 <russellb> vishy: *shrug* can discuss another time i guess :)
20:24:04 <markwash> zaneb: russellb: fair points
20:24:11 <markwash> which brings us back to direct
20:24:39 <zaneb> a shardy's proxy, I'm compelled to bring up the concern that direct election will result in ~11 Nova developers on the TC
20:24:48 <zaneb> ;)
20:24:52 <mordred> so - I think that's fair
20:25:03 <markmc> the amount of ongoing bikesheding we'll have with categories just won't be worth it
20:25:07 <ttx> zaneb: except the current directly-elected seats prove otherwise
20:25:08 <mordred> but I'd like to point out that annegentle-web and I and ttx are all on here
20:25:09 <russellb> markmc: +1
20:25:11 <russellb> it's killing me
20:25:19 <annegentle-web> zaneb: niceone
20:25:36 <russellb> mordred: +1, with really high votes, because you guys are clearly amazing candidates to engage in cross project issues
20:25:47 <annegentle-web> russellb: aw I like naming things :)
20:26:08 <ttx> also it's likely that we would engage with representative condorcet, once we investigate how well it performs, further limiting block voting
20:26:11 <markmc> zaneb, you're not the first to say that, but I really doubt that - do a thought experiment with e.g. posters to openstack-dev and see what names you come up with
20:26:19 <zaneb> mordred: and that's great, the issue would be for smaller projects
20:26:29 <zaneb> i.e. things that don't cut across multiple areas
20:26:30 <mordred> zaneb: you know I got your back :)
20:26:33 <markwash> for me, "right categories" > direct 11 > "wrong categories", but we'll always tend towards wrong categories in time, so direct feels better
20:26:34 <ttx> zaneb: I actually think we'd end up with 11 core-project figures.
20:26:56 <vishy> mordred: agreed, we have proven with past elections that nova doesn't win all the elected seats.
20:27:00 <ttx> + one or two pure Nova devs :)
20:27:04 <mordred> zaneb: I think it we try to tie geting a TC seat to projects, we'll wind up rejecting smaller projects because epople don't want a huge tc
20:27:31 <mordred> and I think that's worse for the 'small' projects in the long run
20:27:39 <mordred> also - anybody can come pipe up during this meeting
20:27:42 <zaneb> not picking on dolphm, but there are only like 5 people smart enough to work on keystone. yet it seems pretty important to me that it be represented
20:27:44 <lifeless> oh  hai
20:27:46 <lifeless> piping up
20:27:53 <jgriffit1> mordred: I'm still confused on what the TC's are doing to projects that this is a concern?
20:27:58 <lifeless> tripleo is one of those small projects
20:28:08 <russellb> programs?
20:28:08 <russellb> :)
20:28:09 <jgriffit1> mordred: we seem to spend most of our time deciding what to vote on as we're doing now
20:28:13 <lifeless> russellb: indeed
20:28:15 <mordred> jgriffit1: yeah. I agree
20:28:16 <annegentle-web> one logistic aspect I realized when doing some math is that there's never 11 directly elected at once. Just five or six.
20:29:02 <annegentle-web> so the "all nova all the time" might be lessened as a risk
20:29:38 <ttx> I'd like a quick show of hands: could you all tell which models are acceptable to you, so that we see which models emerge as favorites and clarify a bit
20:29:57 <lifeless> ttx: also nova will lose leverage as it gets a narrower focus - when we finally kill nova volume and nova network.
20:30:05 * ttx says 1. "All-directly-elected 11" and 2. "Categorized + 7"
20:30:15 <markmc> 1) all 11, 2) best PTLs, 3) categories
20:30:20 <russellb> 1) directly elected, distant 2) best PTLS + whatever, a very very distant 3) categories
20:30:22 <annegentle-web> ttx: one more question. How is "best" PTL calculated -- must number of votes?
20:30:33 <mordred> 1. "All-directly-elected 11" and 2. "Categorized + 7"
20:30:35 <annegentle-web> most
20:30:43 <ttx> markmc, russellb: "categories" or "categories + 7" ?
20:30:52 <markmc> ttx, latter
20:30:59 <dolphm> 1) torn between directly elected 11 and categorized+7
20:31:01 <russellb> i hate it so much i don't even care
20:31:06 <markmc> heh
20:31:07 <jgriffit1> best PTL's +
20:31:11 <markmc> russellb, more than the current model ?
20:31:18 <markmcclain> 1. best PTLs 2) cat+7 3) direct 11
20:31:19 <markwash> 1) good categories + N, 2) direct 11
20:31:26 <jd__> 1. "All-directly-elected 11" and 2. "Categorized + 7"
20:31:33 <russellb> ooh ... good question ... no.  so, categories+7 > current
20:31:38 * dolphm s/categorized/best PTLs/
20:31:46 <markmc> russellb, thought so :)
20:31:59 <notmyname> categories+X or direct elected
20:32:06 <mordred> ttx: it's feeling like perhaps we should do a condorcet vote of three choices here
20:32:11 <russellb> basically no consensus at all ...
20:32:16 <jgriffit1> mordred: :)
20:32:21 <dolphm> mordred: do it!
20:32:27 <markmc> well, I don't see anyone saying they want it to stay as it is
20:32:31 <ttx> mordred: yeah, unless we can narrow down to 2 :)
20:32:31 <markmc> that's consensus
20:32:39 <mordred> markmc: ++
20:32:40 <russellb> markmc: +1
20:32:54 <annegentle-web> is there a directly elected 13 option?
20:32:57 <markmc> and a lot of people not hugely opposed to any of the 3 leading options
20:33:16 <ttx> annegentle: I see it as an implementation detail
20:33:18 <mordred> yeah. so I think we honestly need to do a ranked vote of the three leading options
20:33:22 <mordred> and then just leave it at that
20:33:29 <ttx> mordred: what would be the 3rd leading option ?
20:33:30 <dolphm> annegentle-web: does the number of members affect your opinion on how they're allocated?
20:33:37 <annegentle-web> I slightly prefer 6 Categories + 7 directly elected over directly 11.
20:33:43 <mordred> ttx: direct, cat+7, best ptl+
20:33:59 <markmc> mordred, I object to your ordering!
20:34:02 * markmc chuckles
20:34:03 <annegentle-web> dolphm: more that I want to ensure people aren't concerned of teh diff between 13 and 11 TC members (it just won't matter)
20:34:15 <mordred> or, let's call it direct, cat+ and ptl+ - and leave specifics on how many humans a type has as a detail
20:34:35 <ttx> mordred: so, technically, motions are affirmative votes (agree or not agree), but I guess we can pick the motion using condorcet and see if it gets 2.3 of the votes afterwarrds
20:34:45 <mordred> ttx: zomg
20:34:48 <mordred> ttx: ok
20:34:51 <ttx> 2/3
20:35:09 * mordred makes a motion that we do a condorcet vote, and then unanimously affirm the output of that vote
20:35:27 <ttx> Oh, the other way around. interesting.
20:35:39 <ttx> isn't governance fun
20:35:46 <russellb> quite.
20:35:47 <markmc> mordred, on a point of order, you can't unilaterally unanimously anything
20:35:55 <jgriffit1> keep this up you won't get 13 people willing to run :)
20:35:56 * mordred shoots markmc in the head
20:36:00 <ttx> I'm ready to accept condorcet results over that set of 3
20:36:08 <zaneb> stepping back a little, why are we even worried about numbers? Everybody is already allowed/encouraged to participate in this meeting. The thing you have to be a TC member for - the voting part - is the only thing that already does scale
20:36:12 <ttx> do we have 2/3 of our members agreeing on that ?
20:36:26 <jgriffit1> ttx: I agree
20:36:27 <russellb> i'd rather know what i'm affirming
20:36:37 <russellb> so, the earlier suggestion
20:36:52 <dolphm> ttx: i agree
20:37:03 <mordred> zaneb: I think the thing is that we like to avoid voting when we can
20:37:23 <zaneb> mordred: so it doesn't matter who is on the TC at all then?
20:37:34 <ttx> also we ahve the option to make the meeting +v if we can't have a discussion anymore
20:37:36 <mordred> zaneb: except for when it does
20:37:47 <ttx> so far people are behaving, which is great
20:38:31 <ttx> looks like we don't have 2/3 in support of accepting whatever comes out of the condorcet poll of the three mentioned options
20:38:46 <ttx> speak now or we'll do it in two steps
20:38:49 <jgriffit1> ttx: would it help if I voted 5 times
20:38:57 <markwash> wait
20:39:02 <markwash> was I supposed to #agree or something?
20:39:14 <mordred> ttx: how about we do a #vote on the thign above
20:39:16 * markwash was waiting for the starting gun
20:39:21 <mordred> I tihnk it's not clear how you're counting
20:39:21 <annegentle-web> I'm confused.
20:39:24 <ttx> mordred: ok
20:39:42 <gabrielhurley> +1
20:39:55 <gabrielhurley> also, are we voting on voting?
20:39:58 * annegentle is also confused
20:40:00 <russellb> i think so.
20:40:07 <markmc> gabrielhurley, that's exactly what we're doing
20:40:09 <markwash> annegentle-web died of confusion
20:40:11 <markwash> only to be reborn
20:40:11 <gabrielhurley> if you're gonna vote on something, then make it clear we need to respond
20:40:17 <annegentle> markwash: snort
20:40:24 <ttx> Let's vote on "let's have a condorcet poll with the direct, cat+ and ptl+ options and accept whatever comes out of it"
20:40:39 <mordred> yes please
20:40:42 <dolphm> +1
20:40:45 <ttx> we need 2/3 support otherwise we'll do it the other way around
20:40:49 <annegentle> who are the voters in the poll?
20:40:56 <mordred> the tc
20:40:58 <markwash> what's the other way around?
20:41:01 <ttx> 2/3 affirmative votes. TC members obviously
20:41:03 <annegentle> mordred: ok
20:41:12 <russellb> other way around: condorcet vote, then a vote to affirm the result
20:41:21 <russellb> (or decline and go back to drawing board)
20:41:22 <annegentle> why does it have to be condorcet?
20:41:25 <jgriffit1> 3 votes to get to a vote... sigh
20:41:28 <markwash> russellb: thanks
20:41:35 <mordred> annegentle: because we have three options
20:41:42 <ttx> #startvote let's have a condorcet poll with the direct, cat+ and ptl+ options and accept whatever comes out of it? yes, no, abstain
20:41:43 <dolphm> annegentle: because there's 3 options, and there's no clear best 2
20:41:43 <annegentle> mordred: ok, lightbulb, thanks
20:41:44 <openstack> Begin voting on: let's have a condorcet poll with the direct, cat+ and ptl+ options and accept whatever comes out of it? Valid vote options are yes, no, abstain.
20:41:45 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
20:41:45 <zaneb> I propose we form a subcommittee to vote on how we will vote
20:41:47 * zaneb runs
20:41:52 <dolphm> #vote yes
20:41:52 <russellb> #vote no
20:41:58 <ttx> #vote yes
20:41:59 <mordred> #vote yes
20:42:00 <jgriffit1> #vote yes
20:42:01 <annegentle> #vote yes
20:42:01 <markwash> #vote yes
20:42:03 <markmcclain> #vote no
20:42:08 <zaneb> #vote abstain
20:42:11 <gabrielhurley> #vote yes
20:42:16 <russellb> would you all actually be happy enough with any result?  or do you just want it over?
20:42:23 <markmc> #vote abstain
20:42:24 <russellb> just making sure.
20:42:25 * ttx reads his copy of the charter to figure out if its enough
20:42:31 <dolphm> russellb: both
20:42:37 <notmyname> #vote yes
20:42:38 <mordred> russellb: I want to do a proper vote on the items
20:42:50 <mordred> russellb: I don't think a straight IRC vote will work
20:43:00 <mordred> russellb: so, whatever the outcome of the vote is, is the outcome of us voting
20:43:07 <ttx> we need 10 yes, do we have them
20:43:08 <mordred> russellb: so I will accept it, same as any vote
20:43:18 <ttx> no we don't
20:43:23 <ttx> anyone left to vote ?
20:43:38 <ttx> vishy: ?
20:43:50 <vishy> #vote abstain
20:43:55 <markwash> thanks
20:44:00 <dolphm> lol
20:44:23 <vishy> sorry
20:44:25 <ttx> #endvote
20:44:26 <jd__> #vote yes
20:44:26 <openstack> Voted on "let's have a condorcet poll with the direct, cat+ and ptl+ options and accept whatever comes out of it?" Results are
20:44:27 <vishy> misread the vote
20:44:28 <openstack> yes (8): ttx, notmyname, annegentle, markwash, mordred, gabrielhurley, dolphm, jgriffit1
20:44:29 <openstack> abstain (3): markmc, zaneb, vishy
20:44:29 <vishy> :)
20:44:30 <openstack> no (2): russellb, markmcclain
20:44:37 <gabrielhurley> I blame the abstainers
20:44:39 <dolphm> vishy: haha
20:44:45 <ttx> we needed 10 yes, and even counting jd that's 9
20:44:50 <markmc> gabrielhurley, for our wisdom?
20:45:04 <gabrielhurley> for perpetuating this debate on voting
20:45:27 <ttx> so unless people regret their vote we'll do it the other way around. Condorcet on the 3 options, then draft a motion and approve it 2/3
20:45:38 <gabrielhurley> though perhaps refusing to vote on a vote is a wise statement of principle...
20:45:46 <mordred> gabrielhurley: heh
20:45:46 <annegentle> gabrielhurley: heh
20:45:48 <ttx> let's go to the next topic, unless someone has more to say on this one
20:46:02 <markwash> I got something to say!
20:46:04 <markwash> no wait, nevermind
20:46:28 <ttx> #topic Open discussion: where does diskimage-builder fit ?
20:46:33 <markwash> yay
20:46:36 <ttx> This discussion is a bit linked to the outcome of the previous one
20:46:42 <ttx> lifeless asked where diskimage-builder should fit at:
20:46:47 <ttx> #link http://lists.openstack.org/pipermail/openstack-dev/2013-May/009539.html
20:46:58 <ttx> Should it go through incubation and be an integrated project ? Should it be shipped as part of Glance ? as an Oslo library ? as a by-product of a TripleO program ?
20:47:09 <ttx> As long as there are rights attached to specific types of projects (think PTL seats on the TC) this question is actually a bit loaded
20:47:18 <ttx> (It's not as important if we opt for a model which requires less classification)
20:47:25 <markwash> as somebody who hears a lot about images and interoperability, I think DiB is an awesome tool that deserves some sort of OS blessing of sorts
20:47:27 <ttx> (Then I think it's safe to consider TripleO a "program" and diskimage-builder a deliverable of that "program")
20:47:49 <markwash> that's right "sort of * of sorts"
20:47:53 <annegentle> why not within glance?
20:48:09 <ttx> annegentle: define "within"
20:48:23 <ttx> as a separate deliverable of the Glance team ?
20:48:29 <zaneb> so, to clarify, we're not envisioning diskimage-builder as a foundation for image building as a service, right?
20:48:35 <annegentle> maybe it should be 'part of' glance in the same way python-glanceclient is 'part of' glance.
20:48:39 <ttx> as a binary in glance tarball itself ?
20:48:43 <mordred> zaneb: it has been discussed
20:48:51 <annegentle> (quoting from lifeless 's email)
20:48:52 <mordred> zaneb: but no work in that direction has happened
20:48:59 <markwash> annegentle: I'm open to that, but people have pointed out that glance is really api-focused
20:49:05 <ttx> annegentle: only makes sense if that's the same team working on it
20:49:06 <annegentle> markwash: ok
20:49:11 <markwash> rather than getting down to the crunchy image bits
20:49:13 <ttx> projects are TEAMS.
20:49:21 <markwash> we are pretty agnostic about the bits of the image generaly
20:49:23 <ttx> groups of people working on the same thing
20:49:29 <russellb> I really like the idea of TripleO as a program with DiB as a deliverable
20:49:40 <mordred> me too - it matches how oslo is working
20:49:43 <zaneb> it seems to me that DiB fits very comfortably in TripleO
20:49:44 <ttx> russellb: +1
20:49:46 <mordred> and it has an incubator repo as well
20:49:47 <annegentle> I think a program with a deliverable makes sense
20:49:48 <zaneb> russellb: +1
20:49:55 <markwash> I'm interestd in TripleO but would still want to know more
20:49:57 <markmc> yeah, tripleo definitely seems like the big user of di-b
20:50:06 <markmc> and most overlap in people working on it
20:50:08 <lifeless> markwash: what would you like to know?
20:50:12 <ttx> so the linked question is.. do we bless programs ?
20:50:12 <lifeless> I'm here and can type to it
20:50:15 <mordred> markmc: although reddwarf and others are starting to use it as well
20:50:18 <annegentle> just trying to look at it from a consumer perspective - "where do I get an image builder?" they might go to glance
20:50:26 <markmc> mordred, optionally?
20:50:29 <ttx> does a program goves you ATC rigths ?
20:50:32 <ttx> gives*
20:50:43 <markmc> ttx, I think it would, yes
20:50:45 <markmc> should
20:50:47 <mordred> markmc: no. as the basis for how they build the images they use with their guest in them
20:50:53 <markwash> lifeless: is it a set of deliverables for helping deploy openstack on openstack? or something more monolithic?
20:50:53 <ttx> are the deliverables of a program covered by the vulnerability management team ?
20:51:05 <lifeless> markwash: it's a set of deliverables
20:51:06 <markmc> mordred, but not at runtime, right ?
20:51:06 <ttx> if it gives ATC rights, then the TC needs to bless them
20:51:14 <mordred> markmc: so at the moment, reddwarf depends on dib as best as I understand it
20:51:19 <mordred> markmc: I don't know what you mean?
20:51:30 <ttx> (and program needs to accept oversight of the TC)
20:51:33 <lifeless> markwash: some like dib are new code trees, others like contriutions to heat and nova are patches to existing openstack projects
20:51:46 <markmc> mordred, building a guest image is more of a setup step, and I assume you could use any image builder
20:52:00 <mordred> markmc: yes. I suppose you are completely right
20:52:08 <markmc> mordred, as opposed to reddwarf calling out to di-b while processing an API request
20:52:08 <markwash> lifeless: cool, makes sense then
20:52:17 <lifeless> markmc: so reddwarf build a guest image as part of their test suite,a nd execute it.
20:52:17 <mordred> markmc: totally
20:52:22 <markmc> whereas di-b seems like more of a runtime dep for tripleo
20:52:31 <markwash> lifeless: are there some long-term-plan docs / vision out there somewhere I could read?
20:52:31 <lifeless> markmc: you can use any iamge builder; and we have a narrow definition for just that reason.
20:52:38 <ttx> lifeless: ok, so it seems dib belongs in the tripleo program, we just need to finalize introducing the concept of programs first
20:52:44 <lifeless> markwash: certainly. http://github.com/tripleo/incubator
20:52:46 <jd__> do we know more about the reddwarf/dib dependency? I find this odd at first glance (no pun intended)
20:52:49 <markwash> lifeless: ty!
20:52:50 <ttx> is that a good summary ? ^
20:52:58 <lifeless> ttx: works for me.
20:53:04 <markmc> lifeless, yeah, but that would mean considering di-b as a test tool dependency
20:53:14 <zaneb> ttx: +1
20:53:19 <lifeless> markmc: for reddwarf it is. it's a runtime dep for tripleo.
20:53:25 <markmc> lifeless, right
20:53:53 <lifeless> markmc: I'm not happy with di-b on stackforge when it's a CI dep for incubated/integrated project(s).
20:54:05 <lifeless> markmc: which is why I mailed the list :).
20:54:09 <markwash> ttx: intriguing. . do you have summary of "program vs project" on hand somewhere?
20:54:22 * markwash is sorry if he just wasn't doing his homework. . .
20:54:25 <markmc> lifeless, fair enough
20:54:29 <ttx> markwash: https://docs.google.com/drawings/d/1t1t2Aj1rIvxNnIvbjsiTPe5Szpx-lXBpW1dbL4K08cE/edit?usp=sharing
20:54:35 <ttx> everyone likes a drawing
20:54:47 <markmc> wow
20:54:47 <ttx> markwash: still very much WIP
20:54:59 <ttx> trying to understand all the consequences
20:55:00 <markmc> just happened to have that "on hand", heh ?
20:55:09 <ttx> worked on taht today
20:55:16 <ttx> I've seen the future
20:55:58 <ttx> the interesting parts are actually in the empty spaces. Like where does the VMT support end ? What do we call the horizontal teams ?
20:55:59 <markmc> ttx, I'll talk to you tomorrow about better colours for the colour blind :)
20:56:03 <zaneb> if moving to direct TC elections means we can get rid of all these ridiculous legalistic subcategories of names, then I will vote for it right now
20:56:20 <ttx> zaneb: see, you're starting to get it
20:56:51 <jgriffit1> ttx: how about you just tell us what you saw in the future and we can skip the vote :)
20:56:57 <ttx> markmc: was kinda hoping that "all-directed 11" would get so plebiscited that the whole drawing would be useless
20:57:10 <markmc> ttx, heh
20:57:24 <lifeless> so tripleo is about operating/deploying openstack - with a particular focus on eating-own-dogfood all the way up the stack.
20:57:30 <lifeless> just for clarity
20:57:33 <markmc> ttx, I'm thinking programs would be a useful concept anyway
20:57:37 <annegentle> ttx: yay for data in diagrams
20:57:46 <zaneb> ttx: I welcome our new Nova overlords ;D
20:57:54 * russellb isghs
20:58:06 <russellb> nova people are evil, too, watch out
20:58:08 <ttx> markmc: sure
20:58:19 <ttx> so...
20:58:50 <ttx> #agree dib belongs in the tripleo program, we just need to finalize introducing the concept of programs first ?
20:59:00 <markwash> #agree
20:59:03 <mordred> ++
20:59:10 <annegentle> sounds right
20:59:19 <ttx> also known as "lifeless, please wait while we catch up
20:59:21 <ttx> "
20:59:30 <jgriffit1> +1
20:59:39 <zaneb> +1
20:59:45 <russellb> ++
20:59:48 <ttx> #action ttx to set up TC condorcet poll to help select the model that will be put on the TC motion
21:00:06 <ttx> one more minute
21:00:09 <mordred> #action ttx to buy mordred some beer
21:00:11 <ttx> err not
21:00:12 <mordred> does that work?
21:00:17 <jd__> you wish
21:00:22 <mordred> drat
21:00:28 <russellb> #undo
21:00:31 <russellb> :-p
21:00:34 <jgriffit1> If it does I'm setting up an action item for mordred to buy me multiple beers
21:00:51 <ttx> Only if it is Icehouse beer
21:00:55 <ttx> #endmeeting