20:03:37 <ttx> #startmeeting tc
20:03:37 <openstack> Meeting started Tue Apr 15 20:03:37 2014 UTC and is due to finish in 60 minutes. The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:03:38 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:03:40 <openstack> The meeting name has been set to 'tc'
20:03:41 <retardedd_polish> stop lough'im retard
20:04:04 <ttx> This is the last TC meeting for the Icehouse membership
20:04:10 <ttx> Was great working with you all.
20:04:17 <mikal> :)
20:04:18 <ttx> Our agenda for today:
20:04:24 <retardedd_polish> yeah i love you guys
20:04:30 <ttx> #link https://wiki.openstack.org/wiki/Governance/TechnicalCommittee
20:04:47 <ttx> #topic Integrated projects and new requirements: Gap analysis for Trove
20:04:54 <hub_cap> horray :)
20:04:55 <ttx> hub_cap: o/
20:04:59 <retardedd_polish> https://www.youtube.com/watch?v=Nf5ukMJO2cY
20:05:00 <hub_cap> aye
20:05:03 <ttx> #link https://etherpad.openstack.org/p/TroveIntegrationRequirements
20:05:04 <retardedd_polish> o/
20:05:09 <retardedd_polish> https://www.youtube.com/watch?v=Nf5ukMJO2cY
20:05:17 <hub_cap> so um, we gonan kick this guy or what?
20:05:19 <hub_cap> *gonna
20:05:37 <russellb> everyone have their nick registered? kick and mode +r ...
20:05:46 <ttx> punishment is coming, jeblair on it
20:05:51 <russellb> k
20:05:56 <mikal> Is jeblair assembling power tools?
20:05:59 <hub_cap> russellb: ++
20:06:06 <hub_cap> mikal: hes assembling devastator
20:06:07 <ttx> apparently webclient gets in his way
20:06:21 <eglynn> ... just /ignore ?
20:06:25 <retardedd_polish> im sorry guys yoiu know im love you ;(((
20:06:27 <mikal> webclient was the worst deceptacon
20:06:38 <hub_cap> uh oh, the ((( give him away!!
20:07:00 <retardedd_polish> nobody like me
20:07:11 <hub_cap> so anyway, lets talk trove
20:07:17 <hub_cap> we have gaps, lets analyze them
20:07:35 <mikal> To the gaps!
20:07:44 <hub_cap> i will do my best to mind them
20:07:52 <hub_cap> and make SlickNik mend them
20:08:07 * SlickNik is listening intently
20:08:29 <russellb> hub_cap: who makes up your core team?
20:08:36 <russellb> company wise
20:08:45 <hub_cap> ebay, hp, rax
20:08:49 <russellb> nice
20:09:04 <hub_cap> yea, ill admit core needs to grow
20:09:14 <hub_cap> hip hip horray
20:09:17 <hub_cap> 3 cheers for jeblair
20:09:24 <rcarrillocruz> heh
20:09:30 <SlickNik> russellb / hub_cap: We definitely need to grow the core team.
20:09:32 <ttx> his wrath is slow but thorough
20:09:41 <hub_cap> HAH
20:09:42 <russellb> looks like your review wait times are a little above average
20:09:49 <hub_cap> russellb: yes a good bit
20:09:52 <sdague> hub_cap: the qa gap I think is nicely identified there. Mostly trove is kind of light at the moment in that regard.
20:10:00 <hub_cap> partially due to the core team size
20:10:08 <hub_cap> sdague: yes its been a new thing (thx to SlickNik )
20:10:19 <hub_cap> in honestly sdague, we have a decent ammt of nonstandard tests we still rely on
20:10:32 <hub_cap> so its not as if its not there, its just not in the right place, so to speak
20:10:44 <sdague> hub_cap: right, it would be better to get that focus in the upstream process though
20:10:45 <SlickNik> sdague: I'm working with a few folks to get more of the trove integration tests into Tempest.
20:10:52 <sdague> SlickNik: great
20:11:03 <russellb> that a priority for juno?
20:11:10 <hub_cap> SlickNik: ? ;)
20:11:11 <SlickNik> russellb: Yes
20:11:20 <hub_cap> my guess is its one o the highest prios
20:11:31 <hub_cap> since weve been bitten by the lack of them a good bit
20:12:08 <SlickNik> Another item is figuring out the upgrade testing plan since we don't do any of that currently.
20:12:14 * hub_cap assumes people are reading the sparse wiki
20:12:16 <russellb> yep, that's pretty important
20:12:38 <jeblair> hub_cap: do you think we can eventually get rid of reddwarf ci?
20:12:48 <russellb> looks like the wiki doesn't include all of the requirements
20:12:51 <russellb> like the API section, for example
20:13:02 <hub_cap> jeblair: since day one i want to get rid of all of that ci _and_ trove-integration
20:13:08 <hub_cap> fyi: http://summit.openstack.org/cfp/details/295
20:13:12 <russellb> did you guys only include sections you had comments about?
20:13:13 <hub_cap> a talk on test req's
20:13:27 <hub_cap> yea im sorry for not doing it rigth russellb
20:13:35 <hub_cap> i mustve missed that.. i did the gaps only
20:13:38 <russellb> that's fine
20:13:48 <hub_cap> assume the rest o' it is there, and stable
20:13:51 <ttx> so it looks like we have the same gaps as Ceilometer (integration tests and docs)
20:14:13 <hub_cap> as per the api, ive even backed out a change to the api that caused a "change"
20:14:14 <russellb> so REST API is stable?
20:14:16 <hub_cap> that was a while ago
20:14:20 <hub_cap> yes, no changes in icehouse
20:14:25 <markmc> you've a pretty massive list of blueprints - 122 bps open
20:14:25 <jeblair> hub_cap: cool; i think you've made a lot of progress; just wantod to make sure you thought it was still feasible and you are working toward it
20:14:26 <russellb> k, sounds good then
20:14:27 <hub_cap> sans the KILL XML DED part
20:14:33 <markmc> how are you finding the blueprint process?
20:14:34 <hub_cap> jeblair: 100%
20:14:44 <hub_cap> markmc: wlel we are doing monday bp rallys
20:14:55 <hub_cap> and we pick them and discuss them before anyone even sets a line o code down
20:14:59 <ttx> hub_cap: could you give us your plans for trove-integration in Juno ?
20:14:59 <markmc> are your blueprints too fine grained, too future looking, or it's a good reflection what you hope to do in the next release?
20:15:08 <hub_cap> for instance, someone wanted to do a shadow tenant
20:15:19 <hub_cap> and i asked him to talk to nova about managed vms, or whatever we wanted to call them
20:15:23 <sdague> yeh, just on a personal note, I want to say SlickNik was super responsive in helping get all the requirements issues closed at end of cycle so we could have trove in the main job and requirements enforced
20:15:26 <hub_cap> and there was already functionality to do something like this markmc
20:15:35 <hub_cap> so we killed his bp, no code written.. that was, what 2 wks ago SlickNik ?
20:15:42 <hub_cap> we have a blueprint format
20:15:48 <SlickNik> hub_cap: Yes.
20:15:55 <hub_cap> and we wont even look at a BP if it doesnt match the format
20:15:58 <hub_cap> and SURE wont accept it
20:15:59 <SlickNik> markmc: Historically we've had problems with not enough info in the bps.
20:16:09 <russellb> SlickNik: that's been a common problem
20:16:10 <hub_cap> sdague: SlickNik is the bomb
20:16:27 <hub_cap> we are having a good cadence tho w/ them, we get thru avg 4/ meeting
20:16:31 <SlickNik> markmc: We've moved to a template format (on the wiki) for new bp proposals.
20:16:36 <markmc> so a large number of bps are coming from folks outside of the core team?
20:16:50 <SlickNik> #link https://wiki.openstack.org/wiki/TroveBlueprint
20:17:10 <markmc> nice template
20:17:22 <hub_cap> markmc: most of them are
20:17:24 <SlickNik> markmc: Yes, bps are coming from all contributors.
20:17:43 * devananda likes the idea of a bp template
20:17:45 <hub_cap> we are in more of a code review / bp review / bug triage / code cycle
20:17:46 <dhellmann> do you have an specific plans to increase the core team size?
20:17:48 <hub_cap> in that order
20:18:03 <hub_cap> dhellmann: we want to see more meaningful contributions, as well as meaningful reviews
20:18:04 <markmc> I guess it's a pretty weird time to look at the blueprints list - i.e. not having a plan in place for juno yet
20:18:06 <hub_cap> and then yes
20:18:08 <ttx> hub_cap: could you give us your plans for trove-integration in Juno ?
20:18:19 <hub_cap> ttx, can i defer to SlickNik for that?
20:18:25 <ttx> sure
20:18:27 * hub_cap puts SlickNik on the spot!
20:18:28 <russellb> looks like about 1/4 of your bugs are untriaged
20:18:33 <hub_cap> if yall dnt konw, SlickNik is the new ptl
20:18:33 <dhellmann> hub_cap: sure, I was selfishly asking for hints on how to attract people to do those things :-)
20:18:47 <russellb> that's only 34 bugs untriaged, so should be easy to clean up
20:18:52 <hub_cap> dhellmann: heh, if i had the answers id have a bigger core team ;)
20:19:00 <dhellmann> hub_cap: fair point
20:19:03 <hub_cap> russellb: yes thats something that i think very few people are doing
20:19:10 <hub_cap> dhellmann: i admit its a weak point for trove tho
20:19:10 <SlickNik> ttx: I'm looking to move _most_ API tests out of trove-integration into Tempest.
20:19:16 <hub_cap> our core team is VERY small compared to others
20:19:33 <russellb> should look at core team size compared to patch volume though
20:19:34 <ttx> SlickNik: would the trove-integration repo become obsolete ?
20:19:52 <russellb> i think the key data is being above average on review times
20:19:55 <SlickNik> ttx: there's still some white box, system tests, that Tempest is not the right place for (imho). We might have to transition these to a different jenkins job running in openstack-ci.
20:21:16 <SlickNik> ttx: It will take a fair bit of work with QA to get to a point where trove-integration is not needed anymore.
20:21:19 <hub_cap> russellb: good point.. and we are below avg there
20:21:19 <sdague> SlickNik: sure, a functional test job in ci is probably a possibility
20:22:18 <SlickNik> ttx: It's a top priority and we're moving towards it, but I don't know if we will be able to get it _all_ done in Juno.
20:22:32 <SlickNik> russellb: ++
20:22:41 <mordred> sdague: ++
20:22:45 <jeblair> SlickNik, sdague: yeah, i think a functional job is great if you need it
20:22:47 <ttx> OK, we should wrap up
20:22:51 <mordred> SlickNik: you should check out the swift functional job at some point
20:23:04 <hub_cap> yea last time we spoke w/ infra they wanted _some_ tempest tests first
20:23:11 <hub_cap> and i agreed w/ their thoughts
20:23:16 <mordred> ++
20:23:17 <hub_cap> so we kept our hobbily jenkins :P
20:23:23 <sdague> :)
20:23:30 <ttx> #agreed Trove needs to move integrations tests to Tempest
20:23:31 <SlickNik> russellb: I might have to pick your brain a bit to figure out ways to achieve that. :)
20:23:32 <annegentle> hobbity
20:23:44 <ttx> #agreed Trove needs to work on documentation during the juno cycle
20:23:54 <ttx> anything else ?
20:23:57 <russellb> SlickNik: if only there were magic bullets :-) but yes, more than happy to talk!
20:24:01 <annegentle> ttx: we do have an install patch in review, kudos for that
20:24:13 <jeblair> ttx: i'd like to call out deprecating reddwarf ci explicitly
20:24:30 <devananda> SlickNik: we've also been doing a lot to get functinal testing for ironic into openstack-ci, happy to share what we've done
20:24:46 <ttx> #agreed Trove needs to depercate reddwarf ci
20:24:55 <hub_cap> ++ to both
20:25:20 <SlickNik> devananda: ++ I'll touch base with you offline regarding this.
20:25:55 <hub_cap> cool. so are we saved by the bell then?
20:26:08 <hub_cap> we know our gaps are CI, docs, and core team growth (due to review times)
20:26:31 <ttx> OK, anything else on that topic ?
20:26:49 <hub_cap> plz feel free to blame SlickNik for anything not done in juno
20:26:59 <ttx> we will.
20:27:19 <ttx> eglynn, jd__: around ?
20:27:21 * SlickNik starts sweating
20:27:21 <hub_cap> haha
20:27:23 * eglynn nods
20:27:31 <ttx> #topic Integrated projects and new requirements: Review Ceilometer plan to cover gap
20:27:42 <ttx> eglynn, o/
20:27:44 <ttx> Last week we did a gap anaylsis at:
20:27:48 <ttx> #link https://etherpad.openstack.org/p/ceilometer-integrated-requirements
20:27:49 <eglynn> cool, floor is mine?
20:27:56 <ttx> Three gaps were identified: program mission statement, integration tests and documentation
20:27:57 <SlickNik> Thanks for the discussion regarding trove!
20:28:05 <ttx> One concern was raised: SQLA not being recommended in production but still being the only backend tested in gate
20:28:07 <markmc> another new PTL :)
20:28:13 <eglynn> k, here's the high-level plan to address the specific concerns raised by the TC last week
20:28:13 <ttx> eglynn: what is your plan to address those gaps ?
20:28:15 <eglynn> #link https://etherpad.openstack.org/p/ceilometer-integration-gap-analysis-coverage-plan
20:28:31 <eglynn> idea is to have a designated owner to drive the actions for each specific item
20:28:39 <eglynn> ... and a corresponding summit session proposed if required
20:29:03 <eglynn> maybe go thru' the concerns one by one?
20:29:07 <mordred> I approve of explicitly calling out talking to Mike Bayer on sqla
20:29:18 <ttx> eglynn: no, we can read
20:29:22 <sdague> yeh, that will be great
20:29:26 <eglynn> mordred: hat tip to ildikov on that
20:29:50 <dhellmann> eglynn: he'll be there a couple of days, so there will be time outside of sessions, too
20:29:58 <eglynn> cool
20:30:10 <ildikov> and also many thanks to dhellmann for organizing this
20:30:17 <eglynn> +1
20:30:29 <ttx> now.. am I the only one not knowing Mike Bayer ?
20:30:30 <eglynn> ... so concern #1 was straight-forward, we hacked out a formula of words on etherpad, now out for review on gerrit
20:30:36 <mordred> ttx: author of sqlalchemy
20:30:37 <dhellmann> ildikov: make sure you have notes added to https://etherpad.openstack.org/p/juno-oslo-bayer so we don't overlook it during the session
20:30:43 <eglynn> ttx: you know of his works ;)
20:30:45 <ttx> mordred: ah. That could help
20:31:00 <ildikov> dhellmann: sure, will do, thanks for reminding
20:31:09 <ttx> I like this plan
20:31:28 <eglynn> ttx: cool
20:31:33 <sdague> eglynn: on the test strategies front, there was something that was proposed back in portland about having some ceilometer tests that happen around existing tests (as decorators) to track resource expectations. I think that got lost along the way.
20:31:34 <ttx> Seems like the concerns are taken into account and a plan is in place to address them in Juno
20:31:43 <sdague> is that somethign appropriate for the 152 session?
20:32:03 <eglynn> sdague: yes, good point, will add
20:32:04 <sdague> otherwise, I'm pretty happy with the plan
20:32:24 <eglynn> note BTW that items #3 & #4 are somewhat intertwined
20:32:29 <ttx> Everyone else happy with the plan as spelled ?
20:32:49 <dhellmann> yes, this looks it covers the concerns
20:33:08 <russellb> yep no concerns, seems well organized
20:33:32 <jeblair> looks good
20:33:46 <ttx> #info Proposed plan covers identified gaps. TC will check on progress on that plan during the Juno cycle.
20:34:02 <markmcclain> coverage looks good do we want any estimated delivery dates?
20:34:37 <russellb> some of it probably OK to be just "juno"
20:34:41 <eglynn> markmcclain: a bit premature yet to tie to milestones, but I definitely want to frontload the tempest work
20:34:43 <russellb> i'd think the QA things we'd want earlier
20:34:49 <russellb> eglynn: nice :)
20:34:54 <ttx> at this point, I'll take "juno"
20:35:09 <eglynn> cool
20:35:11 <ttx> but post design summit would be good to have blueprints and milestone targets for those yes
20:35:17 <jeblair> ttx: ++
20:35:23 <eglynn> ttx: aggreed
20:35:31 <ttx> eglynn: just add to the same etherpad
20:35:40 <ttx> we'll reuse it to follow progress
20:35:41 <eglynn> ttx: will do
20:35:57 <ttx> anything else on that topic ?
20:36:32 <ttx> #topic Moving projects around (jeblair)
20:36:37 <ttx> #link http://lists.openstack.org/pipermail/openstack-tc/2014-April/000608.html
20:36:57 <ttx> jeblair: you wanted this to be blessed by the TC ?
20:37:36 <russellb> sounds fine to me
20:37:40 <markmcclain> +1
20:37:40 <sdague> +1
20:37:43 <ttx> +1
20:37:47 <markmc> yeah, me too
20:37:53 <markmc> the gantt thing is a bit weird, but fine ...
20:37:55 <mordred> +1
20:37:58 <russellb> sigh @ gantt
20:38:15 <russellb> i'd love to just remove it honestly
20:38:15 <mikal> +1
20:38:27 <russellb> and if/when a splitout happens, give it a new name
20:38:37 <russellb> so it's not associated with this past effort that completely fell apart
20:38:39 <annegentle> sounds fine and I like your use of mothballing
20:38:42 <jeblair> yeah, we're trying to make it the least bad for everyone, within the constraints that we have
20:38:55 <vishy> +1
20:39:12 <vishy> russellb: what happened with gantt?
20:39:15 <dhellmann> if we mothball gantt does that just mean its replacement needs a different name?
20:39:15 <jeblair> but one of those is don't delete history, so that approach with gantt seemed like the best way to go
20:39:17 <jgriffith> +1
20:39:18 <vishy> not enough people working on it?
20:39:34 <russellb> vishy: that's part of it, yes
20:39:38 <jeblair> dhellmann: no, we actually want to leave it where it is but read-only so that we can reuse the name
20:39:51 <russellb> don't want to get too sidetracked
20:39:52 <jeblair> dhellmann: we can do a keystone-lite style switcheroo
20:39:53 <dhellmann> jeblair: right, I was responding to russellb's suggestion of deleting it
20:39:57 <russellb> can give more detail later though
20:40:03 <vishy> k
20:40:13 <ttx> read-onlying it is probably a good first step
20:40:17 <dhellmann> I wonder if it's going to be confusing to have another gantt in the future, but whatever
20:40:22 <dhellmann> +1 to the plan as written
20:40:22 <russellb> yep, i'm fine with the proposed plan for gantt
20:40:38 <ttx> if we realize we don't need it we could -attic it
20:40:41 <russellb> right
20:40:42 <jeblair> cool. and yeah, its not closing any doors on gantt if we change our minds later
20:41:06 <ttx> jeblair: you got enough love, shall we move on to next topic ?
20:41:09 <jeblair> i'll go ahead and put those renames on our list for the next downtime then. thanks :)
20:41:22 <ttx> #topic Cross-project workshops at the summit (russellb)
20:41:25 <russellb> #link https://etherpad.openstack.org/p/JunoCrossProjectDesignSummitTrackReview
20:41:34 <russellb> thanks to the folks that helped by voting on sessions
20:41:44 <russellb> if you scroll to line 36 or so you'll see the proposed set
20:41:44 <ttx> I think we mostly agreed anyway
20:41:57 <russellb> based on the results, i went ahead and approved 1 through 17
20:42:01 <russellb> and rejected 22 to the end
20:42:09 <russellb> question for today is what to do with the middle ones
20:42:15 <ttx> there is just a bit of uncertainty between giving 2 slots to more sessions, or accepting more
20:42:18 <russellb> right
20:42:38 <russellb> i think my opinion is just give 2 slots to the ones marked as such
20:42:52 <ttx> russellb: I think 18 and 19 are covered if we give a double-session to 11
20:42:53 <russellb> any opinions otherwise? one of the middle ones you really want to have?
20:43:05 <dhellmann> does that leave 21 out? (python 3)?
20:43:09 <russellb> ttx: yes that's a good point
20:43:12 <russellb> dhellmann: yes, right now
20:43:24 <russellb> if we take python 3, we have to drop the [x2] by something
20:43:45 <dhellmann> I would like to have some sort of session so the team that is working on that will be able to land incremental patches -- moving "all at once" is not a realistic plan for the amount of work they have to do
20:43:46 <russellb> maybe #9 ...
20:43:50 <sdague> double slot on 16 seems a little odd, given that it wasn't strongly voted for
20:44:08 <markmc> sad the python3 talk has so little in the description
20:44:08 <jeblair> sdague: that's just what i was thinking
20:44:16 <markmc> maybe we just assume that gets sorted before the session?
20:44:23 <markmc> that there will be useful stuff worth discussing?
20:44:25 <ttx> sdague: yeah, my fault. I think if that session works they will need 2 slots
20:44:27 <annegentle> does talking longer than 40 minutes really help get decisions?
20:44:39 <dhellmann> markmc: yeah, I can push zul and haypo on that
20:44:41 <annegentle> or does it help with listing tasks?
20:44:49 <ttx> if it doesn't and they don't converge, probably not
20:45:26 <ttx> annegentle: some topics are very broad, like SDKs / libraries / openstackclient stuff
20:45:45 <annegentle> ttx: k
20:45:48 <ttx> same for API convergence, sortig etc
20:45:59 <jeblair> i think part of the idea of 16 is to try to get collaboration on projects that may not be collaborating closely right now
20:46:01 <russellb> i'm fine dropping the x2 for #16 and adding Python 3, with the expectation that the details get sorted in time
20:46:19 <russellb> hopefully the conversation doesn't end after the session
20:46:24 <russellb> it'll at least get people connected
20:46:33 <ttx> russellb: yeah, your call
20:46:33 <jgriffith> jeblair: given we've had feedback for those project regarding their collaboration that seems like a req
20:46:52 <sdague> do we know if the right people will be there? I'm a little concerned we've got a lead a horse to water problem with that session
20:47:09 <russellb> sdague: which one, #16?
20:47:11 <sdague> yeh
20:47:13 <russellb> hopefully some of us :)
20:47:17 <jeblair> jgriffith: yep. the rest of that thought was that i think there will be some time spent establishing baselines
20:47:20 <ttx> sdague: I rejected their "other project" sessions
20:47:25 <jgriffith> sdague: there inlies the problem
20:47:25 <russellb> next problem will be scheduling which of these can go in parallel
20:47:26 <annegentle> sdague: I've the same concern with pushing "17. cross project documentation" to the docs track, how do I get people there?
20:47:29 <ttx> sdague: so they won't have time to talk separately
20:47:30 <russellb> to make sur the right people can be in the room
20:47:43 <ttx> it's their only space (Murano and Solum)
20:47:50 <ttx> so I hope they will be there
20:48:02 <russellb> that too
20:48:02 <sdague> ttx: you reaching out to them directly on that?
20:48:02 <jeblair> honestly, i'm really bummed about the python3 thing, but i think i'm still not optimistic that is set up to be a productive session
20:48:11 <ttx> sdague: I can
20:48:23 <ruhe> ttx: murano folks will be there
20:48:23 <zaneb> fwiw I'd be relaxed about having only one session for #16, I think
20:48:27 <russellb> jeblair: but can we afford *not* to talk about it?
20:48:28 <ttx> jeblair: yeah, I'm fearing it doesn't really need a session
20:48:41 <sdague> I think because it's not a session anyone from those groups proposed, but you did directly, then it's probably worth making sure direct contact to them
20:48:43 <ttx> especially on fuzzy goals
20:49:02 <jeblair> russellb: i can at least show up and report what i learned and said at the python language summit
20:49:14 <dhellmann> there's also a sprint going on right now at pycon
20:49:16 <ttx> sdague: right, that's fair. I mentioned that workshop when I rejected their "other project" session though. Will reach out directly
20:49:16 <jeblair> i think that may be helpful, actually
20:49:26 <ttx> sdague: easier sell if they get a double-session
20:49:44 <russellb> jeblair: so you think it's useful then?
20:49:51 <russellb> if we want it, we have to drop some x2 slot ..
20:50:12 <ttx> russellb: I guess we can drop the second UX slot
20:50:19 <russellb> UX is what i was leaning toward
20:50:28 <ttx> russellb: because developer exproence will better be handled in the SDk session anyway
20:50:32 <jeblair> let's say i've got 15 minutes of content i can share. i can start an email thread if we don't want to bet a session slot on that though.
20:50:33 <russellb> ok, proposal: accept python, 1 slot for UX, 2 slots for the other 3 that have x2 by then
20:50:34 <gokrokve> ttx: Murano team knows about this session and we are preparing to it.
20:50:35 <russellb> that sound OK?
20:50:37 <sdague> if we are going to put it on the agenda, can we spin it a little to be our python support story over all
20:50:43 <ttx> gokrokve: good to hear
20:50:54 <sdague> because it seems like we should actually discuss 2.6 deprecation at some point
20:50:59 <mordred> sdague: ++
20:51:00 <ttx> russellb: +1
20:51:01 <russellb> sdague: that sounds reasonable
20:51:06 <markmcclain> sdague: ++
20:51:09 <jeblair> sdague: sounding better and better
20:51:16 <ttx> "Future of Python in OpenStack"
20:51:18 <ttx> :)
20:51:21 <russellb> perfect
20:51:24 <russellb> ok, one more quick issue
20:51:33 <russellb> session #1, Consistency across OpenStack REST APIs
20:51:34 <jeblair> ttx: port to 'go', right? :)
20:51:39 <russellb> the proposer of that session is unlikely to make it
20:51:42 <markmc> that sounds like there's a question whether python has a future in OpenStack :)
20:51:47 <mordred> markmc: ++
20:51:47 <russellb> so we should probably line up someone to lead that one
20:51:48 <jgriffith> jeblair: scala
20:51:52 <sdague> markmc: we're rewriting it all in go
20:51:55 <vishy> jeblair: +1
20:51:59 * russellb prefers bash
20:52:05 <russellb> devstack got it right
20:52:15 <mordred> russellb: agree- we should line up someone to lead it
20:52:18 <ttx> devstack got everythign right
20:52:27 <russellb> but seriously ... API session
20:52:28 <dhellmann> I'll take it
20:52:32 * markmcclain longs for C
20:52:41 <russellb> dhellmann: OK, I think that'd be perfect
20:53:01 <markmc> we've had API consistency sessions several times
20:53:01 <dhellmann> I will, however, expect jeblair and some others to show up to help :-)
20:53:10 <ttx> russellb: jaypipes might be interested in leading that one
20:53:11 <markmc> problem has been someone willing to drive it beyond a session
20:53:15 <mordred> dhellmann: I'll probably, you know, come run my mouth
20:53:25 <russellb> ttx: sure, dhellmann: can you ping jay too?
20:53:28 * dhellmann makes a note to pack his stopwatch
20:53:31 <mordred> jaypipes ++ - as long as the session isn't json vs. xml
20:53:39 <russellb> vs yaml
20:53:41 <jeblair> mordred, dhellmann: in which case i will show up and attempt to get a word in edgewise. ;)
20:53:42 <dhellmann> russellb: wait, I was volunteering on the future of python thing, not the api thing
20:53:45 <ttx> that ship has sailed
20:53:46 <russellb> dhellmann: haha
20:53:50 <sdague> mordred: we've got a good job killing a lot of xml this cycle :)
20:53:58 <mordred> sdague: +1000
20:54:03 <ttx> OK we ned to move on
20:54:09 <ttx> russellb: got what you need ?
20:54:15 <russellb> the time sensitive part yes
20:54:17 <russellb> thanks!
20:54:24 <ttx> russellb: scheduling will be unfun
20:54:30 <russellb> indeed
20:54:35 <russellb> everyone bring your clones
20:54:35 <ttx> russellb: we can talk about it tomorrow
20:54:44 <ttx> #topic Requirements changes
20:54:48 <ttx> * Add Ceilometer requirements (https://review.openstack.org/85978)
20:54:48 <dhellmann> russellb: should I file a separate item for the future of python, or do you want to reuse this one?
20:54:57 <ttx> Looks like most people generally agree on this one but would prefer a more precise wording
20:55:03 <russellb> dhellmann: why don't you file a new one
20:55:07 <dhellmann> russellb: ok
20:55:14 <russellb> thanks!
20:55:28 <ttx> needs a few more iterations, I think
20:55:33 <ttx> * add upgrade testing expectation (https://review.openstack.org/86162)
20:55:41 <ttx> The latest wording on that one looks fine to me, I'll approve it once it reaches 7 YES
20:55:48 <ttx> (if nobody objects)
20:56:02 <ttx> Remarks on those two ?
20:56:59 <ttx> #topic Minor governance changes
20:57:03 <ttx> * Add qa-specs to the QA Program (https://review.openstack.org/86965)
20:57:10 <ttx> This one has past and new PTL approval, no objection: will approve after meeting
20:57:16 <ttx> * Update programs list with Juno PTLs (https://review.openstack.org/86896)
20:57:26 <ttx> This one is a catch-up, will approve after meeting (mikal's objection not being founded)
20:57:35 <ttx> * Adds integrated release names to programs.yaml (https://review.openstack.org/81859)
20:57:42 <mikal> Hey!
20:57:45 <ttx> annegentle was working on a new version -- I fear we'll lose backward compatibility though
20:57:56 <ttx> mikal: :P
20:58:02 <annegentle> ttx: I uploaded the latest
20:58:08 <annegentle> for perusal
20:58:09 <ttx> annegentle: ok we'll look at it
20:58:18 * mikal changes his vote
20:58:32 <ttx> jeblair: in particular the pieces of infra consuming it might need a patch to support a new format
20:58:42 <ttx> at this point there shouldn't be too many
20:58:48 <ttx> I know stackalytics consumes it too
20:58:59 <mordred> I was just about to mention them
20:59:12 <jeblair> ttx: ack
20:59:13 <ttx> * Add the Kite key distribution service to programs.yaml (https://review.openstack.org/84811)
20:59:21 <ttx> This one needs a fix on the commit message and should be able to go in
20:59:29 <ttx> #topic Open discussion
20:59:36 <ttx> last minute
20:59:39 <ttx> Anything else, anyone ?
20:59:51 * jeblair learns SlickNik's real name
20:59:53 <ttx> TC nominations end Friday at like 5 UTC
21:00:08 <mordred> ossum
21:00:13 <russellb> "like 5"
21:00:14 <mordred> can I run for a second seat?
21:00:18 <russellb> is 4 like 5?
21:00:20 <mikal> Seems like a good bunch of candidates so far
21:00:25 <mordred> mikal: ++
21:00:40 <ttx> April 18 05:59 UTC
21:00:41 <mikal> I'm a bit surprised there are so many, but perhaps I've forgotten how competitive it is
21:00:47 <ttx> so more like 6
21:00:51 <jeblair> there were a bunch last time too
21:00:59 <jeblair> at least, many more than seats
21:01:11 <russellb> yeah, i want to say it was closer to 25 candidates for the full election last time
21:01:12 <ttx> OK, time to end it
21:01:38 <ttx> #endmeeting