20:01:53 <ttx> #startmeeting tc
20:01:54 <openstack> Meeting started Tue May  6 20:01:53 2014 UTC and is due to finish in 60 minutes.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:01:55 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:01:57 <openstack> The meeting name has been set to 'tc'
20:01:59 <ttx> Yay, first meeting of the Juno membership!
20:02:02 <rustlebee> o/
20:02:10 <ttx> The agenda for today is intentionally light, mostly around selecting chair and making some announcements:
20:02:11 <mordred> welcome new people
20:02:15 <jeblair> i'm here
20:02:21 <ttx> #link https://wiki.openstack.org/wiki/Governance/TechnicalCommittee
20:02:25 <markmc> welcome :)
20:02:31 <ttx> First things first, we should approve the new membership into governance:
20:02:37 <ttx> #link https://review.openstack.org/92395
20:02:49 <ttx> would be good to approve it now with 7+ yes
20:02:56 <mordred> jaypipes: or, you know, very old people
20:03:05 <jaypipes> mordred: :P
20:03:07 <jeblair> he's not THAT old
20:03:21 <devananda> o/
20:03:28 <devananda> sort of here - at least until this plane takes off
20:03:33 <ttx> although I guess it could count as a basic change
20:03:41 <jeblair> devananda: is attending mordred style
20:03:55 <markmcclain> looks like we've got 7
20:04:06 <ttx> ack
20:04:08 <mikal> Yeah, it should be trivial to vote it thorugh
20:04:08 <ttx> approved
20:04:14 <ttx> #topic Selection of the TC chair
20:04:20 <markmc> heh
20:04:25 <ttx> This role is defined in the Foundation bylaws and the TC Charter.
20:04:36 <mikal> Do we nominate people? I don't remember
20:04:38 <ttx> The TC chair is responsible for making sure meetings are held according to the rules of our charter, and for communicating the decisions taken during those meetings to the Board of Directors and the OpenStack community at large.
20:04:59 <ttx> Basically, the chair organizes and chairs the meetings, keeps track of resolutions and votes, sends out minutes when needed, maintains the TC wiki pages [3], keeps track of the Active Technical Contributors roster, etc.
20:05:08 <markmc> (and for being prepared enough to copy and paste stuff into irc during meetings rather than making us wait while he/she types)
20:05:27 <ttx> the [3] gives it away though
20:05:33 <ttx> Since that's part of my job description I'm happy to continue doing it. Do we have other candidates ?
20:05:36 * jaypipes nominates ttx
20:05:40 <mikal> I nominate ttx
20:05:43 <markmcclain> +1
20:05:44 <sdague> ++
20:05:55 <markmc> definitely :)
20:06:00 <devananda> +1
20:06:02 <vishy> +1
20:06:03 <ttx> Oh why, here is a change to vote on that!
20:06:09 <mikal> LOL
20:06:11 <ttx> #link https://review.openstack.org/92461
20:06:12 <markmcclain> haha
20:06:15 * vishy is shocked
20:06:16 <jaypipes> ttx: thou plan hast failed.
20:06:17 <jeblair> +1
20:06:35 <mordred> +1
20:06:56 <mikal> Heh, fastest approval ever
20:07:04 <mikal> That has its 7 votes
20:07:19 <ttx> Thanks everyone!
20:07:26 <mikal> Congrats!
20:07:29 <mikal> (sucker)
20:07:29 <jaypipes> no, thank YOU
20:07:37 <dhellmann> indeed
20:07:48 <ttx> #topic TC meeting time
20:07:56 <ttx> Shall we keep this time and place for the TC meeting ?
20:08:06 <mikal> So... who is horribly hurt if we shift this meeting by an hour to being later in the day?
20:08:07 <ttx> I think we actually reduced our exposition to weird TZ his time
20:08:18 <ttx> mikal: me
20:08:28 <mikal> This is a 5am start for me, but I can keep doing it if its the least worst choice
20:08:33 <mikal> I just want you guys to feel sorry for me
20:08:48 <ttx> and one hour later is the project/release meeting
20:08:51 <jaypipes> mikal: hour or two later is fine with me
20:09:11 * ttx wouldn't look forward having that meeting at 1am
20:09:15 <jeblair> i'm flexible, but want to attend both -- maybe we can swap them?
20:09:28 <mikal> Swapping wouldn't help me
20:09:29 <ttx> jeblair: wouldn't solve mikal's issue though
20:09:36 <mikal> If its really 1am for ttx, let's stick with this time
20:09:45 <mikal> I knew the meeting time when I ran
20:09:49 <mikal> I just want sympathy hugs
20:09:52 <ttx> well, would end at 1am IF we push back one hour
20:09:55 * jaypipes sends hugs
20:09:58 <mikal> Heh
20:10:09 <jaypipes> course, they won't get there until tomorrow..
20:10:12 <sdague> stupid round earth
20:10:30 * mordred hands mikal a cat
20:10:35 <ttx> mikal: I'm happy to help you find a new home near UTC time
20:10:47 <mikal> ttx: do you want to do a vote resolution thingie for the meeting time?
20:10:49 <ttx> mikal: we also have internet!
20:10:55 <ttx> mikal: not really
20:11:01 <mikal> ttx: I like my home. We have snakes.
20:11:09 <mikal> ttx: just a concesus here then?
20:11:16 <ttx> let's keep it the way it is and revisit once we miss mikal a few times
20:11:17 <mikal> I'm +1 on staying at this time then
20:11:44 <ttx> #topic Live TC gathering/dinner in Atlanta
20:11:50 <ttx> mordred: how is the organization of the TC dinner going ?
20:12:55 <mordred> going well
20:13:06 <mordred> although I need to call a person and give them my credit card details
20:13:12 <ttx> confirmed on Thursday ?
20:13:14 <mordred> yah
20:13:19 <dhellmann> let it be me, please, let it be me!
20:13:25 * ttx books
20:13:30 <mordred> I figure we meet up outside of the last session
20:13:34 <mordred> and go over together
20:13:37 <sdague> sounds good
20:13:42 <markmcclain> sounds good
20:13:50 <dhellmann> +1
20:13:53 <mordred> also - somebody should let lifeless and markmcclain know too?
20:14:02 <ttx> you mean jgriffith
20:14:03 <sdague> there was at one point a talk of a non dinner gathering
20:14:06 <mordred> I do?
20:14:08 <mordred> ok
20:14:10 <mordred> damn
20:14:12 * mordred sucks
20:14:17 <mordred> yes. in fact, markmcclain is right here
20:14:19 <mikal> What time was it again?
20:14:27 <mordred> mikal: after the last summit session
20:14:28 <mikal> Straight after the summit sessions?
20:14:30 <mordred> yeah
20:14:33 <mikal> ok
20:14:39 <mordred> meet at summit session, wander over/get cabs
20:14:51 <markmcclain> where are we wandering?
20:14:55 <sdague> try not to have cabs run off the road
20:15:02 <mordred> http://www.millerunion.com
20:15:19 <markmcclain> sweet he was finalist of beard award yesterday
20:15:21 <mikal> sdague: so true
20:15:23 <ttx> sdague: we already have a few gatherings scheduled with the TC/BoD thing and the ops meeting meet the TC thing
20:15:25 <jaypipes> oh I'll have to figure out what to wear. what a bother.
20:15:34 <markmcclain> sdague: no highways to worry about this time
20:15:38 <mordred> jaypipes: we have a private room
20:15:44 <mordred> jaypipes: so don't worry about it
20:15:48 * devananda updates calendar
20:15:49 <jaypipes> :)
20:16:32 <ttx> jaypipes: just wear something.
20:16:36 <ttx> please.
20:16:43 <mikal> toga!
20:17:00 <ttx> #topic Joint BoD/TC meeting in Atlanta
20:17:01 <jaypipes> :)
20:17:15 <markmc> #link https://wiki.openstack.org/wiki/Governance/Foundation/11May2014JointMeeting
20:17:17 <ttx> Sunday before summit, between 3pm and 5pm we'll have the joint TC/BoD meeting
20:17:27 <ttx> agenda at link markmc posted
20:17:29 <markmc> this hour with 11 topics?
20:17:35 <ttx> (I copy paste but i can adapt)
20:17:35 <markmc> lightning talk format or what?
20:17:44 <lifeless> mordred: I am here ;)
20:17:46 <ttx> It will be followed by a dinner at 6:30pm, where the Foundation staff and the User committee are also invited
20:17:58 <ttx> Dinner will be at Der Biergarten (2 blocks from the Omni / Georgia World Congress Center) 300 Marietta St NW
20:18:33 <ttx> markmc: no comment :)
20:18:57 <markmc> we're close to 40 people at this meeting, right?
20:18:58 <ttx> I think those are board meeting minutes, not metric minutes.
20:19:20 <markmc> the board has never been this ambitious with their agenda
20:19:24 <markmc> and this is even more people :)
20:19:39 <vishy> 11 topics does seem a little agressive
20:19:52 <vishy> * aggressive
20:20:00 <mordred> lifeless: we're doing TC dinner Thursday night and you're invited
20:20:03 <ttx> especially with everyoe around the table wanting to talk to show why they are present
20:20:18 <lifeless> mordred: cool
20:20:30 <ttx> vishy: I'm pretty sure we won't end at 5pm, but rather at 6:30pm
20:20:33 <jeblair> yeah, i think we'll need to keep to a strict schedule
20:21:25 <ttx> jeblair: we might need to skip some topics to give more time to others
20:21:58 <ttx> I'd like to make sure we get to "Clarify devs usage of the OpenStack trademark"
20:22:19 <ttx> as well have at least 5min to raise the 'CLA' issue
20:22:34 <jeblair> depends on whether we think we can actually solve them, or if the benefit is to try to get to some common ground on all of them
20:22:48 <lifeless> mordred: will you be sending invites via mail ?
20:22:50 <dhellmann> did we discuss the priorities on these topics at an earlier meeting?
20:22:51 <vishy> the product management question is most interesting to me
20:23:08 <mordred> lifeless: nope. meet us after the final session of the day thursday and you can tag along
20:23:11 * devananda drops offthe meeting as the plane takes off
20:23:27 <ttx> dhellmann: we made a list of suggestions, and the board accepted almost all of them in the agenda
20:23:40 <ttx> and didn't add much of its own
20:23:44 <dhellmann> ttx: ok, I was wondering about how the times were allocated
20:23:57 <dhellmann> oh, this isn't just our portion of the agenda?
20:23:59 <ttx> dhellmann: I just accepted Alan's time allocation
20:24:39 <ttx> dhellmann: those two hours are the part that is allocated to the joint meeting yes
20:24:46 <dhellmann> got it
20:25:41 <dhellmann> a lot of these topics seem like things that aren't going to be solved by a meeting with the board, and the things that *are* important to discuss in person haven't been given much time
20:26:21 <ttx> dhellmann: I think the goal is to discuss and align on a set of priorities, as well as let a few problems surface
20:26:28 <dhellmann> ok
20:26:52 <ttx> well, anyway, we'll see how it goes
20:26:54 <markmc> is there a leader for each of those topics?
20:27:00 <ttx> does anyone already know they won't be able to make it ?
20:27:01 <markmc> might be more effective
20:27:15 <ttx> markmc: that's a good idea
20:27:16 <mikal> markmc: I agree having a moderator would help
20:27:20 <lifeless> mordred: meed you where
20:27:24 <lifeless> *meet* you where
20:27:26 <markmc> leader gives 60 second intro, 10 minutes for comments from others, then move on
20:27:27 <mikal> markmc: but I think it needs to be someone who doesn't hold a storng stance
20:27:38 <dhellmann> I would expect the alan to moderate, but we should have someone ready to speak briefly on each topic
20:27:45 <mikal> markmc: i.e. the moderator has to stay out of the conversation and just guide
20:27:48 <ttx> markmc: the meeting is co-chaired by Alan and myself, but that doesn't mean we'd be the best moderators for EVERY topic
20:28:20 <ttx> markmc: I'll reach to Alan and try to put a name in front of all of those
20:28:22 <markmc> yeah, I'm talking more about someone to introduce the topic and talk about it
20:28:31 <markmc> probably should be the person who proposed it for the agenda :)
20:28:43 <dhellmann> does the board follow any formal rules for running its meetings? would those apply here?
20:28:46 <ttx> #action ttx to reach to Alan to see if we can have a moderator for each topic to speed up meeting
20:29:00 <ttx> dhellmann: it's not a board meeting, so those rules wouldn't apply
20:29:18 <ttx> #action ttx to prepare the homework reading for the board
20:29:20 <dhellmann> ok, just trying to set my expectations appropriately
20:29:34 <mikal> ttx: please send us the homework too
20:29:44 <mikal> ttx: so we have a shared starting state
20:29:57 <ttx> mikal: that would probably be a couple of my blogposts on the hitory of the TC
20:30:16 <ttx> I need to check if what I wrote back then still applies
20:30:18 <mikal> ttx: oh, ok.
20:30:32 <ttx> mikal: it's like "before the TC there was the PPB
20:30:33 <dhellmann> ttx: if it does, we should put it in the history section of the governance repo for safe-keeping
20:30:33 <ttx> "
20:30:34 <mikal> ttx: I was thinking more specific to the topics under discussion than that
20:30:57 <ttx> mikal: oh, no, it's just that the BoD members sometimes have no idea what the TC is about
20:31:05 <ttx> like they think the Board is above it
20:31:05 <mikal> Heh
20:31:13 <rustlebee> that's kinda sad
20:31:38 <ttx> so rather than spend meeting time explaining it, Alan suggested that I prepare some homework reading for board members
20:31:41 <mikal> I've had at least two conversations about who should set the roadmap for OpenStack overall recently, so that would be a nice thing to discuss over dinner too
20:31:49 <mikal> But I don't think we should add it to that agenda, as its too full already
20:32:14 <markmc> it's kinda there already
20:32:36 <markmc> external view of goals, product management, integrating user feedback, etc.
20:32:57 <mikal> Yeah, this is more "where will openstack be in two / five years"
20:33:22 <mikal> But anyway, its an over beer conversation
20:33:30 <markmcclain> mikal: probably be too many people at dinner to have effective conversation about it
20:33:30 <ttx> OK, anything more on that subject ?
20:33:50 <markmc> kinda related, just thougt of it
20:33:50 <markmc> https://etherpad.openstack.org/p/Win-The-Enterprise
20:33:58 <markmc> a new initiative by some board members
20:34:07 <markmc> was mentioned on foundation@ list
20:34:23 <markmc> ends with "    Once the Board has approved the work group report from the previous phases, the workgroup will engage community members to execute Action Plans. This could include developing new blue prints, making upstream contributions and engage with other work groups (ex. analyst relations) to collaborate on the appropriate actions. "
20:34:39 <markmc> just FYI for everyone that this is happening
20:34:52 <mikal> That's very inline with what people are asking me about road maps
20:35:07 <jaypipes> god I hate the term "enterprise".
20:35:09 <mikal> i.e. who at the foundation / board / tc is tracking feature gaps which hurt openstack adoption and fixing them
20:35:15 <markmc> I'm sure the board members involved would appreciate input on providing that input and action plans in an effective way
20:35:32 <mikal> Yeah, I only just learnt about this initiative
20:35:34 <rustlebee> a lot of that is happening downstream
20:35:38 <mikal> I shall read the etherpad
20:35:44 <rustlebee> but some more coordination would probably be a productive thing
20:35:52 <mikal> rustlebee: it would be nice to have more cooperation on that stuff
20:35:53 <ttx> it's also stepping over the user committee, but meh
20:35:55 <lifeless> I think sdagues point about the user survey effectiveness is very relevant here
20:35:58 <mikal> rustlebee: to avoid forking etc
20:36:15 <rustlebee> kind of orthogonal to forking, i think
20:36:26 <rustlebee> i just mean that downstreams do these things to set their own priorities for what to work on upstream
20:36:33 <mikal> rustlebee: ok, let me rephrase as "duplicated effort"
20:36:40 <rustlebee> sure
20:36:51 <markmc> I think we should welcome any group attempting to put together analysis like this
20:36:56 <rustlebee> agree
20:36:59 <vishy> rustlebee: the problem is that is leading to what we have today
20:37:07 <vishy> which is an explosion of incubated projects
20:37:09 <markmc> doesn't let us off the hook from highlighting what we see are gaps tho
20:37:14 <ttx> I suggest we move on to "minor governance change" and we use open discussion to continue to talk about that joint meeting
20:37:16 <vishy> and some core concerns not getting addressed
20:37:27 <mikal> ttx: that's fine with me
20:37:28 <ttx> #topic Minor governance changes
20:37:38 <ttx> I selected a number of minor changes that should probably not wait two weeks to make further progress:
20:37:50 <ttx> * Adds integrated and incubated release names to programs.yaml (https://review.openstack.org/81859)
20:38:00 <ttx> This one is ripe for approval and will cause a number of rebases
20:38:21 <ttx> will approve after meeting unless someone objects
20:38:35 <ttx> * Update sphinx doc repository layout and toctrees (https://review.openstack.org/91422)
20:38:46 <dhellmann> I fixed that one up based on feedback about the symlinks
20:38:54 <ttx> This one will need to be rebased on top of the recent membership updates
20:39:19 <ttx> but then it can be approved if nobody objects
20:39:19 <dhellmann> yep, I'll do that tomorrow
20:39:25 <ttx> * Render member list in HTML output (https://review.openstack.org/91450)
20:39:27 <ttx> Depends on the previous one
20:39:39 <dhellmann> that will be rebased at the same time
20:39:40 <ttx> also a logistics change, will be approved if nobody objects
20:39:50 <ttx> * Add project mission statement for Ceilometer (https://review.openstack.org/87526)
20:40:07 <ttx> This one still needs some feedback from the OP. Will approve if it gets 7 +1s (and shall be rebased on top of Anne's change)
20:40:18 <ttx> * Add the Kite key distribution service to programs.yaml (https://review.openstack.org/84811)
20:40:22 <mikal> ttx: jogo has some questions about the ceilometer one, but I asked him to comment on the review
20:40:27 <mikal> ttx: not sure if he's done it yet though
20:40:37 <jogo> mikal: I have
20:40:47 <ttx> we are waiting to hear back from the owner
20:40:49 <ttx> This one looks good, we could use the formal approval of the PTL there but once we have it, i'll approve this unless someone complains
20:41:04 <ttx> also will need to be rebased on top of Anne's change
20:41:21 <ttx> or was it already
20:41:33 <ttx> yes it was
20:41:38 <ttx> * Add oslo.db to the Oslo program (https://review.openstack.org/90127)
20:41:47 <ttx> This one has PTL approval, but will need to be rebased on top of Anne's change
20:42:43 <ttx> All of those are not really policy changes but mostly maintenance and logistics, so will approve them without waiting for 7 YES unless someone posts a -1
20:43:09 * ttx approves Anne's one now
20:43:21 <dhellmann> ttx: https://review.openstack.org/92429 is similar, adding oslo.i18n
20:44:00 <ttx> dhellmann: ok
20:44:30 <ttx> Anne's one is now merged, that should clarify
20:45:28 <ttx> #topic Open discussion
20:45:37 <ttx> We shall obviously skip next week meeting
20:46:15 <ttx> For the week after, we have 4 projects left on our requirements gap analysis
20:46:26 <ttx> Glance Swift Horizon and Heat
20:47:10 <ttx> I'll see which one can go next
20:47:42 <ttx> more discussion about the joint meeting ?
20:47:51 <ttx> is everyone coming ?
20:47:54 <mikal> I don't need to talk about the joint meeting any more
20:47:56 <mikal> I'm coming though
20:48:03 <rustlebee> yep, will be there.
20:48:05 <dhellmann> I'll be there
20:48:16 <vishy> yup
20:48:43 <markmcclain> yep
20:49:22 <jaypipes> yup
20:49:28 <ttx> any specific bullet point from the agenda you want a clear outcome from ?
20:49:54 <ttx> my pick would be on "Clarify devs usage of the OpenStack trademark"
20:51:08 <dhellmann> I'd like the discussion of the CLA to at least lead to a "next step" decision
20:51:31 <dhellmann> the response to those patches that were blocked because people couldn't sign the CLA this cycle was underwhelming.
20:52:15 <ttx> I hope the CLA discussion will reboot some members opinion about it
20:52:25 <ttx> so far they have had only the lawyers part of the story
20:52:42 <ttx> it can't hurt to hear the community side
20:52:45 <dhellmann> right
20:52:58 <ttx> not sure that will get to a "next action" though
20:53:22 <ttx> also the dinner could be a better way to win the hearts of members over this issue
20:53:23 <markmc> well, next action will be to discuss further at the cross-project session
20:53:33 <ttx> once it's been introduced as an issue, even for just 5 min
20:53:44 <dhellmann> markmc: are the board members going to be able to get into that?
20:53:47 <markmc> beyond that, it'll be getting into bringing a real proposal for change to the board
20:54:01 <markmc> dhellmann, dunno, it's not the audience I hoped for anyway
20:54:04 <dhellmann> ok
20:54:16 <ttx> dhellmann: we first need rough consensus in the dev community about it
20:54:21 <markmc> indeed
20:54:54 <markmc> I'll have some background material for the board by Sunday
20:54:59 <ttx> Anything else, anyone?
20:55:40 <ttx> Can't wait to see you all in a few days
20:55:48 <sdague> safe travels all
20:55:49 <rustlebee> indeed
20:56:15 <mikal> Yep, looking forward to it
20:57:39 <mikal> I need to change location before the next meeting, so dropping offline for a sec
20:58:32 <ttx> time to end meeting, thanks all
20:59:24 <ttx> #endmeeting