#openstack-meeting: tc

Meeting started by ttx at 20:03:07 UTC (full logs).

Meeting summary

    1. https://wiki.openstack.org/wiki/Governance/TechnicalCommittee (ttx, 20:03:17)

  1. Glance Program Mission Statement and the Catalog (ttx, 20:03:27)
    1. http://lists.openstack.org/pipermail/openstack-dev/2014-June/036767.html (ttx, 20:03:37)
    2. https://review.openstack.org/98001 (ttx, 20:03:50)
    3. https://review.openstack.org/98002 (ttx, 20:04:02)
    4. AGREED: let's iterate on wording on the gerrit review (ttx, 20:20:57)

  2. Glance Functional API and Cross-project API Consistency (ttx, 20:21:11)
    1. http://lists.openstack.org/pipermail/openstack-dev/2014-May/036416.html (ttx, 20:21:19)
    2. http://lists.openstack.org/pipermail/openstack-dev/2014-June/thread.html#36701 (markmc, 20:22:20)
    3. AGREED: Glance can definitely go in that direction for API (ttx, 20:26:31)
    4. TC would like to have "good API design" guidelines to encourage convergence, looking for volunteers to document and propose that (ttx, 20:26:59)
    5. https://restful-api-design.readthedocs.org/en/latest/methods.html (devananda, 20:27:00)
    6. http://fedoraproject.org/wiki/Cloud_APIs_REST_Style_Guide (ttx, 20:28:48)

  3. Integrated projects and new requirements: Gap analysis for Glance (ttx, 20:31:58)
    1. https://etherpad.openstack.org/p/glance-integration-gaps (ttx, 20:32:17)
    2. recommendation: more coverage (API v2, binary content...) (ttx, 20:41:09)
    3. recommendation: saner review pattern (ttx, 20:41:25)
    4. recommendation: fix glance-coresec to only include 2-4 active core members interested in security issues (ttx, 20:43:25)
    5. gap: intgeration tests -- lack of testing a binary image (ttx, 20:45:15)

  4. Defcore status update (ttx, 20:47:28)
  5. Governance changes in review (ttx, 20:53:41)
  6. Housekeeping items (ttx, 21:00:44)
  7. Open discussion (ttx, 21:01:11)


Meeting ended at 21:02:57 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. ttx (117)
  2. markwash (70)
  3. russellb (34)
  4. markmc (33)
  5. dhellmann (31)
  6. mikal (29)
  7. sdague (25)
  8. jaypipes (18)
  9. mordred (17)
  10. annegentle (16)
  11. devananda (16)
  12. anteaya (15)
  13. zaneb (15)
  14. fungi (15)
  15. Kiall (9)
  16. markmcclain (4)
  17. openstack (3)
  18. mugsie (3)
  19. gokrokve (3)
  20. eglynn (3)
  21. dhellman_ (2)
  22. navid (2)
  23. dhellmann_ (1)
  24. vishy (1)


Generated by MeetBot 0.1.4.