20:01:36 <ttx> #startmeeting tc
20:01:37 <openstack> Meeting started Tue May  5 20:01:36 2015 UTC and is due to finish in 60 minutes.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:01:38 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:01:40 <openstack> The meeting name has been set to 'tc'
20:01:51 <ttx> Our agenda for today:
20:01:57 <ttx> #link https://wiki.openstack.org/wiki/Meetings/TechnicalCommittee
20:02:07 <krotscheck> o/
20:02:09 <ttx> #topic Welcome to Liberty TC members
20:02:18 <ttx> lifeless is excused
20:02:20 <ttx> dtroyer, flaper87: welcome!
20:02:23 <flaper87> o/
20:02:28 <dtroyer> thanks
20:02:39 <sdague> ttx: o/
20:03:04 <dhellmann> welcome aboard
20:03:10 <ttx> dtroyer, flaper87: any pressing question ?
20:03:16 <jgriffith> 0/
20:03:20 <mordred> o/
20:03:24 <dtroyer> ttx: not atm
20:03:24 <flaper87> none from me
20:03:31 <ttx> alright, let's dive in it
20:03:33 <ttx> #topic Election of the TC Chair
20:03:39 <ttx> Our first step is to (s)elect the TC chair
20:03:49 <ttx> The TC chair is responsible for making sure meetings are held (and decisions taken) according to the rules of our charter
20:03:59 <ttx> Practically, the TC chair organizes the meetings and pushes the Workflow+1 button on governance changes
20:04:09 <jgriffith> The glue that binds us together :)
20:04:13 <ttx> I'm happy to continue doing that, but if we have other candidates we can set up a quick CIVS poll to decide
20:04:23 <ttx> Anyone else interested ?
20:04:36 <jaypipes> nope.
20:04:37 * dhellmann takes one step back
20:04:41 <egon> heh
20:04:42 * flaper87 silently helps ttx sitting in the TC chair
20:04:43 <sdague> run away ...
20:04:45 <markmcclain> ttx: +1 to you continuing
20:04:54 * ttx innocently hides a gun in his back
20:04:56 * jgriffith hides under his desk
20:05:24 <jeblair> everyone should do it once so they know why they should pretend not to be here now
20:05:40 <jgriffith> maybe next time ttx... maybe next time....
20:05:41 <ttx> ok, don't worry, there will be plenty of new opportunities to step up
20:05:49 <dhellmann> ttx: I'm happy to fill in when you can't be here :-)
20:06:01 <jgriffith> jeblair: lighten up, it's a hard job and I don't have to "do it" to know it's difficult
20:06:44 <markmcclain> ttx: do you need someone for formally nominate you?
20:06:49 <markmcclain> s/for/to/
20:06:54 <sdague> lifeless: already did in email
20:06:55 <ttx> markmcclain: not really
20:06:58 <sdague> I think that counts
20:06:59 <ttx> ok, let's register at least one person approving
20:07:02 <markmcclain> sdague: +1
20:07:06 * flaper87 formally nominates ttx
20:07:24 <ttx> #startvote Approve Thierry Carrez as TC chair for Liberty cycle? yes, no, abstain
20:07:25 <openstack> Begin voting on: Approve Thierry Carrez as TC chair for Liberty cycle? Valid vote options are yes, no, abstain.
20:07:26 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
20:07:32 <sdague> #vote yes
20:07:33 <dhellmann> #vote yes
20:07:33 <flaper87> #vote yes
20:07:36 <annegentle> #vote yes
20:07:36 <dtroyer> #vote yes
20:07:37 <jeblair> #vote yes
20:07:37 <ttx> #vote abstain
20:07:39 <jgriffith> #vote yes
20:07:45 <markmcclain> #vote yes
20:07:47 <ttx> 30 more seconds
20:07:58 <dansmith> #wouldvoteifIcould yes
20:08:09 <egon> dansmith: ditto
20:08:14 <ttx> #endvote
20:08:15 <openstack> Voted on "Approve Thierry Carrez as TC chair for Liberty cycle?" Results are
20:08:16 <openstack> yes (8): annegentle, jeblair, sdague, jgriffith, dhellmann, dtroyer, flaper87, markmcclain
20:08:17 <openstack> abstain (1): ttx
20:08:25 <ttx> OK, I guess that's official enough now
20:08:28 <ttx> thanks for your trust
20:08:31 <jaypipes> #vote yes
20:08:40 <jaypipes> well damn. too late.
20:08:44 <ttx> jaypipes: maybe next time :)
20:08:45 <ttx> #topic Summit week
20:08:55 <markmcclain> ttx: do you have a patch for reference/members queued up? or should I hack on up?
20:09:04 <ttx> Just as a reminder, there is a joint Board/TC meeting Sunday afternoon just before summit
20:09:15 <ttx> markmcclain: no patch queued up, wanted to wait until chair was selected
20:09:24 <ttx> markmcclain: fgeel free to propose one
20:09:36 <ttx> Board/TC joint meeting in theory from 2:30 pm to 5:30pm
20:09:44 <ttx> But then they may have run lkate
20:09:46 <ttx> or late
20:09:52 <ttx> It is followed by a dinner at 6pm, for which you should have received an RSVP
20:10:07 <annegentle> ha I read that as 5:30 am at first
20:10:14 <ttx> Thursday evening we have the TC dinner at 7pm, you should have received an email from mordred about that
20:10:15 * flaper87 won't make it for the meeting, landing at 15:00 ish
20:10:28 <ttx> flaper87: you can join us when you arrive
20:10:41 <ttx> I heard jet lag doesn't affect you
20:10:46 <annegentle> lucky
20:10:48 <flaper87> ttx: that is true :)
20:11:03 <ttx> Questions on that topic ?
20:11:26 <dhellmann> ttx: details of the meeting location will be coming later?
20:11:39 <ttx> Hmm, let me check if I have anything
20:11:44 <ttx> Maybe our board members know more
20:12:30 <eglute> Emerald Ballroom in the Fairmont Pacific Rim Hotel
20:12:50 <annegentle> thanks eglute!
20:12:54 <ttx> Meeting Location: Emerald Ballroom in the Fairmont Pacific Rim
20:12:54 <ttx> hotel
20:12:58 <flaper87> thnx
20:12:58 <ttx> eglute wins
20:13:06 <dhellmann> thanks, eglute
20:13:11 <annegentle> Vancouver is Pacific time?
20:13:15 <ttx> (directly across the street from the Vancouver Convention Centre). It�s located on the 3rd floor of the hotel.
20:13:16 <dhellmann> annegentle: yes
20:14:18 <ttx> For that joint meeting, if you have pressing topics, please send them my way and I'll communicate them to Alan
20:14:33 <annegentle> hm thinking
20:14:35 <ttx> Hopefully we'll have an agenda to present at next week meeting
20:14:45 * ttx needs to contact alan on that
20:15:26 <ttx> #topic Report from the Design Summit Cross-project track working group
20:15:31 <ttx> dhellmann: floor is yours
20:15:35 <dhellmann> thanks!
20:15:43 <dhellmann> We plan 2 tracks of 7 cross-project sessions each (14), all fishbowl-style rooms
20:15:48 <dhellmann> There are 28 proposals in https://docs.google.com/spreadsheets/d/1vCTZBJKCMZ2xBhglnuK3ciKo3E8UMFo5S5lmIAYMCSE/edit#gid=827503418
20:15:57 <dhellmann> lifeless, annegentle, sdague, flaper87, markmcclain, and devananda met last friday and yesterday to discuss the proposals to narrow the list
20:16:05 <dhellmann> The meeting logs are http://eavesdrop.openstack.org/meetings/tc_summit_planning/2015/tc_summit_planning.2015-05-01-20.02.log.html
20:16:05 <dhellmann> Most of the meeting notes are actually in the etherpad we created https://etherpad.openstack.org/p/liberty-cross-project-session-planning
20:16:21 <dhellmann> the discussions yesterday were mostly in email, with me capturing notes to the etherpad
20:16:26 <dhellmann> (stand by for paste-bomb)
20:16:35 <dhellmann> The sessions we came up with are listed at the top, and here (the numbers are row numbers in the spreadsheet):
20:16:35 <dhellmann> 2    In-team scaling
20:16:35 <dhellmann> 3    OpenStack release model(s)
20:16:35 <dhellmann> 4    Moving our applications to Python 3
20:16:36 <dhellmann> 27  Improving user experience across all OpenStack projects
20:16:37 <dhellmann> 9    Modern JavaScript in OpenStack
20:16:38 <dhellmann> 10&25 Asynchronous status updates to users
20:16:39 <dhellmann> 14   OpenStack SDK: where it's at, where it's going
20:16:40 <dhellmann> 17   Functional Testing Show & Tell
20:16:41 <dhellmann> 18   Service Catalog Standardization
20:16:42 <dhellmann> 22 API Working Group: State of the Group
20:16:43 <dhellmann> 26 Unified Policy File
20:16:44 <dhellmann> 11 OpenStack Documentation
20:16:45 <dhellmann> 7   Nova & Neutron network migration
20:16:46 <dhellmann> 29 Managing concurrency
20:16:47 <dhellmann> I confirmed with the organizers of 10 & 25 that merging was acceptable.
20:17:10 <ttx> Looks like a nice list of topics. Great work there !
20:17:25 <dhellmann> we did identify one topic that hadn't been proposed that we felt we needed, but if there are other pressing items we should discuss those
20:17:59 <ttx> dhellmann: now we have the fun part.. scheduling them to reduce conflict
20:18:07 <dhellmann> ttx: thanks, there were a few tough calls but I think we had a good broad set of inputs
20:18:24 * dhellmann takes one step back
20:18:48 <dhellmann> there's one note about the nova/neutron session needing an exact time slot
20:18:55 <dhellmann> I haven't looked into conflicts for the others, yet
20:19:03 * Rockyg dhellmann made right call lon logging
20:19:03 <ttx> dhellmann: for scheduling, in the past I generally had the generalist stuff on one room and the more technical/detail  stuff in another
20:19:11 <jeblair> the title change on #7 is fun :)
20:19:22 <sdague> I guess the only think that I thought about late is we keep hinting that mordred and jeblair are going to do a "what infra hates about openstack" session at some point, which never seems to happen
20:19:23 <jaypipes> dhellmann: what was the one topic not proposed that you felt needed discussed?\
20:19:44 <dhellmann> jaypipes: we added the "managing concurrency" session to cover that topic (sorry, I realize that was phrased poorly)
20:19:47 <sdague> jeblair: the title will change again on #7 to specify which part of the conversation this is, which is basically gap analysis
20:19:55 <jaypipes> ah, gotcha
20:20:03 <mordred> sdague: yeah - we never get aroudn to proposing that - sorry
20:20:07 <dhellmann> sdague: who should I be talking as a driver for that session?
20:20:13 <annegentle> sdague: mordred: jeblair: blog post!
20:20:16 <flaper87> FWIW, I'm quite happy we managed to have a slot for the concurrency topic
20:20:25 <dhellmann> annegentle: ++
20:20:31 <sdague> dhellmann: for the nova/neutron one - that's going to end up being me
20:20:36 <dhellmann> sdague: noted
20:21:32 <dhellmann> flaper87: ++
20:21:53 <sdague> flaper87: I'll be happier if something comes out of it that we think is doable :) There seem to be a lot of different corners at the moment
20:21:56 <dhellmann> do we want to go through questions on the proposed list?
20:22:18 <dhellmann> sdague: yeah, my goal for that one has a very narrow scope: figure out what options might actually be realistic
20:22:28 <sdague> dhellmann: ++
20:22:32 <flaper87> dhellmann: ++
20:22:37 <sdague> dhellmann: you chairing that one?
20:22:51 <dhellmann> sdague: yes, I think so
20:23:00 <sdague> then I have faith :)
20:23:11 <ttx> dhellmann: should we try to resolve TC members conflicts now by trying to pair those sessions now ?
20:23:28 <dhellmann> ttx: that sounds like a good plan - do we know the speaking schedule, yet?
20:23:37 <dhellmann> sdague: ty :-)
20:23:38 <sdague> the speaking schedule is public
20:23:41 <ttx> dhellmann: hmm, maybe do it off-meeting and post it to -tc list for last-minute checks ?
20:23:50 <dhellmann> ttx: ok
20:23:55 <ttx> dhellmann: from experience I know it's difficult to improvise in 5 min
20:24:09 <sdague> honestly, I'd say people should annotate the list with name and "not at X:Y" if they know of conflicts
20:24:12 <ttx> dhellmann: we have session moderators for all of those, right ?
20:24:16 <sdague> and the just guess the rest
20:24:20 <dhellmann> sdague: ++
20:24:35 <dhellmann> ttx: yes
20:24:35 <egon> One of the other teams is using http://doodle.com/ to coordinate meetings.
20:24:40 <sdague> basically, annotate today if you really want to be in a thing, and you have a time restriction
20:24:54 <sdague> egon: yeh, the problem is this is way too many dimensions
20:25:03 <dhellmann> good idea, please update the top of the etherpad where the list of approved sessions is
20:25:05 <egon> sdague: fair
20:25:22 <dhellmann> I will then use my famous note-cards-on-the-floor schedule resolution algorithm
20:25:35 <anteaya> I love that app
20:25:40 <sdague> heh
20:25:46 * flaper87 wonders if there's a youtube video tutorial for that algorithm
20:25:58 <dhellmann> flaper87: they banned it because of the swearing
20:26:04 <flaper87> dhellmann: lol
20:26:06 <markmcclain> haha
20:26:11 <ttx> dhellmann: I annotated the list on the etherpad with my conflicts
20:26:32 <dhellmann> ttx: could you include your nick in the comments so I can tell who's who when you aren't connected to the pad?
20:26:41 <dhellmann> ty
20:27:46 <ttx> dhellmann: ok, let's propose a schedule tomorrow, once everyone has posted their conflicts
20:27:50 <sdague> dhellmann: thanks for all the work putting this together
20:27:58 <flaper87> dhellmann: thanks indeed
20:28:00 <ttx> and see how it goes
20:28:09 <jeblair> ttx: do you have the design summit slot allocation chart handy?
20:28:10 <ttx> moving on
20:28:15 <dhellmann> sdague: I had a bunch of help from the other folks
20:28:23 <dhellmann> jeblair: https://docs.google.com/spreadsheets/d/1VsFdRYGbX5eCde81XDV7TrPBfEC7cgtOFikruYmqbPY/edit#gid=569963128
20:28:28 <jeblair> dhellmann: thx
20:28:49 <ttx> I suspect I'll have ops conflicts too, let's add those
20:29:13 <ttx> but let's do that off-meeting
20:29:24 <ttx> anything else on this topic before we move on ?
20:29:52 <ttx> #topic TC members list
20:29:56 <ttx> markmcclain just proposed the TC members update
20:30:01 <ttx> #link https://review.openstack.org/#/c/180301/
20:30:07 <ttx> I think it makes sense to approve it in this inaugural meeting, unless there is an objection
20:30:46 <dhellmann> LGTM, should we have our election official sign off?
20:30:53 <ttx> I won't nit pick about alpha-ordering of Flavio
20:31:03 <ttx> ah. hm
20:31:18 <annegentle> oh
20:31:23 <ttx> let's see if we can have one of them
20:31:37 * markmcclain goes back to school to learn to alphabetize
20:31:48 <ttx> tristanC, pleia2: could one of you record a comment on https://review.openstack.org/#/c/180301/ saying that corresponds to the election results ?
20:31:51 * flaper87 feels safe between sdague and annegentle
20:32:02 <dhellmann> markmcclain: Flavio comes between Dague and Gentle, just where you have it ;-)
20:32:03 <annegentle> if not randomized :)
20:32:06 <ttx> I'll wait for that election official blessing to approve
20:32:15 <dhellmann> ttx: ++
20:32:18 <ttx> #topic Project list housekeeping
20:32:25 <jeblair> (looks like the gerrit tc group is already updated)
20:32:32 <ttx> In the mean time, three repositories added to Ironic, already +1ed by their PTL:
20:32:41 <ttx> jeblair: yes, lifeless asked me for +1 powerz
20:34:58 <ttx> * Add ironic-discoverd to Ironic project (https://review.openstack.org/178067)
20:34:58 <ttx> * Clean up Ironic project listing (https://review.openstack.org/178066)
20:34:58 <ttx> * Add "bifrost" to Ironic project (https://review.openstack.org/178068)
20:34:58 <ttx> I'll approve them all tomorrow morning unless someone posts a -1 by then
20:34:58 <ttx> so last hours to object
20:34:58 <ttx> #topic Communicating on the TC activity
20:34:58 <ttx> So... There was a thread this week about how much the Kilo membership sucked at communicating what happens at the TC
20:34:59 <ttx> The trick being, with the move to Gerrit-based approvals we are approving stuff asynchronously, and no longer necessarily in meeting
20:34:59 <ttx> Which makes posting meeting minutes a bit weird
20:34:59 <ttx> Last cycle(s) we opted for authored blogposts when we felt like there was enough material to communicate, with a rotation of authors
20:34:59 <dhellmann> ttx: I could wire up yasfb to the governance repo like we did with the specs repos
20:34:59 <jeblair> git changelog? :)
20:34:59 <ttx> But only a handful of authors participated, and we didn't push enough of those
20:34:59 <ttx> My question is... how should we improve on that for this cycle ?
20:34:59 <dhellmann> (yasfb would give us an rss feed, which we could feed into planet.openstack.org)
20:34:59 <jeblair> dhellmann: neat
20:34:59 <maishsk> ttx: The fact that this is on the agenda is already a great step forward :)
20:34:59 <dhellmann> jeblair: http://specs.openstack.org/openstack-infra/infra-specs/rss.xml
20:34:59 <ttx> dhellmann: wouldn't that flood it with repo changes ?
20:35:22 <dhellmann> ttx: no, it produces a feed of pages, not patches, so you only get updates when we add or change pages
20:35:40 <dhellmann> I would have to experiment a bit to make sure that wouldn't be "too much"
20:36:07 <jeblair> yeah, the feed of changes looks a bit busy: http://git.openstack.org/cgit/openstack/governance/atom
20:36:15 <ttx> dhellmann: I fear that would result in only reporting TC activity that results in governance repo changes though
20:36:22 <dhellmann> ttx: well, yeah
20:36:55 <annegentle> dhellmann: ttx: that was one component, but this needs to be more highly curated and regular
20:36:58 <ttx> I kind of wanted us to work on things that may not translate into governance changes
20:37:10 <flaper87> mmh, I kinda feel we should actually collect this manually and write some kind of "this week on the TC"
20:37:10 <ttx> like solving community problems
20:37:39 <ttx> flaper87: +1, only for that we need volunteer(s)
20:37:41 <dhellmann> yeah, that will result in different, probably more useful, content
20:37:42 <sdague> flaper87: right, there was the blogging effort, it kind of ran out of steam
20:37:42 <flaper87> I can help with that
20:37:49 <david-lyle> The blog posts that happened in Kilo were spot on, I think
20:37:50 <zaneb> yeah, the best info for the community is not just what did we decide
20:37:57 <flaper87> but I think there should be more than 1 person behind this
20:38:03 <zaneb> it's what were the issues and the different points of view
20:38:06 <sdague> the problem mostly is the TC ends up super busy and it falls off people's plates
20:38:12 <ttx> ok, so we could continue the blogpost rotation idea
20:38:15 <ttx> only more regular ?*
20:38:32 <maishsk> flaper87: +1
20:38:33 <zaneb> (btw I tried to blog this myself for a cycle back in I think Havana. it's super hard to keep up with)
20:38:34 <ttx> like at every meeting, asking if it's time for a blog post and a volunteer ?
20:38:36 <annegentle> what did people think of the "secretary" idea?
20:38:53 <sdague> I also think every meeting is too much
20:39:07 <ttx> annegentle: the "secretary" idea is fine if we have a volunteer
20:39:10 <dhellmann> it's too much, and not enough -- as ttx pointed out we don't discuss everything in the meetings
20:39:18 <ttx> otherwise a rotation of volunteers sounds more likely
20:39:22 <sdague> dhellmann: sorry, every week
20:39:39 <dhellmann> sdague: yeah, weekly seems excessive
20:39:41 <sdague> I found the bunching up of 3 - 4 weeks ended up creating a more reasonable chunk of content in those pots
20:39:42 <sdague> posts
20:39:46 <dhellmann> yep
20:39:51 <jgriffith> +1 for weekly
20:39:52 <maishsk> ttx: I would be happy to start out as the volunteer. Just let me know what the process would be and the technical details
20:39:59 <annegentle> I think it's okay to have "this week in baseball" for the tc
20:40:03 <ttx> sdague: how about at the end of every meeting, we ask ourselves if it's time for a blog post and a volunteer ?
20:40:06 <dhellmann> the other question we didn't answer in that thread was what medium - blogs, emails to -dev, newsletter drop-ins?
20:40:14 <flaper87> I don't think it's an actual problem if there's not enough content
20:40:19 <dhellmann> ttx: that seems like a good idea
20:40:27 <zaneb> I'd suggest 1 major topic per post. I'd guess that would end up being less often than weekly
20:40:29 <annegentle> I think it's better to have one person be accountable. I can take this on.
20:40:31 <jgriffith> ttx: seems reasonable
20:40:40 <sdague> annegentle: you are awesome
20:40:43 <ttx> I think we failed to bring it back on the table often enough last cycle, but the concept was sound
20:40:53 <flaper87> annegentle: I'm happy to help
20:40:58 <annegentle> flaper87: awesome, thanks
20:41:02 <ttx> if we make it a regular meeting thing, that won't fall off the table*
20:41:27 <ttx> oh, we have a volunteer
20:41:37 <flaper87> ttx: 2 :P
20:41:38 <annegentle> I'll work on a comm plan that slices in with the weekly community newsletter from reed. Channel is tough here, I haven't dug into that completely.
20:41:51 <annegentle> ok
20:41:53 <ttx> So.. annegentle as secretary and Flavio as co-secretary
20:42:07 <annegentle> TC Communication Chairs?
20:42:18 <ttx> with resposibility to communicate TC activity out
20:42:18 <sdague> annegentle: ++
20:42:23 <dhellmann> ++
20:42:24 <sdague> I like that as a better title
20:42:41 <sdague> T triple C
20:42:46 <flaper87> annegentle: ++
20:42:46 <annegentle> heh
20:43:17 <ttx> Note that if I have my ways we'll have a number of subgroups in the TC taking on specific tasks. So the Communication subgroup would just be one of those
20:43:34 <annegentle> that makes a lot of sense
20:44:02 <ttx> #info annegentle and flaper87 to chair the TC communication
20:44:21 <ttx> OK, moving on, lots to cover
20:44:36 <ttx> annegentle: I'll let you come up with a plan ;)
20:44:37 <ttx> #topic Changing the TC decision delays
20:44:40 <annegentle> got it
20:44:43 <ttx> This is another TC process thing we might want to revisit
20:44:54 <ttx> Currently the charter says that to be considered for TC meeting agenda, a given change / proposal needs to have been proposed "at least 4 business days before meeting"
20:45:04 <ttx> The idea was to make sure that the community had plenty of time to comment on a proposal before we took a final decision on it
20:45:07 <ttx> But:
20:45:10 <ttx> - we no longer make decisions in meeting
20:45:16 <ttx> - we have plenty of changes that could be discussed faster (like repo additions)
20:45:26 <ttx> - most changes fly below radar anyway since they are not discussed in a ML thread (only on the Gerrit review)
20:45:33 <ttx> So I feel the old rule is no longer serving its purpose. Should we change it ?
20:45:49 <ttx> Like having different delays depending on the nature of the change ?
20:46:07 <anteaya> how would you categorize?
20:46:12 <ttx> and when should we force a discussion on the -dev ML ?
20:46:35 <dhellmann> I'm comfortable with giving the chair more leeway, but I do like the idea of a minimum amount of time for significant topics because of the nature of time zones
20:46:38 <ttx> anteaya: well, we already do special case repository additions as "project list housekeeping" and fasttrack them
20:46:44 <annegentle> which end goal are you trying for, buying more time for discussion or more strategic agendas?
20:46:56 <anteaya> ttx: okay that is a fairly clear category
20:47:00 <jeblair> ttx: well, i think we addressed the repo thing recently with: http://git.openstack.org/cgit/openstack/governance/commit/?id=321a020cbcaada01976478ea9f677ebb4df7bd6d
20:47:04 <dhellmann> I also think we could probably skip discussing those housekeeping things at all in meeting, unless they are stalled
20:47:11 <ttx> annegentle: I just had a bunch of repo additions posted Friday and those couldn't make the meeting agenda and felt sad
20:47:18 <flaper87> dhellmann: ++
20:47:33 <sdague> dhellmann: yes please
20:47:56 <jeblair> ttx: oh, i see the distinction now
20:47:59 <annegentle> end goal: not make ttx sad
20:48:11 <ttx> OK, so how about we skip repo additions and don't consider them TC stuff. I can let them bake at least one week to check for any -1 and approve them if they have PTL +1 and no TC -1 by then
20:48:16 <dhellmann> so, concrete proposal: housekeeping and repository adds aren't discussed unless they are stalled for a week; other topics need 48 hours
20:48:25 <dhellmann> heh
20:48:52 <sdague> ttx: ++
20:48:56 <annegentle> I think that keeping a strategic agenda is important... timeliness matters
20:49:07 <flaper87> ttx: ++
20:49:14 <mordred> ++
20:49:15 <ttx> FOr other topics let's keep the "4 business days" but translate it as "posted before Thursday evening"
20:49:16 <annegentle> so use the time for lots of discussions as needed
20:49:30 <jeblair> ttx: both suggestions sound good to me
20:49:35 <anteaya> ttx can we say it in utc?
20:49:38 <dhellmann> ttx: repository additions affect voter roles, so I think we need to be taking explicit action to approve them
20:49:55 <ttx> anteaya: before 0800 UTC Friday ?
20:50:01 <anteaya> ttx thank you
20:50:06 <ttx> that's the time where I ususally cllect the agenda
20:50:12 <ttx> collect*
20:50:44 <ttx> #agreed skip repo additions in TC meeting, let them bake at least one week to check for any -1 and approve them if they have PTL +1 and no TC -1 by then
20:50:57 <jeblair> ttx: want to propose that as a governance change?
20:51:22 <ttx> #agreed consider a change TC meeting material if posted before 0800 UTC Friday
20:51:28 <ttx> jeblair: yes, I will propose that
20:51:36 <ttx> just checking what would make sense
20:51:54 <jeblair> ++
20:51:55 <ttx> #action ttx to propose governance change to match, if any
20:52:09 <ttx> Anything else on that topic ?
20:52:16 <ttx> Or on making our meeting generally more efficient ?
20:52:52 <ttx> #topic Open discussion: itches to scratch
20:53:01 <ttx> As you know, I'd like the TC to be involved beyond setting governance and housekeeping projects list
20:53:11 <ttx> I'd like TC members to dive into specific community problems. We can't expect every TC member to know all the issues
20:53:19 <ttx> but we should be able to expect every TC member to be able to dive into a specific issue and report back to the group
20:53:28 <ttx> So we should identify issues and create small groups of interested people to address them.
20:53:40 <ttx> Doesn't have to be "all TC members" involved in every initiative, the subgroups would just report on their findings and the steps they followed
20:53:42 <jaypipes> ++
20:53:50 <annegentle> subgroups ++
20:53:51 <ttx> As an example... Personally I think we need to better document the culture, what is expected of an OpenStack project team
20:53:52 <jaypipes> that's what the working groups ideas are all about.
20:53:53 * jgriffith likes the idea alot
20:54:04 <ttx> Currently we rely on old wiki articles to explain how meetings should be held, what a PTL duties are, how to release stuff, what is acceptable in a stable branch, etc
20:54:15 <flaper87> ttx: that first example is something that I definitely want to tackle
20:54:16 <ttx> For a newcomer project there is no practical way to discover all that stuff. And yet we expect them to "behave like an OpenStack project"
20:54:26 <ttx> So I think we need to produce a "OpenStack project team guide", and I'd like to lead that
20:54:32 <ttx> Join my subgroup!
20:54:37 <flaper87> ttx: cound me in
20:54:39 <ttx> Any pet project / issue YOU would like to help solving ?
20:54:39 * jeblair joins ttx's subgroup
20:54:40 <flaper87> count
20:54:43 * dhellmann takes one step forward
20:54:46 <annegentle> Comms!
20:55:00 * annegentle recruits dhellmann
20:55:02 <ttx> flaper87: you will soon learn not to volunteer for everything :)
20:55:17 <anteaya> ttx: dhellmann wrote most of this as a starting point: http://docs.openstack.org/infra/manual/creators.html
20:55:18 <ttx> Other idea, I'd love people looking into specific projects and report dysfunction / culture divergence there
20:55:40 <sdague> I wanted to socialize the compute kernel tag I posted, which came after the deadline this, week, but I expect to create some vibrant discussions
20:55:40 <annegentle> ttx: hm
20:55:42 <flaper87> ttx: hahaha, everyone tells me that :D
20:55:45 <sdague> https://review.openstack.org/#/c/180112/
20:55:53 <dhellmann> how do people feel about the cross-project specs repo? we have quite a few specs up for review in a repo we nominally manage: https://review.openstack.org/#/q/project:openstack%2Fopenstack-specs+is:open,n,z
20:56:06 <dhellmann> annegentle: count me
20:56:34 <ttx> #info jeblair, flaper87, dhellmann and ttx to start workign on a project team guide to replace wiki and oral tradition
20:56:42 <jeblair> sdague: thank you for doing that
20:56:53 <dhellmann> sdague: did that come out of the ops meetup?
20:57:04 <sdague> dhellmann: the demand for it did
20:57:04 <flaper87> I think another good subgroup would be helping with OPs issues. Syncing more often and bringing back feedback/issues/etc
20:57:05 <ttx> dhellmann: so that is a good topic. What to do with cross-project specs and meeting
20:57:20 <dhellmann> sdague: good
20:57:22 <ttx> dhellmann: I wouldn't describe the ones we had in Kilo as a full success
20:57:30 <ttx> and I'd gladly defer that to a subgroup
20:57:40 <ttx> (if only becaus ethat meetign is at 11pm)
20:57:46 <markmcclain> ttx: I do like the idea of working with projects to identify areas for improvement and encourage best practices… wondering how the PTLs will accept us parachuting in and telling what's wrong or should we use tagging to identify the projects that self-selection for evaluation?
20:58:21 <ttx> markmcclain: I think we are in our role when we point out where they no longer behave like "one of us"
20:58:31 <sdague> markmcclain: I think with all such things, it's going to need to be some bottom up heavy lifting as well
20:58:32 <dhellmann> ttx: yeah, I'm not sure that meeting is the best way to handle them, but I don't have a better idea, yet
20:58:35 <ttx> since that is what we now judge for inclusion in the bigtent
20:59:07 <ttx> markmcclain: part of it is also to expose issues that everyone knows and discuss them in the open
20:59:21 <annegentle> markmcclain: yeah that summarizes my hm... feels a little like a policing thing?
20:59:25 <ttx> rather than only after hours ranting drown in beers
20:59:37 <annegentle> ttx: but yeah, get issues in the open safely
20:59:52 <ttx> annegentle, markmcclain: agree it's a touchy subject
21:00:12 <ttx> Also maybe premature if we don't have the "here is how to do it" doc
21:00:26 <ttx> anyway, time is up
21:00:31 <flaper87> o/
21:00:32 <NobodyCam> thank you
21:00:32 <ttx> Anything else, anyone ?
21:00:39 <markmcclain> I think cleaning up our docs and maybe find a few friendly projects to test what the process would look like
21:00:54 <jeblair> ttx: thanks!
21:00:56 <flaper87> markmcclain: you'd need diverse projects though
21:00:58 <annegentle> thanks ttx
21:01:02 <ttx> #endmeeting