20:01:47 <ttx> #startmeeting tc
20:01:48 <openstack> Meeting started Tue Sep 29 20:01:47 2015 UTC and is due to finish in 60 minutes. The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:01:49 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:01:52 <openstack> The meeting name has been set to 'tc'
20:01:56 <ttx> Our (busy) agenda for today:
20:02:01 <ttx> #link https://wiki.openstack.org/wiki/Meetings/TechnicalCommittee
20:02:05 * ruagair lurks
20:02:09 <ttx> I reorganized it a bit so that easier topics can be cleared fast
20:02:17 <ttx> and because the Kosmos decision might affect other decisions
20:02:24 <ttx> #topic Adds OpenStack UX core reviewers to extra-atcs
20:02:29 <ttx> #link https://review.openstack.org/224923
20:02:34 <ttx> 4 names proposed, all Foundation members.
20:02:45 <ttx> Piet, Eric and Ju Lim are actually already ATCs for their contribution to other projects
20:03:02 <ttx> still missing a few votes
20:03:04 <ttx> objections?
20:03:09 <anteaya> ttx I put them in the patch because I couldn't confirm that when I wrote it
20:03:20 <Piet> This is really about Michael Hinnant who doesn't have ATC status. However, he has been very active providing reviews.
20:03:33 <sdague> none that I see, I think we should just let votes accumulate and move on
20:03:44 <ttx> ok, will approve when it reaches 7
20:03:45 <russellb> ttx: has 7 now
20:03:49 <anteaya> can they still be added to the tc election roll?
20:03:54 <ttx> alright then, approved
20:04:00 <Piet> Sweet!
20:04:04 <ttx> anteaya: no, we tagged it
20:04:09 <anteaya> okay thanks
20:04:20 <ttx> #topic Formal vulnerability:managed application criteria
20:04:24 <ttx> #link https://review.openstack.org/226869
20:04:30 <ttx> The previous version of this was basically saying "whatever the VMT is comfortable with"
20:04:38 <ttx> This version is just them actually detailing what they are comfortable with, so ++
20:04:55 <dhellmann> ++
20:04:58 * dhellmann likes that we are writing things down
20:05:10 <ttx> objections ? Otherwise will approve when it reaches 7 votes
20:05:12 <annegentle> me too
20:05:13 <dtroyer> ++
20:05:15 <sdague> yep, this seems pretty concrete
20:05:42 <russellb> has 5 so far..
20:05:53 <ttx> lets move on, will approve async
20:05:59 <ttx> #topic Add new project Kosmos
20:06:06 <ttx> #link https://review.openstack.org/223674
20:06:13 <ttx> Last week we deferred the decision on this one
20:06:24 <ttx> since it may affect the decision on latter topics I moved it up
20:06:25 * russellb is fine with it, but would rather be approving with clear consensus
20:06:31 <ttx> The project and the project teams are sane, the question is more whether we should generally require "some" work to be done before approving project teams
20:06:37 <ttx> We generally require that of completely-new project teams (see for example kiloeyes)
20:06:41 <sdague> personally I'm fine with this, however I don't think we should force it if people are against it
20:06:43 <russellb> and there doesn't seem to be clear consensus, so i'm also happy saying "go do your thing for a bit first"
20:06:44 <ttx> We didn't require it for the packaging initiatives (packaging-deb, packaging-rpm...), though
20:06:44 <dhellmann> I'm on the fence, but leaning to the side of waiting to see what's actually produced so we don't set a bad precedent
20:06:48 <dtroyer> I think we should no matter the team makeup
20:06:55 <ttx> I'm generally leaning towards requiring "some" work to be present -- it makes judging "are you one of us" a lot straightforward
20:07:00 <dtroyer> the project also needs to prove itself
20:07:02 <ttx> but then should we kick out packaging-deb which do not even have their repositories set up yet ?
20:07:06 <mordred> I do not think we need to require "Some" work myself
20:07:08 <lifeless> so we've set objective criteria up
20:07:10 <ttx> what about packaging-rpm, with its grand total of 4 commits ?
20:07:18 <russellb> ttx: that was probably premature, then
20:07:19 <mordred> but I do not feel so strongly about it to argue vehemently
20:07:37 <dtroyer> me either, but you know, consistency
20:07:42 <lifeless> but we've pushed back on some projects because of lack of evidence of meeting the criteria - it just feels really weird to me that we'd not be consistent about that
20:07:51 * mordred does not care about consistency or a set of rules we published
20:07:53 <russellb> if we go the "needs some work done first", that's fine, i can take the action to propose a guidelines update to make that more clear
20:07:54 <sdague> at this point it's only expensive to add things if it's expensive to delete them
20:07:56 * mordred cares about our judgement as humans
20:07:57 <jeblair> if packaging-* doesn't have anything to show in a cycle or two, we can remove them :)
20:07:58 <ttx> I think one difference now is that theer is no issue in proving yourself in openstack/* repositories without being official just yet
20:08:03 <markmcclain> I like the project and contribs, but seems there should be some kind of digital trail
20:08:20 * mordred considers our guidelines to be guidelines and that we are humans and can decide to accept or not accept a set of humans should we choose
20:08:22 <fungi> note that at last check, the deb packaging repos don't even exist yet
20:08:23 <ttx> so there is no cost in starting the project out of the governance
20:08:24 <lifeless> mordred: I care about our judgement as humans - but I also care about what we're communicating to the other humans involved
20:08:33 <annegentle> mordred: but unfortunately that line of thinking means that we are a clique and the cool kids have to do nothing to get in
20:08:45 <mordred> lifeless: I agree - but I think we can massage our guidelines - I want to make sure we do not become a slave to them
20:08:56 <dhellmann> mordred: I would like for us to make sure we're not establishing a clique culture, where we accept any project from "people we know" and put newcomers through some sort of acceptance test -- it's a low enough bar to say, "run for a couple of months and let's see"
20:08:56 <ttx> Looks like most people are fine waiting, and some people object to approviung. We should therefore delay
20:08:58 <jeblair> annegentle: i consistently vote to add new projects with no history :)
20:09:00 <markmcclain> yeah.. concerned we've never expressed the standard
20:09:06 <jgriffith> annegentle: +1
20:09:16 <sdague> annegentle: is it that? or is it that proven members of the community have some trust which should be portable?
20:09:17 <dtroyer> mordred: we're not a slave, we still have the judgement call of 'how much' needs to be there.. I think it is >0
20:09:19 <mordred> annegentle, dhellmann: I think the only thing left that defines us as people is that the people are part of our set of people
20:09:23 <lifeless> mordred: sure. So - the first thing is that http://governance.openstack.org/reference/new-projects-requirements.html doesn't talk about guidelines
20:09:36 <annegentle> sdague: as a minority in this community I have to state what it looks like to me
20:09:44 <annegentle> sdague: I like trust, I also like earned trust
20:09:46 <ttx> Anyone strongly objecting to delaying until there is something set up ?
20:09:48 <jgriffith> I'm +1 on it, my only thought is going forward keep in mind the criteria used here and in other places
20:09:52 <dhellmann> mordred: sure, but this is as much about appearances as anything. I can't imagine we'll come back in a month and say no to this team.
20:10:08 <mordred> which is to say - I my vote is to be permissive in this case, but I understand and respect the alternate opinion
20:10:11 <ttx> there seems to be more people objecting to approving it, than people objecting to delay it
20:10:25 <lifeless> I'd be happy to appprove if we go back to the folk we pushed back on and approve them, as they were no less conformant
20:10:29 <sdague> for the record, I do not object to a delay
20:10:36 <jeblair> my vote is to include but that's because i _want_ to establish a culture where people start new projects and do them right and fully integrated from the start.
20:10:38 <sdague> but I'd be fine moving forward
20:10:39 <anteaya> annegentle: well said
20:10:45 <annegentle> I think you can definitely approve it even with my no vote, right? Just voicing what I needed to say.
20:10:52 <sdague> jeblair: ++
20:10:53 <mordred> jeblair: ++
20:10:56 <dhellmann> jeblair: fair point
20:11:05 <mordred> jeblair: that is what I was trying and failing to say
20:11:07 <lifeless> jeblair: can they not do that without our blessing?
20:11:09 <edleafe> jeblair: yes~
20:11:25 <lifeless> jeblair: like, what is held back from not-yet-in-governance projects these days?
20:11:55 <fungi> now that applying to governance later doesn't imply a git repo rename, it's possible the interest in starting teh project first and then applying will increase
20:12:00 <mordred> lifeless: voting
20:12:01 <jeblair> lifeless: services on openstack.org like docs hosting, and some amount of attention and care from other cross-project teams.
20:12:07 <ttx> sigh, feels like it's when people don't have strong optionions that it's the most difficult to come to a conclusion
20:12:09 <mordred> lifeless: and that
20:12:16 <ttx> opinions*
20:12:26 <dougwig> ttx: lol
20:12:31 <russellb> heh
20:12:36 <sdague> so, while we have a voting mechanism, we also aim to be concensus based
20:12:45 <ttx> quick check -- who strongly objects to delaying ?
20:12:47 <sdague> no concensus means we should delay
20:12:52 <ttx> and who strongly objects to approving ?
20:13:09 <jeblair> lifeless: like if you want to run ruby on java in your docker, i'm not going to care for a stackforge project, but i'm going to hold openstack projects to a higher standard in terms of ci construction
20:13:10 <ttx> I don't really care either way. Slight preference for delaying.
20:13:19 <russellb> sdague: +1 ... ideally with a guidelines followup that clarifies "do at least some work first", which i don't mind adding
20:13:30 <sdague> it would be good if one or more of the folks that are pro delaying write those guidelines
20:13:32 <sdague> or russellb :)
20:13:48 <markmcclain> russellb: +1
20:13:52 <lifeless> russellb: please do
20:14:03 <markmcclain> I'm happy to work on the guidelines
20:14:03 <russellb> it'll just be a sentence or 2 to http://governance.openstack.org/reference/new-projects-requirements.html
20:14:11 <SpamapS> A counter argument to "do at least some work first" is that it's possible corporate sponsors may want a project team to receive TC blessing before starting on a large endeavor.
20:14:13 <ttx> So the ONE reason why I prefer to delay is: we'd accept the cool kids and delay the people we don't know and ask them to prove themselves first.
20:14:14 <sdague> anyway, it seems like folks that are pro delay probably can best describe what makes them uncomfortable with moving this forward as is
20:14:32 <annegentle> my thinking is we have no evidence of "basic interop" or contributions
20:14:36 <ttx> I think it's simpler to require everyone shows something
20:14:37 <dougwig> SpamapS: fyi, not an issue in this case.
20:14:37 <annegentle> nothing measurable yet
20:14:43 <annegentle> right, just show us something
20:14:51 <russellb> i actually don't care much, but i'm happy doing the guidelines if that helps get us to better consensus
20:15:00 <sdague> russellb: thanks
20:15:11 <russellb> but is it just going to have 5 -1s "we shouldn't have to wait" ?
20:15:14 <jgriffith> I feel strongly that governance should not impact interest/desire to work on the project, I also feel strongly that we should embrace our concept of inclusion
20:15:14 <annegentle> thanks russellb
20:15:16 <russellb> if so, that doesn't really get us anywhere
20:15:21 <ttx> OK, let's delay and have a general rule from now on that the project is started before applying
20:15:22 <jgriffith> In other words, what's the point of wating?
20:15:23 <lifeless> SpamapS: with big tent, if we're doing that, we've gotten the engagement model very wonky
20:15:26 <jgriffith> It succeeds or it doesn't
20:15:49 <annegentle> russellb: so how do I know that the last three bullets are met with Kosmos?
20:15:52 <jgriffith> It has little impact on the TC either way after we get through the process of approving no?
20:15:53 <lifeless> jgriffith: so why did we ask monasca to wait?
20:15:57 <sdague> russellb: well, I'd give it a shot
20:16:04 <russellb> ok, will do
20:16:09 <SpamapS> lifeless: I agree 100% with your statement.
20:16:12 <dtroyer> I don' tthink requiring even a small history doesn't embrace inclusion, as annegentle said, without it the only history we have is personal history and that doesn't reflect what _that_ proiject might do in the future
20:16:14 <ttx> annegentle: we annegentle ssume they will based on what we know of the team members, which very much feels like a bias
20:16:22 <ttx> weird tab completion there
20:16:23 <jeblair> ttx: don't we need someone with a +1 to revoke it in order for the motion to fail?
20:16:25 <annegentle> ttx: right
20:16:30 <annegentle> ha
20:16:57 <markmcclain> dtroyer: right.. we've had other proposed projects that wandered off in teh wrong direction after organizing
20:16:58 <ttx> jeblair: formally yes, which is why I'd like people to agree on the direction
20:17:08 <sdague> jeblair: procedurally can't ttx just table it
20:17:09 * jgriffith lifeless they weren't in the cool-kids club
20:17:09 <edleafe> lifeless: well, they had a definite not-one-of-us history
20:17:21 <jeblair> sdague: that sounds awfully like a veto
20:17:21 <ttx> I can table it like swe did others
20:17:23 <SpamapS> Feels weird to say there's no history available. There's a team somewhere that came up with the idea, and some other team that agrees with the idea. And that sounds like a short history of collaboration between orgs?
20:17:29 <sdague> yeh, I do think monasca was actually the inverse here
20:17:38 <sdague> lots of commit history, very little community history
20:17:42 <ttx> jeblair: the resolution is still valid, just the timing is bad ?
20:17:55 <ttx> rather than rejecting those we have been generally tabling them
20:18:32 <lifeless> edleafe: collaboration with what, 3 different contributing organisations
20:18:43 <dtroyer> ttx: I think that is the right approach.
20:18:57 <markmcclain> SpamapS: group based policy is an example that started the same with known people/team, but ended up in a place that would be hard for inclusion at this point
20:19:00 <lifeless> edleafe: resulted from community discussions at summits...
20:19:04 <edleafe> lifeless: I meant the closed meetings, java codebase, etc
20:19:07 <ttx> If we were to call for a final vote now it would pass, based on current votes
20:19:13 <dtroyer> frankly I liked seeing the application right off, it shows intent and makes the history a shorter peocess in my mind anyway
20:19:25 <dhellmann> dtroyer: ++
20:19:34 <sdague> anyway, I think we agreed on a path forward right
20:19:40 <sdague> 1) delay
20:19:48 <sdague> 2) write up new guidelines on what is expected
20:19:56 <ttx> sdague: jeblair objects and calls for a final vote
20:19:58 <annegentle> I've registered my concerns with the perception and I feel heard. That's how voting works, I think.
20:20:05 <edleafe> I think the hesitation is because removing is not so easy if they don't meet expectations
20:20:26 <sdague> jeblair: is that what's happening?
20:20:39 <ttx> If he does I'm hapopy to call for final vote now
20:20:43 <jeblair> i didn't think that was what i was doing -- i just thought we voted on things. :)
20:20:47 <ttx> or happy even
20:20:48 <russellb> if it goes in, can we still update guidelines to say "we encourage early application" ?
20:21:05 <dtroyer> russellb: yes please
20:21:06 <russellb> let's update guidelines either way, basically :)
20:21:11 <sdague> ok, I guess I'm just confused. How about we #vote on plan listed above
20:21:19 <dtroyer> with whatever history expectations we wind up with
20:21:20 <sdague> delay 1 month and have new guidelines
20:21:34 <dhellmann> I don't understand the issue, we table things for more discussion all the time
20:21:51 <ttx> #startvote Should we delay the vote until the project is set up ? yes, no, abstain
20:21:52 <openstack> Begin voting on: Should we delay the vote until the project is set up ? Valid vote options are yes, no, abstain.
20:21:53 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
20:21:54 <russellb> i'd say we should expect a few months of project history (roughly), or we accept this and say we encourage early application like this
20:22:00 <sdague> #vote yes
20:22:01 <ttx> #vote yes
20:22:02 <dhellmann> #vote yes
20:22:04 <jeblair> #vote yes
20:22:09 <russellb> #vote yes
20:22:20 <dtroyer> #vote yes
20:22:20 <ttx> jeblair: feels less like a veto that way I guess
20:22:26 <markmcclain> #vote yes
20:22:30 <jeblair> ttx: yes :)
20:22:38 <ttx> sdague: thx :)
20:22:40 <annegentle> #vote yes
20:22:47 <ttx> closing in 10 seconds
20:22:53 <mordred> #vote yes
20:22:57 <ttx> #endvote
20:22:58 <jgriffith> #vote no
20:22:58 <openstack> Voted on "Should we delay the vote until the project is set up ?" Results are
20:22:59 <openstack> yes (9): ttx, annegentle, jeblair, russellb, sdague, mordred, dhellmann, dtroyer, markmcclain
20:23:05 <ttx> dammit john
20:23:06 <russellb> jgriffith: just missed it.
20:23:12 <annegentle> aw
20:23:12 <jgriffith> Oh well
20:23:18 <sdague> it will be in the minutes
20:23:22 <russellb> :)
20:23:24 <ttx> #agreed delay the vote until the project is set up
20:23:24 <sdague> and it doesn't impact the actual vote
20:23:30 <ttx> sdague: agreed
20:23:34 <jgriffith> Obviously doesn't matter anyway
20:23:36 <lifeless> #vote yes
20:23:37 <ttx> let's move on
20:23:40 <lifeless> blink and you mis it
20:23:48 <ttx> #topic Add Juju Charms for Ubuntu to OpenStack
20:24:02 <ttx> So the decision on Kosmos kind of sets a precedent here
20:24:04 <russellb> same situation?
20:24:06 <dougwig> the wording of that is odd, since it is setup/created/cookiecutter/irc/etc, so please clarify what it means. i'll assume "show me some code". sdague, 1 month is likely too short in this case, due to it being summit month.
20:24:07 <ttx> This is imho comparable to other packaging efforts we have in the big tent
20:24:12 <ttx> There are no existing repositories though, so we could kosmos this one
20:24:18 <russellb> dougwig: i was thinking "a few months"
20:24:19 <sdague> is it the same situation? I thought they had a ton of code
20:24:23 <annegentle> ttx: verbed a noun
20:24:28 <russellb> sdague: doing it in openstack though?
20:24:32 <dougwig> russellb: agree
20:24:34 <ttx> annegentle: is that dirty ?
20:24:39 <annegentle> nah just funny to me
20:24:41 <annegentle> :)
20:24:47 <sdague> russellb: ok, so is it a delay until there is a project-config import?
20:24:47 <russellb> dougwig: but we'll have a review following up on this agreeing on some rough guideline
20:24:51 <lifeless> thre's a weird thing
20:25:00 <lifeless> the commit message makes me think its not open
20:25:01 <ttx> The only original thing is the integration testing being done on Canonical infrastructure
20:25:03 <dhellmann> I noticed the GPL mentioned here, does that present any issues since this isn't part of the actual applications?
20:25:26 <lifeless> " the core reviewers on
20:25:26 <lifeless> each repository may be derived from the company developing the charm."
20:25:34 <lifeless> maybe I'm reading that wonky
20:25:37 <dhellmann> yeah, that also struck me as odd
20:25:44 <lifeless> but it sounds like a company-lock-on-the-repo
20:25:50 <lifeless> jamespage: ^ ?
20:25:57 <sdague> oh, hey, I guess I missed that bit
20:26:04 <russellb> "Charms are currently licensed under GPL v3."
20:26:15 <fungi> perhaps the "may be derived from" is not definitive and merely a starting point
20:26:33 <ttx> How about we table it since there is nothing yet -- and ask for clarification in the mean time ?
20:26:34 <dhellmann> russellb: yeah, that's what I meant -- is that a problem since the charm code isn't part of the applications we deliver that have to be apache 2?
20:26:41 <lifeless> the GPL v3 is ok per our governance doc requirements - though its definitely unusual
20:26:47 <russellb> dhellmann: our guidelines just say we prefer apache 2
20:26:53 <russellb> dhellmann: just require "an open source license"
20:27:02 <dhellmann> russellb: the bylaws are more specific, aren't they?
20:27:04 <russellb> i'd certainly *prefer* apache 2 ...
20:27:04 <sdague> right, so that seems fine
20:27:08 <russellb> dhellmann: good question
20:27:21 <dhellmann> though those only apply to trademarked code, iiuc, which is why I pointed out this is not application code
20:27:22 <sdague> I thought the bylaws changed on that fron
20:27:24 <ttx> How about we table it since there is nothing yet -- and ask for clarification in the mean time ?
20:27:36 <dtroyer> ++
20:27:38 <lifeless> +1 on tabling, I'll raise my questions on the review
20:27:53 <lifeless> fungi: you're likely right, but if so why mention it at all?
20:27:58 <dhellmann> article VII in https://www.openstack.org/legal/bylaws-of-the-openstack-foundation/
20:28:06 <ttx> The bit on ntegration testing being done on Canonical infrastructure is also making my openness radar buzz
20:28:10 <dhellmann> sdague: did they?
20:28:12 <jeblair> lifeless, fungi: agreed -- likely overspecification but good to double check
20:28:32 <lifeless> fungi: just say 'initial core reviewers will be the folk that create each charm' or something
20:28:38 <fungi> yep
20:28:41 <dhellmann> 7.1.b seems to only apply to the tc-approved-release, so I think we're ok, I just wanted to get confirmation
20:28:46 <jeblair> ttx: i wonder if there is a technical reason they can't do it upstream?
20:28:46 <lifeless> fungi: *company* is a very odd thing here :)
20:28:47 <EmilienM> fwiw, we asked fuel to collaborate with os-infra, we probably might want to do the same with charms.
20:28:52 <dhellmann> ttx: third-party ci?
20:29:10 <lifeless> jeblair: its all part of OIL
20:29:12 <ttx> jeblair, dhellmann: sure, I just want to make sure that's a technical reason
20:29:15 <jeblair> ttx: also, it is worth noting that despite being one of the earliest third-party ci operators, they've never been good about reporting upstream...
20:29:33 <lifeless> jeblair: their proprietary 'openstack interoperability lab' that they sell testing-on-and-via to companies
20:29:41 <jeblair> dhellmann, ttx: so i would not even assume that text means "we will report our local testing upstream"
20:29:58 <russellb> https://www.openstack.org/legal/bylaws-of-the-openstack-foundation/ "INTELLECTUAL PROPERTY POLICY" mentions Apache 2 quite specifically
20:30:03 <sdague> I guess that's a good point for clarification
20:30:05 <russellb> but i need a bit more time to parse it in pedantic mode
20:30:08 <jeblair> lifeless: yeah, concerning.
20:30:09 <ttx> ok, I think we have a path forward here
20:30:09 <lifeless> jeblair: its very much bare metal based, and upstream infra have no baremetal facilities today AIUI - including baremetal routers etc
20:30:25 <dhellmann> jeblair: fair
20:30:40 <mordred> lifeless: that may be true - but I thnk a good faith effort to come up wiht a workable infra soluiton would be nice
20:30:43 <lifeless> jeblair: so AIUI, at least some of the charms aren't able to be exercised in a virtual environment
20:30:58 <ttx> #agreed Juju charms application delayed until there is something substantial in the repositories (they can be set up without being "official" now). We'll clarify other specific points in the mean time
20:30:58 <annegentle> I was still parsing the OIL acronym
20:30:59 <annegentle> :)
20:31:09 <russellb> it says we distributed the "approved release" under the apache license. it also says we accept contributions with an agreemen that lets us redistribute under the apache license.
20:31:11 <EmilienM> the least we can ask is a third party CI where all logs and access are open
20:31:15 <lifeless> mordred: / jeblair: / fungi: has Canonical discussed that with infra?
20:31:22 <fungi> lifeless: not to my knowledge
20:31:27 <dhellmann> annegentle: what did you get? :-)
20:31:29 <mordred> lifeless: no. there has never been any attempt at ocooperation
20:31:31 <ttx> Moving on...
20:31:38 <annegentle> OIL=OpenStack Interop Lab
20:31:58 <ttx> #topic CloudKitty application for Big Tent
20:32:00 <dhellmann> annegentle: thanks
20:32:03 <fungi> russellb: yes, the cla may not be sane for gpl projects?
20:32:11 <lifeless> dhellmann: I expanded it on my next line :)
20:32:12 <ttx> #link https://review.openstack.org/225201
20:32:15 <jeblair> annegentle: of course we have the Wide Area Testing and Experimental Reporting project
20:32:23 <dhellmann> lifeless: ah, missed that
20:32:37 <ttx> OK, so CloudKitty. This feels rather straightforward big-tent to me
20:32:43 <annegentle> jeblair: may they ever mix
20:32:44 <ttx> the project has been around for a while in the OpenStack community and is even used in production somewhere
20:32:54 <russellb> ttx: ++
20:33:15 <annegentle> ttx: yep agreed
20:33:16 <ttx> objections, questions ?
20:33:22 <ttx> I think we have the PTL around
20:33:29 <russellb> fungi: yeah ... and it may just mean that this could never be part of the "TC approved release", which is probably fine
20:33:32 <sheeprine> Yes, I'm here.
20:33:41 <ttx> sheeprine: o/ welcome
20:34:06 <jeblair> how could you say no to something called CloudKitty?
20:34:08 <ttx> one more approval and it's in
20:34:11 <jeblair> with big eyes like that?
20:34:22 <russellb> sheeprine: i request a cute kitten logo
20:34:28 <ttx> jeblair: the name fails annegentle guidelines with capitalization :)
20:34:38 <lifeless> +1 fro me on the spec
20:34:40 <annegentle> ttx: lol oh so true
20:34:45 <jeblair> annegentle kicks kittens!
20:34:45 <maishsk> :)
20:34:53 <ttx> ok, we have a winner, approving now
20:34:55 <markmcclain> ttx: we're at 9
20:35:01 <russellb> welcome, cloudkitty!
20:35:03 <russellb> meow.
20:35:06 <annegentle> cloudkitty!
20:35:10 <ttx> kitty kitty
20:35:19 <annegentle> now go change the capitalization
20:35:23 <sheeprine> thanks
20:35:23 * dhellmann wants a mascot sticker at the summit
20:35:32 <sheeprine> I'll work on the capitalization.
20:35:37 * ttx continues to rush through the busy agenda
20:35:39 <russellb> after you make stickers
20:35:45 <ttx> #topic Remove MagnetoDB from OpenStack
20:35:52 <sheeprine> We've got stickers and more for the summit ;)
20:35:55 <ttx> #link https://review.openstack.org/224743
20:35:58 <dhellmann> sheeprine: \o/
20:36:01 <ttx> We discussed this one last week
20:36:08 <ttx> There is general agreement that we should remove MagnetoDB, we just disagreed on how to encode that in the governance repository
20:36:17 <ttx> Not much progress or proposals on the review this week
20:36:25 <ttx> Should we just have a retired-teams.yaml and move the entries there, with some timestamp to account for expiration of entries after the ATC delay ?
20:36:36 <dhellmann> ++
20:36:44 <russellb> it'd be good book keeping, i think
20:36:52 <dtroyer> ++ it fits with the rest of our dont-delete-history
20:36:52 <dhellmann> I'll propose that if folks want
20:36:57 <sdague> retired-teams.yaml sounds good to me
20:36:59 <russellb> dhellmann: thanks!
20:37:00 <ttx> +1
20:37:12 <ttx> if you do it while we continue the meeting we could even approve it :)
20:37:20 * dhellmann starts typing
20:37:25 <sdague> or projects-emeritus.yaml :)
20:37:28 <jeblair> i mean, i'd love it if git were the history, but i'm okay with retired-teams until our schema stabilizes
20:37:54 <annegentle> attic? /me stops naming things
20:38:00 <ttx> jeblair: yeah, that was my original thinking, but people got worried
20:38:12 <jeblair> (to bikeshed, it really ought to have a name relation to projects.yaml though)
20:38:15 <annegentle> I mean, do we still move code to the attic if a team retires?
20:38:19 <russellb> the worry was about tooling around calculating ATC status wasn't it?
20:38:23 <russellb> not sure it's a real problem in this case
20:38:25 <ttx> ok, let's move on while dhellmann types, and come back to it in a few
20:38:30 <russellb> but could be eventually *shrug*
20:38:33 <jeblair> russellb: yep
20:38:40 <ttx> #topic Cross-project track at Mitaka design summit: status update
20:38:50 <ttx> Flavio set October 9th for the deadline to propose things at http://odsreg.openstack.org/
20:38:57 <sdague> right, in this case it potentially impacted 1 atc, but I could imagine there being more
20:39:06 <ttx> We have 17 proposals there, not sure if all the etherpad was copied or not
20:39:22 <ttx> Ideally the cross-project workgroup volunteers would do the heavy lifting between the 9th and the 13th, so that we have somethign to discuss and approve at the Oct 13th TC meeting
20:39:31 <ttx> And move to scheduling quickly afterwards
20:39:43 <ttx> Does that sound like a plan ? Probably means a quick meeting on the Monday
20:39:55 <ttx> of the cross-project track volunteers
20:40:09 <sdague> damn you flaper87 for closing it on a friday instead of a thursday
20:40:17 <ttx> sdague: I know, right
20:40:19 <anteaya> dates are important
20:40:40 <sdague> I think more importantly, are there topics we feel need to be addressed that aren't getting proposed
20:41:09 <lifeless> I can do monday
20:41:15 <dhellmann> ttx: updated
20:41:23 <lifeless> sdague: ITYM wednesday, since a meeting on your friday is my saturday :)
20:41:55 <sdague> :)
20:42:00 <ttx> everyone: please review https://review.openstack.org/#/c/224743/
20:42:44 <dhellmann> I'm happy to bikeshed the "retired-on" field in a separate patch
20:42:51 <ttx> we'll go back to topic brainstorming at the end of the meeting in Open Discussion. We can also interpret the bylaws on GPLv3 then
20:43:12 <ttx> one more...
20:43:22 <sdague> it seems like a good time for every TC member to put their nickle down on a cross project issue they feel is getting neglected
20:43:47 <ttx> sdague: I filed one but I'll definitely give it another thought session
20:44:18 <ttx> ok, 7 votes, I can approve the MagnetoDB removal
20:44:28 <ttx> last call
20:44:35 <lifeless> sec
20:44:46 <lifeless> there
20:44:56 <fungi> i'll go ahead and force-merge the related retirement change in project-config
20:45:19 <dhellmann> fungi: that was the patch to delete all the code?
20:45:28 <fungi> yep. and i'll also abandon open changes
20:45:42 <fungi> we have some infra documentation (maybe already merged?) on returing repos now
20:45:43 <dhellmann> ok. I was a little surprised by that, but I guess it makes sense
20:45:54 <fungi> retiring too
20:46:07 <jeblair> dhellmann: we have had users not realize that they are using abandoned projects, so we are striving to make it more clear
20:46:08 <ttx> ok done
20:46:15 <annegentle> fungi: thanks for that
20:46:17 <ttx> #topic Communications workgroup report
20:46:20 <dhellmann> jeblair: this is certainly one way to do that :-)
20:46:26 <ttx> annegentle: anything to report ?
20:46:40 <annegentle> blog post done last week, have to admit I had missed 2 from the prior 2 weeks ago so it was chockful of info :)
20:47:26 <annegentle> do you think we should do one flaper87 to get cross-project summit proposals by 10/9?
20:47:44 <jeblair> annegentle: that sounds like a good idea
20:47:48 <ttx> that wouldn't hurt. But could wait next week meeting maybe
20:47:52 <sdague> it seems like getting one out this week to beat that drum would be good
20:47:53 <annegentle> #link http://www.openstack.org/blog/2015/09/technical-committee-highlights-september-25-2015/
20:48:01 <sdague> given that this friday is the 2nd
20:48:05 <dhellmann> ++
20:48:05 <annegentle> let's see the 9th is next Friday... hm
20:48:29 <annegentle> We did mention it at the end of that post ^^
20:48:38 <annegentle> so we're probably covered
20:48:45 <ttx> ok, then maybe wait and do a last reminder one next week ?
20:48:56 <ttx> with things approved today and next week ?
20:49:15 <annegentle> or tweet tweet?
20:49:42 <annegentle> where's my partner in crime flaper87? :)
20:50:00 <annegentle> I can see blogging by next Wed.
20:50:04 <ttx> we might raise a thread on the ML around TC candidates too
20:50:34 <ttx> ok, moving to open discussion since we are talkign about everything at the same time now
20:50:36 <ttx> #topic Open discussion
20:50:43 <ttx> Everyone: Tomorrow is the last day to submit your TC candidacy if you're interested in joining us
20:50:50 <ttx> Also there will be a joint TC/Board meeting in Tokyo on the Monday, starting at 2:30pm
20:50:56 <ttx> At 4:30pm we'll be joining the "Women of OpenStack networking event" (4:30pm - 7:30pm)
20:51:12 <ttx> mark your calendars if you're a member of running for election
20:51:16 <Piet> At some point, we need to chat about how surveys are distributed in the community. Not sure if this is the forum.
20:51:28 <ttx> Piet: probably not. We don't do surveys.
20:51:41 <Piet> ttx: k
20:51:46 <lifeless> ttx: I was going to do one on the devs
20:52:00 <lifeless> ttx: but I ran out of steam - there was lots of interest in it though
20:52:03 <ttx> lifeless: about terminal width ?
20:52:15 <lifeless> ttx: hah, no. I'll dig up a thread pointer for you
20:52:36 <lifeless> ttx: but - I was thinking that the foundation which already runs e.g. the user survey might be a good body to coordinate such things
20:52:45 <lifeless> ttx: do you know anyone there to chat with about that?
20:52:49 <annegentle> Piet: cross-project meeting though sounds right
20:52:50 <russellb> let's ask about editor preferences too
20:53:00 <lifeless> russellb: so actually that was one of the questions I was going to ask
20:53:10 <ttx> lifeless: I can relay the concerns to staff if we voice them
20:53:11 <lifeless> russellb: to put the .gitignore questions to bed
20:53:20 <russellb> but only have "vim" as a choice
20:53:37 <lifeless> ttx: so - the question is, is there someone at the foundation with the time to run a developer survey, if we put the questions together ?
20:53:37 <markmcclain> russellb: vim and "other" I like it
20:53:46 <ttx> in Piet's case maybe the "openstack-foundation" ML is the right forum
20:53:56 <Piet> annegentle: sounds good. I want to make sure that we are able to be responsive to the project teams. Adding a few questions to a bi-annual survey may not get us there.
20:54:07 <ttx> since most surveys are coming from the Foundation surveymonkey account
20:54:16 <annegentle> Piet: ttx is also right, surveys through Foundation
20:54:30 <anteaya> well part of it is that Piet doesn't have access to the fondation survey data
20:54:38 <anteaya> and would like to have some data
20:54:41 <Piet> annegentle: I'm pushing back on that assumption
20:54:46 <anteaya> if I understand correctly Piet
20:54:47 * ttx looks at Foundation bylaws and GPLv3
20:55:11 <lifeless> for clarity, Piet and I are talking totally different things :)
20:55:32 <sdague> yeh, so I swore there was something in Atlanta about it just needing to be open source
20:55:42 <sdague> however, I can't find it anywhere now
20:55:44 <Piet> We generally try to focus on small samples, but occasionally need to do surveys
20:55:54 <russellb> ttx: Article 7.1 in particular
20:55:57 <annegentle> Piet: lifeless: yes still sounds like surveys are cross-project and Foundation areas
20:55:57 <sdague> so maybe GPLv3 is a blocker
20:56:20 <Piet> And the foundation has not provided raw data
20:56:22 <annegentle> not something the TC mediates
20:56:25 <ttx> looks like a question for foundation legal
20:56:26 <russellb> 7.1 (b) sayd "TC approved release", so it would at a minimum mean something non-apache2 could never be in TC approved release
20:56:30 <lifeless> annegentle: so openstack-foundation is the place to ask ?
20:56:31 <russellb> 7.1 (a) is much less clear though
20:56:34 <russellb> ttx: ++
20:56:43 <sdague> right, in the TC approved release, that seems fine
20:56:44 <ttx> russellb: yeah, b is clear, a is lawyerese
20:57:05 <annegentle> lifeless: for your Q I would log a ticket in their system or ask directly on the openstack-foundation list
20:57:06 <sdague> but aren't there things in openstack-infra that are not apache2?
20:57:06 <ttx> "may adopt additional contributor license agreements as may be appropriate for certain organizations or contributions to secure a license on terms which will permit distribution under the Apache License 2.0" seriously
20:57:15 <russellb> yeahhhh
20:57:24 <russellb> "we use a cla, and whatever else want to ensure we can distribute under apache 2"
20:57:25 <russellb> i think..
20:57:31 <clarkb> sdague: I don't think so
20:57:34 <sdague> right, which is the whole CLA trump the world thing
20:57:37 <jeblair> sdague, russellb: i believe we have heard from the foundation's lawyer that things outside the release are gpl-okay
20:58:12 <sdague> speaking of which, have we heard recently about board / tc meeting agenda
20:58:18 <sdague> and the CLA vs. DCO thing
20:58:30 <russellb> this needs to be added to https://wiki.openstack.org/wiki/LegalIssuesFAQ
20:58:33 <ttx> sdague: I'm taking up suggestions for the BoD/TC meeting agenda :)
20:58:41 <lifeless> annegentle: 'their system' ?
20:58:42 <sdague> because I believe the last email statement around that was it would be voted on in Tokyo
20:58:53 <jeblair> ttx: it should be a standing agenda item :(
20:58:54 <sdague> ttx: ok, that's my first suggestion
20:59:03 <dhellmann> jeblair: ++
20:59:06 <dhellmann> sdague: ++
20:59:08 <annegentle> lifeless: they have a ticketing system for support requests, sorry I can't recall the email address. I use it for logo@openstack for example
20:59:12 <jeblair> sdague: agreed, that is my expectation
20:59:16 <ttx> I have no idea what the agenda of the Board part of the meeting is. Maybe mordred or russellb know
20:59:18 <annegentle> lifeless: might be info@openstack?
20:59:21 <russellb> no updates re: DCO
20:59:29 <sdague> o_O
20:59:29 <russellb> no updates available to me anyway
20:59:40 <sdague> russellb / mordred could you push on that?
20:59:41 <russellb> legal affairs committee kind of blocked it
20:59:50 <russellb> and insisted they needed a private lawyer only meeting to move forward
20:59:55 <cpallares> ttx: o/
21:00:01 <jeblair> https://wiki.openstack.org/wiki/Governance/Foundation/26Oct2015BoardMeeting
21:00:01 <russellb> in between last meeting and next one (tokyo)
21:00:01 <ttx> cpallares: o/
21:00:06 <russellb> but i don't know if that has happened ...
21:00:06 <jeblair> no agenda listed yet
21:00:17 <jeblair> or, very little of one
21:00:18 <markmcclain> russellb: really? disappointing
21:00:20 <ttx> ok, we are running out of time
21:00:34 <sdague> because, I'll be honest, if this isn't getting a floor vote in Tokyo, I'm not really sure why the TC is going to the board meeting
21:00:37 <cpallares> ttx: Can we discuss CoC next week?
21:00:45 <ttx> russellb, mordred: could you get an updated status on that ?
21:00:48 <russellb> sdague: i'm going into it expecting a vote
21:00:51 <cpallares> ttx: Should I come back for the next open discussion?
21:00:57 <mordred> ttx: can try
21:00:57 <sdague> as we've been asking about this for 3 cycles now
21:00:57 <ttx> cpallares: yes please
21:01:04 <russellb> that's what we left the last meeting with ...
21:01:12 <sdague> russellb: ok
21:01:12 * mordred agrees with russellb
21:01:12 <russellb> "let people get any last questions answered now, and we vote in tokyo"
21:01:16 <ttx> ok time is up
21:01:22 <ttx> #endmeeting