20:02:26 <ttx> #startmeeting tc
20:02:26 <openstack> Meeting started Tue Oct 13 20:02:26 2015 UTC and is due to finish in 60 minutes.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:02:28 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:02:30 <openstack> The meeting name has been set to 'tc'
20:02:33 <ttx> Our agenda for today:
20:02:38 <ttx> #link https://wiki.openstack.org/wiki/Meetings/TechnicalCommittee
20:02:44 <ruagair> o/
20:02:46 <ttx> #topic Welcome Mitaka membership
20:02:52 <ttx> Congrats to mestery on his election and the others on their reelection
20:02:59 <ttx> So we have a number of things to cover for the first meeting of a new membership
20:02:59 <mestery> thanks :)
20:02:59 <flaper87> w0000h00000! Welcome everyone
20:03:07 <annegentle> welcome mestery!
20:03:07 <markmcclain> welcome
20:03:07 <ttx> First is to approve the the new membership
20:03:08 * mestery ^5s flaper87
20:03:08 * mordred hands mestery a somewhat uneaten jar of pickles
20:03:12 <annegentle> thanks flaper87!
20:03:13 <ttx> #link https://review.openstack.org/#/c/233543/
20:03:15 * mestery weeps
20:03:23 <sdague> "somewhat"?
20:03:26 <ttx> was +1ed by election officials, so will approve now unless there is an objection
20:03:38 * sdague thinks there must be better snacks in this place
20:03:49 <sdague> ttx: do it
20:03:49 <annegentle> thank you jgriffith!
20:03:52 <lifeless> velkomm velkomm
20:04:02 <jgriffith> annegentle: It was na honor
20:04:06 <jgriffith> an even
20:04:06 <jgriffith> :)
20:04:13 <mordred> thanks jgriffith !
20:04:13 <ttx> alright approved
20:04:20 <ttx> Then we have to pick the committee chair
20:04:27 <jeblair> jgriffith: thank you!
20:04:28 <ttx> I'll be happy to serve again, I actually dropped the release management PTL seat to be able to spend even more time on the TC side
20:04:28 <sdague> yeh, thanks for all the fish jgriffith
20:04:36 <ttx> Anyone else interested ?
20:04:45 * sdague not it
20:04:50 <jgriffith> ha... I love that I get that reference :)
20:04:53 * dhellmann touches his nose
20:04:56 * mestery also not it
20:05:01 <ttx> If you'll have me, please approve https://review.openstack.org/#/c/234409/
20:05:05 * lifeless touches dhellmann's nose
20:05:07 * mordred is only aware of one crazy frenchman in the room, and is pretty sure that's a pre-req
20:05:11 <markmcclain> ttx: go for it
20:05:18 <annegentle> ttx: thank you thank you
20:05:18 * dhellmann smacks lifeless' hand
20:05:22 <ttx> I'll need 7 votes on that one for formal vote
20:05:31 <lifeless> dhellmann: thats not how it works?
20:05:32 <lifeless> :)
20:05:36 * flaper87 interested in voting for ttx to be chair
20:05:37 <russellb> +1
20:06:00 <ttx> ok, other administrativia
20:06:03 <ttx> Remember we are all invited to a joint BoD/TC meeting on Monday Oct 26, 2:30pm. I sent an email with details to the list
20:06:25 * flaper87 will be there
20:06:32 <annegentle> ttx: on it
20:06:33 * mestery marks his calendar
20:06:35 <sdague> ttx: and you are sure you aren't off by 30 minutes like last time :)
20:06:54 <ttx> thanks everyone for still wanting me for another round. Although I wonder if that's not an elaborate trick
20:07:06 <ttx> I'd like to spend a few minutes collecting topics that you want to discuss at that joint meeting
20:07:14 <ttx> AlanClark told me he has DCO and diversity work group update on the agenda already
20:07:23 <ttx> Anything else you'd like to cover there?
20:07:41 <lifeless> it might be nice to ask the board if they have anything they want from us
20:07:48 <mestery> lifeless: +1
20:07:48 <russellb> i asked for DCO to be discussed earlier (as well)
20:07:50 <ttx> sdague: it was an optimization based on past data!
20:07:51 <russellb> so that we can actually vote on it
20:08:08 <russellb> i posted to the foundation list about that, but no response on it ...
20:08:17 <sdague> russellb: thanks for posting that
20:08:23 <dhellmann> russellb: so no response at all?
20:08:25 <jeblair> russellb: yeah, we were expecting a vote in july, so we're _really_ expecting a vote in october.
20:08:26 <russellb> dhellmann: none
20:08:42 <ttx> russellb: Alan told me he has the DCO on the list of topics requested by the board
20:08:50 <ttx> maybe that's a yes ?
20:08:57 * flaper87 shrugs
20:08:59 <dhellmann> ttx: but if that's for the joint session, they won't be voting
20:08:59 <russellb> ttx: if it's in the joint meeting, the board can't vote on it
20:09:09 <ttx> oh, good point
20:09:15 <russellb> since that's after the official close of board meeting
20:09:26 <jeblair> and last i checked, it was not explicitly listed on the board agenda
20:09:35 <ttx> hmm, maybe it's just to tell us that the board adopted it in the morning ? /me is an optimistic person
20:09:40 <russellb> hope so
20:09:42 <fungi> sort of wondering if the legal affairs ctte call tomorrow is going to cover dco. might make sense for some of you to lurk?
20:09:45 <flaper87> I'd really like to see the DCO thing resolved this time\
20:09:48 <flaper87> ttx: yeah
20:09:54 <jeblair> oh
20:09:57 <jeblair> (10:40) Legal: ICLA/DCO - Eileen, Mark, Nissa
20:09:57 <russellb> fungi: yes, the timing was interesting, usually that's not public
20:10:02 <jeblair> that has appeared now
20:10:03 <shamail> I heard DCO is on the list too (board, not joint session)
20:10:08 <russellb> jeblair: oh great!
20:10:12 <sdague> jeblair: cool
20:10:20 <flaper87> nice
20:10:24 <ttx> jeblair: the "Legal" part doesn't seem to point to a vote but yet another exposé
20:10:31 <russellb> so then i think it's fair to expect a vote based on what i know
20:10:33 <ttx> but we can hope
20:10:36 * devananda sneaks in late, lurks in the back
20:10:38 <mordred> I agree with russellb
20:10:46 <mordred> I believe the intent is for a vote to happen
20:10:56 <flaper87> awesome
20:10:57 <jeblair> maybe it's "legal committee has come back with this thing to vote on"
20:11:04 <ttx> jeblair: maybe.
20:11:05 * jeblair speculated
20:11:17 <ttx> ok anyway, what else would you like to cover ?
20:11:17 * jeblair is also optimistic
20:11:18 <sdague> so with a vote, will us outsiders get to know who voted for what (roll call vote), or just outcome?
20:11:24 * Rockyg hand devananda a maitai
20:11:33 <russellb> sdague: you'll get to know, it's in the minutes
20:11:37 <sdague> russellb: cool
20:11:44 <russellb> though the minutes are usually approved in the *next* board meeting
20:11:47 <flaper87> I like lifeless' topic proposal
20:11:55 <fungi> sdague: also if you're around, totally show up and join the peanut gallery. i will
20:11:58 <ttx> mordred: if you want us to work on redefining / precising the openstack mission, it's likely to be something the board wants to know about
20:12:01 <russellb> fungi: indeed
20:12:10 <mordred> ttx: that's an excellent point
20:12:11 <clarkb> fungi: will there be room?
20:12:14 <sdague> ttx: yeh, good point
20:12:15 * mestery likes peanuts and will be there
20:12:21 <mordred> ttx: that would be a great topic to add to the joint meeting
20:12:29 <fungi> clarkb: i intend to make room, tokyo or no
20:12:33 <ttx> what is lifeless topic proposal ?
20:12:39 <clarkb> fungi: :) sounds like a plan
20:12:55 <ttx> #info proposed topic: expanding the openstack mission
20:13:04 <jeblair> mordred: have background on that?
20:13:19 <ttx> jeblair: mordred wants it to mention users
20:13:29 <mordred> jeblair: the tl;dr is that our mission currently says nothing about users or making clouds that work similarly
20:13:31 * jeblair assumes he missed a -dev email
20:13:39 <ttx> jeblair: not really
20:13:40 <flaper87> jeblair: the candidacy :D
20:13:44 <sdague> there was a bit of it in his TC candidacy
20:13:46 <mordred> it very much reads as a mission to make a toolkit that cloud providers can use to make clouds
20:13:47 <ttx> yep
20:13:51 <lifeless> ttx: 09:07 < lifeless> it might be nice to ask the board if they have anything they want from us
20:13:54 <lifeless> 09:07 < mestery> lifeless: +1
20:13:59 <jaypipes> sorry, I'm here...
20:14:11 <jeblair> ah, i recall that now.
20:14:18 <ttx> #info topic proposal: ask the board if they have anything they want from us
20:14:18 <sdague> so I think we should action mordred to have some writing words before the meeting
20:14:27 <russellb> sdague: +1
20:14:27 <mordred> I will make some writing words
20:14:29 <ttx> action mordred
20:14:31 <annegentle> mordred: yeah I was thinking how aged that seems now 5 years later
20:14:43 <anteaya> mordred is just an action
20:14:50 <sdague> in the past the "ask the board what they want from us" didn't turn into much
20:14:52 * mordred is an action
20:14:56 <ttx> OK. Well if you have other ideas you can push them to the -tc list today. i'll send that to Alan tomorrow
20:15:02 <flaper87> sdague: oh, good to know
20:15:08 <sdague> I would actually think a bit of that should be the board putting things on the joint agenda
20:15:22 <jeblair> it was last time, iirc
20:15:31 <ttx> Last item on this topic is the TC dinner, or absence thereof
20:15:34 <flaper87> jeblair: we added a couple too
20:15:37 <jeblair> maybe they don't have much to talk about either :)
20:15:40 <ttx> mordred said (rightly so) that the TC hasn't changed much and we know each other already, so there isn't so much need for a formal dinner as there was before
20:15:49 <ttx> I'm fine with getting an evening back for more informal arrangements, but I'm fine with a TC dinner too.
20:15:51 <annegentle> ttx: mordred good point
20:15:58 * russellb fine either way on dinner ...
20:16:00 <ttx> so maybe something less formal ?
20:16:03 <mordred> yah - and I feel like I don't actually do anything with the regular folks because I'm booked so solid all the time
20:16:07 <annegentle> less formal
20:16:08 <jeblair> oh, i din't think the point was to be introduced to people :)
20:16:12 <ttx> I'll definitely have dinner after the WoW event
20:16:14 <mordred> which I imagine is the same for many of you
20:16:18 <ttx> WoO I mean
20:16:20 <lifeless> mordred: I thought you were organising w/HP one ?
20:16:22 <annegentle> WOO :)
20:16:23 <mordred> yeah - dinner after WoW sounds like fun
20:16:29 <lifeless> anyhow, I'm fine any which way
20:16:31 <flaper87> jeblair: lol
20:16:50 <annegentle> lifeless: well there's also that mordred doesn't work at HP any more
20:16:52 <mordred> lifeless: I was, but then we were waiting on the election, and then got to talking, etc etc
20:16:54 <sdague> yeh, post woo dinner sounds reasonable
20:17:02 <annegentle> We could play WoW, whatevs :
20:17:03 <annegentle> :)
20:17:04 <markmcclain> the dinner is one of the few times all 13 of us are in one place that isn't a formal meeting
20:17:06 <ttx> ok, let's skip the formal dinner, and have a post-woo thing for whoever wants
20:17:18 <markmcclain> I still an informal event would be a good idea
20:17:18 <dhellmann> wfm
20:17:22 <mestery> ttx: ++
20:17:24 <dtroyer> ++
20:17:32 <jeblair> for the record, i would love a formal dinner, but i'm happy to have an informal one.
20:17:36 <ttx> markmcclain: we'll be at the woo event. We'll likely be at the core reviewer party event too
20:17:40 <annegentle> I think so too markmcclain -- setting aside the time, mainly
20:17:41 <anteaya> woo posts?
20:17:43 <flaper87> ++
20:17:50 <jeblair> i think us gathering together is a really thing.
20:18:02 <Rockyg> woo is supposed to have enough food that it's likely post drinks rather than dinner
20:18:12 <jeblair> a really good thing.
20:18:14 <flaper87> jeblair: ++ too
20:18:15 <markmcclain> jeblair: ++
20:18:20 <ttx> Rockyg: good to know.
20:18:22 <dhellmann> jeblair, markmcclain : ++
20:19:14 <ttx> OK, so I'm not sure we came to a conclusion here
20:19:16 <lifeless> fwiw I've very much enjoyed, and thought we got lots of important discussions done ina  low-stress environment, the formal dinners
20:19:23 <lifeless> but I'm equally happy with adhocing
20:19:39 <ttx> I'm fine either way. But we need an organizer and a sponsor
20:19:42 <sdague> yeh, honestly the vancouver venue was nice
20:19:52 <sdague> more bar like and able to talk with more folks
20:19:59 <dhellmann> yeah, having a space ready for 13 means more opportunity to talk than we might get ad hoc
20:20:01 <ttx> and a day
20:20:07 <flaper87> and move around, etc
20:20:13 <sdague> so post woo drinks where we can move around is goodness
20:20:24 <annegentle> sdague: ++
20:20:25 <mordred> sdague, ttx: I can work on finding a space
20:20:28 <sdague> and invite jgriffith to join, per tradition of emeritus
20:20:29 <ttx> How about we do something after the WOO event. Dinner if necessary, drinks most likely
20:20:35 <mestery> ttx: ++
20:20:46 <mestery> Informal, drinks, movement. What's not to like?
20:20:48 <flaper87> ttx: sounds good
20:20:49 <dhellmann> ttx: ++
20:20:56 <russellb> karaoke bar?
20:21:03 <flaper87> russellb: WOW!
20:21:07 <flaper87> love the idea
20:21:09 <flaper87> :D
20:21:15 <ttx> flaper87 is already reheasring all week
20:21:16 <sdague> not so good for the talking part
20:21:16 <annegentle> mestery had it, russellb escalated! :)
20:21:17 <mestery> Karoke bar!
20:21:22 <lifeless> nooo
20:21:24 <mestery> Yay!
20:21:25 * flaper87 starts warming up
20:21:25 <lifeless> not for chatting
20:21:26 <jeblair> sdague: some topics are best sung?
20:21:28 <annegentle> lol
20:21:36 <annegentle> "Don't Stop Believing"
20:21:44 <ttx> #topic Cross-project track at Design Summit
20:21:49 <ttx> sorry to be back on track
20:21:53 <ttx> The cross-project workgroup met yesterday to curate the track contents
20:21:54 <lifeless> ttx: one sec
20:21:54 <jeblair> ttx: we all are
20:22:02 <lifeless> I need to know if this is something we're going to get sponsored
20:22:17 <lifeless> or if it will be paid individually
20:22:22 <ttx> I'm fine with paying my share
20:22:35 <lifeless> fine with != plan of record
20:22:35 <russellb> same
20:23:00 <russellb> nobody has said "i'm paying", so I think that means pay your own.
20:23:03 <mordred> lifeless: the post-gathering? we have agreements from humans to fund a TC gathering
20:23:04 <lifeless> simply because if I"m going to chase down whoever mordred was extracting moo from, to do the same, I need warning :)
20:23:12 <mordred> lifeless: specifically, HP has indicated that they are happy to continue paying
20:23:25 <russellb> ah, nice.
20:23:28 <lifeless> mordred: ok, can you loop me in, since I'm going to be the amex-on-the-ground
20:23:29 <ttx> thanks HP
20:23:30 <jeblair> mordred: so the proposal is mordred finds a place and lifeless organizes payment?
20:23:33 <mordred> lifeless: excellent
20:23:35 <mordred> yup
20:23:41 <flaper87> thanks HP!
20:23:46 <mordred> or we might make cody-somerville go over and put a card down, but yeah
20:23:48 <lifeless> mordred: and I suspect i need to dig up a P card for it
20:23:53 <ttx> ok so
20:23:57 <ttx> The result is at the bottom of:
20:23:59 <ttx> #link https://etherpad.openstack.org/p/mitaka-cross-project-session-planning
20:24:00 <sdague> cross project track
20:24:03 <lifeless> mordred: drop me a mail @hpe.com ?
20:24:03 <ttx> I have two suggestions:
20:24:08 <ttx> If we swap 3 and 26, mtreinish can attend 26 (and dhellmann can attend both 3 and 11)
20:24:20 <sdague> ttx: annegentle also spoke up about a conflict
20:24:28 <cody-somerville> :)
20:24:32 <ttx> ah I may have missed that
20:24:33 <annegentle> yah, 2:50 my only talk
20:24:37 <sdague> ttx: it was on the ML
20:24:48 <sdague> so trying to move 10 out of the 2:50 block
20:24:49 <ttx> sdague: I was distracted today for some reason
20:24:53 <sdague> heh
20:24:57 <flaper87> I'm good with swapping but I think sdague had a conflict with 26 IIRC
20:24:58 <annegentle> yah my kids started fighting and it was all downhill from there yesterday afternoon :)
20:25:14 * annegentle is honest
20:25:19 <sdague> flaper87: I think the 3 / 26 flip is fine with me
20:25:27 <flaper87> sdague: cool
20:25:43 <flaper87> ttx: I'll swap them unless someone objects
20:25:50 <ttx> swap 10 and 14 then ? but taht prevents anne from doing design summit 101
20:26:08 <ttx> flaper87: wait
20:26:16 <sdague> or move 10 to 2pm
20:26:19 <sdague> we have the empty slot
20:26:32 <flaper87> ttx: damnit
20:26:35 * flaper87 rollsback
20:26:42 <ttx> moving 10 to 2pm works...
20:26:49 <sdague> annegentle: that work for you?
20:26:51 <ttx> kills my second suggestion but meh
20:26:58 <annegentle> how big is the place for walking time?
20:27:01 <sdague> ttx: what was your second suggestion?
20:27:05 <ttx> sdague: if we should not save one of the NACKs and schedule it on the empty slot at 2pm
20:27:05 <lifeless> having dlm and dynamic reconfig conflict is a poor idea
20:27:11 <ttx> For example one from rockyG on logging, combining 13 and 15
20:27:19 <sdague> ttx: we could put it at 2:50
20:27:21 <lifeless> since both are about dynamically handling changing environments
20:27:29 <ttx> sdague: yeah
20:27:37 <ttx> flaper87: ok go
20:27:44 <flaper87> so, summary:
20:27:47 <flaper87> swap 3 and 26
20:27:50 <flaper87> and ?
20:27:55 <lifeless> isn't 14 and 19 a dhellmann conflict?
20:27:56 <ttx> not sure anyone gets *that* movie reference
20:27:56 <sdague> lifeless: the constraints on there make it a pretty hard flip around at this point
20:27:56 * flaper87 got lost
20:28:01 <annegentle> 10 to morning?
20:28:07 <lifeless> moderating one... oslo ptl hat for other
20:28:16 <sdague> lifeless: he's not oslo ptl
20:28:20 <lifeless> oh
20:28:22 <lifeless> release ptl
20:28:24 <lifeless> meh :)
20:28:29 <ttx> swap 26 /3 move 10 to 2pm
20:28:35 <flaper87> roger
20:28:42 <Rockyg> Another one that might be more important is Refstack and Tempest ... how to make the testing work...
20:28:49 <lifeless> sdague: yeah, I get thats a typical scheduling problem
20:28:50 <dhellmann> lifeless: thanks for pointing that out
20:28:55 <ttx> and maybe make a single logging session for RockyG at 2:50pm
20:29:06 <jeblair> 3 26 swap 10 <empty> swap
20:29:20 <flaper87> jeblair: that's readable! Executed :D
20:29:26 <flaper87> ttx: done
20:29:27 <jeblair> <empty stack>
20:29:42 <Rockyg> Thanks!
20:29:43 <flaper87> jeblair: <snack>
20:29:49 <ttx> RPN I see
20:30:03 * jgriffith would love to attend (delayed response)
20:30:06 * Rockyg empty snack?
20:30:15 <jeblair> Rockyg: :(
20:30:17 <ttx> So what about putting 13+15 in the empty slot at 2:50pm ?
20:30:34 <ttx> I don't think we need to preserve an empty slot at that hour
20:30:43 <dhellmann> ttx: could we move 14 there and add 13+15 at 11:15?
20:30:54 <Rockyg> ttx:  if we can get treinish, I'd prefer working out how to go forward with tempest fw for refstack...
20:30:54 <sdague> yeh, I was going to just suggest what dhellmann said
20:30:58 <ttx> dhellmann: that works
20:31:08 <dhellmann> flaper87: did you get that or should I swap?
20:31:16 <flaper87> sounds good to me
20:31:22 <flaper87> on it
20:31:26 <dhellmann> flaper87: ty
20:31:45 <ttx> Rockyg: I think it's less of a cross-project thing though
20:31:48 <jeblair> there will be a partial conflict with DLMs [lifeless]
20:31:49 <sdague> Rockyg: so we've got "Supporting DefCore and Interop testing" already at 12:05
20:32:14 <Rockyg> ttx  Ah, thanks.  Need to make time with QA session...
20:32:15 <ttx> if not covered there there are refstack slots and QA slots where that might fit
20:32:31 <ttx> Alright, looks like we have a winner
20:32:37 <ttx> Who volunteers to push that one to Cheddar ? I can add them as admin for the track
20:32:49 * dhellmann touches flaper87's nose
20:32:53 <Rockyg> Not covered yet and really important - QA and Refstack...
20:32:56 <flaper87> hahaha
20:33:11 <flaper87> I can do it
20:33:14 <sdague> ttx: I can do it if no other volunteer
20:33:18 <lifeless> Rockyg: sorry, there are no slots from what I can see
20:33:20 * Rockyg sawts at something tickling my nose
20:33:27 <sdague> ok, there is another volunteer, so flaper87 wins
20:33:28 <ttx> flaper87: I'll add you asap
20:33:37 <flaper87> ttx: thanks
20:33:42 <ttx> like during the next topic
20:33:45 <ttx> #topic Kick off N naming
20:33:48 <ttx> sdague: care to drive this one ?
20:33:56 <sdague> sure
20:34:25 <sdague> we're making plans now for things in M, N, and even sometimes O
20:34:39 <sdague> we should get some names out there instead of people inventing things, which get confusing later
20:34:45 <ttx> flaper87: you reached Level 4 Warrior class.
20:34:45 <Rockyg> yay!
20:34:46 * markmcclain thinks there was neutron discussion about completing a feature in X
20:35:05 <sdague> N naming should just go by the current rules, and there is a sub point to change the rules to make O go
20:35:06 * dhellmann thinks x is closer than markmcclain thinks
20:35:11 * flaper87 is honored and ready for the battle
20:35:33 <sdague> so, who's got the batton to drive the naming?
20:35:43 <markmcclain> dhellmann: it was halfway serious... since some deprecation timelines stretch to P
20:35:45 <sdague> for N cycle
20:35:47 <russellb> sdague does!
20:35:53 <lifeless> +1
20:36:01 <lifeless> sdague: thank you for volunteering?
20:36:06 <flaper87> sdague: thanks!
20:36:09 <jeblair> sdague: thanks!
20:36:10 <sdague> russellb: no, I don't think so. I think after the rules changes last time mordred and jeblair signed up for such things
20:36:22 <sdague> we can probably find minutes even
20:36:28 <mordred> I can do it again if people would like
20:36:39 <annegentle> I think sdague's memory serves him
20:36:44 <annegentle> well, even
20:36:45 <mordred> but is also happy to share the love if other people want it
20:36:56 <ttx> mordred: nice try :)
20:37:00 * russellb happy for whoever is up for it to do it
20:37:19 * dhellmann wonders if N will be the "not it" release
20:37:23 <ttx> N is in Texas, might end up being even more dangerous than the Japanese one
20:37:24 <russellb> heh
20:37:34 <mestery> mordred and jeblair do such a nice job, it woudl be shame to not let them do it again :)
20:37:36 <sdague> nixon texas is a town
20:37:40 <sdague> just saying
20:37:48 <flaper87> oh boy
20:37:54 <dhellmann> sdague: I'll just go on record now as saying that I find that offensive ;-)
20:38:02 <sdague> dhellmann: hey, just saying
20:38:14 <ttx> sdague: alright, do you want to mention the rules change ?
20:38:19 <flaper87> ok, so, are we doing this?
20:38:33 <sdague> sure so mordred has the action to run with N naming asap?
20:38:39 <sdague> lets make it a thing
20:38:39 <lifeless> +1
20:38:45 <ttx> yes, it's action mordred day
20:38:55 <ttx> #agreed mordred to handle N naming process asap
20:38:59 <russellb> thanks, mordred !
20:39:01 <sdague> ok, so sub bullet
20:39:06 <mordred> well, so, actually
20:39:16 <mordred> I believe me handling it is a patch to that file
20:39:21 <jeblair> yep, first step is to propose a governance change
20:39:26 <sdague> mordred: and collect
20:39:39 <mordred> so it's great that we've agreed, but let me make a patch and submit it first
20:39:53 <sdague> ok so - https://review.openstack.org/#/c/232489/
20:39:55 <sdague> sub bullet
20:40:07 <sdague> lets not put an artificle restriction on when we can start naming
20:40:10 <sdague> we have a place for O
20:40:33 <sdague> and we're already hit code change discussions for O min libvirt release
20:40:40 <sdague> so I'd like us to name it
20:40:43 <ttx> so on this one I think we need to know the name of the next two releases at any time
20:40:48 <dhellmann> IIUC, it was intended to ensure that the folks participating in the release had a chance to name it, so it wasn't about folks leaving but about folks joining, and it wasn't artificial it was intentional
20:40:56 <ttx> "as soon as we know the location" is a bit open-ended
20:40:58 <dhellmann> that said, I agree it's useful to drop it
20:41:03 <ttx> I have been scouting locations for 2018
20:41:14 <sdague> dhellmann: right, I do see that, but I also think we're planning more than one cycle out
20:41:21 <ttx> I'm fine with "next 2 which means we need to pick O as soon as Liberty is out
20:41:21 <anteaya> ttx: you progressive thinker you
20:41:27 <ttx> as long as we know where the summit is
20:41:30 <sdague> and the shifting term for the N+1 release is confusing to new folks
20:41:34 <dhellmann> sdague: yep, I agree, I just wanted the framing to be accurate in the minutes
20:41:44 <annegentle> yeah and we're heading towards an N release anyway
20:42:07 <flaper87> ttx: do you think the locatoins will be announced with so much time in advance?
20:42:10 <sdague> because we want to land code on O libvirt requirements nowish in official repos, so the distros have a year to get ready for us
20:42:17 <annegentle> I'd like to propose decoupling from the summit, but will do so in a follow-up. Would that be amenable to our end-goals to have some fun, engage those working on releases?
20:42:19 <flaper87> we normally know the locations for the next 2
20:42:35 <flaper87> I'm good with limiting it to just 2 but it may not be necessary
20:42:46 <sdague> https://review.openstack.org/#/c/232489 currently has 11 +1s
20:42:48 <ttx> flaper87: more and more we'll know the locations in advance. We have known about next 3 (Tokyo; Austin; Barcelona) back in YVR
20:42:54 <anteaya> annegentle: decoupling from summit, meaning not tying names to geography?
20:42:58 <annegentle> decouple from location entirely even, or choose a location related to a contributor
20:43:17 <ttx> annegentle: wait until we reach Z maybe
20:43:26 <ttx> sdague: ok, let me approve
20:43:31 <annegentle> ttx: heh, go through 26 first, sure. that's only 8 years away
20:43:59 <ttx> sdague: approved
20:44:14 <ttx> (I abstained, I hope it still works)
20:44:32 <ttx> sdague: anything else on that topic ?
20:44:54 <sdague> nope
20:45:03 <ttx> #topic Workgroup reports and new members
20:45:10 <ttx> We have two established workgroups: comms and next-tags
20:45:14 <ttx> Anyone interested in joining/leaving those groups ?
20:45:25 <ttx> Also I've been toying with the idea of assigning mentor TC members to projects which application has been deferred to mitaka
20:45:34 <ttx> That is Compass, Fuel, kiloeyes, Monasca, Kosmos and Juju charms
20:45:41 <ttx> We deferred all of them waiting for more activity or more alignment with the OpenStack way
20:45:50 <ttx> I think it would help them (and us) if there were some designated person(s) keeping track of their progress
20:46:04 <dhellmann> ++
20:46:19 <ttx> and reporting to the TC when they feel they are ready, for example
20:46:33 <angdraug> +1
20:46:34 <flaper87> I'd be all for that. I proposed this back when marconi was rejected but those were different times, I guess
20:46:34 <annegentle> ttx: tracking as in going to their meetings? Or some other scope?
20:46:37 <ttx> rather than us randomly putting it back on the approval slate after a period of time
20:46:43 <mestery> +1 to that idea on mentoring ttx
20:46:48 <ttx> annegentle: keeping track of their progress, be a mentor
20:47:00 <ttx> answer their questions, reporting to the rest of teh TC about progress
20:47:05 <annegentle> ttx: ok, yeah makes sense, I imagine being available for Qs would be a big helper
20:47:07 <jeblair> it doesn't sound particularly scalable; and things like the project team guide were meant to help scalability...
20:47:25 <ttx> I don't expect we'll have a large backlog
20:47:31 <jeblair> fair
20:47:38 <ttx> or at least, not a growing one
20:47:54 <flaper87> I really hope we don't, otherwise we'd be failing to communicate the requirements
20:48:00 <ttx> we probably reached a peak, partly due to fine-tuning our expectations
20:48:21 <sdague> maybe, it seems like there are new bits coming to the fold quite often in the project-config repo
20:48:22 <angdraug> I think part of a mentor's responsibility would be to identify gaps in documentation based on questions they receive
20:48:55 <annegentle> angdraug: could be, but it's much more than that
20:48:57 <ttx> jeblair: also like for other workgroups I'm not opposed if someone outside the TC would take the job
20:49:05 <angdraug> just trying to address the backlog concern
20:49:09 <lifeless> angdraug: we can do that without a mentor
20:49:25 <flaper87> ttx: I can work with you on that idea (mentor)
20:49:28 <Rockyg> Coaching on outreach to community, or facilitating cross project design meetings...
20:49:39 <lifeless> the backlog is really just the period of time that projects will exist for before they are ready to join, as a minimum
20:49:45 <lifeless> like - we can't expect that to disappear
20:49:46 <ttx> well, it will only work if we have volunteers anyway
20:49:49 <annegentle> I see it as outreach and facilitation, onboarding
20:50:02 <flaper87> lets write down some plan and expectations
20:50:07 <ttx> so no point in saying we'll do it before we have people signed up to actually do it
20:50:12 <flaper87> then we can ask for volunteers and see how it goes
20:50:18 <ttx> flaper87: sounds good
20:50:22 <lifeless> I'd be happy to mentor a project
20:50:48 <markmcclain> I can help out with 1
20:50:51 <ttx> flaper87: the base idea being, if we defer a project application, we should assign someone to follow that project
20:51:03 <ttx> not just leave them out in the cold
20:51:03 <flaper87> ttx: yup
20:51:49 <ttx> If we think a project will never make it we should *reject* the application, not defer it
20:52:02 <mestery> ttx: Those are sane ideas, I like it.
20:52:15 <mestery> flaper87 ttx: I can help out here too if you need more people
20:52:19 <ttx> ack
20:52:23 <flaper87> mestery: awesome, thanks
20:52:26 <ttx> alright, 8 min left
20:52:38 <ttx> I had two other things proposed on the agenda
20:53:02 <ttx> JavaScript to Common Testing Interface is being actively reviewed, not sure there is a point in discussing it in the remaining time
20:53:27 <annegentle> I'm happy for the active docs discussion early on
20:53:35 <ttx> Go comment on https://review.openstack.org/232756 and we'll look into it a future time
20:53:46 <ttx> #topic Add team:non-diverse-affiliation tag
20:53:51 <ttx> #link https://review.openstack.org/218725
20:53:52 <jeblair> annegentle: among good problems to have: "where to put these docs people really want to write"
20:54:02 <ttx> that one is a bit stuck with two parties disagreeing
20:54:06 <annegentle> jeblair: srsly!
20:54:13 <ttx> we could call for a final vote on it
20:54:33 * dhellmann finds both arguments persuasive
20:54:35 <ttx> or we can let it mature a bit more and have people change their opinions over sake
20:54:44 <ttx> I'm for sake at this stage
20:54:53 <flaper87> I meant to comment on that one on Friday and forgot
20:54:58 <ttx> but then I can't oppose a request for final voting
20:55:14 <dtroyer> Agreed.  with the opportunity for in-person discussion close we should take advantage of that
20:55:16 <sdague> honestly, I'd say lets do it post summit / sake
20:55:31 <sdague> but we should resolve it after we get back one way or another
20:55:32 <ttx> (as a reminder, final voting triggers the charter voting rules, meaning the chaneg is accepted if it has more YES than NOes)
20:55:36 <dhellmann> ttx: kanpai!
20:55:39 <flaper87> there's no rush in doing it now
20:55:41 <annegentle> I think we'll be getting lots of input at the summit about what's important to people, so deferring makes sense.
20:55:50 <ttx> right
20:55:56 <ttx> No rush
20:56:00 <ttx> #topic Open discussion
20:56:01 <jeblair> this sounds like a plan.
20:56:08 <ttx> I won't be around next week -- we can either skip or have someone else chair.
20:56:19 <ttx> I don't expect we'll build a backlog by then
20:56:23 <annegentle> anything pressing? I doubt it
20:56:28 <annegentle> I think it's ok to skip
20:56:30 <jeblair> i won't be around either
20:56:32 <sdague> I guess one last thing on naming, should now that we can do O naming, should we run it concurrent with N, or post N ?
20:56:35 <ttx> and it will be too early to reconsider the deferred-to-mitaka projects
20:56:39 <dhellmann> I don't think I'll be here
20:56:47 <sdague> naming that is
20:56:57 <flaper87> I'd appreciate not waking up at 5am next week :)
20:56:58 <ttx> sdague: I'd say post-N
20:57:03 <ttx> to reduce confusion
20:57:06 <dhellmann> yeah, right after
20:57:07 <flaper87> but I'll happily do it if there's a meeting
20:57:14 <markmcclain> yeah... serially
20:57:18 <sdague> ttx: can we do it after polls close, but it's still in trademark search?
20:57:23 <edleafe> +1 for post-N
20:57:25 <angdraug> what's the current state of the discussion of alternatives to LP? dormant?
20:57:28 <sdague> because I'd like to not wait too long
20:57:31 <annegentle> flaper87: where are you, new zealand? Australia? Japan?
20:57:37 <flaper87> annegentle: Japan
20:57:42 <sdague> we are going to commit things to repos that so Osomething
20:57:43 <annegentle> flaper87: cool
20:57:43 <anteaya> angdraug: see the infra meeting log prior to this meeting
20:57:50 <ttx> sdague: I guess so. That would still trigger the confusion... like picking the O candidates while we don't know what N will be
20:58:02 <annegentle> angdraug: ooo I'm going to look also
20:58:03 <sdague> yeh, it will require communication
20:58:43 <sdague> that's why running concurrently honestly seemed like maybe a better deal
20:58:57 <ttx> sdague: I don't think we need to rush it, but I'm fine with whatever
20:59:00 <sdague> maybe I'll poke mordred and volunteer to help
20:59:15 <ttx> so.. skipping next week and see you all at summit ?
20:59:19 <sdague> sounds good
20:59:22 <jeblair> ++
20:59:23 <dhellmann> yes
20:59:23 <flaper87> sounds good
20:59:28 <ttx> alright
20:59:29 <markmcclain> ++
20:59:38 <annegentle> good
20:59:39 <ttx> thanks everyone!
20:59:44 <flaper87> w00h00
20:59:52 <ttx> #endmeeting