20:01:46 <ttx> #startmeeting tc
20:01:46 <openstack> Meeting started Tue Nov 24 20:01:46 2015 UTC and is due to finish in 60 minutes.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:01:48 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:01:50 <ttx> Hi everyone
20:01:51 <openstack> The meeting name has been set to 'tc'
20:01:52 <ttx> Short agenda for today:
20:01:57 <alexpilotti> o/
20:01:58 <mestery> Yay to short agenda! :)
20:01:58 <ttx> #link https://wiki.openstack.org/wiki/Meetings/TechnicalCommittee
20:02:10 <ttx> Should leave plenty of time for open discussion at the end, if you have anything you'd like us to discuss
20:02:16 <ttx> I miss you all, you know that
20:02:25 <ttx> #topic Adding os-win to OpenStack
20:02:25 * flaper87 hugs ttx
20:02:31 <ttx> #link https://review.openstack.org/247022
20:02:40 <ttx> Looks like this is pretty close, we just need to bikeshed on the name
20:02:50 <ttx> to decouple the team name from its first deliverable a bit more
20:03:01 * mestery gets out the red paintbrush
20:03:02 <ttx> and also make it a bit less horrible-sounding
20:03:19 <ttx> So bring on the window analogies
20:03:20 <dhellmann> yeah, I'd like to avoid the ceilometer/telemetry/ceilometer/telemetry dance with this team
20:03:22 * flaper87 gets the black one
20:03:25 <alexpilotti> ttx: looks like "winstackers" got overwhelming support :-)
20:03:34 <ttx> yeah, it's deliciously cheesy
20:03:40 <mestery> ttx: ++
20:03:51 <flaper87> I don't mind winstackers, fwiw
20:03:55 <alexpilotti> :)
20:04:06 <russellb> hi, sorry
20:04:13 <ttx> Alright, with the expanded scope i'm fine with this
20:04:13 <flaper87> actually, it fits quite nicely
20:04:29 * flaper87 is fine with it too
20:04:42 <ttx> Any other question on that ?
20:05:04 <ttx> I think it's a team, it's in openstack community and since oslo doesn't want it it warrants its own team
20:05:22 <russellb> wfm
20:05:52 <alexpilotti> ttx: since oslo does not want us we though about "stockholm"
20:06:02 <lifeless> o/
20:06:14 <dims> alexpilotti ouch :)
20:06:21 <ttx> alexpilotti: it definitely sounds like a syndrome
20:06:46 <mordred> wow
20:06:49 <mordred> the TC meeting is fun today
20:07:05 <ttx> mordred: short and fun, the way it should always be
20:07:11 <dhellmann> alexpilotti, :-)
20:07:12 <flaper87> Oslo wants you... in a separate project/team <3 :D
20:07:16 <dhellmann> flaper87 : ++
20:07:46 <markmcclain> we've got 7 now
20:07:49 <rockyg> flaper87, ++
20:07:58 <ttx> claudiub: how many projects are expected to use os-win ?
20:08:30 <ttx> oh, RTFCM
20:08:31 <claudiub> ttx: for now, it's going to be used in nova, cinder, networking-hyperv. the next one on the list would be os-brick.
20:08:32 <ttx> nova, cinder, ceilometer, networking-hyperv
20:08:45 <ttx> claudiub: nice
20:08:53 * ttx likes deduplication
20:09:08 <alexpilotti> claudiub: manila
20:09:12 <ttx> alright, we have a winner
20:09:15 <alexpilotti> ceilometer
20:09:29 <ttx> Will approve in 30 seconds unless someone screams another question
20:09:54 <bswartz> another question!
20:10:03 <ttx> bswartz: nice try
20:10:12 <edleafe> bswartz: next time try all caps
20:10:13 <mestery> lol
20:10:21 <ttx> Alright, it's in
20:10:29 <mestery> woot!
20:10:31 <flaper87> w000t
20:10:34 <dhellmann> welcome, winstackers
20:10:39 <alexpilotti> yeiiii
20:10:40 <flaper87> mestery: 0 are more meaningful
20:10:42 * flaper87 ducks
20:10:47 * mestery shakes his fist at flaper87
20:10:48 <mestery> ;)
20:10:57 <ttx> #topic Open discussion
20:11:01 <claudiub> thanks folks for your support. :)
20:11:09 <ttx> Alright, I had a few things to discuss
20:11:18 <ttx> First we have a number of asserts in the governance review queue, you might want to check them out before I approve them
20:11:33 * flaper87 watches ttx take his hidden agenda out
20:11:35 <ttx> since a few of them just passed the age requirement
20:11:46 <ttx> Second... Shall we move this meeting to #openstack-meeting-cp ?
20:12:04 <ttx> (starting next week, obviously)
20:12:34 <flaper87> mmh, I'm fine either way, tbh. If that helps freeing up a slot for some other project, fine.
20:12:40 <dhellmann> I suppose that would make sense
20:13:04 <ttx> It's also to give a bit of publicity to that other channel,and make sure nobody holds a cross-project meeting at the same time as the TC meeting
20:13:07 <lifeless> ttx: did we declare bankrupytcy or something?
20:13:15 <lifeless> ttx: my backwards compat change is perhaps worth talking about
20:13:17 <markmcclain> We've also been in this venue for so long would we actually make it harder for those not tracking every detail harder to find us?
20:13:34 * dhellmann hands zehicle a better network connection
20:13:39 * russellb looks at the 4 meeting channels he already has open
20:13:49 <jeblair> i think the main reason to do it would be publicity as ttx says and to _create_ conflicts for #openstack-meeting-cp (so that cp meetings don't get scheduled over this one)
20:13:56 <jeblair> that said, i'm ambivalent :)
20:14:04 <dhellmann> jeblair : +0
20:14:11 <ttx> lifeless: yeah, we buried everyone under piles of bureaucracy and now nobody proposes anything :) Or as I like to think of it, we have caught up with the big tent backlog
20:14:11 <lifeless> https://review.openstack.org/#/c/226157/
20:14:36 <mordred> +0
20:15:06 <lifeless> mordred: +0 on the spec or +0 on ttx's comment?
20:15:14 <ttx> OK, I'll clartify with thingee (cross project master) and sdague (inventor of #openstack-meeting-cp) where they prefer it
20:15:14 <mordred> the moving the meeting
20:15:31 <ttx> I think everyone is +0 on that one
20:15:38 <ttx> I assume everyone is
20:15:44 <lifeless> oh, there's another channel to add?
20:15:44 <lifeless> sigh
20:16:00 <lifeless> I can see why, but :/
20:16:07 * mordred has 165 open IRC windows currently, one more will have zero effect
20:16:12 <flaper87> For the sake of publicity and avoid ppl scheduling cp meetings on the slot used for the TC meeting, then Im +1
20:16:26 <lifeless> mordred: it'll certainly get zero attention :)
20:16:36 <rockyg> So, an announcement should turn up in this channel at the regular time, pointing folks to the other channel...
20:16:39 <mordred> lifeless: most things I do fall into that category
20:16:41 <rockyg> If it moves
20:16:45 <ttx> lifeless: I'll admit my TODO to reread that spec is planned for tomorrow.
20:16:59 <ttx> rockyg: sure
20:17:27 <lifeless> ttx: and here I got it up a week ahead of this meeting to give you time :)
20:17:47 <rockyg> A heads up on another topic.  Product WG started discussing stable and the stable project.
20:17:48 <ttx> lifeless: been on my "tomorrow" list for a few days already
20:17:51 <lifeless> so, AIUI the TC approves such specs
20:17:59 * flaper87 feels bad for not reading lifeless' spec
20:18:06 <lifeless> how do I get actual attention, since its not a governence change
20:18:07 <rockyg> Seems there is interest in providing more "resources" for the stable project
20:18:15 <ttx> lifeless: yes, but the TC seeks consensus across the community first, we just recognize the consensus
20:18:20 <lifeless> perhaps all cross projects specs should be automatically in our agenda
20:18:23 <lifeless> ttx: we do
20:18:40 <lifeless> ttx: but we try to do that broadly anyhow
20:18:40 <ttx> basically we don't vote, we summarize the community opinion
20:18:51 <ttx> We vote, but just as someone else
20:18:57 <dhellmann> I'd like to see some oslo-core +1 votes on that spec, for example
20:19:09 <ttx> usually we seek at least the affected PTLs +1
20:19:14 <dhellmann> the keystone team has several libs, too, so that would be another good place to go for input
20:19:14 <ttx> here it's quite broad
20:19:29 <rockyg> FWIW, I like lifeless
20:19:42 <rockyg> Sorry his spec.  Him.. Eehhh ;-)
20:19:50 <lifeless> rockyg: o/
20:20:06 <ttx> It's a good test for the new cross-project process, which thingee and annegentle have been pushing
20:20:37 <rockyg> Schedule a discussion, advertise its time, then give a week for comments?
20:20:50 <ttx> rockyg: something like that
20:21:15 <lifeless> jeblair: / mordred: how do I look up notmyname in th gerrit add reviewer widget?
20:21:50 <ttx> lifeless: Type John D and select Dickinson
20:22:10 <ttx> (I realize that's not really the answer to your question)
20:22:33 <ttx> Oh, in other news...
20:22:40 <ttx> I got some recent feedback from lawyers on the licensing question (triggered by the Juju charms application a few weeks ago)
20:22:48 <lifeless> ttx: there is no dickinson listed
20:22:53 <ttx> Section 7.1(b) clearly makes ASLv2 mandatory for anything we'd want to put in tc-approved-release (or defcore).
20:22:59 <ttx> lifeless: weird, there is on mine
20:23:10 <lifeless> ttx: after a space it doesn't pipop
20:23:14 <lifeless> ttx: pop up
20:23:15 <ttx> We could make ASLv2 generally mandatory for type:service things just to make sure we do not hit a problem later on...
20:23:31 <dhellmann> lifeless : try me@not.mn
20:23:33 <ttx> Beyond services that we might want to cinlude in defcore one day, section 7.1(a) would allow ASLv2 + licenses which permit distribution under Apache 2 (MIT, BSD) for big-tent projects
20:23:34 <lifeless> ttx: ... its case sensitive. I did not see that coming
20:23:58 <ttx> I'm trying to get clarification on the list of licenses that would be OK. If the interpretation above holds, it appears pretty clear that GPL* would not be an option
20:24:48 <ttx> Thought on that ? Questions I could channel back ?
20:25:31 <russellb> ttx: thanks for following up on that :)
20:25:33 <jeblair> ttx: can you clarify 'big-tent'?
20:25:37 <mordred> yah
20:25:41 <dhellmann> ttx: so both MIT and BSD can be re-distributed under Apache2?
20:25:55 <russellb> i wonder if we already violate what you just said though
20:25:56 <jeblair> ttx: cause earlier you said "tc-approved-release (or defcore)"
20:26:02 <russellb> right
20:26:03 <dims> dhellmann : yes
20:26:42 <mordred> we've previously gotten the explicit ok from legal to have GPL things be in our circle of things we work on as long as they weren't "part of the release"
20:26:45 <ttx> jeblair: released deliverables from an official project team ?
20:27:06 <ttx> yeah, I need to get clarification that it wouldn't affect things we don't "release"
20:27:08 <dhellmann> yeah, I thought we already had GPL projects from infra, if not other teams
20:27:13 <mordred> we do
20:27:13 <ttx> or distribute
20:27:24 <flaper87> we do have GPL things
20:27:31 * flaper87 can't remember OTOH
20:27:45 <flaper87> ... can't remember which ones...
20:28:02 <ttx> jeblair: so a Gerrit local fork would be fine -- a Puppet recipe for deploying openstack, not so sure
20:28:25 <ttx> I'll take that question back. A list of those GPL things might be helpful
20:28:29 <russellb> makes sense
20:28:41 <ttx> usage vs. distribution I guess
20:28:54 <ttx> although it's a bit of a fine line
20:28:58 <ttx> I'll ask for clarification
20:29:00 <jeblair> usage was never in question
20:29:03 <russellb> having a git repo is kinda distribution
20:29:12 <lifeless> right, 30 odd reviewers added
20:29:13 <russellb> probably not even kinda, just is
20:29:19 <lifeless> I'm not sure this is the right mechanism :)
20:29:41 <lifeless> jeblair: is gerrit able to make that index lookup case insensitive, do you know?
20:29:48 <jeblair> we certainly create,author,distribute gpl code though -- with the understanding it's not impacted by the bylaws because it's not part of the official openstack release
20:29:52 * ttx reread 7.1(a)
20:29:56 <lifeless> rockyg: if you like it you should put a vote on it
20:30:12 <ttx> jeblair: maybe we could exempt release:independent things altogether
20:30:28 <mestery> ttx: That would be interesting
20:30:28 <lifeless> ttx: that would imply they can never be defcore
20:31:15 <dhellmann> ttx: I don't think we should tie this to the release model. There's enough confusion about that as it is.
20:31:16 <ttx> lifeless: no, that implies non-ASLv2 things can't be defcore
20:31:19 <jeblair> lifeless: i think that matches my understanding of the intentent of 7.1a
20:31:25 <mordred> yah
20:31:25 <ttx> right
20:31:37 <mordred> infra does not release software that is intended to be part of defcore
20:32:07 <rockyg> lifeless, I now plan to, but I have to read it more closely to see if I have specific comments, first
20:32:12 <mordred> so whie we're clearly "humans who are working on openstack" - our output is not generally confused with "software that is openstack"
20:32:16 <ttx> 7.1(a) is quite clear though
20:32:21 <lifeless> ttx: you're saying its a one-way thing: release-indepednedent '*may*' be suitable for defcore
20:32:45 <ttx> The Foundation shall generally accept contributions under ASLv2, or on a license on terms which will permit distribution under the Apache License 2.0
20:32:58 <ttx> (if teh BoD approves it)
20:33:13 <lifeless> ttx: 7.1 is *may*
20:33:54 <ttx> yeah, shall generally accept contributions under ASLv2, and *may* accept a license on terms which will permit distribution under the ASLv2
20:33:56 <lifeless> ok thats bad, the governance docs link to the cla now goes to a random how to contribute wiki page
20:34:40 <lifeless> (the links from the bottom of https://www.openstack.org/legal/bylaws-of-the-openstack-foundation/)
20:35:01 <ttx> heh
20:35:02 <lifeless> ttx: 7.1a does not say 'accept under ASLv2'
20:35:09 <lifeless> ttx: it says 'accept pursuant to the cla'
20:35:10 <ttx> it says "under the CLA"
20:35:15 <lifeless> and I can't find the CLA
20:35:19 <ttx> and teh CLa says Apache v2
20:35:26 <lifeless> to verify
20:35:29 <ttx> lifeless: you should keep copies of stuff you sign :)
20:35:38 <lifeless> the us government one *does not* say Apache V2 as a data point
20:35:53 <dhellmann> lifeless : https://review.openstack.org/static/cla.html
20:35:56 <ttx> https://review.openstack.org/#/settings/agreements
20:36:02 <dhellmann> via ^^
20:36:07 <lifeless> thanks
20:36:22 <lifeless> so the icla is gone right? DCO now
20:36:29 <ttx> heh, doesn't even mention Apache
20:36:44 <lifeless> the corporate CLA is not accessible from there in gerrit
20:36:50 <lifeless> and thats relevant to most of us
20:36:54 <jeblair> ttx: amusingly enough, the cla is permissive enough to permit the foundation to license openstack under the gpl.
20:37:07 <jeblair> ttx: (with a bylaws change)
20:37:07 <ttx> jeblair: fun!
20:37:15 <lifeless> ttx: and yes, the cla does not say asl
20:37:27 <lifeless> ttx: thank you for bearing with my detail concerns :)
20:37:32 <lifeless> icla
20:37:44 <jeblair> i think the operative thing here is actually 7.1b
20:37:49 <lifeless> is there a copy of the corporate cla around we can check ?
20:38:00 * ttx just can't read legalese
20:38:13 <lifeless> https://secure.echosign.com/public/hostedForm?formid=56JUVGT95E78X5
20:38:17 <jeblair> which is what causes the foundation to take all the contributions it has received under its super-broad cla and then turn around and license them to the world under the asl2
20:38:20 <lifeless> ^ corporate cla
20:38:35 <jeblair> when it "distributes software"
20:38:57 <mordred> I agree. this is all for the purposes of talking about the release we make
20:39:07 <dhellmann> for those following at home, the CCLA on echosign.com is linked from https://wiki.openstack.org/wiki/How_To_Contribute#Contributor_License_Agreement
20:39:12 <lifeless> jeblair: but only the software in 'OpenStack Technical Committee Approved Release'
20:39:19 <ttx> jeblair: so there could be an argument that only the tc-approved release needs to limit choice of license
20:39:20 <jeblair> so i guess the question is, when is it distributing software?  the approved release, or any git repo we host?  our understanding from previous lawyer conversations was more along the lines of 'the approved release'
20:39:23 <lifeless> jeblair: not all distribution of software
20:39:39 <dhellmann> jeblair : "the software in the OpenStack Technical Committee Approved Release"
20:40:04 <ttx> jeblair: ok, I'll go back to lawyers with additional questions. Thanks for your comments!
20:40:16 <ttx> dhellmann: you had something else ?
20:40:36 <dhellmann> yes, do we want to talk about https://review.openstack.org/#/c/244782/ -- the defcore test flagging from the nova driver team at oracle
20:40:40 <ttx> #action ttx to clarify with lawyers what "distribution" means
20:40:50 <dhellmann> several of you have already commented on the review
20:40:52 <lifeless> ttx: we probably want to check about the board's expectations here, even if the foundations are copacetic
20:40:57 <lifeless> we don't want to surprise anyone
20:41:09 <mordred> dhellmann: it seems pretty unanimous feedback on the review
20:41:11 <ttx> lifeless: we won't, this is at early stages
20:41:17 <rockyg> dhellmann, I think the flag issue is a resounding "no" but the linux VM issue is being separated.
20:41:31 * flaper87 hasn't read that defcore review
20:41:40 <dhellmann> rockyg : the two issues are pretty intimately tied together
20:41:46 <lifeless> flaper87: its very interesting
20:42:02 <dhellmann> mordred : I wonder if it would help the defcore committee if we said something officially? or at least all voted.
20:42:10 <rockyg> Yes.  But the second one needs *lots* more discussion.  First one is easier and so I believe it will be rejected shortly.
20:42:11 <ttx> It's actually a very good question being discussed there
20:42:13 <flaper87> lifeless: I'll go through it, I just saw your latest comment and it's quite lengthy
20:42:25 <mordred> dhellmann: I would be more than happy to help put together a resolution to that effect if it's unclear
20:42:41 <lifeless> flaper87: :) all the good bits are the comments, not the actual review diff itself ;)
20:43:04 <rockyg> I think there might be a discussion scheduled for the next TC meeting?
20:43:15 <ttx> rockyg: not on my agenda
20:43:17 <rockyg> Mark Voelker indicated some such
20:43:25 <ttx> you mean next defcore meeting ?
20:43:38 <markvoelker> actually that was hogepodge...he mentioned he might put it on the agenda for next TC meeting
20:43:48 <ttx> ok, he didn't yet ;)
20:43:52 <rockyg> OK.  How does the next meeting look for that?  Plus what is discussed here, now, for prep.
20:44:03 <mordred> the number of things that linux DOESN'T run on these days is so small
20:44:12 <mordred> that trying to carve out it being ok to not be able to run linux
20:44:13 <ttx> well, next meeting agenda is pretty empty right now :)
20:44:18 <flaper87> I'd appreciate some time to read through it, fwiw
20:44:25 <flaper87> so, yeah, next meeting ++
20:44:26 <dhellmann> yeah, I think it's fine for the nova team to say drivers must support running linux
20:44:29 <rockyg> Kewl
20:44:30 <mordred> seems like a solution in search of a problem
20:45:13 <ttx> Alright, next meeting
20:45:25 <dhellmann> wfm
20:45:26 <ttx> (if someone posts it to openstack-tc)
20:45:31 <ttx> Anything else, anyone ?
20:46:17 <ttx> Anything we should be actively working on ? Anything you promised to get elected that you haven't delivered on yet ?
20:46:28 <rockyg> ttx, I'll eat some turkey and drink lots of good wine in your honor at the Thanksgiving dinner ;-)
20:46:39 <lifeless> ttx: the things I discussed two weeks back
20:46:46 <lifeless> ttx: I'm turning them into prose bit by bit
20:46:57 <ttx> rockyg: if i don't drink it myself it's like it doesn't really exist
20:47:02 <flaper87> we promissed to get a post out and we didn't
20:47:05 <flaper87> we = comm wg
20:47:07 <ttx> flaper87: boo
20:47:11 <flaper87> I'll get to that
20:47:12 <flaper87> :D
20:47:13 <lifeless> ttx: the leadership training stuff - gothicmindfood is looking into concrete details to help make it an actual specific proposal not a handwavy thing
20:47:13 <mordred> rockyg: ++
20:47:19 <mordred> lifeless: ++
20:47:19 <rockyg> Next time you're in the bay area.  You can drink some of ours...
20:47:26 <ttx> lifeless: yes she's been in touch with my skeptical side
20:47:41 <lifeless> ttx: *side* implies no more than half...
20:47:50 <ttx> lifeless: I always have two sides.
20:47:59 <flaper87> ttx: just 2 ?
20:48:04 <ttx> flaper87: sssh
20:48:10 <rockyg> flaper87,  ++
20:48:11 * dhellmann imagines flaper87 as a dodecahedron
20:48:25 <ttx> I can always be convinced by good arguments :)
20:48:29 * rockyg thinks he might be a tesseract
20:48:45 <ttx> one thing is sure flaper87 is always moving
20:48:51 * flaper87 can't even see his sibling side
20:48:55 <flaper87> ttx: lol, that's true
20:48:57 <flaper87> :D
20:48:57 <rockyg> Hence, the name...
20:49:05 * dhellmann wonders how we devolved into discussing the wave/particle duality of flaper87
20:49:06 * flaper87 flaps everywhere
20:49:08 <flaper87> omg, that's bad
20:49:25 <ttx> alright, I guess that's all for today then
20:49:42 <ttx> I'm fine with 11 minutes of my evening back
20:49:51 * flaper87 gives ttx 10
20:49:58 <ttx> Also will use the time to contact a few folkds to advance stalled efforts
20:49:58 <flaper87> there's a 1 min fee
20:50:24 <ttx> Are we done ?
20:50:32 <flaper87> nothing here
20:50:39 <dhellmann> done
20:50:43 <ttx> #endmeeting