20:02:24 <ttx> #startmeeting tc
20:02:25 <openstack> Meeting started Tue Jan 12 20:02:24 2016 UTC and is due to finish in 60 minutes.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:02:26 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:02:28 <ttx> Hi everyone!
20:02:29 <openstack> The meeting name has been set to 'tc'
20:02:32 <russellb> i was talking to mestery, i blame him
20:02:34 <ttx> Our agenda for today:
20:02:39 <ttx> #link https://wiki.openstack.org/wiki/Meetings/TechnicalCommittee
20:02:42 * edleafe lurks suspiciously in the corner...
20:02:59 <thingee> would like to potentially add some more rubber stamp business
20:03:10 <thingee> https://review.openstack.org/#/c/243348/
20:03:12 <ttx> thingee: which ones ?
20:03:13 * mestery watches edleafe from the corner of his eyes
20:03:20 <thingee> and https://review.openstack.org/#/c/236712/
20:03:34 <ttx> thingee: fine by me.. objections ?
20:03:48 <lifeless> well
20:03:55 <lifeless> isn't there a one week thing for all items?
20:04:09 <thingee> things have had a lifespan more than a week
20:04:15 <ttx> cross project ruberstamps are not really TC resolutions
20:04:23 * rockyg peeks out from under a stone
20:04:31 <lifeless> ttx: I am obviously confused :)
20:04:32 <ttx> it's more finally rubberstamping consensus
20:04:42 <jeblair> well, i thought they were
20:04:49 <ttx> lifeless: we don't really vote on them -- we acknowledge existing consensus
20:05:08 <thingee> Everyone, these items have existed more than a week.
20:05:09 <dhellmann> thingee : the second one appears to be in conflict with the first :-)
20:05:14 <ttx> hence the name, rubberstamps
20:05:27 <ttx> thingee: not as a TC meeting agenda item though, so I see what they mean
20:05:34 <thingee> ah true
20:05:41 <lifeless> thingee: the TC meeting protocol specifies a date when things have to be on the agenda
20:05:47 <ttx> I'm fine delaying them until properly added to agenda.
20:05:50 <lifeless> thingee: to let participants have time to read them
20:05:55 <annegentle> lifeless: oh I see
20:06:01 * thingee thinks it would be good if people in the tc are watching the repo regardless of agenda item
20:06:10 <ttx> (or rather, I'm only fine adding them to agenda now if nobody objects, and I  would count this as objection)
20:06:15 <mestery> thingee: Good idea
20:06:15 <annegentle> lifeless: ok, that's a fair point
20:06:49 <ttx> yeah it's a bit late to look into those
20:06:54 <annegentle> ttx: I'd say add to the agenda
20:06:56 <lifeless> separately, I want to drill into this 'not a resolution' thing
20:07:05 <lifeless> because at least jeblair and I thought differently
20:07:11 <lifeless> but we can do that late
20:07:12 <lifeless> later
20:07:21 <ttx> cross project specs are things that PTLs need to agree to
20:07:40 <lifeless> ttx: lets defer to open discussion ?
20:07:45 <ttx> since it's difficult to have voting rules on that, we use the TC to check that consensus is there
20:08:16 <ttx> but we just ack consensus, otherwise our vote is just like someone else's vote. At least that's how we have done it until now
20:08:23 <ttx> ok
20:08:25 <thingee> fine with me. There's an agenda item in the cross-project meeting to talk about getting team consensus.
20:08:27 <dhellmann> I don't see a lot of votes on https://review.openstack.org/#/c/236712/ either, fwiw
20:08:31 <ttx> #topic Rubberstamp cross-project spec: Adds spec for Service Catalog standardization
20:08:36 <ttx> #link https://review.openstack.org/#/c/181393/
20:08:58 <ttx> we have 7
20:09:18 <ttx> so I'll consider it ready for merging unless someone objects
20:09:22 <thingee> dhellmann: I don't see objections currently since it existed oct 18 ;)
20:09:40 <lifeless> I had one concern
20:09:42 <sdague> we've been grinding at this for a long time, hopefully what's there is good for folks
20:09:49 <lifeless> which for some reason was stuck in draft
20:09:55 <lifeless> there's a paragraph that claims to contain a list
20:09:59 <lifeless> but there is no list
20:10:06 <sdague> lifeless: which bit?
20:10:08 <lifeless> so its a little confusing at best
20:10:12 <annegentle> for the service catalog, we've whittled for a while, and I think merging now is the right thing to do, with edits as we go
20:10:20 <lifeless> sdague: line 117
20:10:25 <annegentle> since I dislike sentence frags as much as anyone :)
20:10:30 <lifeless> sdague: the para above which also says 'list of' has an actual list with it
20:11:04 <lifeless> sdague: I don't want to hold it up
20:11:17 <lifeless> sdague: but I'm only +1 while confused, for what thats worth
20:11:21 <sdague> lifeless: so the list in the paragraph above is not the list of things after it
20:11:57 <sdague> It's saying "we'd like to get to having a list of things we need to change" and "here are some guiding principles"
20:12:03 <ttx> ok, lets approve, but maybe queue a clarification
20:12:24 <lifeless> sdague: ok, so yeah - that didn't come through clearly. perhaps a post merge tweak?
20:12:30 <annegentle> lifeless: right, it's saying we'll make a list as a task. but I can see the confusion point, sure
20:12:31 <sdague> because at this point, this document is mostly a statement of priciples and direction. The details have to come out as they come out
20:12:43 <ttx> ok approved
20:12:53 <sdague> lifeless: yeh, I'm so english blind on this spec at this point, if you have better words, please propose
20:12:57 <ttx> post merge tweaks welcome
20:13:01 <sdague> ttx: thanks!
20:13:06 <annegentle> heh me too on english-blind
20:13:07 <lifeless> sdague: I can do that
20:13:16 <ttx> #topic Refactor 4 opens as in Project team guide
20:13:22 <ttx> #link https://review.openstack.org/264127
20:13:34 <ttx> This change is about bringing the version of the 4 opens in the governance up to date with the one in the project team guide
20:13:58 <ttx> we have 7 now, will approve unless someone objects
20:14:24 <ttx> (tl;dr being it is mostly placing "principles" bits in the "open" they actually belong in)
20:14:37 <jeblair> do we have our stance on open core written anywhere else?
20:14:53 <ttx> I don't think so
20:14:58 <annegentle> not that I can think of
20:15:04 <ttx> I mean, we need to retire the wiki version obviously
20:15:16 <ttx> and there is the subsequent change to remove it from PTG
20:15:18 <lifeless> So I'm fine with this tweak
20:15:28 <lifeless> I still want to do something about the open core discussion
20:15:28 <mordred> uhm
20:15:33 <mordred> so - yeah
20:15:37 <ttx> jeblair: but otherwise not that I know of
20:15:38 <mordred> sorry, just read this
20:15:43 <jeblair> i'm worried about approving this now because that effectively means we have repealed our open core stance
20:15:47 <mordred> and the open core thing is vexxing
20:15:49 <mordred> yea
20:15:59 <mordred> that's the main reason I wanted to add this to the governance repo in the first place
20:16:00 <ttx> jeblair: why ?
20:16:01 <lifeless> jeblair: wait, what ?
20:16:09 <ttx> read the first line
20:16:16 <ttx> the end lines that I removed are a duplicate stance
20:16:25 <mordred> OH
20:16:27 <ttx> which do not bring additional info
20:16:27 <lifeless> Am I reading the right diff ?
20:16:32 <sdague> yeh, expand the code
20:16:38 <dhellmann> expand the view so you can see the whole file
20:16:38 <ttx> lifeless: no *they* are reading it wrong.
20:16:38 <sdague> lifeless: it's outside the diff
20:16:44 <mordred> sorry - I was reading out of context - those lines at the bottom are lines that describe "Open Community"
20:16:47 <jeblair> ah that's different; let me put a comment there
20:16:53 <mordred> yeah. thanks
20:17:03 * mordred is bad at reading
20:17:08 <jeblair> me too
20:17:28 <dhellmann> mordred , jeblair : don't feel bad. I commented about an addition that was actually a removal yesterday. Diffs are hard.
20:17:41 <mordred> dhellmann: maybe we could replace them with something more trendy and hipster
20:17:50 <mordred> dhellmann: like emoji or something
20:17:51 <ttx> which is why I want to remove the duplication in the first place :)
20:17:59 <sdague> blockchain emoji
20:18:02 <dhellmann> mordred: needs more social
20:18:04 <mordred> sdague: YES!
20:18:06 <ttx> alright approving now
20:18:08 <annegentle> heh
20:18:15 <mordred> sdague: we should definitely replace diffs with something based on blockchain
20:18:20 <lifeless> is the mission in the foundation docs?
20:18:20 <ttx> #topic Add interop and endusers to OpenStack Mission
20:18:23 <mordred> blockchain is the new docker
20:18:25 <ttx> #link https://review.openstack.org/264135
20:18:32 <ttx> So... this resolution is the first step in the likely long road to updating our mission statement
20:18:39 <ttx> This was introduced by mordred in Tokyo during the joint meeting with the board
20:18:41 <mestery> mordred: lol
20:18:47 <ttx> The goal being to mention "interoperability" and "end users" in the stated goals
20:19:05 <ttx> During that meeting we concluded that the mission statement was sufficiently central to OpenStack that it would be preferable that both the board and the TC agree to the change
20:19:19 <ttx> The first step is to propose a wording, and this is what some of us came up with
20:19:27 <ttx> We tried to be additive, and to minimize the change
20:19:41 <sdague> yeh, seems good to me
20:19:56 <annegentle> especially end users
20:20:02 <ttx> alright, ready to approve unless there are questions
20:20:11 <jeblair> lgtm
20:20:32 <jeblair> annegentle, mordred, ttx: thank you for that! :)
20:20:33 <ttx> good to have lots of votes on this one
20:20:42 <ttx> approved
20:21:08 <ttx> russellb, mordred: could you bring that to the board, or should I ?
20:21:17 <annegentle> now we all should look for 1-2 tasks we can do to advocate for users :)
20:21:32 <russellb> ttx: i can ask for it to be on the next board meeting agenda
20:21:37 <ttx> annegentle: now we can't pretend we didn't know :)
20:21:41 <mordred> ttx: yes, russelb is good at doing things
20:21:49 <ttx> I votes for him.
20:21:51 <annegentle> ttx: heh
20:21:52 <mordred> s/russelb/russellb/
20:21:53 <ttx> and voted too
20:22:03 <ttx> #topic Brainstorming about what the TC would like to see on the "upstream dev" track in Austin
20:22:05 <annegentle> thanks russellb
20:22:06 <russellb> thanks :)
20:22:09 <ttx> #link https://etherpad.openstack.org/p/austin-upstream-dev-track-ideas
20:22:16 <annegentle> so weird to see "in Austin" (just have to say)
20:22:18 <ttx> So.. I hope we'll just have good submissions through the normal CFP process
20:22:27 <ttx> But there may still be things we really want to see covered there
20:22:30 <jeblair> annegentle: they keep it weird there
20:22:36 <ttx> and for which nudging some people to make a proposal could help in getting the right content there
20:22:52 <ttx> let's see what we have
20:23:02 <annegentle> jeblair: so I hear
20:23:11 <annegentle> jeblair: not as weird as portland I also hear
20:23:22 <annegentle> ttx: I added "How do you even doc?"
20:25:05 <mordred> annegentle: I think portland favors strange rather than weird, since they don't like bandwagoning
20:25:11 <annegentle> ha!
20:25:18 <ttx> frankly it all feels like things people would naturally submit... is there any must-have in there for which having a volunteer is absolutely necessary ?
20:25:58 * dhellmann hopes coming up with suggestions wasn't the same as volunteering
20:26:06 <dansmith> mordred: thank you for noticing the difference
20:26:09 <sdague> dhellmann: ++
20:26:19 <annegentle> we do usually find session leaders
20:26:22 <ttx> it is not
20:26:26 <sdague> yeh, I was hoping this was more of a pull than a push honestly at this stage
20:26:43 <ttx> dhellmann: though some suggestions clearly point to someone ;)
20:26:46 <dhellmann> annegentle : these are presentation ideas, though, right? so we need speakers to write talks.
20:27:09 <dhellmann> ttx: I'll work on obfuscating those
20:27:09 <annegentle> dhellmann: yea and they're being recorded so nearly workshoppy if we make the most of videos
20:27:16 <dhellmann> annegentle : ++
20:27:16 <sdague> like we should probably rope dansmith into doing a developing for upgradability talk (like the cp session from last time)
20:27:49 <ttx> sdague: yes we should
20:27:58 <dhellmann> sdague : added as 4.6
20:28:03 <ttx> nudge nudge
20:28:26 <annegentle> I made up workshoppy of course but yes, these need to be polished and re-usable
20:29:53 <ttx> any large development process change that we really need to communicate ?
20:30:01 <ttx> I think the last one was reno
20:30:24 <annegentle> explain release tags?
20:30:33 <annegentle> (I even stumbled on it myself)
20:30:34 <ttx> the CFP-closes-two-months-before-event is going to bite us
20:30:39 <lifeless> I've put it on the etherpad
20:30:48 <lifeless> but I think socialising how to work with DLM's is a thing to do
20:30:57 <dhellmann> annegentle : let's talk offline about what you mean by that, it may be covered by our presentation in tokyo
20:31:08 <annegentle> dhellmann: ok cool
20:31:17 <ttx> dhellmann: which no dev attended
20:31:18 <dhellmann> if I'm wrong, we can add it to the list
20:31:28 <dhellmann> ttx: true, but we can share the link to the video
20:31:34 <ttx> also, cats
20:31:41 <annegentle> lolcats?
20:31:44 <dhellmann> we're not expecting all of them to come to these, are we?
20:31:46 <ttx> just cats
20:32:07 <ttx> dhellmann: no but we are expecting all the attendees to be
20:32:14 <dhellmann> k
20:33:11 <ttx> sdague: what would be the next step with this brainstorming ? keep it live and have it trigger volunteers ?
20:33:26 <ttx> maybe start a -dev thread on it
20:33:31 <sdague> yeh, it's probably worth sharing as a -dev thread
20:33:34 <ttx> I should do that
20:33:42 <fungi> just to clarify, the anticipated audience are mostly not the sort of people who will be in design sessions 100% of the time (currenty active contributors), but rather people with some development background who are attending general conference talks (maybe also new or less active contributors)?
20:33:44 <ttx> explaining what the track is about and all
20:33:46 <annegentle> ttx: I did this one weird trick with grep through months of IRC logs, to see what questions newcomers had, do we have any similar analysis of what devs are asking?
20:33:54 <ttx> fungi: no
20:34:03 <dhellmann> fungi : no, these will not run concurrently with design sessions
20:34:10 <fungi> ohhhh
20:34:14 <fungi> that helps a bunch
20:34:16 <ttx> fungi: it's running on the Monday, when the design summit is not started yet, and is meant for openstack upstream devs
20:34:18 <annegentle> ttx: looking for a data set that's not us, since we're not the intended audience, ya know?
20:34:24 * thingee can volunteer to fill speaker slots
20:34:32 <lifeless> if only I'd pushed through that dev survey
20:34:40 <lifeless> I keep stalling on it :/
20:34:41 <sdague> annegentle: actually, I think the target audience is us
20:34:50 <ttx> yes, all of us
20:34:59 <annegentle> sdague: ok, for leveling up your dev skillz? that sort of thing?
20:35:11 <ttx> annegentle: and learn what you need to learn
20:35:16 <sdague> I feel like this is going to be way more useful if each of us came up with 1 "you know, I really wish I understood X more"
20:35:22 <annegentle> sdague: yeah
20:35:54 <lifeless> sdague: ++
20:35:59 <annegentle> do we have any data on which contributor pages or videos get the most views already?
20:36:13 <ttx> #action ttx to explain on -dev what the track is about and point people to the etherpad
20:36:18 <edleafe> submitted anonymously, since we all know all that stuff already, of course
20:36:20 <sdague> honestly, an overview of the neutron resource model, and what you need to put a thing on the network would be great.
20:36:39 <sdague> edleafe: or we are big enough to admit that we don't know everything
20:37:16 <edleafe> sdague: :)
20:37:40 <anteaya> annegentle: I think that would have to come from jimmy wouldn't it?
20:37:46 <annegentle> ttx: I'll chase the data angle
20:37:59 <ttx> talk about new features in some lib that all projects should probably take advantage of
20:38:00 <annegentle> anteaya: I'll start with a request at the foundation
20:38:01 <ttx> etc
20:38:04 <annegentle> anteaya: who's jimmy?
20:38:07 <fungi> i'm assuming a vulnerability management process presentation would fit best in the cross-project themes section? or is there a better section for horizontal effort presentations?
20:38:16 <anteaya> annegentle: jimmy macarthur
20:38:50 <dhellmann> fungi : that seems like a good place for it
20:39:04 <ttx> fungi: sounds good
20:40:00 <ttx> alright, I'll push that fun page to the rest of the world
20:40:39 <ttx> sdague: you can reply to that and suggest people reply with "one thing that as an upstream dev I would really like to learn more about"
20:40:45 <ttx> since that's a brilliant idea
20:40:48 <sdague> sure
20:41:07 <ttx> should be a mine of presentations ideas
20:41:29 <ttx> alright, lets move on but you can continue on the etherpad
20:41:32 <fungi> hrm... bindep integration in the new developer-facing features that need adoption category or the developer-oriented infra category?
20:41:46 <fungi> meh, i'll just pick one
20:41:49 <ttx> skipping next topic since that was not updated
20:42:14 <ttx> #topic Open discussion
20:42:22 <ttx> gothicmindfood had something to mention
20:42:31 <gothicmindfood> hey everyone!
20:42:33 <lifeless> fungi: either
20:42:37 * mestery waves at gothicmindfood
20:42:42 <ttx> otherwise we can reconsider (again) how we approve cross-project specs
20:43:17 <gothicmindfood> I have a #link https://etherpad.openstack.org/p/Leadershiptraining with some info/thoughts gathered on leadership training
20:43:57 * mordred for one supports his new zingtrain overlords
20:44:10 <mordred> (would be interested in participating)
20:44:14 <gothicmindfood> after asking around for some opinions/thoughts I put together a few ideas, and I'll be sending an email to Mark Collier soon to talk foundation funding
20:44:28 * thingee has a couple of things for opend discussion
20:44:40 <gothicmindfood> I purposely gathered intel/data from folks who had *ahem* diverse opinions on this the last time it was brought up in a meeting
20:45:21 <ttx> I'm fine attending, if I can be available
20:45:34 <gothicmindfood> and that was awesome. So I welcome more thoughts or volunteers who'd be interested in participating
20:45:37 <ttx> sounds like they have an interesting approach
20:45:59 <gothicmindfood> ttx: that, and good food. which is the only reason mordred is interested :)
20:46:03 <mordred> also in favor of sending a team of potentially skeptical scouts to come and report back
20:46:21 <jeblair> mordred: i was thinking you were in the generally skeptical camp last time we talked
20:46:26 <gothicmindfood> yeah - I put that in the etherpad write up, but I want to reiterate: I think the more skeptics that go, the better
20:46:31 <jeblair> mordred: food is sufficient motivation? :)
20:46:36 <mordred> I am - but also the sandwiches are AMAZING
20:46:40 <ttx> jeblair: of course it is
20:46:56 <mordred> and honestly, if I have any amount of skepticism, I'd be a good candidate to give it a try
20:47:00 <ttx> gothicmindfood: ok, keep us posted on where that goes
20:47:05 <gothicmindfood> ttx: will do.
20:47:13 <ttx> back on crossproject stuff...
20:47:22 <ttx> Last time we discussed cross-project spec approval, we said that it required community consensus, and that the most convenient way to acknowledge consensus was to ask the TC members to validate that there was consensus
20:47:27 <lifeless> I'm fine with a or B
20:47:29 <lifeless> I'd like to go
20:47:31 <ttx> Hence the current system - everyone reviews the spec and when there is consensus, we push for a rubberstamping by the tc
20:47:33 <annegentle> gothicmindfood: are there dates yet?
20:47:47 <lifeless> I've seen bad things in the space, but also good stuff, and good can be amazing
20:47:49 <ttx> But I think we have an issue if TC members only look at cross-project specs only once they have reached community consensus
20:47:50 <annegentle> (sorry, had to read then type)
20:48:21 <jeblair> gothicmindfood: as a self-identified skeptic, i appreciate the creative solution you are proposing and the work that must have gone into developing it.  :)
20:48:21 <ttx> because then the current system is broken
20:48:29 <ttx> jeblair: +1
20:50:01 <ttx> jeblair, lifeless: so if you consider your cross-project specs vote is similar to your resolution votes, then we have a problem
20:50:18 <ttx> since you are supposed to have already voted +1 on the spec and use your +2 to say "yes, I see consensus"
20:50:20 <gothicmindfood> annegentle: no dates, unless you look at prescheduled options (option A) - the link I just added shows those. Option B would be on OpenStack's timetable
20:50:44 <lifeless> ttx: is this documented ?
20:50:55 <jeblair> ttx: the thing that caught my eye earlier was the idea that we're not actually voting.  i think we are voting on them to give them the weight of a tc vote.
20:50:56 <lifeless> ttx: like, is there a manual I missed reading?
20:50:57 <thingee> so I'm fine with getting more consensus from ptls or cross-project spec liaisons (https://review.openstack.org/266072) before approaching tc. At some point though, we need to move on though regardless of everyone being attentive.
20:50:57 <annegentle> thanks gothicmindfood
20:51:08 <ttx> lifeless: it was discussed in this meeting
20:51:12 <gothicmindfood> jeblair: thanks! Coming from my favorite skeptic, I appreciate that :)
20:51:22 <ttx> might be documented, let me check
20:51:25 <lifeless> ttx: the TC rotates
20:51:27 <dhellmann> ttx: I agree with jeblair. I thought that once we approved these specs, we backed them up.
20:51:50 <lifeless> yah
20:51:52 <ttx> jeblair: oh, we ARE voting. But before it comes to rubberstamp
20:51:56 <lifeless> so there are multiple layers here
20:52:07 <dhellmann> which is not the same as vote +1 at first and +2 later, which is a confusing process but I guess OK.
20:52:11 <ttx> basically our vote is not a +2, it's the same level as a PTL +1
20:52:20 <lifeless> README.rst in openstack-specs does *not* describe special voting mechanisms or anything
20:52:26 <ttx> PTLs are at least as important than us in getting the spec approved
20:52:36 <jeblair> ttx: how they get on the agenda, and how we go about actually achieving the consensus we desire are not things i have strong opinions on -- only that our vote means it is a real tc vote.
20:52:40 <dhellmann> ttx: probably more, since they have to implement them
20:52:46 <ttx> dhellmann: right
20:52:48 <dhellmann> jeblair : ++
20:52:55 <lifeless> nor does its CONTRIBUTING.rst
20:53:13 <ttx> lifeless: yeah, we may have relied on oral tradition there :/
20:53:20 <dhellmann> ttx: it sounds like we need a TC section in the PTG
20:53:31 <ttx> mostly because the crossproject meeting was just after this one and that's where those were discussed
20:53:33 <dhellmann> or an expanded one, if there is already one
20:53:34 <lifeless> dhellmann: that would be nice as well
20:53:46 <lifeless> but also, repos with different rules should have them locally documented IMO
20:53:47 <ttx> oh well
20:53:54 <ttx> that doesn't solve the issue
20:53:59 <dhellmann> lifeless : true
20:54:10 <ttx> which is TC members should look at those specs earlier
20:54:15 <dhellmann> lifeless : but a "here are your duties" list would be helpful. maybe that should go into the governance repo, though
20:54:18 <ttx> the same way we ask PTLs to look at them
20:54:25 <lifeless> dhellmann: yes
20:54:37 <ttx> if you wait for it to be pushed to the TC agenda, we have an issue
20:54:56 <ttx> since it's not a TC item, it's a crossproject item
20:55:11 <ttx> the only reason it's pushed as a TC item is a technicality
20:55:23 <ttx> to get final rubberstamp on it
20:55:34 <ttx> since we have no other way to "approve" a cross project thing
20:55:59 <lifeless> so
20:56:11 <lifeless> there are two disconnected issues
20:56:19 <lifeless> one is the weird voting setup on the repo
20:56:30 <lifeless> by weird I mean non-standard
20:56:34 <jeblair> whew
20:56:35 <ttx> right
20:56:42 * jeblair sits back down
20:56:54 <lifeless> separately there is 'are tc members not reading cross project specs enough'
20:57:02 <lifeless> I don't know that we have evidence/concerns on that
20:57:18 <lifeless> since jeblair, me and dhellmann seem to be more on the 'if we're voting, we're voting' angle
20:57:28 <lifeless> but ttx seems worried about the 'are folk reading' angle
20:57:40 <dhellmann> lifeless : I'm also worried that folks aren't reading
20:57:47 <lifeless> dhellmann: ack
20:58:31 <dhellmann> not just the TC, though
20:58:43 <ttx> basically we raise those at the TC meeting to give it the final approval push, but lately it felt like that's when TC members start to register objections on them
20:58:52 <ttx> (or others for that matter)
20:59:03 <dhellmann> see https://review.openstack.org/#/c/236712/ for example, which thingee wanted us to consider for approval today but that has a very small number of contributors
20:59:51 <ttx> meaning the "consensus" we are supposedly rubberstamping is not really there yet, and we are having a technical discussion about the spec rather than a social discussion about the presence of consensus
20:59:52 <dhellmann> we're basically in a state where if someone wants to do cross-project work, they already have to be well known and very noisy about it to get anywhere
21:00:06 <dhellmann> which means we're not doing enough to grow leaders within the community
21:00:08 <annegentle> dhellmann: yeah
21:00:09 <ttx> excluding non-TC members from the technical discussion
21:00:25 <ttx> and we are out of time
21:00:31 <ttx> and the cross-project meeting starts :)
21:00:34 <cdent> I think you're getting at some of the fundamental economics of openstack there
21:00:42 <cdent> we're paid
21:00:43 <thingee> I would like to say quickly while I have the tc's attention
21:00:44 <cdent> it make it weird
21:01:15 <thingee> please attend the cross-project meeting to discuss the cross-project spec liaison which aims on getting consensus from each team for spec for approval
21:01:19 <thingee> at least improving it
21:01:19 <annegentle> yes
21:01:21 <annegentle> please
21:01:27 <ttx> I'll be there in a minute
21:01:32 <ttx> closing here first
21:01:35 <ttx> Thanks everyone
21:01:39 * harlowja joined twitter recently to be more noisy
21:01:40 <ttx> #endmeeting