20:01:31 <ttx> #startmeeting tc
20:01:32 <openstack> Meeting started Tue Mar 8 20:01:31 2016 UTC and is due to finish in 60 minutes. The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:01:33 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:01:35 <openstack> The meeting name has been set to 'tc'
20:01:39 <ttx> Hi everyone!
20:01:40 <amrith> ./
20:01:44 <ttx> Our agenda for today:
20:01:46 * edleafe hides in the back of the room
20:01:49 * rockyg is lurking but distracted
20:01:49 <jeblair> o/
20:01:59 <ttx> #link https://wiki.openstack.org/wiki/Meetings/TechnicalCommittee
20:02:10 <ttx> is Piet around
20:02:27 <ttx> he added some topics one week ago
20:02:47 <ttx> hmm.
20:03:22 <ttx> thingee: do you know what he was looking for ? Adding personas and GUI checklist/heuristic to OpenStack Cross-Project Specifications
20:03:45 <thingee> ttx: he's not around, perhaps should start in cross-project.
20:03:47 <flaper87> this is the first time I've seen ttx confused at the beginning of a TC meeting
20:03:57 * flaper87 writes this date down on a diary
20:03:58 <ttx> well, usually the people submitting topics show up
20:03:59 <thingee> ttx: I heard his talk in the product workgroup midcycle
20:04:12 <ttx> hmm, ok. Let's skip
20:04:23 <annegentle> thingee: based on that was TC needed? Or cross project consensus?
20:04:24 <ttx> The second topic kinda requires to have both mordred and lifeless in the room
20:04:41 <ttx> and none of them are
20:04:44 <annegentle> heh
20:04:48 <jeblair> this is going really fast
20:04:53 <ttx> looks like it will be a quick one
20:05:05 <ttx> let's go back to that one if tey show up
20:05:08 <ttx> #topic Review of stale governance changes
20:05:09 * flaper87 opens a new tab and loads netflix^Wgerrit
20:05:18 <ttx> I'll skip the first one since that was for mordred too
20:05:19 <thingee> annegentle: this should be a cross-project discussion
20:05:28 <ttx> * Neutron stadium things
20:05:34 <thingee> annegentle, ttx I'll reach out to piet
20:05:42 <ttx> russellb posted an update on those. These reviews are basically stuck until the start of the next cycle
20:05:42 <flaper87> russellb: thanks for the update! That was useful :)
20:05:51 <ttx> Should I abandon them and ask that people re-propose them once it's ready for consideration ?
20:06:04 <ttx> We usually only keep things that are ready for TC member voting on the slate
20:06:09 <russellb> ttx: i guess so
20:06:12 <flaper87> ttx: +1
20:06:16 <ttx> ok, I will
20:06:25 <ttx> * Split out the amended stackforge resolution (https://review.openstack.org/269862)
20:06:31 <ttx> jeblair: any plans there, or still waiting for more feedback on the initial patchset ?
20:06:32 <armax> russellb: did I miss the upadte?
20:06:52 <ttx> armax: that was a summary for the TC, I tink it was sent to the -tc list in reaction to my agenda item
20:06:53 <russellb> armax: it was by email, just tried to summarize the status, and also indicated that it's on backburner in favor of mitaka release work
20:06:55 <flaper87> armax: trying to find the email link
20:07:01 <russellb> armax: should have CC'd you sorry
20:07:02 <jeblair> 862 is not really a think we're voting on -- it's something we already voted on...
20:07:05 <armax> oh, gotcha, thanks
20:07:07 <sdague> I guess on the general topic of the stadium, is there anything useful that the rest of the TC outside of neutron can do to help move thing along? (either now or in next cycle)
20:07:24 <flaper87> armax: http://lists.openstack.org/pipermail/openstack-tc/2016-March/001139.html
20:07:25 <ttx> jeblair: right, just wondering if I should keep it on the slate
20:07:26 <russellb> sdague: i've been thinking about that, i'm not sure
20:07:26 <armax> russellb: no worries, I am good with abandoning thsose for now
20:07:33 * jeblair waits for neutron discussion to end
20:07:34 <armax> flaper87: thanks
20:07:37 <flaper87> armax: np
20:07:47 <russellb> it's mainly a question of whether there's any general criteria we could write down that could have helped guide this
20:07:49 <ttx> jeblair: or if you wanted to discuss the various suggestions live
20:08:19 <armax> russellb: we’ll get this resolved as soon as I can spare more mental cycles to the matter
20:08:36 <armax> russellb: with your help, of course :)
20:08:37 <russellb> armax: sure, i agree that finalizing mitaka is more important, don't worry about it
20:09:09 <flaper87> ttx: jeblair right, I don't think we need formal vote on that one. Other than making sure the edits are good and annegentle and others are heling with that already
20:09:26 <flaper87> I thought I had reviewed that one, though. I must have forgotten to click "review"
20:09:33 <jeblair> ttx: well, i thought i did what we talked about in the tc meeting, so if we want to change the approach, discussing it here would be good
20:09:38 <flaper87> s/"review"/"post"/
20:09:41 <annegentle> jeblair: I did wonder about "why isn't git history good enough"
20:09:57 <annegentle> but maybe I missed something
20:10:23 <jeblair> annegentle: apparently we as the tc decided it wasn't :) -- i think we decided we'd rather publish resolutions once, as we originally voted on them
20:10:34 <annegentle> jeblair: ah, voting. ok
20:10:44 <jeblair> annegentle: so, contrary to reference documentation, resolutions should be considered immutable
20:11:12 <ttx> jeblair: yeah, the remaining question is how do we make sure the end result is not confusing to the reader, and this is why I suggested moving the original resolution to a subdirectory
20:11:21 <jeblair> so i guess the "big" question is whether we should do the approach in that change, or whether we should do what ttx suggests ^
20:11:40 <jeblair> i don't object to that; if folks like it, i can re-propose with that change
20:11:45 <ttx> the doc build is no longer live, but I remember the published result was pretty confusing
20:11:55 <flaper87> tbh, I don't think jeblair patch is confusing
20:12:18 <jeblair> the original does link to the updated one, so hopefully you end up at the right place regardless
20:12:18 <ttx> flaper87: that's because you haven't seen the governance.openstack.org result
20:12:19 <flaper87> I'm happy with it. It keeps things in one dir and they are sorted by date anyway so, I'm good
20:12:36 <flaper87> ttx: oh, mmh. you got me there
20:12:49 <jeblair> recheck coming up :)
20:12:57 <ttx> yep
20:13:00 <annegentle> ok
20:13:08 <ttx> recheck recheck
20:13:19 * flaper87 rechecks ttx's recheck
20:13:35 <ttx> let's move on to open discussion in the mean time ?
20:13:44 <ttx> We can discuss best form in open discussion anyway
20:14:03 <jeblair> yeah, folks just let me know which style you prefer :)
20:14:04 <flaper87> sure
20:14:10 <ttx> As far as the topic goes, I think this one shouldn't be abandoned
20:14:12 <jeblair> happy to oblige, just don't want to do it too many times :)
20:14:18 <ttx> #topic Open discussion
20:14:22 <ttx> * Election season coming up
20:14:27 <ttx> Election officials kicked off the election season:
20:14:33 <ttx> #link http://lists.openstack.org/pipermail/openstack-dev/2016-March/088558.html
20:14:34 <flaper87> YAY!
20:14:38 <ttx> I can't believe it's been 6 months since the last elections. Those sure passed by fast
20:14:46 <ttx> On the TC side, 7 seats are renewed (jeblair, lifeless, flaper87, markmcclain, jaypipes, dtroyer and myself)
20:14:57 <ttx> jeblair: you wanted to add something ?
20:14:59 <russellb> can't believe it?
20:15:02 <russellb> feels like elections never end
20:15:09 <flaper87> russellb: lol
20:15:27 <jaypipes> is anyone *not* running again?
20:16:03 * jaypipes promises to build a wall between OpenStack and AWS and have Amazon pay for it.
20:16:10 <flaper87> jaypipes: does that answer your question?
20:16:14 <flaper87> :D
20:16:18 <jaypipes> flaper87: heh, yep :)
20:16:20 <dims> lol
20:16:24 <jeblair> i'd like to bring the tc's attention to this spec: https://review.openstack.org/287577
20:16:34 <jeblair> it was brought up in the infra meeting today
20:16:41 <markmcclain> jaypipes: are you going to insist that all design sessions start with a pledge to openstack?
20:16:45 <jeblair> i think it's fairly simple and straightforward, and it's a good idea
20:16:54 <jaypipes> markmcclain: but of course.
20:17:04 <flaper87> jaypipes: will take a look. Thanks for the heads up!
20:17:07 <russellb> jeblair: seems sane
20:17:09 <sdague> jeblair: will it make it in time for this go around?
20:17:15 <sdague> or is this longer term
20:17:15 <annegentle> I think we shouldn't need another subdomain and governance should suffice
20:17:21 <jeblair> but i do think it would be good for the tc to ack it, as well as provide feedback on whether we should host it under governance.o.o
20:17:33 <jaypipes> jeblair: ++
20:17:36 <jaypipes> will check into it.
20:17:36 <ttx> jeblair: I'm good with it being under governance
20:17:44 <russellb> under governance sounds fine to me.
20:17:46 <ttx> elections are a by-product of our charter anyway
20:17:51 <flaper87> under governance ++
20:17:51 <sdague> I'm fine either way
20:18:02 <fungi> yeah, governance site feels like the right place for election details, but i don't want us to put content there which isn't directly controlled by the tc without some consensus
20:18:03 <ttx> and election officials run them under formal delegation from the TC
20:18:05 <sdague> top level makes it a bit more visible
20:18:12 <sdague> and there were concerns on turnout
20:18:21 <flaper87> It's already confusing to have the many subdomains we have now. IF we can have it under governance, let's do that
20:18:22 <ttx> fungi: if it's a subdir it sounds fine
20:18:41 <ttx> then it's clear where the delegation ends
20:18:52 <dhellmann> we would have to make sure we don't ever add that same subdir to the existing governance repo, or we'd compete with patches publishing to the location
20:18:57 <fungi> it's trivial enough to graft a publication tree into a subtree of that site. just a line in the vhost config
20:19:29 <jeblair> sdague: i'm not sure we got a firm conclusion on whether we should push for it this cycle (time is short), but it doesn't affect the actual process too much, so we should be able to start using it mid-election even, but we don't want to confuse people. we might compromise on a soft-launch this cycle.
20:19:30 <fungi> dhellmann: nah, it would just get shadowed by the election tree if you did it the way i mentioned, but implementation details anyway
20:19:57 <dhellmann> fungi : sure, either way we have a potential for overlap. not a big deal, but something to be aware of
20:20:04 <fungi> yep!
20:20:07 <sdague> jeblair: yeh, if it's not going to hit before the elections start, seems best to soft launch and not really talk about it until next time
20:20:14 <ttx> jeblair, fungi: have enough to proceed ?
20:20:16 <annegentle> agreed on soft launch
20:20:19 <tonyb> if we use g.o.o would there be links between the rc content and the election content?
20:20:21 <sdague> just to prevent confusion
20:20:27 <dhellmann> tonyb : we could add those
20:20:35 <tonyb> that's the part I thought would be hard ...
20:20:40 <dhellmann> tonyb : either to the header, or inline where appropriate, or both. I can work with you on that.
20:20:55 <tonyb> dhellmann: okay thanks.
20:20:55 <fungi> hyperlinks are simple. html borrowed them from gopher anyway ;)
20:21:03 <annegentle> fungi: ha
20:21:26 <ttx> * Leadership training
20:21:37 <ttx> gothicmindfood posted an update on that
20:21:42 <ttx> #link http://lists.openstack.org/pipermail/openstack-dev/2016-March/088646.html
20:21:47 <ttx> Looks like the 'not two consecutive weeks' camp won against the 'not two US travels' camp
20:22:08 <ttx> she is looking into other dates
20:22:20 <flaper87> plus, some of us were already booked before the announcement of the dates went out
20:22:22 <ttx> comments/remarks ?
20:22:27 <annegentle> heh I was the only one who lives in Austin :)
20:22:27 <flaper87> I think that's great
20:22:39 <dhellmann> do we have a set of goals for this trip?
20:22:52 <gothicmindfood> oh hai. Most people seem pretty cool with June 28/29th
20:22:55 <ttx> dhellmann: I think colette described the goals well
20:23:07 <gothicmindfood> so - just fyi to everyone - that's what I'm going to look into and confirm via ML in the next couple days
20:23:07 <jeblair> something about sandwiches iirc
20:23:09 <dhellmann> ok, I'm probably behind on email, I'll look for that
20:23:11 <flaper87> my only recommendation so far is to not do it in the west coast
20:23:16 <gothicmindfood> jeblair: definitely sandwiches
20:23:21 <gothicmindfood> flaper87: it will be in Ann Arbor, Michigan
20:23:26 <sdague> flaper87: it's in Ann Arbor
20:23:28 <flaper87> it's way too far and expensive for a 2 days trip
20:23:29 <ttx> I'm still skeptical of leadership training, but she managed to turn that into a reason why I should go
20:23:30 <gothicmindfood> unless someone strongly objects to delicious sandwiches.
20:23:31 <flaper87> gothicmindfood: ++
20:23:32 <flaper87> w00h00
20:23:52 <jeblair> ttx: she must have taken the course already :)
20:23:52 <flaper87> I think I didn't read the location on the email (or wherever it was announced) :D
20:23:54 <gothicmindfood> ttx: my ninja-psychology is strong this month. :)
20:24:10 <ttx> gothicmindfood: more like judo
20:24:14 <russellb> flaper87: a leader would have read it
20:24:26 <flaper87> I *have* to go then
20:24:28 <ttx> alright, next up
20:24:29 <flaper87> totally
20:24:35 * flaper87 can't miss that training
20:24:36 <ttx> mtreinish: you had something to mention ?
20:24:42 <mriedem> so the leadership training is for TC members? what about those not on the TC?
20:24:44 <ttx> flaper87: you need more leader foo
20:24:50 <mtreinish> ttx: yeah
20:25:03 <russellb> mriedem: thanks for bringing that up. gothicmindfood ^^^ i got that question as well
20:25:18 <mtreinish> ttx: I wanted to bring up that in investigating the stable breakages on trove with mriedem we found that they don't really comply with the standard testing interface
20:25:20 <mriedem> i don't mind being a drone, but
20:25:30 <ttx> mriedem: yeah, I'm not sold on that too. I think we should grow the next generation of leaders rather than camping on the existing ones
20:25:34 <mtreinish> and also workaround things like global requirements as it suits their needs
20:25:35 <mriedem> mtreinish: way to bring me into this...
20:25:42 <annegentle> ttx: agree
20:25:48 <jeblair> oh dear
20:26:02 <flaper87> mtreinish: o.0
20:26:03 <ttx> mriedem, annegentle: but then it's the first editoin and it's more of a test balloon
20:26:09 <anteaya> mtreinish: thanks for bringing your discovery to the tc
20:26:11 <mtreinish> and this has been an issue for quite some time
20:26:11 <flaper87> mriedem: do you have links to that? I know there's a thread on the m-l
20:26:19 <flaper87> erm, mtreinish ^
20:26:24 <mtreinish> mriedem: heh, I couldn't not drag you in
20:26:27 <gothicmindfood> mriedem: it initially, just because of scope, is meant for the TC/members of the board. but if we have extra space, I will definitely let the ML know and ask if anyone else wants to sign up!
20:26:29 <carolbarrett> ttx: we need to do both.
20:26:47 <ttx> hmm, let's focus on trove now please
20:26:50 <mtreinish> flaper87: https://github.com/openstack/trove/blob/master/tox.ini#L12-L16
20:27:01 <russellb> oh dear
20:27:04 <flaper87> gothicmindfood: just *active* members or are we going to include previous members too?
20:27:10 <ttx> I'd suggest discussing the scope of leadership training on colette's ML thread
20:27:14 <amrith> what about trove ;)
20:27:16 <gothicmindfood> mriedem: it's definitely meant as a first step towards 'doing leadership' for the whole community, so it's not meant to be exclusive, just meant to be a place to start
20:27:31 <flaper87> gothicmindfood: I mean, members up for election in 2 weeks
20:27:51 <russellb> flaper87: active and previous i believe
20:28:00 <flaper87> russellb: don't tell me it was on the email
20:28:02 <jeblair> gothicmindfood did answer all of these questions in her excellent email :)
20:28:02 <flaper87> hahahhaha
20:28:05 <gothicmindfood> flaper87: because we're straddling elections with this discussion, and we ostensibly have room for TC+others, it's been basically a given that current TC + future elected TC who are available and interested would be invited
20:28:09 <russellb> flaper87: it was.
20:28:23 <anteaya> mtreinish: that is concerning
20:28:24 * flaper87 -> head -> desk
20:28:30 <flaper87> mtreinish: thanks for bringing that up
20:28:33 <dhellmann> amrith : trove is using a version of pymongo not listed in global requirements, can you fix that?
20:28:49 <amrith> dhellmann, I can certainly fix that
20:29:06 <dhellmann> amrith : there's a custom install line in the tox.ini
20:29:07 <cdent> Is following global requirements a requirement?
20:29:17 <amrith> I'm more concerned with some of the 'broad and sweeping' statements that I've heard today about trove.
20:29:18 <flaper87> amrith: and, please, in the future let's not do that again.
20:29:24 <dhellmann> mtreinish : was there anything else?
20:29:26 <ttx> mtreinish: what other kinds of violations of the project testing interface did you find ?
20:29:27 <flaper87> cdent: it is if you're part of the big tent
20:29:34 <dhellmann> cdent : it is for projects that claim to sync requirements
20:29:37 <amrith> so I'd like to be more precise.
20:29:45 <mtreinish> besides the fact that it's really a functional test job, a unit test job, and a sample updater in one tox job (which is just confusing) the functional tests don't conform to the standard testing interface
20:29:47 <amrith> flaper87, do what?
20:29:49 <mriedem> trove's test-requirements also uses the troveclient tarball
20:29:57 <flaper87> cdent: dhellmann was more precise than I was
20:29:58 <mtreinish> they don't run with testr or emit subunit (which iirc was part of that doc)
20:30:24 <ttx> ew
20:30:28 <dhellmann> mtreinish : have you raised this with the trove team already?
20:30:34 <flaper87> amrith: sorry for being vague. I meant to say that it's not recommended adding pip install calls to tox.ini. It'd be great if you could bring this feedback to the trove team
20:30:38 <mriedem> testing with trunk clients (unreleased) on stable branch has bit us in the past
20:30:53 <mriedem> and is biting us right now actually
20:30:56 <mriedem> which is why this was coming up
20:30:58 <mtreinish> mriedem: yeah there's that too, which is just kinda weird
20:31:10 <sdague> fwiw - this is where that was landed - 4 months ago - https://review.openstack.org/#/c/241754/
20:31:20 <mtreinish> dhellmann: not recently, I just found it today
20:31:24 <amrith> mriedem, I understand some of what you are saying
20:31:33 <mtreinish> dhellmann: but digging through history this has been a known thing for some time
20:31:33 <amrith> but you'll also recall that on 2/5 I asked of the community http://openstack.markmail.org/thread/tmy2dema4baoulif
20:31:47 <amrith> in regards to the bug we've been discussing today
20:31:48 <mtreinish> dhellmann: like https://review.openstack.org/#/c/54436/
20:31:57 <fungi> for clarity, keeping your deliverable repos in sync with openstack/requirements is not strictly a qualifier for inclusion in the big tent, though it is important to, e.g., repos which need care from other cross-project teams who expect some degree of standardization
20:32:18 <amrith> so, I'm happy to do whatever it takes to make progress but let's be more precise and avoid sweeping generalizations please.
20:32:31 <amrith> dhellmann, I will push up a change to add pymongo to global requirements.
20:32:34 <anteaya> the trove ptl is cp16net
20:32:38 <anteaya> is that person around?
20:32:43 <mriedem> amrith: pymongo is in g-r
20:32:49 <ttx> looks like we need to come up with a clear set of things that should be changed
20:32:51 <amrith> anteaya, cp16net has been off on vacation for some weeks
20:32:53 <mriedem> it's just not blacklisting or capping whatever version breaks trove
20:32:55 <dhellmann> anteaya : I think amrith is filling in temporarily
20:33:07 <mtreinish> fungi: I think it's more problematic if you say you subscribe to and respect g-r and then you don't
20:33:10 <amrith> so I'm trying to catch a large number of balls that are in the air.
20:33:17 <fungi> mtreinish: yep
20:33:19 <anteaya> amrith: oh do you have an idea of when they will return?
20:33:22 <anteaya> dhellmann: thank you
20:33:31 <amrith> anteaya, no I don't.
20:33:37 <anteaya> hmmmm
20:33:40 <flaper87> amrith: thanks for filling in for cp16net and attending the meeting
20:34:26 <amrith> to be clear, the issue that mriedem and I are discussing is not "broken backward compatibility" but rather tests in liberty that are broken in a way that just needs fixing. Tests, not code that customers would use.
20:34:33 <amrith> there's an ML discussion about this
20:34:37 <amrith> a change has been proposed.
20:34:40 <mriedem> amrith: that's not accurate
20:34:46 <amrith> ok, mriedem
20:34:49 <amrith> let's discuss it
20:34:49 <mriedem> the tests are using troveclient as a user would,
20:34:55 <mriedem> to create an instance
20:35:01 <jeblair> we only recently started adding anything to the pti about openstack/requirements, and that was in relation to constraints. we may want to elaborate a bit more in that document.
20:35:06 <mriedem> it uses a kwarg in the troveclient api that was removed in master troveclient
20:35:08 <mriedem> which breaks stable
20:35:11 <fungi> for the record, it looks like this was added 4 months ago as a workaround https://review.openstack.org/241754
20:35:34 <mriedem> so yes, the tests are busted, but they are busted b/c a deprecated kwarg was removed from troveclient 2.1.0
20:35:35 <amrith> mriedem, removing the argument in master is fine, I believe
20:35:39 <mriedem> well,
20:35:46 <mriedem> it's fine if you're not following backward compat
20:35:47 <anteaya> fungi: sdague had linked to that in backscroll
20:35:49 <fungi> they seem to be pinning things in tox.ini instead of requirements lists (and getting them into global requirements)
20:35:55 <amrith> mriedem, that's not helpful.
20:36:04 <fungi> ahh, i missed sdague's link. sorry!
20:36:06 <mriedem> specifically, a spec that lifeless has for backward compat
20:36:22 <clarkb> mriedem: amrith you also need to use semver
20:36:25 <mriedem> amrith: basically, the idea being clients and libs are backward compat until the oldest stable branch that uses them are still around
20:36:26 <sdague> troveclient 2.1.0 was also a semver failure
20:36:31 <mriedem> yes, that too
20:36:37 <sdague> but semver wouldn't have helped here anyway
20:36:40 <mriedem> nope
20:36:49 <mriedem> constraints would have, but trove unit tests don't use constraints on liberty
20:37:01 <amrith> sdague, what is semver and is that part of the solution or just something tangential?
20:37:11 <dims> amrith : https://review.openstack.org/#/c/226157/ - details here
20:37:30 <amrith> mriedem, please put your comments in review https://review.openstack.org/#/c/290069/
20:37:39 <fungi> so on 241754 i'm curious why there was a delay in getting a pin updated in global requirements. it seems that was acknowledged as a challenge in the review comments
20:37:55 <amrith> and please, I am trying to get caught up on what is going on so being cryptic and terse is not going to help me do anything
20:38:18 <anteaya> you have a whole channel of people trying to help you
20:38:32 <anteaya> perhaps you can express some gratitude to them
20:38:32 <amrith> anteaya, and I'm happy to take any and all help.
20:38:36 <dhellmann> amrith : semver is "semantic versioning" and is a way of choosing version numbers to signal the nature of the changes in the release. http://docs.openstack.org/developer/pbr/semver.html
20:38:37 <mriedem> yeah i'm not trying to be terse, i've given a few options today and spend most of my day on unwinding this
20:38:40 <amrith> I have a review https://review.openstack.org/#/c/290069/
20:38:41 <ttx> amrith: semver = major.minor.patch versioning.
20:38:47 <amrith> which I would appreciate comments in.
20:38:57 <ttx> if you break backward compat you should increment major
20:39:01 <dhellmann> amrith : that wouldn't really fix the problem, but you should become familiar with that anyway
20:39:16 <fungi> i'd certainly like to figure out what challenges projects are encountering getting global requirements updates approved and propagated in a timely fashion. that the workaround got left on the project for months thereafter is a bit secondary i think
20:39:44 <mriedem> i don't really know what our goal here is for the tc meeting
20:39:49 <dims> agree fungi
20:39:51 <amrith> anteaya, I would love for some feedback on my ML request (for help) http://openstack.markmail.org/thread/tmy2dema4baoulif
20:39:52 <russellb> i was wonder that myself, mriedem
20:39:55 <flaper87> mriedem: I was about to say that
20:40:01 <ttx> OK, so it looks like there are a number of things that should definitely be changed, in Trove's code and practices. Is there reason to believe any of those changes are impossible ?
20:40:02 <mriedem> personally, as of this morning, i wanted to either cap troveclient in liberty or revert the backward incompat change https://review.openstack.org/#/c/290048/
20:40:04 <russellb> sounds like issues have been raised, amrith and trove team need some time to respond and address
20:40:09 <amrith> thanks, I just saw a mention of "trove" so my ears perked up.
20:40:09 <flaper87> I see amrith is trying to catch up with the issue and working on a way to fix it
20:40:27 <flaper87> so, I'd say let's give him and the trove team enough time to work on the fix
20:40:37 <amrith> flaper87, thank you
20:40:38 <mriedem> well, there are fixes posted,
20:40:46 <mriedem> it's a question of what's appropriate for end users
20:40:53 <mriedem> but that can happen in gerrit
20:40:54 <flaper87> I'm sure we can follow up on the mailing list and trove's channel if they need more support
20:41:01 <dhellmann> it would be useful to have a list, maybe mtreinish and mriedem can put together an etherpad or something to help amrithwith tracking
20:41:10 <amrith> dhellmann, ++
20:41:14 <ttx> mriedem: now if there is resistance in fixing the issues, I think we should definitely intervene
20:41:14 <mriedem> it's in the ML
20:41:23 <flaper87> amrith: no, thank you for bearing with us
20:41:23 <dhellmann> mriedem : ok, that works, too
20:41:25 <russellb> ttx: ++
20:41:37 <mriedem> #link http://lists.openstack.org/pipermail/openstack-dev/2016-March/088689.html
20:41:39 <amrith> and while we're on the subject, dhellmann ttx we need to also discuss another python-toveclient for the FFE
20:41:51 <dhellmann> amrith : we can take that out of this meeting
20:41:51 <amrith> we could, maybe, roll all of these into one resolution.
20:41:54 <mtreinish> mriedem: well parts are in the ML. Some of the issues I was raising weren't
20:41:56 <amrith> dims, thanks for the link.
20:42:10 <amrith> dhellmann, for now, one request
20:42:14 <amrith> what do you want re: pymongo?
20:42:22 <amrith> I see https://github.com/openstack/trove/blob/master/tox.ini#L12-L16
20:42:24 <dhellmann> amrith : use the version listed in the global requirements repo
20:42:38 <mriedem> we can sort this out in -dev
20:42:40 <dhellmann> amrith : and declare that you're using that version in the standard requirement list files
20:42:43 <mriedem> i don't want to derail the tc meeting
20:43:02 <dhellmann> mtreinish : if you could follow up to the list with the rest of the issues, that would help
20:43:15 <anteaya> mriedem: according to the agenda, the agenda had been addressed prior to this item
20:43:23 <amrith> ok, thx dhellmann
20:43:26 <mtreinish> dhellmann: well I don't like that because it requires me to do something :) But, sure I can follow up on the ml
20:43:39 <mriedem> mtreinish: you dealt it
20:43:40 <ttx> yep, let's bring discussion of the issues to -dev and -release. The Tc is now aware of the issues and will follow up on the resolution
20:44:14 <ttx> #action ttx to put trove issues and status update on the agenda for next meeting
20:44:57 <dhellmann> mtreinish : yeah, if you show up here asking for action, be prepared with documentation :-)
20:44:58 <sdague> there is kind of a meta issue right, if a project core team isn't up on what it means to work on things in an openstack way, and it has to be caught outside and unwound outside of that team, we've got a bigger issue
20:45:21 <sdague> especially because there is a very finite amount of global catchers time
20:45:26 <anteaya> sdague: ++
20:45:38 <dhellmann> sdague : Yes, clearly the trove liaisons need to become more active in their respective roles.
20:45:41 <russellb> depends if the issue is with trove, or that it's hard to keep up with and understand "openstack ways"
20:45:45 <mriedem> global catchers are like, leaders right? :)
20:45:46 <flaper87> sdague: I'd rather assume good faith
20:45:50 <ttx> also wondering about the PTl situation there
20:45:56 <sdague> flaper87: I'm not assuming bad faith
20:45:58 <anteaya> mriedem: ha ha ha
20:46:03 <edleafe> mriedem: heh
20:46:07 <flaper87> sdague: sorry, misread you then!
20:46:13 <sdague> I'm saying it's a problem that there ever was a disconnect here
20:46:25 <sdague> that 2 core reviewers every thought the pymongo pin was a thing
20:46:30 <flaper87> sdague: that I agree with
20:46:33 <ttx> if a PTL can go off the map without anyone knowing when he will likely be back, around release time...
20:47:05 <ttx> that's a bit of a concern
20:47:16 <sdague> sure. We just have to be very careful about deciding that it is mriedem and mtreinish's job to build a detailed fix plan for projects because they found issues
20:47:18 <russellb> could be a very good reason ... emergencies happen
20:47:27 <dhellmann> sdague : I'm asking for a list of issues, not fixes
20:47:29 <sdague> because if that's the case, then people will stop raising issues that they find
20:47:30 <mriedem> sdague: yeah...
20:47:39 <sdague> because they don't want to have to own fixing it
20:47:52 <anteaya> sdague: good point
20:47:58 <dhellmann> otoh, you can't just show up here in a TC meeting complaining about a project and not expect anyone to ask for details
20:47:58 <amrith> ttx, I understand that he let TC know.
20:48:03 <russellb> ttx: sounds worth following up on
20:48:09 <amrith> the reasons he's not here are likely not worth airing on IRC
20:48:13 <anteaya> amrith: do you know when or how?
20:48:16 <amrith> but I assumed y'all knoew abotu it.
20:48:17 <fungi> well, in the change which introduced it, the first patchset added it to the requirements list, but a (non-core) reviewer suggested putting it in tox.ini instead, rather than pointing out that there should be a change proposed to openstack/requirements
20:48:23 <amrith> when/how what?
20:48:35 <mtreinish> dhellmann: did I not provide details?
20:48:36 <anteaya> when the trove ptl communicated wtih the tc
20:48:38 <ttx> sdague: right, a lot is about education. The Project team guide helps, the Upstream dev track should help too
20:48:40 <mriedem> fwiw, cp16net has been one of the only people helping with stable branch issues on trove,
20:48:44 <mriedem> so i've appreciated his work there
20:48:46 <amrith> anteaya, I don't know
20:48:47 <mriedem> i didn't realize ht was out
20:48:50 <mriedem> *he
20:48:52 <dhellmann> mtreinish : I was responding to sdague, I think you're fine but a summary would be useful
20:48:52 <amrith> maybe a couple of weeks ago
20:49:00 <ttx> but there will always be siloed teams doing their own thing thinking it's great
20:49:18 <amrith> mriedem, I thought I was helping today
20:49:20 <mriedem> also, if you're not part of gate-tempest-dsvm-full, these things happen in satellite projects
20:49:21 <amrith> with stable?
20:49:27 <fungi> oh, wait, worse, the suggestion to just put it in the tox.ini did indeed come from a trove-core reviewer
20:49:34 <mriedem> amrith: yes, you are after i started the fire alarm :)
20:49:41 <anteaya> mriedem: good to know he has been helpful to the stable team
20:50:10 <ttx> amrith: I don't know anything about it... but maybe others do
20:50:52 <anteaya> fungi: the owner of 241754 is the trove ptl
20:50:57 <fungi> anteaya: yep
20:51:15 <fungi> i'm still hunting for the corresponding global requirements change
20:51:17 <dhellmann> ttx: I knew cp16net would be out, and amrith was filling in for their release, but I don't think I know the dates (if I do, I don't remember them)
20:51:22 <flaper87> I'll try this again. I think the trove issue is going to be handled and we can follow up on that next week. If we want to discuss the "why" this happened, lets try to gather some more data and come with a better analysis and try to find a solution rather than wasting our time trying to find who we should blame
20:51:36 <cdent> flaper87++
20:51:42 <anteaya> flaper87: I don't think we are looking for blame
20:51:44 <fungi> i'm more interested in finding out what we should blame
20:51:57 <dhellmann> yeah, I'm not sure doing this live in this meeting is the best way to handle it
20:51:57 <ttx> ack
20:51:58 <anteaya> if anything we haven't clearly communicated as a team, so that's on us
20:52:03 <flaper87> anteaya: well, unless I'm reading all the messages wrong, that's my impression
20:52:08 <anteaya> we are trying to understand what happened and when
20:52:18 <ttx> I think the topic is closed for this week and we'll follow up on progress on fixes next week
20:52:22 <anteaya> flaper87: that's fine if that is your impression but that is not my motivation
20:52:33 <ttx> was there anythig else that people wanted to raise for open discussion ?
20:52:41 <amrith> flaper87, thank you.
20:53:30 <ttx> still no piet, no mordred and no lifeless, so the skipped topics will stay skipped
20:53:40 <piet> Hey!
20:53:45 <ttx> hey!
20:53:51 * dhellmann notes the time
20:53:54 <ttx> #topic UX: Adding personas and GUI checklist/heuristic to OpenStack Cross-Project Specifications (piet)
20:54:03 <ttx> piet: what did you want to propose there ?
20:54:16 <ttx> in 5 minutes ?
20:54:35 <piet> I wanted to throw out that we are working on a personas doc for the community
20:55:01 <piet> Still some discussion on how it relates to the x-project doc for roles
20:55:19 <piet> And where the docs should live
20:55:25 <piet> Thoughts/suggestions are welcome
20:55:38 <ttx> you mentioned cross-project specs, too ?
20:56:04 <ttx> maybe post links to those on the ML, and we could find a home for them ?
20:56:10 <piet> Sure, but felt like I was getting ahead of myself. It might be, but would like to defer to the TC
20:56:10 <anteaya> who is the target audience for consuming the personas doc?
20:56:14 <dhellmann> piet: docs.openstack.org/developer/$reponame ?
20:56:50 <piet> anteaya Product WG, Foundation and the individual projects
20:56:56 <anteaya> thank you
20:57:09 <piet> Want to pick-up next week?
20:57:27 <russellb> some kind of written proposal would be helpful
20:57:33 <ttx> piet: I would rather start with a ML thread, then engage with the cross-project specs group (led by thingee)
20:57:43 <piet> Kk
20:57:51 <ttx> not sure if the TC would have to get involved (I prefer we stay out of the way whenever possible)
20:58:20 <piet> Yeah, but need to let ya'll know what coming down the road
20:58:33 <ttx> It's good! Looking forward to your talk btw
20:58:53 <piet> We're also working on a spec on trying to drive consistency in anything with a GUI
20:59:14 <ttx> piet: that would be a classic cross-project spec ?
20:59:26 <thingee> piet: engaging with the TC is getting a bit ahead. a lot of stuff like this starts with cross-project consensus so the TC can have better feedback
20:59:40 <thingee> better feedback/informed
20:59:55 <piet> thingee I'll reach-out to you later to discuss
21:00:06 <ttx> alright, anything else, anyone ?
21:00:19 <ttx> we are out of time anyway
21:00:23 <ttx> #endmeeting