20:01:45 <ttx> #startmeeting tc
20:01:46 * mestery consoles edleafe
20:01:46 <openstack> Meeting started Tue Apr 12 20:01:45 2016 UTC and is due to finish in 60 minutes.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:01:47 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:01:49 <openstack> The meeting name has been set to 'tc'
20:01:52 <mordred> ttx: sup?
20:02:00 <ttx> Welcome to the Newton membership !
20:02:14 * mordred looks around and is scared by all the new faces
20:02:22 <ttx> dims, mtreinish, morgan, thingee: welcome
20:02:28 <agentle> mordred: they're not that new :)
20:02:31 <ttx> This is the agenda for our first meeting:
20:02:34 <morgan> ^_^
20:02:34 <dims> thanks ttx
20:02:35 <ttx> #link https://wiki.openstack.org/wiki/Meetings/TechnicalCommittee
20:02:36 <mordred> agentle: inorite?
20:02:36 <mtreinish> ttx: thanks
20:02:43 <ttx> #topic Welcome Newton TC members
20:02:47 <russellb> have you told them about the initiation ritutal yet?
20:02:50 <russellb> or is that a surprise?
20:02:53 <ttx> surprise
20:02:53 <thingee> mordred: you're no longer the only one sitting up front with blue hair.
20:02:58 <ttx> * Update member roster
20:03:00 <mordred> thingee: WOOT
20:03:06 <ttx> I did update voting rights in Gerrit and the -tc ML moderation bits
20:03:14 <ttx> We just need to approve the new roster, which was +1ed by election officials
20:03:18 <ttx> #link https://review.openstack.org/303119
20:03:23 <mordred> thingee: the hair-posse has doubled in size (and tripled in awesome)
20:03:46 <edleafe> no wonder jay left
20:03:47 <ttx> if anyone else wants to boost their +2 stats before I approve
20:03:49 <mordred> ttx: what happens if we do not approve it?
20:03:58 <ttx> mordred: then I approve it
20:04:07 <morgan> ttx: hehe all about the boosting of +2 stats
20:04:09 <russellb> we're all about gaming governance voting stats, huh?
20:04:10 <sdague> and we kick you off the island
20:04:13 <morgan> russellb: totally
20:04:14 <mordred> ttx: I was wondering if it was lke the US Debt Ceiling or something
20:04:21 <mestery> russellb: It's in our DNA
20:04:21 <dims> :)
20:04:27 <ttx> alright it's in
20:04:32 <ttx> * Select chair
20:04:40 <ttx> The chair is responsible for making sure meetings are held (and decisions made) following our charter rules
20:04:49 <ttx> I'll be happy to continue to serve as the guardian of the rules and meeting organizer
20:04:55 <agentle> hurrah ttx
20:04:57 <ttx> If another member is interested in such duties they should file a change similar to https://review.openstack.org/303308
20:04:57 <sdague> ++
20:05:02 <morgan> ++
20:05:03 <mestery> yay for ttx!
20:05:03 <jaypipes> edleafe: :)
20:05:08 <ttx> If nobody else is interested, we should just approve https://review.openstack.org/303308
20:05:16 <flaper87> o/
20:05:18 <edleafe> ttx 4ever!
20:05:41 <ttx> Alright
20:05:42 <dims> ++ttx
20:05:46 <ttx> Thanks everyone !
20:05:54 <ttx> * Confirmation of change approval rules & agenda buildup process
20:06:03 <ttx> Next in the boring things we need to cover today...
20:06:10 * mordred puts on boring hat
20:06:12 <ttx> Quick reminder of the rules we followed in Mitaka to build agenda and approve governance changes
20:06:14 <russellb> thanks for all you do, ttx.
20:06:18 * flaper87 steals mordred's hat
20:06:24 * mordred puts on flaper87
20:06:24 <ttx> Anyone can propose a change to openstack/governance or a topic to be discussed at the following TC meeting (by editing the agenda wiki page directly)
20:06:34 <ttx> Things need to be proposed before EOD Thursday to be considered for next meeting, to give time for evaluation and/or community discussion
20:06:44 <ttx> For openstack/governance changes, there are 4 types.
20:06:46 <flaper87> mordred: mmh... you won...
20:06:55 <ttx> 1. typo fixes, where the content we publish is obviously wrong, and I'm authorized to fast-track them.
20:07:06 <ttx> 2. code changes, which affect the tools or doc publication in the repository, for which we use the classic "two votes in addition to the author" code review rule
20:07:22 * dims pays attention
20:07:27 <ttx> 3. project team updates (like a new repository addition or the assertion of a tag), where as long as the PTL approves the change (+ security team for security: tags, release team for release: tags, stable team for stable: tags...), we do lazy consensus approval
20:07:42 <ttx> which means if nobody objected after one week the change has been proposed, it is automatically approved
20:07:57 <ttx> 4. formal votes (everything else), where we'll discuss the topic at the next TC meeting, and require motion approval
20:08:12 <ttx> which generally means reaching 7 votes in favor (or if that fails, at least 5 votes in favor and more votes in favor than votes against after calling for a final vote)
20:08:20 <ttx> Changes to our charter text are a special case requiring 9 votes in favor.
20:08:25 <agentle> this is a good review :)
20:08:34 <ttx> The idea being to limit the number of changes we actually need to discuss
20:08:43 <ttx> We use the topic "formal-vote" for all formal votes, so you can quickly filter using
20:08:46 <dims> makes sense
20:08:49 <ttx> #link https://review.openstack.org/#/q/status:open+project:openstack/governance+topic:formal-vote
20:09:03 <ttx> In all cases the chair applies W+1 when the rules are met. Don't hesitate to call me out if you feel I'm not following those rules.
20:09:07 <edleafe> agentle: there will be a test at the end
20:09:08 * mtreinish likes having less things to worry about
20:09:13 <ttx> Will this work for you in Newton ? Any change you'd like to make to that ?
20:09:18 * morgan agrees with mtreinish
20:09:33 <morgan> this all sounds pretty spot on an reasonable.
20:09:34 * agentle is furiously taking notes
20:09:35 <sdague> this all seems fine
20:09:36 <dims> ttx : sounds good to me
20:09:39 <mtreinish> ttx: wfm
20:09:40 <mestery> LGTM ttx
20:10:14 <agentle> I don't have suggestions, it's working fine to me.
20:10:28 <ttx> Alright, we can always change that after some time, nothing is set in stone here
20:10:33 <ttx> * Austin reminders
20:10:41 * morgan puts away chisel.
20:10:43 <ttx> We'll have a joint Board/TC meeting, Sunday starting at 2:30pm
20:10:52 <ttx> at the JW Marriott, Level 3, Salons G/H
20:11:03 <mestery> ttx: Is it 2:30-5:30?
20:11:23 <ttx> checking
20:11:45 <ttx> unclear...
20:11:50 <mestery> ttx: Ack, thanks for checking :)
20:11:51 <mordred> Level 3 of the JW Marriott is quite nice
20:11:57 <agentle> heh has it been on time before?
20:12:01 <mordred> agentle: nope
20:12:02 <mestery> mordred: It's pretty lush indeed
20:12:12 <ttx> No closure hour announced, but there is WOO at 6pm after that
20:12:14 <sdague> it was on time in vancouver
20:12:26 <ttx> There is also optional dinner with the BoD, UC, Gold Member Reps and Foundation Staff, Saturday before the event at 7pm
20:12:33 <ttx> note the *Saturday*
20:12:41 <ttx> You should all have received the link to RSVP if you're around / interested.
20:12:41 <mestery> Boo to Saturday :)
20:12:42 <agentle> sdague: good memory. Vancouver was so awesome.
20:12:59 <sdague> yeh, no go on the sat for me, I shall be on the plane
20:13:01 <ttx> Please RSVP asap since they were supposed to close teh RSVP one week ago
20:13:16 <ttx> so I have no idea how much longer they will wait
20:13:34 <ttx> Questions on Austin ?
20:13:37 * morgan has RSVPd and made sure to book appropriate flight to not miss these things.
20:13:59 <russellb> i most likely won't be in person this time around
20:14:15 <anteaya> russellb: for the board meeting or for the summit?
20:14:22 <dims> thanks ttx i won't make it to the Dinner. should be in time for the 2:30 meeting
20:14:27 <russellb> whole thing ... having another kid due summit week
20:14:30 <mestery> russellb: You'll be there in spirit
20:14:35 <anteaya> russellb: congratulations
20:14:38 <russellb> thanks
20:14:40 <dims> russellb : congrats!
20:14:43 <morgan> russellb: good reason to not be there, congrats!
20:14:43 <ttx> russellb: keep us posted, with pictures
20:14:44 <sdague> russellb: congrats, and will miss you
20:14:45 <anteaya> russellb: healthy experience to your family
20:14:47 <mestery> russellb: You're naming the new child Newton, right? ;)
20:14:54 <ttx> Isaac
20:14:57 <russellb> thanks for the kind words, everyone :)
20:14:58 <dims> :)
20:14:58 <mtreinish> russellb: Cognrats! heh, you know how to time things :)
20:15:08 <dims> lol
20:15:10 * Rockyg thinks Austin is a great name for a kid
20:15:27 <ttx> Rockyg: better than Bexar for sure
20:15:32 <russellb> ha
20:15:37 <ttx> ok, next topic...
20:15:42 <ttx> #topic Propose topics for Joint board / TC meeting agenda
20:15:59 <ttx> Alan Clark reached out to me to build an agenda for the joint meeting, I replied we'd wait for the elections to conclude and for us to have our first meeting
20:16:05 <sdague> DCO status?
20:16:08 <ttx> So... What should we be discussing there ?
20:16:10 <morgan> sdague: ++
20:16:10 <sdague> as that's still not  thing yet
20:16:11 * mordred will give russellb a billion dollars to name his kid bexar
20:16:16 <ttx> yeah, that sounds like a regular
20:16:25 <anteaya> sdague: ++
20:16:26 <mordred> sdague: it's blocked on us
20:16:32 <mordred> no need to discuss with board
20:16:36 <mestery> sdague: ++
20:16:40 <sdague> mordred: define "us"
20:16:47 <anteaya> mordred: he'll need the whole billion to pay for the therapy
20:16:53 <mordred> sdague: well, bug tracking is the main thing
20:16:54 <ttx> mordred: we could still give an update, esepcially if that depends on "us"
20:16:56 <russellb> mordred: i'd call you on your bluff, but that sounds like a lot of work on my part
20:17:01 <mestery> ttx: ++
20:17:20 <Rockyg> anteaya, you got that right!
20:17:22 <ttx> like "we are still working on it"
20:17:35 <mordred> sdague: we still do not have an option to get bug tracking off of launchpad openid, which means we don't have a solid 'so now we can move gerrit off of launchpad openid' story
20:17:40 <sdague> mordred: yeh, I think it's still appropriate, as it would be good to track to completion
20:17:49 <mordred> sdague: which is the thing we need to do to fulfill ourside of the "move to dco is ok" agreement
20:17:54 <mordred> sdague: ok
20:18:08 <sdague> and, maybe is now a TC ask back to infra to make that a priority
20:18:08 <ttx> I also wanted the board to know that we would likely kick out from the "big tent" some projects that do not follow the rules during this cycle, if only to warn them that this can happen
20:18:15 <mordred> sdague: it is
20:18:18 <mordred> already
20:18:28 <ttx> but this may not require a full topic
20:18:40 <agentle> ttx: sounds like we might need a technical discussion on container v vms?
20:18:41 <mestery> ttx: I think it makes sense to keep them aware
20:18:44 <anteaya> mordred: but would be fair to keep the tc updated on status, yes?
20:18:45 <mordred> agentle: ++
20:18:47 <agentle> esp. at API levels
20:18:50 <mordred> agentle: TOTALLY
20:18:50 <morgan> ttx: that sounds like a reaonable bit
20:18:56 <dims> agentle : ++
20:19:02 <mestery> I recall at the Tokyo joint TC/board meeting there was confusion on the big tent still from some board members
20:19:03 <ttx> let me etherpad this
20:19:08 <mordred> I'm not opposed to talking about DCO/openid at all - I just want to make sure we're going in to the discussion with the riht context
20:19:19 <russellb> i think there's a lot of big tent concern in the board
20:19:20 <ttx> Please throw thoughts to https://etherpad.openstack.org/p/KAZvzrNkoM
20:19:20 <mordred> mestery: there is always confusion on the topic :)
20:19:28 <mestery> mordred russellb: Indeed :)
20:19:35 <russellb> in general, about the picture of openstack being totally unclear to people
20:19:53 <morgan> russellb: that is a concern i've had echoed to me privately
20:20:06 <russellb> might be worth hearing concerns and brainstorming
20:20:10 <mordred> thing is ... to be blunt
20:20:11 <mestery> russellb: ++
20:20:25 <mordred> every time it comes up in the board meeting, it's the same set of concerns as last time it was brought up
20:20:33 <russellb> mordred: pretty much
20:20:38 <mordred> I'm sure we'll talk about it again this time
20:20:49 <russellb> it's about lack of focus and clarity
20:20:49 <mordred> but it woudl be really great if we could nudge people to get up to speed
20:20:50 <mtreinish> mordred: that doesn't sound too surprising
20:20:53 <mestery> mordred: Is there a way out of that quagmire other than not discussing it?
20:20:56 <ttx> russellb: I'd say it's not ours to put in the agenda, if they have questions they should add it
20:20:56 <russellb> honestly, that was a theme in TC candidacy messages, too
20:21:01 <russellb> ttx: fair enough
20:21:08 <mordred> ttx: ++
20:21:10 * russellb doesn't desire to have it on the agenda
20:21:17 <ttx> russellb: you being a Board member can switch hats and add it to Alan's portion of the agenda :)
20:21:25 * mordred realizes he's being grumpypants - apologizes
20:21:31 <mestery> russellb: I see what ttx did there ;)
20:21:37 <dims> ninja move :)
20:21:41 <ttx> mordred: anything we could discuss to push/encourage interoperability or end user experience ?
20:21:49 <mordred> oh god.
20:21:51 <mestery> dims: lol :)
20:21:51 * russellb wearing TC hat firmly toeday
20:21:58 <thingee> mordred: heh
20:22:00 <russellb> today, not toeday.  toeday is a weird idea.
20:22:04 <mordred> ttx: so many things - but I'd actually be wearing my board hat on that one
20:22:27 <mordred> ttx: I believe the only direcitonal ask would be for the board to ask the TC to do more about it
20:22:35 <ttx> Like, "now that the mission statement is changed, what can we actually do (TC or board) to make it happen"
20:22:45 <mordred> ttx: see - you say things so much better than I do
20:22:55 <agentle> ttx: api docs clarity
20:23:22 <agentle> and yes, I'm willing to report latest and how hellish the path has been
20:23:24 <russellb> there was discussion at the last board meeting about defcore trying to decide if they want to own their own test suite
20:23:28 <mordred> agentle: on your containers vs vms discussion - at the last board meeting we talked about openstack as a single platform for baremetal, vms and containers ...
20:23:28 <russellb> that was slightly alarming
20:23:29 <sdague> agentle: is that another item, or in reference to the interop story?
20:23:36 <mordred> agentle: it seems we should maybe tlak about what that means with the TC
20:23:41 <mordred> but I don't want to dilute the other topic
20:23:49 <agentle> sdague: for interop and end user both
20:24:06 <agentle> sdague: as a general indicator of "this is difficult in execution with volunteer staffing"
20:24:07 <russellb> i don't think it needs to be on the agenda though ...
20:24:14 <mtreinish> russellb: yeah I heard the tail end of some of that discussion. It doesn't seem to have any traction though
20:24:17 <russellb> i'm just going to keep bringing up things i don't think need to be on the agenda
20:24:19 <sdague> so I think ttx's openning sounds like the right place to open that up
20:24:32 <thingee> russellb: oh yeah that's good. I was attending the last defcore meeting and also was alarmed.
20:24:35 <mordred> agentle: meh. I just added it as a sub bullet
20:24:37 <mtreinish> russellb: weirdly enough it came up in qa spec review too
20:24:41 <thingee> /meeting/midcycle/
20:24:46 <sdague> as long as we time box interop, we can ask questions, and also highlight some things going on that could use more hands
20:24:57 <russellb> mtreinish: well good that it's on QA radar.  i think people are aware and talking about it, so no need to raise alarm yet i suppose ...
20:25:02 <morgan> sdague: +1 on timebox
20:25:12 <agentle> sdague: I suppose it's also about scope -- big tent drowns the middle such as API docs
20:25:26 <mtreinish> russellb: https://review.openstack.org/301879
20:25:27 <dims> sdague : critical technical debt that needs man power like we talked about oslo.messaging/rabbitmq etc
20:25:46 <thingee> russellb: I wrote "some people" ... there was disagreement at the midcycle
20:25:51 <ttx> dims: so "areas needing more resources" ?
20:25:52 * russellb thinks we should just use rabbitmq as little as possible isntead
20:25:57 <dims> ttx : yep
20:26:20 <sdague> I'm a little afraid that's going to turn into a giant laundry list
20:26:26 <russellb> that's a blog post i need to get out of my system ...
20:26:39 <ttx> yeah, we should have a target
20:26:40 <cdent> sdague: perhaps it will but maybe it is also true
20:26:46 <agentle> to be clear, when I talk about volunteer staffing I specifically mean web dev
20:26:48 <mordred> ttx: ++
20:26:54 <sdague> if we want to have a specific tack on this around interop, we could maybe do something about it
20:26:56 <ttx> like determine top 3 areas and discuss that
20:27:09 <morgan> ttx: ++
20:27:22 <ttx> which would be the top 3 areas struggling at this point that critically need resources
20:27:32 <ttx> Technical writers working on docs ?
20:27:52 <ttx> With dims and dhellmann helping with release management, we are covered there
20:28:06 <agentle> ttx: no more about web delivery issues, we have much of the content and can spread out the content dev
20:28:40 <ttx> I feel like what we really need is more people working cross-project from within vertical teams
20:28:41 <mordred> agentle: I'd love to hear more about the web delivery issues - although maybe not in the middle of the TC meeting :)
20:28:42 <agentle> ttx: sdague's efforts of late are about web dev and nova only
20:28:44 <mordred> ttx: ++
20:28:46 <agentle> mordred: heh
20:28:47 <ttx> like cross-project liaisons
20:28:47 <agentle> right
20:28:47 <anteaya> ttx: yes
20:29:10 <mordred> ttx: that actually came up at the last board meeting too, amusinglyenough
20:29:11 <ttx> and peopel ready to tackle cross-project work but having a foothold in a project already
20:29:16 <sdague> ttx: but is that a board discussion? I guess I don't know how the board helps fix that?
20:29:21 <dims> we are also struggling with things like quotas and scheduling across projects
20:29:46 <ttx> sdague: I was thinking influencing them to provide resources there. But I agree it's mostly shouting to the wind
20:29:49 <agentle> +1 to all cross-project work, but maybe not for board discussion
20:30:14 <ttx> At the first BoD/TC meeting there was this big push for providing tech writers already
20:30:18 <dims> so what can we ask or tell them? (from previous meetings?)
20:30:23 <morgan> dims: and some other bits related to authz/interproject-communication. mostly the same as quotas and scheduling when you bridge across the services
20:30:37 <mordred> so - at the last board meeting, the topic of cross-project-with-foothold came up in the context of wanting to do more work with other communities
20:30:37 <ttx> They all said something like 'we'll provide one each'
20:30:56 <anteaya> ttx: did they say when?
20:30:59 <mordred> russellb and I pointed out that there was some of that, but it usually involved a person being solidly grounded in at least one place and being an ambassador to the other place
20:31:15 <mordred> I could see that being a topic the board might want to discusss similarly with us
20:31:25 <morgan> mordred: ++
20:31:26 <agentle> that could be a good discussion then
20:31:30 <sdague> yeh, that could be useful
20:32:04 <ttx> I think explaining, again, that we need more people working cross-project than we need features, can only help
20:32:30 <anteaya> well it is the truth
20:32:31 <russellb> yeah, and in genreal, how to encourage more outreach and collaboration with other communities
20:32:37 <dims> ttx : +1
20:32:41 <mordred> yah. but also that that's not about adding more people as much as it's reducing the feature pressure. just having 100 new devs show up to "work on cross project" is unlikely to be helpful :)
20:32:42 <russellb> how to incentivize that type of behavior
20:32:48 <ttx> We could give out stats about developer retention and other community insights
20:33:07 <morgan> ttx: getting that sentiment grounded in the community is something we need to figure out how to incentivize (x-project, feature pressure reduction, etc)
20:33:31 * morgan is typing slow today as others cover that sentence almost exactly as i was typing it ;)
20:33:38 <ttx> morgan: magic eh
20:33:46 <dims> morgan : true :)
20:33:46 <morgan> ttx: i know!
20:33:56 <dims> i can get out only a few words at at time :)
20:34:12 <ttx> OK, let's keep the etherpad open at least until Thursday, and I'll collect it and discuss it with Alan then
20:34:18 <mestery> dims morgan: Welcome to the machine :)
20:34:24 <morgan> mestery: hehe
20:34:29 <ttx> so if you think of something else just add it there
20:34:31 <dims> ha!
20:34:35 <ttx> ideally with your name
20:36:10 <ttx> mordred: how are we doing infra-resource wise. Should we ask for more from the board members ? Or are public clouds not that well represented there anyway ?
20:36:28 <mordred> public clouds are not well represented on the board
20:37:05 <mordred> I mean, we can always use more resources - would it be useful to present a report on that perhaps though?
20:37:11 <mordred> just to get people aware and on the same page?
20:37:21 <sdague> mordred: yeh, I think so
20:37:25 <sdague> given how low we are on nodes
20:37:28 <fungi> yeah, infra is always oversubscribed, but the community's done a not-terrible job of keeping us staffed
20:37:30 <russellb> can ask for foundation funding if you want to cross that bridge
20:37:31 <dims> mordred : +1000
20:37:31 <anteaya> mordred: it would be great to say the names of those donating resources publicly
20:37:43 <morgan> ++
20:37:45 <sdague> anteaya: that too
20:37:51 <dims> right
20:38:02 <mordred> k. I'll sign jeblair up to help me with that. he likes it when I do that
20:38:07 <sdague> but our current node counts are not going to handle milestone 2 or 3 this time around
20:38:09 <anteaya> ha ha ha
20:38:22 <sdague> it will impact the ability to land features and bug fixes for the release
20:38:24 <agentle> sdague: that's good data to get out there ahead of the milestones for sure
20:38:24 <fungi> i'd like to be able to have our root sysadmins and core reviewers around more often (some of them seem to also be mired in internal company stuff), but we'll take what we can get ;)
20:38:53 <mordred> sdague: yah - I want to give some more detailed reports to folks
20:38:57 <morgan> sdague: that is a really good thing to highlight
20:38:59 <mordred> sdague: so that people can know what is and isn't causing problems
20:39:00 <dims> fungi : especially off US work hours :)
20:39:04 <mordred> and what we do and don't have, etc
20:39:08 <fungi> dims: yep!
20:39:24 <ttx> the Bod/TC meeting is also about communicating and educating
20:39:31 <fungi> anteaya: good point. we do recognize the ones that are at or over our target threshold
20:39:53 <Rockyg> might be worth putting together a "this is what we need to use a public cloud for nodepool" doc for the board to send out to corporste members
20:39:58 <anteaya> yup, good to say thanks often
20:39:58 <dims> ttx : so update about how we are streamlining release processes and scaling up would help?
20:39:59 <fungi> #link https://www.openstack.org/foundation/companies/#infra-donors Infrastructure resource donors
20:40:00 <ttx> OK, we need to move on, but keep on working on that etherpad
20:40:01 <jeblair> wha?
20:40:08 <ttx> dims: not sure
20:40:16 <ttx> jeblair: you thought you would get rid of us
20:40:20 <ttx> jeblair: nice try
20:40:38 <anteaya> Rockyg: http://docs.openstack.org/infra/system-config/contribute-cloud.html
20:40:47 <anteaya> Rockyg: share it liberally
20:40:47 <ttx> OK, let's cover a few more topics now
20:40:49 <jeblair> wait are we talking about cloud resources?
20:41:02 <ttx> jeblair: yes, we want more
20:41:12 <mordred> jeblair: yah. well, specifically about a report at the board/tc meeting
20:41:20 <mordred> jeblair: so taht we can get people up to speed on the actual situation
20:41:24 <jeblair> great
20:41:29 <jeblair> i wasn't planning on being there
20:41:36 <ttx> mordred can do it
20:41:40 <ttx> or fungi
20:41:45 <fungi> i planned to show up
20:41:49 <jeblair> i've done a lot of work in this area
20:41:54 <mordred> jeblair: yah. I can do it - I just mostly wanted some help compiling data
20:42:03 <jeblair> but am surprised by this
20:42:15 <jeblair> i would like to be involved
20:42:27 <jeblair> but i did not know we were at the stage of going to the board
20:42:35 <agentle> jeblair: it's brainstorming BoD topics time, maybe we're not at that stage
20:42:36 <mordred> we're not going to the board asking for resources
20:42:44 <fungi> i do suspect that some of the impression we're low on cloud resources is running in a time lag and hasn't caught up with the present
20:42:48 <jeblair> i thought this was something we were going to start talking about amongst ourselves
20:42:57 <jeblair> fungi: that is definitely the case
20:43:16 <ttx> how about giving just a status update
20:43:34 <fungi> "how we dealt with the loss of hpcloud"
20:43:43 <jeblair> i will attempt to help how i can, but i would also like to express my strong desire to be involved in this
20:43:59 <jeblair> if that means showing up for meetings like this, it would be nice to have some advance warning
20:44:20 <ttx> jeblair: we can scrap the idea if that creates more issues than it solves
20:44:29 <fungi> it doesn't seem to me like it's something so urgent we have to bring it to the board (it's basically solved for now?)
20:44:31 <jeblair> who else is involved?
20:44:35 <ttx> I'll let you discuss that offline with fungi and mordred
20:44:37 <jeblair> okay
20:44:45 <ttx> #topic Tidy of item 5 of the vulnerability:managed tag
20:44:49 <jeblair> will do -- we'll see what's necessary, thanks
20:44:51 <ttx> #link https://review.openstack.org/300698
20:45:13 <ttx> I'd like to have the VMT's blessing on that one, since this tag is theirs
20:45:29 <ttx> Feels like it needs to bake a bit more before getting their blessing
20:45:54 <ttx> so let's revisit that once it has their approval ?
20:45:58 <mestery> ttx: I think that's reasonable, it's got enough votes once that happens too
20:46:01 <morgan> it does look like there is still a bit more conversation there.
20:46:11 <morgan> but i don't think it's going to materially change much
20:46:14 <ttx> yep, not ready for us yet
20:46:34 <morgan> stick it back in for a bit longer :)
20:46:36 <ttx> #agreed wait until it gets VMT's approval
20:46:40 <ttx> #topic Cross-project workshops at the Austin summit
20:46:44 <tristanC> moreover there is a session at Austin to discuss that item 5
20:46:48 <ttx> sdague: Could you give us a quick update on that ? All set ? No complaints on the scheduling ?
20:47:00 <sdague> sure
20:47:02 <ttx> tristanC: ok, maybe mention htat we should defer that post-Austin
20:47:03 <sdague> #link https://www.openstack.org/summit/austin-2016/summit-schedule/global-search?t=Cross%20Project%20workshops%3A
20:47:05 <morgan> sdague: i just want to say the x-project sessions look amazing :)
20:47:22 <sdague> cross project sessions all scheduled there, I've yet to get hard complaining about conflicts
20:47:38 <sdague> as we already did a bunch of conflict dodging to get that together
20:47:49 <agentle> yeah nice work sdague!
20:47:51 <sdague> yeh, I'm pretty excited by the content in the schedule, this should be good
20:48:09 <sdague> thanks to all TC members voicing opinions, and dtroyer and ttx for helping on the scheduling
20:48:09 <thingee> thanks sdague
20:48:11 <dims> agentle : morgan : +1
20:48:15 <dims> thanks sdague
20:48:23 <mtreinish> sdague: I could complain about the overlap between stable and devstack keystone v3 :)
20:48:37 <sdague> mtreinish: you could :)
20:49:23 <ttx> questions on that ?
20:49:26 <sdague> ttx: ok, unless there are questions, I think that's done on topic
20:49:53 <ttx> #topic Video with advice for design summit session moderators
20:50:04 <ttx> Not much of an update there, we are "shooting" tomorrow
20:50:10 <morgan> nice.
20:50:12 <ttx> We'll send the link to TC for review before sending to big-tent PTLs to disseminate to their session moderators
20:50:47 <ttx> For those who missed previous episodes, that would make up a short video with tips specifically targeted to session moderators
20:51:05 <ttx> since with so many project teams we can't assume everyone knows how this works
20:51:13 <ttx> #topic Open discussion
20:51:25 <ttx> Alright... open discussion now. Anything you'd like to achieve during the coming 6 months ?
20:51:38 <ttx> Other topics to add to the BoD/TC meeting agenda ?
20:52:11 <docaedo> I was wondering if this might be an appropriate TC agenda item:
20:52:12 <morgan> I think post summit i'll have a better idea of the next 6mo and ideas there :) besides what we already put on the BoD/TC meeting agenda
20:52:16 <ttx> Maybe the newcomers could tell us what they plan to achieve/push over the Newton session
20:52:29 <docaedo> "unifying application development efforts"
20:52:38 <ttx> docaedo: explain
20:53:07 * mordred steps back slowly from the can of worms docaedo is opening ...
20:53:10 <docaedo> I joined the app dev WG and have been lurking in product WG and following along with much of the conversations
20:53:23 <docaedo> I'm seeing many people have very different versions of what an openstack application would look like
20:53:29 <mordred> docaedo: ++
20:53:31 <kfox1111> +1
20:53:33 <Rockyg> ++
20:53:34 * jroll pushes mordred back into the mosh pit
20:53:35 <agentle> yeahhhh docaedo
20:53:38 <docaedo> and would like help getting some focus on this
20:53:49 <mestery> docaedo: Seems like a nice can of worms right there :)
20:53:53 <docaedo> I'm trying to get educated to see where I can help
20:54:01 <russellb> those are definitely words
20:54:03 <docaedo> (and I am all about cans of worms :D )
20:54:03 <jroll> I'm curious if "openstack application" is meant to be "an app that runs on an openstack cloud" or?
20:54:09 <morgan> docaedo: +1
20:54:19 <mordred> jroll: this is the thing
20:54:21 <mordred> exactly
20:54:25 <mordred> people say "app developer"
20:54:27 <dims> more developer-centric?
20:54:28 <kfox1111> jroll: yeah.
20:54:31 <Rockyg> jroll, what mordred said
20:54:31 <mordred> and pretend that it means something
20:54:41 <kfox1111> often a lot of the openstack projects assume user = developer.
20:54:41 <agentle> jroll: yeah this is about the app catalog, heat templates, containers, all of it
20:54:51 <mordred> are you an openstack app developer if you deploy a production gerrit on an openstack cloud using ansible and puppet?
20:55:10 <kfox1111> we want a world where that assumption doesn't hold true. app devloper provides program though the app catalog, and a 'user' launches it on their cloud.
20:55:13 <jroll> right, I guess idk what's special about an "openstack application" versus a "software application"
20:55:15 <mordred> or are you only an app developer if you wrote a from-scratch cloud-native app that stores its data in swift and its keys in barbican
20:55:16 <kfox1111> without knowing how the thing works.
20:55:17 <russellb> but ... APPS!
20:55:17 * morgan dislikes "app developer" as a term
20:55:23 <mordred> morgan: +10000000
20:55:26 <docaedo> My intention is not just to try to make the app catalog relevant - it's to help define who we are trying to reach, and get better at that as a community
20:55:35 <kfox1111> docaedo: +1
20:55:46 <dims> containerize all the stuff! then everyone is happy :)
20:55:51 <morgan> russellb: hehehe
20:55:53 <kfox1111> right now we're pretty exclusive to non developers.
20:56:05 <mtreinish> jroll: yeah, I'm not sure where the distinction is
20:56:10 <mestery> docaedo: Sounds like an admirable goal, and I think it would help our USERS a lot to clarify that
20:56:12 <jroll> I'm still confused, I guess, but maybe that's the point
20:56:17 * docaedo notes only 4 minutes left, and appreciates the grenade he lobbed
20:56:19 <mestery> jroll: It may indeed be :)
20:56:20 <kfox1111> you have to be at least devops to use openstack for the most part.
20:56:20 <agentle> kfox1111: oh I hadn't thought of an app dev that way, interestign
20:56:46 <agentle> kfox1111: that's a cloud architect writing templates to me, but what I think continues to be shaped heh
20:56:56 <mordred> kfox1111: I do not agree with you
20:56:59 <jroll> sounds like some folks maybe have an end goal for openstack clouds to be "push a button, get a deployment of a FOSS application". is that a valid interpretation?
20:57:03 <kfox1111> you should be able to have pure ops as an example. cloud dev provides a heat template to launch a scalable trac website.
20:57:05 <ttx> docaedo: I bet dfflanders would like to speak to you about that
20:57:10 <mordred> kfox1111: and I think that is one of the biggest misconceptions about openstack
20:57:14 <kfox1111> pure op uses it to launch and maintain track sites using openstack.
20:57:15 <mordred> openstack is a great tool for traditional ops
20:57:20 <docaedo> I'm happy to discuss in person or on IRC further, but mainly want some attention around the issue because it's important to whether we're able to engage USERS of clouds in addition to people who are building clouds
20:57:21 <thingee> I would like to increase our quality with cross-project efforts that I have already been part of.
20:57:35 <docaedo> ttx: dfflanders and I are talking muchly about it
20:57:48 <fungi> the infra team uses a lot of openstack public cloud as a traditional operations workflow enhancer
20:57:52 <kfox1111> I want end user scientists, chemists, bioligists to be able to use openstack with the app catalog to run "apps" and consume resource. :)
20:57:53 <mordred> fungi: ++
20:58:10 <morgan> docaedo: i think this also plays into the general definiton of what openstack really is (to deployers, end users, developers storing data in clouds).
20:58:10 <thingee> Things like installation docs being a necessary thing for big tent projects.
20:58:17 <anteaya> thingee: awesome!
20:58:18 <docaedo> fungi: yep - infra is a good example for sure
20:58:19 <dims> kfox1111 : interesting
20:58:22 <ttx> so looks like we should start a taxonomy of "users"
20:58:29 <morgan> ttx: ++
20:58:34 <docaedo> ttx: ++
20:58:35 <ttx> because we are lacking the words to describe things
20:58:47 <ttx> and "app dev" and "end user" won't cut it
20:58:48 <kfox1111> openstack is an OS. right now its simliar to linux in its infancy. back then, users = developers.
20:58:56 <dims> yep
20:58:58 <anteaya> thingee: I agree installation docs are rather important
20:59:00 <dtroyer> that has been a recurring theme lately, needing a common vocabularty to be able to discuss these thingss clearly
20:59:01 <morgan> ttx: absolutely
20:59:04 <fungi> it sounds to me like maybe the disconnect is that there should also be an audience of people consuming this stuff without needing to know how to be server sysadmins? that seems like a dangerous idea though
20:59:08 <mordred> kfox1111, dims that's just not true
20:59:12 <kfox1111> we need to seperate the two use cases so more users then just developers can consume resource.
20:59:13 <mordred> like, not even a little bit
20:59:18 <jroll> mordred: ++
20:59:20 <mordred> it's what peopel keep saying
20:59:24 <mordred> but it's absolutely inaccurate
20:59:29 <mordred> and I would like to stop the meme
20:59:33 <dims> mordred : my yep was on "app dev" and "end user" :)
20:59:36 <ttx> in one min
20:59:44 <jroll> there's been multiple discussions about "is an application built on top of openstack, openstack?"
20:59:50 <jroll> and I think this loops back to that
20:59:56 <mordred> jroll: wow. that sounds like a fun one
21:00:01 <ttx> One min left
21:00:05 <ttx> Personally in Newton (as discussed in my candidacy email) I'd like to have the time to do some tent cleanup, discuss the limits of the tent (i.e. the Poppy/Tacker type issues), and nail down the split event format
21:00:05 <lifeless> jroll: meep
21:00:14 <lifeless> jroll: hope you've got alcohol for that one
21:00:15 <agentle> ttx: +1 on tent
21:00:18 <jeblair> jroll: openstack is built using servers running on openstack.  ;)
21:00:18 * jroll runs away from the grenade he threw
21:00:27 <morgan> ttx: +1
21:00:29 <anteaya> ttx: sounds good
21:00:39 <kfox1111> its true. whats the difference between a rest api and a linux syscall? abstraction? syscalls? both have it. both let you run programs, both provide datastorage abstractions, etc.
21:00:48 <ttx> Oh, btw, if new TC members would like to get involved in the project team guide, just ask
21:01:10 <ttx> Also the comms team (flaper87/agentle) would probably not mind some help/rotation
21:01:17 <agentle> that's a good idea ttx
21:01:24 <ttx> so feel free to reach out to them
21:01:27 <ttx> and we are out of time
21:01:33 <ttx> Thanks everyone !
21:01:38 <docaedo> thanks!
21:01:38 <ttx> #endmeeting