20:01:42 <ttx> #startmeeting tc
20:01:42 <jroll> \o
20:01:43 <openstack> Meeting started Tue Oct  4 20:01:42 2016 UTC and is due to finish in 60 minutes.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:01:44 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:01:46 <openstack> The meeting name has been set to 'tc'
20:01:48 * edleafe hides on the side of the room
20:01:55 <ttx> Last meeting for the Newton TC membership! Our agenda:
20:01:59 <ttx> #link https://wiki.openstack.org/wiki/Meetings/TechnicalCommittee
20:02:10 <ttx> (remember to use #info #idea and #link liberally to make for a more readable summary)
20:02:13 <bauzas> \o
20:02:20 <ttx> #topic Decide and schedule Cross-project workshops for Barcelona
20:02:26 <ttx> #link https://etherpad.openstack.org/p/ocata-cross-project-sessions
20:02:32 <ttx> We had 16 proposals by the deadline
20:02:50 <ttx> one (1) was struck out for some reason (abandoned ?)
20:03:00 <ttx> another (15) is lacking a session lead, so we should drop it unless there is a volunteer
20:03:12 <ttx> For the remaining 14, judging by the votes, we have four categories
20:03:31 <ttx> A/ 2 must-have (5, 13)
20:03:39 <mtreinish> ttx: I would volunteer for 15, but I won't be able to make it
20:04:02 <ttx> B/ 7 pretty obvious choices (2, 3, 4, 6, 10, 11, 16)
20:04:28 <ttx> hmm, maybe add 14 to that set
20:04:41 <ttx> C/ 2 slightly-less obvious choices (7, 9)
20:04:47 <ttx> D/ 2 subpar (8, 12)
20:04:59 <ttx> So... We should discuss if we should assign a double-slot to any of these
20:05:11 <ttx> Then see how many of category C we want to approve
20:05:22 <ttx> To give you an idea, there are two scheduling strawmen on the etherpad
20:05:41 <dhellmann> 13 looks like a good candidate for a double session
20:05:41 <ttx> johnthetubaguy's is not assigning any double-slot, and nothing for category C, for a light schedule
20:05:51 <ttx> mine's is assigning double slots for #5 and #13, and saves #7
20:05:58 <dhellmann> maybe even split those 2 sessions over 2 days
20:06:00 <ttx> slightly busier schedule, but still a lot less busy than Austin (where we ran 3 in parallel)
20:06:19 * Rockyg waves to edleafe and wishes him success
20:06:25 <johnthetubaguy> yeah, I was thinking about getting more people to the ones I think we need to worry about
20:06:38 <ttx> Agree on #13 needing a double slot
20:06:40 <johnthetubaguy> but I am warming a lot to ttx's proposal after thinking about it more
20:06:44 <edleafe> Rockyg: thanks!
20:06:45 <dhellmann> +1 to keeping the number of parallel sessions to a minimum
20:06:46 <dims> dhellmann : for 13 we may end up getting different sets of people show up (not sure if that's good or bad)
20:07:02 <ttx> What about #5 ? Do you think we can get to something useful there in 40 min ?
20:07:05 <dhellmann> dims : I was thinking about having the ability to "sleep on" the first part of the discussion
20:07:18 <dims> dhellmann : yep that would help
20:07:31 <johnthetubaguy> if we had only one double, I would vote for 13
20:07:32 <dhellmann> ttx: I think so, though I'd be interested in smcginnis, diablo_rojo, and thingee's input
20:07:41 <flaper87> dims: dhellmann I'd be worried that the set of people attending the first part would not attend the second part
20:07:51 <fungi> i thought %5 was an opinion-gathering forum?
20:07:54 <fungi> er, #5
20:07:57 <flaper87> If we split 13 into 2 sessions, that is
20:08:18 <fungi> i was definitely planning to participate in #5 anyway
20:08:24 <dhellmann> flaper87 : yeah, that's a concern. might be worth the risk, though, esp. if we make it clear up front what the plan is
20:08:37 <thingee> I feel like it'll start conversations, on #5... at least having a picture of where things are.
20:08:41 <piet_> ttx #1 wasn't receiving any votes and decided to use another forum to select research priorities for next cycle
20:08:47 <smcginnis> dhellmann: Yeah, I think so as well.
20:08:52 <ttx> piet_: thx for the info
20:08:58 <smcginnis> A start at least.
20:09:01 <dhellmann> smcginnis : so there's no need for a double session?
20:09:18 <thingee> diablo_rojo is currently on working on what things look like for other projects. smcginnis has done a great job on the cinder side
20:09:29 <thingee> dhellmann: I don't think so
20:09:30 <ttx> we'll probably need to expand to a wider audience after brushing up the topic anyway
20:09:46 <dhellmann> thingee : ok, thanks
20:09:49 <ttx> It's not somethign that will be decided in 40 or 90 min anyway
20:09:55 <thingee> ttx: +1
20:10:00 <dougwig> for #5. it could use a double if the first is "where is the line" and the second is "a common framework/method".  i don't think feeling out the line will happen in less than 40 minutes.
20:10:09 <diablo_rojo> I was planning on emailing the cp liaisons this week about if they will be attending the session/ asking for representation.
20:10:22 <smcginnis> dhellmann: If we can only do one, I think there's still value. But two would likely be needed. But I'm OK if we can at least get the conversation started and then defer to the PTG if we really have to.
20:10:26 <thingee> dougwig: that's true. we could draw out multiple solutions. just the final decision will take place after I think
20:10:29 <fungi> dougwig: i agree with you there
20:10:45 <thingee> dhellmann: I guess I'm unsure now :)
20:10:48 <dhellmann> heh
20:10:52 <smcginnis> diablo_rojo: Good call.
20:10:52 <fungi> "a common framework" sounds like the e-mail thread which will follow that session
20:10:55 <dhellmann> I like the topic split that way
20:10:59 <ttx> So we could have one session for where is the line, a session on driver log where we can continue to touch on those topics
20:11:06 <dims> dhellmann : #3 and #4, do we need 40 mins each or can we club them together?
20:11:08 <dhellmann> but yeah, I wonder if the implementation details of a framework are a much much longer discussion
20:11:12 <smcginnis> fungi: Could be.
20:11:23 <dhellmann> dims : #3 may not need 40 minutes, but I expect #4 will
20:11:26 <ttx> dims: different topics I think
20:11:37 <ttx> OK, so only #13 using a double-slot ?
20:11:41 <thingee> ttx: I kind of feel like the driver log stuff alone needs the 40 mins. If we have extra time, I would be happy to continue the conversation of #5
20:11:45 <dims> ack ttx dhellmann
20:12:10 <ttx> #info #13 should have a doubleslot
20:12:32 <ttx> Which ones do we want to include from category C ?
20:12:45 <ttx> #7 and/or #9
20:13:02 <ttx> 7 is "Stewardship Working Group (SWG) discussion"
20:13:03 <dhellmann> #info group A/ 2 must-have (5, 13)
20:13:06 <dtroyer_zz> I'm not sure how much a single conversaion is useful in #9
20:13:16 <dtroyer_zz> that sounds like a conversaion per SDK
20:13:20 <ttx> 9 is "SDK fishbowl"
20:13:20 <dhellmann> #info group B/ 7 pretty obvious choices (2, 3, 4, 6, 10, 11, 16)
20:13:30 <dhellmann> #info group C/ 2 slightly-less obvious choices (7, 9)
20:13:30 <ttx> Note that both are narrow-enough and would likely not genberate conflicts
20:13:47 <dhellmann> #info group D/ 2 subpar (8, 12)
20:13:47 <thingee> ttx: I spoke to flanders about #9. I think we agreed there wouldn't be much attendance from the sdk devs themselves.
20:14:02 <thingee> the real value would be in consumers of the sdks. Mostly talking about shade though at this time
20:14:06 <flaper87> dhellmann: I think ttx said we should add 14 to the obvious choices (in case you want to have an info on that too)
20:14:14 <thingee> there are efforts in the future pre-next summit to start building this up more for sdk devs
20:14:23 <dhellmann> #info group B/ 7 pretty obvious choices (2, 3, 4, 6, 10, 11, 14, 16)
20:14:26 <dhellmann> flaper87 : thanks
20:14:33 <annegentle> thingee ttx if the working groups related to SDKs got time, it would be okay to drop
20:14:40 <ttx> OK, so we'd save only #7 ?
20:14:46 <thingee> In case people don't know, Flanders works for the OpenStack Foundation in improving our app dev community
20:15:10 <ttx> he is a cool neighbour
20:15:12 <dhellmann> dtroyer_zz : what do you mean "a single conversation"?
20:15:21 <annegentle> ttx does the Product WG also have time elsewhere?
20:15:24 <ttx> dhellmann: all SDKs at the same time
20:15:26 <dhellmann> ah
20:15:39 <dtroyer_zz> what ttx said
20:15:41 <ttx> annegentle: I think they have a workgroup room somewhere
20:15:46 <mtreinish> dtroyer_zz: yeah, that's a good point. What is the end goal of a session like that?
20:15:56 <dhellmann> is mordred here? his name is on that sdk item too
20:15:57 <dtroyer_zz> there is very little that actually spans all of the SDKs, as much as I wish that were not the case
20:15:57 <annegentle> ttx yeah
20:16:15 <flaper87> dhellmann: think he's on a plane
20:16:20 <flaper87> (based on twitter info)
20:16:21 <smcginnis> Would that encompass openstackclient as an "sdk"
20:16:29 <Rockyg> prod wg definitely has a session and on Friday, a working session
20:16:30 <dhellmann> dtroyer_zz : the description makes it sound like the idea is to turn one fishbowl room into a bunch of work sessions
20:16:40 <annegentle> dtroyer_zz yeah it's unfortunate, I was thinking in past summits it's usually the OpenStack client, API WGm and the App Ecosystem WG sessions that are useful
20:16:42 <dtroyer_zz> smcginnis: no, plus OSC has its own sessions
20:16:47 <annegentle> right
20:16:55 * ttx tweaks his strawman schedule to remove the double-slot for #5
20:17:00 <smcginnis> dtroyer_zz: Gotcha, thanks!
20:17:32 <dims> slightly offtopic, With all the email conversations about what the new candidates for TC should/could do, feels like we need a session "Throw eggs at your TC"
20:17:45 <fungi> or vegetables
20:17:48 <thingee> smcginnis: see original email on project team slots http://lists.openstack.org/pipermail/openstack-dev/2016-September/103560.html
20:17:51 <dims> :)
20:17:56 <smcginnis> thingee: Thanks!
20:18:07 <smcginnis> Forgot about that.
20:18:09 <thingee> smcginnis: and join us! :)
20:18:10 <stevemar> dims: tomatoes will work just fine
20:18:18 <dhellmann> dims, fungi : TC Frittata?
20:18:25 <fungi> dims: better might be to just rotate tc members staffing a dunking booth
20:18:31 <smcginnis> :)
20:18:31 <flaper87> dhellmann: lol
20:18:32 <anteaya> throw blueberries at me
20:18:34 <ttx> OK, so any objections to the current selection ?
20:18:36 <dims> stevemar : i have to learn how to say "no fish, no meat" :)
20:18:36 <anteaya> all the blueberries
20:18:40 <johnthetubaguy> dims: the SWG is kinda the TC re-inventing whats its doing in a way
20:18:41 <dims> ttx : +1
20:18:55 <ttx> Aa (including double for #13) + Bs + #7
20:18:58 <smcginnis> +1 for dunking booth
20:19:00 <flaper87> ttx: none from me
20:19:08 <dhellmann> ttx: +1
20:19:09 <ttx> Trying to fix my schedule
20:19:09 <johnthetubaguy> ttx: does your current strawman proposal have all those in at the moment? I guess it does
20:19:17 <ttx> johnthetubaguy: yes, trying to optimize though
20:19:21 <dims> johnthetubaguy : so let's make sure we word it such that people know lot of TC folks will be there
20:19:22 <dhellmann> ttx: I like the org/tech split you identified
20:20:15 <fungi> yep, sort of track-like
20:20:38 <dhellmann> ttx: I would appreciate it if you could keep #3 and #13 from overlapping
20:20:39 <dims> ++ to org/tech split
20:20:48 <ttx> tweaked it a bit to remove a conflict I had.. How does that one look for you all ?
20:21:30 <ttx> check for hard conflicts you may have
20:21:48 <fungi> i worry that overalpping #4 with anything is going to have some impact on whatever it overlaps with
20:22:04 <dhellmann> ttx: I wanted to participate in the decomposition discussion. can #3 move to wed 12:15?
20:22:38 <ttx> dhellmann: I wanted to avoid having all "architects" missing the decomposition discussion
20:22:42 <johnthetubaguy> 13 and 6 look a bit bad for me, but meh, nothing is going to be perfect
20:22:43 <dhellmann> ah, ok
20:22:57 <fungi> but especially considering the number of tc members who were mentioning #4 in their platform statements this election, i wonder if havig it overlap with the swg means there won't be a lot of tc members in the swg session
20:23:07 <ttx> I could swap with the upgrade discussion
20:23:07 <flaper87> also, can we swap 10 and 4 ?
20:23:32 <ttx> flaper87: same lots of overlap between architects and SWG members
20:23:35 <flaper87> I'd like to attend 4 and 7, that's why
20:23:41 <dhellmann> fungi : yeah
20:23:43 <flaper87> gotcha
20:23:44 <ttx> let me see
20:23:54 * dtroyer_zz is surprised at the conflicts with just two rooms active
20:24:05 <ttx> dtroyer_zz: it's actualkly not surprising
20:24:06 <dtroyer_zz> must mean we've got some good topics
20:24:10 <ttx> less topics means less optional topics
20:24:14 <johnthetubaguy> ttx spotted this earlier, with less sessions we are getting more conflicts
20:24:19 <johnthetubaguy> yeah
20:24:56 <ttx> moved Python 3 a bit, does that look better ?
20:25:03 <johnthetubaguy> argh, so now I am skipping 6 with I had intended on leading somewhat
20:25:38 <ttx> how about that
20:26:02 <dhellmann> I still won't be in the SWG session this way, but I don't see a way to avoid that
20:26:28 <ttx> dhellmann: swap with rolling upgrades ?
20:26:39 <dims> y i really want to see what will be in SWG as i missed the training
20:26:41 <ttx> 3<-> 11
20:26:41 <dhellmann> ttx: that would work
20:26:45 <flaper87> ttx: +1 to swap it
20:26:47 <johnthetubaguy> better... so I kinda want to be in all of them, which is bad, but live
20:26:49 <flaper87> ttx: 3 and 11
20:27:05 <ttx> done
20:27:20 <johnthetubaguy> is 11 in a ops friendly slot still?
20:27:21 <flaper87> sold
20:27:30 <ttx> johnthetubaguy: argh
20:27:32 <dhellmann> I'm looking forward to the PTG, when we'll have more time for these sorts of things
20:27:40 <annegentle> dhellmann +
20:27:40 <ttx> it is still somewhat ops friendly
20:27:50 <ttx> (everything on wednesday is)
20:27:50 <flaper87> johnthetubaguy: I think it's ops friendly
20:27:53 <dims> if both 13 sessions are on the same day, we can't sleep on it
20:27:59 <johnthetubaguy> I still want to be in 11 & 7, but I think 7 should still win
20:28:00 <mtreinish> dhellmann: heh, and more potential scheduling conflicts :)
20:28:01 <johnthetubaguy> ttx: cool
20:28:11 <dhellmann> dims : at this point, I'm prepared to give up on that idea :-)
20:28:13 <ttx> do we want to sleep on it ?
20:28:23 <dims> dhellmann wanted to :)
20:28:39 <dhellmann> mtreinish : if we have 2 days, we could have some sessions scheduled in their own slot (community goals, for example)
20:28:39 <ttx> OK, let's sleep on the schedule
20:28:44 <johnthetubaguy> yeah, +1
20:28:54 <dhellmann> ttx: dims meant the split between the 2 parts of session #13
20:28:59 <ttx> I'll do a thread to finalize it tomorrow
20:29:09 <dims> dhellmann : right
20:29:10 <dtroyer_zz> ++
20:29:11 <dhellmann> I had suggested putting those on separate days, but I don't think it's worth breaking what we've come up with to do that.
20:29:28 <dims> ack
20:29:30 <ttx> We could swap 13part2 with 5
20:29:30 <dtroyer_zz> swapping both sessions with another pair might do it
20:30:14 <ttx> oh well, let's sleep on that and finalize scheduling tomorrow
20:30:14 <dims> ttx : yep
20:30:19 <dhellmann> 13.2 for 5 might work
20:30:28 <ttx> Need to check that session leads are not dual-booked too
20:30:32 <dhellmann> I assume no session leaders are speaking on these days?
20:30:44 <ttx> #action ttx to start a thread on finalizing schedule
20:30:49 <ttx> dhellmann: you assume wrong
20:31:07 <ttx> #info ttx to check for session lead conflicts with talks
20:31:20 <ttx> #info consider swapping 13.2 for 5
20:31:30 <ttx> ok, let's switch to another topic
20:31:48 <ttx> #topic Clarify the process for the TC approved release
20:32:11 <ttx> #link https://review.openstack.org/374027
20:32:30 <ttx> Only minor objections, including recommending the use of "Interop WG" instead of Defcore, and removing the duplicate "that"
20:32:43 <dhellmann> yeah, I'm happy to prepare a follow-up to fix those wording nits
20:32:50 <thingee> +1
20:32:57 <ttx> OK, let's approve that one then
20:33:04 <annegentle> thanks dhellmann
20:33:08 <ttx> objections ?
20:33:12 <mtreinish> ttx: go for it
20:33:13 <flaper87> none
20:33:35 <ttx> ok done
20:33:43 <ttx> #topic YAML cleanups
20:33:52 <ttx> Two small housekeeping items:
20:33:57 <ttx> * Rename retired-projects.yaml to legacy.yaml (https://review.openstack.org/376828)
20:34:09 <ttx> That will capture better that projects that are removed from governance are not necessarily abandoned / retired from infra
20:34:24 <ttx> this one also has enough approvals to pass now
20:34:28 <ttx> Objections ?
20:34:42 <fungi> fwiw, that file is not (yet) integrated into our election tooling anyway but is intended to be soon
20:34:58 <dims> no objections
20:35:05 <fungi> so renaming is entirely nondisruptive in that regard
20:35:08 <ttx> which reminds me, we missed adding OpenStackSalt to that one
20:35:17 <annegentle> ok good to know fungi
20:35:19 <anteaya> ttx: yes it was agreed to add it after
20:35:32 <ttx> #action ttx to add OpenStackSalt to legacy.yaml
20:35:32 <dims> after this merges, i'll take an action on that ttx
20:35:33 <fungi> there was at least one fuel repo made unofficial recently which should have ended up in there was well
20:35:36 <anteaya> ttx: my understanding is once this patch merges dims will add salt
20:35:40 <ttx> #undo
20:35:41 <openstack> Removing item from minutes: <ircmeeting.items.Action object at 0x7f66f46d4d10>
20:35:56 <ttx> #action dims to propose change to add OpenStackSalt to legacy.yaml
20:36:04 <dims> fungi : ack on that fuel repo, will take care of that
20:36:08 <dhellmann> #info wording tweaks on the tc-approved-release patch: https://review.openstack.org/382064
20:36:08 <fungi> i spotted it when trying to figure out why the atc count shrunk over a given time period
20:36:10 <ttx> and... approved
20:36:15 <anteaya> thank you
20:36:20 <anteaya> thanks dims
20:36:20 <ttx> * Alphabetise team names (https://review.openstack.org/376070)
20:36:32 <ttx> This can't really hurt, but is a rebase hell, so better approve it while it's fresh
20:36:36 <annegentle> heh
20:36:52 <ttx> still missing a few votes
20:36:54 <annegentle> ttx darn, clobbers my api refresh
20:37:39 <ttx> annegentle: arh. Another rebase hellish one. If you rebase it on top of this one we could approve it in session
20:37:48 <annegentle> ttx nah it's oka
20:37:50 <annegentle> okay even
20:37:52 <ttx> because the one-week baking period is killing it
20:38:04 <annegentle> ttx I'll fix my links after this one lands
20:38:24 <annegentle> ttx there's seven
20:38:24 <ttx> TC members; please review https://review.openstack.org/#/c/376070/, still missing votes
20:38:36 <ttx> annegentle: oh, not too bad
20:38:42 <annegentle> yeah
20:38:58 <ttx> Objections ?
20:39:11 <flaper87> none
20:39:16 <ttx> ((to the alpha-ordering one)
20:39:22 <thingee> whoops thought I already voted on this
20:39:25 <ttx> ok, ready to approve
20:39:38 <ttx> and done
20:39:45 <ttx> #topic Add stable:follows-policy tag to heat
20:39:52 <ttx> #link https://review.openstack.org/379114
20:40:06 <ttx> This addition was vetted by Tony as stable maint PTL, and there doesn't seem to be any objection so far
20:40:34 <annegentle> ttx did the heat PTL circle in on it?
20:40:49 <thingee> don't think it's required.
20:40:54 <ttx> I think Rabi is the current ptl
20:40:57 <dhellmann> the author is hte heat ptl
20:41:00 <annegentle> thingee ttx ok, cool
20:41:23 <ttx> OK, ready to approve
20:41:42 <ttx> Last-minute objection ?
20:42:04 <ttx> and... done
20:42:26 <ttx> wow, we actually have time to discuss Assume Good Faith a bit
20:42:32 <ttx> #topic Add "Assume Good Faith" to OpenStack principles
20:42:38 <ttx> #link https://review.openstack.org/365590
20:42:47 <ttx> Feedback so far seems to be that the idea is good, but this is about personal conduct and therefore is a better match for the CoC
20:42:59 <flaper87> I'd like to start by saying that this proposal did not try to tell folks that do not assume good faith should not be part of the community. I'd like to also add that I don't think assuming good faith stops at simply trusting that members of the community put openstack first when needed. There's more to it than that. For example, it's often said that the TC runs with a secret agenda, which is way
20:43:01 <flaper87> far from being true. This and other things like this have been *assumed* in the past about other members.
20:43:03 <flaper87> That being said, I'm good with linking the CoC. I'd rather have this written down with explicit words that would help us set expctations but I don't want to exclude anyone and I'm happy to keep reminding people to assume good faith.
20:43:07 <thingee> I think assuming good faith on anyone within a code conduct is not right.
20:43:10 * flaper87 admits the obvious paste
20:43:33 <ttx> Personally I prefer this kind of thing to be in the CoC because I think it applies to all of our community, beyond the TC's constituency
20:43:34 <thingee> What it's trying to capture I think is already within the code of conduct.
20:43:56 <flaper87> thingee: It's scattered in the CoC
20:43:56 <ttx> Also if we start tackling general personal behavior in community in the "principles" document, we'll end up copying all the CoC over
20:44:11 <ttx> So I'd rather draw the line and point from one to the other (the link is already there).
20:44:12 <thingee> flaper87: You can propose changes to the CoC sure.
20:44:15 <flaper87> It's there but you have to read between lines to actually get to the "Assume Good faith" point
20:44:24 <flaper87> thingee: yup, I mentioned that in one of my comments
20:44:34 <flaper87> or in one meeting, can't recall
20:44:50 <flaper87> point is. If we prefer to link the CoC then I think we can propose a change to the CoC
20:44:56 <annegentle> this is different from the CoC to me.
20:45:10 <ttx> flaper87: we already linked the Coc
20:45:11 <flaper87> but again, putting this in the CoC feels like forcing it to people
20:45:23 <annegentle> Definitely all behavior should start from the CoC but this is a governance context document.
20:45:25 <flaper87> which is the same problem we have with my proposal to begin with
20:45:37 <annegentle> flaper87 so I'd advocate to have it be in this document
20:46:04 <ttx> annegentle: why is it different from a CoC-style expectation ?
20:46:12 <flaper87> annegentle: my preference goes to have it in this document
20:46:20 <edleafe> You can tell people how they must behave (CoC). You can't tell them how to think or feel (Assume Good Faith).
20:46:42 <ttx> edleafe: Ah. Isee. Good distinction
20:46:51 <annegentle> ttx CoC's have enforcement rules. This is a principle
20:46:57 <thingee> edleafe: +100
20:46:58 <flaper87> right
20:46:59 <thingee> thank you
20:47:03 <flaper87> edleafe: loved the wording
20:47:05 <cdent> that's why I highlighted "we don't blame and shame" in my comment. That's a conduct
20:47:06 <annegentle> we're not going to report people for not assuming good faith
20:47:13 <ttx> I'm not certain we can tell people how they should think in a "principles" document either
20:47:37 <flaper87> cdent: that can be fixed, likely just poor wording on my side
20:48:06 <dtroyer_zz> I think cdent pointed out one other reason why it is different from the CoC: including corporate behaviours here
20:48:24 <ttx> flaper87: maybe "try to assume good faith" is better then
20:48:36 <annegentle> ttx to me, this principles document tells people how to approach others in the context of OpenStack, and writing down that we all assume good faith is a principle "We should all assume good faith in our interactions"
20:48:50 <flaper87> ttx: I guess
20:48:59 <flaper87> We all fail to assume good faith from time to time
20:49:01 <dims> Are we trying to say that we all wear multiple hats, but we need to the right thing when we are thinking/working on openstack?
20:49:02 <flaper87> I've failed
20:49:14 <flaper87> One good thing about this is that we can also link people to it
20:49:20 <ttx> I fail to assume good faith and use wrong english words :)
20:49:28 <smcginnis> :)
20:49:31 <flaper87> ttx: ditto
20:50:06 <edleafe> ttx: I assumed your good faith when reading your email today
20:50:07 <edleafe> :)
20:50:10 <ttx> flaper87: maybe we could reword it to include a sentence on being mindful of geographical difference etc
20:50:14 <flaper87> To be honest, putting it there doesn't mean people will do it. I'd hope more folks would but that's just my personal hope/belief
20:50:19 <flaper87> ttx: ++
20:50:40 <jroll> ttx: +1, and cultures
20:50:41 <annegentle> flaper87 I think it's about the "write expectations down"
20:50:47 <smcginnis> I think the intro paragraph positions this well as "guiding principles that are used to inform and shape decisions"
20:50:47 <mtreinish> flaper87: heh, but it means you can link to it :)
20:50:48 <ttx> flaper87: let's see how we can tweak it to make it less of a behavior definition and more of an aspiring thing
20:50:56 <flaper87> annegentle: that's what I want, that's the point
20:51:07 <flaper87> mtreinish: right
20:51:14 <flaper87> ttx: sounds good to me
20:51:25 <flaper87> smcginnis: ++
20:51:50 <thingee> ttx: +1
20:52:05 <ttx> #info Work on wording to make it more aspirational and include being mindful of our language/geographical/cultural diversity
20:52:12 <dims> +1 ttx
20:52:20 <annegentle> flaper87 ++ yep
20:52:25 <flaper87> Also, it's fine if some folks don't want to assume good faith but it's not ok to make it public. So, aspiring to assume good faith is definitely the goal
20:52:38 <flaper87> making it public is offensive for many cultures
20:52:39 <ttx> We might be able to avoid most of the CoC-like language in it, in which case I would not oppose it that much
20:53:05 <flaper87> And by making it public I mean accussing people based on the personal preference to not assume good faith
20:53:06 <dhellmann> most of the other principles are either focused on leaders or on teams, not individual contributors. Maybe if it can be reframed a bit more that way that would make it feel like it fits better.
20:53:11 <ttx> ok, looks like we ahve some way forward
20:53:26 <flaper87> thanks everyone
20:53:43 <ttx> #topic Open discussion
20:53:47 <johnthetubaguy> I think we are all pointing at a thing that we want to capture there, +1 capturing that
20:53:55 <ttx> Elections are under way, vote if you haven't already. We'll hold the first meeting for the Ocata membership next week
20:54:01 <dhellmann> the patchf for the wording tweaks on the tc-approved-release is up https://review.openstack.org/382064
20:54:12 <ttx> Small reminder that there will be a BoD+TC+UC meeting in Barcelona on Monday afternoon, starting at 2:30pm, followed by dinner at 7:30pm
20:54:17 <annegentle> rebase went fine on this one
20:54:18 <annegentle> #link https://review.openstack.org/#/c/371538/
20:54:24 <ttx> I'll send RSVPs over once elections are complete
20:54:25 <mtreinish> dhellmann: I was actually working on adding a principle to say the way to implement change is individual contributors doing the work
20:54:31 * flaper87 read patchf and thought that was a secret command to fix patches
20:54:32 <mtreinish> to try and capture that sentiment
20:54:47 <mtreinish> I'm trying to come up with the right wording to express that thought clearly though :)
20:54:57 <dhellmann> mtreinish : "we work together"
20:55:02 <ttx> mtreinish: "Contribution Is Our Currency" ?
20:55:03 <dims> :)
20:55:15 <Rockyg> Own the change you want to happen
20:55:25 <smcginnis> hah
20:55:28 <mtreinish> heh, those are all better than my tenative title right now "The Mechanism for Change is People"
20:55:54 <ttx> I'm getting attached to our weird capitalization there
20:55:58 <johnthetubaguy> I thought we had a patch up for that already, maybe from sdague?
20:55:58 <fungi> it's worth noting that the civs maintainer reported cornell's mailservers are either deferring or dropping a lot of messages (hence the resend of all ballots), so lots of the electorate may not have received ballots still
20:56:03 <anteaya> mtreinish: ha ha ha
20:56:17 <smcginnis> OpenStack is made out of people
20:56:21 <dims> Do-Do-ocracy
20:56:21 <dhellmann> fungi : is that software something we could host for ourselves?
20:56:32 <Rockyg> Soylent green!!!!!
20:56:32 <mtreinish> johnthetubaguy: I think sdague complained about it on the original goals, but I haven't seen a patch for it
20:56:36 <ttx> dhellmann: we could.
20:56:39 <anteaya> smcginnis: so apparently is soylent green if you watch cloud atlas
20:56:41 <smcginnis> Rockyg: ;)
20:56:43 <dims> Rockyg : you typed faster than me :)
20:56:59 <fungi> dhellmann: it is, but then we lose the current third party situation which sort of helps defend us from ourselves (granted the trade-off may be better than losing ballots)
20:57:02 <johnthetubaguy> mtreinish: I may have imagined it
20:57:08 <dhellmann> fungi : yeah
20:57:32 <ttx> everyone: please check the tentative cross-project workshop schedule and let me know if you spot hard conflicts
20:57:45 <anteaya> dhellmann: it has come up before
20:58:02 <ttx> Newton was a great TC session (it's also a great release, despite the general modd)
20:58:07 <ttx> mood*
20:58:13 <anteaya> dhellmann: I think the loss of the independant third party would be large if we hosted it
20:58:18 <jroll> ttx: ++
20:58:31 <flaper87> fungi: is it something we can contribute servers/cpu too? (admitelly, I'm not familiar with the problems they are haivng ?
20:58:36 <ttx> So as we wrap it up, please find the time to celebrate
20:58:44 <dhellmann> anteaya : makes sense. Still, if we've outgrown what they can support, it might be necessary.
20:58:50 <fungi> flaper87: no, i don't think it's likely to be a resource issue
20:58:56 <annegentle> ttx agreed! Well done, all.
20:58:58 <ttx> People are using that software everywhere for a lot of things, and they are getting happier and happier using it
20:58:59 <flaper87> fungi: gotcha
20:59:00 <fungi> flaper87: and it's the cornell university mailservers in this case
20:59:11 <flaper87> fungi: oh, mmh. :(
20:59:13 <dhellmann> ttx: well said
20:59:22 <flaper87> ttx: ++
20:59:24 <fungi> if through some strange turn of events i'm elected to a seat on the tc, i'm on vacation next week and so won't be around for the meeting
20:59:27 <flaper87> ttx: group hug ?
20:59:34 * flaper87 grabs ttx before he runs
20:59:38 <ttx> There is probably a chinese proverb with a mountain and a rock to express seeing only the negative aspects :)
21:00:06 <ttx> "Those who walk the mountain pay attention to the rocks" ?
21:00:08 <dims> fungi : thanks for the heads up. best wishes
21:00:29 <anteaya> ttx: are you making up proverbs?
21:00:43 <ttx> anteaya: I'm making up lots of things
21:00:47 <edleafe> Thanks to all the outgoing TC members for their service!
21:00:48 <ttx> and that is a wrap
21:00:49 <dolphm> ancient openstack proverb
21:00:51 <annegentle> ttx make it up as you go!
21:00:52 <annegentle> :)
21:00:55 <anteaya> dhellmann: it is worth another discussion yeah
21:00:58 <ttx> #endmeeting