20:02:02 <ttx> #startmeeting tc
20:02:03 <openstack> Meeting started Tue Oct 18 20:02:02 2016 UTC and is due to finish in 60 minutes.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:02:04 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:02:07 <amrith> ./
20:02:07 <openstack> The meeting name has been set to 'tc'
20:02:20 <ttx> Hi everyone,
20:02:23 * edleafe lurks in the back of the room
20:02:24 <ttx> Our agenda for today:
20:02:24 <flaper87> hello
20:02:25 <johnthetubaguy> o/
20:02:30 <ttx> #link https://wiki.openstack.org/wiki/Meetings/TechnicalCommittee
20:02:36 <ttx> (remember to use #info #idea and #link liberally to make for a more readable summary)
20:02:38 * stevemar drags edleafe up to the front
20:02:50 <ttx> #topic Finalized BoD/TC/UC meeting agenda
20:03:08 <ttx> So I communicated our ideas to Alan and he came up with an agenda that should cover most of our points
20:03:14 <mordred> o/
20:03:15 <ttx> #link https://wiki.openstack.org/wiki/Governance/Foundation/24Oct2016BoardMeeting#Joint_Board.2FTC.2FUser_Committee_Meeting_.28DRAFT.29
20:03:33 <ttx> let me know if you have comments
20:03:44 <ttx> Note that the "Incubating New Concepts and Projects" point (proposed by Board members) is a bit of a misnomer.
20:03:54 <ttx> I expect it to be about our criteria for approving projects
20:04:03 <ttx> - the "Mission" fit, and how far it can go
20:04:15 <ttx> - the "Community" fit, and the cost of [not] supporting additional languages
20:04:19 * flaper87 wonders what "Incubating New Concepts and Projects" is
20:04:24 <flaper87> guess we'll find out
20:04:27 <mordred> I'm SOOOOO looking forward to that section
20:04:28 <dtroyer> heh, it Imad
20:04:36 <ttx> mordred: inorite
20:04:52 <mordred> I will try my best to not get kicked out of the room for violating the code of conduct
20:05:01 <ttx> I managed to put it at the end, so maybe we could start drinkikng at the same time
20:05:04 <sdague> mordred: don't try too hard
20:05:07 <mordred> sdague: :)
20:05:11 <stevemar> :)
20:05:38 <ttx> I hope we can keep it civil and mostly around explaining our current decision on Go and how we expect to make progress in the future
20:05:42 <fungi> mordred can be the off-the-chain element so that the rest of us seem comparatively rational
20:05:48 <mordred> ttx: I actually ....
20:05:57 <ttx> but yes, could end up being pretty heated :)
20:06:00 <mordred> ttx: honestly, I reject the premise that we need to explain our current decision on go
20:06:15 <amrith> ttx, I'm wondering about the item "Upstream developer investment". Is that being led by the TC or the Board or the UC?
20:06:18 <mordred> any more than we expect the board to explain decisions it makes on trademark policy
20:06:20 <ttx> we don't need to justify it, but explaining it sounds good to me
20:06:37 <mordred> ttx: sure. but I would like to make sure we keep i mind that explaining is what we're doing, not justifying
20:06:44 <ttx> amrith: it's coming from us, but the title is alan's
20:06:51 <johnthetubaguy> explaining why we think its hard would be no bad thing
20:07:08 <flaper87> TBH, I don't mind to talk about it but, if we need to *explain* it, then we might have done a poor job communicating the decision properly
20:07:14 <amrith> ttx, thx. as in the past, I'm assuming that this is an open meeting (open to non TC/Board/UC), yes?
20:07:18 <ttx> yes
20:07:21 <flaper87> I'd expect the same message to the dev community to be useful for the board
20:07:22 <amrith> thx
20:07:31 <dhellmann> flaper87: a lot of people heard "no" and stopped listening at "because..."
20:07:32 <fungi> amrith: concerns over loss of large blocks of upstream contributors as some of our member companies shift directions and scale back their involvement/use of openstack
20:07:41 <ttx> dhellmann: exactly
20:07:49 <amrith> fungi, you are describing my day-to-day
20:07:54 <fungi> :/
20:07:57 <flaper87> dhellmann: right, I would expect some people not to stop there
20:08:05 <ttx> dhellmann: a lot of people heard "no" when we said "no, not now and not this way"
20:08:12 <dhellmann> ttx: yes, that, too
20:08:24 * johnthetubaguy nods at ttx
20:08:31 <flaper87> That being said, (over-)communicating won't get rid of surprises entirely and surprises are not always a sign of lack of transparency
20:08:46 <dtroyer> fwiw, some have had it explained to them many times since then
20:08:56 <ttx> Another topic I raised (and which was accepted on the agenda) is how we approach the programming of the “forum” for Boston and beyond.
20:09:07 <flaper87> anyway, like I said, I don't mind us talking about it. I do want us to reflect if something went wrong on how we communicated this
20:09:10 <ttx> To make that event successful we need to make sure all of the facets of our community participate in proposing (and selecting) the topics we'll discuss there
20:09:17 <ttx> so it's a good cross-community topic (UC+TC)
20:09:23 <stevemar> ttx: that came up today in the keystone meeting, folks were wondering what the forums will look like
20:09:24 <ttx> It's a tight agenda
20:09:43 <johnthetubaguy> true, we need UC help there
20:10:09 <ttx> stevemar: they will look like a lot like cross-project workshops, ops fishbowls and other town halls we had in the past
20:10:36 <ttx> stevemar: happy to give people more explanation, but maybe off-meeting
20:10:42 <stevemar> ++
20:11:01 <ttx> Any other comment on the BoD+TC+UC agenda ?
20:11:48 <dhellmann> it does look tight, but all of the topics look good this time
20:12:08 <ttx> ok, moving on then
20:12:15 <ttx> #topic Add more ways to get extra-atcs into the books
20:12:22 <ttx> #link https://review.openstack.org/381894
20:12:32 <ttx> So in the reviews there seems to be two ways of looking at this one
20:12:42 <ttx> 1/ Ops feedback is an upstream contribution, so AUCs should be considered extra-atcs and vote in the TC election
20:12:53 <ttx> 2/ Solution is to set up proper elections around the UC to give that body more influence, so this change is a distraction that would likely delay efforts for proper recognition of users for what they are
20:13:04 <ttx> Both are valid imho, so I'd like us to think a bit more about it
20:13:19 <ttx> We'll discuss in-person the UC charter at the BoD+TC+UC meeting, so I think it will be a great venue to make progress on that question
20:13:29 <johnthetubaguy> honestly, it feels like the end goal might be both
20:13:35 <ttx> And discuss if it's better to (1) have TC and UC constituency overlapping, but distinct; or (2) have both consituencies voting in both elections (ATC vote for UC and AUC vote for TC)
20:13:41 <dhellmann> based on earlier discussions about extra-atcs, I've added "reminder" notes to the release process to be sent out at different times in the countdown emails that I send for the release team
20:13:42 <ttx> or (3) some other creative solution
20:13:50 <sdague> johnthetubaguy: yeh, it just feels like 2 should go first
20:13:55 <dtroyer> ttx, did I understand your comment about the timeframe for the UC to be 6months or so? -ish?
20:14:03 <ttx> Personally I like to keep constituencies aligned with the area the body oversees, so I lean toward (1)
20:14:12 <ttx> dtroyer: it might actually get even faster
20:14:12 <johnthetubaguy> sdague: yeah, it feels like we violate our principals if not
20:14:24 <ttx> the board might vote on bylaws amendment before end of year
20:14:26 <sdague> ttx: are AUCs already being accumulated and listed somewhere?
20:14:30 <ttx> for elections early January
20:14:47 <dhellmann> ttx: what sort of things are you thinking when you say "give that body more influence"?
20:14:48 <ttx> sdague: I don't thnk they finalized the criteria, it's part of their charter they want to present at the meeting
20:15:09 <thingee> I agree with sdague's last comment that I'd like to see that first as well.
20:15:20 <fungi> it's worth noting that auc covers a lot more types of contribution than people may be realizing. for example, writing an article for superuser magazine, being a track chair for the conference, answering questions on ask.o.o...
20:15:27 <dtroyer> yeah, if the timeframe isn't long, agreed on #2 first
20:15:34 <thingee> dtroyer: +1
20:15:39 <johnthetubaguy> I love the idea of everyone voting in both elections, on the grounds of us all needing to work closely together, but that might be going too far too quickly
20:15:51 <johnthetubaguy> everyone = AUC + ATC
20:15:58 <fungi> it's not entirely clear to me that all of the things which make someone eligible as an auc make sense for the tc electorate
20:16:01 <ttx> dhellmann: I think it's better if the UC has legitimacy built from elections, rather than start counting how many AUCs there are vs. ATCs
20:16:20 <ttx> Also I like the suggestion of having a representative from the other committss sitting
20:16:24 <dhellmann> ttx: ok, that makes sense
20:16:26 <johnthetubaguy> our principals do suggest the need for electing a UC
20:16:28 <flaper87> ttx: yeah
20:16:31 <dhellmann> fungi : yes, I tend to agree
20:16:32 <ttx> like UC appointing one member to the TC and the other way around
20:16:37 <stevemar> fungi: agreed, and vice versa
20:16:41 <mordred> ++
20:16:59 <johnthetubaguy> appointing a representative is a nice alternative
20:17:14 <ttx> otherwise it's like, the moment there are 51% AUC in the electorate we get ops, and at 49% we don't
20:17:29 <ttx> I prefer to guarantee some representation
20:17:49 <dhellmann> yes, good point
20:17:51 <ttx> and mend the gap by having people sitting on both sides
20:17:54 <johnthetubaguy> ttx: hmm, true
20:18:16 <johnthetubaguy> sounds like a good starting point
20:18:22 <ttx> so I think it's urgent to wait for the meeting and see how fast that elected UC can be set up
20:18:23 <sdague> honestly, I would be careful trying to build a complex model instead of just making more forums to talk to each other
20:18:44 <ttx> happy to discuss this more in-person next week
20:18:49 <flaper87> ++
20:18:51 * mordred wants to also remind everyone that UC !== ops because users != operators
20:18:54 <Rockyg> ++
20:19:07 <mordred> there are at least 2 different sets of under-represented users, ops are one
20:19:15 <johnthetubaguy> sdague: more forums? do you have an example? is that the new "forum" thingy?
20:19:15 <ttx> mordred: how much does the AUC criteria care for end users, though
20:19:25 <sdague> johnthetubaguy: no, I just mean in general
20:19:39 <mordred> ttx: I do not know how much it cares for end users now - but hopefully it will be working towards caring about them
20:19:45 <Rockyg> ttx:  pretty good representation beyond Ops
20:19:47 <dhellmann> yeah, I've always associated the UC with "people who run openstack" not just people on the other side of an openstack API
20:19:51 <mordred> otherwise I will need to suggest we call it the operator committee
20:19:51 <johnthetubaguy> sdague: OK, cool, +1 that, I am just struggling to work out how to make that happen
20:19:52 <sdague> some times it looks like we can build a complicated process or governance thing to replace spending time getting to know each other and listen
20:19:54 <ttx> ack
20:20:01 <sdague> and... I think it works poorly :)
20:20:03 <mordred> I am on a mission to remind people that API users are users
20:20:08 <stevemar> sdague: bad timing to use the word "forum" :P
20:20:13 <sdague> stevemar: yes
20:20:26 <johnthetubaguy> sdague: yeah, thats certainly a thing we have a tendency towards
20:20:27 <flaper87> mordred: might be the case... (re name)
20:20:37 <stevemar> "channels/venues for communication"
20:20:45 <mordred> but - we'll be in the room with the UC next week - so we can chat about it :)
20:20:46 <sdague> mordred: maybe that's another reason to get the UC going on direct election first and make sure it's getting the right mix there
20:20:47 <ttx> ok, everyone agrees to defer the decision on that one to at least after that BoD+TC+UC meeting ?
20:20:54 <mordred> ttx: ++
20:20:56 <dhellmann> ++
20:20:56 <flaper87> oh yeah
20:20:56 <mordred> sdague: ++
20:20:59 <sdague> ttx: ++
20:21:00 <thingee> ++
20:21:02 <johnthetubaguy> ++
20:21:10 <dtroyer> ++
20:21:11 <fungi> sounds good
20:21:16 <stevemar> ++
20:21:26 <ttx> #agreed let's defer the decision on this one until after the UC presents its charter to the BoD+TC+UC meeting next week
20:21:41 <ttx> moving on to next topic
20:21:50 <ttx> #topic Add "Contributing Is Our Currency" to principles doc
20:21:56 <ttx> #link https://review.openstack.org/382110
20:22:07 <ttx> Looks like this one is close enough to be merged now
20:22:20 <ttx> There is a follow-up tweak from cdent @
20:22:24 <stevemar> ++, its been through enough word smithing (and the follow-on patch)
20:22:24 <ttx> #link https://review.openstack.org/#/c/387370
20:22:30 <ttx> which we'll consider at the next meeting (also would very much like to have mtreinish's opinion on it)
20:22:38 <cdent> yeah, I stripped it down to its bare essence
20:22:50 <flaper87> ttx: can we start merging mtreinish's ?
20:22:53 <ttx> Objections to getting the initial one merged now ?
20:22:55 <cdent> I hope people saw the comment I left on patchset one, I'm increasingly concerned about that
20:23:22 <dhellmann> cdent : ps1 of which?
20:23:30 <ttx> 387370
20:23:32 <cdent> dhellmann: my follow up
20:23:40 <ttx> "While working on this it made think of something I've been very concerned about in a lot of 'do-ocracy' style communities: If contribution is cast as "fixing problems" then being overly zealous about 'do-ocracy' can have a negative impact on people being wiling to "identify problems" (aka "complain about stuff that doesn't work well") because they will be expected to fix it at that point, even if
20:23:42 <ttx> they don't know how or don't have time. I've both witnessed and experienced this in OpenStack."
20:23:55 <dhellmann> ah, yes
20:24:04 * ttx merges initial version unless someone screams
20:24:21 <flaper87> ttx: what if I scream "YES, MERGE IT" ?
20:24:32 <ttx> flaper87: that will make me pause and merge it
20:24:38 <flaper87> oh ok
20:24:41 * flaper87 takes note
20:24:49 <fungi> and elicit offers to help you fix your caps-lock key
20:24:49 * mordred likes the cdent followup- wants to bikeshed over 'anyone' vs. 'everyone'
20:24:54 <ttx> ok, it's in
20:24:55 <stevemar> cdent: we can add something that encourages folks to still identify problems?
20:25:14 <cdent> mordred++
20:25:29 <sdague> I think the point of this is there were 3 sections about voting in the priciples before, and 0 sections about contributing
20:25:31 <flaper87> fungi: but it's a scream :P
20:25:39 <flaper87> sdague: ++
20:26:07 <dhellmann> I'm not sure about removing the sentence about hierarchy from cdent's follow-up. We see that frequently, folks joining the community and trying to push change through the TC or PTLs instead of allocating resources and doing work.
20:26:11 <mordred> I would also love to how to communicate "we value identifying problems, but also you can't possibly get upset if your issues don't get immediately addressed if you aren't providing resources to address them" without being negative
20:26:22 <mordred> dhellmann: we may have just said the same thing
20:26:34 <mordred> although dhellmann said it nicer, as might be expected
20:26:35 <dhellmann> mordred : I think so, yes
20:26:36 <ttx> dhellmann: yeah, I don't think that this sentence is redundant at all
20:26:46 <sdague> and while I do get the concern that when there is an imbalance of reporting vs. fixing problems we run into friction, I'm not sure any set of words make that go away
20:26:47 <stevemar> mordred: i like that one
20:26:54 * flaper87 agrees with dhellmann therefore he agrees with mordred (on that last sentence)
20:27:27 <flaper87> sdague: agreed, I think comon sense comes into play there
20:27:29 <EmilienM> (hi, just landed)
20:27:29 <mordred> although I agree with sdague
20:27:30 <cdent> part of the reason I remove the hierarchy sentence was because it was so twisted and strained that I couldn't think of a good way to put it, so I just dropped it
20:27:32 <edleafe> dhellmann: it's tricky. Sometimes they do the work, and then get told "that's not how we want to go".
20:27:48 <dhellmann> maybe we can add something about there being a lot of different ways to contribute, to address the concern about do-ocracy?
20:27:50 <mordred> cdent: yah. like, I like the way your thing reads, and although I have my concern, I think sdague makes a good point
20:28:01 <dhellmann> edleafe : yeah, that's a completely different problem
20:28:01 <ttx> ok, let's do a few other review rounds on cdent's tweak
20:28:08 <dhellmann> edleafe : or, well, related but not identical
20:28:09 <ttx> and move on to the next agenda item
20:28:12 <johnthetubaguy> cdent: coming to talk constructively with the community about the problem, and helping write it down counts as doing, but maybe I am stretching that too far?
20:28:18 <fungi> edleafe: the challenge there being that part of "doing the work" means making it acceptable to the rest of the community
20:28:20 <mordred> which is that the c-suite folks who expect everyone else to fix their problems without doing anything themselves aren't going to read this in the first place
20:28:21 <edleafe> dhellmann: yup
20:28:38 <flaper87> johnthetubaguy: I don't think there's a magic formula for that
20:28:49 <johnthetubaguy> yeah, I am +1 sdague's comment on that
20:28:57 <sdague> and also realizing we are all humans with finite bandwidth, and sometimes people don't fully understand the ramifications of things from early sketches
20:28:59 <mordred> yah. also, sometimes your idea is bad
20:29:09 <mordred> and the rest of the community will tell you that
20:29:15 <mordred> and it doesn't make you a bad person
20:29:15 <stevemar> IMO the sentence removed in 387370 just explains our structure, that's not the same as 'hey i found an issue, but don't have the technical skill to fix the code', filing a bug is still helpful
20:29:20 <fungi> (my ideas are often bad, and i'm glad people tell me)
20:29:24 <mordred> fungi: same here!
20:29:30 <mordred> it's like the definition of most of my days
20:29:57 <johnthetubaguy> fungi: FWIW, thats totally why I love OpenStack
20:29:58 <ttx> ok, let's iterate on the review rather than try to paint it blue right now
20:30:05 <stevemar> okie
20:30:22 <mordred> ttx: I WANT GREEN
20:30:22 <ttx> moving on
20:30:25 * cdent suspects edleafe will want red
20:30:26 <ttx> #topic Adjust TC and PTL election timeframes
20:30:28 <ttx> mordred: I know
20:30:32 <ttx> #link https://review.openstack.org/385951
20:30:40 <ttx> So the proposal seems to be pretty popular
20:30:44 <ttx> That changes
20:30:51 <edleafe> cdent: it's the only sane choice, really
20:30:52 <ttx> notmyname raises an interesting point though -- do we need buy-in from current PTLs on it ?
20:31:03 <dhellmann> yes, I think so
20:31:03 <ttx> On one hand they are affected by the decision, and it can't really hurt
20:31:13 <ttx> On the other hand it's /very/ unlikely that we'll get all PTLs to signoff on this
20:31:13 * dims peeks
20:31:14 <dhellmann> it would have been better to do this before the election, but the timing didn't work out
20:31:20 <ttx> (I mean, I can't even get them to all fill their design summit schedule)
20:31:35 <ttx> A thread was raised on the ML, but only a few PTLs chimed in on the review as a result
20:31:37 <mugsie> Yes. Or at least push it out to them, and say this is going to be merged in x days
20:31:37 <dhellmann> ttx: I don't think they need to agree, but they need to acknowledge the change
20:31:51 <flaper87> +1 for acknowledging
20:31:52 <sdague> acknowledgement would be good
20:31:54 <ttx> mugsie: so... wait a bit more to gather more PTL +1s, but mention a hard deadline
20:31:59 <dhellmann> or be given a chance to acknowledge
20:32:00 <mugsie> Yea
20:32:05 <ttx> sounds good to me
20:32:05 <stevemar> ttx: set a deadline? say something now or forever hold your peace?
20:32:05 <thingee> dev ml announcement / dev digest I think covers us
20:32:18 <mordred> stevemar: ++
20:32:24 <flaper87> thingee: TBH, I'd even push it to their inboxes
20:32:30 <edleafe> But what if they claim the whole thing is rigged?
20:32:35 <stevemar> flaper87: that would be good too
20:32:37 <mordred> edleafe: let's not go there
20:32:41 <edleafe> :)
20:32:42 <ttx> so I'll reply to the ML thread mentioning that we'll pass it and that they should raise now if they object
20:32:43 <sdague> honestly, having a straw poll of them would be good. If we could hit them directly and ask them to weigh in
20:32:43 <stevemar> :)
20:32:51 <EmilienM> flaper87: right, what ttx does most of the time
20:33:00 <EmilienM> flaper87: and even with that, iiuc, some ptls still don't ack
20:33:06 <dhellmann> ttx: would Nov 8 be a good deadline?
20:33:10 <sdague> because, I honestly think most people thought this is how it would be
20:33:10 <ttx> EmilienM: sadly yes
20:33:12 <flaper87> EmilienM: yup :(
20:33:29 <ttx> dhellmann: or Nov 1st if we think we can have a meeting then
20:33:30 <johnthetubaguy> sdague: +1 I think most did
20:33:37 <flaper87> Again Surprise != lack of transparency/communication
20:33:59 <mordred> zomg. I want to jump out from behind things and yell Surprise at people all next week
20:34:02 <dhellmann> ttx: if we can get feedback by then, I'd be ok with the 1st, but the 8th gives PTLs time to catch up on the mailing list after summit
20:34:19 <mordred> and then follow up with a really obscure TC governance factoid
20:34:20 <flaper87> ttx: I'd prolly go with the 8th, just to give ppl time after the summit
20:34:20 <dtroyer> I don't think waiting a week will hurt us
20:34:22 <ttx> #action ttx to reply to thread mentioning a hard deadline and asking PTLs to +1
20:34:23 <EmilienM> +1 on 8th, it's a fair deadline regarding scheduling
20:34:31 <edleafe> flaper87: not always. You can lead a horse to water...
20:34:31 <stevemar> dhellmann: yeah, we have some runway here
20:34:42 <ttx> #agreed deadline should be TC meetign on NOv 8
20:34:43 * bswartz thinks PTLs should be elected for life...
20:34:44 <mugsie> I would actually be ok with the first, but just giving a hard deadline helps getting people to do stuff
20:34:58 <mugsie> bswartz: obviously
20:35:21 <fungi> bswartz: a lifetime term would drive me to an early grave, so we still might have just as much ptl turnover as we do now ;)
20:35:33 <ttx> ok that sounds like a plan
20:35:42 <dhellmann> fungi : I was thinking something similar. "Stepping down" would take on a whole new meaning.
20:35:42 <ttx> anything else on that topic ?
20:35:52 <mordred> have we had an instance of a sitting PTL losing to a challenger?
20:35:54 <ttx> dhellmann: hard to do it gracefully then
20:35:55 <johnthetubaguy> fungi: yeah, surprisingly equivalent I suspect
20:36:01 <dhellmann> ttx: quite
20:36:14 <ttx> mordred: yes
20:36:17 <mordred> ttx: neat!
20:36:18 <edleafe> mordred: mikal lost to johnthetubaguy
20:36:20 <sdague> mordred: yes
20:36:20 <fungi> mordred: neutron at least
20:36:26 <fungi> oh, right, so nova too
20:36:34 <ttx> and magnum
20:36:36 <mordred> that's excellent. I had forgotten both of those
20:36:38 <ttx> it happens
20:36:42 <sdague> ironic too iirc
20:36:44 <edleafe> and I think devananda lost to jroll
20:36:58 <mordred> so tons of them and I'm just dense :)
20:37:00 <ttx> adrian lost to Hongbin in magnum
20:37:04 <fungi> so it's actually a tradition
20:37:05 <stevemar> so what we're saying is, it's happened :)
20:37:08 <edleafe> mordred: yes, that :)
20:37:09 <mordred> \o/
20:37:10 <flaper87> and Glance
20:37:15 <sdague> mordred: it's not a huge percentage, but it has happened
20:37:31 <ttx> sdague: given the number of elections we had (not so many), it's actually significant
20:37:38 <edleafe> But has an incumbent TC member lost re-election
20:37:42 * edleafe stirs up the pot
20:37:45 <sdague> edleafe: yes
20:37:50 <dtroyer> ed, yes, a couple of times
20:37:58 <mordred> I lost to jaypipes back in the PPB days
20:37:59 <stevemar> thats true, many more win-by-default than actual elections every 6 months
20:38:01 <edleafe> ok, good to know
20:38:17 <ttx> looks like we are in open discussion already
20:38:22 <stevemar> :)
20:38:23 <amrith> mordred, PPB was smaller
20:38:25 * ttx officializes
20:38:26 <edleafe> ttx: sorry, my bad
20:38:29 <ttx> #topic Open discussion
20:38:30 <stevemar> lets get the train back on track?
20:38:39 <amrith> I did download all the old data and was looking at this and voting trends.
20:38:46 <amrith> surprising blocks :)
20:38:52 <stevemar> ttx: what about https://review.openstack.org/#/c/365590/ ?
20:38:53 <mordred> amrith: the blocks are fun :)
20:38:57 <fungi> amrith: any specific insights?
20:39:04 <mordred> amrith: if you REALLY want fun - go read the old PPB meetings in the IRC logs
20:39:08 <ttx> amrith: were there ? My partisan analysis could not detect that many
20:39:23 <mordred> the ones from year one are _fascinating_ and also make you want to remove your own leg and beat yourself with it
20:39:24 <ttx> amrith: I detected a Cinder voting block and an Infra voting block
20:39:24 <fungi> i'm always really interested in our project-wide voting trends, but lack the bandwidth to do real analysis
20:39:25 <sdague> mordred: you and I have a different definition of fun :)
20:39:28 <amrith> fungi, was going to write a blog post about the surprising number of votes with one 1 and a number of 21's ...
20:39:35 <amrith> in this past election.
20:39:41 <fungi> amrith: i would read ;)
20:39:49 <amrith> fungi, I am writing
20:39:52 <mordred> amrith: those don't do quite what people think they do
20:39:55 <mugsie> Well, there is the lack of elected people who came from a project that didn't spin out of nova
20:40:03 <mordred> mugsie: not true
20:40:07 <mugsie> Oh?
20:40:11 <mugsie> I couldn't find any
20:40:13 <stevemar> ttx: any change on https://review.openstack.org/#/c/384317/ getting punted through? it's a typo type fix
20:40:14 <mordred> mugsie: ttx, me, fungi
20:40:16 <ttx> mordred: release management has 3 members
20:40:36 <ttx> dhellmann arguably did not come from nova either
20:40:58 <mordred> yah. dhellman. flaper87 depending on whether we associate him with zaqar or glance
20:40:59 <ttx> same for EmilienM
20:41:05 <mordred> yup
20:41:06 <stevemar> mordred: me and EmilienM too
20:41:13 <dtroyer> depends if ' came from' == 'has >1commit to'
20:41:21 <mordred> dtroyer: :)
20:41:29 <flaper87> I don't think I have commits on nova...
20:41:30 <ttx> heck, I have more commits in Swift than in Nova
20:41:32 <flaper87> oh I do
20:41:35 <mordred> mugsie: in fact, really, most of the TC does not descend from nova
20:41:38 <flaper87> nvm
20:41:38 <flaper87> but yeah
20:41:38 <flaper87> what mordred said
20:41:44 <ttx> mugsie: what made you think that ?
20:41:44 <amrith> for the record; I got a bad microphone and I lost because the election was rigged. I'm not saying that, that's what others are saying.
20:41:51 * flaper87 doesn't descend from nova
20:41:58 <dhellmann> oh, yeah, I probably have a bunch of release or oslo-related commits to nova over the past few years, but I don't consider myself a "nova contributor"
20:42:00 <ttx> interesting myths
20:42:00 <stevemar> amrith: :)
20:42:11 <cdent> mugsie said project that spun out of nova
20:42:13 <cdent> not from nova
20:42:14 <mugsie> Projects spun out of Nova ;)
20:42:16 <cdent> jinx
20:42:19 <cdent> :)
20:42:20 <mugsie> Hah
20:42:38 <ttx> We'll obviously be skipping the online IRC TC meeting next week
20:42:40 <mugsie> Sorry, it's cross project or not spun out of Nova
20:42:42 <ttx> mordred: what news re: TC dinner night in Barcelona ?
20:42:49 <mordred> ttx: still planning on having one
20:43:03 <mordred> I should get a head count - so I'll send out an email and stuff
20:43:03 <ttx> mugsie: true. Cross-project work definitely gives you a lift for TC, but I would argue that's fair
20:43:24 <ttx> since the TC is actually about openstack as a whole
20:43:33 <mugsie> ttx: oh, I agree
20:43:34 <fungi> mugsie: i sprung fully formed from zeus's forehead
20:43:41 <mugsie> But is it interesting non the less
20:43:46 <ttx> fungi: I thought you came from a spore
20:43:52 <fungi> touché
20:43:53 <jeblair> fungi: from zuul's forehead?
20:43:54 <edleafe> ttx: ha!
20:43:54 <amrith> :)
20:43:58 <johnthetubaguy> Nova is surprisingly cross project-ey in nature
20:44:04 <clarkb> I think ttx wins
20:44:07 <fungi> jeblair: if only
20:44:12 <amrith> edleafe, good question.
20:44:40 <ttx> mordred: I checked, Tickets is all booked
20:44:44 <ttx> :)
20:44:50 <flaper87> mordred: I'm in
20:44:51 <notmyname> is cross-project defined as a particular set of code repos or simply "work that involves more than one project"?
20:44:52 <mordred> ttx: yah. also, I was aiming for lower-key than that :)
20:45:12 <mordred> notmyname: work that is focused on the aggregate whole rather than a specific subset
20:45:20 <dhellmann> mordred : my only request is not friday, since I have a friday flight
20:45:28 <mordred> dhellmann: yah - thursday is when we're aiming for
20:45:29 <flaper87> notmyname: I'd say projects that impact the community horizontally (?)
20:45:29 <ttx> mordred: Disfrutar has some kitchen staff from El Bulli, but not low-key at all
20:45:33 <dhellmann> mordred : ++
20:45:41 <flaper87> mordred: thursday should work
20:45:49 <fungi> sometimes work on a particular library or tool that is used by many projects could be cross-project work on a single repo
20:46:19 <fungi> though more often there are corresponding changes in those projects to implement as well
20:46:54 <mugsie> notmyname: I don't really have a definition, just looking at a project or repo and saying that it looks cross project
20:46:55 <ttx> mordred: thursday ok but not too early (but then any decent catalan place would not serve before 9)
20:47:25 <Rockyg> Guys,  wanted to toss some UX info your way so you can chew on it before the summit....https://drive.google.com/file/d/0B8h-c0zHxYBoXzFMQWJsY09Eclk/view?usp=sharing
20:47:40 <ttx> notmyname: my definition is cross-project = work that affect most projects, while inter-project = work that affect multiple projects
20:48:00 <ttx> (terminology courtesy of ildiko actually, to give credit where due)
20:48:07 <notmyname> ttx: ah. "inter-project". interesting
20:48:20 <ttx> like Nova-Cinder work, or Swift-Storlets
20:49:18 <ttx> ok, sounds like we can wrap up early
20:49:24 <ttx> Anything else, anyone ?
20:49:44 <fungi> Rockyg: thanks for the heads up!
20:49:46 <dhellmann> I'm looking forward to seeing everyone again next week
20:49:56 <EmilienM> Rockyg: interesting document, thanks
20:49:56 <amrith> safe travels everyone
20:50:03 <stevemar> will be great to see everyone
20:50:06 * dtroyer is heading there now, will be sure to not drink all the wine…
20:50:06 <ttx> dhellmann: not "everyone" but "a lot"
20:50:32 * EmilienM at airport now
20:50:34 <amrith> dtroyer, if they get low on wine, just text me ... I'll bring some.
20:50:41 <fungi> yes, it's worth remembering there are a lot active participants in the community who will be missing this one than we've seen in the past for various reasons
20:50:47 <Rockyg> Your welcome.  But piet_ is the one to thank ;)
20:50:50 * edleafe knows that ttx had me in mind
20:51:00 <dhellmann> ttx: fair :-)
20:51:20 <flaper87> safe travels everyone!
20:51:33 <ttx> alright, see you all in not-so-warm Barcelona
20:51:45 * flaper87 is happy that he's been long enough in this TZ to adapt already
20:51:46 <EmilienM> see you folks
20:51:50 * dtroyer shivers
20:52:06 * stevemar waves by at EmilienM from a few kilometers away
20:52:07 <fungi> (forecast says hawaiian shirts and shorts for me)
20:52:08 <stevemar> bye*
20:52:12 <EmilienM> stevemar: :'(
20:52:22 <ttx> Oh, I spotted a beach bar like 5 min from the summit venue
20:52:27 <EmilienM> fungi: ahah, not surprised ;-)
20:52:40 <ttx> https://goo.gl/maps/kdNvrKQt8NS2
20:52:41 <thingee> ciao
20:52:44 <fungi> bookmarked
20:53:04 <ttx> http://www.panteagroup.es/en/chiringuito-gastronomico-bambu-beach-bar/
20:53:22 <ttx> on those good words
20:53:30 <ttx> #endmeeting