20:01:41 <ttx> #startmeeting tc
20:01:42 <openstack> Meeting started Tue Nov  1 20:01:41 2016 UTC and is due to finish in 60 minutes.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:01:43 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:01:45 * mordred has the internets
20:01:46 <openstack> The meeting name has been set to 'tc'
20:01:48 <ttx> Hi everyone,
20:01:51 <mtreinish> ttx: I'm excused?
20:02:03 <ttx> mtreinish: oh, I thought you said you wouldn't be attending this one
20:02:15 * jroll pokes his head in
20:02:17 <dims> hey mtreinish. missed you at the summit
20:02:21 <mordred> ++
20:02:28 <amrith> +++
20:02:30 <ttx> at least you're still on the apologies for absence on https://wiki.openstack.org/wiki/Meetings/TechnicalCommittee
20:02:38 <mtreinish> oh, I forgot to remove myself
20:02:46 <ttx> mtreinish: welcome!
20:02:46 <mtreinish> I was on vacation the past couple weeks
20:02:52 <thingee> mtreinish yeah I had to announce "just fungi" in the lightning talks.
20:03:02 <ttx> Since it was unclear that we would get enough people around, I focused of summit feedback and previously-submitted issues:
20:03:06 <ttx> #link https://wiki.openstack.org/wiki/Meetings/TechnicalCommittee
20:03:15 <ttx> (remember to use #info #idea and #link liberally to make for a more readable summary)
20:03:21 <mtreinish> dims: yeah, I'm upset I wasn't able to make it to BCN
20:03:24 <ttx> #topic Barcelona feedback
20:03:29 <ttx> * General feedback
20:03:36 <ttx> Was great seeing almost everyone last week
20:03:55 <ttx> Personally I wish I could have spent more time with teams but Summit week is not getting better in terms of conflicts
20:04:03 <ttx> So I'm looking forward to the PTG now
20:04:24 <dhellmann> pretty soon we'll all have to move into the same airbnb together
20:04:34 <ttx> Any other general feedback before we move on to discussing BoD+TC+UC meeting ?
20:04:34 <dims> :)
20:04:50 * Rockyg shoots a wadded up openStack summit badge at jroll's head
20:05:17 * jroll throws a cough drop back at Rockyg
20:05:19 <fungi> yeah, i normally don't present at the main conference, but missing most of a day of x-proj sessions to attend keynote rehearsals on tuesday taught me the pain of those who do
20:05:57 <ttx> ok, moving on, we can comment more in open discussion at the end
20:05:59 <ttx> * Following up on the BoD+TC+UC meeting
20:06:08 <ttx> We discussed several topics there, I think we have a number of action items
20:06:24 <ttx> For example it would be good to estimate which teams will be struggling in Ocata due to developer attrition
20:06:28 <ttx> dhellmann and myself are working on that
20:06:43 <ttx> We also identified the need of encouraging users of OpenStack to directly support development
20:06:52 <ttx> which would create a pretty virtuous circle...
20:06:53 <Rockyg> Thanks for that ttx and dhellmann
20:06:54 <amrith> dhellmann, ttx, I'd like to speak with you about that (asking for a friend).
20:06:58 <EmilienM> is there an etherpad we could contribute for that?
20:07:08 <ttx> The trick being they can't hire dozens of them, so we want to make sure those few get a good experience contributing
20:07:34 <ttx> EmilienM: on the dev attrition ? I'd rather collect data semi-anonymously
20:07:44 <EmilienM> ttx: fair enough
20:07:44 <dhellmann> EmilienM : I've been collecting data quietly. You can email me directly, if you like.
20:07:50 <EmilienM> dhellmann: I will
20:07:51 <fungi> i agree, the force that keeps most free software projects running long-term is their users becoming active developers
20:07:58 <dhellmann> fungi : ++
20:08:00 <smcginnis> Have we ever thought of having an "intro to contiributing" at the ops midcycle?
20:08:07 <dims> dhellmann : email you with list of projects that i think will be affected?
20:08:18 <ttx> smcginnis: sounds like a good idea
20:08:32 <dhellmann> dims : yes, please send any data you have. We'll also be contacting PTLs directly.
20:08:39 <dims> ack dhellmann
20:08:41 <amrith> an interesting twist ... at the ops midcycle ...
20:08:41 <fungi> smcginnis: could basically just do a day of "upstream university" the day before, like we've done at summits the past couple years?
20:08:49 <smcginnis> fungi: +1
20:09:00 <fungi> seems like it should be reasonably portable
20:09:04 <Rockyg> +100
20:09:13 <smcginnis> fungi: They would have a little different take on some of it, but it could be tailored to fit their perspective.
20:09:38 <ttx> fungi: note that we'll have upstream recruitment classrooms in future summits (as part of the "academy")
20:09:58 <fungi> well, i know the uu crowd are wanting to also be able to do on-site training for large contributor companies as well, so presumably are getting ready for audiences to vary pretty widely
20:09:59 <ttx> probably more project teams doing a deep dive, but could be generalist too
20:10:10 <Rockyg> if nothing else there could be a hot bugfix training session..
20:10:20 <ttx> On the "other communities" engagement, we said it would be great to be a bit more formal about it
20:10:30 <ttx> like knowing who is involved where and get regular reports from those "ambassadors"
20:10:38 <diablo_rojo> fungi: ildikov and I were just talking about doing a mini upstream with OSD's this morning
20:10:57 <fungi> diablo_rojo: ildikov: that's excellent
20:11:05 <ttx> Finally we discussed making sure we get critical mass of developers in both PTG and Summit/forum
20:11:13 <ttx> which will likely require some more discussion/education
20:11:20 <dhellmann> there's still a surprising amount of confusion about that
20:11:32 <amrith> dims, maybe we can repurpose the talk we gave at BU
20:11:41 <dims> amrith : +1
20:11:50 <ttx> dhellmann: yes, at some point it feels like to much communication kills the message
20:11:55 <Rockyg> dhellmann, lots in the community learn by example, so first ones will be critical
20:12:07 <ttx> After that meeting it was also pretty clear that we should communicate a bit more with board members and the community at large about recent decisions we made
20:12:24 <ttx> At this stage it is too easy to interpret (or spin) the Swift/Go decision into "the TC doesn't want Go", or "the TC doesn't want innovation/competition"
20:12:25 <cdent> dhellmann: how much of the confusion is actually fear about not being able to go because of budgetary concerns?
20:12:43 <ttx> cdent: the two are tied, definitely
20:13:08 <dhellmann> hmm, I know they're both out there but I didn't see them as tied.
20:13:11 <amrith> #action [dims, amrith] repurpose talk from BU for general consumption as a "intro to contributing" (H/T: smcginnis)
20:13:11 <ttx> So I think we'll have to be clearer on the way forward -- what does it take for "OpenStack" to adopt other languages or technologies
20:13:25 <ttx> Several of us plan to write blogposts to help with that
20:13:44 <smcginnis> cdent: +1
20:13:52 <ildikov> ttx: I would also be interested in figuring out the "other communities' engagement" things, like OPNFV for instance and help them out where we can, joint trainings for instance, etc.
20:13:53 <dhellmann> ttx: didn't we also get a volunteer to start writing up something in the governance repo when we talked last week?
20:13:55 <ttx> We'll discuss the UC part in a minute, any other feedback on the Board+TC+UC meeting ?
20:14:20 <ttx> dhellmann: ISTR someone volunteering for something yes
20:14:30 <ttx> it's all a bit fuzzy
20:14:31 <dhellmann> was that flaper87?
20:14:53 <ttx> dhellmann: good bet, he always volunteers for things
20:15:02 <dhellmann> and he's not here, so let's put him down for it
20:15:05 <ttx> Wondering if that wasn't Emilien though
20:15:06 <dims> ildikov : i talked a bit in the meeting about what some of us do with kubernetes community
20:15:19 <dhellmann> oh, maybe it was EmilienM
20:15:19 <EmilienM> I can take it and work with Flavio
20:15:24 <dhellmann> cool, thanks
20:15:50 <ttx> dims/ildikov: the embassy / ambassador analogy was good there
20:15:54 <ildikov> dims: cool, that sounds great too, it would be good to catch up on that later if you have some time!
20:16:11 <dims> ildikov : ack sounds good
20:16:13 <ttx> * An elected UC
20:16:24 <ildikov> ttx: +1
20:16:28 <ttx> During that same meeting the UC presented their plans to get to a proper mandate in the bylaws and an elected committee early 2017
20:16:31 <ildikov> dims: cool, tnx!
20:16:31 <fungi> yes, mordred's political analogies were spot on
20:16:43 <EmilienM> #action EmilienM & flaper87 to start writing up in governance repo about TC thoughts during board+tc+uc meeting
20:16:45 <ttx> From that discussion it was clear to me that the two bodies will have more legitimacy and clearer boundaries if the electorate of one is not included in the other
20:16:59 <ttx> We do want to encourage as much overlap as we can between the two, but not inclusion IMHO
20:17:05 <fungi> well, not explicitly included at least
20:17:08 <ttx> #link https://review.openstack.org/381894
20:17:17 <mtreinish> ttx: that makes sense to me
20:17:24 <ttx> So I think the UC is moving fast enough (and we have enough overlap between electorates) that we don't need that one ?
20:17:33 <dims> ttx : folks can end up in both, just won't get automatic privileges in the other if they are part of one
20:17:38 <mtreinish> and kinda how I assumed it was gonna work anyway (being absent from the discussions)
20:17:59 <dhellmann> yes, I'm glad to see this proposal moving forward with so much support
20:18:01 <fungi> though 381894 made an excellent straw-man alternative
20:18:14 <ttx> yea, that was useful to frame the discussion
20:18:56 <ttx> mordred: want to defend it, or abandon it ?
20:20:08 <mordred> ttx: I'll just abandon it
20:20:15 <ttx> Cool
20:20:24 <ttx> * Outcome of the proprietary drivers discussion
20:20:40 <ttx> Another thing we discussed in cross-project sessions which has TC implications was the proprietary drivers line
20:20:45 <ttx> There is a thread now to discuss it:
20:20:49 <ttx> #link http://lists.openstack.org/pipermail/openstack-dev/2016-October/106432.html
20:21:00 <ttx> I think we can comment there and discuss it in a future meeting
20:21:05 <ttx> Anything else re: Barcelona ?
20:21:53 <dims> thanks to mordred to setup the dinner (though i had to drop off at the last minute!)
20:22:08 <EmilienM> mordred: ++ thx
20:22:46 <dhellmann> ttx: we also discussed setting up a special category of teams for driver-only projects. I'm interested in helping to work on that language. I think fungi said he was, too?
20:23:01 <fungi> yes, count me in when the time comes to discuss
20:23:09 <ttx> ++
20:23:12 <mordred> my pleasure! I thuoght it was really great to get to see humans and talk to their faces
20:23:19 <ttx> ok, moving on!
20:23:22 <fungi> i'd love to pitch in on the mechanics and summary documentation around whatever we arrive at
20:23:32 <ttx> #topic Overdue update of mission statement in charter
20:23:37 <ttx> #link https://review.openstack.org/389611
20:23:46 <ttx> Realized recently we updated the mission statement in the charter to an intermediary version instead of the final
20:23:50 <ttx> So this fixes it
20:24:01 <ttx> Looks like it's good to go
20:24:03 <fungi> (oops!)
20:24:15 <ttx> yes, "oops"
20:24:22 <ttx> approved
20:24:30 <ttx> #topic Update QA's extra-atc
20:24:36 <ttx> #link https://review.openstack.org/389324
20:24:42 <ttx> This one renews Scott Moser's ATC status
20:25:02 <ttx> Looks like it's also good to go
20:25:26 <ttx> "Narwhal, narwhal"
20:25:28 <dhellmann> that was a response to my cleanup patch: https://review.openstack.org/388170
20:25:51 <ttx> #topic Tighten up language in "Contribution Is Our Currency"
20:26:15 <ttx> #link https://review.openstack.org/387370
20:26:20 <ttx> I think this is a good incremental improvement...
20:26:38 <ttx> Would love to have mtreinish's opinion on it though, since he is the original author
20:27:15 <ttx> checking this doesn't denature his original goal
20:27:28 * ttx checks if that is a verb in english
20:27:37 <anteaya> it is
20:27:41 <mtreinish> ttx: I think that is a good reword. It gives off the same vibe I was looking for in the original
20:27:54 <ttx> You borrowed so many words from French that I'm sometimes lost
20:28:02 <dims> whoa, that's new one for me :)
20:28:03 <ttx> mtreinish: Cool!
20:28:22 <ttx> So I think it is good to go
20:28:30 <ttx> Last-minute comments/objections ?
20:28:47 <mtreinish> ttx: all I was looking for with that was that was basically to say things don't happen top down, some one still needs to push a patch to get something done
20:29:48 <ttx> ok then, approved
20:30:02 <ttx> cdent: many thanks
20:30:08 <cdent> my pleasure
20:30:09 <ttx> #topic Add "Assume Good Faith" to OpenStack principles
20:30:13 <dims> ++ thanks cdent
20:30:15 <ttx> #link https://review.openstack.org/365590
20:30:28 <ttx> We don't have flaper87 around to defend it
20:30:36 <ttx> I like the new wording on this one. Still slightly torn on adding behavior guidelines to a principles document (vs. CoC)
20:30:37 <fungi> i need convincing on this one. it doesn't seem at all specific to the openstack community
20:30:46 <ttx> But then last week showed how much of a trust issue there is in some corners of OpenStack, so maybe that can't hurt
20:30:55 <ttx> I'm +0
20:31:31 <thingee> ditto
20:31:34 <fungi> it strikes me as general advice for participating in a culturally-diverse organization
20:31:39 <anteaya> is this patch going to fix an existing trust issue?
20:31:52 <thingee> I also think it's wrong for the CoC to state that people should assume good faith
20:32:46 <fungi> i seriously doubt this is a situation we're going to improve with messaging. it really only happens organically through example
20:33:52 <ttx> Any other opinion ?
20:33:54 <fungi> and we're already pretty good in this regard. on our mailing lists i don't see anything close to the rants and flame wars typical to lkml or debian-devel, for example
20:34:01 <EmilienM> I agree actions would actually make this change happen, eg: when we add/remove projects from OpenStack -etc
20:34:39 <EmilienM> fungi: true, our ML is pretty clean on this side.
20:35:13 <fungi> well, i think it really happens by people seeing one another make mistakes in public and then apologize for the misunderstanding
20:35:18 <ttx> This one is struggling a bit to get people excited about it
20:35:33 <dhellmann> yeah, I want people to do this but I don't know if this is the approach to ensure it happens
20:35:38 <ttx> and it feels like to make it to a "principle" we'd need to feel more strongly about it
20:35:44 <thingee> +1
20:36:04 <ttx> Not sure we want a bunch or "yeah, whatever" principles
20:36:07 <ttx> of*
20:36:10 <fungi> and if we get too much nonspecific advice in this document, it loses its impact
20:36:30 <EmilienM> well, documenting it is still a good first iteration
20:36:38 <ttx> It's probably better to rediscuss it with flaper87 around
20:36:51 <persia> On the other hand, some of what some of us may consider nonspecific advice may be new and interesting to those from other corners of the "open source community"
20:36:55 <ttx> so let's table it a bit. No urgency
20:37:34 <ttx> #topic Open discussion
20:37:52 <ttx> We have a bunch of important topics for next week
20:38:01 <dhellmann> maybe this is less a principle and something we should put into a "how to communicate successfully" section of the project team guide
20:38:17 <mugsie_> dhellmann: ++
20:38:23 <fungi> i could be convinced of that
20:38:24 <ttx> We'll close the TC/PTL election timeframe discussion -- I'll send a new email to remind PTLs to express their opinion
20:38:32 <ttx> dhellmann: ++
20:38:33 <dims> dhellmann : right, this came up in the election thread too (http://markmail.org/message/srbbu7pxnfire3yq) and we were able to uphold good faith there
20:38:35 <EmilienM> ttx: I'll update Wiki but I'm on vacations the next 2 weeks. I'll do my best to attend TC meeting but in case I can't do it, Doug or Flavio will be my proxies.
20:38:43 <ttx> EmilienM: sounds good
20:38:53 <ttx> "
20:38:55 <anteaya> dhellmann: then I'd encourage the route of discuss differences with people rather than make assumptions about them
20:38:57 <Rockyg> "Community based on trust and good faith" is more a definition of the openstack community than a principle
20:39:05 <dhellmann> anteaya : sure.
20:39:11 <anteaya> dhellmann: thanks
20:39:11 <ttx> mordred: We'll have Tricircle on the agenda next week... will you be around ? Since you followed them
20:39:19 <dims> Anyone interested in "create a "new project" checklist for things that projects need to do when they join the big tent", i picked up a TODO in the release team meeting?
20:39:33 <ttx> dhellmann: Should we defer "Add networking-cisco back into the Big Tent" until you have a proposal up for driver-only teams ?
20:39:35 <EmilienM> dims: yes, please
20:39:55 <dims> EmilienM : ack, i'll ping you when i get started on that :)
20:39:57 <EmilienM> mtreinish: removing you from absence section in Wiki
20:39:57 <fungi> dims: like as a governance-oriented companion to our more technical process-oriented primer?
20:40:13 <EmilienM> dims: I did this process many times, I think I can help there.
20:40:13 <dhellmann> ttx: yes, please. I want to vote yes, but we can't with our current rules and I'd rather not have them get a "no" then a "try again!"
20:40:14 <mtreinish> EmilienM: ok, sure thanks
20:40:28 <dims> fungi : some details here (https://etherpad.openstack.org/p/ocata-relmgt-plan Line 148)
20:40:40 <dims> fungi : y for governance repo
20:40:42 <ttx> #action ttx to defer networking-cisco to after dhellmann proposed a driver-only team resolution
20:41:02 <fungi> dims: oh, awesome. i was floating back and forth between infra and other rooms so missed that discussion. thanks!
20:41:05 <ttx> BTW We are starting to see "goals acknowledgement" changes being posted. How do you want those approved ?
20:41:10 <ttx> Should we use our usual "lazy consensus" rule ? I.e. one week without -1 is good enough ?
20:41:24 <dhellmann> ttx: we called that out specifically in the house rules document somewhere
20:41:25 <dims> ttx : +1
20:41:34 <dhellmann> #link http://governance.openstack.org/reference/house-rules.html#goal-updates-from-ptls
20:41:41 <fungi> yeah, i thought i remembered seeing it there
20:41:43 <ttx> oooh, shiny
20:42:07 <fungi> granted, i only read that because it was in my "tc orientation packet"
20:42:26 <EmilienM> dims: sure thing, email is best for me
20:42:38 <ttx> I wasn't in the upgrade cross-project workshop but it feels like we should now proceed on https://review.openstack.org/#/c/372686/ ?
20:42:43 <dims> EmilienM : yep, will add you and fungi
20:44:07 <fungi> 372686 seems noncontentious, at least on the surface
20:44:41 <ttx> fungi: we wanted to nail down testing first
20:44:53 <mtreinish> ttx: iirc the blocker for 372686 is that there is no method for verifying that. We need testing set up first before we can do that
20:44:56 <EmilienM> ttx: +1 for lazy consensus on this one
20:45:00 <mtreinish> heh, I should type faster :)
20:45:13 <ttx> About Barcelona: I found the cross-project workshops more useful than usual. Makes me think we might want to keep a fishbowl room at the PTG to facilitate inter-project discussions (think: the review scaling discussion)
20:45:17 <fungi> oh, thanks ttx, mtreinish
20:45:46 <dims> ttx : the SWG session went well too i thought
20:45:46 <dhellmann> ttx: ++
20:45:51 <smcginnis> ttx: +1
20:45:51 <EmilienM> ttx: well, I wished some of cross-project sessions would be less nova-centralized
20:45:59 <ttx> Something we could book for an ad-hoc discussion
20:46:15 <jroll> ttx: +1 on x-project workshops being super useful
20:46:16 <cdent> EmilienM: ++
20:46:26 <fungi> EmilienM: those weren't really _supposed_ to be entirely nova-specific, but they served as a primary example
20:46:47 <ttx> the trick being to not cross the line with stuff that would require all the community being present
20:47:07 <EmilienM> fungi: I wish we could have talked more about other projects in general. Nova seems to have a lot of problems that other projects don't seem to have
20:47:10 <dims> right, kudos to mriedem to open up the nova team to the microscope
20:47:37 <fungi> EmilienM: also possible that nova is having problems other projects haven't hit _yet_ due to being one of the earliest and largest
20:47:41 <mriedem> i tried to get other project input
20:47:42 <ttx> EmilienM: yes at one point it turned nova-specific, but the first part was pretty inclusive
20:47:54 <mriedem> i took away that it's not just a problem for nova
20:47:56 <EmilienM> cool, just giving feedback
20:48:02 <mriedem> but amplified given the size
20:48:08 <jroll> mriedem: ++
20:48:12 <dims> ++ mriedem
20:48:12 <dhellmann> mriedem : yeah, that's more or less what I got, too
20:48:20 <fungi> seemed like issues where nova is our canary in the coal mine
20:48:20 <EmilienM> mriedem: thx for leading this session btw
20:48:30 <ttx> it was also very useful to have all those projects in the room to get their advice/input/solutions
20:48:34 <dhellmann> at least we learned that no one is keeping the answer to this problem a secret from other teams :-)
20:48:35 <dims> fungi : nova and neutron :)
20:48:44 <dims> dhellmann : hahaha
20:48:56 <EmilienM> ttx: right, it was useful
20:49:00 <ttx> ok... Anything else, anyone ?
20:49:03 <ildikov> dims: amrith: if you would like to have some brainstorming about the 'How to contribute' session for the Ops mid-cycle we're quite in the middle of these with diablo_rojo due to our Upstream training assignments recently
20:49:34 <amrith> hello ...
20:49:36 <ildikov> also if anyone would be interested in shorter training version before in connection to the OSD events please reach out to either of us :)
20:49:36 <smcginnis> Is there still a separate ops midcycle? If so, is there a date set?
20:49:50 <dims> ack ildikov
20:49:56 <amrith> ildikov, ack
20:49:57 <fungi> i got from the ops ml that they're still working on scheduling
20:50:07 <fungi> smcginnis: ^
20:50:08 <ildikov> it would be great if we could connect local development communities with newcomers, who are interested
20:50:16 <smcginnis> fungi: tx
20:50:27 <dougwig> mriedem: neutron had similar issues, we just traded them for different issues.
20:50:28 <dhellmann> ildikov : will that info be available for local meetups, too? my group in ATL is interested in something like this.
20:50:44 <ildikov> several people have time zone issues and find people from whom they can ask to get started, etc.
20:51:06 <EmilienM> dougwig: nicely said ;-)
20:51:14 <ildikov> dhellmann: we are developing the content in the open, having weekly meetings with the training guides team
20:51:22 <dims> nice ildikov !
20:51:24 <dhellmann> ildikov : excellent, I'll look for that
20:51:42 <ildikov> dhellmann: so if you know people/areas interested I think we could work together to have parts delivered people are interested at
20:51:45 <anteaya> smcginnis: http://lists.openstack.org/pipermail/openstack-operators/2016-October/011866.html
20:51:52 <fungi> yeah, the training guides team are doing an excellent job of being transparent with all this
20:51:52 <smcginnis> anteaya: ty
20:51:58 <anteaya> welcome
20:52:21 <EmilienM> OSD = OpenStack Days for the record (I had to google it)
20:52:26 <ttx> Alright, if we have nothing else, let's get 5 minutes of our lives back
20:52:38 <ttx> we might need those later
20:52:38 <anteaya> EmilienM: thanks, I also didn't know
20:52:43 <ildikov> EmilienM: tnx! :)
20:53:14 <dhellmann> ttx: ++
20:53:17 <dims> aha EmilienM
20:53:36 <ttx> Thanks everyone! Take it easy this week :)
20:53:36 <EmilienM> ttx: thanks for chairing!
20:53:39 <ttx> #endmeeting