#openstack-meeting: tc

Meeting started by ttx at 20:02:06 UTC (full logs).

Meeting summary

    1. https://wiki.openstack.org/wiki/Meetings/TechnicalCommittee (ttx, 20:02:32)

  1. Driver teams: discuss various options (ttx, 20:02:48)
    1. http://lists.openstack.org/pipermail/openstack-dev/2016-November/thread.html#108074 (ttx, 20:02:53)
    2. option 1. Say that we prefer having a level playing field to allowing standalone driver teams. (Identified as the "hard black" option) (dhellmann, 20:03:58)
    3. https://review.openstack.org/#/c/403834/ (dhellmann, 20:03:59)
    4. option 2. Say that the level playing field policy doesn't apply to driver teams, if the resources needed to work on the driver are open. (Identified as the "soft black" option) (dhellmann, 20:03:59)
    5. https://review.openstack.org/#/c/403836/ (dhellmann, 20:03:59)
    6. 3. Remove the level playing field statement from the project team policies. (Identified as the "hard white" option) (dhellmann, 20:03:59)
    7. https://review.openstack.org/#/c/403838/ (dhellmann, 20:04:00)
    8. 4. Loosen the level playing field statement to exempt driver teams completely. (Identified as the "soft white" option) (dhellmann, 20:04:01)
    9. https://review.openstack.org/#/c/403839/ (dhellmann, 20:04:02)
    10. 5. Define a new type of team with different rules based on different expectations for driver teams. (Identified as the "grey" option) (dhellmann, 20:04:03)
    11. https://review.openstack.org/#/c/403829/ (dhellmann, 20:04:04)
    12. 6. Require project teams with driver abstractions to host drivers in one of their official repos, as long as they meet some community standards. (Identified as the "red" option) (dhellmann, 20:04:05)
    13. https://review.openstack.org/#/c/403830/ (dhellmann, 20:04:06)
    14. https://review.openstack.org/#/c/403826/ (dhellmann, 20:04:09)
    15. start of thread http://lists.openstack.org/pipermail/openstack-dev/2016-November/thread.html#108074 (dhellmann, 20:04:17)
    16. continuation of thread http://lists.openstack.org/pipermail/openstack-dev/2016-December/thread.html#108410 (dhellmann, 20:04:17)
    17. ACTION: stevemar to summarize outcomes for each proposal and propose abandons (ttx, 20:45:09)

  2. Amend reference/PTI with supported distros (ttx, 20:45:19)
    1. https://review.openstack.org/402940 (ttx, 20:45:25)
    2. http://eavesdrop.openstack.org/meetings/tc/2013/tc.2013-01-08-20.02.html (jeblair, 20:51:32)
    3. dhellmann and EmilienM should see if we can get some resources working on better centos support for devstack (ttx, 20:54:57)
    4. because it's a blocker to larger use of CentOS in test jobs (ttx, 20:55:21)

  3. Do not allow data plane downtime during upgrades (ttx, 20:56:15)
    1. https://review.openstack.org/404361 (ttx, 20:56:20)

  4. Open discussion (ttx, 20:57:36)


Meeting ended at 21:01:57 UTC (full logs).

Action items

  1. stevemar to summarize outcomes for each proposal and propose abandons


Action items, by person

  1. stevemar
    1. stevemar to summarize outcomes for each proposal and propose abandons


People present (lines said)

  1. ttx (120)
  2. dhellmann (87)
  3. sdague (38)
  4. fungi (34)
  5. mordred (30)
  6. flaper87 (30)
  7. EmilienM (20)
  8. mtreinish (16)
  9. jroll (11)
  10. dtroyer (10)
  11. dims (9)
  12. Rocky_g (9)
  13. stevemar (8)
  14. jeblair (6)
  15. clarkb (6)
  16. mugsie (6)
  17. smcginnis (4)
  18. dolphm (3)
  19. openstack (3)
  20. JayF (2)


Generated by MeetBot 0.1.4.