20:00:36 <dhellmann> #startmeeting tc
20:00:37 <openstack> Meeting started Tue Apr 25 20:00:36 2017 UTC and is due to finish in 60 minutes.  The chair is dhellmann. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:38 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:00:40 <openstack> The meeting name has been set to 'tc'
20:00:43 <EmilienM> o/
20:00:44 <smcginnis> o/
20:00:44 <dhellmann> ttx is away this week, so I will be acting as chair for the meeting
20:00:44 <dhellmann> courtesy ping for TC meeting: cdent, dims, dtroyer, emilienm, flaper87, fungi, johnthetubaguy, mordred, sdague, smcginnis, stevemar
20:00:46 <sdague> o/
20:00:46 <dtroyer> o/
20:00:47 <smcginnis> fungi: :D
20:00:53 <cdent> o/
20:00:54 <flaper87> o/
20:00:57 <heidijoy> o?
20:01:02 <heidijoy> o/
20:01:06 <dims> o/
20:01:26 <dhellmann> 8, so we have quorum
20:01:34 <dhellmann> our agenda is in the wiki in the usual location
20:01:34 <dhellmann> #link agenda https://wiki.openstack.org/wiki/Meetings/TechnicalCommittee
20:01:38 * rockyg does a quick shout out to the new members.  congrats!
20:01:42 <dhellmann> #topic Welcome new membership
20:01:47 <dhellmann> Welcome to our new and returning members!
20:01:52 <dhellmann> We have a few administrative tasks to take care of before we get into the main portion of today's meeting.
20:01:59 <dhellmann> Your Gerrit rights should be set up, so you should all be able to RollCall-Vote +1/-1 changes in the openstack/governance repository; let ttx know if you can't
20:02:05 <dhellmann> We currently use the openstack-tc mailing-list for administrative communication between TC members, like meeting reminders
20:02:11 <dhellmann> The list is moderated for non-members, and the moderation bit was removed for all new TC members so you should all be able to post directly
20:02:19 <EmilienM> in openstack/project-navigator-data also
20:02:28 <dhellmann> IOW, you should all be ready to go and start voting and whatnot
20:02:37 <cdent>20:02:38 <smcginnis> dhellmann: +1
20:02:39 * edleafe watches from the sidelines
20:02:41 <dhellmann> if not, that's a bug and ttx is the person to fix it
20:03:06 <dhellmann> #topic Reminder of current house rules
20:03:11 <dhellmann> We'll discuss potential changes to the process very soon, but in the meantime, a quick reminder of how we currently operate.
20:03:12 * flaper87 saw some votes from cdent and smcginnis so it should be fine
20:03:24 <dhellmann> Changes or resolutions must be proposed before Thursday 20:00 UTC for discussion at the meeting the following Tuesday
20:03:24 <dhellmann> Sometimes we defer topics if there are too many to cover in one meeting
20:03:41 <dhellmann> We also need to discuss/mention topics during at least one TC meeting before approving them in a formal vote on the review
20:03:44 <dhellmann> Ultimately, things are approved if there are more approvals than rejections, and at least 5 approvers
20:03:47 <dhellmann> Though in most cases we just merge them when the majority (7 votes) is reached
20:04:04 <dhellmann> There are a number of standing exceptions to that rule (to remove most of the useless discussions from meeting agendas), all documented in
20:04:05 <dhellmann> #link http://governance.openstack.org/reference/house-rules.html
20:04:08 <dhellmann> For example, when a team adds a new repository, the change will be approved after one week if there is no objection.
20:04:13 <dhellmann> it's the chair's responsibility to keep that list of reviews moving along
20:04:19 <dhellmann> If there is an objection then it will be discussed at the following meeting
20:04:25 <dhellmann> To facilitate finding the things we actually have to vote formally on, the chair marks them with the topic: formal-vote
20:04:33 <dhellmann> I have found this review dashboard useful for keeping up with TC reviews
20:04:34 <dhellmann> #link http://bit.ly/os-tc-dashboard
20:04:45 <dhellmann> that was a big pastebomb, does anyone have questions?
20:04:46 * flaper87 loves the dashboard
20:05:05 <cdent> so, just to clarify: before something is a formal-vote we use code-review to indicate our pleasure or displeasure with a change
20:05:18 <cdent> once the topic formal vote then we may, if we're inclined register a vote
20:05:21 <cdent> yes?
20:05:38 <dhellmann> cdent : I don't think we're consistent on that. I never use the code-review status except when I'm voting as a PTL. Others seem to always use it.
20:05:54 <cdent> dhellmann: yeah, that's part of my confusion, I couldn't identify the pattern
20:05:54 <flaper87> cdent: you can vote whenever, really. ttx keeps the topics updated
20:06:03 <flaper87> well, most of the time he does
20:06:13 <flaper87> other times some folks just use the right topic
20:06:17 <cdent> I'll figure it out and develop my own unique style
20:06:36 <dhellmann> I recommend just using the roll-call voting level in all cases, so we can easily tell whether there's consensus on the TC vs. from other folks (which may indicate a need for more communication about something, even if we all agree on it)
20:06:54 <smcginnis> Makes sense, I was confused as well.
20:06:55 <fungi> yeah, it's not really clear so i tend to use code-review on these changes if there's a technical issue with the change, and rollcall-vote for roll
20:07:00 <dhellmann> that has come up in the past, where we had a shared understanding that non-tc folks didn't have because they weren't present for a meeting somewhere
20:07:01 <mordred> o/
20:07:02 <dtroyer> I've used code-review to indicate when I've looked at something in-depth (code-review-like) as opposed to agreement
20:07:21 * fungi basically same as dtroyer then
20:07:28 <flaper87> fungi: ++
20:07:34 <dhellmann> a roll-call vote is not really like a -2 on a code patch, since no one has veto power
20:07:39 <dhellmann> so it's OK to use it
20:07:48 <dhellmann> does that help?
20:07:52 <cdent> yes, thanks
20:08:07 <dhellmann> ok, cool
20:08:18 <dhellmann> let's start looking some of the reviews we need to cover, then
20:08:23 <dhellmann> #topic Approve new TC roster
20:08:24 <smcginnis> Yep, thanks for the explanations.
20:08:30 <dhellmann> Our first order of business is to approve the new results from the recent TC election.
20:08:35 <dhellmann> Please review the results and the CIVS poll outcome and then indicate your approval or point out any issues
20:08:40 <dhellmann> #link CIVS poll results http://civs.cs.cornell.edu/cgi-bin/results.pl?id=E_072c4cd7ff0673b5
20:08:44 <dhellmann> #link updating TC membership after April 2017 election https://review.openstack.org/458770
20:09:01 <edleafe> Does anyone ever vote against their being elected? :)
20:09:12 <smcginnis> :)
20:09:15 <dhellmann> I see 11 votes there, so no need to stop and discuss unless anyone has questions
20:09:30 <dhellmann> edleafe : we did have a conversation once about whether it makes sense for the new members to be voting on that type of patch :-)
20:09:32 <EmilienM> ship it
20:09:45 <EmilienM> (ah, only ttx can do it)
20:09:48 <edleafe> "I'm a fraud!!"
20:09:53 * flaper87 votes against EmilienM
20:10:03 <dhellmann> yeah, we'll have to wait for him to W+1 all of these
20:10:04 <dhellmann> #topic Elect TC chair
20:10:06 <dhellmann> We select our chair for each cycle by updating the governance repository.
20:10:33 <dhellmann> ttx always stands, but he also always tries to encourage someone else to step up
20:10:38 <dhellmann> If you would like to serve as chair, please propose a patch to nominate yourself ASAP so we can finalize the selection by the next meeting.
20:10:45 <dhellmann> For example, here is ttx's self-nomination:
20:10:48 <dhellmann> #link ttx's self-nomination for TC chair https://review.openstack.org/458774
20:10:54 <smcginnis> dhellmann: This is a 6 month stint, correct?
20:11:00 <dhellmann> yes
20:11:13 <smcginnis> Maybe next time then.
20:11:15 <EmilienM> the rule could change if 6 months is too long (maybe)
20:11:55 <dhellmann> it's tied to the cycle, much like the PTL role is
20:12:01 <flaper87> right
20:12:01 <dhellmann> #topic Boston Summit
20:12:09 <dhellmann> oops
20:12:10 <dhellmann> #undo
20:12:10 <EmilienM> dhellmann: ok, got it
20:12:11 <openstack> Removing item from minutes: #topic Boston Summit
20:12:15 <dhellmann> any other questions?
20:12:19 <fungi> since the chair is also sort of a liaison to the board and so on, having it change more often than every 6 months is probably counter-productive
20:12:33 <dhellmann> good point
20:12:46 <flaper87> fungi: ++
20:12:56 <dhellmann> ok, moving on with more pastebombs
20:12:58 <dhellmann> #topic Boston Summit
20:13:08 <dhellmann> A few reminders for those who will be in Boston
20:13:12 <dhellmann> There will be a joint Board/TC/UC meeting, Sunday May 7th at 2:00pm
20:13:15 <dhellmann> The agenda is mostly set at
20:13:17 <dhellmann> #link https://wiki.openstack.org/wiki/Governance/Foundation/7May2017BoardMeeting
20:13:28 <dhellmann> The plan is to go through the various workstreams that were identified at the workshop in Boston in March
20:13:33 <dhellmann> We can probably still try to add topics to the agenda if there is something urgent we want to cover.
20:13:37 <dhellmann> Saturday May 6th, at 7pm, there will be a Staff+Board+TC+UC dinner, on the Level 3 of the Marriott Copley Place Hotel, Boston
20:13:42 <dhellmann> RSVP at https://bostonboardofdirectorsdinner.eventbrite.com
20:13:58 <dhellmann> I found out about that too late (my flight will be landing during dinner), but I hope the rest of you are able to make it
20:14:32 <dhellmann> does anyone know for sure they will miss the meeting on sunday?
20:14:47 * smcginnis arrive early Saturday afternoon
20:15:02 <cdent> I'm still working on that. I had booked my flights quite a while back, but I'm working on getting them changed
20:15:09 <dhellmann> good
20:15:28 <dhellmann> dinner will be a good opportunity to meet the board and UC members
20:15:38 * flaper87 will attend both
20:15:50 <dims> same here
20:15:55 <dtroyer> ditto
20:16:09 <fungi> also much of the foundation staff will be at dinner as well
20:16:17 <dhellmann> fungi : yes, good point
20:16:29 <EmilienM> I'll skip dinner, I'm flying on Sunday morning.
20:16:36 <sdague> won't be at the dinner, but I'll be at the board meeting
20:16:47 <sdague> I do miss the days when the dinner was post board meeting
20:17:04 <fungi> i agree that was my preference as well
20:17:05 <dhellmann> yes, I think ttx said it conflicted with another event sunday evening
20:17:15 <fungi> maybe in sydney
20:17:54 <dhellmann> ++
20:18:04 <dhellmann> let's move on to cover some old business
20:18:09 <dhellmann> #topic Adjustments to status:maintenance-mode tag definition
20:18:15 <dhellmann> #link https://review.openstack.org/457794
20:18:41 <dhellmann> this patch updates the new tag we approved last week with a few adjustments mentioned in the meeting and in the review itself
20:18:58 <cdent> good tidies
20:19:00 <EmilienM> looks like this one is ready to ship too
20:19:03 <dhellmann> I don't think I caught everything, but I picked up what seemed to be the easy changes
20:19:14 <dhellmann> I see lots of +1s, did anyone have questions about it
20:19:16 <dhellmann> ?
20:20:02 <dhellmann> ok, then
20:20:15 <dhellmann> we'll wait for the votes to accumulate and for the next chair to approve it
20:20:21 <dhellmann> #topic Presentation of User Survey findings
20:20:24 <dhellmann> heidijoy has provided some summary information, which I'll paste into the record now before turning the floor over to her for Q&A
20:20:30 <dhellmann> #link A 4-minute video overview of report highlights https://www.openstack.org/user-survey/survey-2017/landing?BackURL=/user-survey/survey-2017/
20:20:33 <heidijoy> Hello TC! Thank you for inviting me to this meeting. I’m here to give you additional insights and answer questions you have about the survey. I want to be sure you have the most important links, which are all at www.openstack.org/user-survey - especially the 4-min video overview. Please feel free to ask me questions at any time.  You can download the survey directly from this link, and I’ll refer to page numbers or
20:20:39 <dhellmann> #link the full report https://www.openstack.org/assets/survey/April2017SurveyReport.pdf
20:20:45 <dhellmann> #link interactive analytics tool http://openstack.org/analytics
20:20:50 <dhellmann> She also wanted to highlight a few key findings:
20:20:55 <dhellmann> #info Report represents 44% more deployments (nearly 600) and 22% more organizations than ever before, however, fewer total respondents
20:21:00 <dhellmann> #link https://www.dropbox.com/s/8ihd6rw7efhdalj/1.1%20Compare%20to%20prior%20cycle.png?dl=0
20:21:09 <dhellmann> #info The majority of OpenStack users are on an unsupported release
20:21:09 <dhellmann> #link all deployments https://www.dropbox.com/s/8hukz6lzaged46j/3.4%20Release%20used%20-%20all%20.png?dl=0
20:21:09 <dhellmann> #link deployments in production https://www.dropbox.com/s/wnlx6yx3t239wn2/3.5%20Releases%20used%20-%20deployments.png?dl=0
20:21:18 <dhellmann> #info NPS scores declined for users overall and for those with deployments - see the full report for verbatim comments
20:21:19 <dhellmann> #link NPS scores overall https://www.dropbox.com/s/vejq9ou4xu8ytiu/2.2b%20NPS%20over%20time.png?dl=0
20:21:19 <dhellmann> #link NPS scores for users with deployments https://www.dropbox.com/s/6x2d56eor2dzpvl/NPS%20Deployments%20only.png?dl=0
20:21:25 <dhellmann> #info 12 projects asked specific questions to inform future development. See answers on pages 58-65 of the report.
20:21:32 <dhellmann> #info See the report "Deployment Decisions" section (pages 42-57) for installation/configuration insights.
20:21:37 <dhellmann> does anyone have questions for heidijoy?
20:21:47 <heidijoy> Thank you Doug!
20:21:52 <heidijoy> To give you some context on our ninth semiannual user survey, this represents a snapshot of more than 1,400 completed surveys and nearly 600 deployments logged in the first two months of 2017—the largest sample of OpenStack deployments ever (44% more than one year ago). We believe results are representative of our community as a whole, revealing users’ attitudes, technology choices, and uses of OpenStack software. A
20:22:29 <heidijoy> Oops - I got cut off: All OpenStack Foundation members, more than 70,000 people across 160 countries, were invited to fill out the survey.
20:22:37 <heidijoy> Here are the key findings that we are working to share broadly:  More clouds: OpenStack’s growth is demonstrated by rapid development of new clouds, with 44% more deployments reported on this survey. The average age of a deployment is less than 1.7 years.
20:22:50 <heidijoy> Larger clouds: 37% of clouds have 1,000 or more cores, up from 29% last year, and 17% of clouds are running more than 1 petabyte of object storage, up from 4% one year ago.
20:22:59 <heidijoy> Diverse users: Users of every organizational size and industry find value in OpenStack, 32% have 10,000 employees or more, while 25% have fewer than 100 employees, and users hail from 78 countries.
20:23:06 <heidijoy> Mature technology: OpenStack’s maturity is demonstrated by two-thirds of deployments in production and 90% or greater adoption of key infrastructure services (Nova, Neutron, Keystone, Cinder and Glance).
20:23:15 <heidijoy> Deep adoption: The median user runs 61–80% of their overall cloud infrastructure on OpenStack, while the typical large user (deployment with 1,000+ cores) reports running 81–100% of their infrastructure on OpenStack.
20:23:44 <heidijoy> While you’ll see certain charts highlighted for our marketing purposes, we intend this to be a solid and defensible report for the community - with qualitative and quantitative answers to key development questions.
20:23:51 <smcginnis> heidijoy: I need to review yet, but do we have numbers for public vs private cloud deployments?
20:24:10 <dfisher> so, I have a couple of questions from the sidelines
20:24:20 <heidijoy> @smginnis - Yes, we do have those, I'll grab the page number for you...
20:24:27 <heidijoy> Please go ahead, @dfisher
20:24:34 <dfisher> background:  I'm a Solaris developer at Oracle.  I'm the tech lech for OpenStack on Solaris
20:24:48 <dfisher> Reading the user survey, i see the same issues time and time again.
20:24:59 <dfisher> pages 18-19 of the survey are especially common points.
20:25:12 <heidijoy> @smcginnis - go to page 26 of the report for Public/private cloud info.
20:25:21 <smcginnis> heidijoy: Thank you!
20:25:23 <dfisher> things move too fast, no LTS release, upgrades are terrifying for anything that isn't N-1 -> N.
20:25:33 <dfisher> these come up time and time again
20:25:45 <dfisher> how is the TC working with the dev teams to address these critical issues?
20:25:58 <heidijoy> @dfisher you're right - we've seen these themes highlighted before. I'll leave it open to TC to discuss.
20:26:08 <fungi> i think it comes down to member companies investing in making those issues priorities for their developers, first and foremost
20:26:30 <dhellmann> I know some of the distributors provide longer term support, for example
20:26:40 <edleafe> fungi: +1. I don't see the TC having a big role here
20:26:42 <flaper87> fungi: ++
20:26:43 <dhellmann> that's not necessarily the thing we have resources for upstream
20:26:43 <dfisher> Kilo is still supported on Solaris 11.3
20:26:49 <smcginnis> It impacts us, but I do think that comes down to the distributors providing support.
20:26:50 <fungi> though we are rolling out new plans to attempt to highlight these sorts of concerns for member companies who don't know where to invest their time
20:27:03 <heidijoy> A main issue for the TC to look at is the fact that the majority of OpenStack deployments are on unsupported releases. You can see that chart on page 27-28.
20:27:09 <dfisher> ^ exactly
20:27:16 <dfisher> Kilo's been EOL'd for awhile now.
20:27:23 <dfisher> but it's what we have on 11.3
20:27:27 <dfisher> Solaris* 11.3
20:27:38 <mordred> heidijoy: sure - main thing is that nobody provides any resources to work on kilo upstream
20:27:39 <dfisher> yes, I know it's Solaris and not Linux and we've had *that* particular discussion before
20:27:57 <heidijoy> The survey noted: "It is important to note that the Liberty release was end-of-life (EOL) and not security supported as of Nov. 17, 2016. Additionally, Mitaka will be EOL and not security supported on April 10, 2017. Combined with the still significant Juno and Kilo userbase, that means the majority of OpenStack users are on an unsupported release."
20:27:59 <fungi> different distros are also picking different releases to "stabilize" on their own, without any obvious coordination between one another
20:28:02 <dfisher> but it's a small piece of the larger problem.
20:28:03 <smcginnis> dfisher: So if Oracle is not updating that to something newer, I assume they have resource to continue to support the older release?
20:28:04 <dhellmann> heidijoy : are there still complaints about patch review throughput, or do those show up in other places?
20:28:14 <dtroyer> dfisher: this isn't particular to Solaris or any given Linux distro, it is entirely due to how contributing companies allocate resources
20:28:15 <EmilienM> dfisher: I agree it's a resource issue here. A lot of folks want a lot of things but the people who actually make it happen need more help I think
20:28:16 <mordred> and each of the times we've discussed increasing the support window in the past, people have asked for it, it's been ok'd in some circumstances, but then nobody has shown up to do the work
20:28:26 <dfisher> smcginnis: sadly, we don't.  we're stuck on Kilo for now for internal political reasons.
20:28:30 <flaper87> I think the community has done a great job on improving upgrades from N-1 -> N and given the current resources I think that's already a huge goal... hate to be defensive and not constructive but...
20:28:40 <heidijoy> @dtroyer I didn't see complaints about patch review throughput in any of the verbatim comments (there were about 1800 of them)
20:28:41 <mordred> flaper87: ++
20:28:46 <edleafe> flaper87: +1
20:29:02 <flaper87> Supporting upgrades from kilo to current would not only imply having to maintain the release but it has a *HUGE* impact on CI and the infrastructure used to develop openstack
20:29:11 <dims> flaper87 : true, but it's hard to keep upgrading systems at the rate
20:29:14 <mordred> said another way - I tihnk we'd love to support longer releases or n+2 upgrades or whatnot - but we simply have no humans
20:29:27 <dhellmann> heidijoy : ok. that has been a complaint in the past, which would seem to be in opposition to the current complaint about going too fast. Maybe we exchanged one problem for another, or maybe different users have different perspectives.
20:29:29 <dfisher> OpenStack, in general, appears to be managed by project teams (read: engineers) rather than a central body (read: the TC or maybe even the foundation itself)
20:29:31 <fungi> flaper87: i think the concern though is that it's not possible to upgrade from n to > n+1 (e/g/ from n to n+2 or to n+3 without taking intermediate upgrade steps)
20:29:35 <EmilienM> mordred: yes, that
20:29:40 <flaper87> dims: not saying it's easy but I do think it's something that distros will have to handle specifically
20:29:41 <mriedem> dfisher: read through and grok all of this https://etherpad.openstack.org/p/stable-branch-eol-policy-newton
20:29:45 <mriedem> ^ was the austin summit
20:29:46 <mriedem> for newton
20:29:48 <mordred> dhellmann: I think it's different users have different perspectives
20:29:53 <EmilienM> dfisher: is Oracle willing to allocate engineers helping us on doing release management?
20:29:59 <mordred> I've had two different board members approach me during the same break
20:30:04 <dmsimard> FWIW, from the perspective of a distro (RDO), even supporting an extra stable release (Mitaka) due to the Ocata short cycle was a significant strain on human and physical resource
20:30:06 <mordred> making each side of the opposites of that complaint
20:30:09 <edleafe> Perhaps we can get help to get some of those comanies that are going to be staying on an unsupported release to get together and... well, support it.
20:30:13 <mordred> "things are too fast" and "things are too slow"
20:30:18 <dhellmann> before we get too far into this specific issue, I want to point out that this may not be the best forum for it
20:30:21 <fungi> basically the release-skipping requests are closely tied to the "lts" requests, since you need guarantees for one to be able to provide the other
20:30:26 <heidijoy> @dfisher  - I agree that eng teams seem to manage project output more than a governing body/ product management group
20:30:26 <sdague> dhellmann: ++
20:30:28 <dfisher> EmilienM: obviously I can't speak for Oracle.  I shouldn't even speak for Solaris but we don't have the staff in Solaris to support that.
20:30:31 <dhellmann> we've had quite a few complaints recently about the speed of discussions in this meeting, for example
20:30:44 <dhellmann> and this is the sort of thing that really would be better served by moving to the mailing list
20:30:46 <sdague> dhellmann: I think this is pretty far off the original topic
20:30:49 <sdague> dhellmann: ++
20:30:51 <flaper87> dhellmann: yeah, wonder if a late addition to the forum schedule makes sense
20:31:02 <dhellmann> so, are there other questions about the survey or the results for heidijoy?
20:31:03 <smcginnis> dhellmann: +1
20:31:04 <dfisher> please, please, please understand that I'm not trying to ask you about something that I want to just consume and not provide for
20:31:05 * flaper87 shrugs
20:31:07 <heidijoy> I know there is room for it - specifically for late adds.
20:31:11 <flaper87> dfisher: perhaps start a new ml thread ?
20:31:12 <cdent> I've got one for heidijoy :
20:31:13 <cdent> Is there any correlating done between type of survey respondent and the NPS scores? That is, do we know what type of user/contributor/deployer/etc does or does not like stuff?
20:31:31 <dfisher> flaper87: engineers get stuck on the "Solaris" and "Oracle" part of the email.  I've done it before.
20:31:42 <smcginnis> dfisher: But at the same time you've said Oracle can't provide support for it. So there's the catch-22.
20:31:46 <heidijoy> Yes!! We've done a lot of those correlations. Pulling details @cdent...
20:32:04 <dfisher> smcginnis: agreed 100%.  What I'm trying to get across is what Solaris customers are telling us.
20:32:14 <dfisher> my customers want an LTS.
20:32:17 <sdague> heidijoy: as a follow on to cdent's point, are there key issues / factors impacting NPS over time
20:32:21 <dhellmann> dfisher, smcginnis, flaper87 : please move that to the mailing list
20:32:24 <dfisher> done.
20:32:27 <smcginnis> dhellmann: +1
20:32:31 <heidijoy> @cdent we looked at NPS correlations with user org size, which releases they are on, age of cloud (this one we showed in the report),
20:33:05 <cdent> heidijoy: underlying my question is wondering whether upstream developers like or dislike openstack more than deployers or users
20:33:05 <heidijoy> And surprisingly we didn't see correlations between NPS and demographic/firmographic data
20:33:22 <heidijoy> Ah - that is something I could explore more and follow up on in the ML
20:33:36 <sdague> heidijoy: I know in a previous survey there were some raw comment blocks, and pull quotes from those were sometimes useful. In much the same way as looking at all the TC vision responses in the raw provides some interesting insights that would get lost if it was just turned into numbers.
20:33:49 <heidijoy> We did do a correlation study on user role in April 2016 with no sig differences
20:34:03 <cdent> heidijoy: I'll look out for that, woudl be very interesting
20:34:25 <heidijoy> @sdague agree - and you'll find several pages of raw comments pulled from the ~1800 verbatim responses to our 3 qualitative questions
20:34:59 <heidijoy> I'll promise to take action to follow up on NPS correlations with the TC mailing list.
20:35:28 <heidijoy> Obviously we want to get to the bottom of this and reverse the trend. The NPS score declined significantly compared to one year ago: down 5 points among all users, down 10 points among users with deployments. Here’s a chart not included in the final report that looks at NPS for those with deployments only:  https://www.dropbox.com/s/6x2d56eor2dzpvl/NPS%20Deployments%20only.png?dl=0
20:35:46 <heidijoy> We included a lot of verbatim comments in the report from those who gave OpenStack a low NPS score and also from those who answered the question “what areas of OpenStack need further enhancement?” Also the Foundation execs have segmented NPS answers looking for trends and reaching out to users to help create a better user experience.
20:35:56 <lsell> sdague pages 12-22 of the long-form report capture many of the raw comments
20:35:56 <dhellmann> #action heidijoy follow up on NPS correlations with the TC
20:36:08 <fungi> this is also our first drop in nps since we started doing a periodic user survey, correct?
20:36:12 <heidijoy> Thank you @lsell for the page numbers
20:36:14 <heidijoy> When you read the report, you’ll want to dig into the "Deployment Decisions" section (pages 42-57) for installation/configuration insights.
20:36:28 <heidijoy> One more thing I’d like to highlight for the TC is that 12 projects asked specific questions to inform future development. See answers on pages 58-65 of the report.
20:36:37 <sdague> ah, the user perspectives bit, ok, will read through that
20:36:44 <sdague> thanks heidijoy / lsell
20:37:05 <dhellmann> are there any other questions or comments before we move on to the next topic?
20:37:19 <heidijoy> Thank you! That's all from me. I'll leave you to digest and remind you my email is heidijoy@openstack.org if I can help with other follow up.
20:37:48 <dhellmann> heidijoy : thank you for preparing the summary and for making time to be here for the meeting today for the discussion
20:37:59 <dims> thanks heidijoy
20:38:00 <smcginnis> heidijoy: Thanks!
20:38:02 <heidijoy> Very welcome!
20:38:57 <dhellmann> I do think the history behind dfisher's question is something worth documenting. Does anyone want to volunteer to help with that?
20:39:09 <EmilienM> dhellmann: I can do it
20:39:35 <smcginnis> There was really good info in the stable session in Austin on that.
20:39:42 <dhellmann> EmilienM : thanks
20:39:47 <jbryce> dhellmann: agreed. it continues to come up repeatedly and i don't think there's a universal understanding of the state of things and the reasons why it's that way
20:40:04 <dhellmann> smcginnis : good, that's a good reference to have
20:40:12 <flaper87> EmilienM: it'd be great to gather feedback from smcginnis and mriedem on this
20:40:20 <fungi> maybe we need an faq eventually, for easier reference in the future
20:40:21 <dhellmann> jbryce : there seems to be an impression that the contributors are making up the things they want to work on, rather than being directed by their employers :-)
20:40:35 <smcginnis> jbryce: Maybe worth some blog posts and some frank discussions with vendors selling support.
20:40:40 <flaper87> these topics have been discussed by cinder and nova in the past (and other parts of the communities but those 2 come to mind)
20:40:44 <mriedem> flaper87: it's more than just us, it's also vmt, stable team, infra team, qa team
20:41:00 <dhellmann> fungi : that's what I was thinking. Something that includes a history not just of how often it has come up, but how much the request and response have been the same.
20:41:19 <flaper87> mriedem: I didn't say it was just you :)
20:41:33 <smcginnis> It's all mriedem's fault.
20:41:35 <dhellmann> I'll work with EmilienM on gathering some of that history, but if anyone has references please share
20:41:40 <EmilienM> #action EmilienM to gather feedback from smcginnis / mriedem / dfisher and document the history on why we don't have OpenStack LTS
20:41:43 <EmilienM> is it correct ^ ?
20:41:53 <dhellmann> that should work, yes
20:41:58 <smcginnis> EmilienM: Sounds good.
20:42:01 <EmilienM> well, for dfisher I need to discuss more and know exactly what's wrong
20:42:05 <mriedem> also https://docs.google.com/presentation/d/1k0mCHwRZ3_Z8zJw_WilsuTYYqnUDlY2PkgVJLz_xVQc/edit?usp=sharing
20:42:09 <mriedem> if you don't like etherpads
20:42:23 <EmilienM> mriedem: can you open the doc please?,
20:42:28 <dhellmann> I know the reading I did recently on logging uncovered some interesting patterns
20:42:29 <EmilienM> it's restricted
20:42:39 <mriedem> https://docs.google.com/presentation/d/1k0mCHwRZ3_Z8zJw_WilsuTYYqnUDlY2PkgVJLz_xVQc/edit?usp=sharing
20:42:50 <EmilienM> mriedem: works
20:42:59 <dhellmann> mriedem : nice, thanks
20:43:11 <mriedem> and yes i make charts for non presentation sessions
20:43:16 <dims> :)
20:43:27 <dhellmann> is there anything else on this topic before we move on?
20:44:04 <dhellmann> ok
20:44:05 <dhellmann> #topic Update diversity tags
20:44:11 <dhellmann> It is time to take care of maintenance on some of the tags that need to be updated regularly.
20:44:16 <dhellmann> ttx has put together an update for the team diversity tags based on recent statistics
20:44:20 <dhellmann> #link https://review.openstack.org/448667
20:44:26 <johnsom> o/ In case there are questions for us
20:44:37 <dhellmann> cdent , I know you had a question about this one. did dtroyer's response answer it?
20:44:59 <cdent> yeah, dtroyer's response was good enough for me
20:45:07 <dhellmann> ok, good
20:45:12 <dhellmann> did anyone else have questions?
20:45:14 * dtroyer wipes brow
20:45:15 * dhellmann checks the latest revision
20:46:12 <dhellmann> I believe we say we'll do this review every cycle, but I don't think there is anything stopping us from doing it more often
20:46:51 <dhellmann> well, I may be wrong there, it says "should be updated around the same time as the 6 month release"
20:46:59 <smcginnis> There are some interesting comments in there from johnsom about how those numbers are calculated.
20:47:11 <fungi> also anyone who's interested can run it themselves and ask that we perform an interim update
20:47:58 <fungi> i'm curious if there are reasons for making it once a cycle only
20:48:17 <fungi> or if that was just to address expectations that it's automatically reassessed more often
20:49:01 <dhellmann> johnsom : yes, the rules as written say no one organization should represent more than 50% of any one of a list of several criteria. It seems the review stats are what changed in this case.
20:49:26 <johnsom> Yep
20:49:41 <johnsom> Frankly, recent events will make that metric worse.
20:49:43 <dhellmann> fungi : I think that was to ensure we did it regularly, but the phrasing may not have captured all of the subtleties of "we can do this more often, if needed"
20:49:48 <mordred> johnsom: yah. :(
20:49:58 <dhellmann> yeah, I would imagine so
20:50:00 <EmilienM> timebox: we have 3 more topics and 10 min left
20:50:07 <dhellmann> johnsom : were you objecting to the definition of the tag, or the calculations?
20:50:09 <mordred> johnsom: especially since the #1 feature people want from the user survey for networking is "software load balancing"
20:50:20 <dhellmann> EmilienM : thanks
20:50:25 <fungi> johnsom: if the people involved find sponsorship to continue upstream from different employers, then it could actually improve?
20:50:27 <johnsom> mordred Grin, for the second year running.
20:50:32 <mordred> johnsom: \o/
20:50:53 <dhellmann> we're going to have to start recruiting users to fund developers at some point, so they get exactly what they want :-)
20:51:08 <johnsom> My concern was about perceptions of what this metric means and the way it is calculated.  I think my thoughts in the comments.
20:51:14 <dhellmann> ok
20:51:30 <dhellmann> I think any discussion of redefining the tag will need to be handled separately
20:51:31 <fungi> or convincing the users who are funding developers to change their minds about what they want to fund a little less often ;)
20:51:39 <dhellmann> fungi : or that
20:51:55 <johnsom> fungi We lost one core, from outside of Rackspace, so the number will weigh heavier towards Rackspace now
20:52:03 <fungi> ahh
20:52:05 <dhellmann> as EmilienM points out, we have some other topics to cover
20:52:06 <dhellmann> #topic Next steps (if any) for Driver teams and networking-cisco's standing request
20:52:07 <dhellmann> #link https://review.openstack.org/403829
20:52:08 <dhellmann> #link https://review.openstack.org/403836
20:52:09 <dhellmann> #link https://review.openstack.org/363709
20:52:29 <dhellmann> I originally raised this issue, and it was put on the backlog until thingee had some time to do some work exposing driver status
20:52:34 <dhellmann> is there an update on that work?
20:52:38 <EmilienM> fungi: you made a good point
20:52:56 <thingee> o/
20:53:06 <dhellmann> thingee : where do things stand with the driver log work?
20:53:26 <thingee> project config work for new repo https://review.openstack.org/#/c/452556/
20:53:43 <thingee> and inclusion in projects yaml https://review.openstack.org/#/c/452548/
20:54:05 <thingee> and until I have a repo the work is being done here https://review.openstack.org/#/c/330027/
20:54:12 <thingee> taking over for ankur-gupta-f4 now
20:54:30 <dhellmann> thingee : have you had a chance to talk to the Cisco team about whether this would address their concerns?
20:54:48 <thingee> I have not received responses
20:55:08 <thingee> so I'm not sure the original person cares anymore?
20:55:11 <dhellmann> I still have my concerns about the fact that they've been disenfranchised, but I'm curious to know their perspective on the driver log
20:55:32 <dhellmann> yes, well, there were always the 2 sides to the issue. I set my concern aside until some of this work was done.
20:55:39 * ijw (who has a standing alert on 'Cisco') can find you someone to talk to, if that helps
20:56:00 <dhellmann> thingee, can you work with ijw to find the right contact?
20:56:12 <thingee> this example is being tested against nova and neutron for building their matrices. designate on the other hand might require some tweaking with their support-matrix.ini file
20:56:28 <thingee> but it should all the same in the end of what's rendered today with this disjointed script
20:56:40 <thingee> dhellmann: yes
20:56:43 <thingee> ijw: hi!
20:56:46 <dhellmann> thingee : ok, thanks
20:56:57 <dhellmann> let's squeeze in one more item before we have to yield the room
20:57:04 <dhellmann> #topic Abandoning the weekly meeting
20:57:19 <dhellmann> the time we have won't do this topic justice, but flaper87 do you want to introduce it?
20:57:30 <flaper87> yeah, super quick
20:57:34 <flaper87> I proposed a resolution a couple of mins before the meeting (sorry for the delay) so I'll just paste some context here:
20:57:36 <flaper87> Review: https://review.openstack.org/459848
20:57:45 <dhellmann> #link https://review.openstack.org/459848
20:57:50 <flaper87> I have more context but it's all pretty much in the review's commit message
20:57:56 <EmilienM> let's postpone it to next meeting, since topics have to be proposed before Thursday :-P
20:57:59 <smcginnis> I understand the argument for it, but I do like having a set time every week to make sure things get done.
20:58:07 <flaper87> I'm not good at writing resolutions so, please, help me out there
20:58:15 <dhellmann> EmilienM : yes, we wouldn't approve it this week, but it was on the agenda
20:58:17 <fungi> EmilienM: the topic was proposed before, just not the resolution ;)
20:58:22 <EmilienM> fungi: oops
20:58:27 <flaper87> smcginnis: the assumption we need this meeting to get things done is something I'd like to get rid off
20:58:37 <flaper87> I'd like us to be proactive *outside* the meeting
20:58:44 <EmilienM> flaper87: thanks for bringing this topic up, some teams in OpenStack have the same question for themselves
20:58:48 <flaper87> not 5 mins the meeting happens
20:58:58 <flaper87> sorry, that came out a bit snarky, it was not my intention
20:59:10 <mordred> I like the idea of us being proactive outside the meeting - and of making the meetings be more "as it becomes clear we need a meeting to talk about a thing"
20:59:21 <flaper87> mordred: ++
20:59:25 <sdague> yeh, at the same time, we do always seem to be running out of time at meetings
20:59:29 <fungi> i like the meeting as an "office hours" and maybe we don't need quorum
20:59:32 * dhellmann checks clock
20:59:33 <dhellmann> yes
20:59:38 <mordred> if we do that, maybe we sohuldalso have some sort of "office hours" where people can count on TC people to be in a place on IRC and easy to reach
20:59:43 <mordred> fungi: ++
20:59:48 <dhellmann> fungi : office hours is a useful idea
20:59:49 <flaper87> ok, let's start the discussion on the review
20:59:52 <jeblair> while it's not ideal, i find the weekly meeting helps keep me involved without needing to read *everything* on the mailing list.  basically, if we change this, let's try to make sure it doesn't make it harder for people to keep up or be involved in things they don't have 100% time for.
20:59:58 <EmilienM> @all for open discussion, some TC members (/me included) remain available on #openstack-dev
21:00:00 <mordred> jeblair: ++
21:00:03 <dhellmann> jeblair : I share your concern
21:00:04 <smcginnis> jeblair: I agree
21:00:06 <david-lyle> jeblair++
21:00:07 <flaper87> fungi: that will end up in almost the same guys always showing up
21:00:12 <dhellmann> speaking of time, we're out of it
21:00:17 <fungi> yes, the communication team will have their work cut out for them
21:00:19 <flaper87> if you make a meeting at 23:00 my time optional, you can be sure I won't attend
21:00:24 <dhellmann> thank you all!
21:00:28 <mordred> but I think we could also have staggered "office hours" so that non-US TC members aren't quite so disadvantaged
21:00:39 <flaper87> my brain is fried and drunk at that time
21:00:40 <smcginnis> mordred: +1
21:00:45 <smcginnis> flaper87: Hah!
21:00:47 <dtroyer> thank you dhellmann
21:00:48 <fungi> thanks for chairing, dhellmann!
21:00:55 <flaper87> dhellmann: thanks a bunch for chairing
21:00:56 <EmilienM> dhellmann: thanks!
21:01:00 <cdent> office hours ++
21:01:05 <dhellmann> next week your regular ttx should be back in the hot seat
21:01:15 <dhellmann> #endmeeting