14:01:45 <dhellmann> #startmeeting tc
14:01:46 <openstack> Meeting started Thu Jan 3 14:01:45 2019 UTC and is due to finish in 60 minutes. The chair is dhellmann. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:47 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:50 <openstack> The meeting name has been set to 'tc'
14:01:50 <dhellmann> happy new year, tc-members!
14:01:55 <TheJulia> o/
14:01:55 <dhellmann> #link http://lists.openstack.org/pipermail/openstack-discuss/2019-January/001354.html agenda for this meeting
14:01:55 <smcginnis> o/
14:01:55 <fungi> thanks dhellmann!
14:01:57 <lbragstad> o/
14:02:01 <dhellmann> #topic roll call
14:02:01 <dhellmann> tc-members, please indicate if you are present for the logs
14:02:14 <cdent> ahoy
14:02:16 * fungi is present and accounted for
14:02:24 <mnaser> o/
14:02:37 <lbragstad> present
14:02:56 <ttx> o/
14:03:17 <TheJulia> present
14:03:39 <dhellmann> evrardjp, zaneb, and gmann all signed up on the wiki as not being able to be present today
14:04:10 <dhellmann> let's start with old business
14:04:19 <dhellmann> #topic technical vision for openstack
14:04:19 <dhellmann> we have approved the first draft of the vision
14:04:19 <dhellmann> #link https://governance.openstack.org/tc/reference/technical-vision.html
14:04:26 <dhellmann> we have an update proposed by gmann
14:04:26 <dhellmann> #link https://review.openstack.org/#/c/621516/
14:04:32 <dhellmann> and another from fungi
14:04:32 <dhellmann> #link https://review.openstack.org/628181
14:04:39 <dhellmann> should we consider to track this at a high-level or are we ready to remove this topic from the tracker now, and treat further updates as individual work items?
14:04:45 <dhellmann> #link https://wiki.openstack.org/wiki/Technical_Committee_Tracker#Technical_Vision_for_OpenStack
14:04:49 <dhellmann> thoughts?
14:04:58 <fungi> i think we can take the umbrella task off the tracker
14:05:18 <cdent> I think we should keep it on until we use it to cause some kind of change
14:05:20 <ttx> +1
14:05:35 <ttx> that was a +1 for fungi
14:05:42 <cdent> The point of the creation of the vision was to have it leverage _something_ but it's not clear what the something is
14:05:58 <fungi> so what is the task we're tracking at that point?
14:06:00 <cdent> if it's just going to fade back into the reference background, then it was for naught
14:06:05 <smcginnis> Future decisions?
14:06:09 <cdent> "change stuff" :)
14:06:20 <fungi> how do we know when that's accomplished?
14:06:21 <cdent> I'm not certain, but since we don't know, it feels unfinishd
14:06:24 <dhellmann> I thought the purpose of this document was to influence future decisions about new projects?
14:06:31 <smcginnis> dhellmann: ++
14:06:43 <dhellmann> "to help clarify the boundary for where projects fit into OpenStack and where they may not"
14:06:47 <TheJulia> My interpretation was it was to serve as an overall guiding light, new and old projects moving forward
14:07:15 <mnaser> It seems like we’re not getting much new project additions (or rather sorry, new teams)
14:07:16 <cdent> One of the major driving forces behind its creation was to change existing projects, by making the religion more clear
14:07:18 <persia> I thought the purpose of the docunent was to help everyone (not just TC) understand shared common goals.
14:07:18 <dhellmann> I do like the idea of using it to drive other changes, but that feels like a second thing
14:07:24 <TheJulia> So I think it makes sense to keep it on the tracker. I feel that the discussion on gmann's edit just needs more time
14:07:43 <TheJulia> mnaser: +1
14:07:56 <dhellmann> cdent : perhaps, although I thought we went to great lengths to start by documenting the current state of things
14:08:04 <cdent> "start"
14:08:08 <cdent> thus it's not ready to be done
14:08:15 <mnaser> It seems like we’re maybe needing some work to be a more attractive home for projects.
14:08:21 <fungi> we're bound to have future edits too though. i suppose getting through the ones brought up as needed during the forum session could be seen as completing the initial version
14:08:37 <smcginnis> cdent: Are you thinking we now need to take this vision and review what we currently have to see how well they match up?
14:08:50 <cdent> smcginnis: yes, that would be a good next step
14:09:12 <TheJulia> I feel like we're at the next step point, so beyond edits, what is the next step for us?
14:09:27 <TheJulia> popularize it?
14:09:44 <TheJulia> further I guess
14:09:48 <smcginnis> That makes senese to me. I was primarily thinking of the vision doc as a point to apply for future decisions, but using it as a way to judge our current state also has value.
14:09:55 <cdent> I think we could invite people to express whether we're aligned with it, and what needs to change to make it more aspirational
14:10:07 <cdent> because unless it has aspirations, it's not a vision
14:10:21 <fungi> mnaser: attractive in what ways? (and how do you make sure what you change to make it more attractive to new projects doesn't make it less attractive to the ones which are already invested in driving the community we have?)... but also i'm not sure how that's relevant to the technical vision for cloud design
14:10:29 <TheJulia> cdent: I completely agree, and I think that might be good feedback for projects to explicitly attempt to collect as part of planning for Train
14:10:38 <cdent> TheJulia++
14:10:49 <dhellmann> hold that thought for later in the agenda :-)
14:10:54 <cdent> yeah, making that an explicit todo would be a good concrete step
14:11:00 <smcginnis> Train goal for each team to submit a
14:11:03 <fungi> i like that idea
14:11:14 <smcginnis> "vision review" self evaluation?
14:11:24 <TheJulia> I like it
14:11:26 <mnaser> fungi: afaik, the technical vision was created so we don’t have arbitrary discussions about if we can accept a project to be under OpenStack, that was my understanding
14:11:36 <ttx> I think it's good to drive change using it, but not sure an umbrella task is helping -- I'd rather track individual change when we come up with it
14:11:50 <mnaser> But it seems that no one is really applying to be new OpenStack projects, so it’s hard to see value in using it right now
14:12:04 <dhellmann> which of you is going to lead the effort to ask teams to do the self-evaluation?
14:12:05 <TheJulia> so, we should hold this discussion and proceed with the agenda for now
14:12:13 <TheJulia> I think were on a good track tbh
14:12:17 <fungi> mnaser: created to help guide those decisions, but there will still always be factors which come up that aren't clearly laid out in the vision and require further debate. i see it as a means of helping shape the debates we have
14:12:22 <smcginnis> TheJulia: ++
14:12:38 <smcginnis> and... fungi: ++
14:13:08 <TheJulia> fungi: ++ as well
14:13:51 <dhellmann> cdent : perhaps you want to sign up to lead that?
14:13:55 <TheJulia> dhellmann: if it comes down to it, I can lead the effort to try and drive teams to self evaluate
14:13:59 <cdent> dhellmann: yes, I'll take that
14:14:14 <cdent> and am happy to work with TheJulia on it
14:14:24 <dhellmann> #info cdent and TheJulia to work on initiative to have teams self-evaluate against the technical vision document
14:14:43 <smcginnis> Thanks cdent and TheJulia
14:14:46 <dhellmann> and it seems we agreed to leave the item on the tracker as-is for now
14:14:57 <smcginnis> dhellmann: Yes, I believe so. At least for now.
14:15:04 <dhellmann> cdent: would you please update that section of the wiki with the next step info
14:15:12 <cdent> ✔
14:15:16 <dhellmann> thanks
14:15:19 <dhellmann> next up:
14:15:27 <dhellmann> #topic next step in TC vision/defining the role of the TC
14:15:27 <dhellmann> we also approved a document explaining the role of the TC
14:15:27 <dhellmann> #link https://governance.openstack.org/tc/reference/role-of-the-tc.html
14:15:38 <dhellmann> is there more work to do here, or are we ready to remove this from the tracker now?
14:15:41 <dhellmann> #link https://wiki.openstack.org/wiki/Technical_Committee_Tracker#Next_steps_in_TC_Vision_.2F_defining_role_of_the_TC
14:16:10 <dhellmann> ttx, TheJulia, & cdent are listed as the drivers for this one
14:16:11 <cdent> A bit before christmas I agreed to publicise and verify it with a wider audience
14:16:26 <cdent> but I felt best to wait until later (i.e. now) to do that
14:16:44 <ttx> yes that is the next step
14:16:47 <cdent> the idea was "here's what we think we do, do you think that's true and right?"
14:17:00 <ttx> (is there anything missing? etc)
14:17:21 <cdent> (i'll update that on the wiki too, since I'm in there now)
14:17:27 <TheJulia> I don't think so, I think we need to kind of keep it simple and fact based, and just see what we get
14:17:45 <dhellmann> #info cdent to start discussion on the mailing list
14:17:47 <dhellmann> cdent : thanks
14:18:18 <dhellmann> I think that's covered then, unless anyone else has anything to add?
14:18:49 <dhellmann> moving on then
14:18:52 <dhellmann> #topic keeping up with python 3 releases
14:18:52 <dhellmann> We have approved all of the patches for documenting the policy and for selecting the versions to be covered in Stein.
14:18:52 <dhellmann> What are the next steps for ensuring that any implementation work is handled?
14:19:30 <dhellmann> I feel like gmann signed the QA team up to work on some of this, and since he's out today maybe we should hold the discussion
14:20:00 <smcginnis> Probably need to publicize better to the teams that they should be working towards 3.6 with 3.7 around the corner.
14:20:02 <TheJulia> It would be good for there to be a second pass review by a team such as QA, but yeah, we should wait on that
14:20:27 <dhellmann> maybe we can discuss this in an office hour when gmann is back from pto
14:20:36 <smcginnis> That sounds good to me.
14:20:39 <dhellmann> let's move on to the next topic
14:20:42 <TheJulia> New mailing list, so re-publicizing sounds like a good idea
14:21:09 <dhellmann> #topic Reviewing TC Office Hour Times and Locations
14:21:09 <dhellmann> #link https://wiki.openstack.org/wiki/Technical_Committee_Tracker#Reviewing_TC_Office_Hour_Times_and_Locations
14:21:09 <dhellmann> the most recent mailing list thread was resolved with no changes to the number of office hours
14:21:09 <dhellmann> #link http://lists.openstack.org/pipermail/openstack-discuss/2018-December/000542.html
14:21:09 <dhellmann> does anyone want to propose different times, or are we happy with the current schedule?
14:21:34 <smcginnis> Should we do a meeting #vote?
14:21:46 <smcginnis> I am for the status quo with this one.
14:21:59 <ttx> status quo
14:22:00 <dhellmann> if someone says they want to propose new times, I'll let them do that on the mailing list. otherwise, I consider this done.
14:22:06 <smcginnis> I think the thread kind of leaned that way towards the later posts.
14:22:07 <ttx> ++
14:22:10 <cdent> I think the thread resolve as "status quo"
14:22:11 <TheJulia> I kind of am too
14:22:19 <dhellmann> of course if the folks who aren't here want to do that later, that's fine, too
14:22:20 <lbragstad> ++
14:23:03 <fungi> yeah, status quo for me too
14:23:19 <dhellmann> #info we will keep the current meeting and office hour schedule
14:23:23 <dhellmann> k
14:23:24 <fungi> i concur that was the gist of the discussion on the ml
14:23:54 <dhellmann> right, now for some new business items
14:24:04 <dhellmann> #topic Train cycle goals selection update
14:24:04 <dhellmann> Thank you, to lbragstad and evrardjp for agreeing to lead the selection process for the Train goals.
14:24:04 <dhellmann> Do you have any updates to share with us this month?
14:24:35 <lbragstad> a couple of minor things
14:24:36 <dhellmann> lbragstad started a thread to discuss the goals and seek champions
14:24:37 <dhellmann> #link http://lists.openstack.org/pipermail/openstack-discuss/2018-December/000558.html
14:24:44 <dhellmann> sorry, go ahead lbragstad
14:24:45 <lbragstad> we're still pushing the discussion on the mailing list
14:25:22 <lbragstad> there have been just a couple people to step up for the pre-work, so we're in discussions with those folks, too
14:25:38 <dhellmann> great!
14:26:05 <lbragstad> but other than that... evrardjp and i will be touching base next week
14:26:24 <lbragstad> which will probably result in another nudge on the mailing list, or at least summarizing where the different goals stand
14:26:41 <lbragstad> that's about all from our end
14:26:42 * dhellmann nods
14:26:43 <dhellmann> it would be good to have regular updates about those discussions and any pre-work on the mailing list to keep the goals in everyone's minds
14:27:00 <lbragstad> i think so, too
14:27:12 <lbragstad> i'll make sure to send one out after i meet with jp
14:27:21 <dhellmann> which goals were the volunteers interested in helping with?
14:27:36 <lbragstad> moving legacy clients to osc
14:28:01 <lbragstad> there was some pre-work there that folks mentioned in the mailing list
14:28:20 <dhellmann> some analysis, irrc
14:28:27 <dhellmann> iirc
14:28:54 <dhellmann> are there any other questions?
14:29:34 <dhellmann> ok, next up then
14:29:35 <dhellmann> #topic health check status for stein
14:29:35 <dhellmann> #link https://wiki.openstack.org/wiki/OpenStack_health_tracker#Project_Teams
14:29:43 <dhellmann> how is it going contacting the PTLs for the health check for stein?
14:29:51 <dhellmann> does anyone have anything to raise based on what they have learned in their conversations?
14:30:12 <TheJulia> I simply have not had time to get started since the last meeting. I'll hopefully be able to get that started in the next couple of days.
14:30:13 <mnaser> I’ll personally admit I have not had the time to do mine. I plan to do them soon. It is a slow time in general right now anyhow
14:30:29 <cdent> I've got nothing from my formal trackees, but I can say that in general I've heard a lot of people saying (not just because of the holidays): Not much reviewing happening.
14:30:37 <ttx> Been putting that on pause over past month, will pick up again in January
14:30:48 <ttx> Difficult to do over the holidays :)
14:30:59 <cdent> That is: there is a dearth of regular reviewers and has been for a few months.
14:31:19 <smcginnis> I have heard the same about lack of reviewing happening.
14:31:24 <lbragstad> i've noticed a similar thread with my updates
14:31:32 <fungi> my hope was that 1. entrenchment into the new ml along with 2. a return from the holiday black hole would make for a prime opportunity to start reaching out at a time and place where ptls and others on those teams are likely to follow up with answers and concerns
14:32:10 <cdent> I reckon the concept of coherent teams is starting to fade.
14:32:35 <cdent> which is a natural evoluation, but something our process and approach needs to catch up to
14:32:47 <dhellmann> I wonder if that's an opportunity to fight back against the effect of Conway's Law
14:33:06 <cdent> possibly
14:33:20 <fungi> it does seem to me like we're getting more and more cross-project/casual involvement (though perhaps not as much as the reduction in project-centric involvement)
14:34:31 <dhellmann> it's definitely something to keep an eye on
14:34:31 <TheJulia> I've been thinking along fungi's line of thought, although it is going to vary for project to project
14:34:42 <mnaser> I think we should try to come up with something to make OpenStack exciting. People still need it, they just don’t know they do
14:35:12 <mnaser> We’re dealing with humans and emotions. If everyone else is working on that “other cool thing”, everyone will want to move towards working on it too
14:35:28 <TheJulia> I think the only way to really make it exciting again is enable faster velocity. Our structures have kind of made it more and more difficult to maintain or increase velocity as time goes on
14:35:34 <zhipeng> Big +1 mnaser
14:35:38 <cdent> TheJulia++
14:35:51 <mnaser> As employers also get excited over that new other cool technology they move employees to other projects
14:36:01 <mnaser> I agree with TheJulia as well on that
14:36:10 <dhellmann> I wonder if a slower velocity focused on more interesting things wouldn't have the same effect as a faster overall velocity
14:36:14 <mnaser> This initiative has to come from *somewhere*. I don’t know where.
14:36:22 <fungi> i thought faster velocity was what contributors complained caused them to be unable to keep up?
14:36:49 <dhellmann> mnaser: one of the bits of feedback we got from Alan back in Denver was that the TC needed to take on more of a "strategic leadership" role
14:36:55 <fungi> "openstack: moves too fast to allow for casual contribution"
14:36:56 <ttx> velocity and flow volume are related, but different
14:37:00 <cdent> I think we need to be careful to not overestimate the potential here. OpenStack is mature. It will never be exciting again in the way it once was. We need to adapt to that, not try to force a carnival.
14:37:06 <TheJulia> I think two pronged is going to be the only way. Begin to tear-down some of the limiting structure (like 2 +2s as a standard), and also try and have a few shiny things with lots of touch points
14:37:16 <ttx> They are basically complaining about how large the river is, not how fast it goes
14:37:24 <smcginnis> Big +1 cdent
14:37:34 <mnaser> I agree cdent I think it’s a matter of putting things in a different context maybe
14:37:37 <TheJulia> cdent: ++
14:37:46 <TheJulia> ttx: ++
14:37:48 <dhellmann> ttx: good metaphor
14:38:03 <smcginnis> Very good.
14:38:03 <cdent> mnaser: yes. rather than "lookie, shiny" it's 'look how much stuff is based on top of nice stron openstack'
14:38:19 <cdent> s/stron/strong/
14:38:22 <mnaser> cdent: exactly. In my experience at kubecon, many people didn’t see that value
14:38:24 <TheJulia> cdent: but that in its self could be shiny
14:38:36 <ttx> I think we can still encourage more... visible endeavors. I like the work on the K8s "cloud provider" because it has practical result
14:39:04 <smcginnis> I think the k8s thing is still partly due to deployment complexity.
14:39:10 <smcginnis> It's great having multiple cloud provider options.
14:39:10 <fungi> the linux kernel is far from being an exciting project (personal drama roller coaster aside), but still seems to manage a good amount of contribution and throughput
14:39:19 <cdent> that's a two way street too. From deep within the bowels of (e.g.) nova it's hard to be aware of things like the cloud provider and feel a bit meh
14:39:24 <smcginnis> But it's so, so easy for someone to just throw their cluster on AWS or others.
14:39:36 <mnaser> I agree ttx. Explaining the cloud provider benefits to folks at kubecon was super exciting for them (oh I can do this stuff on the big 3 but on my own cloud?)
14:39:49 <smcginnis> I'm sure they would be happy to have some control over their infra, but for many it's not possible due to how difficult it is for them to maintain their own cloud.
14:40:02 <cdent> fungi: yes, but they've got a very mature process that's adapted to that. we don't, yet.
14:40:05 <dhellmann> smcginnis : I've been hearing similar feedback about deployment complexity lately
14:40:05 <mnaser> Yeah but magnum also solved that problem, and for deployment, I dunno, I feel like as a PTL of a deployment project, it’s really not that hard
14:40:07 <ttx> We've been (rightly) focusing on the ops experience, but we should still do stuff that speaks to end users
14:40:18 <mnaser> Write a YAML file and call a command
14:40:30 <fungi> cdent: completely agree. that was more or less my point (in support of yours)
14:40:31 <mnaser> Other tools even have UIs
14:40:49 <mnaser> I think the deployment isn’t hard, i think historically it has been and people still think it’s that way.
14:41:07 <cdent> yeah, historical baggage is a biggie
14:41:14 <cdent> and upgrade baggage
14:41:16 <smcginnis> Eh, I just recently rebuilt my basement cloud and was a little disheartened by how little that deployment ease has progressed.
14:41:32 <mnaser> smcginnis: how did you deploy it?
14:41:35 <dhellmann> mnaser : what we learned in Vancouver (?) was that operators were doing their own deployment for reasons like flexibility and moving *off* of their home-grown solutions was hard
14:42:03 <smcginnis> mnaser: I started with ansible, then went back to following the install guides we publish on docs.o.o.
14:42:05 <lbragstad> another thing i've heard from people is that even though they can write a yaml file and call a command, they usually want to understand all of what's happening when they do that
14:42:12 <ttx> I place a lot of hope in the future "deployment toolkit features" classification taht will make it easier to pick your method
14:42:21 <mnaser> dhellmann: I can name a few which then realIzed that was really hard and decided to switch back to an upstream thing
14:42:34 <smcginnis> For two reasons: 1) Test the docs, 2) I needed a little more control without wanting to spend a week reading how to customize the ansible deployment.
14:42:34 <dhellmann> mnaser : no doubt
14:42:43 <mnaser> I think deployment tools maybe need a bit more work to make it easier.
14:42:49 <dhellmann> yeah, #2 there is I think what leads people to roll their own
14:43:03 <mnaser> (Except we don’t have much resources in OSA world unfortunately)
14:43:17 <dhellmann> sometimes an all-in-one whizbang tool isn't as "easy" as a well-defined process
14:43:31 <mnaser> so maybe tripleo has the bigger chance of success, theoretically.
14:43:33 <dhellmann> but I think we're getting a bit in the weeds
14:43:40 <mnaser> Yes
14:43:43 <TheJulia> dhellmann: ++
14:43:56 <mnaser> I forgot what we were discussing initially :)
14:44:00 <TheJulia> I was thinking that a minute or two ago while trying to come up with a cogent thought to express my perception
14:44:14 <dhellmann> so let's move on
14:44:18 <dhellmann> #topic next meeting
14:44:24 <dhellmann> #info the next TC meeting will be 7 February 2019 1400 UTC in #openstack-tc
14:44:29 <dhellmann> If you have suggestions for topics for the next meeting, please add them to the wiki at https://wiki.openstack.org/wiki/Meetings/TechnicalCommittee#Agenda_Suggestions
14:44:58 <dhellmann> between now and then, I would like for all of you to spend time thinking about (and talking about) what the TC's goals should be for the rest of stein
14:45:20 <ttx> ack
14:45:23 <cdent> based on the conversation we just had, I think our goal should be that
14:45:26 <fungi> sounds good. thanks dhellmann!
14:45:32 <TheJulia> cdent: ++
14:45:43 <dhellmann> in denver we agreed to focus on a small number of items, and I would like us to pick 1-2
14:45:44 <cdent> we've got to adapt culture, soon
14:45:51 <TheJulia> cdent: I guess the first step is a realistic self evaluation for projects
14:45:58 * cdent nods
14:46:08 <dhellmann> let's pick the *goal* and then discuss the implementation
14:46:14 <fungi> also, let's be sure to have those discussions primarily on the ml and in gerrit
14:46:34 <dhellmann> self-evaulation isn't an ends in itself; it's a means to gaining some insight, and *that* is the goal
14:46:51 <TheJulia> yeah, first you have to know where you are to plot a course
14:47:22 <cdent> fungi++
14:47:54 <dhellmann> #action tc-members consider goals for the TC for stein
14:48:01 <smcginnis> train
14:48:06 <dhellmann> we're still in stein
14:48:16 <dhellmann> the train tc will be a different group, and should set their own goals
14:48:18 <lbragstad> i think these are separate from community goals, right?
14:48:22 <dhellmann> yes
14:48:27 <smcginnis> Oh, things we still would like to accomplish. Gotcha.
14:48:32 <dhellmann> what does this group of 13 people want top accomplish as a team
14:48:37 <dhellmann> s/top/to/
14:48:51 <smcginnis> World peace.
14:48:56 <dhellmann> think bigger, smcginnis
14:49:01 <smcginnis> :)
14:49:27 <dhellmann> that's all we had on the agenda for today, so I think we can close a bit early and have a short break before office hours
14:49:34 <dhellmann> Thank you, everyone!
14:49:36 <cdent> thanks dhellmann
14:49:37 <TheJulia> Thanks!
14:49:38 <lbragstad> thanks dhellmann
14:49:50 <dhellmann> #endmeeting