14:00:05 <asettle> #startmeeting tc
14:00:06 <openstack> Meeting started Thu Jun  6 14:00:05 2019 UTC and is due to finish in 60 minutes.  The chair is asettle. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:07 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:09 <openstack> The meeting name has been set to 'tc'
14:00:16 <evrardjp> o/
14:00:17 <jroll> \o
14:00:22 <asettle> #link agenda https://wiki.openstack.org/wiki/Meetings/TechnicalCommittee
14:00:22 <mugsie> o/
14:00:22 <gmann> o/
14:00:29 <asettle> Rolling the call...
14:00:30 <ricolin> \o/
14:00:35 <lbragstad> o/
14:00:35 <mnaser> o/
14:00:42 <asettle> Will give a minute before jumping right into it
14:00:43 <TheJulia> o/
14:00:44 * fungi rollcalls like a mouseketeer
14:00:50 <dhellmann> o/
14:01:15 <zaneb> o/
14:01:30 <ttx> o/
14:01:30 <asettle> Entirely inappropriate but I do love a good gif-fuelled meeting. Let it be known that I am very welcoming of reaction gifs in my hosted meetings.
14:01:48 <asettle> Alright!
14:01:54 * mugsie opens http://replygif.net/ on 2nd display
14:02:02 <asettle> #topic Changes to the health check process
14:02:10 <asettle> The suggestion was to remove the formality of "health checks" and focus on TC members being liaisons to projects in an effort to help manage a project's health (if required).
14:02:18 <asettle> We need to assign TC members to teams on the project team page. fungi offered to update the wiki, and asettle offered to update the ML on this change once the wiki was updated.
14:02:28 <asettle> For everyone's memory to be jogged...
14:02:30 <asettle> #link https://etherpad.openstack.org/p/tc-train-ptg
14:02:42 <asettle> Line 62 were our action items assigned from the PTG
14:02:44 <fungi> yep, was mostly waiting for the recap to make sure before forging ahead on that task
14:02:51 * asettle nods
14:03:15 <asettle> In summary: we're moving away from the rigidity of the "health checks" for each project, and going to focus on "liaising" with different teams
14:03:27 <TheJulia> Seems reasonable
14:03:39 <fungi> didn't we also discuss moving the roster of liaisons out of the wiki?
14:03:42 <asettle> The suggestion was that each TC member is assigned a group of projects. Minimum effort required would be an introductory email, and the wiki to keep track of tehse assignments
14:03:46 <mugsie> fungi: we did
14:03:48 <asettle> fungi, yes but in favor of ^^
14:03:59 <asettle> The SIGs are to be included in the team health checks
14:04:05 <evrardjp> fungi: we did indeed
14:04:11 <fungi> just making sure
14:04:14 <asettle> Governance docs to be updated - mnaser (but this to be done after we've announced and formalised)
14:04:15 <mugsie> I have a patch somewhere I wrote on the plane for that, will get ti uploaded.
14:04:20 <asettle> Thanks mugsie
14:04:23 <dhellmann> it looks like we need an action item to move that list of liaisons
14:04:37 <gmann> hope liaisons things work which was not so successful till now for example- horizontal projects like QA
14:04:53 <mugsie> the issue I had was getting the info attached to sigs, as they are not defined in our repo, but i can start with projects to begin with
14:05:05 <asettle> mugsie, that would be helpful
14:05:16 <asettle> Do we want to assign action items in this meeting or continue to ref the etherpad?
14:05:22 <fungi> right, aiui, the wiki article will go to just being at most a few brief sentences and a breadcrumb trail leading to the liaisons info on the governance site
14:05:30 <mugsie> fungi: ++
14:05:30 * asettle nods
14:05:45 <mugsie> asettle: I think in the etherpad is best (to keep it consistant)
14:05:47 <asettle> Does anyone have any concerns about being "assigned" projects to introduce yourself and informally liase with?
14:05:50 <asettle> mugsie, cool sounds good to me
14:05:59 <mnaser> i vote for setting up action items during this
14:06:00 <fungi> no concerns here
14:06:10 <asettle> mnaser, you're the boss
14:06:25 <asettle> #action fungi to update wiki
14:06:28 <gmann> yeah action item are more useful and clear
14:06:38 <asettle> #action asettle to update community via openstack-discuss
14:06:41 <mnaser> it's just easier to consume for all of us afterwards (or at least i think :])
14:06:51 <fungi> from a standpoint of simplicity of implementation, liaisons can presumably be added to the projects.yaml and then rendered from that
14:06:59 <mugsie> fungi: that was my plan
14:07:02 <asettle> #action mugsie to update his patch
14:07:11 <fungi> awesome
14:07:13 <asettle> I like that idea, fungi
14:07:23 <mugsie> I think thats what i wrote, but it is on my open source laptop :)
14:07:30 <fungi> wasn't my idea, i don't think. or if it was it came up diring the ptg anyway
14:07:40 <asettle> Who wants to/has time to randomly assign individuals to projects in the projects.yaml file?
14:07:41 <dhellmann> mugsie : are you updating tools/assign_liaisons.py or are we dropping that?
14:07:53 <mugsie> dhellmann: I had not considered that
14:08:02 <mugsie> i seems like a godo thing to update
14:08:05 <mugsie> good*
14:08:17 <fungi> i wonder if it needs much/any updating
14:08:36 <mnaser> it probably just needs to update and do yaml changes to projects.yaml
14:08:38 <fungi> i suppose it could be improved to generate a patch to the projects.yaml with randomly-assigned liaisons
14:08:40 <dhellmann> well, it spits out wiki formatted text today to be pasted into the wiki. it doesn't modify projects.yaml
14:08:40 <mugsie> just to write out the info in the yaml file possibly? But thats a CR issue for later :)
14:08:41 <mnaser> i can pick that up.
14:08:57 <dhellmann> probably not a top priority, either way
14:08:58 <asettle> #action mnaser to update yaml file with liaisons
14:09:03 <asettle> Brilliant okay
14:09:07 <asettle> ANy further questions or actions for this topic?
14:09:20 <dhellmann> I think that last action isn't right.
14:09:28 <asettle> Oh, there's a lot going on here
14:09:30 <dhellmann> mnaser said he would update the tool, but mugsie is already updating the yaml
14:09:36 <asettle> Ah my bad
14:09:41 <dhellmann> #undo
14:09:42 <asettle> How does one erase an action?
14:09:42 <fungi> you can #undo an #action
14:09:47 <asettle> OH neat
14:09:54 <fungi> just #undo on a line by itself
14:10:03 <asettle> #undo #action mnaser to update yaml file with liaisons
14:10:04 <openstack> Removing item from minutes: #action mnaser to update yaml file with liaisons
14:10:21 <asettle> #action mugsie update yaml file with liaisons
14:10:27 <asettle> #action mnaser to update the tool
14:10:31 <asettle> Okay, sorry folks
14:10:34 <fungi> i think it ignores everything after the #undo regardless, but that works ;)
14:10:49 <fungi> just undoes whatever the last command was
14:10:53 <asettle> Oh
14:10:57 <asettle> Well now it's definitely undo
14:10:59 <asettle> undone*
14:11:00 <asettle> So, win win
14:11:01 <asettle> Right!
14:11:03 <asettle> Anything else?
14:11:25 <asettle> No rest for the wicked here people
14:11:36 <fungi> keep it movin'
14:11:49 <asettle> #topic Evolution of the help-most-needed list
14:11:58 <asettle> this was discussed and decided to become an uncapped list, adding docs surrounding annual re-submission for items. We will go through the action items on this list (line 84 of the etherpad). Business cases requiring updates.
14:12:15 <zaneb> #link https://review.opendev.org/657447
14:12:15 <asettle> gmann, provided an update the other day, thanks gmann
14:12:23 <asettle> zaneb, be doing a thang
14:12:24 <gmann> #link http://lists.openstack.org/pipermail/openstack-discuss/2019-June/006890.html
14:12:27 <asettle> Look at us
14:12:33 <zaneb> review above is to change the name and format
14:12:39 <asettle> ttx, update on the survey changes?
14:12:52 <lbragstad> there are a couple of reviews left that are looking for reviews
14:12:54 <asettle> evrardjp, ping for this discussion
14:12:55 <zaneb> evrardjp and I had a discussion yesterday on how to move forward
14:12:59 <lbragstad> s/reviews/patches/
14:13:14 <asettle> zaneb, TL;DR please for the purpose of the meeting :)
14:13:14 <gmann> zaneb: +1 thanks for that.
14:13:21 <zaneb> his suggestion was to copy the existing ones into a 2018 directory
14:13:25 <gmann> i  think we should keep old list till we fill items in new structure.
14:13:25 <ttx> err
14:13:41 <zaneb> also we have an etherpad to start working on massaging them into the new format
14:13:44 <gmann> zaneb: and with same url right ?
14:13:49 <zaneb> #link https://etherpad.openstack.org/p/2019-upstream-investment-opportunities-refactor
14:14:11 <asettle> Individuals have stepped up to refactor. Anything require volunteers still, zaneb ?
14:14:13 <mugsie> we should - myself and wendar have already talked to Oregan State University about this, and I would prefer not to delete the content as we are talking to them
14:14:16 <zaneb> gmann: no. only the 2019 stuff will be linked directly from the page (until next year)
14:14:27 <ttx> asettle: which survey changes ?
14:14:51 <asettle> ttx, action item on the etherpad for this topic on line 86: Suggest adding questions in user survey (ttx)
14:14:52 <gmann> ok, but till we fill new items, old link will keep pointing to old list ?
14:14:58 <ttx> We discussed adding TC questions and iirc came up with a shortlist
14:15:01 <zaneb> yeah, also we don't plan to merge that review until we have content to go up
14:15:17 <gmann> +1
14:15:32 <ttx> dhellmann: did you drive that TC questions in survey effort?
14:15:33 <asettle> ttx, anything further on that one?
14:15:38 <ttx> ISTR you did
14:15:53 <zaneb> still need volunteers to rework the existing text from that etherpad into investment opportunities instead of begging for help :)
14:15:55 <ttx> (I did suggest it, they said of course, and we did come up with questions)
14:15:58 <mugsie> I think "what projects do you contribute to" and a "what is stopping you contributing" were two (just a lot better worded)
14:16:16 <fungi> that sounds right
14:16:22 <lbragstad> zaneb so - expanding the value section, right?
14:16:26 <ttx> #link https://etherpad.openstack.org/p/tc-user-survey-2019
14:16:34 <fungi> aha
14:16:40 <asettle> ttx, gracias
14:16:49 <fungi> so are those in a state we can get them in front of osf staff maintaining the survey?
14:17:03 <ttx> not taking any credit for teh questions as someone else [tm] drove that :)
14:17:14 <asettle> zaneb, we probably need someone who is more business minded than our techy selves for that. That was half the problem in the first place.
14:17:17 <zaneb> lbragstad: more just putting it front and centre. there's a template: https://review.opendev.org/#/c/657447/3/reference/upstream-investment-opportunities/template
14:17:31 <AlanClark> zaneb - if you point me to the etherpad with some simple instructions and timeframe (deadline) I'm happy to help with the text
14:17:42 <evrardjp> AlanClark: good to hear :)
14:17:53 <fungi> woo, a great volunteer. thanks AlanClark!
14:17:54 <zaneb> AlanClark: thanks! https://etherpad.openstack.org/p/2019-upstream-investment-opportunities-refactor
14:17:55 <asettle> #action AlanClark to help update investment opportunities document in etherpad.
14:18:03 <lbragstad> thanks AlanClark
14:18:04 <asettle> #action zaneb to liaise with AlanClark and provide appropriate deadline
14:18:04 <dhellmann> ttx: yes, the question was added to the survey
14:18:07 <gmann> AlanClark: thanks. really very helpful
14:18:21 <asettle> Okay, anything further on this item?
14:18:35 <asettle> lbragstad, zaneb evrardjp ?
14:18:37 <zaneb> nope
14:18:43 * lbragstad doesn't have anything
14:18:46 <asettle> Smashing
14:18:48 <lbragstad> i like how this is shaping up
14:18:48 <asettle> ONWARDS
14:18:50 <evrardjp> nope
14:18:55 <gmann> nothing  from me
14:18:58 <asettle> #topic Goal selection is changing
14:19:06 <asettle> The way goals are being selected for the upcoming release will change. For Train, we will work on socialising the idea of proposing goals that are OpenStack-wide, but not tech-heavy. The new goal selection process splits the goals into "goal" and "implementation". Further details at the meeting. See line 101 of the etherpad for action items.
14:19:34 <mugsie> I have not moved on this yet - I need to transcribe my notes into a patch
14:19:42 <asettle> Thank you mugsie
14:19:56 <asettle> For those who were not in the room, any questions on why/what is happening here before we dive into action items?
14:20:08 <asettle> Specifically looking at jroll and TheJulia
14:20:15 <asettle> and gmann
14:20:45 <gmann> not much idea on details. but waiting for mugsie patch to get into details and discussion
14:20:50 <asettle> Good plan, stan
14:20:59 <fungi> what was the sequence we came up with for approving these?
14:21:05 <asettle> mugsie, do you have an estimation on when you'd be able to update?
14:21:06 <dhellmann> I don't remember why we said new goals would not be "tech heavy" can someone remind me of that?
14:21:12 <asettle> dhellmann, oh that was me
14:21:27 * zaneb doesn't remember that either
14:21:30 <TheJulia> asettle: Nothing from my end, the notes made sense to me
14:21:37 <jroll> I don't see the problem we're solving written on the etherpad, so it's hard to understand what we're trying to accomplish by changing the process
14:21:40 <asettle> Socialising goals so that individuals realise ANYONE can propose a goal (AKA PDF goal)_
14:21:43 <zaneb> also Train is like fully underway...
14:21:44 <asettle> It was about socialisation of the goal process
14:21:50 <asettle> I wrote it badly in the agenda, sorry. I was in a rush
14:22:04 <dhellmann> ah, so proposals do not need to have all of the implementation details?
14:22:11 <mugsie> zaneb: I thought this was for post train?
14:22:17 <dhellmann> that bit does seem familiar, as a way to have goal ideas collected earlier
14:22:18 <lbragstad> we received feedback from people saying they were surprised that the goal wasn't super focused on writing code
14:22:23 <mugsie> dhellmann: yeah, for the first stage (thats what I have in my notes anyway)
14:22:25 <zaneb> mugsie: that would make more sense
14:22:27 <zaneb> :)
14:22:28 <asettle> dhellmann, of sorts, yes. And also that a goal can *be* anything, as long as it applies across the whole community
14:22:37 <fungi> i'm assuming the plan is still not to approve the goal part before there's any implementation written (even if we approve it assuming we'll discover that the implementation needs further refinement on the ground)
14:22:37 <asettle> lbragstad, yes thank you
14:22:46 <dhellmann> asettle : ok, thanks for clarifying
14:22:57 <mugsie> fungi: yeah, thats what I understood
14:23:09 <asettle> #action asettle to clarify "tech-heavy" in the agenda.
14:23:13 <fungi> okay, seems i remembered correctly then
14:23:22 <fungi> the etherpad was vague on the process change
14:23:48 <asettle> jroll - it was a retrospective, less of a problem. We talked about the fact we had very limited goal proposals, and we had to push really hard for those.
14:23:53 <TheJulia> It seems like themes versus highly specific things
14:23:54 <asettle> This was a discussion around the process, and how we could improve it.
14:23:54 <gmann> it will be good we can write details on etherpad and then take those on gerrit ?
14:24:12 <asettle> I like that idea, gmann - mugsie would this be okay?
14:24:26 <fungi> jroll: if i haven't completely imagined it, the idea was this would allow us to apply different sorts of review rules to the goal text vs the implementation plan
14:24:39 <dhellmann> it would be good for someone to prune the https://etherpad.openstack.org/p/community-goals etherpad, too, since we've done some of those things
14:24:47 <gmann> also i remember from joint leadership meeting discussion that AlanClark or someone from BoD mentioned about helping on those goal ideas ? how we can accommodate that process?
14:24:52 <asettle> Any takers?
14:24:57 <asettle> #link https://etherpad.openstack.org/p/community-goals
14:25:04 <lbragstad> o/
14:25:07 <zaneb> gmann: there was a thread on the foundation list about that
14:25:08 <lbragstad> i can take a stab at it
14:25:17 <asettle> #action lbragstad to prune the community-goals etherpad
14:25:19 <mugsie> I saw that the BoD were interested in suggesting some goals on the foundation list
14:25:20 <gmann> zaneb: ohk, thanks will check
14:25:20 <asettle> thank you
14:25:42 <jroll> fungi: thanks, that makes some amount of sense. seems like a lot of work for a review rules optimization, but I guess folks seem eager to do it so /shrug
14:25:57 <fungi> yeah, goal suggestions welcome from everyone in the community, including board members ;)
14:26:01 <asettle> Aye
14:26:07 <asettle> Right - any further action items here or questions?
14:26:20 <ttx> nope
14:26:29 <fungi> jroll: the hope is that it reduces the actual work of iterating on goal implementation plans
14:26:38 <AlanClark> gmann - I am interested in having the board participate on the goal ideas.
14:26:39 <jroll> okay
14:26:40 <fungi> i'm good
14:26:44 <jroll> thanks fungi
14:27:08 <gmann> AlanClark: +1.
14:27:31 <asettle> AlanClark, that's great to hear. Let's talk about that after this meeting and ensure the board is aware of how the ycan do that. The process is open to them now.
14:27:34 <dhellmann> #link http://lists.openstack.org/pipermail/foundation-board/2019-May/000501.html foundation-board thread on proposing themese
14:27:48 <asettle> Okay, let's skidads - we're only halfway through
14:27:53 <asettle> #link https://media.giphy.com/media/3o6wrBG9xOvMrVsp3i/giphy.gif
14:28:04 <asettle> #topic Pop-up teams
14:28:12 <asettle> Officially recognised and implemented into governance thanks to ttx.
14:28:19 <ttx> well not approved yet
14:28:19 <asettle> Everyone please review
14:28:21 <asettle> #link https://review.opendev.org/#/c/661356/
14:28:29 <asettle> And I'm missing the link handy to the other one, sorry ttx
14:28:35 <ttx> just posted a fix for your suggestions asettle
14:28:46 <asettle> ttx, yes I saw :) thanks for doin that. I'll review again shortly.
14:28:47 <ttx> the other one is linked from the first one
14:28:56 <asettle> Neat. Any questions on the pop-up teams?
14:29:39 <dhellmann> #link adding image encryption as a popup team https://review.opendev.org/#/c/661983/2
14:29:42 <asettle> Thanks for those patches, ttx
14:29:44 <asettle> Gracias, dhellmann
14:29:54 <asettle> #link https://media.giphy.com/media/90UFDHjEA9RwQ/giphy.gif
14:30:05 <evrardjp> haha
14:30:07 <asettle> #topic SIG governance
14:30:20 <asettle> ricolin ?
14:30:38 <asettle> ricolin and I are in the process of defining what SIG governance looks like. 137 in the etherpad for action items
14:31:08 <asettle> Clarify that it's okay to disband/part of life cycle + evaluating SIGs over time (ricolin)
14:31:08 <asettle> Liaisons for SIGs from the TC (ricolin, asettle)
14:31:08 <asettle> Reach out to OSF/UC to increase content/question in user survey (ricolin, asettle)
14:31:21 <ricolin> The upgrade sig is gone, and doc SIG might be on the way
14:31:29 <ricolin> asettle, give me a sec
14:31:38 <asettle> ricolin, np
14:32:15 <ricolin> #link https://etherpad.openstack.org/p/explain-team-formate-differentiate
14:32:42 <ricolin> So I'm wondering if this looks like right format for that action
14:32:51 <asettle> I still need to review more (I'm yellow)
14:33:01 <asettle> #action asettle to review ricolin's etherpad for SIG items
14:33:45 <ricolin> I try to separate those as Long/short term Mission oriented or Require deliverable service
14:33:56 <ricolin> to explain goals, popup, SIG and project
14:34:04 <fungi> i'm interested in having a discussion after the meeting on where things like the technical election officials and vulnerability management team fall into the growing taxonomy of group structures we have
14:34:17 <ricolin> If that sounds like right, I can push it up for review
14:34:35 <fungi> (doesn't have to be immediately after the meeting, just when folks who are also interested in this topic have time)
14:34:42 <asettle> ricolin, maybe tc-members should review the etherpad first
14:35:03 <ttx> also I wanted to list all of out social constructs on a single diagram, like what the Kubernetes community does to explain SIGs, committees and workgroups they have
14:35:11 <asettle> #action tc-members to review goal, popup, and SIG project etherpad https://etherpad.openstack.org/p/explain-team-formate-differentiate
14:35:16 <asettle> ttx, that's a good suggestion
14:35:16 <ttx> I found that useful
14:35:22 <asettle> Could you share a link, ttx ?
14:35:35 <ricolin> ttx +1
14:35:36 <ttx> was on slides... let me see
14:35:43 <asettle> Thank you ttx
14:36:06 <ricolin> ttx I think that's what's short from my etherpad docs
14:36:21 <asettle> Anything further ricolin ? Sorry to cut short, but we need to move fast. Lots to cover :)
14:36:42 <asettle> #link https://media.giphy.com/media/EhIrNwoxFXt84/giphy.gif
14:36:47 <ttx> will link if I find it
14:36:49 <ricolin> asettle, fine for now
14:36:52 <asettle> Thank you both :)
14:36:55 <asettle> #topic Python 3 check in
14:37:10 <asettle> mugsie, this was on your plate again. Also, discussion about checking in with Swift and seeing where they were at
14:37:50 <asettle> See lines 146 of the etherpad for action items
14:37:50 <mugsie> yes - the -train jobs seem to have been proposed across the projects
14:38:22 <mugsie> I need to sync with dhellmann or release-team to find the code for the proposal bot :)
14:38:30 * ttx screencaps
14:38:32 <zaneb> btw this action is captured in the Train goal
14:38:37 <zaneb> #link https://review.opendev.org/657908
14:39:00 <zaneb> which we have a champion for and is ready to approve
14:39:05 <asettle> Fabulous
14:39:09 <asettle> Swift?
14:39:32 <mugsie> we had it marked as the liason
14:39:34 <asettle> #action mugsie to sync with dhellmann or release-team to find the code for the proposal bot
14:39:37 <asettle> mugsie, we sure did
14:39:41 <ttx> #link https://imgur.com/a/ke3t6eC
14:39:44 <asettle> tc-members - who was the swift liaison?
14:39:54 <mnaser> let me grab that
14:40:00 <zaneb> hmm, I might be one of them :)
14:40:01 <asettle> ttx, excellent
14:40:03 <asettle> mnaser, okay thank you
14:40:13 <asettle> #action mnaser to sync up with swift team on python3 migration update
14:40:16 <mnaser> (the list was not updated due to discussed earlier, but cdent and zaneb)
14:40:23 * asettle nods okay
14:40:33 <asettle> zaneb, sync up with mnaser?
14:40:39 <ricolin> ttx thx
14:40:43 <zaneb> can do
14:40:50 <mnaser> thanks zaneb.
14:40:55 <asettle> We are over halfway team!
14:40:57 <asettle> #link https://media.giphy.com/media/ujvW8qiDfbCJRnIHPq/giphy.gif
14:41:07 <asettle> #topic Leaderless projects
14:41:13 <asettle> Summary: it's a concern
14:41:27 <asettle> Action items were on line 185 of the etherpad. Suggestions include reworking the documentation around the current role of the PTL and providing tips on how to "be a better PTL" and offering shadowing and mentoring for potential candidates. This all needs to be socialised further.
14:41:46 <fungi> we've had one recently go missing after being assigned outside normal electoral process, right?
14:41:58 <asettle> We had a number of interested parties on this item. Including jungleboyj , timburke_ , me apparently, ttx and ricolin
14:42:03 <asettle> fungi, we have indeed
14:42:30 <zaneb> fungi: was this Zaqar?
14:42:43 <ttx> I was interested in helping better document PTL expectations
14:42:52 <asettle> Ben Nemec also shared his PTL tips and tricks
14:42:53 <TheJulia> I think this also lines up with kind of preventing burnout in the community. PTL is very much a role that essentially puts people on a train to burnout
14:42:57 <asettle> #link https://etherpad.openstack.org/p/DEN-ptl-tips-and-tricks
14:42:57 <ttx> since the current content in the projectteam guide is a bit overwhelming
14:43:03 <fungi> zaneb: yes, not sure the action items we established for this would necessarily have solved that case
14:43:05 <asettle> ttx, that it is
14:43:07 <ttx> with an eye toward encouraging delegation
14:43:10 <gmann> is this to improve the existing doc or new doc/process ?- https://docs.openstack.org/project-team-guide/ptl.html
14:43:17 <asettle> #link https://docs.openstack.org/project-team-guide/ptl.html
14:43:22 <ttx> I'd improve existing content
14:43:26 <asettle> Improve
14:43:28 <ricolin> ttx we definitely need to update the guideline, so +1
14:43:31 <gmann> ok
14:43:40 <asettle> We want to encourage people to take on the role, but we need to make sure it isn't too much for people
14:43:59 <asettle> ttx, ricolin - let's sync up sometime and review the PTL section. Cool?
14:44:06 <asettle> Anyone else want to volunteer to help?
14:44:13 <ricolin> asettle, yes
14:44:35 <gmann> i like to idea to circulate this doc to elected PTL(new or old)
14:44:50 <zaneb> fungi: fwiw we found reviewers to approve the patch to get their gate working again
14:44:57 <asettle> gmann, I believe this has been something we've been trying to do. Definitely was brought up that people didn't know it existed.
14:44:59 <asettle> #action asettle ttx ricolin to sync up and review the PTL section of the project teams guide to improve the PTL experience
14:45:04 <fungi> zaneb: thanks, that's a relief
14:45:07 <asettle> gmann, we also  talked about offering better peer mentorship
14:45:21 <gmann> +1
14:45:27 <asettle> Groovy dudes
14:45:29 <asettle> #link https://media.giphy.com/media/cdNSp4L5vCU7aQrYnV/giphy.gif
14:45:40 <asettle> Anything else on this topic?
14:46:31 <evrardjp> nothing
14:46:37 <asettle> Coolio hoolio
14:46:38 <asettle> SO CLOSE
14:46:42 <asettle> #topic Kickstarting innovation in Openstack
14:46:52 <asettle> zaneb,  proposed a zany (har har har) suggestion regarding a new multi-tenant cloud with ironic/neutron/optionally cinder/keytstone/octavia (vision will be completed with k8s on top of OpenStack). Suggestion was for new whitepaper written by zaneb and mnaser.
14:47:00 <asettle> How's that going along, fellas?
14:47:05 <zaneb> I am still working on this
14:47:16 <asettle> Any updates to share with your fans?
14:47:26 <zaneb> mostly talking to networking experts to make sure that we propose something that isn't actually insane
14:47:27 <mugsie> #link http://replygif.net/i/1021.gif (for the pun)
14:47:34 <mnaser> i have not sync'd up with zaneb on that but i've done some (personal) work on trying something like that
14:47:38 <evrardjp> zaneb: that phrase doesn't work
14:47:38 <zaneb> tl;dr networking is hard
14:47:47 <asettle> mugsie, excuse you I clearly thought long and hard about that one
14:47:55 <mugsie> zaneb: yes, yes it is
14:48:00 <asettle> zaneb, mate preach
14:48:01 <johnsom> lol, zaneb let me know if I can answer anything with Octavia
14:48:15 <asettle> johnsom, dude do you have an octavia ping setup?
14:48:16 <evrardjp> johnsom: I thought you wanted to answer everything with it? :p
14:48:29 <asettle> So hilariously eerie when people just APPEAR
14:48:33 <zaneb> it's been on the back burner, but I need to sink some proper time into it again
14:48:34 <mugsie> asettle: yes, he does
14:49:02 <asettle> #link https://media.giphy.com/media/PIYYhi1eoZHSE/giphy.gif
14:49:03 <asettle> yahuh
14:49:04 <asettle> Okay
14:49:05 <johnsom> Many folks lurk watching over the TC.  lol
14:49:06 <evrardjp> thanks zaneb. That will be a very interesting read :D
14:49:08 <asettle> zaneb, anythi ngelse?
14:49:11 <zaneb> I imagine johnsom has his IRC client set up to ping him whenever anyone says "networking is hard"
14:49:14 <asettle> johnsom, I hope they're all enjoying my gifs
14:49:19 <ttx> johnsom: come for the TC, stay for the GIFs
14:49:34 <evrardjp> zaneb: I hope it's not "octavia" as his ping
14:49:37 <fungi> this seems a lot like a "constellation" (even though i know we basically stopped trying to artificially generate some)
14:49:38 <asettle> That's cause my gif game strong!
14:49:41 * asettle flexes
14:49:48 <mugsie> fungi: a little bit, yeah
14:49:49 <ricolin> lol
14:49:52 <johnsom> ttx Totally accurate
14:49:58 <asettle> Okay but seirously zaneb we goo?
14:49:58 <ttx> so many GIFs... I feel younger already
14:50:00 <asettle> good*
14:50:02 <ricolin> the gif better be there ever since!
14:50:19 <fungi> so many gifs it's like being back on compuserv
14:50:21 <evrardjp> asettle: you now have "peer pressure"
14:50:33 <asettle> evrardjp, mate I can HANDLE IT
14:50:34 <evrardjp> roll for initiative!
14:50:40 <zaneb> yes, let's move on because there's not much to report yet because I am lazy
14:50:41 <asettle> Okay let's rock 'n' roll homies
14:50:50 <asettle> #topic Deleting all the things!
14:50:55 <asettle> #link https://memegenerator.net/img/instances/14634311.jpg
14:50:58 <asettle> ^^ obviously have to add
14:51:09 <asettle> mugsie, or as I like to call you in my head, muggles - update us!
14:51:09 <ttx> that guy looks a bit like mugsie indeed
14:51:15 <asettle> See line 234 for action items
14:51:16 <evrardjp> better with the fire meme
14:51:37 <asettle> In summary: Should we be deleting things? Yes we should! (with caveats)
14:51:42 <mugsie> I tried writing this up, but couldn't get something I liked, and it fell of the burner
14:51:50 <mugsie> off*
14:51:56 <ttx> mugsie: as long as you did not delete it...
14:51:59 <asettle> I have noticed that a lot of the AIs here are mugsie - perhaps we could be sharing the load here?
14:52:05 <evrardjp> ttx: haha.
14:52:07 <zaneb> mugsie: that sounds messy
14:52:16 <asettle> Does anyone else feel like they could pick up the action item for deleting unmaintained things?
14:52:21 <mugsie> it was. there was words all over the office
14:52:57 <asettle> Don't everyone offer at once hey
14:53:14 <mugsie> its ok, it was my hobby horse
14:53:23 <asettle> Alright, ping if you need assistance mugsie
14:53:24 <evrardjp> I thought we didn't really have to write that up. "It's okay to delete stuff"
14:53:35 <mnaser> i think the action is probably to socialize deleting things, rather than doing it ourselves D:
14:53:39 <asettle> #link https://media.giphy.com/media/3og0IF4QM5XYI6tF3G/giphy.gif
14:53:46 <evrardjp> mnaser: probably
14:53:47 <mugsie> we need to make it clearer, and fix the tags to allow it be better
14:53:49 <asettle> Who wants to write that email?
14:53:59 <fungi> evrardjp: more about encouraging folks to delete things which are an unnecessary maintenance burden
14:53:59 <evrardjp> mugsie: oh that was the action item? Change the tags?
14:54:15 <evrardjp> fungi: that's what I meant, sorry for my poor english again
14:54:19 <asettle> GUYS 5 MINUTES
14:54:22 <asettle> TALK AFTER
14:54:24 <asettle> MUGSIE FINE
14:54:42 <smcginnis> asettle is in shouting mode. :)
14:54:45 <evrardjp> well if it's not to talk about this, couldn't this be an email?
14:54:53 <evrardjp> :p
14:54:53 <mugsie> evrardjp: yes
14:54:58 <mugsie> :P
14:54:59 <evrardjp> ok let's move on
14:55:01 <asettle> #topic Forum session planning
14:55:06 <asettle> In summary - weeeeee kinda forgot a few things
14:55:08 <asettle> #link #topic Forum session planning
14:55:17 <asettle> this one was done rather hastily and we missed a few things (such as a goals session). See action items on line 243 of the PTG etherpad
14:55:27 <ttx> shoudl we plan to regroup by train-2 milestone?
14:55:49 <asettle> ttx, for forum session planning?
14:55:53 <ttx> yes
14:55:59 <asettle> That seems reasonable
14:56:01 <asettle> Any objections?
14:56:04 <evrardjp> sounds good
14:56:07 <ttx> sounds like te right moment to start talking about it
14:56:09 <zaneb> +1
14:56:14 <gmann> +1
14:56:16 <zaneb> right now is a bit early
14:56:16 <ttx> I mean le right moment
14:56:23 <fungi> makes sense, yes
14:56:26 <asettle> #action tc-members to regroup by train-2 milestone for Shanghai forum session planning
14:56:27 <asettle> Fab
14:56:39 <ttx> damn now we went too fast
14:56:42 <asettle> ONWARDS
14:56:46 <asettle> #topic Socialising successbot and thanksbot.
14:56:49 <asettle> In summary: do it. Let's do it
14:56:49 <dhellmann> we should make sure someone actually schedules that regrouping
14:56:50 <asettle> Get do it
14:56:53 <asettle> YEAH YEAH
14:57:07 <evrardjp> #thanks asettle for reviving thanksbot
14:57:08 <openstackstatus> evrardjp: Added your thanks to Thanks page (https://wiki.openstack.org/wiki/Thanks)
14:57:13 <ttx> #success asettle managed to fit all the TC agenda in one hour
14:57:15 <openstackstatus> ttx: Added success to Success page (https://wiki.openstack.org/wiki/Successes)
14:57:18 <asettle> YES
14:57:19 <asettle> \o/
14:57:23 <asettle> dhellmann, good call. You're up!
14:57:26 <evrardjp> ttx: I like your style
14:57:30 <zaneb> #thanks asettle for running this epic marathon meeting and wrapping it up on time
14:57:31 <openstackstatus> zaneb: Added your thanks to Thanks page (https://wiki.openstack.org/wiki/Thanks)
14:57:38 <asettle> Aw thanks fronds <3
14:57:39 <dhellmann> asettle : I won't be there, so it should be someone else :-/
14:57:42 <asettle> Oh yeah
14:57:44 <asettle> ttx, ?
14:57:49 <ttx> ...sure
14:58:03 <ricolin> #thanks asettle for the GIFs
14:58:04 <asettle> #action ttx to schedule said milestone 2 forum meeting with tc-members
14:58:04 <openstackstatus> ricolin: Added your thanks to Thanks page (https://wiki.openstack.org/wiki/Thanks)
14:58:05 <asettle> omg
14:58:07 <ttx> not sure where to schedule it tho
14:58:08 <dhellmann> could be the chair, too, it's just to make sure we schedule the discussion
14:58:09 <asettle> THANKS EVERYONE
14:58:16 <lbragstad> thanks all
14:58:20 <fungi> also if someone is interested in extending it further, adding a #til or #tip feature should be quite simple (idea stolen from teh debian community which has a "til" irc channel for such things)
14:58:21 <asettle> You have 2 minutes to say what you need to say
14:58:53 <mnaser> i can get an action item to schedule something by m-2
14:59:03 <jroll> thanks asettle, I'm impressed with the on topicness of this meeting
14:59:08 <TheJulia> thanks!
14:59:10 * jroll votes asettle to host all meetings going forward
14:59:15 <evrardjp> fungi: I like this
14:59:18 <ttx> asettle: ideally we'd resurface it at the August TC meeting
14:59:19 <mugsie> asettle: http://replygif.net/i/595.gif
14:59:24 <fungi> mnaser: i think ttx akready got actioned
14:59:26 <TheJulia> jroll: I second the motion
14:59:27 <asettle> I think mnaser might feel a bit pushed aside, hey jroll ? :P
14:59:33 <ttx> any chance you can write that done wherever you take notes for agendas?
14:59:35 <asettle> mugsie, that is excellent
14:59:42 <mnaser> oh okay, seems fair
14:59:49 <jroll> well then, I vote for asettle to give out meeting hosting lessons :P
14:59:51 <asettle> ttx, hm?
14:59:58 <asettle> jroll, happy to!
15:00:04 <ttx> mnaser, asettle: we need to make sure it's added to the August TC meeting agenda
15:00:06 <fungi> it's all about cracking the whip
15:00:08 <evrardjp> asettle: sounds you just enrolled for that
15:00:09 <asettle> It's all about gif game, needing to pee and still drinking your tea
15:00:12 <asettle> A fine balance, if you will
15:00:17 <ttx> asettle, mnaser: (the forum prep topic)
15:00:29 <asettle> #action asettle and mnaser to sort August TC meeting agennda
15:00:32 <mnaser> ttx: i think we'll use the last agenda as basis so we can carry that forward
15:00:33 <asettle> AND THAT'S AL LWE HAVE TIME FOR FOLKS
15:00:36 <asettle> #endmeeting