14:00:05 <asettle> #startmeeting tc
14:00:06 <openstack> Meeting started Thu Oct 10 14:00:05 2019 UTC and is due to finish in 60 minutes.  The chair is asettle. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:07 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:09 <openstack> The meeting name has been set to 'tc'
14:00:18 <asettle> #topic roll call
14:00:21 <ricolin> o/
14:00:23 <asettle> o/
14:00:25 <jroll> \o
14:00:26 <njohnston> o/
14:00:26 <openstackgerrit> Merged openstack/governance master: New charm and interface for placement split  https://review.opendev.org/686253
14:00:30 <jungleboyj> o/
14:00:36 <asettle> tc-members - get your https://giphy.com/ ready
14:00:44 <diablo_rojo> o/
14:00:47 <asettle> Allowing for 3 minutes grace for all to arrive.
14:00:51 <dirk> o/
14:00:55 <asettle> Well, probs 2. We got shit to get through.
14:00:55 <ttx> o/
14:00:56 <mnaser> o/
14:01:15 <asettle> tc-members - agenda incoming
14:01:19 <asettle> #link https://wiki.openstack.org/wiki/Meetings/TechnicalCommittee
14:01:25 <asettle> For all those that don't have it open already
14:02:08 <asettle> Right
14:02:10 <asettle> Let's kick it
14:02:18 <asettle> Firstly, before we dive into the ageanda, going to address the elephant
14:02:19 <asettle> Me rn: https://giphy.com/gifs/animation-reaction-halloween-d0QrBg3r8qL0Q
14:02:33 <asettle> SUSE is no longer actively developing their OpenStack cloud offering
14:02:46 <jungleboyj> :-(
14:02:51 <asettle> evrardjp, and myself are SUSE employees, but we stand by the community and will continue to work in this capacity
14:03:07 <jungleboyj> asettle:  evrardjp  Thank you!
14:03:10 <asettle> We will both continue to be employed by SUSE, but in new roles. More confirmation of what that means at a later date.
14:03:12 <ricolin> hope it will not send any people away from community:(
14:03:25 * evrardjp lurks in the back
14:03:47 <asettle> SUSE employees are clearly still welcome in the community, and SUSE is still encouraging of their employees to stand by their open source values
14:04:06 <asettle> We will see more and more what this looks like for the community once the dust settles.
14:04:09 <asettle> Any questions before we move on?
14:04:15 <njohnston> Yes, I'm hoping that support for existing customers will mean that at least some staff that is OpenStack (and community) focused will be kept on that task
14:04:27 <evrardjp> correct njohnston
14:04:38 <njohnston> No questions, just best wishes and good luck!
14:04:39 <evrardjp> We still have an OpenStack team
14:04:43 <asettle> Absolutely. No new development, but no abandonment either.
14:04:49 <jungleboyj> njohnston:  ++
14:04:55 <evrardjp> njohnston: and thank you
14:05:20 <asettle> https://giphy.com/gifs/animation-reaction-halloween-d0QrBg3r8qL0Q
14:05:26 * diablo_rojo cant remeber if either of you were going to be in Shanghai
14:05:31 <asettle> Okay, let's dive in to business as usual.
14:05:35 <mnaser> asettle: won't but evrardjp will be afaik
14:05:37 <ricolin> evrardjp, and did they freeze the openstack team size?
14:05:39 <evrardjp> I will be
14:05:40 <asettle> I definitely am not. Anymore long haul travel and I'll shoot myself.
14:05:57 <diablo_rojo> evrardjp, okay got it :)
14:06:11 <asettle> ricolin, yes. It's been reduced to a small number from EMEA and the US
14:06:26 <diablo_rojo> asettle, I can understand the feeling, but I thankfully haven't gotten it before.
14:06:35 <zaneb> o/
14:06:44 <asettle> zaneb, way to walk in late mate jeez
14:06:45 <asettle> ;)
14:06:46 <asettle> OKAY
14:06:52 <asettle> #topic Follow up on past action items
14:07:02 <asettle> ricolin - Follow up with SIG chairs about guidelines
14:07:08 <asettle> #link https://etherpad.openstack.org/p/SIGs-guideline
14:07:27 <ricolin> Still need to target ttx's comment to separate optional and necessary part. Plan to do it the following days.
14:07:53 <ricolin> and possible one of topic for meta-sig in PTG I assume
14:08:10 <asettle> #action ttx to provide feedback for ricolin regarding SIG chairs guidelines
14:08:24 <asettle> Okay, thanks ricolin
14:08:25 <ricolin> more feedback are welcome:)
14:08:37 <asettle> ricolin, TC feedback?
14:08:50 <ricolin> yeah include all TCs for sure
14:09:06 <asettle> Thanks ricolin - tc-members please review the above doc if you haven't already
14:09:11 <jungleboyj> Sounds good.  Will take a look.
14:09:12 <asettle> Moving swiftly onwards.
14:09:17 <njohnston> ack
14:09:25 <asettle> ttx - contact interested parties in a new 'large scale' sig (help with mnaser, jroll reaching out to verizon media)
14:09:25 <ricolin> thanks jungleboyj njohnston
14:09:34 <jungleboyj> :-)
14:09:44 <mnaser> i think that's largely been quiet, verizon mentioned it was a "not now" at teh time
14:09:52 <ricolin> And we have a forum for large scale SIG
14:09:53 <mnaser> and there is a scheduled (i think) forum session around this
14:09:54 <mnaser> ^
14:10:01 <ricolin> #link https://www.openstack.org/summit/shanghai-2019/summit-schedule/events/24405/facilitating-running-openstack-at-scale-join-the-large-scale-sig
14:10:16 <jroll> yep
14:10:24 <asettle> mnaser, backlog item then or shall we bring this up again next month?
14:10:42 <mnaser> i think we should follow up on this post summit aka next month
14:10:56 <ricolin> I think we should plan to invite large scale user to join that Forum too (who might be new in community). Like Line, Blizzard, etc.
14:11:19 <asettle> Something we can do at short notice?
14:11:25 <ricolin> yes
14:11:33 <mugsie> is there going to be people from those orgs at shanghi?
14:11:40 <ricolin> that will be nice for large scale user I think?
14:11:40 <mnaser> ^ that's the thing to know
14:11:42 <asettle> ^ that
14:11:48 <asettle> lol
14:11:59 <ricolin> mugsie, yes
14:11:59 <mugsie> I get the feeling not many tech people from them are going
14:12:10 <asettle> ricolin, is that an action item you can take on? Figure out who is going, and who we can invite?
14:12:16 <ricolin> yes
14:12:33 <ricolin> asettle, make it a action, and I will make sure it's taking cared
14:12:35 <asettle> #action ricolin to figure out who from the large scale user groups are going to Shanghai and invite them to forum
14:12:37 <asettle> Thank you ricolin
14:12:46 <asettle> Anything further on this topic?
14:13:01 <mnaser> i think that's all
14:13:02 <asettle> Fabulous.
14:13:08 <asettle> Now, for the other most wonderful topic in the world
14:13:09 <asettle> https://media.giphy.com/media/EckH9c8kzRLGg/giphy.gif
14:13:19 <asettle> Release Naming - Results of the TC poll - Next action
14:13:26 <diablo_rojo> Heh
14:13:28 <jroll> oh boy
14:13:32 <asettle> This is relatively vague, since it doesn't accompany an action item
14:13:34 <asettle> Just another "let's do the thing"
14:13:38 <jungleboyj> He he.
14:13:40 <asettle> Whereas I think most of us would like to put our heads in the sand.
14:13:50 <corvus> o/
14:13:55 <gmann> o/
14:14:00 <asettle> You say naming and corvus appears, it's like a fun trick
14:14:11 <gmann> sorry for late
14:14:13 <asettle> Summary: we have naming for V - Z. Not after, correct?
14:14:14 <diablo_rojo> ...V release..in Vancouver..
14:14:20 <asettle> It's okay gmann we'll probably just never forgive you but it's fine
14:14:21 <ttx> sorry missed the question above, multiplexing
14:14:31 <asettle> ttx, all good, we're onto the next item.
14:14:34 <asettle> We've got a lot to get through.
14:14:35 <jungleboyj> V works out nicely.
14:14:44 <asettle> So, great, we've got V-Z. What's our grand plans for after?
14:14:45 <ttx> but yes I'm going to reach out to people for large scale SIG, based on registration data
14:14:52 <njohnston> So there are now two additional proposals, to name after movie quotes or to name based on cities over a given population threshold but not tied to the summit location.  Both stipulate V is for Vancouver.
14:14:54 <corvus> sorry i missed, what's the plan for v-z?
14:14:58 <ricolin> One thing I'm curious, do we need a PTG session for Release Naming?
14:15:05 <ttx> We don;t have a plan for V-Z
14:15:06 <ricolin> ttx thank
14:15:07 <mugsie> I hope not
14:15:20 <diablo_rojo> W,X,Y,Z are going to be a delight I'm sure.
14:15:28 <diablo_rojo> ricolin, I really hope not.
14:15:30 <asettle> We don't have a plan? Frick. Missed that. mugsie you performed a condorcet poll and there was a tie? We were unable to sort that out?
14:15:31 <ttx> asettle: summary is...
14:15:39 <asettle> I don' think it's appropriate to be accepting anymore suggestions at this stage.
14:15:46 <jungleboyj> asettle:  ++
14:15:48 <ttx> None of the options proposed beat the "keep it the same" in the last round
14:15:49 <mugsie> basically no one dislikes the current system enough to change it
14:15:56 <diablo_rojo> asettle, agreed, don't need more options
14:16:07 <ttx> We have two new proposals, which might beat "keep things the same"
14:16:07 <asettle> For once, the community is not actually picking ridiculous sides.
14:16:29 <zaneb> we don't have a plan that's different from the status quo
14:16:34 * mnaser would like to hear from corvus for starters given he brought this subject up
14:16:35 <asettle> ttx, it's past that stage though. We fairly opened the floor for everyone to come up with new ideas, and that time has ended. Sorry to be the cut throat one here, but we have done that. That's over. We couldn't agree.
14:16:36 <ricolin> I mean we have a tie from poll let's re open a poll with only those two opions?
14:16:39 <mnaser> unless this is ~the tc~ meeting only
14:16:40 <ttx> asettle: the issue is.. if nothing that is already proposed can beat "keep thinsg the same" it means we should keep things the same
14:16:55 <corvus> i feel like there are a substantial number of folks on the tc who acknowledge the problems, and supportchanging the process, but we haven't come to a consensus on how.  how can we move forward?
14:17:12 <ttx> I see no reason why we can't continue to propose options
14:17:13 <zaneb> ricolin: how will that help?
14:17:15 <corvus> was the condorcet poll structured in a way to do that, or do we need it structured a little differently?
14:17:16 <ttx> We have two already proposed
14:17:27 <corvus> i heard there was some confusion
14:17:47 <mnaser> i think we're at like 2 polls? one with the old rosters and one with the new?
14:17:54 <asettle> ttx, because it will create a snowball effect. If we continuously say "yeah come with your ideas" we're never going to make a decision.
14:18:04 <asettle> People are going to have dreams and come up with ideas the next day, just when we thin kwe're going to get this sorted.
14:18:05 <ttx> corvus: we had one poll to select the two best options, than one to compare those two with "keep things the same"... and none came out on top
14:18:07 <asettle> We need to have a deadline.
14:18:23 <ricolin> zaneb, just assume we need to have a way to move forward instead of take all the options but no decision out
14:18:38 <ttx> asettle: I disagree. As long as we keep things the same, we can propose changes
14:18:55 <mnaser> i agree with ttx
14:18:57 <diablo_rojo> If we do allow for more ideas, we need a hard date that they need to be submitted by.
14:19:08 <jungleboyj> Just to be totally clear, we have V taken care of.  Correct?
14:19:11 <corvus> there are a number of problems with the current system, among them: alienating contributors, cultural issues with host countries, cost in resources and time to run the process, and potential disconnect with future summit schedule.
14:19:13 <asettle> Just V, yep.
14:19:13 <ttx> Current status is: we keep things the same, none of the proposed options beats "keep things the same"
14:19:21 <corvus> is keeping the status quo really okay?  i don't think it is.
14:19:28 <ttx> I strongly think we need to alter the system
14:19:30 <gmann> jungleboyj: not yet
14:19:32 <zaneb> I don't agree that we have V taken care of
14:19:38 <ttx> so I'll continue to propose changes until one wins :)
14:19:41 <mnaser> i agree with ttx on that too, especially with the recent osf announcement regarding events.
14:19:45 <jungleboyj> Ok.  Glad I asked.
14:19:48 <zaneb> I think we *should* take care of V using the existing process though
14:19:49 <ttx> V is not taken care of at all
14:20:03 <ricolin> jungleboyj, some propose just go with Vancouver but nothing is decided
14:20:07 <gmann> zaneb: +1
14:20:08 <ttx> We have two proposed options that do take care of V, then V-Z, then A-Z
14:20:09 <mnaser> in a few weeks we're going to be in a "oops, we don't have 2 summits a year, what now?"
14:20:17 <ttx> mnaser: exactly
14:20:36 <mnaser> so lets just get that over with now and fix the system starting now because waiting until Z is not right
14:20:45 <ttx> The two options currently proposed indeed say "for V, let's say Vancouver"
14:20:55 <ttx> but others might be proposed
14:21:14 <asettle> Okay tc-members , I think we're going to need a significant slice of time to discuss next steps. I propose the following: An announcement that we are continuing to accept proposals as we are  currently "staying the same". That the TC does not wish to continue with the same process, but we won't accept just "anythiNg", we want "better".
14:21:15 <fungi> also having to wait until event locations are announced means we end up making a lot of compromises in other places to account for the fact that we don't yet have enough information to select a cycle name
14:21:28 <ttx> asettle: personally I think we should vote on those, and if one ever gets 7 votes for, it should be accepted
14:21:42 <ttx> just make sure your vote reflects that
14:21:44 <asettle> ttx, would you like to take the action item of communicating this post-meeting?
14:21:47 <njohnston> I agree with ttx
14:22:08 <ttx> Don;t vote +1 on one that you prefer "keep it the same" over it
14:22:13 <fungi> the reason an election official ended up being the one to push on the u cycle name was that we needed to start setting up the schedule for related elections
14:22:14 <ttx> I'm happy to summarize the situation
14:22:15 <jungleboyj> asettle: ttx We need to set a cut off date for making proposals then.
14:22:17 <zaneb> yes, I think that now we have narrowed down the field, the regular voting rules are sufficient to handle it
14:22:25 <ttx> jungleboyj: why?
14:22:36 <ttx> jungleboyj: we can change it again in the future
14:22:41 <mnaser> ^^^
14:22:43 <ttx> I'll just vote no
14:22:48 <mnaser> yeah its not like this is something set hard in stone
14:22:53 <asettle> #action ttx to summarise current situation with release naming and steps TC would like to take further.
14:22:53 <ttx> but I don;t see why we should decide for all times
14:23:09 <asettle> Personally I disagree, but I think we can take this conversation to a ML so we have a wider audience.
14:23:15 <corvus> ttx: sounds good, thanks :)
14:23:17 <ttx> I'll definitely only vote for things that project for the next A-Z
14:23:20 <asettle> We need to move on with this meeting.
14:23:21 <jungleboyj> asettle:  ++
14:23:31 <asettle> Thank you ttx
14:23:34 <ttx> corvus: you might want to alter your proposals so that they cover "any foreseeable future"
14:23:37 <jungleboyj> I feel like we are going to just make it more complicated, but we can see what the community says.
14:23:40 <corvus> ttx: will do
14:23:43 <asettle> #topic New initiatives and/or report on previous initiatives
14:23:46 <mugsie> jungleboyj: ++
14:23:50 <asettle> Help gmann on the community goals following our new goal process.
14:23:58 <asettle> It includes 1. Ussuri goal proposals update 2. Plan for V cycle goal discussion 3. One more TC member to Volunteer
14:24:14 <gmann> 1. Ussuri goal proposals update
14:24:27 <gmann> we already started collecting the ideas for U cycle goal
14:24:29 <gmann> #link https://etherpad.openstack.org/p/PVG-u-series-goals
14:24:40 <asettle> Fantastic
14:24:44 <gmann> and we have 3 proposal till now which is good number
14:24:52 <asettle> That is good.
14:25:12 <gmann> we can wait for more or as next step we can ask author to start drafting the goal deyails as per our new process
14:25:14 <asettle> Pleased to hear we're getting tracking there
14:25:15 <gmann> details
14:25:17 <asettle> traction*
14:25:47 <gmann> and once we have details up then we do our regular review
14:26:00 <diablo_rojo> I can probably help gmann
14:26:06 <asettle> gmann, need anything from tc-members?
14:26:18 <gmann> diablo_rojo: thanks. that is 3rd point and really appreciated
14:26:23 <gmann> 2. Plan for V cycle goal discussion
14:26:33 * diablo_rojo apologizes for jumping ahead
14:26:40 <asettle> ;)
14:27:21 <gmann> forum sessions for V cycle goal discussion is not selected. so we have two options either merge the V goal discussion with U cycle goal sessions or leave the V cycle goal discussions or kickoff on ML
14:27:58 <ricolin> we can moave kickoff it on ML and use PTG for it?
14:27:59 <gmann> U cycle goal sessions is more of discussing the implementation details of u cycle goals
14:28:11 <ricolin> *moave/maybe
14:28:35 <ricolin> gmann, yeah, totally agree
14:28:38 <gmann> ricolin: PTG would not be suitable as it need more audience than just TC. i am afraid many will be busy in their project PTG
14:29:24 <jungleboyj> gmann:  ++
14:29:33 <ricolin> gmann, PTG just sounds like the best second option IMO
14:29:37 <gmann> NOTE- next summit of f2f conference will be in V release cycle not before that so we need this to start before V cycle start
14:30:13 <asettle> gmann, perhaps it seems reasonable to merge? jroll and I were at the forum selection meeting and there was discussion of providing more time for a double slot
14:30:17 <asettle> So it could be split in half?
14:30:35 <ttx> gmann: how is that different from U ?
14:30:50 <njohnston> My concern is that V is far enough in the future that people are going to have a hard time concentrating on what the community needs will be at that point
14:30:57 <asettle> Good point
14:30:59 <ricolin> are we allow to change forum name to said U+V?
14:31:07 <ttx> I think we can have the V discussion asynchronously
14:31:20 <ttx> V is just too abstract to select V cycle goals now
14:31:28 <gmann> ok.
14:31:30 <jungleboyj> ttx:  Sounds reasonable.
14:31:40 <njohnston> ricolin: I think that is a more sensible idea, say U plus brainstorming for V, with the note that V goals will be formalized on the ML as we get closer.
14:31:42 <ttx> I mean, we can definitely look at the backlog
14:31:54 <diablo_rojo> Yeah I think things are a little early for V at this point.
14:31:55 <mugsie> s/can/should/ :P
14:32:02 <jungleboyj> njohnston:  ++
14:32:03 <ttx> but starting the selection process... probably not
14:32:22 <mnaser> i think if we've learned anything it's that goal selection process and discussion happening at forums is not the best thing to do
14:32:30 <mnaser> based on logistics, timing, etc.
14:32:43 <ricolin> Jump out a little. For V, I kind of hope we can have one for overall metering or arm support (there's a forum for arm), but assume we should create a popup team to investigate first. if anyone also interested with:)
14:33:10 <mnaser> i personally feel this fits much better than trying to stuff things into forums that happen way too early
14:33:13 <mugsie> ricolin: we have a process, we should use it
14:33:18 <gmann> but this time it will be implementation details of new proposed sessions and selection we will leave for later
14:33:34 <asettle> gmann - I think we're going to have to take this to the ML so we have a proper discussion on the best next steps seeing as we are not in agreement here.
14:33:35 <ricolin> mugsie, those two idea just come out of me:)
14:33:41 <mnaser> (maybe we should play around the idea of having scheduled online conferences or meetings or something to have those "forum" sessions during a cycle)
14:33:42 <asettle> Could I put you down for an action item to compelte that, gmann ?
14:33:49 <asettle> complete*
14:33:59 <gmann> sure
14:34:31 <diablo_rojo> gmann, we can sync post meeting and get on the same page/you can tell me what you need help with :)
14:34:41 <asettle> Thank you gmann
14:34:51 <gmann> diablo_rojo: sure. I will sync up on that
14:34:56 <asettle> #action gmann to email ML regarding U and V cycle forum collaboration (otherwise)
14:35:00 <gmann> that's all from my side on goal
14:35:02 <asettle> #action diablo_rojo to help gmann with forum selection
14:35:03 <asettle> Thank you gmann
14:35:05 <asettle> moving right along
14:35:12 <asettle> mugsie - to sync with dhellmann or release-team to find the code for the proposal bot
14:35:15 <asettle> UPdates?
14:35:42 <mugsie> I belive evrardjp jumped the gun, and did the thing :)
14:35:45 <fungi> i believe i pasted the link to it in here a month ago in the last meeting
14:35:59 <asettle> Fabulous, I'll scribble that one out. I was not in the last meeting :)
14:36:09 <asettle> jroll - ttx  Feedback from the forum selection committee
14:36:11 <smcginnis> mugsie: For the cycle job updates?
14:36:15 <asettle> Follow up on https://etherpad.openstack.org/p/PVG-TC-brainstorming
14:36:15 <ttx> ohai
14:36:16 <mugsie> yeah
14:36:20 <asettle> #link https://etherpad.openstack.org/p/PVG-TC-brainstorming
14:36:24 <asettle> Final accepted list?
14:36:26 <ttx> So I was not on the selection committee, but the results are in
14:36:34 <asettle> Yah it was me and jroll - dunno why your name was there :P
14:36:43 <jroll> I gave an update on the ML on this, and the etherpad has which were accepted as well
14:36:45 <ttx> (shows as "accepted" in the etherpad)
14:36:49 <asettle> Fabulous jroll :)
14:36:56 <asettle> Any questions team before I move on from that one?
14:37:03 <ttx> maybe the selection committee can explain the rationale for picking / not accepting sessions there :)
14:37:10 <jroll> I think evrardjp suggested discussing what to do about the not accepted selections
14:37:18 <asettle> sure, jroll ?
14:37:30 <ttx> Like the PTl tip and tricks session... should we plan time to cover that in PTG?
14:37:45 <jroll> yeah, so the committee agreed the PTL thing might be better for the PTG
14:37:56 <jroll> as we'd have more current and prospective PTLs there
14:38:04 <asettle> Yes, more targetted to the right audience.
14:38:09 <ttx> fair.. maybe open the TC session with that on Friday?
14:38:21 <ttx> so that PTLs can all go elsewhere after that?
14:38:24 <jungleboyj> ttx:  ++
14:38:34 <ttx> "elsewhere" meaning in the same room at another table
14:38:42 <jroll> seems reasonable
14:38:58 <jroll> the other rejected submission was the V goals - we put that off to make room for more project team sessions, IIRC.
14:39:05 <ttx> ack
14:39:50 <asettle> Correct from my memory too. We tried our best to have a decent variation of items, and combine things that were combinable. IE: Cinder's sessions
14:40:08 <asettle> By combining more similar topics, we could open the floor for other items that haven't come up before
14:40:26 <gmann> +1
14:40:36 * mnaser maybe thinks we should spill this over to office hours
14:40:45 <asettle> mnaser, completely agree.
14:40:51 <asettle> Any more questions about the forum selection, afterwards please
14:40:54 <asettle> Moving on
14:40:59 <ricolin> overall forum looks great to me #link https://www.openstack.org/summit/shanghai-2019/summit-schedule#track_groups=90
14:41:03 <asettle> #topic addendums
14:41:10 <ricolin> thanks asettle jroll
14:41:13 <ttx> Also in case you missed it... jroll and I archived all non-official repos from the GitHub "openstack" org
14:41:14 <asettle> I don't know who added this, or what it's supposed to be for buhhhtttt
14:41:23 <asettle> "define goal select process schedule"
14:41:27 <asettle> This is different discussion to select goals. We need to make sure we can have a schedule for cycles to follow. So we know when exactly to ask for goal idea, ask for champion, start +1 cycle goal select process, and start +2 cycle select process.
14:41:36 <asettle> Thank you ttx :)
14:41:46 <ricolin> asettle,  we still have one for `mnaser: sync up with swift team on python3 migration` ?
14:41:53 <asettle> Oh shit!
14:41:54 <asettle> I'm so sorry mnaser
14:41:58 <ttx> We'll continue curating that GitHub content, stay tuned
14:42:00 <ricolin> I mean before addendums:)
14:42:11 <mnaser> its fine, i think we mentioned last time that we're all good
14:42:14 * ttx addendumed
14:42:17 <asettle> mnaser, nothing to add?
14:42:21 <mnaser> we can remove it at this point
14:42:26 <asettle> Okay, thanks mnaser :) sorry for skipping!
14:42:32 <asettle> Derpy brain
14:42:36 <asettle> I blame birthday
14:42:43 <ttx> there is a gif for that
14:42:46 <jungleboyj> Birthday brain!
14:43:07 <asettle> Okay, so, roll back to the "define goal select process schedule"
14:43:25 <ttx> https://gph.is/1QpzoFx
14:43:37 <asettle> ttx, me this morning
14:43:40 <diablo_rojo> LOL
14:43:49 <ricolin> My idea just like what I put on
14:43:49 <ricolin> We need to make sure we can have a schedule for cycles to follow. So we know when exactly to ask for goal idea, ask for champion, start +1 cycle goal select process, and start +2 cycle select process.
14:43:53 <gmann> I do not know who added but this seems good proposal to me, if we have proper schedule ready for goals it will be easy for TC to execute the new goal process and with current summit schedule.
14:43:59 <jungleboyj> OMG
14:44:01 <asettle> ricolin, is this yours?
14:44:12 <ricolin> 'define goal select process schedule'
14:44:15 <asettle> Ye
14:44:21 <diablo_rojo> Seems like a good idea to me.
14:44:28 <ricolin> I put that on but everyone can jump in:)
14:44:32 <diablo_rojo> Certainly helps with running elections and gathering forum submissions
14:44:40 <asettle> I agree. Anyone want to work together with ricolin to define this properly?
14:44:41 <njohnston> I agree, it sounds sensible.
14:44:49 <ricolin> IMO we should make this a real schedule so we can have more time to investigate into goals.
14:44:49 <ricolin> The schedule should not block any new goal idea to join but will give us a chance to make sure the goals we already have are on schedule.
14:44:50 <gmann> as per history "GuanYu, lin "
14:44:50 <diablo_rojo> Those examples of schedules might be good to look at for guidance.
14:45:03 <ricolin> gmann, that's me:)
14:45:08 <asettle> tc-members - anyone to work with ricolin on this? :)
14:45:11 <gmann> ricolin: ohk :)
14:45:13 <asettle> I'll action you in
14:45:14 <jungleboyj> Sounds like a good idea.
14:45:20 <gmann> i can help ricolin
14:45:20 <diablo_rojo> ricolin, I could probably help given my experience with elections and whatnot
14:45:25 <ricolin> thanks gmann
14:45:28 <asettle> #action gmann and ricolin to work on defining goal selection process schedule
14:45:29 <asettle> THANKS FAM
14:45:32 <ricolin> diablo_rojo, tnaks!
14:45:37 <ricolin> *thanks!
14:45:46 <asettle> Alright I saw this one in the chan yesterday I think
14:45:47 <asettle> Maintain issue with Telemetery
14:45:51 <asettle> Who put this one up? ricolin ?
14:45:55 <ricolin> all me:)
14:45:59 * diablo_rojo now makes promise to herself to stop volunteering for things
14:46:05 <ricolin> I mean
14:46:09 <ricolin> ttx got some report on the lack of maintain for telemetry project
14:46:17 <ricolin> Also there's a unsync issue between Aodh and Gnocchi
14:46:21 <ricolin> #link http://lists.openstack.org/pipermail/openstack-discuss/2019-August/008541.html
14:46:33 <asettle> Appreciated, thanks for the TL;DR
14:46:44 <asettle> What can we do, ricolin ?
14:46:48 <mnaser> tbh its probably time to sunset telemetry
14:47:06 <mnaser> and start working with other communities on things that have become a much stronger standard of metrics collection (say: prometheus and co)
14:47:18 <ricolin> I invited zhurong to join but assume he didn't received my message
14:47:20 <asettle> Have we got another thread going with this topic?/
14:47:24 <asettle> ML thread, that is
14:47:26 <jungleboyj> mnaser:  That isn't a bad idea.
14:47:29 <ricolin> mnaser, agree
14:47:32 <njohnston> I wonder if we are at a point where we should start on a Telemetry v2.
14:47:41 <jungleboyj> Leverage the technologies that are out there.
14:47:45 <mnaser> why re-invent the wheel when there is a huge thriving ecosystem that's good at that
14:47:53 <jungleboyj> mnaser:  ++
14:47:56 <zaneb> every time we try to sunset it somebody pops out of the woodwork to say they'll keep it alive because they rely on it
14:48:07 <asettle> Totally. mnaser - possible you could start the ML thread on this one? Get the ball rolling for community discussion?
14:48:13 <njohnston> mnaser: Yes, include prometheus, but we can still make use of gnocchi as a storage option (although I know some people that would opt for influxdb instead)
14:48:23 <mnaser> oh man
14:48:24 <jungleboyj> I spoke with one of the architects at Elastic the other day and they would love to have help from the community.
14:48:32 <mnaser> why do i get the fun ones "hey lets rm -rfv telemetry
14:48:36 <asettle> mnaser, that "oh man" is "oh yes" right? ;)
14:48:37 <asettle> HAHA
14:48:40 <asettle> Cause you're fearless?
14:48:44 <ricolin> not just what tools we can use but to update current resource around community
14:48:49 <mugsie> there are people out there who use prometheous, telegraf etc with gnochi
14:49:00 <asettle> mnaser, we can sync up and write it together?
14:49:01 <ricolin> like I think heat already have some broken template to fix
14:49:13 <mnaser> given gnocchi isnt even openstack, i wouldnt even "encourage" to use it
14:49:22 <mnaser> there are very good solutions out there, things like thanos/etc
14:49:28 <fungi> njohnston: i think that suggestion relies on someone taking over gnocchi. aiui, that's now also basically unmaintained
14:49:37 <mnaser> asettle: i can write it now and send it and then mute the thread and hide all summit
14:49:37 <mnaser> :D
14:49:43 <njohnston> fungi: oh, that's a shame.  I had not heard.
14:49:47 <mugsie> i will say, I know there is a lot of telco tools that have been build on aodh and celiometer
14:49:50 <asettle> #action mnaser (and asettle) to start ML thread reading Telemetry issue(s)
14:49:53 <asettle> Perfect, mnaser ;)
14:49:54 <gmann> also this sounds good proposal for the PTG discussions with telemetry team + users if any there
14:50:02 <mugsie> and they *will* freak out if it goes away
14:50:03 <gmann> after ML thread
14:50:04 <asettle> I'll put myself down on the action item so we have two points of contact
14:50:13 <zaneb> let's just be clear that monitoring can mean two different things: monitoring the openstack services and monitoring the user workloads
14:50:13 <asettle> gmann, good call. Could you put that on our etherpad?
14:50:13 <ricolin> I will update zhurong with all the discussion so he won't missed it
14:50:23 <mugsie> zaneb: ++
14:50:25 <gmann> sure
14:50:26 <asettle> ricolin, thank you. A kind warning will no doubt be appreciated.
14:50:28 <asettle> Thank you gmann
14:50:38 <asettle> Okay, let's jump into the last topic which will need the last 10 minutes
14:50:46 <asettle> Overall review for TC summit and PTG plans
14:50:47 <zaneb> at this point it would be crazy *not* to use prometheus for the former, but it is faaar from a drop-in replacement for Telemetry (or Monasca) for the latter
14:51:01 <asettle> #link https://etherpad.openstack.org/p/PVG-TC-PTG
14:51:05 <asettle> Current Shanghai PTG planning page
14:51:16 <asettle> Has everyone looked at this?
14:51:24 <gmann> thanks asettle for link, i was searching that
14:51:27 <ricolin> The forum session is settled but PTG is not:(
14:51:28 <asettle> Heh no worries :D
14:51:43 <asettle> ricolin, indeed.
14:52:02 <jroll> mnaser: I'm late, but gnocchi isn't maintained anymore, agree we shouldn't recommend it
14:52:37 <ricolin> do we need a deadline for PTG session proposal?
14:52:42 <asettle> tc-members - how do we feel about thsee suggestions? I think... yes perfect ricolin
14:52:59 <ricolin> jroll, also there's Aodh not sync with Gnocchi issue
14:53:07 <mnaser> i think someone should find the one from last time in denver
14:53:13 <gmann> +1. deadline and we can use office hours to discuss the details/selection
14:53:17 <asettle> mnaser, the etherpad?
14:53:17 <mnaser> and see what were good topics we can bring out here
14:53:19 <gmann> or schedule
14:53:20 <mnaser> yeah
14:53:34 <mnaser> and also, what about the board meeting presentation? what's happening with that?
14:53:35 <jungleboyj> mnaser:  ++
14:53:58 <ricolin> maybe oct 17 so we might have two weeks for prepare?
14:54:07 <asettle> mnaser, have you synced up with evrardjp to make him aware of what needs to be done there?
14:54:30 <asettle> ricolin, that seems like a reasonable date
14:54:33 <ricolin> I will sync with evrardjp to make sure  board meeting presentation will start early
14:54:53 <mnaser> is there anything in specific needed? there isn't soemthing in specific that you needto be aware of per say
14:54:53 <asettle> ricolin, great, thank you :)
14:55:02 <mnaser> working together on our messaging to the board is important
14:55:12 <asettle> mnaser, that's good to know. He's not here, so just figured if there was any knowledge to impart, that would be helpful
14:55:19 <ricolin> since he's back around 23th, I will start prepare for it
14:55:32 <mnaser> nah, no secret sauce, nothing that dhellmann or ttx gave me anyways :)
14:55:38 <asettle> #action ricolin and evrardjp to sync up and work on board meeting presentation
14:55:44 <asettle> mnaser, cool :D (might include that in one of the docs)
14:55:49 <ricolin> mnaser, :)
14:56:06 <ricolin> also TC dinner for summit:)
14:56:13 <asettle> #action all tc-members to add topics to the PTG planning etherpad before Oct 17: https://etherpad.openstack.org/p/PVG-TC-PTG
14:56:21 <asettle> Who organised the TC dinner for Denver? was that you, mnaser ?
14:56:27 <diablo_rojo> ricolin, lol the important things ;)
14:56:33 <ricolin> diablo_rojo, yeah!
14:56:34 <ttx> that was me I think
14:56:35 <gmann> we do not have TC user feedback topic for this meeting ? or it was for later..
14:56:36 <mnaser> i dont think that was me because if it was me we'd all be having happy meals at the mcdonalds
14:56:47 * diablo_rojo votes ttx organizes dinner
14:56:48 <gmann> :)
14:56:51 <ttx> it's a thing I do
14:56:55 <diablo_rojo> ttx has good taste :)
14:57:00 <asettle> #action ttx to organise Shanghai TC dinner
14:57:02 <asettle> ;)
14:57:03 <jungleboyj> gmann:  I can provide an update.
14:57:11 <asettle> gmann, it's not on the agenda, but we have 3 minutes
14:57:17 <gmann> ohk
14:57:18 <asettle> Or, perhaps we can wait until the meeting closes
14:57:19 <diablo_rojo> ttx, should go to that ultraviolet place that mordred has a reservation at ;)
14:57:25 <jungleboyj> asettle:  Either way.
14:57:25 <ricolin> ttx I can help you one dinner plan if you needed
14:57:26 <openstackgerrit> Merged openstack/election master: Re-Add Kendall as Election Official  https://review.opendev.org/687646
14:57:27 <asettle> jungleboyj, could you provide in office hours after this?
14:57:27 <openstackgerrit> James E. Blair proposed openstack/governance master: Name releases after major cities  https://review.opendev.org/677745
14:57:36 <ttx> who is going? Everyone but asettle and jroll?
14:57:36 <ricolin> *one/on
14:57:43 <jungleboyj> asettle:  Yep.
14:57:44 <mnaser> ttx: and njohnston isnt either
14:57:48 <asettle> ttx, njohnston isn't going either
14:57:50 <asettle> JINX
14:57:51 <mnaser> cloudnull-afk: is an unknown afaik
14:58:14 <ttx> mugsie?
14:58:14 <asettle> Does anyone have any questions or concerns about the PTG they'd like to voice in the last few minutes?
14:58:14 <mugsie> I am still waiting for a visa, but I should be fine
14:58:17 <ttx> ok
14:58:27 <ttx> Will keep track of that
14:58:31 <asettle> tc-members - if everyone could stick around for office hours afterwards, jungleboyj will provide us with TC user survey feedback.
14:58:34 <jungleboyj> asettle:  No coffee in the meeting rooms.  That is a concern.  ;-)
14:58:39 <asettle> jungleboyj, NOTED
14:58:45 <mnaser> prepare to drink hot water
14:58:46 <mnaser> everywhere
14:58:54 <ricolin> mugsie, is there expected day for the visa result?
14:59:05 * mnaser would stash cold water bottles in their fridge all the time
14:59:11 <asettle> Good tip!
14:59:18 <asettle> #action all TC members to drink plenty of water in Shanghai
14:59:20 <ricolin> sparking water please:)
14:59:23 <jungleboyj> mnaser:  Thanks for the heads up.
14:59:25 <asettle> (that'll confuse the frick out of JP next month)
14:59:28 <mnaser> get 2 in my day every room, put both in my fridge lol
14:59:29 <diablo_rojo> I literally laughed out loud when I heard that rule from the venue.
14:59:30 <mugsie> ricolin: 22/10 apparently :?
14:59:40 <diablo_rojo> And then cringed when I thought about telling the community about it.
14:59:47 <asettle> Alright, any last words?
14:59:48 <jungleboyj> diablo_rojo:  Yeah ...
14:59:55 <ricolin> asettle, I have one
14:59:58 <jungleboyj> Welcome to China.
15:00:00 <asettle> ricolin, go you've got like 30 seconds :p
15:00:09 <ricolin> asettle, Happy Birthday:)
15:00:10 <asettle> Okay it was more like 2 seconds
15:00:11 <gmann> :) fast ricolin
15:00:13 <asettle> AWWW THANKS ricolin :D
15:00:14 <diablo_rojo> Dawwwwwww
15:00:18 <gmann> wow
15:00:21 <njohnston> happy birthdday asettle https://media.giphy.com/media/l2QZZMUmvtFYYBUWY/giphy.gif
15:00:21 <asettle> <3
15:00:29 <ricolin> :)
15:00:33 <gmann> Very happy birthday asettle
15:00:37 <openstackgerrit> Frode Nordahl proposed openstack/governance master: Add ``charm-neutron-api-plugin-ovn`` charm  https://review.opendev.org/687926
15:00:39 <ricolin> woohoo!
15:00:41 <asettle> Thanks all :D
15:00:46 <asettle> Alright, closing out: https://media.giphy.com/media/Xj1GHC7mXPquY/giphy.gif
15:00:48 <diablo_rojo> https://media2.giphy.com/media/26FPpSuhgHvYo9Kyk/giphy.gif?cid=790b7611a6c01be57d056919ec328c807c1dac2b2b7935c9&rid=giphy.gif
15:00:49 <mnaser> happy birfday
15:00:50 <jungleboyj> Happy birthday again.
15:01:04 <asettle> #endmeeting