14:00:04 <evrardjp> #startmeeting tc
14:00:05 <openstack> Meeting started Thu Jan 16 14:00:04 2020 UTC and is due to finish in 60 minutes.  The chair is evrardjp. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:07 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:10 <openstack> The meeting name has been set to 'tc'
14:00:14 <njohnston> o/
14:00:16 <evrardjp> #topic rollcall
14:00:35 <mnaser> o/
14:00:53 <jungleboyj> O/
14:00:54 <ttx> o/
14:01:02 <ricolin> o/
14:01:10 <evrardjp> o/
14:01:26 <evrardjp> one more and we have quorum
14:01:37 <evrardjp> jroll: still there? :)
14:01:39 <gmann> o/
14:01:41 <evrardjp> woot
14:01:45 <evrardjp> we have quorum
14:01:57 <njohnston> o/
14:02:07 <evrardjp> let's start!
14:02:11 <evrardjp> #topic Report on large scale sig
14:02:18 <evrardjp> #link https://media.giphy.com/media/FlOHnTIv1mj2U/giphy.gif
14:02:27 <evrardjp> ttx: how does this fly and how/what are the action items?
14:02:50 <jroll> \o
14:03:07 <ttx> I post regular updates on the ML about it, it's going well so far
14:03:43 <evrardjp> yup thanks about that
14:03:44 <ttx> Participants are motivated, they held a meeting this week while I could not chair it and the co-chairs stepped up
14:03:53 <evrardjp> great to hear!
14:04:13 <ttx> So yes, current signs are pretty positive, now to turn that into results :)
14:04:40 <evrardjp> If you don't mind let's keep that for next month, so we'll see if the momentum is still there?
14:05:01 <ttx> yes, sure. I'll post a summary of this week meeting later this week
14:05:09 <evrardjp> thanks!
14:05:36 <evrardjp> #action ttx post a summary of large scale sig's meeting on the ML this week
14:05:45 <evrardjp> #topic report about the vision reflection update, that should be started in January
14:06:05 <evrardjp> ttx, you want to say a few words?
14:07:19 <ttx> well the postortem on that was pretty short
14:07:39 <evrardjp> indeed, so I thought you might want to say a few words
14:07:43 <ttx> Like few really seemed to care or object to my summary
14:08:14 <ttx> TL;DR being: glad we did it, no value in doing another immediately again
14:08:25 <openstackgerrit> Merged openstack/governance master: Make mistral-dashboard a separate deliverable  https://review.opendev.org/700368
14:08:27 <openstackgerrit> Merged openstack/governance master: Reorder repos  https://review.opendev.org/701679
14:08:43 <ttx> I think it was useful to wrap it up with a ML post though
14:08:57 <evrardjp> I think too
14:08:59 <ttx> so if we wind down other things in the future it's definitely a good way to close
14:10:09 <evrardjp> #link http://lists.openstack.org/pipermail/openstack-discuss/2019-December/011566.html
14:10:20 <evrardjp> let's move on, shall we?
14:10:29 <evrardjp> #topic report on the analysis of the survey
14:10:38 <evrardjp> jungleboyj, a few words?
14:10:54 <jungleboyj> Hey.
14:11:12 <jungleboyj> So, a few people have reviewed what I put together.
14:11:23 <jungleboyj> #link https://review.opendev.org/#/c/698582/
14:11:30 <jungleboyj> Thanks to all who have given input.
14:11:50 <jungleboyj> It didn't look like there were strong objections to anything I said.
14:12:28 * asettle scrambles in the front door
14:12:29 <evrardjp> I guess that we are setting up a framework for the next iterations, do anyone think there is something missing?
14:12:39 <jungleboyj> zaneb:  Was hoping to have me do an analysis of users who said they used a project as compared to contribution.
14:12:52 <evrardjp> can people check on the review and comment there, if not done already?
14:13:06 <jungleboyj> I could do that analysis.
14:13:18 <evrardjp> I think it could be valuable
14:13:18 <gmann> i think after the % update for the users vs contributors. it will good data to publish somewhere to motivate more contribution from users. newsletter or ML ?
14:13:23 <jungleboyj> I think the other open question is where this document should go.
14:13:33 <evrardjp> gmann: maybe even collaborate with the board on this
14:13:40 <gmann> +1
14:13:41 <evrardjp> (after publication)
14:13:43 <jungleboyj> gmann: evrardjp ++
14:13:57 <jungleboyj> I think there is good information in there.
14:14:07 <zaneb> o/
14:14:14 <zaneb> forgot to put this in my calendar
14:14:24 <jungleboyj> :-)
14:14:46 <evrardjp> yeah I didn't send an ics or something, maybe I should if it's not on the usual day
14:14:49 <jungleboyj> So, are we thinking this would be an ML post or go to a blog or ...
14:15:09 <evrardjp> I am okay if we put this in goverannce. We can post the results in the ML afterwards.
14:15:24 <evrardjp> (pointing to governance)
14:15:31 <fungi> appendices to the project teams guide could be an option too
14:15:31 <evrardjp> or the other way around, I don't really mind.
14:15:42 <gmann> yeah, keeping in governance doc will be good to quickly refer and maintain history
14:15:53 <evrardjp> I think it's a governance topic, so I would prefer seeing it there
14:15:59 <jungleboyj> gmann:  ++ Ok.  I was hoping it was something we would hold on it.
14:17:15 <jungleboyj> So, I if anyone else has comments, please review.  I will make another draft next week.
14:17:23 <evrardjp> sounds good, thanks jungleboyj!
14:17:26 <jungleboyj> I will add the user data.
14:18:13 <evrardjp> Let's move on, and discuss this in the review
14:18:16 <evrardjp> #topic report on infra liaison and static hosting
14:18:17 <jungleboyj> If anyone has strong feelings about where the document should go, please add those in the review.
14:18:21 <jungleboyj> ++
14:18:30 <evrardjp> mnaser: any progress to report ?
14:19:13 <evrardjp> is it me, or is the meeting really silent, and boring? Where are all the lively things?
14:19:18 <mnaser> i haven't done much on that to be honest
14:19:35 <mnaser> i think andres put all the base infra
14:20:04 <mnaser> but i havent followed up with the rest, i'm planning to take a few cycles this weeekend to get through it
14:20:14 <evrardjp> ok -- It might impact the "ideas" project, so I will have to contact you back on this, and help if necessary.
14:20:22 <mnaser> sure, please do
14:20:33 <jungleboyj> https://gph.is/2mWzTNG
14:20:45 <evrardjp> jungleboyj: :)
14:21:06 <fungi> yeah, several changes for it merged yesterday
14:21:16 <fungi> (for the underlying hosting automation)
14:21:20 <mnaser> openstack/ideas might be a good poc for that, but yeah, i need to pick up the slack on that
14:21:32 <evrardjp> we can discuss that later in the ideas section if you like
14:21:53 <evrardjp> let's move on to another topic on which jungleboyj's gif applies too
14:21:55 <evrardjp> #topic report on stable branch policy work.
14:22:02 <evrardjp> #link https://media.giphy.com/media/XpYyhn0Gutfaw/giphy.gif
14:22:22 <evrardjp> mnaser, any extra since the email of smcginnis changing stable reviews from releases perspective? Is that enough? Is there more required? Should we revisit in a few months?
14:22:28 <jungleboyj> *Laughing*
14:22:51 <mnaser> i have a drafted change that i plan to push up on what we seem to have converged on the ML
14:22:59 <mnaser> or at least, what i think we did :)
14:23:17 <evrardjp> ok
14:23:44 <evrardjp> oh I forgot a few action items in the previous topic, my bad
14:24:09 <evrardjp> #action mnaser follow up on the static hosting
14:24:24 <evrardjp> #action jungleboyj update the survey report patch
14:24:51 <gmann> mnaser: +1. pushing that up for review will be good.
14:25:06 <evrardjp> #action mnaser push an update to distill what happened on the ML in terms of stable branch policy
14:25:25 <evrardjp> sorry for the mess there.
14:25:28 <njohnston> https://media.giphy.com/media/Kun1AbKVIWhRm/giphy.gif
14:25:53 <evrardjp> I suppose we can go ahead, and we'll wait for your update mnaser
14:25:58 <jungleboyj> njohnston:  We all have those days.
14:26:07 <evrardjp> jungleboyj: for me, it's today :p
14:26:13 <evrardjp> #topic report on the oslo metrics project
14:26:16 <jungleboyj> :-)
14:26:19 <evrardjp> mnaser jroll: has code appeared since last convo?
14:26:30 <mnaser> i think ttx had the ocmms with the individuals
14:26:34 <jroll> not that I have seen
14:26:35 <mnaser> and afaik none has, not that i know of
14:26:40 <evrardjp> #link https://media.giphy.com/media/12NUbkX6p4xOO4/giphy.gif
14:26:44 <ttx> checking for progress from last meeting logs
14:26:51 <zaneb> bnemec: o/
14:27:12 <evrardjp> zaneb: well thought :)
14:27:53 <ttx> so... spec is coming up, a bit delayed since the author had to deal with an outage in January
14:27:57 <ricolin> ttx large scale SIG will help on tracking one oslo.metrics?
14:28:46 <ttx> we large scale SIG are waiting for the first draft of that spec (from masahito @ LINE) before refining it
14:29:13 <ttx> hopefully more to tell by end of month
14:29:22 <evrardjp> ok I will keep for the next month then
14:29:31 <ttx> yes please
14:29:55 <evrardjp> ok moving on
14:30:00 <ricolin> ttx that's great
14:30:16 <evrardjp> #topic report on the community goals for U and V, py2 drop, and goal select process schedule
14:30:42 <evrardjp> gmann: you want to say a few words? I saw patches updated very recently and things merging, so that's good! :)
14:30:51 <gmann> Goals for U: This is latest and final update on selection of Ussuri cycle goals #link http://lists.openstack.org/pipermail/openstack-discuss/2020-January/012019.html
14:31:01 <gmann> we have both goals ready now #link https://governance.openstack.org/tc/goals/selected/ussuri/index.html
14:31:02 <evrardjp> thanks again for tackling this gmann. It's very hard work.
14:31:13 <ttx> ++
14:31:26 <jungleboyj> ++
14:31:35 <gmann> V cycle goals: zuulv3 goal is updated by tosky. #link https://review.opendev.org/#/c/691278/
14:32:06 <gmann> its lgtm, ready for review from other members.
14:32:15 <evrardjp> Do you need any support outside the reviews?
14:32:33 <gmann> support for implementation ?
14:33:02 <evrardjp> anything you think it's good to spread the word
14:33:41 <gmann> tosky is champion to this goal, i would leave the planning and implementation part to him once we select it for V. and yes we can help him for sure.
14:33:53 <njohnston> Neutron stadium is already close to done with the zuulv3 migration, we have been doing it in tandem with the py27 drop
14:33:55 <gmann> once it is merged in proposed dir, i will move it to selected.
14:34:20 <evrardjp> yes I think it's fair to say they will be selected :)
14:34:27 <gmann> njohnston: +1. nova is also almost done. few experimental jobs are left seems
14:35:00 <gmann> py2 drop: This is last update is ent on ML and next will be tomorrow: #link http://lists.openstack.org/pipermail/openstack-discuss/2019-December/011580.html
14:35:22 <gmann> phase-2 is going on which is common lib and QA tooling to start dropping the py2.
14:35:45 <tosky> njohnston: good to hear!
14:35:57 <gmann> py2 drop schedule is there on main ussuri cycle schedule #link https://releases.openstack.org/ussuri/schedule.html
14:36:40 <gmann> Goal select process schedule: This is merged and available in goal doc #link https://governance.openstack.org/tc/goals/index.html#goal-selection-schedule
14:36:51 <evrardjp> I should have removed that one
14:37:03 <smcginnis> For the record, I think it's way too late in the cycle to be approving more cycle goals.
14:37:09 <ricolin> tosky, FYI heat jobs (except for grenade job) just migrated to zuul v3
14:37:10 <gmann> my plan is to start this process for W cycle goals which will be in V cycle. let's see how it goes.
14:37:45 <gmann> smcginnis: zuulv3 migration s for V cycle. Ussuri cycle is finalized with 2 goals
14:38:02 <smcginnis> gmann: I was referring to the newly approved U goal.
14:38:26 <gmann> smcginnis: ohk. that is easy one i think in term of projects involvement and effort.
14:38:50 <gmann> that's all from my side on goal things.
14:39:08 <evrardjp> thanks for the report.
14:39:54 <evrardjp> it's a very hard thing, and we are playing catch-up. I think gmann is doing a tremendous work to make sure we don't have late goals for V and W, so again, thank you gmann.
14:40:02 <evrardjp> let's move on
14:40:12 <evrardjp> #topic Report on the convo with Catalyst
14:40:17 <ricolin> gmann, we can create a ics schedule so no step of W cycle goals (including pre-select part) will be forgot
14:40:18 <gmann> yeah target to streamline for V and W.
14:40:28 <evrardjp> ricolin: evrardjp where are we now?
14:40:33 <gmann> ricolin: +1. I  will check.
14:41:24 <ricolin> As promised, Telemetry PTL sended the report out
14:41:25 <ricolin> #link http://lists.openstack.org/pipermail/openstack-discuss/2019-December/011586.html
14:41:25 <ricolin> In general, people from Telemetry team are welcome any one to join the discussion and help with that issue.
14:41:25 <ricolin> I think we need someone with experience on monitoring services to keep following on next step.
14:41:25 <ricolin> I can help on checking the status as auto-scaling SIG also affected by it, but will help if someone got more experience stepped in and help.
14:41:29 <evrardjp> as far as I know there was this idea of forking gnocchi back into openstack/opendev, not really sure where we are
14:41:52 <ricolin> evrardjp, that's considered as one of solution
14:43:04 * ricolin think we should stop calling convo with Catalyst since one of the co-PTL is from ZTE :)
14:43:21 <ttx> I need to run now, will catch up with logs
14:43:51 <evrardjp> ricolin: fair. I should have said telemetry in general.
14:44:46 <evrardjp> I am confused about the next steps. What if nobody shows up, we're gonna have things re-merged into telemetry, things that were painfully removed?
14:45:32 <ricolin> evrardjp, that won't be worst than keep it broken
14:45:47 <openstackgerrit> Akihiro Motoki proposed openstack/governance master: doc nit: remove unnecessary space  https://review.opendev.org/702879
14:47:00 <zaneb> there were several volunteers to help maintain gnocchi in that thread
14:47:02 <evrardjp> People seemed to have disagreed there, so I am concerned of a split.
14:47:12 <zaneb> I would like to see us go ahead with the fork
14:47:21 <evrardjp> zaneb: I haven't seen an action from them
14:47:23 <zaneb> but I don't know that anybody picked up that action
14:47:29 <evrardjp> zaneb: I agree though
14:47:32 <ricolin> to fork gnocchi is not the worst idea, but we need to have people to make sure all discussion has been made (including the discussion in Gnocchi part)
14:47:47 <zaneb> yes
14:48:01 <evrardjp> I think forking gnocchi isn't _the_ solution, but it needs to enter in the mind of people actively looking for one :)
14:48:11 <zaneb> but I don't think they'll object. they all have other jobs now and they effectively abandoned it
14:48:23 <fungi> just to be clear, did ceilometer break due to gnocchi ceasing maintenance, or is it merely the cnocern that it might break in the future because gnocchi is unmaintained?
14:48:33 <zaneb> fungi: the latter
14:48:46 <evrardjp> sadly only the latter afaik fungi
14:48:57 <evrardjp> but there are other concerns apparently
14:49:20 <evrardjp> "mongo works for us"
14:49:23 <fungi> so there is a scramble for ceilometer to remove a backend which is currently still working and was considered at the time of implementation superior to what they're hoping to switch it out for
14:49:36 <zaneb> tbh I think the issue is more that it doesn't fit with the plans of the folks actually maintaining telemetry
14:49:52 <mnaser> fwiw from an operator pov
14:49:58 <zaneb> the people working on it actively are the people who need to keep it how it was 5 years ago
14:50:18 <zaneb> the people who are happy with gnochhi are not contributing because they're happy with how it is
14:50:19 <mnaser> i have given up on the telemetry stack and moved on to prometheus based stuff
14:50:51 <jungleboyj> mnaser:  I get the feeling that a lot of people have gone that way.
14:50:58 <mnaser> i honestly cant recommend our telemetry stack to attempting to run openstack at decent scale
14:51:29 <zaneb> mnaser: y'all do billing with prometheus?
14:51:30 <mnaser> and the biggest root of that problem is the "holding onto things" which is manifesting again by adding the ceilometer api
14:51:36 <evrardjp> it's maybe better to kill a project than trying to revive one with almost no future
14:51:41 <ricolin> evrardjp, some current member from Telemetry team figure out some way to optimize mongo
14:51:56 <mnaser> mongodb is a document database
14:52:02 <mnaser> its not meant for metrics
14:52:11 <mnaser> that was a mistake we did a long time ago because mongo was WeB sCaLe back then
14:52:28 <mnaser> there is better, more reliable, more actively developed options
14:52:43 <mnaser> zaneb: yes, and we have a bunch of open sourced exporters too (one for libvirt and another one for openvswitch soon)
14:52:46 <evrardjp> we have 4 topics remining and 8 minutes
14:52:57 <evrardjp> should we continue this in the office hours?
14:53:08 <gmann> +1
14:53:09 <zaneb> +1
14:53:10 <ricolin> IMO as long as it's just a optional driver, I think bother to block that effort
14:53:14 <ricolin> +1
14:53:15 <njohnston> +1
14:53:18 <jungleboyj> +1
14:53:19 <evrardjp> I think the last topics to report are fast
14:53:24 <evrardjp> ok let's move on
14:53:25 <evrardjp> #topic Report on multi-arch SIG
14:53:27 <ricolin> think so too:)
14:53:41 <evrardjp> ricolin: I see there are updates on that, even just before the meeting
14:53:44 <evrardjp> anything to report?
14:53:44 <ricolin> SIG is doing great, found a lot of tasks that this SIG can  works on.
14:54:01 <ricolin> Here's the initial meeting log from last meeting if anyone would like to see
14:54:04 <evrardjp> and I suppose people are taking the tasks? :)
14:54:06 <ricolin> #link http://lists.openstack.org/pipermail/openstack-discuss/2020-January/011894.html
14:54:13 <evrardjp> thanks!
14:54:16 <ricolin> We also keep asking people if they can provide more CI resources to community, or join in anyway. For now, I document all resources in SIG etherpad
14:54:22 <jungleboyj> That is good news.
14:54:26 <evrardjp> good news indeed
14:54:34 <gmann> nice.
14:54:42 <ricolin> If you know anyone to can help on provide CI resources let us know!:)
14:54:43 <evrardjp> anything else to report?
14:54:53 <ricolin> I just propose adding tonyb as SIG chair https://review.opendev.org/70286
14:54:53 <ricolin> His experience will definitely help a lot.
14:55:07 <mnaser> fwiw we have aarch64 nodes at vexxhost
14:55:09 <evrardjp> #action everyone let the multi-arch SIG know if you have CI resources in different architectures :)
14:55:10 <mnaser> we can probably help out wit ha few.
14:55:23 <ricolin> mnaser, that's great to know!:)
14:55:28 <ricolin> And finally, I will set up StoryBoard and repo for SIG before next Tue. . After that the others can have more clear view on what's going on in Multi-Arch.
14:55:29 <evrardjp> mnaser: awesome!
14:55:33 <mnaser> i'm happy to sponsor hosting different archs if a hardware vendor wants to provide hardware
14:55:45 <mnaser> arm was extremely cool at providing us with hardware to make available, so yeah.
14:56:00 <ricolin> mnaser, that's definitely helpful
14:56:02 <jungleboyj> mnaser:  That is great.
14:56:15 <evrardjp> anything else?
14:56:18 <ricolin> evrardjp, that's all I got
14:56:23 <evrardjp> ok let's move to next topic
14:56:24 <evrardjp> #topic report on release naming
14:56:32 <evrardjp> mugsie: Can we remove this, as the policy is changed, and we already started V/W already.
14:56:33 <evrardjp> correct?
14:56:43 <tonyb[m]> mnaser: I think there are vendors interested but it's a lot slower than I'd like
14:57:05 <mugsie> evrardjp: sorry, double meeting -_- but yeah, I think os
14:57:07 <mugsie> so*
14:57:11 <evrardjp> ok
14:57:17 <evrardjp> let's move to the next topic
14:57:22 <evrardjp> #topic report on the ideas repo
14:57:30 <jungleboyj> Our naming was Victoriaous ;-)
14:57:40 <evrardjp> jungleboyj: haha
14:57:55 <ricolin> evrardjp, what's next step plan for that repo:)
14:57:56 <evrardjp> ok, the repo for crazy^W ideas got created recently
14:58:12 <evrardjp> I will make sure that the framework is in place
14:58:22 <jungleboyj> https://gph.is/2GiLazc
14:58:28 <evrardjp> the idea would be to have it freely available and linked in the governance website
14:58:35 <evrardjp> (pun intended)
14:59:05 <jungleboyj> :-)
14:59:06 <evrardjp> more seriously, the content is there for anyone to jump and write what they think.
14:59:21 <evrardjp> More news in the next meeting.
14:59:48 <evrardjp> We'll probably be able to start drafting ideas at that time, which will be notified on the MLs.
14:59:59 <evrardjp> next and last topic
15:00:04 <evrardjp> #topic charter change
15:00:17 <evrardjp> we have charter change that we need to pass very quickly before next elections
15:00:29 <evrardjp> it went through a few iterations already, and it would be nice if you could all vote
15:00:37 <evrardjp> or propose a change
15:00:58 <gmann> #link https://review.opendev.org/#/c/699277/
15:00:58 <jungleboyj> Link?
15:01:00 <evrardjp> #action tc-members review the charter change
15:01:04 <jungleboyj> gmann:  Thx
15:01:09 <evrardjp> thanks gmann :)
15:01:20 <zaneb> reminder that we need like 9 votes on this one
15:01:29 <gmann> :)
15:01:33 <evrardjp> yup, it's a charter-change, not formal vote :p
15:01:37 <evrardjp> ahem ahem
15:01:40 * jungleboyj will vote now.
15:01:47 <zaneb> evrardjp: that wasn't directed at you ;)
15:01:59 <evrardjp> ok that's all we have for the meeting. Thanks everyone!
15:02:11 <evrardjp> we can now talk about telemetry in the office hours
15:02:14 <zaneb> just that we need to round up everyone to vote
15:02:15 <evrardjp> :)
15:02:43 <evrardjp> thanks for the reminder zaneb
15:02:58 <evrardjp> thanks everyone for your presence too, and let's continue to move things forward!
15:03:02 <evrardjp> #endmeeting