14:00:18 <ricolin> #startmeeting tc
14:00:19 <openstack> Meeting started Thu Feb  6 14:00:18 2020 UTC and is due to finish in 60 minutes.  The chair is ricolin. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:20 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:23 <openstack> The meeting name has been set to 'tc'
14:00:28 <ricolin> #topic rollcall
14:00:29 <ttx> o/
14:00:31 <diablo_rojo__> o/
14:00:32 <ricolin> o/
14:00:34 <gmann> o/
14:00:37 <evrardjp> o/
14:00:57 <njohnston> o/
14:01:13 <ricolin> tc-members meeting time:)
14:01:36 <mnaser> bonjour
14:01:52 <evrardjp> thanks ricolin for hosting this time!
14:02:05 <ricolin> mnaser, bonsoir:)
14:02:21 <evrardjp> so much french mastery
14:02:29 <ricolin> looks like we have a quorum:)
14:02:41 <ricolin> #link https://giphy.com/gifs/marcelo-4lkkKZVCeyHLy
14:02:48 <ricolin> #topic Report on large scale sig
14:03:00 <ricolin> ttx how's everything there:)
14:03:37 <ttx> Things are good. Slow progress. We can talk more about the oslo.metric spec when we cover that topic
14:03:42 <ricolin> evrardjp, I'm not going to Paris without learning some:)
14:03:58 <ttx> Not sure there is value in keeping it forever on the meeting agenda
14:04:10 <ttx> I post updates on the ML for those interested
14:04:11 <ricolin> next opendev event in Vancouver contains track `Large-scale Usage of Open Source Infrastructure Software (scale pain points, multi-location, CI/CD)`, is there any plan from  large scale sig?
14:04:45 <jungleboyj> o/
14:04:45 <ttx> Yes, there should be a in-person large scale SIG happening
14:04:54 <ricolin> agree with you, that SIG is all on track
14:05:17 <jroll> \o
14:05:26 * jroll neglected to put this one on his calendar, apologies
14:05:28 <ttx> we are trying to set reasonable expectations and steady albeit slow progress achieving those
14:05:56 <ttx> next topic!
14:05:58 <ricolin> ttx I wonder how can we help to attract more new joiner to the SIG
14:06:14 <ttx> ricolin: I'm pitching it to the user companies I talk to
14:06:27 * ricolin think PTG is not the best place IMO
14:07:32 <ricolin> ttx great idea to approach user companies, maybe we should added it to SIG guideline:)
14:07:45 <ricolin> Anyway that's something else, move on:)
14:07:47 <ricolin> #topic Report on tc/uc merge
14:08:04 <ricolin> ttx, how's that going:)
14:08:08 <ttx> I started to look into the corresponding bylaws changes
14:08:14 <ttx> It's not very fun
14:08:27 <ttx> So I'm all in the "is this really worth it" doubt phase
14:08:36 <ttx> Shall have something to present for next meeting
14:08:45 <ricolin> #link https://giphy.com/gifs/reaction-pretty-little-liars-pll-BnpZF3hWIyLgQ
14:09:16 <gmann> other option is to distribute the UC tasks among SIG, TC and dismiss UC. if that avoid by-law things easy
14:09:19 <ttx> Basically it's a costly move, fora psyops effects
14:09:26 <evrardjp> the gif game is strong
14:09:30 <ricolin> #action ttx report on tc/uc merge next meeting
14:09:32 <evrardjp> agreed with ttx
14:09:54 <ttx> gmann: yes. The costly change is really to rename the TC
14:10:33 <njohnston> https://media.giphy.com/media/26FL35TKSXu8KwiR2/giphy.gif
14:10:37 <ttx> But it's the alternative is basically to disband the UC and absorb its tasks into SIGs -- probably not a decision for us (TC) to make
14:10:49 <ttx> err.. But the...
14:10:49 <gmann> +1
14:10:50 <evrardjp> njohnston: :)
14:11:03 <ttx> So yeah, more on taht later
14:11:11 <evrardjp> thanks for the report!
14:11:24 <gmann> ttx i think it will be TC as SIG will be under TC only if noo UC. yeah we can discuss later
14:11:35 <ricolin> ttx is that means these need to present to board to grep approval eventually?
14:12:00 * ricolin think rename TC is not a bad idea
14:12:02 <ttx> I think if the best solution is to disband the UC, it has to come from the UC itself.
14:12:18 <evrardjp> agreed
14:12:24 <gmann> +1
14:12:26 <jungleboyj> Not a bad idea.  Too bad it is hard.
14:12:32 <ttx> Renaming the TC is very costly from a bylaws perspective, for a mostly psychological effect
14:12:33 <ricolin> spotz, just like you to be aware of this discussion:)
14:12:34 <evrardjp> jungleboyj: yup!
14:12:56 <ttx> But an important psychological effect ("Ops are welcome here")
14:13:21 <jungleboyj> ttx:  ++
14:13:28 <ttx> So yeah, one morning I'm motivated and the next day I'm like "wow, is it really worth it"
14:13:37 <evrardjp> haha
14:13:48 <evrardjp> well, it's out of our hands right now.
14:14:02 <ttx> ok next topic
14:14:08 <evrardjp> I think it's noble, and thanks ttx for adressing this from your perspective
14:14:12 <ttx> we need to go faster to cover everything
14:14:13 <ricolin> we can certainly help to push that
14:14:26 <evrardjp> ttx: +1
14:14:31 <ricolin> #topic report on the post for the analysis of the survey
14:14:39 <ricolin> jungleboyj, hey!:)
14:15:08 <jungleboyj> Hey.
14:15:31 <ricolin> jungleboyj already propose a patch for it, but we need tc-members to review it.
14:15:32 <jungleboyj> So, I apologize for lack of progress here.  My other job has become nuts.
14:15:37 <ricolin> #link https://review.opendev.org/#/c/698582/
14:16:04 <evrardjp> the question I have, outside the folks needing review, is that there is a blog post or not to write... If there is, it will be hard to track just in the review
14:16:07 <jungleboyj> ricolin: I had an additional comment to address.
14:16:15 <evrardjp> so it would be good to keep it on the agenda for next time
14:16:50 * asettle stumbles in the front door
14:16:51 <asettle> Yellow
14:16:54 <jungleboyj> FYI, I don't recommend trying to release a product with a Chinese team during a plague.
14:16:56 <gmann> sending the doc link on ML can be enough but yeah writting blog post is more audience
14:17:08 <ttx> jungleboyj: sounds like fun
14:17:20 <jungleboyj> Something like that.
14:17:27 <evrardjp> jungleboyj: Not sure plague is the right term.
14:17:40 <ricolin> "virus"
14:17:45 <evrardjp> but I am not english native :p
14:17:46 <ttx> I bet that would apply to any pandemic
14:17:55 <jungleboyj> ttx: ++
14:17:57 <evrardjp> it's not a pandemic afaik
14:18:02 <ricolin> #action jungleboyj report on user survey update next meeting
14:18:10 <ttx> evrardjp: the media treated it as one for sure
14:18:14 <evrardjp> but hey, I will stop being pedantic :)
14:18:23 <evrardjp> ttx: haha yeah
14:18:24 <jungleboyj> ricolin:  Yes, I will.  I will try to get a new patch up in the next couple of days.
14:18:32 <ricolin> jungleboyj, anything more on this topic in this meeting?
14:18:37 <evrardjp> ttx: it's serious business though.
14:18:39 <ricolin> jungleboyj, thanks
14:18:43 <jungleboyj> ricolin:  No.  Thanks guys!
14:18:47 <ricolin> move on:)
14:18:50 <ricolin> #topic Report on the convo Telemetry
14:19:08 <ricolin> For what I know, the ML discussion stopped at Dec. and there's no meeting for Telemetry since then.
14:19:18 <ricolin> There are few works been pushed, like Improve Quota API. No much reviewer and patch activity. I feel like they need help to push through the entire finding solution for Gnocchi thing.
14:20:05 <ricolin> A moderator will be nice
14:20:47 <ricolin> Let's all I have for now, I will keep an eye on it
14:21:00 <ricolin> s/Let/That/
14:21:07 <ttx> to be fair I'm not sure what we (the TC) can do. Someone has to care enough to put effort in this, effort which the TC can encourage/bless/support, but I'm not sure that benefits from being driven at TC-level
14:22:18 <ttx> I feel like a sustainable-telemetry pop up team would be more efficient, if someone wanted badly-enough to fix the situation
14:22:24 <ricolin> ttx, agree with you totally, I think to encourage to make the final call will be something TC can help
14:22:43 <ricolin> we don't need to be part of that decision
14:23:02 <ricolin> pop up team +1
14:23:04 <zaneb> o/
14:23:15 <ricolin> zaneb, o/
14:24:08 <spotz> ricolin: catching up
14:24:13 <ricolin> spotz, thx
14:24:38 <ricolin> ttx, I will rich out to ptl to see if they're in any status need our help
14:24:47 <ricolin> move on
14:25:00 <ricolin> #topic Report on multi-arch SIG
14:25:19 <ricolin> We have WIP for docs, and CI jobs, doc init structure will sended out this week. Not yet ask others if multi-arch SIG will join Vancouver opendev even.
14:26:05 <ricolin> Since just get back from CNY, haven't got any chance to update with mnaser and Huawei guy for ARM resource donation yet, hope that's on going:)
14:26:29 <mnaser> in my case, the hardware is already there and exists in the cloud thats part of openstack-infra
14:26:45 <mnaser> just need to upload images with correct properties
14:26:50 <ricolin> there's something need to fix in current ARM CI environment, and ianw is working on it
14:27:50 <fungi> also it turns out that new arm environment isn't reachable from our prior arm environment in mainland china, so we had to relocate the image builder
14:28:03 <ricolin> mnaser, that's great news, will sync with you out side of meeting:)
14:28:03 <evrardjp> should we continue reporting here? I have the impression it's in good hands now, and that people interested can be doing so by reaching the SIG... Correct?
14:28:04 <fungi> something something firewalls something
14:28:19 <ricolin> fungi, that's the issue ianw is working on I assume
14:28:33 <fungi> ricolin: actually he fixed that one
14:28:42 <ricolin> evrardjp, we can leave it out of TC meeting for sure:)
14:28:44 <fungi> now it's image properties, as mnaser indicated
14:29:01 <mnaser> oh sorry
14:29:03 <ricolin> fungi, thanks for the update info.
14:29:11 <mnaser> im talking about arm hardware inside vexxhost
14:29:38 <ricolin> Anything else need to discuss here?
14:29:46 <evrardjp> nope
14:29:46 <fungi> well, there's an issue with setting the right image properties in the new arm cloud too, it's looking like (last i heard anyway)
14:30:07 <fungi> but i haven't caught up on it yet since yesterday
14:30:32 <ricolin> fungi, is there any story I can trace this issue?
14:31:00 <fungi> i believe there is but i don't know it off the top of my head
14:31:09 <fungi> check in #openstack-infra after the meeting
14:31:17 <ricolin> fungi, got it
14:31:23 <ricolin> okay let's move on
14:31:27 <ricolin> #topic report on infra liaison and static hosting
14:31:38 <ricolin> mnaser, any update on this?
14:31:48 <mnaser> i think the dns was updated a few days ago
14:32:07 <mnaser> given i was a bit out of things because of some $personal_stuff, ianw and andreas did a lot of the work
14:32:18 <mnaser> afaik, infra updated dns not long ago for those domains
14:32:40 <fungi> yep
14:32:45 <ricolin> super
14:32:45 <evrardjp> I think we are good indeed, IIRC a comment from fungi during fosdem
14:32:47 <mnaser> 2020-01-29 20:30:35 UTC governance.openstack.org and security.openstack.org switched CNAMEs to new static.opendev.org server
14:32:50 <fungi> i think we're just down to rehoming the tarballs site now
14:33:06 <evrardjp> I am removing this from the agenda of the meeting, as everything seems to be in good hands
14:33:08 <mnaser> yeah, so that's mostly wrapped up, tarballs seems to be a different bigger beast that infra is dealing with
14:33:10 <evrardjp> :D
14:33:39 <evrardjp> from the agenda of next meeting*
14:33:47 <ricolin> move on:)
14:33:51 <ricolin> #topic report on stable branch policy work
14:33:59 <ricolin> mnaser, ^^^;)
14:34:16 <mnaser> yeah, sorry, not pushed up :(
14:34:34 <evrardjp> ok
14:34:37 <mnaser> i'll try to get to it, but nothing has developed on that
14:34:39 <evrardjp> let's keep it for next time then
14:34:47 <ricolin> mnaser, I can make a action for this in next meeting:)
14:34:56 <mnaser> hopefully it'll be gone by then
14:35:01 <ricolin> #action mnaser to report on stable branch policy work
14:35:10 <ricolin> #topic report on the oslo metrics project
14:35:32 <ttx> There is a spec proposed
14:35:57 <ricolin> ttx can you post the link:)
14:36:02 <ttx> #link https://review.opendev.org/#/c/704733/
14:36:12 <ttx> Please have a look if you care about the topic :)
14:36:31 <evrardjp> will there need to be a follow up after that? Or will it magically get done?
14:36:34 <evrardjp> :D
14:36:48 <ttx> it's early draft stage and I bet masahito-san would love comments
14:36:50 <evrardjp> (to know if I can remove this from the topics, I love magic)
14:37:04 <evrardjp> #action tc-members review https://review.opendev.org/#/c/704733/
14:37:10 <ttx> no need to keep it in-TC
14:37:20 <ttx> people interested should join largescale SIG really
14:37:22 <evrardjp> that's true
14:37:41 <ricolin> a ML update will be nice:)
14:38:27 <ricolin> let's see how the review goes
14:38:48 <ricolin> move on
14:38:50 <ricolin> #topic report on the community goals for U and V, py2 drop
14:38:54 <ricolin> gmann, :)
14:38:56 <gmann> U cycle community goals: We have 2 goals ready as updated over ML. Both goals are in progress. You can check the status updates on ML
14:39:03 <gmann> py2 drop: #link http://lists.openstack.org/pipermail/openstack-discuss/2020-February/012310.html
14:39:16 <ttx> Thanks for the updates on those
14:39:19 <evrardjp> awesome!
14:39:21 <gmann> Contribution goal: #link http://lists.openstack.org/pipermail/openstack-discuss/2020-February/012364.html
14:39:25 <ricolin> gmann, nice job!
14:39:46 <gmann> V cycle goal: I have started the ML to collect the ideas: #link http://lists.openstack.org/pipermail/openstack-discuss/2020-February/012396.html
14:40:07 <gmann> there is etherpad to collect the ideas and then we will start the discussion on individual idea
14:40:11 <njohnston> Thanks for your hard work on these. The py27 in particular has had some last minute twists.
14:40:12 <diablo_rojo> Thanks for getting the next rounds started already gmann :)
14:40:17 <ricolin> We have our first goal propose for V already
14:40:19 <gmann> #link https://etherpad.openstack.org/p/YVR-v-series-goals
14:40:24 <evrardjp> sorry I didn't get the chance to comment on the ML yet gmann. But thanks for doing so
14:40:24 <ricolin> the zuul migrate one
14:40:34 <gmann> looking for one more TC member for driving it
14:40:40 <jungleboyj> Yay!
14:40:51 <mnaser> wow YVR again
14:40:52 <jungleboyj> evrardjp: ++
14:40:53 <gmann> please write your name on etherpad if interested
14:40:59 <njohnston> I can help drive it
14:41:01 <mnaser> time is going by :>
14:41:27 <gmann> Py drop Drama: This is causing lot of issues/complexity than expected
14:41:36 <zaneb> mnaser: next summit is BER again. it's a replay of 2018
14:41:56 <gmann> master gate is all ok and if any project still left with py2 jobs which will fail due to oslo and other lib dropping py2 can drop py2 jobs
14:41:57 <ricolin> njohnston, you don't mind if I put an action on this?
14:41:57 <jungleboyj> Thankfully at a Venure that is closer to things.
14:42:10 <jungleboyj> *Venue
14:42:21 <gmann> but stable branch testing till stable/rocky is all bad. I have been fixing those since last weeks or more
14:42:38 <gmann> current issue fix is in progress: #link https://review.opendev.org/#/q/topic:fix-stable-gate+(status:open+OR+status:merged)
14:42:40 <njohnston> ricolin: sure
14:42:55 <ricolin> #action njohnston help with gmann to drive v series goals
14:43:00 <ricolin> njohnston, thx:)
14:43:01 <gmann> i have to fix devstack-gate for legacy ocata job which unblock the pike grenade job and so on.
14:43:15 <gmann> let's see if i can bring up the stable gate green again
14:43:21 <gmann> njohnston thanks
14:43:31 <gmann> that's all from my side. question ?
14:43:47 <evrardjp> no questions
14:44:07 <ricolin> none from me, but this is how I see you now https://giphy.com/gifs/superman-man-of-steel-FiBzv5FRE85PO
14:44:09 <evrardjp> except: is there a tc member that can help you? It seems a lot of work for just one person
14:44:25 <evrardjp> so true
14:44:31 <jungleboyj> :-)
14:45:23 <gmann> yeah, fixing py is more dynamic issues occur as lib drop py2. but as next week is deadline, we should have all potential failure and then fix them
14:45:44 <ricolin> got to push the meeting schedule, let's keep the finding volunteer in office hour:)
14:45:55 <gmann> one more thing: next week which is m-2 is target to finish the py drop from everything except requirement repo
14:46:15 <evrardjp> ricolin: oh yeah I meant that as an asynchronous thing. We can continue ...
14:46:24 <gmann> and then keep fixing the issue and make everything stable before m-3 or early
14:47:07 <gmann> +1, we can move next.
14:47:20 <ricolin> gmann, indeed important message to record in meeting, I think we need to figure out how can we help you with it
14:47:22 <njohnston> gmann: if you have a sub task that you want to carve off the rest I can try to help lighten the load
14:47:39 <ricolin> njohnston, :)
14:47:42 <ricolin> #topic report on release naming
14:47:44 <gmann> njohnston great, i will post you for that. thanks
14:48:02 <ricolin> Anyone can update the W progress?
14:48:23 <ttx> naming still open until tomorrow
14:48:34 <njohnston> lots of great names
14:48:36 <zaneb> there's a good list
14:48:47 <ricolin> zaneb, it is
14:48:56 <evrardjp> I haven't received a member that asked me to vote for x or y yet.
14:48:57 <jungleboyj> That is good to hear.
14:49:12 <evrardjp> I mean W1 or W2
14:49:14 <ttx> most people missed that memo (that they would not vote)
14:49:16 <jungleboyj> evrardjp:  ++
14:49:33 <gmann> #link https://wiki.openstack.org/wiki/Release_Naming/W_Proposals
14:49:38 <ricolin> definitely need to discuss this in our next office hour or meeting
14:49:42 <evrardjp> ttx: well it was sent on the ML, so...
14:50:00 <ricolin> #action mugsie help to report on W release naming
14:50:03 <evrardjp> let's just continue our things, haters are gonna hate anyway
14:50:08 <ricolin> move on
14:50:13 <ricolin> #topic report on the ideas repo
14:50:23 <ricolin> evrardjp, how's crazy idea goes:)
14:50:31 * gmann wondering how many request to ask for name support will be :)
14:50:38 <jungleboyj> I hadn't seen this list.  Looks good.
14:50:57 <evrardjp> in progress. will report on the ml when ready
14:51:05 <evrardjp> currently at static hosting changes
14:51:28 <ricolin> #action evrardjp report on ideas repo on ML
14:52:02 <ricolin> #topic report on charter change
14:52:09 <ricolin> evrardjp, ^^^
14:52:45 <evrardjp> I think we can remove this from the action items
14:52:59 <evrardjp> Everything is ready for the next elections afaik.
14:53:09 <evrardjp> removing it now!
14:53:14 <ricolin> okay, that's good news:)
14:53:16 <ricolin> move on
14:53:21 <ricolin> #topic Report on whether SIG guidelines worked
14:53:26 <ricolin> I actually got not much to update for this, I use it to settup Multi-Arch SIG and it works for me. Haven't got feedback from other SIGs but mostly is because this is more needed for new SIGs.
14:53:59 <ricolin> IMO no need to keep this in TC meeting agenda anymore
14:54:15 <evrardjp> ok
14:54:25 <ricolin> anyway, moving forward:)
14:54:27 <ricolin> #topic volunteers to represent OpenStack at the OpenDev advisory board
14:54:36 <ricolin> evrardjp,
14:54:56 <evrardjp> yeah, so we received a call on the ML from clarkb
14:55:18 <fungi> we basically need one volunteer to be the openstack liaison on the advisory board for the opendev collaboratory
14:55:34 <evrardjp> I am fine with being that liaison for the time of my chairing
14:55:34 <zaneb> does it have to be a TC member or just somebody we nominate?
14:55:52 <ricolin> better from one of member not getting re-election this time
14:55:53 <fungi> openstack's technical governing body can pick anyone they please
14:55:58 <ttx> can be anyone really
14:56:09 * zaneb nominates fungi
14:56:14 <ttx> I'd pick Andreas personally :)
14:56:47 <evrardjp> Infrastructure providers are also on the advisory board too, so we don't need to nominate mnaser :p
14:56:48 <fungi> zaneb: ideally not a sysadmin for the collaboratory, but i don't think we discussed whether that would cause a problem
14:56:48 <zaneb> we should probably put out a wider call for volunteers
14:57:00 <ttx> yes ML thread is the right way
14:57:08 <mnaser> ya just yell at me
14:57:12 <fungi> so it raises a very good point anyway
14:57:13 <mnaser> :>
14:57:35 <gmann> timecheck: 3 min left
14:57:49 <ricolin> gmann, thx
14:58:13 <ricolin> I assume we can keep this discussion in office hour to find our best candidate
14:58:16 <ricolin> move on
14:58:19 <ricolin> #topic Report on the OSF board initiatives
14:58:24 <evrardjp> just ML will be good enough :)
14:59:05 <evrardjp> yeah so... it's been a while we didn't report on what's going on in the board. Well basically there are initiatives started to get more contributors, with the help of mentoring and universities, IIRC.
14:59:31 <evrardjp> If a board member or previous board member could say a few words, that would be awesome.
15:00:14 <ricolin> Also the COA is back on again
15:00:15 <evrardjp> I had prepared this better, but my notes are in a box in my new home, sorry.
15:00:15 <smcginnis> There are some universities in Sweden that would like to include some real world hands on open source development.
15:00:17 <gmann> +1. i think getting some result on that would be nice or we find some other way
15:00:40 <smcginnis> We need to identify some good things they could work on over a few weeks time during the semester.
15:00:53 <jungleboyj> smcginnis:  ++
15:01:06 <smcginnis> ildikov and diablo_rojo have sent a few things out to the ML, but not sure if that's been widely seen/noticed.
15:01:15 <evrardjp> smcginnis: ok should we start ML thread, or take from our pool of community goals?
15:01:25 <gmann> smcginnisthat is for few weeks duration or some long term maintainer even with less bandwidth
15:01:26 <smcginnis> Seems like we need a better way to build up a pipeline of things, but I don't have any good ideas.
15:01:31 <evrardjp> I see
15:01:37 <jungleboyj> smcginnis:  I had pointed rosmaita at it but didn't see further action.
15:01:56 <njohnston> I believe the Octavia team may be working with that group of Swedish students (or possiblky another pool of Swedes).  I heard about that from johnsom.
15:02:02 <smcginnis> gmann: The idea would be that it's just for a few weeks, but with the hope that it would get at least a few of them interested in continuing after the class is over.
15:02:17 <gmann> ok.
15:02:17 <smcginnis> njohnston: Oh, great!
15:02:23 <evrardjp> I guess in the meantime, the investment opportunities and the community goals are the first targets...
15:02:31 <johnsom> North Dakota State University
15:02:45 <diablo_rojo> njohnston, those or NDSU students
15:02:47 <smcginnis> Getting their help on community goal completion could be a good way to have a discrete item of work for them to focus on.
15:03:05 <gmann> evrardjp true but that need longer time commitment from contributors
15:03:17 <njohnston> johnsom: Ah, well North Dakota is basically half of Swedish descent anyway :-)
15:03:20 <ricolin> like zuul v3 migrate?:)
15:03:31 <diablo_rojo> I'm working with johnsom mentoring those NDSU students (though johnsom is doing most of the work)
15:03:38 <gmann> anyways, we can discuss on list to work on in office hour
15:03:39 <evrardjp> gmann: everything is :) I just hope that having something that matter a lot gives an incentive to come back :D
15:03:43 <zaneb> evrardjp: that reminds me, we need to roll over the 2019 investment ops to 2020
15:03:49 <evrardjp> zaneb: correct
15:03:54 <zaneb> are there any we need to prune?
15:04:10 <evrardjp> technically they are all pruned, until someone propose it back to 2020
15:04:15 <evrardjp> again*
15:04:20 <zaneb> are there any we need to not roll over?
15:04:23 <diablo_rojo> evrardjp, I think we need smaller pieces of work than the investment opportunities.
15:04:36 <evrardjp> zaneb: the way it is built was to ensure pruning.
15:04:44 <gmann> we can propose one by one and see which one we can drop
15:04:46 <johnsom> Yeah, we are having them add actual features to Octavia and following through with tests, CLI, SDK, and dashboard updates. It's not just "grunt" work, lol
15:04:55 <evrardjp> So my understanding is that the community has no business opportunities for 2020 as of today.
15:05:07 <gmann> yes
15:05:23 <njohnston> I think the Designate opportunity at a minimum should roll over
15:05:26 <ricolin> we should move to our last topic as we already running out of time, can we move this to office hour and ML too
15:05:31 <gmann> need action item for that
15:05:34 <gmann> ricolin^^
15:05:48 <ricolin> gmann, got it
15:05:56 <ricolin> move on first
15:06:00 <ricolin> #topic Dropping side projects: using golden signals
15:06:06 <ttx> ohai
15:06:07 <ricolin> ttx
15:06:09 <gmann> that is TC assignment at start of every year
15:06:20 <ttx> So we can probably discuss this in open discussion and close the meeting first
15:06:25 <evrardjp> gmann: agreed. I will tackle this.
15:06:36 <gmann> thanks
15:06:56 <ricolin> can anyone help me to comes out with a nice action itemfor previous one?:)
15:07:00 <ttx> My point is that it's difficult to close a project, because every time we find something unmaintained that almost nobody uses, someone volunteers to keep it up
15:07:01 <evrardjp> because I don't believe we have considerably improved the community since 2019 :p
15:07:06 <ricolin> losing words here:)
15:07:33 <ttx> That volunteer should be encouraged to step up in more ... positive areas
15:07:54 <ttx> so how do we look at good candidates for pruning
15:08:02 <ttx> Contribution stats are not so great
15:08:16 <ttx> since a project can be slow and totally maintained and useful and operational
15:08:24 <ttx> I think we need to look at a combination of factors
15:08:33 <evrardjp> they are a good signal of maintainance though
15:08:51 <evrardjp> gates break regularily, so that + no contribution trigger a view of health
15:08:54 <ttx> Starting with a golden signal -- no PTL nomination, no goal completion with no communication to the champion etc
15:09:05 <fungi> missed releases
15:09:17 <ttx> then if that "abandoned" project also has no user and no dependency...
15:09:36 <ricolin> #action roll over the 2019 investment ops to 2020
15:09:37 <evrardjp> reduction of the amount of core reviewers is also a _warning_ sign (not a big red sign)
15:09:46 <ttx> It becomes a very good candidate for being dropped from the release and the projectteams
15:10:00 <evrardjp> ttx: agreed
15:10:02 <gmann> we can start tag for each project like SIG and guidlines to move state like mentioned above
15:10:02 <ricolin> I'm gonna end the meeting so we can keep this discussion going
15:10:15 <evrardjp> ricolin: yeah sorry we mixed the topics at the end
15:10:20 <ttx> We have a good list from gmann in http://lists.openstack.org/pipermail/openstack-discuss/2020-February/012310.html
15:10:23 <ricolin> #endmeeting