14:00:08 <evrardjp> #startmeeting tc
14:00:09 <openstack> Meeting started Thu Mar  5 14:00:08 2020 UTC and is due to finish in 60 minutes.  The chair is evrardjp. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:10 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:12 <openstack> The meeting name has been set to 'tc'
14:00:13 <evrardjp> #topic rollcall
14:00:17 <njohnston> o/
14:00:22 <diablo_rojo_phon> o/
14:00:29 <evrardjp> o/
14:00:41 <evrardjp> that makes us 3, mnaser and ttx won't be there
14:00:46 <evrardjp> 8 missing.
14:00:52 <gmann> o/
14:00:53 <ricolin> o/
14:01:10 <evrardjp> two more for quorum
14:01:47 <evrardjp> jroll: asettle jungleboyj cloudnull maybe?
14:01:52 <asettle> o/ hallo
14:01:58 <evrardjp> woot!
14:02:13 <evrardjp> one more, one more!
14:02:20 <jungleboyj> o/
14:02:24 <evrardjp> wooot!
14:02:28 <jungleboyj> I am here.  :-)
14:02:30 <evrardjp> we can go ahead
14:02:36 <evrardjp> #topic a little message from evrardjp
14:02:46 <evrardjp> as this might be my last meeting as TC chair, I would like to say a few words before starting our official meeting...
14:02:46 <evrardjp> it's been a pleasure working with all of you. we had a good team! Thank you for your support and your leadership.
14:03:13 <evrardjp> I would like to highlight that some of us were more discreet than others. Those shouldn't hesitate to share their opinions, or propose new topics that motivate them! at the opposite, those who are more vocal (like me or mnaser) should always remember to let the opportunity for the less vocal ones to speak.
14:03:13 <ricolin> https://gph.is/1rKtPXj
14:03:28 <evrardjp> ricolin: haha :)
14:03:47 <evrardjp> It would be nice if we could all reflect on what was achieved this last 6 months, and think about how we can improve further forward.
14:03:47 <evrardjp> We should discuss this in our next real life event, or, if the next event is cancelled, do it in a side meeting.
14:04:00 <evrardjp> I don't want to leave the TC with the skeletons in the closet, or the elephant(s) in the room, whatever applies in your language :)
14:04:05 <evrardjp> So, I propose we discuss all the big things like glance cli or nova ptl after this official meeting, in the office hours.
14:04:16 <njohnston> +1
14:04:18 <evrardjp> I am glad we introduced the ideas concept, and I am glad a few ideas were already proposed. Thanks zaneb for example.
14:04:21 <jungleboyj> :-)
14:04:30 <evrardjp> Let's leverage this framework for ambitious changes that might not fit into a simple change in the governance repo.
14:04:45 <evrardjp> last, I want to especially thank gmann, who has done a tremendous work on the difficult community goals.
14:04:57 <evrardjp> now, let's get the ball rolling by reporting what happened last month.
14:05:15 <evrardjp> #topic Report on tc/uc merge
14:05:21 <evrardjp> there is nothing to report, everything is on the ML
14:05:26 <evrardjp> #link http://lists.openstack.org/pipermail/openstack-discuss/2020-February/012806.html
14:05:39 <evrardjp> #topic report on survey analysis: jungleboyj
14:05:49 <evrardjp> I saw this was updated today/yesterday, is there anything else to say than checking the review?
14:05:55 <evrardjp> #link https://review.opendev.org/#/c/698582/
14:06:17 <jungleboyj> No, I don't think so other than if people want to provide other thoughts on the % participation.
14:06:32 <gmann> I think UC meeting to discuss the same is after half an hour if I remember
14:06:56 <evrardjp> good feedback gmann
14:06:59 <gmann> oh, for uc/tc merge things not survey
14:07:00 <jungleboyj> Sorry I didn't get an update in sooner.  Month went quickly.
14:07:07 <njohnston> I joined the UC meeting that just happened BTW, they have clarified what responsibilities they have.  I think the two main remaining points are agreeing on a mechanism for the join and how to make operators/users feel represented.
14:07:15 <evrardjp> oh I thought you meant they analysed the results too :p
14:07:37 <evrardjp> njohnston: can this be done on the MLs?
14:07:50 <evrardjp> jungleboyj: no worries :)
14:07:54 <njohnston> evrardjp: Yep, I just wanted to note it.
14:07:57 <cloudnull> o/
14:07:59 <evrardjp> ok cool
14:08:03 * cloudnull late to the party
14:08:10 <jungleboyj> Rather than making a statement about being concerned about the amount of participation thought it would just be good to note that I would like to see what the trend is.
14:08:59 <evrardjp> jungleboyj: I think that was the point of doing the exercise to its fullest, and re-iterate the experience in 2020
14:09:01 <ricolin> jungleboyj, I think the latest patch set provide great information already
14:09:12 <evrardjp> but it's indeed worth noting in the review
14:09:18 <evrardjp> or in another one
14:09:23 <evrardjp> I will keep that in mind when reviewing
14:09:34 <evrardjp> anything else?
14:09:44 <jungleboyj> Ok.  Everyone take a look.  I will prioritize responding so we can get it merged.
14:09:51 <evrardjp> :D
14:09:55 <jungleboyj> Thank you to aprice  for getting me the data I needed.
14:10:15 <evrardjp> thank you for handling that new kind of effort jungleboyj!
14:10:34 <jungleboyj> No problem.
14:10:38 <evrardjp> establishing long term trends is good to have data about our community :)
14:10:47 <evrardjp> until we have other tools to do that ofc :)
14:11:08 <jungleboyj> ++
14:11:08 <evrardjp> s/until we have/in addition to the future/
14:11:20 <evrardjp> ok moving on
14:11:28 <evrardjp> #topic telemetry
14:11:28 <evrardjp> nothing to report
14:11:40 <evrardjp> #topic stable branch policy
14:11:42 <jroll> \o sorry I'm late, got distracted by a baby :)
14:12:10 <evrardjp> #action mnaser still write the summary of what's going on in terms of stable branch policy
14:12:17 <evrardjp> jroll: no worries :)
14:12:25 <evrardjp> #topic report on goal contribution guide: diablo_rojo
14:12:41 <evrardjp> diablo_rojo: is the situation clear nowadays?
14:12:51 <ricolin> diablo_rojo_phon,
14:12:53 <evrardjp> should I say "state" instead of "situation" ?
14:12:58 <diablo_rojo_phon> Yes I would say so
14:13:03 <evrardjp> ok
14:13:08 <diablo_rojo_phon> A consensus has been reaches
14:13:10 <diablo_rojo_phon> Reached
14:13:18 <diablo_rojo_phon> And I updated the ML yesterday
14:13:20 <evrardjp> cool, then I guess people can just comment on reviews and start helping on the goal then
14:13:24 <evrardjp> oh awesome
14:13:27 <tosky> I... sent an small update for cookiecutter
14:13:30 <tosky> just formatting
14:13:39 <evrardjp> tosky: I saw that, thanks!
14:13:45 <tosky> just in case: https://review.opendev.org/#/c/711407/
14:13:57 <diablo_rojo_phon> tosky: I saw that this morning, will review today :)
14:14:03 <evrardjp> ok let's move on
14:14:06 <evrardjp> #topic report on other community goals: gmann njohnston ricolin
14:14:23 <gmann> U goals:
14:14:32 <gmann> 1. py2 drop I will cover later
14:14:41 <gmann> 2. contributor guide:
14:14:53 <gmann> diablo_rojo_phon sent the updates on ML
14:15:00 <gmann> #link http://lists.openstack.org/pipermail/openstack-discuss/2020-March/013003.html
14:15:09 <gmann> goal doc update patch is also merged
14:15:28 <diablo_rojo_phon> Coolio. Full steam ahead then.
14:15:30 <gmann> we need to merge the tosky fix also#link https://review.opendev.org/#/c/711407/
14:15:46 <tosky> there is also a fix from zaneb
14:16:01 <evrardjp> tosky: indeed
14:16:13 <gmann> ok, we have separate core on that repo so we need to ping them to get them merge soon
14:16:16 <gmann> V cycle goal:
14:16:18 <evrardjp> you should review the jinja to see if I am not too rusty in my comments btw
14:16:27 <gmann> ML: http://lists.openstack.org/pipermail/openstack-discuss/2020-February/012866.html
14:16:39 <evrardjp> #link http://lists.openstack.org/pipermail/openstack-discuss/2020-February/012866.html
14:17:01 <gmann> zuulv3 goal is selected for V and grenade base job are in good shape and close to merge
14:17:07 <gmann> thanks tosky again for working hard on those
14:17:09 <evrardjp> that's awesome
14:17:15 <tosky> yep, I need a few final fixes
14:17:16 <gmann> njohnston sent the request for V cycle goal proposal to a few individuals also.
14:17:25 <gmann> I replied on OSC thread also if anyone interesting to drive the OSC as a community goal or pop-up team.
14:17:37 <gmann> but no new proposal or volunteer
14:17:40 <njohnston> Yes, so far the main thing that has come up has been the OSC matter that we'll discuss later
14:17:47 <evrardjp> if we do this, we really need to pay attention to not fail like last time :p
14:18:18 <gmann> yeah, key things is we need more than one volunteer for this and it can be multi cycle goal
14:18:42 <gmann> other idea is - njohnston and I are going to check the backlogs and start pushing on ML for a volunteer to drive those.
14:18:55 <gmann> Any feedback/ideas are welcome here.
14:18:56 <evrardjp> and that all projects help, some shouldn't say "no to this"
14:19:21 <evrardjp> gmann: sadly I don't have another idea than this
14:19:28 * gmann wait for  tc members to take one of the goal :)
14:19:38 <evrardjp> except if you have someone in your company or a tc member that can take those
14:19:55 * evrardjp sees what gmann has done there ;)
14:19:55 <gmann> yeah project motivation is much required as this is for their user benefits
14:20:07 <gmann> py2 drop:
14:20:13 <ricolin> I think we can start a ML for OSC and ask if anyone not in favor of that one and also ask for volunteers too
14:20:24 <gmann> Latest Updates on ML: #link http://lists.openstack.org/pipermail/openstack-discuss/2020-March/012953.html
14:20:46 <gmann> Few tempest plugins are failing and fixes are in progress. I started doing updates required on deployment projects.
14:20:55 <gmann> phase-2 should be finished by now but it is not. Let's see how fast we can complete that and start phase-3 which is audit and requirement drop py2.
14:21:03 <gmann> Not so much failure nowadays, which shows we might have fixed the big issues and going towards stabilizing this migration.
14:21:41 <gmann> I will continue working on this on priority and try to finish as soon as possible.
14:21:44 <gmann> that's all from my side, any question/feedback?
14:22:18 <evrardjp> I have no question, that's crystal clear
14:22:19 <ricolin> gmann, all grenade issue with py2 drop fixed, right?
14:22:37 <gmann> yeah.
14:22:56 <gmann> zuulv3 jobs for grenade are also very close to nerge
14:22:58 <gmann> merge
14:23:32 <jungleboyj> gmann:  Thanks for all the work there.
14:23:54 <ricolin> From a project team point of view, it will definitely helpful if other teams can help to collect examples together and provide some brief about what this patch is special about.
14:24:17 <ricolin> like `how other teams migrate grenade to v3`
14:24:21 <gmann> ricolin: +1.
14:24:36 <gmann> once it is ready, tosky or i can add
14:24:52 <ricolin> Also most of zuul v3 patches didn't follow the goal defined Garrit topic
14:25:26 <ricolin> Are we still plan to use that?
14:25:33 <tosky> there were no many patches so far after the goal was merged
14:25:45 <ricolin> tosky, totally agree
14:25:49 <tosky> and I changed the topic of the patches that I uploaded after the goal was merged
14:25:51 <gmann> yeah, now onwards or when tosky start the goal then we can ask them to use
14:26:14 <ricolin> that's why I think collect patch from team might works too:)
14:26:22 <ricolin> gmann, +1
14:26:59 <evrardjp> anything else ricolin gmann or tosky?
14:27:10 <ricolin> nope:)
14:27:12 <gmann> nothing from my  side
14:27:24 <evrardjp> ok let's move on then
14:27:27 <evrardjp> #topic report on  release naming
14:27:38 <evrardjp> I think we are all good now, is there anything else to report or do mugsie/smcginnis?
14:28:01 <jungleboyj> Yay for Wallaby!
14:28:15 <mugsie> we are good afaik
14:28:18 <jungleboyj> It comes with a cute built-in mascot.  :-)
14:28:24 <evrardjp> :)
14:28:26 <evrardjp> ok
14:28:33 <evrardjp> #topic report on the ideas repo
14:28:45 <evrardjp> this is started. thanks to those putting ideas there, like zaneb or hberaud
14:29:05 <evrardjp> I have a few ones pending, but I am waiting for the nova conversation to be distilled, because it was kinda linked
14:29:16 <evrardjp> anyway
14:29:18 <ricolin> Teapot in review
14:29:23 <evrardjp> indeed
14:29:37 <smcginnis> Sorry - nope, we are all good on release naming.
14:29:41 <evrardjp> if you haven't read it, you should
14:29:43 <smcginnis> I think it went well. Thanks everyone.
14:29:53 <evrardjp> smcginnis: thank you for handling this
14:29:57 <jungleboyj> smcginnis: ++
14:30:02 <evrardjp> ok next topic
14:30:03 <gmann> just updates from nova meeting.  eric message: "A couple of folks have talked to me privately about taking over the PTL role. But nothing has solidified as yet."
14:30:03 <evrardjp> #topic report on volunteers to represent OpenStack at the OpenDev advisory board
14:30:04 <ricolin> are we plan to start X release naming shortly?
14:30:08 <smcginnis> No problem. Pretty easy now.
14:30:10 <jungleboyj> smcginnis:  Did you get any feedback from the community?
14:30:19 <smcginnis> Surprisingly no.
14:30:23 <evrardjp> apparently I went too fast
14:30:27 <jungleboyj> Ok.  Guess that is good.
14:30:35 <jungleboyj> evrardjp:  Sorry, I was too slow in thinking.
14:30:39 <jungleboyj> We can move on.
14:30:40 <smcginnis> evrardjp: Nothing to see here, move along. :)
14:30:55 <jungleboyj> :-)
14:31:01 <evrardjp> I guess the question of ricolin could deserve some answering though :p
14:31:21 <evrardjp> but that can be done later if necessary
14:31:31 <jungleboyj> https://gph.is/2a6mXOM
14:31:33 <evrardjp> ok so...!
14:31:37 <ricolin> just curious:)
14:31:38 <evrardjp> #topic report on volunteers to represent OpenStack at the OpenDev advisory board
14:31:55 <evrardjp> nothing to report, we'll wait for the creation of the advisory board first :p
14:32:01 <evrardjp> #topic report on OSF board initiatives
14:32:41 <evrardjp> nothing to report on my side, mnaser had a last minute thing which prevent him to be in this meeting, so maybe he can report next time if there is something to report
14:32:55 <evrardjp> #action mnaser (if anything to report), report on OSF board initiatives
14:33:15 <evrardjp> I guess we now https://gph.is/2a6mXOM
14:33:28 <evrardjp> (thanks for the gif jungleboyj :p )
14:33:29 <evrardjp> #topic report on dropping projects
14:33:34 <evrardjp> #link https://review.opendev.org/#/c/707421/
14:33:41 <evrardjp> this merged, so nothing to report. We only have to apply now.
14:33:53 <evrardjp> #topic elections
14:34:02 <jungleboyj> :-)
14:34:02 <evrardjp> #link https://review.opendev.org/#/c/708470/
14:34:24 <evrardjp> with this merge, I guess the only thing to report is that we'll have elections soon, and therefore tc elections soon.
14:34:47 <ricolin> also we should encourage people to join that election too
14:34:54 <jungleboyj> ricolin:  ++
14:34:55 <evrardjp> FYI I won't apply to be chair next time
14:34:56 <gmann> +1
14:34:57 <ricolin> PTL and TC
14:35:11 <evrardjp> yes indeed!
14:35:24 <jungleboyj> Wonder what we can do to socialize things and drum up more interest.
14:35:27 <gmann> we should write up some motivational message for people to take leadership
14:35:37 <jungleboyj> ++
14:35:37 <ricolin> jungleboyj, +1
14:35:50 <evrardjp> I think it would be nice for those leaving the tc and know that they won't run another time to make it public, and try to gather interest in the community
14:35:57 * gmann wait for ttx :)
14:36:06 <jungleboyj> evrardjp: ++
14:36:20 <gmann> ttx motivation is great, some ML message from him can help.
14:36:48 <zaneb> o/
14:36:53 <ricolin> we can put some words in ML, foundation news letter, and Super user magz
14:37:05 <ricolin> *magazine
14:37:24 <jungleboyj> ricolin: ++
14:37:36 <ricolin> Anyone here good at motivation?:)
14:37:42 <evrardjp> zaneb:
14:37:47 <evrardjp> :D
14:37:48 <ricolin> sold!
14:38:04 <evrardjp> haha
14:38:09 <evrardjp> ok
14:38:11 <evrardjp> well
14:38:11 <gmann> +1
14:38:18 <evrardjp> that's all we had today to report
14:38:30 * zaneb reads scrollback to figure out what he was just volunteered for
14:38:35 <evrardjp> I will close this one up, and we can talk about other things then
14:38:41 <gmann> can we have action item for that ? we need to do something so that more people show up for those elections
14:38:56 <ricolin> +1
14:39:01 <evrardjp> isn't that what everyone should do though?
14:39:07 <evrardjp> I am fine with defining action items
14:39:14 <zaneb> actually that was on my list anyway
14:39:35 <ricolin> :)
14:39:44 <gmann> everyone can do by taking to people they thing should come up but a ML message from motivational people like ttx zaneb can help
14:39:59 <jungleboyj> gmann: ++
14:40:14 <jungleboyj> I also thought about reaching out to people who might be interested.
14:40:26 <gmann> +1. thank jungleboyj
14:40:31 <zaneb> it occurred to me that it would be helpful if everyone posted a retrospective of what they actually did on the TC
14:40:48 <evrardjp> #action asettle mugsie jroll mnaser ricolin ttx zaneb post a message on the ML if not running again in the next tc elections, and encourage people to run
14:40:51 <zaneb> because the most common question is "what does the TC actually do?"
14:41:03 <asettle> evrardjp, aye aye captain
14:41:04 <evrardjp> zaneb: I actually said that in the first few words of the meeting
14:41:15 <ricolin> zaneb, yeah, evrardjp mentioned that part earlier, and indeed will be great if we put this two things together
14:41:18 <gmann> in separate email or a collective one ?
14:41:39 <jroll> evrardjp: will do
14:41:40 * ricolin slow typer:)
14:41:42 <evrardjp> gmann: I think it's better to have a separate email :)
14:41:52 <gmann> ok.
14:41:53 <evrardjp> People might have different reasons
14:41:59 <evrardjp> but this can be in a thread :)
14:42:04 <zaneb> yeah, separately
14:42:05 <ricolin> separate but link to another one
14:42:46 <gmann> ok, replying separately on single thread will be helpful.
14:42:48 <evrardjp> #action all tc members, encourage folks to take a leadership role in the next elections
14:43:43 <jungleboyj> ++
14:44:33 <evrardjp> #action tc-members: reflect on achievements done in this cycle (see also beginning of this meeting)
14:44:46 <evrardjp> probably a terrible wording, sorry for that ^
14:44:58 <evrardjp> but I suppose you get the idea
14:45:13 <evrardjp> ok let's wrap this up, and talk about other things, like nova or glance! :P
14:45:16 <evrardjp> #endmeeting