14:00:21 <evrardjp> #startmeeting tc
14:00:22 <openstack> Meeting started Thu Apr  2 14:00:21 2020 UTC and is due to finish in 60 minutes.  The chair is evrardjp. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:23 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:25 <openstack> The meeting name has been set to 'tc'
14:00:27 <evrardjp> oops
14:00:51 <evrardjp> oh no, I am right, it's time for the meeting
14:00:52 <evrardjp> #topic rollcall
14:00:56 <gmann> yeah
14:00:58 <gmann> o/
14:01:00 <evrardjp> #link https://media.giphy.com/media/2YtTdoSEl4m4/giphy.gif
14:01:11 <njohnston> o/
14:01:27 <evrardjp> o/
14:01:27 <mnaser> not sure i count, but, hi, i'm here.
14:01:29 <evrardjp> #link https://media.giphy.com/media/l2SpZuKuoluoknWU0/giphy.gif
14:01:44 <diablo_rojo> o/
14:01:45 <evrardjp> :)
14:01:45 <jungleboyj> Hello all!
14:02:04 * diablo_rojo has been awake for 2 hours already
14:02:06 <jungleboyj> :-)
14:02:43 <evrardjp> I think we technically have quorum :)
14:03:10 <ttx> p/
14:03:17 <evrardjp> let's roll
14:03:18 <evrardjp> #link https://media.giphy.com/media/KR0OAYFpP7gaY/giphy.gif
14:03:19 <ttx> evrardjp: :)
14:03:34 <evrardjp> #topic report on tc/uc merge
14:03:44 <evrardjp> We had this in our reports meetings for a while. Now that ttx term is ending,
14:03:44 <evrardjp> we would probably need someone to keep this topic alive, or bury it.
14:03:44 <evrardjp> Please talk on the ML about what you think the next steps should be.
14:04:04 <evrardjp> does that sound good ttx?
14:04:16 <evrardjp> is that an accurate report? :p
14:05:03 <mnaser> fwiw i don't think ttx cant drive it even if they're not part of the tc
14:05:12 * mugsie slinks in late
14:05:24 <evrardjp> not disagreeing there mnaser :)
14:05:26 <mnaser> i don't want to sign them up for work but they certainly are in a place with access to all the right resources at the osf
14:05:48 <evrardjp> no I just want the community to be aware of what's going on
14:05:56 <evrardjp> that's merely this.
14:06:03 <mugsie> I think some one on the TC should follow it, but the work can be done by anyone imho
14:06:26 <evrardjp> mugsie: at least it should be clear whether we pursue this or not
14:06:34 <mugsie> ++
14:06:36 <ttx> I'll drive simplification from where I stand
14:06:46 <evrardjp> ok
14:06:52 <ttx> but yes, havign a TC official relay can't hurt
14:07:00 <evrardjp> we'll make sure someone reports regularily on what's going on then
14:07:12 <jungleboyj> evrardjp: ++
14:07:24 <gmann> +1
14:07:25 <evrardjp> #action keep track of the tc/uc merger topic further
14:07:28 <evrardjp> ok next
14:07:32 <mnaser> (i'm unsure as to why ttx can't just report themselves, but ok)
14:07:35 <ttx> If anything, driving it without wearing  the TC team jersey will facilitate
14:07:46 <evrardjp> that's true
14:07:55 <mugsie> mnaser: no one is saying they can't
14:08:02 <evrardjp> and yeah, we welcome the reporting from other folks :)
14:08:15 <evrardjp> I think it already happened in the past multiple times! Please join! :)
14:08:19 <ttx> and with more ops incoming at the election, that should be easier to convince they will keep good representation
14:08:20 <evrardjp> anyway
14:08:29 <evrardjp> ttx: +1
14:08:33 <jungleboyj> Yeah, that is good to see.
14:08:34 <njohnston> ttx: +1
14:08:40 <gmann> ttx: +100
14:08:44 <evrardjp> let's see how it reflects in the votes :)
14:09:13 <evrardjp> #topic Report on the analysis of the 2019 survey (jungleboyj), and survey 2020.
14:09:17 <evrardjp> moving on
14:09:26 <evrardjp> 2019 analysis is in
14:09:26 <jungleboyj> Hello.
14:09:36 <jungleboyj> Yes.  Thank you for getting attention to it.
14:09:42 <evrardjp> what about the trends for 2020? ;)
14:09:47 <jungleboyj> Sorry for causing confusion with the topic on the change.
14:10:08 <evrardjp> don't you worry about that.
14:10:18 <evrardjp> that's paperwork, I can deal with that :)
14:10:27 <gmann> jungleboyj: if i remember the chat, you or aspiers will add some blog or link somewhere ?
14:10:31 <evrardjp> so you don't have to*
14:10:33 <jungleboyj> I think we started getting some more interesting data as I started putting %'s in place.
14:10:42 <jungleboyj> :-)
14:11:20 <jungleboyj> gmann:  So, it is published now.  I was hoping that aprice  might get it into one of the things that she was releasing but I didn't see that happen.
14:11:29 <evrardjp> Do we need further analysis on the 2019, and iterate over the text there? Or should we jsut wrap up 2019, and keep the framework for 2020?
14:11:35 <gmann> perfect, i want to circulate that to company side also.
14:11:42 <evrardjp> gmann: awesome!
14:11:57 <evrardjp> gmann:
14:12:00 <evrardjp> #link https://governance.openstack.org/tc/user_survey/analysis-12-2019.html
14:12:01 <jungleboyj> Let me follow up with aprice to see where a good place to socialize this more might be.
14:12:13 <gmann> +1
14:12:23 <jungleboyj> I have been meaning to send out a tweet with the link too.  Will do that now.
14:12:33 <evrardjp> :)
14:12:54 <jungleboyj> Does anyone know how soon we will see the 2020 results?
14:13:14 <evrardjp> I don't know. Could you ask aprice? :)
14:13:23 <jungleboyj> Yeah.  I will.
14:13:44 <evrardjp> awesome. let's report on the next meeting then
14:13:49 <jungleboyj> I would like to do that analysis sooner as I think it will be more interesting as we will have more than one data point.
14:13:52 <aprice> jungleboyj: we incorporated it into a lot of direct outreach that we did last week for the user survey
14:14:13 <evrardjp> oh, aprice! wonderful :)
14:14:16 <jungleboyj> aprice:  Ah, ok.  I must have missed that.
14:14:22 <jungleboyj> That is great.  Thank you!
14:14:26 <aprice> i do think that we can think about different ways to socialize it more as well, but there are also other places like on Superuser where we are plugging it in
14:14:47 <aprice> yeah - it's that time we bug people to take the survey, so we used that link to show them how the upstream community really cares about their feedback
14:14:55 <aprice> so thank you all :)
14:14:58 <jungleboyj> aprice:  Good.
14:14:59 <gmann> +1 on putting on Superuser.
14:15:22 <jungleboyj> Any idea when we will see the next results?
14:15:23 <aprice> i can think about a few ideas and share with yall if you would like
14:15:27 <gmann> and to BoDs too :)
14:15:34 <aprice> +1
14:15:41 <jungleboyj> aprice:  Please do.
14:15:43 <evrardjp> our pleasure aprice! I'm glad people can see that we care about their opinions, and want to learn from this!
14:15:56 <evrardjp> aprice: awesome!
14:15:57 <asettle> WHAT A HUSTLE OMG I HATE LINUX
14:15:59 <asettle> Hello o/
14:16:01 <aprice> definitely!
14:16:12 <evrardjp> asettle: hahahah
14:16:46 <evrardjp> your ircnickname (in my client) is green too. Just saying.
14:16:46 <jungleboyj> asettle:  I think that messaging is off brand.  ;-)
14:16:46 <mugsie> asettle: no comment
14:16:57 <evrardjp> haha
14:17:01 <evrardjp> let's go on
14:17:09 <evrardjp> #topic Report on telemetry
14:17:10 <jungleboyj> evrardjp:  Sounds good.
14:17:19 <evrardjp> ricolin_: anything to report?
14:17:34 <evrardjp> should we consider all is fine now, and the crisis is averted? ;)
14:17:34 <asettle> jungleboyj, nah mate super on brand for my goddam week.
14:17:36 <asettle> Whatever, mdae it
14:17:36 <ttx> asettle is obviously orange
14:18:06 <asettle> evrardjp, I'm green?
14:18:11 <evrardjp> ttx: hulk is definitely green. And she is working at SUSE, so moar green. You have to guess why I said green now.
14:18:22 <jungleboyj> :-)  Yes you are.
14:18:43 <asettle> Cause I'm green with ... hate
14:18:43 <evrardjp> Or maybe because she cares about environment? Who knows...!
14:18:45 <evrardjp> anyway
14:19:14 * jroll is suuuuper late but now here
14:19:16 <evrardjp> I think we can leave the telemetry topic on the agenda for next meeting
14:19:23 <evrardjp> woot jroll!
14:19:24 <asettle> jroll, I just got here too
14:19:36 <gmann> evrardjp: +1
14:19:46 <evrardjp> #topic report on stable branch policy work
14:20:03 <evrardjp> this has been there for months, still no progress to report afaik
14:20:17 <evrardjp> mnaser, any update?
14:20:29 <evrardjp> last action item was you were okay to push an update to distill what happened on the ML in terms of stable branch policy
14:20:38 <jungleboyj> https://gph.is/26kKW1Y
14:20:50 <mnaser> no, i went over the mailing list thread and honestly felt like we ended up with many different options
14:21:37 <evrardjp> should we at least document it, to say that we've tried to change it, and it wasn't successful due to lack of consensus?
14:21:45 <mnaser> i think our entire stable and upgrade policy needs to be cleaned up and simplified
14:22:18 <mnaser> i will push up a change in what i think is best for our community given the feedback
14:22:22 <evrardjp> I think this isn't too far from my idea. I will tackle a documentation.
14:23:04 <mnaser> i have a lot less going on than every time we talk about this
14:23:06 <evrardjp> I have written a large idea already. If you want to think of a large change, I would welcome you to contribute to it. I will push that tomorrow.
14:23:27 <evrardjp> ok let's move on, it seems we know the next steps
14:23:47 <evrardjp> I will work with you on this mnaser
14:23:49 <evrardjp> #topic report on the community goals
14:24:01 <evrardjp> gmann: do you want to say a few words?
14:24:06 <gmann> U cycle goal progress:
14:24:19 <gmann> Contributor guide goal progress is here: http://lists.openstack.org/pipermail/openstack-discuss/2020-March/013381.html
14:24:30 <gmann> diablo_rojo: can add if anything more
14:24:46 <gmann> this is py2 drop goal updates: http://lists.openstack.org/pipermail/openstack-discuss/2020-April/013777.html
14:25:01 <gmann> #link http://lists.openstack.org/pipermail/openstack-discuss/2020-March/013381.html
14:25:03 <gmann> #link http://lists.openstack.org/pipermail/openstack-discuss/2020-April/013777.html
14:25:17 <diablo_rojo> I think its pretty straight forward.
14:25:27 <diablo_rojo> Making progress, slowly but surely.
14:25:30 <gmann> py2 drop is very close, few projects are still left and i am reaching out to them and get those merge
14:25:52 <gmann> I am going to start the audit soon, may be next week or so
14:26:01 <jungleboyj> Well, the list of participating projects is a good start.
14:26:23 <jungleboyj> gmann:  ++ That is great.  Thank you for all the work there.
14:26:25 <evrardjp> gmann: That's a big milestone
14:26:29 <gmann> for V cycle goal: This also has two possible candidates with champion
14:26:31 <gmann> #link http://lists.openstack.org/pipermail/openstack-discuss/2020-March/013528.html
14:26:42 <gmann> #link https://etherpad.openstack.org/p/YVR-v-series-goals
14:26:50 <gmann> items 3rd and 4th in that etherpad.
14:27:07 <gmann> we are hoping to get those goal proposal soon, may be after u-3
14:27:14 <evrardjp> I would love to see those happen.
14:27:18 <gmann> me and njohnston will continue tracking on those
14:27:37 <njohnston> indeed
14:27:44 <gmann> OSC migration as multi cycle goal is something i am positive about but lets see
14:27:54 <gmann> that is all from my side.
14:28:32 <evrardjp> yes! lbragstad and I were super thrilled to put that in our list a certain time ago. Let's not repeat mistakes of the past! :)
14:28:45 <evrardjp> anyway
14:28:53 <gmann> :), sure lets try again.
14:28:54 * evrardjp and his old memories :)
14:29:11 <evrardjp> #topic Report on the OSF board initiatives
14:29:38 <evrardjp> mnaser do you have anything to tell us from the board perspective, as you're our man there? :p
14:30:22 <mnaser> i just want to speak about this, i'm not sure how this ended up on the agenda
14:31:02 <mnaser> but just to be clear, while i sit on the board, the best thing to do is to rely on the updates that jbryce publishes post board meetings/discussions, as i wouldn't feel comfortable being a "spokesperson" from the board towards teh community and the implications of that
14:31:02 <evrardjp> it was regularily on the agenda... I think the last 6 months. Nothing much to usually report though
14:31:40 <mnaser> i'll gladly be the other way around as a bridge of the community towards the board, but i'd be more comfortable letting folks who know this stuff better than me for now :)
14:32:47 <mnaser> (and really, i'm still settling down adn figuring it all out)
14:33:17 <evrardjp> ok let's move on then
14:33:54 <evrardjp> #topic Moving OpenDev discussion forward
14:34:02 <evrardjp> I think that topic was raised by clarkb
14:34:20 <mnaser> change has landed already, opendev is a thing, it might have been added before the change landed afaik
14:34:20 <clarkb> ya, I put it on the agenda back when I wasn't sure what needed to be done to make progress here
14:35:01 <evrardjp> yes, it's probably worth reporting what happened, for the folks who haven't followed?
14:35:07 <evrardjp> Any of you two care saying a few words?
14:35:26 <clarkb> since then we've made progress. If you are wondering what the next steps are on the OpenDev side we plan to spin up proper mailing list and meeting channels so that historical record of progress from this point can be recorded in places people are likely to look at them in the future
14:35:32 <evrardjp> (or pointing to links)
14:36:23 <evrardjp> ok
14:36:40 <evrardjp> thanks for the report!
14:36:43 <clarkb> essentially we've formalized the (long) planned spin off of openstack-infra software hosting activities into opendev. The two major changes that I wanted to bring up here if we hadn't made progress were removing related infra projects from openstack/goverance and adding the basis of opendev governance to opednev docs
14:37:07 <clarkb> formally electing a leader and building the advisory board of involved individuals is the next thing that we wwant to do on the new mailing list
14:37:09 <mugsie> glad to see it happen :)
14:37:16 <evrardjp> mugsie: +1
14:37:25 <evrardjp> awesome
14:37:38 <clarkb> once the mailing list is up I'll send out subscription invites to the various project lists so those that are interested don't miss these conversations
14:38:19 <clarkb> and that way history ends up preserved where people expect it (rather than say openstack-infra mailing ist)
14:39:04 <evrardjp> I like it
14:39:16 <evrardjp> Glad to see you're not blocked, and this is moving forward
14:39:33 <evrardjp> ok let's move on
14:39:37 <evrardjp> last topic for today
14:39:39 <clarkb> yup EOD from me thanks
14:39:42 <clarkb> er EOT
14:39:50 <evrardjp> that was a short day :p
14:39:52 <evrardjp> haha
14:39:56 <evrardjp> #topic Technical Election Nomination Period Results
14:40:07 <evrardjp> diablo_rojo: do you want to say a few words?
14:40:13 <diablo_rojo> Yeah.
14:40:29 <diablo_rojo> So. Basically we had 16 projects without PTL nominations in before the close
14:40:41 <jungleboyj> :-(
14:40:45 <diablo_rojo> There's a discussion going on in this etherpad for what to do: https://etherpad.openstack.org/p/victoria-leaderless
14:41:08 <diablo_rojo> a few have had people step up, but there are a number that require discussion.
14:41:14 <mnaser> btw -- did we decide about tobias' nomination?
14:41:28 <evrardjp> there were 7 in Ussuri IIRC
14:41:42 <diablo_rojo> mnaser, the election officials feel that because his nomination wasn't into gerrit in time, that its not valid
14:41:51 <gmann> we are 9 with  no leader seems. I am positive on getting someone for tacker
14:42:03 <diablo_rojo> Its a hard line, but I think its good to maintain a clear policy.
14:42:11 <mnaser> diablo_rojo: ok so even if their ML post for nomination came before that?
14:42:19 <diablo_rojo> If we had know he was having issues, we could have helped him.
14:42:21 <evrardjp> gmann: I saw that, it's awesome.
14:42:36 <diablo_rojo> mnaser, yeah I think we are treating the elections repo in gerrit as the source of truth.
14:43:03 <mugsie> yeah, the repo as the source of truth has been the thing for a while
14:43:05 <mnaser> fair. i'd encourage in the future for people to not post to teh mailing list in the future
14:43:17 <mnaser> that way a new comer doesnt feel like "ok i sent my email, im good to go"
14:43:22 <gmann> i really feel to relax the nomination things especially for 'Foundation Membership which automatic get disable for no vote in election for a year'
14:43:24 <mnaser> not saying tobias is, but i can imagine someone seeing it that way :)
14:43:46 <fungi> https://governance.openstack.org/election/#how-to-submit-a-candidacy doesn't mention a need to send candidacies to the mailing list at all, for what it's worth
14:43:54 <ttx> #link https://etherpad.openstack.org/p/victoria-leaderless
14:43:54 <mnaser> but yeah, we're having more and more leaderless projects
14:44:01 <mugsie> mnaser: yeah, there was talk of automting the nomination to the ML to clarify this, but I think it came into E_NO_TIME
14:44:09 <jungleboyj> fungi:  Yeah, that has always kind of just been something people do.
14:44:22 <evrardjp> ttx: thanks for doing so :)
14:44:39 <mnaser> lets all leave commenst about the leaderless projects in the etherpad
14:44:57 <mnaser> and then maybe discuss during office hours
14:45:01 <gmann> +1
14:45:21 <jungleboyj> So, dumb question on the Tobias situation will it default to a volunteer that is then Tobias?
14:45:25 <fungi> are you soliciting input from non-tc-members in that etherpad, or just tc members?
14:45:45 <mnaser> fungi: i think everyone should put comments there, not to limit to certain people :)
14:45:54 <mugsie> jungleboyj: Tobias was running for the TC
14:45:57 <mnaser> jungleboyj: in the case of tobias they were running for at tc seat
14:45:57 <fungi> jungleboyj: if you mean tobberydberg, he was submitting a candidacy for a seat on the tc, not as a ptl for a prohect
14:46:00 <fungi> project
14:46:10 <diablo_rojo> fungi, I think I am fine with anyone submitting opinions.
14:46:13 <jungleboyj> Doh.  Ok.  I missed the context there.
14:46:24 <mnaser> so if any non-tc members that are sitting here quietly reading this meeting
14:46:29 <mnaser> feel free to leave comments
14:46:35 <jungleboyj> Bummer that that got messed up.  Ok.
14:46:43 <mnaser> (previous tc members dont count, we know fungi will always be around :P)
14:46:49 <jungleboyj> He he.
14:46:55 <fungi> diablo_rojo: mnaser: thanks, in that case the infra team can take the opportunity to explain in the etherpad why they didn't produce a ptl candidate and what they actually want to do
14:47:11 <diablo_rojo> fungi, yeah that sounds good. Please do!
14:47:15 <mnaser> fungi: yes, i think i have a very vague idea of where it might be going given the current direction
14:47:36 <jungleboyj> fungi:  ++ Yeah, the discussion in there is good and should have all parties involved.
14:47:46 <diablo_rojo> Basically I just wanted people to make aware of the etherpad as we will need to figure that all out at some point.
14:48:00 <gmann> any deadline for that ?
14:48:10 <evrardjp> asap?
14:48:12 <gmann> before final release or after
14:48:17 <mnaser> there is none but logistically it's probably better to have it cleared out
14:48:29 <diablo_rojo> gmann, I think it would be nice to have decided by the time the rest of the election closes/ the final release yeah.
14:48:40 * diablo_rojo puts election official hat on
14:48:50 <ttx> fwiw I was CC-ed on an email from the CloudKitty PTL to the list that never made it
14:48:50 <gmann> ok
14:48:54 <diablo_rojo> evrardjp, can you also tag the repo for us so we can generate the electorate?
14:48:56 <ttx> Maybe some weird moderation issue
14:48:59 <mugsie> yeah, we have had some of the appointmes drag on for weeks after elections
14:49:09 <mnaser> diablo_rojo: what was the tag name again?
14:49:34 <ttx> fungi: is there anything from jferrieu in the moderation queue ?
14:49:35 <mnaser> ttx: fungi mentioned that over teh weekend the ML did oom a bunch of times
14:49:42 <diablo_rojo> mnaser, uhhh I think its normally $year-$month-elections or something like that?
14:49:52 <ttx> could be that he used a non-list email
14:50:31 * evrardjp facepalms
14:50:35 <mnaser> diablo_rojo: yeah, we count this as april or march?
14:50:49 <fungi> ttx: i'll take a look, haven't checked it yet this morning
14:51:00 <diablo_rojo> mnaser, april? cause thats when the polling will happen and the elections will conclude?
14:51:01 <evrardjp> diablo_rojo: seems like mnaser wants to handle this?
14:51:09 <diablo_rojo> evrardjp, lol seems like it :)
14:51:15 <mnaser> i'm helping driving the discussion
14:51:30 <fungi> mnaser: the memory issues only delayed deliveries by part of a day
14:51:33 <mnaser> and helping understand what we'll be doing
14:51:50 <mnaser> so i guess the tag should be apr-2020-elections
14:52:02 <mnaser> based on the previous history: https://review.opendev.org/#/admin/projects/openstack/governance,tags
14:52:23 <diablo_rojo> mnaser, works for me :) I had the details right and the order wrong
14:52:31 <mnaser> yep
14:52:36 <mugsie> we still have one topic left, so tagging logistics can be done off line, rigth?
14:52:42 <evrardjp> I agree
14:52:45 <evrardjp> let's move on
14:52:47 <mugsie> not sure if prakesh is here though
14:52:52 <fungi> Subject: [election][cloudkitty][ptl] Announcing my PTL candidacy for CloudKitty (Justin Ferrieu)
14:52:55 <fungi> Received: Thu Apr 2 10:14:56 2020
14:52:56 <fungi> approving it now
14:52:56 <mugsie> prakash*
14:53:09 <evrardjp> prmachan ?
14:53:20 <evrardjp> #topic refstack 2020
14:53:32 <fungi> evrardjp: usually "pramchan" in irc
14:53:51 <evrardjp> I just copy-pasted :)
14:53:57 <mugsie> he emailed the board list last night to say he would be here, but I don't see him
14:54:06 <gmann> not sure if he joined.
14:54:14 <evrardjp> I don't see him here at least
14:54:27 <evrardjp> and he didn't answer on my ML
14:54:31 <evrardjp> mail*
14:54:40 <evrardjp> so I wasn't sure if showing up or not
14:54:51 <evrardjp> let's hope this will be for the office hours then
14:54:57 <evrardjp> thanks everyone for joining!
14:55:03 <evrardjp> #endmeeting