14:00:35 <mnaser> #startmeeting tc
14:00:36 <openstack> Meeting started Thu Jul  2 14:00:35 2020 UTC and is due to finish in 60 minutes.  The chair is mnaser. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:37 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:39 <openstack> The meeting name has been set to 'tc'
14:00:40 <mnaser> #topic rollcall
14:00:42 <mnaser> o/
14:00:55 <ttx> o/
14:01:08 <ricolin> o/
14:01:11 <belmoreira> o/
14:01:12 <evrardjp> o/
14:01:26 <jungleboyj> o/
14:01:34 <jungleboyj> Though multi-tasking.
14:02:06 <mnaser> i count 5 tc members so far
14:03:30 <evrardjp> only one missing
14:03:34 <evrardjp> diablo_rojo: are you there?
14:03:45 <diablo_rojo> o/
14:03:50 <evrardjp> there you go mnaser :)
14:04:14 * diablo_rojo needs caffeine..
14:04:16 <mnaser> 6/11 makes us good
14:04:33 <mnaser> tc-members: friendly reminder our monthly meeting is happening
14:04:54 <mnaser> cool, let's get started.
14:04:59 <mnaser> #topic Follow up on past action items
14:05:11 <mnaser> there was no action items from the past meeting, also, the last meeting was quite a while back too.
14:05:31 <mnaser> so it doesn't have a lot of context.  there's not much here, hopefully we come up with a bunch this week.
14:05:37 <mnaser> s/week/month
14:05:46 <evrardjp> lgtm
14:06:02 <diablo_rojo> There were a bunch of action items from the PTG though
14:06:06 <diablo_rojo> in my summary email
14:06:11 <mnaser> ah, right.
14:06:16 <diablo_rojo> :D
14:06:17 <mnaser> let's grab those, that makes sense, we have quorum there
14:06:23 <evrardjp> that's probably what we should indeed report here for community members
14:06:24 <jungleboyj> :-)
14:06:35 <evrardjp> thanks ttx for being there btw :)
14:06:42 <mnaser> Start the User Facing API Pop Up Team
14:06:46 <knikolla> o/
14:06:47 <ttx> who says I'm here
14:06:57 <evrardjp> busted
14:06:58 <mnaser> we don't have an owned for that item yet
14:07:04 <mnaser> s/owned/owner/
14:07:36 <mnaser> i would suggest that we send an email out to the ML asking for owners for these.  it's probably a little unfair we pick one up at the meeting.  i don't think any progress has been done much on that
14:08:37 <mnaser> #action Find an owner to start the user facing API pop-up team
14:08:47 <mnaser> anything else about this action item?
14:09:25 <diablo_rojo> Nothing from me.
14:09:35 <mnaser> #undo
14:09:36 <openstack> Removing item from minutes: #action Find an owner to start the user facing API pop-up team
14:09:45 <mnaser> #action mnaser to find owner to start using facing API pop-up team over ML
14:09:57 <mnaser> next is "Write a resolution about how the deconstructed PTL roles will work"
14:10:19 <mnaser> i think i was one of those who was running my mouth a lot about this :) also, i think ttx has some sorts of proposal in gerrit which was abandoned
14:10:36 <mnaser> maybe restoring that change and iterating on it could be what we need to do.
14:10:59 <diablo_rojo> I thought njohnston had kinda claimed that one in discussions..
14:11:01 <evrardjp> weren't this one assigned to two people already?
14:11:04 <diablo_rojo> but I could be misremembering
14:11:05 <evrardjp> like njohnston and I?
14:11:07 <evrardjp> :D
14:11:10 <mnaser> o
14:11:16 <diablo_rojo> evrardjp, lol
14:11:33 <evrardjp> not saying this because we have a meeting on this just _after_ this meeting .
14:11:39 <mnaser> based on the mailing list post, it mentinoed that we need to find an action owner but no follow up email there saying that they have :)
14:11:47 <mnaser> #undo
14:11:48 <openstack> Removing item from minutes: #action mnaser to find owner to start using facing API pop-up team over ML
14:11:48 <evrardjp> I meant I will chat with Nate
14:12:07 <gmann> o/
14:12:11 <gmann> sorry for late
14:12:12 <mnaser> #action evrardjp & njohnston to start writing resolution about how deconstructed PTL role
14:12:21 <evrardjp> mnaser: I think you undoed the wrong one
14:12:28 <mnaser> sidfhkl;dfgghfjdkgh
14:12:34 <evrardjp> nice password
14:12:39 <mnaser> its "monday" for me because yesterday was a day off :)
14:12:43 <diablo_rojo> Its a rough day.
14:12:44 <mnaser> #action mnaser to find owner to start using facing API pop-up team over ML
14:12:52 <mnaser> i think we're good now
14:12:55 <evrardjp> :)
14:13:09 <mnaser> cool, next item: Update Goal Selection docs to explain that one or more goals is fine; it doesn’t have to be more than one
14:13:19 <mnaser> now this one i'm pretty sure i havent seen a change merge about that one =P
14:14:10 <mnaser> i guess we need to find an owner for that one too, righT?
14:14:27 <gmann> i can do that
14:14:46 <mnaser> gmann: awesome.  thank you.
14:15:06 <mnaser> #action gmann update goal selection docs to clarify the goal count
14:15:45 <mnaser> next up is "Two volunteers to start the W goal selection process".  we can maybe keep that until the following topic?
14:16:07 <mnaser> the next topic is "W cycle goal selection start" so perhaps its logical we discuss that potential action item there
14:16:21 <njohnston> o/
14:17:11 <mnaser> i take the silence as a yes
14:17:30 <mnaser> next up was Assign two TC liaisons per project
14:17:53 <diablo_rojo> I thiiink we had volunteers for this during the PTG too
14:17:54 <mnaser> mugsie: took care of it here https://review.opendev.org/#/c/735667/
14:18:11 <mnaser> so i think that's closed :>
14:18:16 <gmann> yeah
14:18:42 <mnaser> and then finally.... " Review Tags to make sure they are still good for driving common behavior across all openstack projects"
14:19:49 <diablo_rojo> We've had some new tags proposed so thats been good.
14:20:16 <gmann> api-interoperability tags is also one which we need more work as only nova has that tag and also we do not have a strong policy/guide around what API are interop.
14:20:52 <gmann> "tc:approved-release" can be removed after manila applying for this tag is merged.
14:21:05 <mnaser> perhaps what we need is to find an interested group and start working/having that conversation?
14:21:15 <gmann> yeah
14:21:19 <ricolin> gmann, +1
14:21:24 <mnaser> (as much as i disagree with the 'policy' but we've historically said, meeting are for updates, not for discussions.. but i dont agree with this)
14:21:30 <mnaser> okay so
14:21:42 <mnaser> maybe starting an ml list discussion to gather interested parties to start that discussion
14:21:52 <mnaser> anyone wanna volunteer, if not, i'll throw something on the ML to cover other tc members too
14:22:03 <gmann> for tag things right?
14:22:28 <mnaser> yeah
14:22:51 <gmann> I can start checking those and start some discussion over ML one by one, some might end up or need pop-up etc.
14:23:17 <gmann> api-interoperability tag was anyways in my list
14:23:17 <mnaser> yeah, this is going to be something that needs to be discussion driven
14:23:23 <gmann> yeah
14:23:36 <mnaser> #topic gmann start discussion around reviewing current tags
14:23:40 <mnaser> #undo
14:23:40 <openstack> Removing item from minutes: #topic gmann start discussion around reviewing current tags
14:23:45 <mnaser> ok seriously
14:23:51 <mnaser> #action gmann start discussion around reviewing currenet tags
14:24:06 <mnaser> alright, we're done with those
14:24:19 <mnaser> shall we move onto the few listed topics?
14:25:21 <jungleboyj> ++ ?
14:25:31 <gmann> this one covered - 'Propose a change to implement a weekly meeting' ?
14:25:33 <diablo_rojo> Yes, lets.
14:26:05 <mnaser> gmann: go for it.  i'll support this 100%
14:26:17 <mnaser> heck, i'll do it.
14:26:25 <mnaser> #action mnaser propose change to implement weekly meetings
14:26:45 <gmann> yeah that is what we discussed in PTG. propose. thanlks
14:26:46 <gmann> thanks
14:26:52 <mnaser> cool
14:26:55 <mnaser> #topic OpenStack Foundation OSU Intern Project (diablo_rojo)
14:27:04 * mnaser hands mic to diablo_rojo
14:27:32 * jungleboyj hears feedback
14:27:42 <diablo_rojo> So! Basically the tldr is that the FOundation can fund an intern at OSU next year like we did this last year
14:27:50 <evrardjp> \o/
14:27:53 <jungleboyj> Cool.
14:27:59 <diablo_rojo> I wondered if the TC had any preferences on what project we want them to work on.
14:28:00 <ricolin> super!
14:28:04 <evrardjp> community goals?
14:28:08 <diablo_rojo> This last year it was Glance.
14:28:18 <mnaser> ouu, interesting.
14:28:22 <diablo_rojo> evrardjp, that might be a little much..
14:28:32 <gmann> upstream opportunities ?
14:28:34 <diablo_rojo> They only work part time for the school year.
14:28:48 <diablo_rojo> Also they are going to need a fair amount of mentorship.
14:28:53 <gmann> or i will say osc thing can be good candidate also
14:29:13 <evrardjp> I thought of the osc bit, but I was afraid it would be too complex/political
14:29:16 <diablo_rojo> gmann,  yeah I was thinking about that since there are others around to help.
14:29:18 <mnaser> diablo_rojo: you're pretty involved in terms of first contact sig and upstream institute.  what are your thoughts on good starter places that we can have success at?
14:29:23 <evrardjp> but I might be wrong
14:29:37 <diablo_rojo> but I share evrardjp's concern about it being too political
14:29:46 <gmann> evrardjp: there will be people for to handle those things :) and inter to just code what we need
14:29:47 <evrardjp> why not proposing a list of topics for next time?
14:30:02 <evrardjp> Discuss this over the ML
14:30:20 <diablo_rojo> Well last year it was a decision between Glance and Designate and we went with Glance because we were trying to get grant money for a second student for Designate.
14:30:35 <evrardjp> I can't find a proper topic right now that's good for the whole openstack without discriminating a project or another :)
14:30:38 <mnaser> personally, i support perhaps first contact sig to come up with a few items that we can discuss
14:30:49 <evrardjp> mnaser: good idea
14:30:56 <gmann> yeah that's fair. +1
14:30:56 <diablo_rojo> Not looking for a decision just suggestions/to make people aware.
14:31:04 <diablo_rojo> I was also planning on the ML post.
14:31:07 <evrardjp> oh ok
14:31:12 <evrardjp> perfect then! :)
14:31:13 <jungleboyj> Makes sense.
14:31:14 <diablo_rojo> This week has just gotten away from me with opendev and the oss
14:31:29 <mnaser> ++ perfect.  i guess we're all completely aligned up
14:31:31 <gmann> we can discuss and find the feasible and starter work in FC SIG and then propose to TC
14:31:33 <diablo_rojo> If anyone had suggestions now, call them out :) Otherwise we can move on and discuss more later.
14:31:51 <evrardjp> thanks diablo_rojo to liaise on this :)
14:31:53 <mnaser> i think docs could be interesting too
14:32:18 <diablo_rojo> Well the TC doesn't technically approve the choice.. the foundation does since they hold the purse strings, but I wanted to get input from everyone.
14:32:32 <mnaser> depending on their interests, that could be a high impact thing.  but anyways
14:32:51 <jungleboyj> I do like the OSC idea as well.
14:33:01 <mnaser> oh, potentially horizon.  there was some concerning comments the other day in the thread i started about patternfly
14:33:13 <diablo_rojo> mnaser, true, would just need some more specific direction on docs as there are many.. and another mentor to help supplement me.
14:33:16 <gmann> true but we should not ignore most help-needed things like osc or upstream-investment-opportunities
14:33:16 <gmann> https://governance.openstack.org/tc/reference/upstream-investment-opportunities/2020/index.html
14:33:21 <ricolin> +1 on OSC too
14:33:26 <mnaser> aka: "horizon is just dying and it's barely surviving, it's in maintenance mode and it's almost impossible to get out of the hole we're in" type of thing
14:33:34 <gmann> then going with easy work which is not on the priority
14:33:53 <diablo_rojo> horizon could be good too.
14:33:59 <njohnston> +1 for Horizon I feel that we have a critical deficit in JS expertise, I just worry that the time horizon for the changes that need to be made is far beyond what an internship cal allow for
14:34:14 <njohnston> *can
14:34:32 <evrardjp> agreed with njohnston
14:34:35 <diablo_rojo> Yeah, Keeping in mind its a part time student for the school year.
14:34:47 <mnaser> #action diablo_rojo start discussion on ML around potential items for OSF funded intern
14:34:47 <evrardjp> maybe we can remove all the js from the interface? :p
14:34:53 <diablo_rojo> I can present like two options to the OSU staff that is looking for a student and let them chose.
14:34:55 <mnaser> evrardjp: >:(
14:35:02 <diablo_rojo> lol
14:35:09 <njohnston> python in the browser
14:35:13 <evrardjp> webasm
14:35:17 <evrardjp> lol
14:35:23 <evrardjp> I should stop doing jokes like that.
14:35:24 <gmann> :)
14:35:24 <mnaser> evrardjp: there's 'openstack' cli for that, type it once and you have a js-less ui :)
14:35:30 <mnaser> okey, cool
14:35:58 <mnaser> next up
14:36:02 <mnaser> #topic W cycle goal selection start
14:36:23 <mnaser> anyone wanna provide context for this? :>
14:36:46 <gmann> i added this to start the W cycle goal work as we are late as per goal schedule
14:37:12 <gmann> we discussed this in PTG and got two volunteer, if i am not wrong, njohnston and mugsie ?
14:37:37 <gmann> https://governance.openstack.org/tc/goals/#goal-selection-schedule
14:37:39 <gmann> #link https://governance.openstack.org/tc/goals/#goal-selection-schedule
14:37:58 <mnaser> why don't we just make patches that move all the listed goals from proposed/ to cycle/ (each one an individual patch) and have tc members vote there?
14:38:25 <njohnston> yes, so the idea is that mugsie and I will review the candidates for cycle goal, and try to groom the backlog
14:38:27 <gmann> yeah, that is one option. rootwrap is already there and having one also good.
14:38:45 <njohnston> and try to look forward and identify if we have another focal-style goal that might be coming
14:39:04 <gmann> njohnston: +1, that is good thing to check.
14:40:09 <njohnston> So mugsie, perhaps we can meet next week and chat about this?
14:40:51 <mnaser> i dont think they're around but perhaps that can be an action item?
14:41:01 <njohnston> +1
14:42:18 <mnaser> #topic njohnston and mugsie to work on getting goals groomed/proposed for W cycle
14:42:22 <fungi> one thing that has worked in the past is patches proposing different combinations of goals. it's hard to sort out which set is popular
14:42:24 <mnaser> ok.
14:42:24 <mnaser> #undo
14:42:24 <openstack> Removing item from minutes: #topic njohnston and mugsie to work on getting goals groomed/proposed for W cycle
14:42:29 <mnaser> #action njohnston and mugsie to work on getting goals groomed/proposed for W cycle
14:42:43 <mnaser> fungi: ah, yes, that's a really neat thing too
14:43:00 <ricolin> agree on vote first. We can vote on to have few pre-selected goals, then have volunteers to check on the possibility
14:43:09 <fungi> if you have 10 proposed goals and only room for 3, it's tough to tell from votes on individual per-goal proposals which three to select
14:43:29 <mnaser> very true
14:43:43 <njohnston> The other consideration is: how much bandwidth does the community have for a goal?
14:44:06 <gmann> yeah, that is imp and i feel we should only select 'what is actually needed'
14:44:11 <mnaser> i think that's the question that you might have to ask around to gather :)
14:44:19 <fungi> and not all goals are going to require the same amount of effort
14:44:51 <ricolin> njohnston, for W-goal at current stage, we only need one volunteer to do pre-survey
14:45:08 <fungi> depending on the goals you pick, one complex one might require the same amount of community effort as three minor ones
14:45:23 <gmann> doing priority item even slow pace is good things to do instead of burning low priority things first
14:46:03 <mnaser> we could leave this discussion to spill over into office hours
14:46:37 <mnaser> any other things to update on this last topic?
14:48:01 <njohnston> nothing from me at this point
14:48:36 <mnaser> #topic Completion of retirement cleanup (gmann)
14:48:48 <mnaser> so, i'll update a bit also on my side
14:48:59 <mnaser> https://etherpad.opendev.org/p/tc-retirement-cleanup is a scratch pad, nothing pushed out towards the community
14:49:32 <mnaser> with the help of fungi, retired.config means that now tc members can force merge patches to retired repos, so we could technically clean things up if we want to
14:50:05 <mnaser> the goal was to find a way to be able to make sure our projects are all properly retired (and that's with the help of a ci job)
14:50:07 <gmann> +1, thanks that is good move.
14:50:38 <mnaser> it's obviously currently failing: https://review.opendev.org/#/c/737559/ but once we (hopefully) clear all that stuff out, we won't have it happen again
14:50:50 <njohnston> +1 good improvement
14:52:11 <mnaser> gmann: has done a lot of the work on retiring stuff with help of AJaeger and smcginnis, so thanks there
14:52:55 <gmann> one thing to share, especially to do all cleanup asap
14:53:04 <mnaser> we'll continue to move forward with the work and hopefully normalize all of it
14:53:21 <mnaser> there's one quirk which is some people expressed that its not long HEAD~1 if we push a commit that fixes the tip..
14:53:34 <mnaser> (aka HEAD~1 doesn't contain the original code)
14:54:09 <mnaser> honestly, i think that's a bit of a detail and i (sadly) feel like most of the code probably won't be touched again anyways
14:54:17 <gmann> yeah, that is what networking-l2gw facing
14:54:20 <AJaeger> mnaser: so, update the README when you push something to reference HEAD~2
14:54:32 <gmann> while doing networking-l2gw retirement, we found we have an active team for this project and it is not easy/good thing for them to move to new namespace.
14:54:35 <clarkb> AJaeger: mnaser or even to reference a specific sha
14:54:38 <clarkb> then it won't change over time
14:54:44 <gmann> we missed that during our transition of namespace things but doing it now is really disturbing the development for such active but not openstack-govern projects
14:54:56 <mnaser> gmann: also, an example of that is python-dracclient too
14:55:02 <gmann> yeah.
14:55:09 <mnaser> formerly ironic, currently inside openstack/ namespace, but actively developed
14:55:22 <gmann> we should cleanup asap to avoid such a situation again.
14:55:22 <mnaser> so we need to clean house, so help is really welcome in this
14:55:33 <gmann> +1
14:56:12 <gmann> networking-l2gw is in-process with AJaeger help.
14:56:28 <gmann> i can help on few of other next week.
14:56:50 <gmann> but more volunteer and finishing it in one shot will be good.
14:59:18 <mnaser> i will try and help with this
14:59:28 <mnaser> #action tc and co to help finish properly and cleanly retiring projects
14:59:36 <gmann> thanks
14:59:51 <mnaser> #endmeeting