14:00:01 <mnaser> #startmeeting tc
14:00:02 <openstack> Meeting started Thu Oct  1 14:00:01 2020 UTC and is due to finish in 60 minutes.  The chair is mnaser. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:04 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:06 <openstack> The meeting name has been set to 'tc'
14:00:07 <mnaser> #topic roll call
14:00:10 <mnaser> o/
14:00:24 <gmann> o/
14:01:22 <mnaser> hmm
14:01:45 <ttx> o/
14:01:51 <diablo_rojo> o/
14:03:05 <mnaser> so we need at least 6, we have 4 (i assume belmoreira joining means they've just come around) :)
14:03:25 <belmoreira> o/
14:04:18 <mnaser> hrm
14:04:27 <mnaser> i guess we can resort to manually pinging people
14:05:03 <mnaser> as we don't have quorum
14:05:25 <mnaser> jay is going to be late as they mentioned
14:05:45 <mnaser> mugsie / evrardjp / cloudnull / njohnston / ricolin / knikolla -- are you around?
14:06:00 <knikolla> o/
14:06:03 <cloudnull> o/
14:06:07 <mugsie> omw
14:06:11 <ttx> nothign like the old fashioned ping
14:06:19 <gmann> :)
14:06:24 <fungi> once it dawned on me to add the startmeeting pattern for meetings i attend regularly as irc client highlights, that has made a world of difference for me
14:06:35 <mnaser> ok, so in that case that puts us a 6 with 1 incoming
14:06:44 <mnaser> thats ok with me to get moving
14:06:50 <knikolla> ooo, cool idea
14:07:07 <mnaser> #topic Follow up on past action items
14:07:24 <mnaser> #link http://eavesdrop.openstack.org/meetings/tc/2020/tc.2020-09-03-14.01.html
14:07:37 <mnaser> tc-members to follow up and review "Resolution to define distributed leadership for projects"
14:07:44 <evrardjp> o/
14:07:49 <mnaser> this is marked as complete, we'e already merged everything
14:08:06 <mnaser> and seems like some projects are adopting it
14:08:42 <mnaser> next up, mnaser schedule session with sig-arch and k8s steering committee
14:09:17 <mnaser> i was discussing with diablo_rojo and they mentioned thy would be able to schedule this
14:09:29 <mnaser> as they seem to be somewhat involved on the k8s side of things
14:10:22 <diablo_rojo> Yep. As soon as we know when we want to do it. I am happy to facilitate.
14:10:40 <evrardjp> fungi: yeah, I remember Colleen giving me that tip, and I said "Why didn't I think of it before!" It's just a good pattern :)
14:10:43 <mnaser> ok perhaps we should hold this off until we have a new roster
14:11:10 <mnaser> i'll keep it as an action item to carry over next meeting
14:11:13 <njohnston> o/
14:11:17 <gmann> +1
14:11:35 <mnaser> #action diablo_rojo schedule session with sig-arch and k8s steering committee
14:11:50 <mnaser> just in time, njohnston.  we had "njohnston to find someone to work with on getting goals groomed/proposed for W cycle"
14:12:22 <diablo_rojo> Agreed that we should wait till the new TC is seated.
14:12:59 <njohnston> mugsie contacted me and we worked tgether to get started on the process; he has been moving forward with some ML threads
14:13:12 <gmann> this one  #link http://lists.openstack.org/pipermail/openstack-discuss/2020-September/017459.html
14:13:15 <mnaser> yeah i noticed that
14:13:18 <njohnston> Since I am rotating off the TC he has graciously agreed to carry the torch moving forward
14:13:33 <mnaser> #link http://lists.openstack.org/pipermail/openstack-discuss/2020-September/017459.html
14:13:56 <mnaser> ok cool, so i think we're getting a little tight on time given this cycle is ending and W is starting quite soon
14:14:12 <mugsie> I was hoping for more ideas form the thread
14:14:39 <mugsie> there is one item in the thread that may be good to dicuss on the thread  - one goal for the cycle
14:15:06 <mnaser> i think as alway, we don't have a limit / minimum in the number of goals
14:15:24 <mnaser> so if one makes sense i will +1 it
14:15:26 <gmann> +1, two goals are somehow difficult to finish in a cycle.
14:15:33 <njohnston> +1
14:16:03 <mnaser> we have a topic to discuss this in a bit
14:16:15 <mnaser> so i'll leave the action item here and we can discuss it later as a topic
14:16:29 <mugsie> +1
14:16:29 <mnaser> #action mugsie Drive Wallaby cycle community goals
14:16:37 <mnaser> (not very actionable but i think enough to keep it on our radar)
14:16:50 <mnaser> next up is: "belmoreira/knikolla figure out logistics of a document with gaps within osc"
14:17:36 <knikolla> no update on my part from this. got caught up in other work. however i will reach out to belmoreira after the meeting to sync up.
14:17:46 <belmoreira> I started a google sheet to document the feature gap
14:17:57 <gmann> btw this is compute gap etherpad #link https://etherpad.opendev.org/p/compute-api-microversion-gap-in-osc
14:17:58 <belmoreira> https://docs.google.com/spreadsheets/d/1C5f0BQcfD8czzhKJmWQ-nnDq_6_D9W2xsWsEh-zHIAo/edit?usp=sharing
14:18:32 <gmann> compute microversion gap
14:18:51 <belmoreira> nice gmann. Thanks
14:18:52 <mnaser> fwiw, i am working with a local college for interns who might be able to do some of the osc work (or that's the goal at least)
14:19:05 <mnaser> i will update on my end when i have more info but this will likely be jan-apr period
14:19:34 <njohnston> nice!
14:19:48 <knikolla> cool
14:20:02 <gmann> +1
14:20:04 <mnaser> it is 3rd year students from a tech program who need to complete an internship as part of their program
14:20:23 <mnaser> (that was part of my education oddly enough so that works nicely :])
14:20:23 <belmoreira> mnaser nice
14:20:34 <mnaser> ok and finally
14:20:41 <belmoreira> also, I'm also supervising a fellow and he already started contributing with few patches
14:20:42 <mnaser> diablo_rojo help schedule forum session for OSC gaps
14:20:52 <mnaser> belmoreira: yay, nice.
14:21:13 <evrardjp> mnaser: nice!
14:21:36 <evrardjp> belmoreira: nice too!
14:21:48 <jungleboyj> o/
14:21:50 <evrardjp> are you syncing with mnaser on scope and method?
14:22:26 <evrardjp> it would be bad that two interns are working on the same things in parallel without communication :)
14:22:31 <mnaser> evrardjp: that is still very early right now, we just started talking a few days ago with the college, but i will keep updating
14:22:33 <evrardjp> (I doubt it, but just in case)
14:22:41 <mnaser> but the idea is to get them fully engrained in our OSS process
14:22:45 <diablo_rojo> ..like you need help scheduling something?
14:23:06 <evrardjp> mnaser: very nice, it's very important, thank you tremendously for doing htat!
14:23:29 <mnaser> diablo_rojo: i think at the time we wanted to know if we could reserve time in the forum for a session on that
14:23:39 <mnaser> i remember my bad joke that i knew someone who was an insider :p
14:24:45 <diablo_rojo> Ohh okay.
14:25:02 <diablo_rojo> I think we could still sneak something in, but you would probably need to talk to Jimmy to get that done.
14:25:12 <diablo_rojo> mnaser, what school are they from?
14:25:19 <mnaser> diablo_rojo: john abbott college
14:25:28 <diablo_rojo> I wanna add them to the list of other universities we do similar with.
14:25:30 <diablo_rojo> THanks!
14:25:37 <mnaser> they are technically interning for "vexxhost" but i am putting them on upstream only
14:25:54 <smcginnis> diablo_rojo: Did anything ever come about with the intern program Kim from City Cloud was trying to do?
14:25:59 <mnaser> (i.e. i have to do a whole bunch of stuff around evaluating them and all so there's some overhead here but yeah)
14:26:29 <gmann> Forum sessions schedule is up already - https://www.openstack.org/summit/2020/summit-schedule/global-search?t=forum
14:26:34 <mnaser> i'll ping jimmy today and see if they can put something in
14:26:58 <gmann> +1
14:27:15 <mnaser> does anyone want to write up a very very small short summary to add it on the list?
14:28:14 <mnaser> ok, jimmy says we can do it :) i just need a title, abstract and moderator
14:28:15 * jungleboyj is catching up.
14:28:59 <diablo_rojo> smcginnis, last I recall he had horizon things for them to work on.
14:29:07 <smcginnis> Great
14:29:21 <diablo_rojo> I have a todo to revive that email thread lol
14:30:27 <mnaser> belmoreira / knikolla: are you able to help with the above for the forum? ^
14:31:52 <mnaser> can *anyone* help with this to get a forum session going?
14:32:16 <belmoreira> yes, sure
14:32:34 <mnaser> awesome, thank you belmoreira -- lets try to get that asap, i'll setup an email thread with you + jimmy so we can get it on the schedule
14:32:53 <mnaser> #action belmoreira draft up title, abstract and moderator for OSC gaps session
14:33:20 <mnaser> ok next up
14:34:29 * mnaser lost in their tabs
14:34:35 <mnaser> #topic OpenStack User-facing APIs and CLIs (belmoreira)
14:34:44 <mnaser> belmoreira: all yours
14:35:40 <belmoreira> we more or less discussed this...
14:36:30 <belmoreira> I started the doc that I previously shared, and having some hope that the forum session can keep things moving
14:36:55 <mnaser> ok that's good, i think the forum session will be help
14:37:31 <gmann> it will be good  to carry that discussion in PTG too?
14:37:53 <mnaser> i would assume that maybe would be discussed in the sdk sessions
14:38:19 <gmann> yeah that is more relevant
14:38:25 <belmoreira> yes
14:38:33 <jungleboyj> I think discussion at the PTG would be good.
14:38:43 <mnaser> i guess we'll have more info over there about it more indepth
14:39:04 <mnaser> some teams have been merging things that stop osc usage
14:40:01 * evrardjp facepalms
14:40:10 <mnaser> so we should probably add to our ptg session a discussion around a tc policy with that
14:40:24 <mugsie> yeah
14:40:28 <gmann> +1
14:40:34 <evrardjp> I thought there kinda was one already
14:41:11 <mnaser> we can push that over to that topic
14:41:16 <mnaser> but as we are getting short on time
14:41:19 <mnaser> #topic W cycle goal selection start
14:41:27 <evrardjp> (https://governance.openstack.org/tc/reference/principles.html)
14:41:40 <mugsie> so - there is a single goal that hasn't had major pushback
14:41:44 <mugsie> Privsep
14:42:06 <mugsie> which, personally I think is a lot more work than people think (to do properly)
14:42:13 <gmann> +1 on privsep this is there since last cycle.
14:42:28 <gmann> and my vote is to go with only one goal in W.
14:42:35 <mugsie> if we do privsep I would ask to have it on its own
14:42:38 <fungi> needs people converting rules and, more importantly, tightening them up
14:42:55 <evrardjp> I think privsep community goal needs to be very clear
14:42:58 <jungleboyj> +1 on privsep
14:43:02 <mugsie> fungi: yeah - not just copy/pasting from rootwrap, or havikng a massive open ruleset
14:43:06 <evrardjp> (to make sure things _are done properly_)
14:43:09 <fungi> some of the existing converted privsep rules have holes big enough to drive a truck through
14:43:20 <evrardjp> mugsie: exactly
14:43:38 <mugsie> personally, i have 0 experience with privsep
14:43:55 <ricolin_> +1 on privsep
14:44:03 <evrardjp> I think it's good to make this the only goal, and it would be best if the champion has deep knowledge in how we should do this, so that's gonna be a tough role
14:44:17 <mugsie> for the people that have done migrations, do you have a good idea how to write it up / do pre work to help teams?
14:44:45 <gmann> ralonsoh volunteer on that in last cycle so we also need to re-check with him
14:44:50 <mnaser> i remember we had a few volunteers last time
14:44:52 <mugsie> I am going to ping ralonsoh to see if he can still doit
14:45:20 <mnaser> #action mugsie reach out to ralonsoh wrt helping with privsep
14:45:25 <evrardjp> thanks mugsie
14:45:26 <mnaser> it might be hard without someone who is deeply involved in it
14:45:38 <evrardjp> mnaser: yeah
14:45:45 <mugsie> unless there is any other suggestions, I am going to ping ralonsoh, and if they are on board, upodate the ML thread
14:45:49 <gmann> thanks mugsie for driving it.
14:46:07 <ralonsoh> mugsie, hi
14:46:09 <mnaser> deals
14:46:11 <ricolin_> :)
14:46:29 <mugsie> healthcheck is on my personal wishlist, but its not ready yet :(
14:46:38 <mugsie> ralonsoh: hey :)
14:46:50 <fungi> even just pointers to some example changes which implemented privsep for a project might be helpful for others as a starting point
14:47:07 <gmann> yeah. we need more detail check for healthcheck
14:47:47 <mnaser> ok, looks like we have a good direction, we're a bit short on time so i will try and push to move on, but i think we have some good direction
14:47:50 <ralonsoh> there are several examples in the storyboard
14:47:51 <mnaser> #topic Completion of retirement cleanup (gmann)
14:47:52 <ralonsoh> https://storyboard.openstack.org/#!/story/2007686
14:48:01 <mnaser> ^ i think we can kill this right?  it's all done at this point
14:48:14 <gmann> yeah all done on this
14:48:17 <mnaser> awesome
14:48:23 <mnaser> #topic Audit and clean-up tags (gmann)
14:48:28 <mnaser> #link https://review.opendev.org/#/c/749363/
14:48:34 <mnaser> that one has been merged
14:48:43 <mnaser> any plans for any other tags or can we mark this as complete for now
14:48:53 <gmann> yeah,  I will post it on ML also to notify
14:49:05 <mnaser> ++
14:49:09 <gmann> I am going to start assert:supports-api-interoperability as next
14:49:31 <mnaser> neat
14:49:44 <mnaser> #action gmann to start cleaning-up assert:supports-api-interoperability tag
14:49:53 <gmann> this might need more pre-work and discussion. goal is to have more projects to take this tag
14:50:06 <mnaser> (sometimes i really wish irc had "is typing", sorry for cutting off ralonsoh)
14:50:24 <ttx> mnaser: only sometimes, though
14:50:42 <ralonsoh> np
14:50:49 <mnaser> ok, last ten minutes
14:50:54 <mnaser> #topic PTG Planning
14:51:02 <mnaser> #link https://etherpad.opendev.org/p/tc-wallaby-ptg
14:51:08 <mnaser> i added the tc policy on openstack client in there
14:51:12 <mnaser> i think that is becoming more and more relevant
14:52:30 <mugsie> yeah
14:53:13 <mnaser> so please fill that out if possible
14:53:20 <mnaser> #topic open discussion
14:53:44 <mnaser> this is probably the last meeting as tc members for some individuals today, so i just wanted to thank them today while we're here :)
14:54:08 <knikolla> ++ thank you
14:54:16 <mugsie> mnaser: ++
14:54:27 <ricolin_> ++ thank you
14:54:32 <gmann> +1, thanks njohnston evrardjp  for serving in TC and wonderful work.
14:54:36 <mnaser> thanks evrardjp, njohnston, ricolin_ :)
14:54:40 <belmoreira> yeah, thank you
14:55:11 <evrardjp> my pleasure, I should probably say _our_ pleasure though :)
14:57:02 <mnaser> we have a few candidates running for tc which include new names, should they be elected, i plan on hosting some sorts of an online meeting where we can on-board.  it was a bit on me of not doing that properly then
14:57:25 <mnaser> i think having (at least) a vocal connection to discuss and walk through things should help getting on-boarded, everyone is welcome of course
14:57:57 <gmann> online meeting is nice idea.
14:58:15 <mnaser> i will try to document the 'on-boarding package' which i'll go through as much as i can too
14:58:30 <mnaser> and hopefully for those who joined in the last election who feel like they need a bit more info are free to refer/join too
14:59:06 <belmoreira> +1 it's a good idea
14:59:32 <mnaser> well
14:59:40 <mnaser> "see you guys at the summit and ptg" ;)
14:59:53 <mnaser> take care everyone, have a good rest of your morning/evening/afternoon
14:59:58 <mnaser> #endmeeting