15:00:32 <mnaser> #startmeeting tc
15:00:33 <openstack> Meeting started Thu Dec  3 15:00:32 2020 UTC and is due to finish in 60 minutes.  The chair is mnaser. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:34 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:37 <openstack> The meeting name has been set to 'tc'
15:00:38 <mnaser> #topic rollcall
15:00:41 <mnaser> o/ hello all
15:00:56 <gmann> o/hi
15:00:59 <belmoreira> o/
15:01:14 <mnaser> how are you gmann, belmoreira ?
15:01:19 <mnaser> winding down for the holidays?
15:01:29 <mnaser> "any exotic destinations you're heading off to for the holidays?" :'(
15:01:33 <gmann> m good, how r u
15:02:10 <gmann> from one room to other :)
15:02:19 <mnaser> hah :)
15:02:20 <belmoreira> hi, I'm good
15:02:23 <mnaser> friendly tc-members ping
15:02:25 <jungleboyj> Hey all running later than hoped period will do my best to follow along.
15:02:30 <knikolla> o/
15:02:52 <belmoreira> "exotic destinations"? ahaha :) staying in the Geneva cold
15:04:14 <belmoreira> mnaser I was expecting the meeting at 14:00 utc
15:04:26 <mnaser> did i mess up timing
15:04:28 <mnaser> ugh
15:04:48 <belmoreira> np, was just to clarify
15:05:03 <jungleboyj> I have seen multiple times planned. Not sure which is right anymore.
15:05:04 <mnaser> no i just want to verify that so that other tc members are here
15:05:12 <knikolla> timing is right, our calendars are a mess, haha.
15:05:23 <mnaser> Weekly on Thursday at 1500 UTC in #openstack-tc (IRC webclient)
15:05:37 <mnaser> ok, so it is the right time
15:05:44 <mnaser> i will try an update all references to 1400 utc
15:06:20 <belmoreira> my fault... the etherpad is wrong
15:06:38 <mnaser> belmoreira: do share so we can fix it :)
15:06:52 <mnaser> we have gmann, jungleboyj, knikolla, belmoreira  and me ... so we have 'quorum' though that might not matter that much if this becomes more informal
15:07:24 <mnaser> #topic Follow up on past action items
15:07:27 <mnaser> #link http://eavesdrop.openstack.org/meetings/tc/2020/tc.2020-10-01-14.00.html
15:08:15 <mnaser> so diablo_rojo took care of the sig-arch and k8s steering for tc ptg time whiuch was awesome
15:08:35 <mnaser> wallaby cycle goals seem to be "progressing" (to discuss later, so lets keep going with that)
15:08:56 <mnaser> osc gaps session was done too, privsep stuff moved, and gmann wrt tag stuff is to be discussed today :)
15:09:20 <mnaser> #action mnaser change all reference of meeting time to go towards eavesdrop for single source of truth
15:09:58 <mnaser> #topic OpenStack User-facing APIs and CLIs (belmoreira)
15:10:14 <mnaser> do we have anything to update about this, i know there's a review up by diablo_rojo based on our ptg discussions
15:10:38 <belmoreira> Unfortunately not much from me. I have been off most of the November.
15:10:48 <belmoreira> During the Summit/PTG I think we had a very discussion on the topic.
15:11:12 <belmoreira> yes, I see that diablo_rojo wrote the TC resolution for the OSC. Thanks!
15:11:15 <mnaser> #link https://review.opendev.org/c/openstack/governance/+/759904
15:11:53 <mnaser> i think that's a good step to move toiwards
15:12:02 <mnaser> so review on that are welcome
15:12:28 <mnaser> i think once th is merges, there is no immediate 'follow-up'
15:12:44 <mnaser> so maybe we should remove this discussion item, unless someone feels like we should keep it there
15:13:02 <belmoreira> I agree
15:13:06 <gmann> +1
15:13:20 <jungleboyj> Fine with me.
15:13:24 <mnaser> #action mnaser remove openstacksdk discussions for future meetings
15:13:53 <mnaser> #topic W cycle goal selection start
15:14:15 <mnaser> this seems to be pretty much complete
15:14:21 <mnaser> should we start with the next cycle early?
15:14:38 <gmann> there is one patch to update JSON->YAML goal doc
15:14:41 <gmann> #link https://review.opendev.org/c/openstack/governance/+/764261
15:15:20 <gmann> +1 on starting the next cycle goal as we do not have any proposed goal yet.
15:15:33 <mnaser> i just +W that gmann
15:15:38 <gmann> thanks
15:16:02 <gmann> getting goal proposed and finding champion can take time so starting early is good idea
15:16:21 <mnaser> gmann: should we reach out to ML to start asking?
15:16:46 <gmann> we need to find 2 TC members to drive this
15:17:01 <jungleboyj> Sounds like a good plan.
15:17:08 <gmann> and yes then reaching out to ML and search from backlogs
15:17:27 <mnaser> perhaps we should bring up over the ML for the tc members request
15:17:31 <mnaser> as not everyone is here :)
15:17:55 <gmann> this is schedule we should follow which seems we are already delay not early :) https://governance.openstack.org/tc/goals/#goal-selection-schedule
15:18:04 <gmann> +1
15:18:27 <mnaser> i can draft up that email
15:18:31 <mnaser> #link https://governance.openstack.org/tc/goals/#goal-selection-schedule
15:18:54 <mnaser> #action mnaser send email to ML to find volunteers to help drive goal selection
15:19:08 <mnaser> anything else on this topic?
15:19:23 <gmann> nothing from my side
15:19:57 <mnaser> cool
15:19:59 <mnaser> #topic Retirement for Leaderless projects (gmann)
15:20:08 <mnaser> #link https://review.opendev.org/c/openstack/governance/+/764530
15:20:13 <mnaser> #link https://review.opendev.org/c/openstack/governance/+/764523
15:20:18 <mnaser> tc-members: we really need reviews on those...
15:20:48 <mnaser> it is a formal-vote IMHO, not a project-update (i feel like 'removing' a project from official openstack warrants that vs a normal project update)
15:21:32 <gmann> I think we did with project-update in past
15:21:47 <gmann> but formal-vote make sense
15:21:55 <mnaser> oh? well, thanks to knikolla vote we have enough and now we need to start the 3 day timeline
15:22:04 <mnaser> so on the 5th we can merge this and we over with it
15:22:06 <mnaser> i think that's not so bad
15:22:07 <gmann> also these are depends on other cleanup work which I will try to reachout to respective team to merge the dependency patches.
15:22:23 <gmann> #link https://review.opendev.org/q/topic:%22retire-searchlight%22+(status:open%20OR%20status:merged)
15:22:24 <gmann> #link https://review.opendev.org/q/topic:%22retire-qinling%22+(status:open%20OR%20status:merged)
15:22:46 <gmann> ocne project-config patches are merged for ACL things then I can merge the code removal one and so
15:22:59 <mnaser> gmann: are project-config patches pending on the governance change?
15:23:27 <gmann> mnaser: other way around. governance one is last
15:23:58 <gmann> but having positive vote on governance patch is single for those to merge.
15:24:26 <mnaser> gmann: i also +2'd the project-config changes too
15:24:50 <gmann> mnaser:  thanks, these  # https://review.opendev.org/c/openstack/project-config/+/764519/1  https://review.opendev.org/c/openstack/project-config/+/764534/2
15:25:13 <gmann> #link https://review.opendev.org/c/openstack/project-config/+/764520/1 #link https://review.opendev.org/c/openstack/project-config/+/764532/3
15:25:18 <gmann> these ^^ for qinling
15:25:28 <mnaser> gmann: i merged the zuul gating change
15:25:45 <gmann> thanks
15:25:50 <mnaser> let me check with opendev team if merging gerrit change projects for acl and stuff are ok right now
15:25:54 <mnaser> and i will land it if that is the case
15:26:08 <gmann> +1
15:26:31 <mnaser> gmann: feel free to ping me for project-config changes to help you with this
15:26:38 <mnaser> once i get the ok i can merge the gerrit changes tooo
15:26:42 <mnaser> thanks for driving this
15:27:04 <gmann> sure, thanks
15:27:38 <gmann> there is one more project need to retire, Karbor which diablo_rojo is taking care. reviews are not up yet
15:27:47 <openstackgerrit> Merged openstack/governance master: Update example and oslo code usage in JSON->YAML goal  https://review.opendev.org/c/openstack/governance/+/764261
15:27:49 <mnaser> ok sounds good
15:28:17 <mnaser> maybe i can add those as action items that we can follow up on next meeting
15:28:26 <gmann> sounds good
15:28:26 <mnaser> and then remove this topic
15:28:27 <jungleboyj> ++
15:28:36 <mnaser> cause i think we just need to get it done really, not much to discuss, just follow up on progress
15:28:38 <openstackgerrit> Merged openstack/governance master: Remove already done use-builtin-mock from goal  https://review.opendev.org/c/openstack/governance/+/764262
15:28:45 <openstackgerrit> Merged openstack/governance master: Generate the TC liaisons assignments  https://review.opendev.org/c/openstack/governance/+/763810
15:28:49 <mnaser> #action gmann complete retirement of searchlight & qinling
15:28:58 <mnaser> #action diablo_rojo complete retirement of karbor
15:29:37 <mnaser> #action mnaser remove project retirement from agenda
15:29:52 <mnaser> anything else? :)
15:30:19 <gmann> that's all form me
15:30:50 <mnaser> #topic Audit and clean-up tags (gmann)
15:31:01 <mnaser> #link https://review.opendev.org/c/openstack/governance/+/761975/
15:31:34 <mnaser> there has been not much more reviews on this tag, we talked about it on the ptg, this is the minimum number of votes needed for it to merge, it's ben open for 24 days and i've posted it on the ML like 2-3 weeks
15:32:01 <jungleboyj> :-(
15:32:12 <mnaser> i will merge it
15:32:18 <mnaser> if someone is very unhappy they can propose a revert
15:32:19 <gmann> I forgot to add my vote itself, done.
15:32:40 <jungleboyj> mnaser:  That makes sense.  Doesn't seem very contentious.
15:32:43 <mnaser> next up is
15:32:44 <mnaser> #link https://review.opendev.org/c/openstack/governance/+/760562
15:33:25 <mnaser> same time line, similar situation, i will merge it a s well
15:33:35 <jungleboyj> ++
15:33:39 <gmann> once this ^^ is merge the I will start approaching to projects to apply for this tag over ML.
15:33:43 <gmann> +1
15:34:24 <mnaser> anything else on this?
15:34:36 <jungleboyj> Not from me.
15:34:40 <gmann> nothing from me
15:34:50 <mnaser> #topic Open Reviews
15:34:58 <mnaser> not sure who put up the dashboard link but it seems that it's borked
15:35:20 <gmann> yeah, i pasted that but seems it is invalid now :)
15:35:47 <mnaser> FYI - https://review.opendev.org/759904 is ready to land but gouthamr had some comments for diablo_rojo that i think would be useful to address
15:35:54 <mnaser> i'll just hold off a bit for that
15:36:07 <gmann> #link https://review.opendev.org/q/project:openstack/governance+status:open
15:36:19 <jungleboyj> Yeah, all-in-all I think that is good but wouldn't hurt to address the comments.
15:36:32 <mnaser> i think we can also land https://review.opendev.org/c/openstack/governance/+/722399
15:36:52 <gmann> yeah, +1
15:36:53 <mnaser> plenty of votes, seems polished enough too, straightforward
15:36:55 <knikolla> \o/
15:37:06 <mnaser> knikolla: sorry that took so long
15:37:13 <jungleboyj> ++
15:37:43 <mnaser> gmann: seems the tc liaison patch has made a merge conflict
15:37:49 <mnaser> for project removal
15:38:04 <gmann> yeah, I will rebase those quickly
15:38:40 <mnaser> ok so we have 3 in gate, 2 waiting 3 days to merge, osc pending some comments
15:38:46 <mnaser> the only one that is left is https://review.opendev.org/c/openstack/governance/+/752699
15:39:56 <mnaser> so it seems like there hasnt been much traction and i think evrardjp is busy with other things :)
15:40:01 <mnaser> so we'll have to drive that patch
15:40:56 <jungleboyj> Yeah, I don't have a problem with adding the content suggested there.
15:41:10 <mnaser> i've added the release managers team into this
15:41:12 <mnaser> appreciate their reviews on it
15:41:18 <gmann> yeah seems straight forward
15:41:42 <gmann> I can fix that comment
15:42:06 <mnaser> gmann: ok awesome, and if that's ok, then we can vote on it and get some release team members to vote on it and we'll be at 0 reviews open :)
15:42:20 <fungi> sorry, stepped away for a sec, but yeah we can merge whatever project-config changes, nothing's frozen right now in that regard
15:42:30 <jungleboyj> gmann:  Thanks.
15:42:44 <mnaser> fungi: cool!  thanks, i'll do those 2 patches gmann
15:43:01 <mnaser> and done
15:44:03 <mnaser> that's pretty much it for oepn reviews
15:44:06 <mnaser> this is awesome and super productive
15:44:38 <gmann> \o/ yeah super productive.
15:44:49 <jungleboyj> Yay for productivity!  Something I haven't felt this week.  :-)
15:45:06 <mnaser> #justdecemberthings
15:45:06 <openstackgerrit> Ghanshyam proposed openstack/governance master: Clarify impact on releases for SIGs  https://review.opendev.org/c/openstack/governance/+/752699
15:45:09 <knikolla> yay \o/
15:45:17 <mnaser> #topic open discussion
15:45:25 <mnaser> anyone has anything else that they'd want to bring up?
15:45:51 <gmann> X release naming vote but not all members are here
15:46:06 <jungleboyj> I voted!  :-)
15:46:19 <mnaser> so did I, so that puts us at 4 (given smcginnis mentioned there was 2 already done)
15:46:36 <gmann> I am still in favor of getting vote from community than just TC so voted equal to all proposals
15:47:01 <jungleboyj> gmann:  Interesting.
15:48:08 <fungi> just remember in a ranked choice vote, ranking all choices the same is the equivalent of an abstention
15:48:20 <mnaser> tc-members: please look for an email "OpenStack X Release Naming" and make sure to vote
15:48:56 <knikolla> i did vote yesterday. didn't realize it was TC only as of now.
15:49:42 * jungleboyj had forgotten it was TC only also.
15:49:48 <gmann> oh. it changed since V or may be W release name i think
15:50:05 <fungi> #link https://governance.openstack.org/tc/reference/release-naming.html#release-naming-process
15:50:23 <fungi> and yeah, see the review comments and associated openstack-discuss ml thread(s) leading up to that
15:50:32 <gmann> fungi: yeah, to avoid waiting for all TC, i did vote but yes with abstention
15:51:23 <fungi> #link https://review.opendev.org/695071 Simplify release naming process
15:51:35 <gmann> this change was additional to solving the  issue we had during U cycle naming.
15:51:35 <fungi> merged a year ago next week
15:51:45 * jungleboyj remembers that now.
15:52:14 <openstackgerrit> Merged openstack/governance master: Remove assert_supports-zero-downtime-upgrade tag  https://review.opendev.org/c/openstack/governance/+/761975
15:52:20 <openstackgerrit> Merged openstack/governance master: Clarify the requirements for supports-api-interoperability  https://review.opendev.org/c/openstack/governance/+/760562
15:52:47 <mnaser> knikolla: can you rebase https://review.opendev.org/c/openstack/governance/+/722399 quickly?
15:52:52 <jungleboyj> Look at stuff getting merged.
15:53:19 <knikolla> mnaser: sure, on it
15:53:45 <gmann> \o/ I think that is the main benefit of weekly meeting. fast discussion, fast review, fast merge :)
15:54:19 <jungleboyj> ++
15:56:17 <mnaser> gmann: true.  btw, i had to remove my +W on the gerrit changes because of some mangae-project stuff
15:56:22 <mnaser> ill follow up
15:59:08 <openstackgerrit> Kristi Nikolla proposed openstack/governance master: Add assert:supports-standalone  https://review.opendev.org/c/openstack/governance/+/722399
16:01:26 <knikolla> mnaser: rebased. the index.rst had changed :)
16:05:51 <gmann> may be we can end meeting.
16:05:53 <gmann> mnaser: ^^
16:06:10 <mnaser> yes! :)
16:06:12 <mnaser> #endmeeting