15:00:55 <mnaser> #startmeeting tc
15:00:55 <openstack> Meeting started Thu Jan 28 15:00:55 2021 UTC and is due to finish in 60 minutes.  The chair is mnaser. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:56 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:58 <openstack> The meeting name has been set to 'tc'
15:01:24 <gmann> o/
15:01:33 <mnaser> #topic roll call
15:01:34 <mnaser> o/
15:01:40 <ricolin> o/
15:01:47 <belmoreira> o/
15:02:21 <mnaser> how are y'all doing
15:02:49 <diablo_rojo> o/
15:03:15 <jungleboyj> o/
15:03:24 <diablo_rojo> Tired. How are you mnaser?
15:03:35 <mnaser> lololol very much the same
15:03:38 <mnaser> with this ball of energy running around me
15:03:42 <ricolin> mnaser, doing great:)
15:03:47 <mnaser> currently spinning at 4000 rpm chasing his own tail
15:04:01 <jungleboyj> mnaser:  ++ Yeah, that is how I feel.
15:04:06 <gmann> going same way, nothing changed actually, stuck inside  :)
15:04:11 <diablo_rojo> mnaser, have you realized yet that he now runs your life?
15:04:30 <mnaser> im doing my best to make that turn around lol
15:04:50 <diablo_rojo> mnaser, it will take a couple months lol
15:05:13 <mnaser> he's a land shark right now
15:05:19 <mnaser> #topic Follow up on past action items
15:05:29 <ricolin> hanging there:)
15:05:29 <mnaser> #link http://eavesdrop.openstack.org/meetings/tc/2021/tc.2021-01-21-15.00.html
15:05:34 <mnaser> diablo_rojo complete retirement of karbor
15:05:51 <diablo_rojo> I updated the patches that needed to be updated (I think)
15:06:04 <diablo_rojo> The days blur together a bit.
15:06:17 <mnaser> #link https://review.opendev.org/c/openstack/governance/+/767056
15:06:34 <mnaser> #link https://review.opendev.org/c/openstack/project-config/+/767057
15:06:46 <gmann> this is still failing, did not see failure yet, anything pending on repo side
15:07:04 <diablo_rojo> I will take that as a no- still more work to do.
15:07:13 <mnaser> the project-confgi change has a -1
15:07:18 <gmann> rebase issue https://review.opendev.org/c/openstack/project-config/+/767057/2/zuul.d/projects.yaml
15:07:24 <mnaser> ^ yeah
15:07:43 <diablo_rojo> Whoops.
15:07:53 <diablo_rojo> Bungled that rebase.
15:08:00 <diablo_rojo> Ill fix it today.
15:08:16 <gmann> https://review.opendev.org/q/topic:%2522retire-karbor%2522+status:open
15:08:35 <mnaser> #link https://review.opendev.org/q/topic:%2522retire-karbor%2522+status:open
15:08:37 <gmann> diablo_rojo: x/flame is not active so you can leave that open
15:08:59 <mnaser> ok cool, so we'll keep it as an action item for the next one to follow up on it
15:09:07 <mnaser> #action diablo_rojo complete retirement of karbor
15:09:11 <diablo_rojo> Yep. Sorry!
15:09:14 <mnaser> diablo_rojo/ricolin reach out to SIGs/ML and start auditing states of SIGs
15:09:25 <diablo_rojo> I did this
15:09:28 <ricolin> diablo_rojo, already make ML and etherpad out
15:09:30 <diablo_rojo> and started an etherpad
15:09:31 <mnaser> (we have a topic for this later diablo_rojo ,wanna keep it for then?)
15:09:37 <mnaser> and ricolin :>
15:09:41 <diablo_rojo> Sure?
15:09:44 <diablo_rojo> Either works
15:10:02 <mnaser> okey cool, lets keep it for the agenda discussion topic :>
15:10:08 <mnaser> mnaser drop "Add Resolution of TC stance on the OpenStackClient" from agenda < done
15:10:35 <ricolin> #link https://etherpad.opendev.org/p/2021-SIG-Updates
15:10:39 <mnaser> mnaser reach out to tripleo + other high usage job teams re: usage < done, and started talking with the tripleo team about reducing their usage, i dont have a full update yet but we are progressing, i will try and ask a public share of the progress :)
15:11:07 <mnaser> the rest is a bunch of topic drops which are all done, so lets save some time  :>
15:11:14 <mnaser> #topic Audit SIG list and chairs (diablo_rojo)
15:11:18 <mnaser> #link https://etherpad.opendev.org/p/2021-SIG-Updates
15:11:26 <diablo_rojo> So there's that etherpad^
15:11:28 <mnaser> #link http://lists.openstack.org/pipermail/openstack-discuss/2021-January/019994.html
15:12:00 <diablo_rojo> I sent it to the ML and have had a little pickup, but could use more opinions than largely just ricolin's and mine :)
15:12:17 <mnaser> tc-members: ^ please leave comments on that etherpd
15:12:53 <gmann> may be we should get the SIG chari/co-chair opinion also if we can reach out to them.
15:13:02 * dansmith is here, btw
15:13:24 <gmann> if not reachable then automatically that SIG need update either new chair or move the state
15:13:42 <mnaser> yes that si correct
15:14:44 <mnaser> #action tc-members review and leave comments on the etherpad for SIG updates
15:14:48 <diablo_rojo> Thats kind of what I was hoping
15:14:50 <ricolin> we can indeed ask each SIG to update it's chair or status if they don't reply the ML or etherpad
15:14:56 <diablo_rojo> I just didnt do direct outreach yet
15:15:28 <gmann> yeah, ML has been ignored by leaders in many cases in past like PTL case:)
15:15:31 <mnaser> ok thats fair, well i think diablo_rojo and ricolin are pushing this pretty well :)
15:15:39 <gmann> +1
15:17:18 <mnaser> next-up
15:17:20 <mnaser> #topic Gate performance and heavy job configs (dansmith)
15:17:24 <jungleboyj> ++
15:17:34 <dansmith> oh sticky
15:17:52 <dansmith> things are a lot better today than they were a week ago, which I chalk up to the tripleo jobs being dropped from neutron,
15:18:05 <dansmith> and also fungi had some cloud capacity he was using for personal bitcoin mining that he gave back to the pool
15:18:10 <gmann> yeah but still it is ling queue
15:18:13 <fungi> hah
15:18:18 <dansmith> yeah, it's still very long, but better
15:18:32 <dansmith> we have a bunch of spurious job failures which are also not helping
15:19:05 <dansmith> I also cut 25% of the time off of a devstack run,
15:19:08 <dansmith> but gmann wasn't impressed
15:19:25 <gmann> :), I am still bringing my VM up to test that.
15:19:44 <dansmith> but, I think progress is being made.. I still wouldn't rule out a syncup with the tripleo people
15:19:45 <dansmith> gmann: :)
15:19:51 <mnaser> dansmith: wow how was that done?
15:20:09 <gmann> +1 on tripleo syncup
15:20:12 <dansmith> mnaser: trying to figure out how to answer that properly :)
15:20:34 <dansmith> mnaser: I have a patch up to parallelize devstack instead of do everything in serial which saves a lot of time
15:20:39 <dansmith> five minutes to stack for me locally
15:20:50 <dansmith> and there's a lot of parallelizing left that can be done to make it faster
15:20:57 <mnaser> neaaaat
15:21:05 <dansmith> mnaser: this is just stack.sh time, not the whole devstack tempest run of course
15:21:05 <slaweq> dansmith: hi, do we have any new data how much of time are neutron jobs using now?
15:21:26 <dansmith> slaweq: we could ask clarkb to regen that, but I think it probably takes several weeks to get a noticeable number
15:21:37 <jungleboyj> dansmith:  That is cool.
15:21:38 <slaweq> dansmith: ok
15:21:40 <ricolin> dansmith, nice!
15:21:42 <dansmith> slaweq: I have taken you and your project off my dart board though :)
15:21:54 <slaweq> dansmith: good to hear that :)
15:21:57 <slaweq> thx
15:22:58 <mnaser> I will try and have an update from the tripleo team
15:23:21 <mnaser> Thanks for those patches. Have a link for them handy dansmith
15:23:21 <gmann> +1, thanks
15:23:28 <dansmith> yeah,
15:23:35 <gmann> #link https://review.opendev.org/c/openstack/devstack/+/771505/5
15:23:41 <gmann> ^^
15:23:41 <dansmith> https://review.opendev.org/c/openstack/devstack/+/771505
15:23:44 <dansmith> er, yeah
15:24:09 <dansmith> mnaser: gmann had them handy because he's busy reviewing them, I'm sure :P
15:24:13 <gmann> I will test and update on this, mainly with fresh VM as gate does fresh VM always instead of stack/unstack
15:24:18 * dansmith stops laying it on so thick
15:24:24 <gmann> dansmith: yeah :)
15:24:28 <dansmith> hehe
15:24:39 <gmann> its one of the priority open tab for me
15:24:48 <dansmith> woohoo :)
15:27:06 <mnaser> cool
15:28:02 <mnaser> #action mnaser continue to sync with tripleo team to reduce usage
15:28:14 <mnaser> #action qa team to land parallelizing changes for devstack
15:28:18 <mnaser> #topic Dropping lower-constraints testing from all projects (gmann)
15:28:56 <gmann> I am testing the l-c job with direct deps only which is what we have in requirements.txt
15:29:05 <gmann> that is one of the proposal on ML
15:29:06 <gmann> #link https://review.opendev.org/c/openstack/nova/+/772780
15:29:39 <gmann> I will update the results on ML after gate finsh
15:29:59 <gmann> that is all form me on this.
15:30:33 <gmann> may be fungi has something to update or share on this.
15:32:30 <mnaser> i guess they are afk :)
15:32:37 <mnaser> ok so we'll just update on that
15:32:40 <mnaser> #topic Open Reviews
15:32:50 <gmann> yeah, we can continue this on ML and next week we can have more data
15:33:13 <fungi> i didn't have anything new on the l-c discussion beyond what i posted to the ml, no
15:33:27 <fungi> (not afk, just lots of discussions to juggle right now)
15:34:49 <mnaser> ok, we have a few reviews that we need to finish up
15:35:08 <mnaser> can i ask tc members to carve up sometime to go over reviews
15:35:46 <gmann> two left for me as un-reviewed, i will do today(within meeting as we have time)
15:36:08 <jungleboyj> mnaser:  Will make time for that.
15:36:09 <mnaser> any changes anyone wants to call out?
15:37:10 <gmann> #link https://review.opendev.org/c/openstack/governance/+/770860
15:37:28 <gmann> Xena testing runtime, which replacing centos -> centos stream
15:37:38 <gmann> something rdo community to notice
15:37:49 <gmann> yoctozepto: ^^
15:38:59 <ricolin> +1ed
15:39:27 <mnaser> any other open discussion items?
15:41:37 <gmann> nothing from me
15:41:43 <ricolin> nothing from me
15:42:24 <jungleboyj> Nothing from me.
15:43:59 <dansmith> le no
15:44:04 <yoctozepto> gmann: thanks
15:45:48 <mnaser> #endmeeting