15:00:02 <gmann> #startmeeting tc
15:00:03 <openstack> Meeting started Thu Apr  8 15:00:02 2021 UTC and is due to finish in 60 minutes.  The chair is gmann. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:04 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:05 <yoctozepto> \o/
15:00:07 <openstack> The meeting name has been set to 'tc'
15:00:10 <gmann> #topic rollcall
15:00:12 <jungleboyj> Howdy!
15:00:15 <gmann> o/
15:00:15 <yoctozepto> \\o//
15:00:24 <dansmith> I'm here, wondering why yoctozepto is so excited about a boring old meeting
15:00:30 <diablo_rojo> yoctozepto, are you going to add slashes every week?
15:00:32 <ricolin> o/
15:00:46 <yoctozepto> diablo_rojo: yeas
15:00:51 <diablo_rojo> dansmith, its because he has a fancy new title.
15:01:04 <dansmith> :/
15:01:07 <jungleboyj> :-)
15:01:19 <yoctozepto> it's just my usual lol
15:01:21 <jungleboyj> \\\\o////
15:01:39 <gmann> :)
15:01:40 <jungleboyj> That looks like I am falling into a hole.
15:01:47 <gmann> let's start
15:02:01 <gmann> #topic Follow up on past action items
15:02:07 <yoctozepto> well, honestly, the doubled were meant to express movement :P
15:02:10 <gmann> no action item form previous meeting
15:02:20 <gmann> #topic PTG
15:02:30 <gmann> #link https://etherpad.opendev.org/p/tc-xena-ptg
15:03:10 <gmann> we have few topics not on etherpad and still have time to fill out with more
15:03:23 <jungleboyj> Wow, some interesting topics.
15:03:43 <gmann> 1 thing to update is aboput  L18
15:03:59 <gmann> 14 to 15 UTC time slot will be published live on youtube channel.
15:05:04 <gmann> we will select the topics for that slot in our agenda preparation time, basically topic interested to more audience and appropriate for live video.
15:05:20 <spotz> hehe
15:05:55 <gmann> another things for PTG is 'Kubernetes Cross Community discussion'
15:06:34 <gmann> i sent the email to k8s steering committee ML and diablo_rojo  also informed them in their  meeting
15:06:56 <gmann> i did not get any response yet, diablo_rojo did you get any confirmation or slot preference ?
15:08:40 <gmann> anyways I will check later and update etherpad after response
15:08:53 <gmann> that's all from my side on PTG.
15:09:21 <gmann> any other things to discuss for PTG?
15:10:05 <yoctozepto> not from me
15:10:16 <gmann> let's move then
15:10:17 <gmann> #topic Gate performance and heavy job configs (dansmith)
15:10:30 <dansmith> I sent an email to the list recently,
15:10:32 <diablo_rojo> gmann, I haven't seen anything yet but I can prod them along again
15:10:34 <dansmith> with some new numbers
15:10:40 <gmann> yeah
15:10:47 <dansmith> some incremental improvement for sure
15:10:48 <gmann> diablo_rojo: thanks,
15:10:52 <dansmith> neutron is still incredibly heavy
15:11:01 <dansmith> #link http://lists.openstack.org/pipermail/openstack-discuss/2021-April/021534.html
15:11:05 <jungleboyj> Well, any improvement is good news.
15:11:08 <dansmith> yup
15:11:14 <dansmith> I'm still seeing plenty of cinder fails,
15:11:20 <dansmith> which I expect are still the primary blocker
15:11:40 <noonedeadpunk> we in OSA know the "reason" of many failures, and have kind of fix, but don't have a time to make upgrade path for users yet
15:11:42 <dansmith> but life has sucked less lately, due probably to both lower load during this lull and the incremental improvements that have been made
15:11:49 <yoctozepto> kolla is bumping success rates by running away from dockerhub to quay
15:12:02 <yoctozepto> but can't really limit the amount of testing to be done
15:12:34 <gmann> yeah we should not limit testing
15:12:36 <jungleboyj> I know we have some additional Cinder fixes we are working on.
15:12:39 <belmoreira> o/ (apologies for being late)
15:12:45 <yoctozepto> also, we have happy contributions with more than 100 patchsets
15:12:46 <yoctozepto> so
15:12:47 <yoctozepto> :D
15:12:53 <gmann> belmoreira: np!
15:12:57 <noonedeadpunk> also we merged a lot of small performance improvements, that all in all should speed up builds for some percents
15:12:58 <jungleboyj> Just having to be careful with the RCs.
15:13:27 <gmann> noonedeadpunk: nice, i think you have removed the non voting jobs from gate pipeline too ?
15:13:29 <yoctozepto> stability is the primary goal
15:13:54 <noonedeadpunk> yeah, merged fix for them and made voting
15:14:01 <gmann> ok
15:14:15 <dansmith> so in summary, sounds like lots of good stuff going on :)
15:14:20 <ricolin> the arm64 job to run full tempest test on devstack is ready, but it's kind of slow, I think if will take advantage by improve overall devstack performance as dansmith is doing
15:14:24 <noonedeadpunk> eventually, switche centos 8 to centos stream :)
15:14:47 <gmann> noonedeadpunk: +1
15:15:31 <gmann> slaweq reported about post_failure due to stackviz failing on stable rocky/queen. which QA team think we can make stackviz failing mode false so that i would not fail job
15:15:42 <yoctozepto> ++
15:15:55 <gmann> i remember i hd patch up but somehow that is lost
15:16:01 <gmann> ricolin: +1
15:16:22 <gmann> dansmith: i think it is time to move devstack default to parallel mode also
15:16:28 <dansmith> gmann: \o/
15:16:30 <gmann> we have wallaby branch setup
15:16:36 <yoctozepto> yes, we are "safe" now
15:16:38 <dansmith> do I need to rebase that?
15:16:45 <gmann> let me check
15:16:48 <dansmith> gmann: I'd really also like to see the OCaaS thing merged,
15:16:49 <jungleboyj> dansmith:  Is there any concerns with that introducing new race conditions?
15:16:52 <dansmith> which is hugely helpful
15:16:53 <yoctozepto> paste-da-link
15:17:04 <gmann> #link https://review.opendev.org/c/openstack/devstack/+/783311
15:17:09 <yoctozepto> thanks
15:17:21 <dansmith> jungleboyj: with parallel? we have been running it on a number of jobs so far and I haven't found any problems
15:17:33 <gmann> dansmith: rebase not needed, yoctozepto and I will review after meeting
15:17:35 <yoctozepto> jungleboyj: the design was pretty solid
15:17:37 <jungleboyj> dansmith: ++ Ok.  Seeing that now as I look at the patch.
15:17:43 <dansmith> jungleboyj: so I mean.. it's parallel, so sure, but..
15:17:44 <dansmith> gmann: thanks
15:18:00 <ricolin> +1ed
15:18:17 <gmann> we have few jobs data also with parallel mode, tempest-full-parallel and few in nova gate also
15:18:37 <gmann> anyways its start of cycle so let's try that
15:18:50 <yoctozepto> yeah, you can approve already I guess
15:19:33 <gmann> anything else on gate performance ?
15:19:38 <dansmith> not from me
15:19:46 <yoctozepto> neither here
15:19:55 <gmann> ok, let's move then. thanks dansmith
15:19:57 <jungleboyj> I'm good.
15:20:01 <gmann> #topic PTL assignment for Xena cycle leaderless projects (gmann)
15:20:10 <gmann> we have merged the keystone patch for DPL model too
15:20:20 <jungleboyj> \o/
15:20:27 <gmann> so we are all done for leader assignment for Xena cycle
15:20:33 <yoctozepto> :D
15:20:35 <ricolin> :)
15:20:41 <gmann> no retirement of any project in this cycle
15:20:42 <ricolin> finally
15:21:02 <gmann> I will remove this from next week meeting.
15:21:09 <yoctozepto> ++
15:21:13 <gmann> #action gmann to drop 'PTL assignment for Xena cycle' topic from agenda
15:21:32 <gmann> #topic Election for one Vacant TC seat (gmann)
15:21:44 <gmann> I think we have two candidate for election
15:21:53 <yoctozepto> yeas
15:21:59 <gmann> #link https://governance.openstack.org/election/
15:22:15 <gmann> with ~8 hrs to go for nomination end
15:22:34 <fungi> yep
15:22:38 <dansmith> who are the two?
15:22:40 <gmann> no action item for us on this until election official post the election result.
15:22:47 <fungi> spotz and flwang
15:22:52 <gmann> Amy Marrich (spotz) Feilong Wang (flwang)
15:22:54 <jungleboyj> Yep.
15:22:54 <dansmith> ack
15:23:20 <fungi> we'll get the civs poll put together and ballots sent out around/after 00:00 utc
15:23:27 <ricolin> fungi, thx
15:23:31 <jungleboyj> ++
15:23:55 <gmann> fungi: and as you mentioned in email, there will be only new candidates in poll for 1 seat right ?
15:23:58 <gmann> just confirming
15:24:06 <fungi> yes
15:24:10 <gmann> perfect
15:24:25 <fungi> two candidates (so far) vying for one available seat on tge tc
15:24:31 <fungi> s/tge/the/
15:24:46 <gmann> ok, thanks fungi for taking care of election.
15:24:51 <fungi> yw
15:25:06 * yoctozepto learns new words with fungi
15:25:17 <gmann> #topic Community newsletter: "OpenStack project news" snippets
15:25:28 <gmann> #link https://etherpad.opendev.org/p/newsletter-openstack-news
15:25:38 <gmann> we have good number of items to publish
15:26:12 <gmann> diablo_rojo: ^^ we can go ahead with this if not yet informed to foundation staff
15:26:44 <diablo_rojo> Yeah I think we are good here for now.
15:26:52 <gmann> ok
15:27:05 <diablo_rojo> I am the one that writes the openstack section so consider the foundation informed lol
15:27:21 <diablo_rojo> (with the help of fungi and ttx)
15:27:50 <gmann> +1
15:27:52 <gmann> #action gmann to drop the 'Community newsletter' topic from agenda
15:28:02 <gmann> #topic Open Reviews
15:28:12 <gmann> #link https://review.opendev.org/q/project:openstack/governance+is:open
15:28:20 <yoctozepto> empty!
15:28:21 <gmann> zero open review.
15:28:24 <gmann> great work
15:28:30 <yoctozepto> :D
15:28:31 <jungleboyj> :-)
15:28:37 <fungi> governance review inbox zero success
15:28:51 <gmann> yeah
15:28:53 <yoctozepto> gotta get this tattoed
15:29:02 <yoctozepto> tattooed*
15:29:24 <gmann> last thing to update form me is about vice chair, yoctozepto is vice chair for this term. also thanks ricolin for showing interest too.
15:30:09 <ricolin> gmann, NP, IMO more people showing their interest the better:)
15:30:16 <yoctozepto> :-)
15:30:19 <gmann> yeah, +1
15:30:21 <jungleboyj> yoctozepto: Congrats!  Thanks to ricolin as well.
15:31:00 <gmann> that's all form me today, anything else to discuss?
15:31:04 <ricolin> yeah, Congrats yoctozepto!:)
15:31:22 <yoctozepto> thank you all
15:31:51 <spotz> Congrats yoctozepto
15:32:56 <gmann> if nothing else, let's close.
15:32:58 <gmann> thanks everyone for joining.
15:33:03 <gmann> #endmeeting