15:00:17 <gmann> #startmeeting tc
15:00:18 <openstack> Meeting started Thu Apr 29 15:00:17 2021 UTC and is due to finish in 60 minutes.  The chair is gmann. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:19 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:21 <openstack> The meeting name has been set to 'tc'
15:00:29 <gmann> #topic roll call
15:00:32 <gmann> o/
15:00:36 <belmoreira> o/
15:00:38 <mnaser> o/
15:00:38 <yoctozepto> o/
15:00:57 <TheJulia> o/
15:02:31 <gmann> let's start
15:02:40 <gmann> #link https://wiki.openstack.org/wiki/Meetings/TechnicalCommittee#Agenda_Suggestions
15:02:44 <gmann> today agenda ^^
15:02:56 <gmann> #topic Follow up on past action items
15:03:15 <gmann> no action item form last meeting #link http://eavesdrop.openstack.org/meetings/tc/2021/tc.2021-04-15-15.00.html
15:03:24 <gmann> #topic PTG
15:03:53 <gmann> we have captured the discussion in PTG etherpad #link https://etherpad.opendev.org/p/tc-xena-ptg
15:04:18 <gmann> I have also summarized the discussion on ML http://lists.openstack.org/pipermail/openstack-discuss/2021-April/022120.html
15:04:20 <jungleboyj> o/
15:04:36 <gmann> if anything I missed, feel free to add it
15:04:56 <spotz> o/
15:05:02 <gmann> anything on PTG things?
15:05:39 <spotz> Not from my sidee
15:05:52 <gmann> ok, I will remove this topic for next weekly meeting onwards.
15:06:02 <gmann> #action gmann drop PTG topic from agenda
15:06:07 <gmann> #topic TC tracker for Xena cycle (gmann)
15:06:27 <gmann> as discussed in PTG, I have created the Xena cycle tracker etherpad
15:06:29 <gmann> #link https://etherpad.opendev.org/p/tc-xena-tracker
15:06:45 <gmann> I added all the working item with assignee
15:07:08 <gmann> one item I forget to ask assignee during PTG is 'OpenStack to a yearly release cycle'
15:07:15 <gmann> item #11 in etherpad
15:07:30 <gmann> I would like to ask volunteer for this.
15:09:17 * jungleboyj nominates TheJulia ;-)
15:09:30 <TheJulia> I have an absurd number of items on my plate, fwiw
15:09:38 <jungleboyj> I was kidding.
15:09:48 <jungleboyj> gmann:  What were the next items for that?
15:09:59 <spotz> More seriously maybe one person for the change and one person against the change?
15:10:15 <gmann> there are two Ai we collected
15:10:20 <gmann> 1. Reach out to Project team + operators about feedback via ML.
15:10:20 <gmann> 2. Encourage "Operation Docs and Tooling" SIG to add upgrades and operational education guideline
15:10:21 <TheJulia> the problem is it becomes an argument of "who is the loudest winds"
15:11:05 <gmann> we did not conclude to change it but more about getting more feedback and improve the education bits
15:11:06 <jungleboyj> Ok.  I think 1 is the most important there as we have feedback from a couple of people.  Would like to get more input.
15:11:18 <gmann> yeah
15:11:26 <yoctozepto> I like this version with "winds"
15:11:50 <gmann> anyways I will keep it open in case anyone take this.
15:12:00 <jungleboyj> ++
15:12:05 <gmann> mnaser: as you missed the last hr of PTG. we distributed the working item to all the TC members with having each TC member taking at least one item.
15:12:14 <spotz> I was more for making sure both sides were represnted to make sure the information was fully collected
15:12:16 <TheJulia> jungleboyj: ++ to feedback
15:12:32 <gmann> mnaser: and one I added for you is 'Stable core team process change' L34 in https://etherpad.opendev.org/p/tc-xena-tracker
15:12:36 <jungleboyj> spotz:  ++
15:12:40 <mnaser> fair enough :) thanks for putting my name down
15:12:47 <gmann> mnaser: hope that is ok, if not I can help jungleboyj on this
15:12:54 <mnaser> nope, thats okay for me
15:13:00 <gmann> cool, thanks
15:13:32 <gmann> and for tracking, I am thinking to keep checking status in every alternate weekly meeting.
15:13:41 <gmann> is that ok for all?
15:14:03 <jungleboyj> That makes sense.
15:14:08 <yoctozepto> ok for me
15:14:16 <gmann> weekly check might be very frequent so i thought once in a 2 week is reasonable time in term of progress also
15:14:26 <spotz> DO we have a way to get all PTL email addresses?
15:14:37 <gmann> yeah, in project yaml
15:14:53 <spotz> Ok thanks
15:14:55 <gmann> spotz: this one #link https://governance.openstack.org/tc/reference/projects/
15:15:09 <gmann> each project has PTL email as mandatory and IRC as optional
15:15:29 <spotz> perfect!
15:16:22 <mnaser> that wfm wrt alternate meeting
15:16:28 <gmann> ok
15:16:44 <gmann> I think we should add email id for SIG chair/co-chair too #link https://governance.openstack.org/sigs/
15:17:27 <gmann> I will add it in case SIG wiki page does not have or old info
15:17:46 <gmann> #action gmann to add SIG chair/co-chair info in sig doc site
15:17:57 <gmann> ok, anything else on Xena tracker ?
15:18:33 <yoctozepto> not from me
15:18:33 <gmann> ok, let's move
15:18:37 <gmann> #topic Gate performance and heavy job configs (dansmith)
15:18:51 <gmann> dansmith updated that he might not be available today.
15:19:16 <gmann> one thing to inform about dropping Bionic support from devstack (Xena onwards)
15:19:41 <gmann> #link https://review.opendev.org/c/openstack/devstack/+/788754
15:19:58 <gmann> we can reduce the maintenance of fixing bionic bugs that way
15:20:19 <gmann> but there are few jobs running on Bionic which needs to be migrated to focal first.
15:20:33 <gmann> anything else on gate check?
15:20:35 <gmann> yoctozepto: ?
15:20:42 <yoctozepto> do we have a list of those bionic jobs?
15:21:02 <gmann> yoctozepto: I need to fetch all form here #link http://logstash.openstack.org/#/dashboard/file/logstash.json?query=message:%5C%22Failed%20to%20start%20rtslib-fb-targetctl.service%5C%22
15:21:15 <gmann> one is cinder-plugin-ceph-tempest-mn-aa
15:21:19 <yoctozepto> hah, that's one way
15:21:27 <gmann> and in octavia also
15:21:45 <gmann> I will put this on ML and then we can wait for bionic drop patch
15:22:05 <yoctozepto> well, I can see nova too
15:22:14 <gmann> that is in gate to merged
15:22:20 <yoctozepto> ack
15:22:23 <gmann> #link https://review.opendev.org/c/openstack/nova/+/778885/10
15:22:49 <gmann> basically finding via 'rtslib-fb-targetctl' failure but there might be few more.
15:23:43 <gmann> I am more concern on 3rd party CI where migration to new distro happens very late.
15:24:02 <gmann> but we have to trigger them at some point
15:24:26 <yoctozepto> perhaps this cycle precisely
15:24:31 <gmann> yeah
15:24:35 <yoctozepto> as we simply don't support bionic at this point
15:24:38 <yoctozepto> so it's only by luck
15:24:41 <yoctozepto> that those pass
15:24:49 <gmann> anyways let's put this on ML and see if project need more time.
15:24:55 <yoctozepto> ok
15:25:01 <gmann> true, and as this is start of cycle, it is perfect time.
15:25:21 <gmann> let's move next
15:25:23 <gmann> #topic TC's context, name, and documenting formal responsibilities (TheJulia)
15:25:33 <gmann> we have on topic from TheJulia
15:25:37 <gmann> TheJulia: go ahead
15:26:11 * yoctozepto asked on #openstack-infra if we can have a better way to list the bionic jobs
15:26:24 <TheJulia> Greetings, after the discussion during the ptg last week, I'm worried that the TC has has essentially dropped the responsibilites that came with the user committee and is also seeming to not want to recognize the reality that as leaders, non-technical questions must be part of the discussion.
15:26:53 <TheJulia> I honestly feel, the name is now out of sync, and I realize the fear of bylaws changes is a concern, but I don't believe the board would object if the TC passed a resolution to amend it's name
15:27:43 <gmann> i see, what all responsibilities from UC ?
15:28:16 <gmann> I remember we excluded few of them like local user groups reach-out/management etc
15:28:25 <TheJulia> Well, so that is an interesting conundrum aside from the implication of representation of the users of the software, much of the formal responsibilities seems not to be documented, at least in bylaws
15:28:47 <TheJulia> so a single unified list needs to be accessible as well
15:28:55 <jungleboyj> ++
15:28:56 <TheJulia> even if it is just for consensus building amongst the committee
15:29:04 <spotz> ++
15:29:19 <TheJulia> The bottom line is time has changed and evolved, so must practices and expectations.
15:29:28 <jungleboyj> I think it is important that the Users are represented but don't really know what that entails.  :-)
15:29:28 <yoctozepto> agreed
15:29:34 <gmann> yeah i agree that, I think we merged few of them. if not then we should add in #link https://governance.openstack.org/tc/reference/role-of-the-tc.html
15:29:36 <jungleboyj> TheJulia: ++
15:29:46 <belmoreira> +1
15:29:47 <jungleboyj> gmann: ++
15:30:44 <gmann> we merged the charter from uc, i remember that
15:31:25 <gmann> #link https://governance.openstack.org/tc/reference/user-committee-charter.html
15:32:31 <TheJulia> It seems like there seems to be some agreement that work in this area needs to be done to clean up/consolidate. Motivation to merge doesn't tell me what the responsibilities were much less what the committee now believes it should be doing.
15:32:48 <jungleboyj> Agreed.
15:32:59 <spotz> Looking at the TC role page it doesn't seem to cover all that we need to do since the Foundation isn't just OpenStack anymore
15:33:06 <TheJulia> Again, times change, and so on and so forth
15:33:08 <gmann> yeah
15:33:22 <gmann> we should add those resp in TC role doc to make very clear #link https://governance.openstack.org/tc/reference/role-of-the-tc.html
15:34:05 <TheJulia> One thing, a high level index on that might be useful since it is an overflow of words to have to skim it :)
15:34:46 <spotz> As I mentioned during the PTG, to all intent and purpose we are not the Governing Board of OpenStack overseeing the project not just the technical side
15:34:50 <TheJulia> That is really all, and I would encourage the TC to consider addressing it's name. Again, I don't think from a board member pov, that will be much of an issue since there will be a round of bylaws cleanup due to the foundation rename this year
15:34:57 <spotz> not=now
15:34:58 <gmann> we also need to do more work on UC repo too, merging it in tc or so
15:34:58 <TheJulia> So it may actually be a *good* time
15:35:41 <jungleboyj> Yeah.  I think it is a good time.
15:35:42 <TheJulia> So, I've voiced my concerns, thanks for listening everyone!
15:35:45 <gmann> TheJulia: agree, thanks for raising it which is very imp
15:35:52 <jungleboyj> TheJulia: Thank you for raising.
15:36:36 <gmann> I will add AI for me to start adding those in our doc or repo merge etc
15:37:03 <yoctozepto> TheJulia: thanks
15:37:08 <ricolin> sorry I'm late, was in another meeting call
15:37:32 <gmann> #action gmann to start updates to consume/merge UC responsibility in TC
15:37:44 <jungleboyj> Sounds good.
15:37:53 <spotz> +1
15:38:16 <belmoreira> +1
15:39:06 <gmann> and as we have many user facing faces in TC it will be much easy for us to engage the users/feedback/circulating it to projects
15:39:18 <gmann> anything else on this topic?
15:40:10 <gmann> ok, moving next then
15:40:11 <gmann> #topic Open Reviews
15:40:19 <gmann> #link https://review.opendev.org/q/project:openstack/governance+is:open
15:40:41 <gmann> we have 4 formal-vote and 2 documentation changes open
15:41:26 <yoctozepto> you have my votes on everything
15:41:55 <spotz> I wasn't sure if we shhould vote so was just reviewing
15:41:56 <gmann> spotz: in case you missed to add Recall-Vote in this ? i saw only code review +1 from your. https://review.opendev.org/c/openstack/governance/+/786942
15:42:05 <gmann> yoctozepto: great, thanks
15:42:29 <gmann> spotz: ok, you can Recall-Vote so that we can merge them as per change type.
15:42:54 <yoctozepto> Rollcall-Vote*
15:42:59 <gmann> we have different set of criteria on number of vote/time to be open or so
15:43:02 <spotz> gmann adding votes
15:43:05 <yoctozepto> though it's hard to mistake anyhow
15:43:08 <gmann> cool thanks
15:43:24 <gmann> yoctozepto: :) i always mistype that :)
15:43:46 <yoctozepto> no problem
15:43:48 <yoctozepto> here to help :-)
15:44:11 <gmann> ok, that's all form me. anything else to discuss today ?
15:44:19 <fungi> catching up, but remember there were no new responsibilities which "came with the uc," the uc was defunct and the most effective way to let it go without an expensive rewrite of parts of the foundation bylaws was to say the tc was also the uc... but the bylaws do not actually give the uc any explicit responsibilities, so the "uc responsibilities" are whatever the tc-members want them to be
15:44:29 * jungleboyj will do code reviews here when I am not in two meetings at once.  :-)
15:45:05 <fungi> if tc members want there to be specific uc-oriented responsibilities then they're free to take those on
15:45:13 <yoctozepto> good point, fungi
15:45:21 <gmann> fungi: agree, as we merged both entity now, we can reflect them in tc-role doc too
15:45:39 <yoctozepto> though TheJulia is right that we should strive to cover that role as well to have a healthier community
15:45:43 <gmann> but i remember we decided not to take marketing stuff like user groups reachout or so
15:45:58 <jungleboyj> Right.  I think part of the reason this is important is really, OpenStack is transitioned to a period of more use than development.
15:46:24 <spotz> The problem gmann is that if we don't there's no one else who will. So we need to decide if that's ok
15:46:27 <jungleboyj> As a leadership body we need to keep that in mind.
15:46:27 <ricolin> jungleboyj, true
15:46:28 <gmann> let's start adding the things and see if something new comes up or its just things we should reflect in our doc too
15:47:02 <fungi> "marketing stuff like user groups reachout" was a responsibility the old uc claimed it had, but ultimately the foundation staff were taking care of most of that for them
15:47:07 <gmann> spotz: that part is moved to foundation side, at least that is what i know from uc-tc merge discussion
15:47:29 <spotz> ok
15:47:43 <gmann> fungi: indeed, that is what i think you or ttx  mentioned that time too
15:47:48 <TheJulia> I think contextually, it is lost on many, the foundation staff responsibilities are different than they were even just two years ago.
15:48:51 <TheJulia> It is easy for people to get stuck in that context, and not move forward, so without re-evaluating and coming back to "what are the responsibilities of x group", then that continue which ultimately may hinder other aspects or cause whole areas to not receive attention.
15:49:49 <yoctozepto> ok, gmann already put an action on himself to collect those extra reqs from uc that make sense, and we will discuss them in the following meetings
15:50:07 <yoctozepto> not much to dwell on today unless we have concrete ideas already
15:50:17 <fungi> keep in mind i'm not disagreeing that the tc might want to consider taking on some of that, just pointing out the "old uc" didn't really do it either, convincing community volunteers to oversee those sorts of things isn't easy
15:50:18 <gmann> yeah, let's discuss each resp one by one and discuss.
15:50:52 <yoctozepto> need to keep in mind to deliver those that the community would care about
15:50:56 <yoctozepto> and not just art for art
15:51:02 <gmann> yeah, once we have exact list of what UC was doing and TC need to adopt then we can have concrete discussion
15:51:22 <TheJulia> yoctozepto: even if it is just a call or encouragement, then it can go very far.
15:51:39 <yoctozepto> it can indeed
15:52:04 <fungi> you probably want to follow up with the foundation staff, since they were the folks doing those things
15:52:12 <gmann> along with that we need to cleanup UC repo also which was pending item also #link https://github.com/openstack/governance/blob/master/reference/user-committee-repos.yaml
15:52:20 <gmann> fungi: +1
15:52:31 <yoctozepto> like, if it was not for you, TheJulia, we would probably be not discussing this now at all ;-)
15:52:37 <yoctozepto> thanks for the gentle nudge
15:52:44 <TheJulia> :)
15:52:46 <gmann> and i am sure during those repo cleanup we will get more points/responsibility
15:53:05 <yoctozepto> ++
15:53:08 <gmann> anyways, I am adding this in our Xena tracker too in case we forget about this even i added AI
15:53:14 <yoctozepto> ++
15:53:25 <spotz> ++
15:53:26 <TheJulia> bottom line, the repos are hard to find data. Indexing is a huge issue on how to just find information. It is a classic problem though :(
15:53:29 <jungleboyj> Makes sense.
15:53:55 <gmann> we have 7 min left, any other topic.
15:55:36 <gmann> if nothing let's close meeting.
15:55:44 <gmann> thanks everyone for joining
15:55:46 <gmann> #endmeeting