15:00:10 <gmann> #startmeeting tc
15:00:11 <jungleboyj> o/
15:00:11 <openstack> Meeting started Thu May  6 15:00:10 2021 UTC and is due to finish in 60 minutes.  The chair is gmann. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:12 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:14 <gmann> #topic Roll call
15:00:14 <openstack> The meeting name has been set to 'tc'
15:00:17 <gmann> o/
15:00:17 <ricolin> o/
15:00:23 <mnaser> o/
15:00:23 <jungleboyj> Happy Thursday.
15:01:23 <gmann> let's start
15:01:30 <belmoreira> o/
15:01:35 <gmann> #link https://wiki.openstack.org/wiki/Meetings/TechnicalCommittee#Agenda_Suggestions
15:01:39 <gmann> today agenda ^^
15:01:51 <gmann> #topic Follow up on past action items
15:01:51 <dansmith> o/
15:02:01 <gmann> gmann drop PTG topic from agenda
15:02:02 <spotz> o/
15:02:04 <gmann> done
15:02:12 <gmann> gmann to add SIG chair/co-chair info in sig doc site
15:02:21 <gmann> I have not done this, will push patch today
15:02:28 <gmann> I will continue this as AI
15:02:29 <jungleboyj> ++
15:02:33 <gmann> #action gmann to add SIG chair/co-chair info in sig doc site
15:02:39 <gmann> gmann to start updates to consume/merge UC responsibility in TC
15:02:49 <gmann> I have added this in Xena tracker etherpad
15:03:07 <gmann> so we can track the work there instead of Action
15:03:43 <gmann> L64 in https://etherpad.opendev.org/p/tc-xena-tracker
15:03:56 <gmann> Gate performance and heavy job configs (dansmith)
15:04:07 <dansmith> things have seemed pretty good lately
15:04:12 <gmann> +1
15:04:15 <diablo_rojo> o/
15:04:18 <jungleboyj> \o/
15:04:27 <spotz> +1
15:04:30 <dansmith> I dunno about others, but I've been surprised with how quick things have gone through, how few spurious failures I've seen
15:04:43 <jungleboyj> dansmith:  I have noticed that as well.  Been better.
15:04:52 <dansmith> cool
15:04:58 <gmann> nice
15:05:17 <yoctozepto> o/
15:05:48 <spotz> All the ones I've been following have been pretty fast
15:06:31 <gmann> anything else on this topic?
15:07:26 <fungi> opendev's zuul is spending a lot less time at full capacity in recent weeks
15:07:34 <dansmith> not from me, which is a good sign :)
15:07:43 <jungleboyj> :-)  ++
15:07:44 <fungi> not sure if it's a cause or an effect, but it's likely related one way or the other
15:08:14 <jungleboyj> Either way it is good.
15:08:23 <gmann> yeah.
15:08:45 <gmann> let's move next and keep monitoring it
15:08:51 <jungleboyj> ++
15:09:25 <gmann> I will rename this topic as 'Gate health check' from next meeting which is what we discussed in PTG
15:09:34 <gmann> #topic Project Health checks (gmann)
15:09:52 * dansmith agrees with the topic name change
15:09:53 <gmann> this is continuation of discussion from what we left in PTG
15:09:57 <gmann> L471 https://etherpad.opendev.org/p/tc-xena-ptg
15:10:51 <gmann> one open things we have is whether we should continue with TC liaisons mechanism or find new way to check health/reachout the project team
15:11:53 <gmann> one suggestion from ricolin was to automate the contribution stats check which can give us the health checks for  projects
15:12:20 <gmann> any other suggestion?
15:12:32 <ricolin> also belmoreira, and I volunteer to take that action
15:12:38 <ricolin> volunteered
15:12:41 <gmann> yeah.
15:12:45 <dansmith> aren't they two different things?
15:13:01 <ricolin> dansmith, yes, two different indeed
15:13:07 <dansmith> meaning, whether or not to keep the liaisons is a thing.. not sure they're really helping us monitor health currently,
15:13:16 <dansmith> and then another is trying to automate some health metric
15:13:41 <gmann> TC liaisons was started for health checks + reachout to project team
15:13:44 <dansmith> both seem good to me (dropping liaisons which I think don't really do much) and anyone trying to mine data for any reason :)
15:13:51 <dansmith> I know it was, but that's not really happening right?
15:13:59 <gmann> yeah, agree
15:14:22 <spotz> Also outreach before elections will tell us a bit about health but potentially too late
15:15:04 <gmann> +1, and if we see patches not merging in projects repos means we can just reachout to team if they are active or need help or so
15:15:31 <belmoreira> +1
15:15:38 <jungleboyj> Yeah, I think adding the data mining is an important first step.
15:15:49 <gmann> for 1st part health checks, we can wait for automate things
15:16:23 <gmann> but as TC liaisons which is supposed to reachout to projects team what next we can try ?
15:16:35 <gmann> main goal here is to engage project team with TC
15:16:38 <dansmith> have we spent as much time reaching out to projects we're liaison for, as we have maintaining the list of liaisons?
15:17:01 <dansmith> the latter has happened twice since I showed up, and it's the most liaison-related activity I've seen (obviously I don't see what people are doing, but just guessing)
15:17:31 <gmann> agree, this is not working so definitely need change
15:18:01 <gmann> but before we remove the liaison things we should have some other way in place
15:18:50 <jungleboyj> dansmith:  You aren't alone.
15:19:14 <jungleboyj> Thought we did have an activity at some point last year where we had a coordinated effort for liaisons to reach out.
15:19:40 <dansmith> gmann: I don't think we need a replacement for something that brings no value, but it's also only costing us maintaining the useless list, so if having it makes us feel better, then that's fine too I guess :)
15:21:14 <gmann> sure, if any new way also goes same way 'no value' then yes I agree with you to not continue that
15:22:10 <belmoreira> I agree with dansmith
15:22:23 <belmoreira> also, if we detect that a project is not healthy we can find a TC volunteer to interact with the project
15:22:26 <gmann> one idea i have is to conduct PTL+TC meeting (audio/video) monthly or once in a 2 month and ask them about their feedback on us or anything they would like to see TC doing
15:22:35 <jungleboyj> belmoreira:  ++  That makes sense.
15:22:46 <gmann> belmoreira: yeah for project health that works fine/
15:22:46 <fungi> at one point it was suggested that the liaisons give teams specific points of contact on the tc they can reach out to, but i'm unconvinced that's any easier than just reaching out to the tc as a whole, or random tc members
15:22:49 <ricolin> One way we can try is to have liaison for projects on demand, like right now, we might need someone to check with sahara for potential no maintainer left or check with DPL model projects for one cycle to see if they're doing okay. The only down side for this is we can't really find out when a project goes from healthy to unhealthy
15:22:56 <spotz> It sounds like what ricolin and belmoreira have planned is the first part of a new plan. It's worth a try and there's nothing wrong with just getting rid of something not working
15:23:06 <gmann> but to engage project teams more with TC we need some reachout mechanism
15:23:12 <jungleboyj> fungi:  ++
15:23:13 <dansmith> fungi: finding that list (or even knowing it exists) is probably much harder than coming here and asking something :)
15:23:19 <fungi> agreed
15:23:47 <spotz> ++
15:23:49 <gmann> yeah.
15:23:58 <jungleboyj> spotz:  I agree.
15:24:16 <ricolin> gmann, +1
15:24:37 <gmann> for unhealthy projects I think we have agreed way of what ricolin and belmoreira is planning to do.
15:25:01 <gmann> for reachout/engage healthy projects with TC, does PTL+TC meeting idea fine?
15:25:23 <dansmith> gmann: are you talking about a big meeting where all the PTLs come at once?
15:25:23 <gmann> I feel once in a 2 month should be enough
15:25:31 <gmann> yeah
15:25:39 <gmann> or whoever want to join
15:25:52 <gmann> I am sure not all will be there at same time but if they do yes
15:25:58 <spotz> And should we return to imperson go back to having the TC session in the Forum
15:26:01 <gmann> or we can divide into slots
15:26:08 <dansmith> IMHO, that adds something to their calendar for a checkin, which is pretty inefficient, and is likely to be ignored by most.. we have these meetings every week that they can join if they have concerns
15:26:15 <ricolin> gmann, like a mid-cycle meeting?
15:26:32 <jungleboyj> dansmith:  Right.  Everyone is in meeting burnout as it is.
15:26:39 <dansmith> right, especially right now
15:27:03 <dansmith> maybe we could do something like that each time before a PTG in the week leading up to it so we don't compete
15:27:27 <dansmith> but once every two months seems too often to me for a heavyweight meeting, but that's just MHO
15:27:44 <dansmith> mostly thinking about how I as a PTL would consider that obligation in my current calendar load
15:28:36 <dansmith> I feel like I'm being so negative today, my apologies gmann  :)
15:28:40 <ricolin> It make sense to me to at least reach out one month before cycle election
15:28:42 <gmann> ok, twice in a cycle. like once in the mid of cycle and one during end like before PTG or so
15:29:11 <gmann> +1, 'reach out one month before cycle election' this can solve our election promotion also
15:29:28 <dansmith> that periodicity seems better for sure
15:29:32 <jungleboyj> I think that sounds reasonable.
15:29:44 <gmann> dansmith: no, its been productive discussion which is what we need otherwise we end up trying no-value-addition things :)
15:30:47 <spotz> Sounds good
15:31:00 <gmann> ok, let's try periodic one with slot or so. I will prepare something on time/slot/agenda etc and we can continue discussion in next meeting..
15:31:24 <jungleboyj> gmann:  ++
15:31:42 <ricolin> +1
15:31:48 <gmann> #action gmann to prepare the etherpad for draft proposal of PTL+TC periodic meeting
15:32:11 <gmann> anything else on this?
15:32:31 <ricolin> should encourage SIG chair to join this meeting if possible:)
15:32:45 <gmann> yeah, good point.
15:32:53 <belmoreira> ricolin that's a good idea
15:32:55 <ricolin> also popup
15:32:57 <gmann> ack
15:33:27 <gmann> we should merge the PTL word with PTL+SIG-chair+popup-team-chair
15:33:45 <jungleboyj> Community leaders
15:33:50 * diablo_rojo is failing at doing two meetings at once
15:33:54 <gmann> +1, better idea
15:34:13 <gmann> ok let's move next
15:34:15 <gmann> #topic TC's context, name, and documenting formal responsibilities (TheJulia)
15:34:15 <spotz> Yeah
15:34:30 <gmann> we discussed about it in previous week meeting
15:34:59 <gmann> and agreed to add the 'Merging/documenting the UC responsibility in TC and docs.' which i added in Xena tracker also
15:35:02 <gmann> L64 #link https://etherpad.opendev.org/p/tc-xena-tracker
15:35:30 <diablo_rojo> For the record, I do think renaming is a good idea (particularly with the changes over the last year merging the UC + TC).
15:35:38 <diablo_rojo> Since I wasn't here last week to voice that opinion.
15:35:45 <gmann> +1
15:36:01 <gmann> yeah that is why i kept this for this week too. in case you missed last week meeting
15:36:02 <dansmith> I don't, FWIW
15:36:22 <diablo_rojo> dansmith, even though the TC is not just the TC anymore?
15:36:35 <dansmith> even though :)
15:36:51 <yoctozepto> are we aiming for TC still?
15:36:56 <fungi> i think that came up when i was at an appointment... is the concern that people are confused about the tc being the governance body for the openstack project?
15:36:57 <yoctozepto> The Committee
15:37:01 <yoctozepto> :D
15:37:11 <diablo_rojo> dansmith, I assume you explained why last week and I should read those logs?
15:37:11 <gmann> sorry i miss read the diablo_rojo ' I do think renaming is a good idea '
15:37:26 <gmann> I do not think renaming we need
15:37:36 <dansmith> diablo_rojo: no I wasn't here either and didn't get to opine, hence doing it here
15:37:44 <diablo_rojo> Ahhh got it dansmith :)
15:37:52 <gmann> we still doing same what we used to do + having more user facing members
15:38:14 <diablo_rojo> gmann, yes, but its a mindset change? That would be good to have reflected in the name?
15:38:17 <jungleboyj> Regardless of name we need to act more like a community leadership group and not just technical leaders.
15:38:17 <yoctozepto> why not rename though? That makes sense imho
15:38:19 <gmann> I feel merging the doc which can convey we do user facing discussion + technical things
15:38:30 <yoctozepto> jungleboyj ++
15:38:34 <jungleboyj> diablo_rojo:  ++
15:38:41 <fungi> the makeup of the tc didn't change when the uc was "folded into" it (for bookkeeping reasons, so the foundation bylaws wouldn't need editing to reflect that the uc is gone)
15:38:50 <diablo_rojo> If we want to keep user focused members a name change might be good as 'Technical Committee' is a bit narrowly focused.
15:38:53 <fungi> the tc has always had representatives of openstack users on it
15:39:12 <jungleboyj> Agreed.
15:39:13 <gmann> true
15:39:18 <fungi> so i don't see it as a new situation
15:39:31 <jungleboyj> Honestly, since joining the TC I haven't found it to be an appropriate name.
15:39:32 <gmann> that is why my point no structural change now what we used to have
15:40:02 <ricolin> agree with fungi's point
15:40:02 <yoctozepto> perhaps then we can rename to fix this old issue
15:40:03 <fungi> the tc engaged in plenty of "non-technical" activities even long before i was on it, for the record
15:40:11 <gmann> if TC is not appropriate name that is since starting then not with uc + tc merge
15:40:31 <fungi> but the name is taken from the foundation bylaws
15:40:35 <diablo_rojo> Yeah fungi that makes sense. Simultaneously, if we no long have a user focused committee, it might be better to rename and be more inclusive?
15:40:38 <yoctozepto> ok, so rename for a different reason
15:40:38 <gmann> but what value a rename will add?
15:40:43 <fungi> because it was described as such when the bylaws were written
15:40:54 <gmann> +1 on bylaw point
15:41:01 <yoctozepto> gmann: sanity :-)
15:41:02 <dansmith> gmann: right, I don't see what it will add.. our users are technical :)
15:41:16 <gmann> yoctozepto: it cost a lot just for sanity :)
15:41:25 <diablo_rojo> I think another part of the idea of doing a rename now was that if other bylaws will be changed with the foundation rename then it might be good to do it all at once to save cost if we decide to do it later?
15:41:36 <gmann> dansmith: exactly, only developers are not considered as technical :)
15:41:42 <fungi> from the perspective of the bylaws, there is an openstack technical committee and an openstack user committee (and for simplicity, the "user committee" is merely made up from a selected subset of tc members these days)
15:41:49 <yoctozepto> well, we are used to paying off TECHNICAL debts :-)
15:42:15 <dansmith> and honestly, this kind of bikeshedding on naming for inclusiveness is really not a useful activity for us to spend time on, yet we seem to do a lot of this kind of thing.. which I guess means we should rename to "The Naming Committee"
15:42:34 <yoctozepto> oh come on
15:42:35 <fungi> yeah, if the idea is to propose an adjustment to the bylaws, then that probably needs to be the topic, "renaming the tc" is really only a small part of it
15:42:36 <jungleboyj> *sad trombone.wav*
15:42:39 <dansmith> or maybe "The committee for ensuring proper pigmentation of conveyance storage facilities" :)
15:42:43 <yoctozepto> the name is important
15:42:58 <yoctozepto> well, that was rude
15:43:05 <gmann> and big issue in rename i see "to convey TC is not gone but just rename"
15:43:16 <spotz> I think a rename would be good and favored it when discussing the merger. Should we maybe figure out what we do as gmann has been working on and then decide on a new name if warranted vs just picking a new name that may not fit when that effort is completed?
15:43:42 <yoctozepto> spotz ++
15:44:16 <gmann> and we might spend lot of time/cost on 'just renaming without any structural change'
15:44:38 <gmann> if no structural change, i do not see value in spending time on renaming or so
15:44:42 <dansmith> ++
15:44:50 <jungleboyj> gmann:  I do agree with that.
15:44:53 <gmann> not any time is perfect and we can keep changing it
15:44:59 <diablo_rojo> TBH, I had a fair amount of impostor syndrome about joining the technical committee because I didn't think *I* was technical enough so I can imagine I am not the only one in thinking that particularly when you consider those that might be interested in voicing opinions about user things, but maybe doesn't actively contribute upstream..
15:45:07 <diablo_rojo> Perhaps I am projecting.
15:45:47 <jungleboyj> diablo_rojo:  No, you are right.  Same here.  It is a perception we need to change.
15:45:48 <dansmith> I think the current TC makeup shows that's not a huge deal, personally, but obviously I'm biased
15:45:51 <gmann> I wrote previously also. Technical is not just developer but a wider group or people
15:45:59 <spotz> diablo_rojo: me too
15:46:10 <dansmith> if we were called "the developer committee" I would agree
15:46:16 <gmann> treu
15:46:17 <gmann> true
15:46:47 <gmann> everyone in TC participate in various technical discussion so that is what technical commitee means
15:47:05 <yoctozepto> but not only
15:47:13 <diablo_rojo> I think we should at least consider it since other bylaws updates will be done.
15:47:52 <gmann> humm, I think foundation renaming bylaws change is different things.
15:48:04 <belmoreira> I don't have a strong opinion about the name... but we go back to the PTG discussion... we only allow ATCs to vote for the TC
15:48:06 <gmann> we need to see if there is any structural change or not
15:48:14 <dansmith> belmoreira: I think we resolved that
15:48:17 <gmann> belmoreira: good point
15:48:29 <gmann> we will add AUC as extra ATC
15:48:30 <jungleboyj> belmoreira:  That definitely needs to be fixed I feel.
15:48:56 * ricolin remember the same as gmann mentioned
15:48:57 <gmann> I think dansmith has that item https://etherpad.opendev.org/p/tc-xena-tracker
15:49:08 <gmann> L 48 in #link https://etherpad.opendev.org/p/tc-xena-tracker
15:49:17 <dansmith> well,
15:49:26 <gmann> 'Document the process for adding SIG+project contributors, AUC as extra ATC.'
15:49:27 <diablo_rojo> belmoreira, I think that is a good point.
15:49:38 <dansmith> I was trying to pick things to help with, but I definitely don't think I can do that on my own, especially given the lack of agreement here
15:49:59 <dansmith> so I should probably remove my name from that, unless at least one more person is going to join and drive that :)
15:50:04 <gmann> ? adding AUC as extra-ATC was agreed in PTG
15:50:14 <yoctozepto> yeah
15:50:22 <gmann> i do not think any change in that.
15:50:27 <dansmith> ah,
15:50:33 <dansmith> I thought this also included the naming bit
15:50:50 <gmann> no, renaming is separate things
15:50:53 <dansmith> gotcha
15:50:58 <yoctozepto> cool
15:51:16 <dansmith> I think spotz needs to join this effort for the U part of AUC :D
15:52:07 <gmann> anyways let's keep it separate and clear. how about this plan:
15:52:23 <gmann> 1. making AUC in extra-ATC
15:52:25 <spotz> I think you've just claimed the TC is for users s and they're techniical
15:52:28 <belmoreira> my point is that the TC is now TC + UC, represented by ATC and AUC. Without a name change can be very difficult to reflect this change to the community.
15:52:34 <gmann> 2. merging UC doc into TC site/doc etc
15:52:37 <fungi> it's also worth remembering that the foundation bylaws don't define the word "technical" but effectively imply that it's a handle for any governance not relaetd to administration of legal matters, trademarks, et cetera
15:52:42 <diablo_rojo> belmoreira, +2
15:53:14 <gmann> 3. if we need rename that is a separate topic than UC + TC merge so feel free to add in agenda if needed
15:53:29 <fungi> the scope of the "user committee" defined in the bylaws is much more focused in scope, but also doesn't have any obligations or responsibilities outlined therein
15:53:43 <dansmith> spotz: to be clear, I meant join (me) in owning the todo item of defining how we get the AUC people included in the voting body of extra-ATCs
15:54:18 <gmann> belmoreira: we can try to rename ATC term or so as part of 1st which can help to clear the confusion may be
15:54:45 <spotz> gmann: AC - active contibutor
15:55:06 <jungleboyj> spotz: ++
15:55:09 <gmann> yeah, +1
15:55:15 <yoctozepto> spotz ++
15:55:28 <jungleboyj> Don't need to specify what type of contributor.
15:55:36 <gmann> exactly
15:55:45 <yoctozepto> The Contributor
15:56:00 <gmann> anyways let's find correct name as part of 1st
15:56:08 <yoctozepto> agreed
15:56:19 <gmann> I am writing plan again, in case any one disagree
15:56:34 <diablo_rojo> The ATC status makes sense for what it is, as does the AUC, but I guess I am fine with just making it AC, but i think we will still need to separately define APCs for when there are PTL runoffs
15:56:44 <gmann> 1. making AUC in extra-ATC + rename ATC in more correct way
15:56:46 <gmann> 2. merging UC doc into TC site/doc etc
15:56:51 <diablo_rojo> (switched from TC hat to Election Official hat mid sentence there)
15:57:31 <gmann> 3. if we need rename TC that is a separate topic than UC + TC merge so feel free to add in next week agenda if needed
15:58:01 <diablo_rojo> I disagree that its a completely separate topic, but fine, I think it can be a new topic on the agenda for next week.
15:58:13 <gmann> otherwise we can mixup the many things into it
15:58:14 <diablo_rojo> I also think we should get opinions from the community on the ML.
15:58:25 <gmann> and I will remove this from agenda as we have two action item from it.
15:58:28 <spotz> +1
15:58:36 <jungleboyj> diablo_rojo:  It would be interesting to see if anyone cares.  :-)
15:58:41 <yoctozepto> it's related but uc merge is not a new thing nowadays
15:58:46 <gmann> sure, please add in agenda or in ML. that is good way
15:59:00 <gmann> jungleboyj: exactly :)
15:59:36 <gmann> IMO, we should spend more time on engaging and some productive work as TC not renaming which many people do not care much
16:00:11 <gmann> many project/community think as TC we could do much more better which is very valid feedback I think
16:00:18 <gmann> anyways we are out of time,
16:00:29 <dansmith> yup
16:00:30 <gmann> #topic Open Reviews
16:00:33 <diablo_rojo> yoctozepto, I agree they are related. Definitely not completely separate.
16:00:38 <gmann> #link https://review.opendev.org/q/project:openstack/governance+is:open
16:00:59 <gmann> we have  one open review for Y cycle name. please vote
16:01:22 <spotz> voted:)
16:01:29 <gmann> thans
16:01:37 * gmann again naming things :(
16:01:42 <gmann> thanks
16:01:50 <diablo_rojo> Before I was on the TC I thought it was a super technical role (based on the name and knowing they approved new projects/repos, etc) and then I joined and realized its mostly *not* technical.
16:02:12 <dansmith> you joined without knowing what they did, and just went on the name? :)
16:02:18 <gmann> let's continue discussing in channel and close meeting
16:02:22 <gmann> thanks all for joining and good discussion.
16:02:25 <gmann> #endmeeting