15:00:25 <gmann> #startmeeting tc
15:00:25 <opendevmeet> Meeting started Thu Jun  3 15:00:25 2021 UTC and is due to finish in 60 minutes.  The chair is gmann. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:26 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:29 <opendevmeet> The meeting name has been set to 'tc'
15:00:34 <dansmith> o/
15:00:35 <gmann> tc-members: meeting time
15:00:42 <mnaser> o/
15:00:44 <ricolin> o/
15:00:45 <diablo_rojo> o/
15:00:46 <belmoreira> o/
15:00:47 <spotz_> I/
15:00:50 <gmann> #topic Roll call
15:00:54 <gmann> o/
15:01:29 <ricolin> o/
15:01:35 <gmann> one in Absence section : yoctozepto would not be able join due to holiday
15:02:09 <gmann> let's start
15:02:10 <jungleboyj> o/
15:02:14 <gmann> #topic Follow up on past action items
15:02:35 <gmann> two action item
15:02:36 <gmann> gmann to push the resolution for ATC/AC terms
15:02:52 <gmann> I did push this #link https://review.opendev.org/c/openstack/governance/+/794366
15:02:54 <gmann> please review
15:03:19 <gmann> this is basically recording that ATC is now renamed to AC
15:03:44 <gmann> next action item is 'ricolin to start testing patch for TLS and send on ML.'
15:03:52 <gmann> ricolin: any update
15:04:06 <ricolin> #link https://review.opendev.org/q/topic:%22exame-tls-proxy%22+(status:open%20OR%20status:merged)
15:04:13 <ricolin> not sending ML yet
15:04:28 <ricolin> but do enable tls-proxy in several services
15:04:36 <ricolin> but failed mostly
15:04:46 <ricolin> not look in detail yet
15:04:55 <gmann> ok
15:05:44 <gmann> ricolin: you want to continue this as Action item or just keep testing it ?
15:05:57 <ricolin> still need this action item
15:06:02 <gmann> sure
15:06:16 <gmann> #action ricolin to continue testing patch for TLS and send on ML.
15:06:31 <gmann> #topic Gate health check (dansmith/yoctozepto)
15:06:38 <gmann> dansmith: any updates
15:06:46 <dansmith> the number one thing I've seen in the last week is cinder fails
15:07:04 <dansmith> we had some hiccup with some subset of workers yesterday for less than an hour, but that was quickly resolved
15:07:15 <dansmith> so I think cinder fails are the only kinda systemic thing I've noticed
15:07:20 <gmann> i saw that in morning on one of my nova patch too
15:07:23 <jungleboyj> :-(
15:07:40 <jungleboyj> So Cinder is still the problem child.
15:08:16 <jungleboyj> Shouldn't be surprised given our logo.  :-)
15:08:18 <spotz_> Pot Cinder
15:08:21 <dansmith> other than that I don't have much to report
15:08:29 <gmann> ok, thanks
15:08:33 <spotz_> Poor even
15:08:43 <jungleboyj> :-)
15:08:46 <gmann> other one is issue on devstack with ovn default. horizon integration jobs is also failed
15:08:48 <jungleboyj> I will chat with rosmaita again.
15:09:08 <gmann> fixes are up on devstack side, hope we can merge them soon
15:09:12 <gmann> jungleboyj: thanks
15:09:42 <dansmith> gmann: oh yeah, forgot about that one
15:10:03 <gmann> dansmith: yeah I will review that today. we have testing patch also up.
15:10:26 <dansmith> cool
15:10:48 <gmann> let's move to next topic
15:10:49 <gmann> #topic Migration from 'Freenode' to 'OFTC' (gmann)
15:11:02 <jungleboyj> \o/  Success
15:11:07 <gmann> as you know bot and logs are done.
15:11:18 <dansmith> although I didn't realize there are still meetbot issues
15:11:21 <gmann> but we have more work to do on this especially on communication part
15:11:32 <fungi> not really issues, it just doesn't edit the channel topic currently
15:11:36 <dansmith> I think most people are not on service-discuss, so hadn't seen some announcement about it there
15:11:36 <spotz_> Yeah I haven’t seen any issues
15:11:48 <dansmith> fungi: yeah, it just looks like it's not working
15:11:58 <fungi> it still annotates the meeting minutes with the topics you declare
15:12:57 <fungi> the difference in oftc's channel permissions model makes the old method meetbot used for that complicated, but we've got a long-pending rewrite of the meetbot onto a new framework which is finally underway as of this week, and we'll implement a better solution in that
15:13:19 <dansmith> sweet
15:13:23 <gmann> nice
15:13:49 <gmann> I have created this etehrpad for tracking all work #link https://etherpad.opendev.org/p/openstack-irc-migration-to-oftc
15:14:00 <gmann> if you find some of the item missing, feel free to add
15:14:03 <jungleboyj> fungi:  Thank you for all your efforts!
15:14:17 <fungi> it was a group effort, but you're welcome!
15:14:21 <spotz_> +2
15:14:21 <gmann> TC resolution is all set to merge today in evening or so #link https://review.opendev.org/c/openstack/governance/+/793260
15:14:28 <fungi> glad it was fairly painless for everyone
15:14:58 <gmann> yeah smooth migration till now.
15:15:13 <fungi> we do still need someone to reach out to sergey (i hear he's still at mirantis) about getting control of the #openstack-sahara channel, but the rest are fine now
15:15:27 <gmann> fungi: yeah i was writting that
15:15:40 <gmann> L15 in https://etherpad.opendev.org/p/openstack-irc-migration-to-oftc
15:16:00 <gmann> fungi: did we send email to him or just ping on IRC ?
15:17:20 <fungi> gmann: so far i only tried irc, it's been a lower priority for me
15:17:41 <fungi> but maybe it's a higher priority for folks using that channel if one of them wants to try to get in touch with him
15:17:47 <gmann> ok, I will add this to sahara meeting and ping jeremyfreudberg if they can reachout
15:17:52 <gmann> yeah
15:18:12 <fungi> i can probably eventually get around to e-mailing him myself, but my to do list is... lengthy
15:18:26 <gmann> #action reachout to sahara team and PTL to get control of the #openstack-sahara channel
15:18:37 <gmann> fungi: ^^ i will check it
15:18:43 <gmann> #action gmann reachout to sahara team and PTL to get control of the #openstack-sahara channel
15:19:04 <gmann> we two things to discuss about this migration
15:19:14 <gmann> Backporting OFTC reference changes (mnaser)
15:19:21 <mnaser> o/
15:19:21 <ricolin> jeremyfreudberg, ^^^
15:19:23 <jeremyfreudberg> ack
15:19:34 <gmann> this came up in morning from tkajinam
15:19:46 <mnaser> this morning (my morning anyways :]) we had a question if we should backport refs to irc
15:20:05 <mnaser> my opinion: yes if possible
15:20:30 <gmann> yeah I think we should. people refer to stable release doc too
15:20:37 <jungleboyj> Agreed.
15:20:49 <gmann> mostly it is contributor doc but there are few other doc too
15:20:56 <jungleboyj> Sometimes it is what comes up in google searches by default.
15:21:06 <gmann> true
15:21:46 <fungi> however, separately, it's worth questioning whether publishing branched contributor docs is sane in the first place
15:22:13 <fungi> if they all use consistent urls, we can probably add a single pattern-based redirect in the .htaccess file for the docs site to always send people to the latest contributor docs
15:23:00 <gmann> doc is fine but CONTRIBUTING.rst in top for github repo need that right?
15:23:28 <gmann> contributor/contributing.rst can be maintained  in master only
15:23:34 <fungi> are users likely to pay attention to the CONTRIBUTING.rst files on old branches?
15:24:09 <diablo_rojo> ..I kind of doubt it?
15:24:26 <fungi> i mean, it doesn't hurt to backport that stuff, it just doesn't seem like it's critical if folks are unlikely to look at the old versions
15:24:36 <gmann> I do not know but we can keep it as anyone can do
15:24:40 <dansmith> google often returns things of pike-era, FWIW
15:24:57 <tkajinam> some projects mentions irc server in README.rst as well
15:25:07 <tkajinam> I tend to go for "fix anything" style
15:25:09 <gmann> I think  if we keep doc/source/contributor/contributing.rst  on master then should be mainly ok.
15:25:12 <dansmith> probably because at peak hype, most things linked to docs of the day, which raises their rank
15:25:13 <tkajinam> instead of setting complicated rules...
15:25:21 <fungi> tkajinam: wow your projects must have no bugs left!
15:25:23 <gmann> tkajinam: yes README also like in nova
15:25:51 <gmann> fungi: it is about mentioning some meeting info or so with freenode info
15:25:55 <gmann> so not bug actually
15:26:00 <tkajinam> s/anything/everything/
15:26:02 <tkajinam> sorry :-P
15:26:20 <tkajinam> fungi, I hooope so :-D
15:26:20 <fungi> dansmith: yeah, addressing it in old docs, assuming web search engines are sending people to the docs site, can be handled by a redirect much more easily for a lot of it
15:26:24 <gmann> should we ask project to remove  doc/source/contributor/contributing.rst  from stable then ?
15:26:57 <dansmith> fungi: not sure what that means.. effectively removing old docs and redirecting to current?
15:27:06 <gmann> becasue that is always referred to latest from stable branch too #link https://github.com/openstack/nova/blob/stable/wallaby/CONTRIBUTING.rst
15:27:06 <fungi> back to my old question, are people looking at old branches of the git repo (not old versions on the docs site)?
15:28:01 <gmann> we have two file here top level CONTRIBUTING.rst which is kind of static and point to */latest/contributor/contributing.html
15:28:01 <fungi> dansmith: if it's mostly the contributor docs in branched projects which are the problem, then adding a pattern-based redirect in the docs site's .htaccess file like we do for tons of other stuff. one line could cover all projects using the same url patterns
15:28:20 <gmann> so keeping  top level CONTRIBUTING.rst on stable does not harm anything
15:28:24 <fungi> and would be one review to land instead of potentially hundreds
15:28:26 <dansmith> okay, if it's just the contributor doc, then sure
15:28:41 <gmann> but  doc/source/contributor/contributing.rst  on stable is not referred on stable
15:29:02 <dansmith> having the contributor doc exposed on a stable branch is just asking for trouble anyway
15:29:16 <jungleboyj> fungi:  I am all for whatever the easiest and most visible solution may be.  :-)
15:29:39 <diablo_rojo> dansmith, I would agree. Outdated info potentially.
15:29:39 <fungi> if we think lots of people are going to be finding old contact info on old git branches and in old docs other than the project contributor docs, then sure maybe the many hours of contributor and ci time to push and review and merge those changes is warranted, but do at least consider it as a cost/benefit ratio
15:30:02 <fungi> there are still lots of projects with branches which mention the openstack-dev mailing list too, fwiw
15:30:10 <diablo_rojo> ..and the general lack of spoons
15:30:18 <fungi> and git.openstack.org site
15:30:28 <jungleboyj> True.
15:30:28 <fungi> and whatever else was a thing at one time but isn't today
15:30:34 <gmann> for long term I think this is good way to remove from stable
15:30:45 <jungleboyj> ++
15:30:59 <gmann> ok  so-
15:31:20 <mnaser> i mean imho i am in the school of thought of 'if you wanna do it, go for it, it would be nice'
15:31:39 <fungi> my not-on-the-tc opinion is that projects are free to update that on old branches but telling them it's mandatory is questionable
15:31:42 <mnaser> but maybe not 'please make sure you backport this doc change 6 release back'
15:31:51 <gmann> remove the doc/source/contributor/contributing.rst and keep CONTRIBUTING.rst(this does not have freenode info) on stable instead of backporting OFTC change
15:32:01 <gmann> backport everything else you changed for OFTC
15:32:22 <dansmith> but, fungi is going to land some redirect for the contributor doc to make it all mostly hidden anyway right?
15:32:23 <gmann> that we can sugegst to projects
15:32:36 <gmann> redirect ?
15:32:52 <gmann> oh on stable, yes
15:33:16 <gmann> and we can ask projects to remove them with redirect
15:33:32 <gmann> but when they have time so its a suggestion for long term easiness
15:33:37 <mnaser> i think what fungi suggested is that, opendev infra will handle a global redirect
15:33:38 <dansmith> we don't have to ask projects, I thought... fungi is going to do it globally?
15:33:43 <dansmith> right
15:33:45 <mnaser> and projects just need to rm -rfv contributor/contributing.rst
15:34:01 <gmann> ok if that can be done globally its great
15:34:05 <dansmith> personally, I'd not want to delete anything from git history
15:34:22 <gmann> dansmith: then it may be outdated
15:34:33 <dansmith> if it's being handled on the rendered site globally, I'd just say leave it and only people looking at git trees will see the old stuff
15:34:43 <dansmith> it's the rendered page that is the most important, IMHO
15:34:59 <dansmith> or just say "backport what you want, or delete it from your old trees, but neither are required" ?
15:35:02 <fungi> mnaser: dansmith: it would just be a line in the .htaccess file in the openstack-manuals repo
15:35:08 <fungi> but sure i can take a first shot at it
15:35:09 <gmann> yeah
15:35:52 <jungleboyj> Yeah, I think we should just go with the one liner change.
15:36:03 <fungi> there's a ton of redirects already in openstack-manuals, which used to be maintained by the docs team
15:36:04 <gmann> - backport the OFTC things and for contributing.rst remove the doc/source/contributing.rst for ling term
15:36:31 <gmann> otherwise many project might need to do partial backport so let them backport as it is
15:36:39 <gmann> and then they can remove it based on time
15:37:22 <gmann> any other point on backport ?
15:37:50 <gmann> next thing to decide is - 'Topic change on Freenode channel'
15:37:58 <gmann> when we should do this ?
15:38:16 <spotz> Will we just get the channel banned if we do?
15:38:18 <dansmith> I think the freenode people have already made their mea culpa on over-reaction to these things
15:38:28 <dansmith> so I think we can do it now and likely won't see a big reaction right?
15:38:30 <gmann> spotz: may be so not sure but that is risk
15:38:33 <dansmith> and if we do, meh
15:38:44 <mnaser> i've been hanging around at channels pointing people over
15:38:47 <mnaser> still see 1-2 people a day
15:38:53 <fungi> yeah, that seems to be working so far
15:38:55 <gmann> we can assume they will do some action as worst case
15:38:58 <spotz> Centos channel names is now actually centos-has-moved:)
15:39:17 <fungi> also my past experience is that most people who aren't paying attention in channels also don't look at the channel topic wherever it's displayed in their client anyway
15:39:24 <mnaser> i feel as long as we're in the channels
15:39:30 <mnaser> and we're ok with sending people over
15:39:43 <mnaser> lets keep doing that until it clearly feels like we're doing it less often
15:39:46 <gmann> and by this week all meeting should have happened on OFTC so that is good trigger also
15:40:22 <gmann> we can keep it open for next week also and change topic on 11th June Friday ?
15:40:42 <gmann> and until then continue redirecting people from there
15:40:58 <mnaser> yeah could be a good idea
15:41:42 <gmann> ok, we can work on Topic change wording with fungi meanwhile.
15:42:04 <gmann> other progress on project side doc/wiki can be seen in etherpad
15:42:08 <fungi> yeah, if you do decide you want to update channel topics in all the openstack project channels, i can help do that
15:42:23 <gmann> fungi: +1, thanks
15:42:44 <gmann> anything else on OFTC?
15:42:57 <fungi> not from me
15:43:05 <mnaser> huge thanks to fungi for championing most of this
15:43:08 <spotz> Not I
15:43:09 <mnaser> the transition has been pretty darn flawless
15:43:16 <gmann> yeah thanks again fungi
15:43:25 <jungleboyj> Thanks!
15:43:39 <fungi> it was a group effort from the opendev sysadmins and broader community, but on their behalf, you're welcome!
15:43:51 <gmann> +1
15:43:53 <gmann> moving next
15:43:54 <gmann> #topic OpenStack Newsletters
15:44:04 <gmann> #link https://etherpad.opendev.org/p/newsletter-openstack-news
15:44:11 <gmann> I have added three key things thetre
15:44:13 <gmann> there
15:44:17 <gmann> anything else to add ?
15:44:51 <spotz> I think those are the main things
15:44:53 <fungi> i did already supply oftc migration wording to the newsletter editors earlier in the week
15:44:53 <mnaser> i have a more of a market-y idea
15:45:16 <mnaser> why dont we rephrase a 'critical help needed' to 'do you want to help operate ES at scale' or something along those lines
15:45:29 <mnaser> either as learning/trying/etc
15:45:42 <ricolin> gmann, will be good to also mention y cycle goal idea collecting
15:45:45 <mnaser> seem a lot more 'come do this cool thing' rather than 'plz help we cant convince anyone to look at it' :p
15:45:51 <gmann> mnaser: we can do whatever help us to get help :)
15:46:19 <gmann> ricolin: that is good one to add but can we add more than 3? may be question to diablo_rojo ?
15:46:36 <gmann> ricolin: but feel free to add it in Future one
15:46:55 <ricolin> diablo_rojo, ^^^ question here:)
15:46:56 <gmann> mnaser: feel free to reword that on etherpad
15:47:07 <ricolin> gmann, will check
15:47:26 <gmann> ricolin: the one in Future section will be added in next newsletter
15:47:49 <gmann> diablo_rojo: when is deadline to finalize it? I think today?
15:48:00 <diablo_rojo> deadline for the newsletter?
15:48:14 <diablo_rojo> EOD (for US) today
15:48:37 <ricolin> diablo_rojo, how many items we can added to newsletter
15:49:06 <gmann> diablo_rojo: ok, I think we are ready with that.
15:49:10 <ricolin> I do have a y cycle goal one can mention in newsletter, but I can added to feature list if three is the limit
15:49:32 <gmann> * Future items
15:49:52 <ricolin> ;p
15:50:04 <gmann> let' move next and we can check on y goal addition if ok as per limit
15:50:07 <gmann> #topic Open Reviews
15:50:13 <ricolin> sure
15:50:16 <gmann> #link https://review.opendev.org/q/project:openstack/governance+is:open
15:50:40 <ricolin> let me added to future items for now
15:50:42 <gmann> please review those OFTC resolution is all set to merge today
15:50:47 <gmann> ricolin: cool, thakns
15:50:56 <diablo_rojo> There is no limit
15:51:02 <gmann> one thing or OFTC i missed.
15:51:08 <diablo_rojo> I just have to write it up lol so have a little pity on me
15:51:14 <mnaser> gmann: fyi, i would reference https://review.opendev.org/q/projects:openstack/governance+is:open usually (projectS instead of project), there's some changes to other repos we should occasionally look at
15:51:27 <diablo_rojo> I think that will already be mentioned elsewhere in the newsletter- the OFTC stuff
15:51:44 <gmann> mnaser: ohk, that will help more. will fix that
15:52:00 <gmann> renaming the #heat channel to #openstack-heat https://review.opendev.org/c/openstack/heat/+/794596/1/doc/source/developing_guides/pluginguide.rst#647
15:52:10 <gmann> ricolin ^^
15:52:34 <gmann> this is good time to fix that like octavia did/doing ?
15:52:37 <ricolin> gmann, +1
15:53:30 <ricolin> do I need to propose the patch myself? or we do have other automatic way to do it now:)
15:53:32 <gmann> mnaser: even let me prepare query for all repo under TC, like openstack/ideas etc
15:53:48 <mnaser> gmann: yes, good idea
15:54:01 <mnaser> i think we can have project dashboards or soemthing with the newer gerrit but
15:54:04 <mnaser> not my expertise =)
15:54:07 <gmann> ricolin: I think fungi can answer that. working with opendev or so
15:54:38 <fungi> i encourage you to skim through our accessbot channels list looking for other channels which need to be renamed or are no longer needed
15:54:55 <fungi> #link https://opendev.org/openstack/project-config/src/branch/master/accessbot/channels.yaml OpenDev AccessBot channels list
15:55:36 <gmann> that's all from me today. anything else from anyone ?
15:56:08 <fungi> for example cloudkitty, tacker and tripleo don't use openstack- prefixes either, so is heat that much of an outlier?
15:56:49 <TheJulia> personally, I could see ironic wanting #ironic, but we already moved *shrug*
15:57:14 <mnaser> does oftc support channel forwarding
15:57:14 <fungi> but if the heat tam wants to move from #heat to #openstack-heat then yeah, do similar to what the octavia team is doing
15:57:20 <gmann> If heat team is interested to rename I think it is fine
15:57:21 <fungi> mnaser: no, it doesn't
15:57:27 <mnaser> aw, okay
15:57:34 <fungi> mnaser: we have a new process up for review
15:57:58 <fungi> #link https://review.opendev.org/794313 Update channel renaming instructions for OFTC
15:58:04 <gmann> may be keep monitoring old channel for some time can help for forwarding-gap
15:58:56 <fungi> yeah, the new process suggests an entrymessage as an available option for that too
15:59:04 <gmann> let's close meeting. thanks all for joining.
15:59:08 <gmann> #endmeeting