15:00:07 <gmann> #startmeeting tc
15:00:08 <opendevmeet> Meeting started Thu Jun 10 15:00:07 2021 UTC and is due to finish in 60 minutes.  The chair is gmann. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:09 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:11 <gmann> #topic Roll call
15:00:12 <opendevmeet> The meeting name has been set to 'tc'
15:00:17 <gmann> o/
15:00:19 <yoctozepto> \o/
15:00:27 <dansmith> o/
15:00:27 <mnaser> hola
15:01:23 <gmann> jungleboyj and diablo_roj will be absent today
15:01:34 <ricolin> o/
15:01:58 <gmann> let's start
15:02:00 <gmann> #topic Follow up on past action items
15:02:03 <gmann> two Ai
15:02:11 <gmann> gmann reachout to sahara team and PTL to get control of the #openstack-sahara channel
15:02:47 <gmann> jeremyfreudberg updated about contacting SergeyLukjanov via linkedin and other way but no response
15:03:37 <gmann> we are waiting for one more response if tosky get reply on mirantis address if no then we can go with asking oftc staff to take control.
15:03:51 <belmoreira> o/
15:03:55 <gmann> I will keep this as AI until then
15:04:08 <gmann> #action gmann reachout to sahara team and PTL to get control of the #openstack-sahara channel
15:04:16 <gmann> next is 'ricolin to continue testing patch for TLS and send on ML.'
15:04:21 <gmann> ricolin: ^^
15:05:16 <ricolin> gmann, I do take some deep looks into most attempt on turn tls-proxy on, there's no common error
15:05:20 <spotz> o/
15:05:45 <ricolin> that actually means we're not tls-proxy ready
15:06:02 <yoctozepto> I know masakari hates tls-proxy atm
15:06:07 <yoctozepto> I will update you when I debug that
15:06:30 <yoctozepto> mayhaps we find a pattern to enable tls-proxy everywhere
15:06:43 <gmann> but should we send this to ML and ask projects to start working/testing  on this in meantime
15:06:51 <ricolin> right now we can do is to only ask team to use tls-proxy and fix bugs
15:06:56 <yoctozepto> I believe so, we need their help nonetheless
15:06:59 <ricolin> gmann, we do
15:07:08 <gmann> +1
15:07:10 <ricolin> and I will send it later today
15:07:18 <yoctozepto> thanks ricolin
15:07:23 <gmann> yoctozepto: we can do in devstack but that can break things
15:07:37 <gmann> ricolin: thanks, keeping this AI
15:07:42 <mnaser> (sorry, i might be a bit out of loop, do you have some context about this tls stuff)
15:07:42 <yoctozepto> no, we better not force it on them
15:07:58 <ricolin> will see if we can fix this before Y-cycle
15:08:02 <gmann> yoctozepto: right
15:08:10 <yoctozepto> mnaser: the jobs in devstack run with tls-proxy but it's not devstack default
15:08:12 <ricolin> and in that way, it does not need to be a goal
15:08:19 <yoctozepto> mnaser: many projects opted out of it
15:08:22 <mnaser> ack
15:08:29 <gmann> yeah it is disabled in jobs side
15:08:45 <yoctozepto> https://codesearch.opendev.org/?q=tls-proxy%3A%20false&i=nope&files=&excludeFiles=&repos=
15:08:46 <yoctozepto> roughly
15:08:53 <ricolin> #link https://codesearch.opendev.org/?q=tls-proxy%3A%20false&i=nope&files=&excludeFiles=&repos=
15:09:42 <gmann> #action ricolin to send email on asking projects to enable and test tls-proxy in their jobs
15:09:54 <ricolin> and that's all I have for tls-proxy
15:10:03 <gmann> ricolin: thanks for working on this and updates
15:10:05 <gmann> moving next
15:10:08 <gmann> #topic Gate health check (dansmith/yoctozepto)
15:10:23 <gmann> gate is not smooth for this week.
15:10:34 <dansmith> not much from me this week.. still see cinder failures as the primary thing, but tbh I didn't hit them, as much (lower traffic this week too)
15:10:35 <gmann> dansmith: yoctozepto any news on this
15:10:44 <gmann> ok
15:11:05 <gmann> devstack and ovn hitting the issues
15:11:14 <mnaser> should we get a group of people who can help work with the cinder team and help investigate those
15:11:49 <mnaser> im unsure if this is a "we dont have enough people to address this" or "we dont really know what's going on and need help" problem
15:11:53 <gmann> mnaser: I think we have communicated it in cinder team. but not sure about priority for them
15:12:07 <yoctozepto> the gate atm is possibly still blocked by zuul failure
15:12:08 <dansmith> mnaser: it's both I think
15:12:12 <yoctozepto> let's see
15:12:15 <mnaser> it's only going to get worse the closer we get to release as usual
15:12:18 <gmann> yoctozepto: yeah.
15:12:38 <mnaser> which makes this the best time to investigate these issues
15:12:42 <yoctozepto> it looks like it moved forward
15:12:43 <fungi> what zuul failure is blocking the gate?
15:13:05 <yoctozepto> fungi: nah, old story
15:13:10 <yoctozepto> what frickler was describing
15:13:21 <gmann> i have not read the log in QA channel yet but yoctozepto or frickler knows about zuul issue
15:13:27 <fungi> oh, i think frickler was confusing several different (and likely unrelated) issues
15:13:46 <yoctozepto> oh, so I was tricked
15:14:01 <mnaser> but i think whatever this potential 'zuul' issue, it's probably just transient or whatever
15:14:07 <mnaser> not like the repeating cinder stuff for example
15:14:10 <yoctozepto> but there was some high time job in the queue nonetheless
15:14:14 <yoctozepto> mnaser: yeah, definitely
15:14:16 <gmann> yeah
15:14:20 <yoctozepto> that was just another related topic
15:14:24 <yoctozepto> the cinder looks serious
15:14:45 <yoctozepto> so I will quoute mnaser
15:14:53 <gmann> so what we can do for cinder? pining cinder team ? (again)
15:14:53 <yoctozepto> 17:11:14 <mnaser> should we get a group of people who can help work with the cinder team and help investigate those
15:14:53 <yoctozepto> 17:11:49 <mnaser> im unsure if this is a "we dont have enough people to address this" or "we dont really know what's going on and need help" problem
15:15:00 <yoctozepto> 17:12:15 <mnaser> it's only going to get worse the closer we get to release as usual
15:15:04 <yoctozepto> 17:12:38 <mnaser> which makes this the best time to investigate these issues
15:15:09 <yoctozepto> and I agree with all of the above
15:15:44 <gmann> ' group of people' you mean cinder team or cinder team + more folks want/know about how to debug/fix ?
15:16:11 <yoctozepto> I think it means a subset of us or another team
15:16:12 <spotz> Should we reach out and invite them to the next meeting?
15:16:40 <dansmith> I don't think they need to come to this meeting,
15:16:51 <dansmith> I think we probably just need to sync up with them in their channel and offer help
15:16:52 <gmann> spotz: I will say they can debug in theior time
15:16:57 <dansmith> I've done that in the past and got very little response, FWIW
15:17:28 <gmann> yeah
15:17:47 <gmann> anyways let jungleboyj try it again and we can see if any update he can get
15:17:50 <spotz> ok, I was mainly thinking about snawering the questions is it they don't know or doon't have the people in our meeting not debugging though
15:17:58 <dansmith> they know
15:18:04 <dansmith> they suffer from them more than everyone else
15:18:19 <spotz> k
15:18:45 <mnaser> so should we come up with something actionable
15:18:52 <mnaser> i can volunteer to help out troubelshoot these issues
15:18:52 <yoctozepto> dansmith: is there specific backend in place that fails more? or? do we track details anywhere atm?
15:19:13 <dansmith> yoctozepto: I dunno the details of their jobs, so unsure
15:19:26 <gmann> mnaser: thanks. I will add action for you and jungleboyj on this ?
15:19:30 <dansmith> yoctozepto: it's definitely not something obvious like "the ceph job always fails but the others are fine"
15:19:36 <yoctozepto> dansmith: yeah, I was thinking more in terms of their job names
15:19:38 <yoctozepto> dansmith: ack
15:20:03 <yoctozepto> keep me in the loop too
15:20:08 <yoctozepto> and dansmith I guess as well
15:20:18 <dansmith> um, yes please? :)
15:20:34 <yoctozepto> <puppy eyes>
15:20:47 <gmann> ok so as actionable who all will debug this with cinder team?
15:20:57 <mnaser> i can do that
15:21:12 <yoctozepto> I can as well
15:21:46 <gmann> ok, also adding jungleboyj in list as he was doing/volunteer in past meeting
15:21:48 <gmann> #action mnaser, yoctozepto, and jungleboyj to work on cinder bug with cinder team.
15:21:53 <yoctozepto> I guess with our varied experience we might come up with something finally
15:22:03 <mnaser> yes, i'm sure we can dig it out
15:22:18 <gmann> yoctozepto: on ovn things, I will check log/patch in QA after meeting
15:22:28 <gmann> anything else on gate status ?
15:22:49 <yoctozepto> gmann: no problem, I persuaded neutrinos already :-)
15:22:59 <gmann> +1
15:23:01 <gmann> #topic Migration from 'Freenode' to 'OFTC' (gmann)
15:23:11 <gmann> #link https://etherpad.opendev.org/p/openstack-irc-migration-to-oftc
15:23:24 <yoctozepto> still occasional wanderers
15:23:36 <gmann> we have update on this.
15:23:42 <mnaser> i think we'll need a month a tleast imho
15:23:47 <spotz> I'm idling there, mainly seeing rude bots
15:23:51 <gmann> as decided in last meeting, we can change the freenode channel topic tomorrow 11th Junew
15:23:52 <mnaser> so that any monthly meeting folks
15:24:06 <mnaser> i've noticed it's mostly a "are we not meeting today?" messages
15:24:18 <yoctozepto> will infra help mass-set the topic to a unified one?
15:24:28 <yoctozepto> mnaser: hah, nice
15:24:38 <gmann> and project side doc/wiki updates are going on
15:25:00 <gmann> we have published this migration in newsletter also
15:25:19 <fungi> i can set topics in any of the openstack channels, sure
15:25:23 <yoctozepto> yeah, and I am very positive I have covered all places for my two projects, yet they still get visitors
15:25:37 <yoctozepto> so it's just people are used to it
15:25:37 <gmann> once we change the Topic I will check with oif staff to publish it on twitter or so if ok with them
15:25:43 <fungi> just be forewarned that freenode staff may take the channels over and reset/wipe topics once we do
15:25:46 <yoctozepto> have their chat clients for openstack ready
15:25:50 <yoctozepto> just for the old network
15:25:53 <gmann> fungi: yeah, I will ping you for that. tomorrow is time to do that
15:26:12 <gmann> yeah i think we are ready for that if freenode take any action
15:27:06 <gmann> anything else on this topic?
15:27:15 <yoctozepto> fwiw, freenode had a surprise this week
15:27:24 <yoctozepto> one of their servers did not register NickServ
15:27:28 <yoctozepto> and someone claimed it
15:27:30 <yoctozepto> ;d
15:28:05 <gmann> #topic Xena Tracker
15:28:07 <dansmith> IRC as usual :)
15:28:07 <spotz> My bouncer is still freenode, oftc and libera aren't on it yet:(
15:28:11 <gmann> #link https://etherpad.opendev.org/p/tc-xena-tracker
15:28:24 <gmann> I have updates on my side
15:28:51 <gmann> on PTL guide etc I have updated it with OFTC and projects are merging the patches faster than before
15:29:21 <gmann> on UC repos, I found some of the repo we can retire. I will prepare the etherpad next week to discuss about those repo
15:29:37 <gmann> that is all from my side
15:29:51 <gmann> anyone please update if you have any progress on your assigned item
15:31:14 <ricolin> updating
15:31:31 <gmann> thanks
15:31:48 <gmann> everyone (tc-members ) please check your assigned item. we will again track it on 24th June meeting
15:32:03 <gmann> moving next
15:32:05 <gmann> #topic Recommendation on moving the meeting channel to project channel
15:32:15 <gmann> #link https://review.opendev.org/c/openstack/project-team-guide/+/794839
15:32:40 <gmann> as we discussed about suggesting project to move their meeting to project channel, I am updating the project team guide for that
15:32:54 <gmann> I think we do not need resolution for that as such and updating it in project team guide is enough
15:33:04 <gmann> but we can check it here if any tc is against of that ?
15:33:23 <fungi> i'm still unclear on where that recommendation came from, it's a reversal to a very long-standing recommendation
15:33:32 <gmann> FYI: nova, neutron and few more projects already moved their meritng
15:33:34 <gmann> meeting
15:33:36 <spotz> I thhink all the meetings I go to arer in channel for the last few years
15:33:51 <yoctozepto> fungi: to get more eyes on meetings
15:34:03 <dansmith> fungi: it came from me, at least
15:34:21 <dansmith> glance does not want to move, FWIW, and even though I wish they would, there's really no reason to require it, IMHO
15:34:25 <fungi> more eyes? by expecting everyone to be in every project's channel if they want to participate in meetings, seems like that would be fewer eyes
15:34:54 <yoctozepto> folks interested in a project sit in its channel
15:35:25 <fungi> not openstack any longer, but the infra meetings when given the choice even created a new dedicated meeting channel to keep their regular channel discussions and bot announcements from colliding with the meeting
15:35:26 <spotz> There's pros and cons both ways to be honest
15:35:31 <gmann> I think most of the audience now a days  in meetings are project active contributors or who are already in that channel
15:36:18 <yoctozepto> fungi: you run a very active support
15:36:21 <fungi> makes sense, openstack as a whole is becoming increasingly silo'd so cross-project cooperation is probably less and less of an expectation these days
15:36:57 <gmann> well cross-project is separate things, most of contributors are already doing cross-project contribution
15:37:15 <gmann> most of us involved in multiple projects so we have are in those channel
15:37:31 <gmann> attending meeting in project channel does not ask anything extra
15:37:55 <fungi> well, until they decide to all also reschedule to the exact same timeslots i suppose
15:38:32 * fungi is already triple-booked during tc meetings, expects things to get worse after this
15:38:41 <gmann> yeah but that is less chance
15:38:54 <dansmith> fungi: get worse after what?
15:38:57 <yoctozepto> you are good at multitasking, fungi
15:39:05 <gmann> most of project ask via doodle vote so we adjust the conflcit
15:39:13 <fungi> dansmith: more meetings colliding in the same timeslots
15:39:18 <spotz> I understand tthe double and triple booked thing:(
15:39:22 <dansmith> and they don't avoid a time because there are no meeting channel slots, I'm sure :)
15:39:30 <gmann> like nova ask and I or dansmith vote for non-tc meeting time slot so less chance of conflict
15:39:58 <fungi> well, we used to avoid having too many meetings at the same time bu scheduling them cross-project into a limited number of channels, but yes that's no longer in vogue
15:40:00 <gmann> double triple booking is for separate reason i think not becasue of where those meeting are
15:40:26 <dansmith> since we gained eleventy billion projects I think that's pretty much out the window anyway
15:40:39 <spotz> fungi's point is therer was less of that if everryone booked there meetings in 1 of 4 rooms
15:41:25 <gmann> if that happen then attendees will ask either of one to reschedule
15:41:28 <dansmith> so eleventy billion divided by 4 is greater than 24,
15:41:33 <gmann> that is how it work now a days
15:41:39 <dansmith> or even 24*7 :)
15:41:42 <dansmith> right
15:41:50 <fungi> i'll cope well enough, i already join ~50 different project channels for openstack, and regularly deal with participating in multiple meetings simultaneously, just not sure if the same goes for other folks
15:42:46 <yoctozepto> may we add some functionality to irc-meetings
15:43:01 <yoctozepto> to let projects designate what other projects should not collide
15:43:18 <yoctozepto> if we really think, it's going to be a huge issue
15:43:21 <yoctozepto> I personally don't
15:43:45 <gmann> anyways let's review the proposal in this patch and I will keep it open until next meeting. if I see many objection then we can discuss it again  #link https://review.opendev.org/c/openstack/project-team-guide/+/794839
15:43:52 <yoctozepto> ++
15:44:24 <gmann> #topic Open Reviews
15:44:26 <gmann> #link https://review.opendev.org/q/projects:openstack/governance+is:open
15:45:04 <gmann> fungi: In case you forget. I am waiting for your vote in this #link https://review.opendev.org/c/openstack/governance/+/795385
15:45:07 <belmoreira> I understand fungi concern and I still remember the discussions before the introduction of meeting-alt. But since the addition of the different meeting channels we have been moving this issue...
15:45:12 <gmann> or you do not want to retire it :)
15:45:29 <fungi> gmann: yep, i'm in the middle of a multi-day internet outage so... it may be a bit still
15:45:37 <gmann> fungi: sure
15:45:45 <fungi> but thanks for the reminder
15:46:12 <gmann> tc-members: please vote on these two #link https://review.opendev.org/c/openstack/governance/+/794366  #link https://review.opendev.org/c/openstack/governance/+/794680
15:47:33 <spotz> done
15:47:53 <gmann> belmoreira: yeah, even with 4 meeting channels, i personally find it difficult to keep up with every meeting.
15:48:34 <gmann> thanks.
15:48:42 <gmann> anything else to discuss today?
15:49:35 <gmann> if nothing let's close then
15:49:38 <gmann> thanks everyone for joining.
15:49:41 <gmann> #endmeeting