15:00:16 <gmann> #startmeeting tc
15:00:16 <opendevmeet> Meeting started Thu Jun 17 15:00:16 2021 UTC and is due to finish in 60 minutes.  The chair is gmann. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:16 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:16 <opendevmeet> The meeting name has been set to 'tc'
15:00:22 <gmann> #topic Roll call
15:00:23 <dansmith> o/
15:00:23 <jungleboyj> o/
15:00:25 <gmann> o/
15:00:30 <belmoreira> o/
15:00:31 <spotz> o/
15:01:04 <yoctozepto> o/
15:01:59 <gmann> let's start
15:02:00 <gmann> #topic Follow up on past action items
15:02:16 <gmann> gmann reachout to sahara team and PTL to get control of the #openstack-sahara channel
15:02:39 <gmann> there is no response , I will check again
15:02:43 <fungi> that's been solved
15:02:47 <gmann> ok
15:02:51 <gmann> did you get contyrol
15:03:09 <diablo_rojo> o/
15:03:12 <fungi> sergey got back to folks, and got access turned over, and i've reverted the temporary bot removal patch for that channel, so yeah all set now
15:03:40 <gmann> fungi: great. thanks
15:03:53 <fungi> at this point there are no remaining channel access tasks
15:04:04 <gmann> nice, thanks again
15:04:05 <fungi> we're completely caught up
15:04:08 * mnaser wallks in late
15:04:16 <ricolin> o/
15:04:19 <jungleboyj> fungi:  Nice!
15:04:32 <gmann> ricolin to send email on asking projects to enable and test tls-proxy in their jobs
15:05:11 <ricolin> also send patches already to projects
15:05:11 <gmann> ricolin: you did I think
15:05:18 <fungi> i know he sent it, i read it ;)
15:05:24 <ricolin> to enable tls-proxy
15:05:28 <spotz> :)
15:05:33 <gmann> #link http://lists.openstack.org/pipermail/openstack-discuss/2021-June/023000.html
15:05:38 <ricolin> #link https://review.opendev.org/q/topic:%2522exame-tls-proxy%2522+(status:open+OR+status:merged)
15:07:09 <gmann> mnaser, yoctozepto, and jungleboyj to work on cinder bug with cinder team.
15:07:23 <gmann> any update on the cinder bug
15:07:24 <mnaser> i had some discussions .. yesterday or before yesterday? this week is all a blur :)
15:07:32 <jungleboyj> gmann:  I followed up with Cinder and thanks to mnaser for debug help.
15:07:38 <mnaser> we've identified one failure caused by a segfault that has an open patch
15:07:40 <mnaser> not sure if that merged or not
15:07:51 <jungleboyj> I need to double check.
15:07:54 <mnaser> #link https://review.opendev.org/c/openstack/cinder/+/772126
15:08:15 <jungleboyj> mnaser:  Ah good.  Will work to get that merged today.
15:08:24 <gmann> nice
15:08:27 <mnaser> so this is ONE failure case where lvdisplay was segfaulting ... so, once that merges, if we see more further failures, id be happy to debug them
15:08:37 <jungleboyj> We also had barbican issues causing failures which are now fixed.
15:08:39 <mnaser> i dont know if this is going to close all of the issues, but, it's one class of them
15:08:58 <mnaser> thanks to dansmith for sharing a failure with me,
15:09:00 <jungleboyj> I think that there will be more sefaults that we need to handle.
15:09:21 <mnaser> please feel free to share cinder fails with me and im happy to debug, turns out being an operator for a hot minute means you can comb through these failures quickly (:
15:09:24 <jungleboyj> We have gotten agreement from the Cinder team to not blindly recheck but to start keeping track of failures.
15:09:44 <jungleboyj> mnaser:  Yeah, I was impressed with the response time. :-)
15:09:44 <gmann> that is good direction
15:09:46 <mnaser> jungleboyj please cc me on any failures and ill gladly dig into them
15:09:56 <jungleboyj> mnaser: Awesome.  Thank you!
15:10:07 <fungi> our ci resources thank them for not just blindly rechecking changes without looking into failures too ;)
15:10:09 <jungleboyj> So, I think we made good progress there this week.
15:10:14 <mnaser> gmann: in summary, we're moving in a positive direction
15:10:23 <dansmith> excellent news
15:10:30 <gmann> great, thanks a lot mnaser jungleboyj dansmith for getting things done
15:10:42 <gmann> and Cinder team.
15:10:45 <spotz> Great work!
15:11:07 <jungleboyj> :-)
15:11:13 <gmann> let's move to next topic
15:11:15 <gmann> #link Gate health check (dansmith/yoctozepto)
15:11:19 <gmann> this is same topic
15:11:23 <gmann> any other news
15:11:28 <dansmith> nothing other than the above from me
15:12:22 <gmann> ok
15:12:34 <jungleboyj> That is progress too.  :-)
15:12:48 <gmann> #topic Gate health check (dansmith/yoctozepto)
15:12:55 <gmann> sorry i missed the topic thing
15:12:59 <dansmith> look gmann , I said no more! :P
15:13:11 <dansmith> oh, hehe
15:13:18 <gmann> ok
15:13:30 <gmann> #topic Migration from 'Freenode' to 'OFTC' (gmann)
15:13:30 <jungleboyj> ヽ(ຈل͜ຈ)ノ︵ ┻━┻
15:13:40 <gmann> #link https://etherpad.opendev.org/p/openstack-irc-migration-to-oftc
15:13:52 <mnaser> freenode helped us in doing that so thats nice
15:13:54 <mnaser> is anyone still there?
15:14:08 <gmann> I sent reminder to projects to finish the wiki/doc updates
15:14:09 <dansmith> I dropped all my openstack joins
15:14:14 <gmann> me too
15:14:20 <jungleboyj> I got k-lined
15:14:37 <jungleboyj> Gave up at that point.
15:14:43 <spotz> I'm still thterer I thihnk
15:15:08 <gmann> I did small write up also in openatack blog #link https://www.openstack.org/blog/the-openstack-community-irc-network-moved-to-oftc/
15:15:28 <gmann> and OpenStack/Openinfra site required update on two page are also informed
15:16:00 <gmann> also I asked Alison price about twitter etc from openstack account
15:16:17 <gmann> and remaining thigns we need is to finish the project side wiki/doc
15:16:28 <gmann> I will keep this until we finish those too
15:16:45 <gmann> anything else on this topic ?
15:17:33 <gmann> #topic Recommendation on moving the meeting channel to project channel
15:17:39 <gmann> #link https://review.opendev.org/c/openstack/project-team-guide/+/794839
15:17:46 <gmann> this is merged now so we are good on this
15:17:55 <gmann> I will remove this from next meeting agenda
15:18:07 <gmann> #topic Governance nono-active repos retirement & cleanup
15:18:22 <gmann> #link https://etherpad.opendev.org/p/governance-repos-cleanup
15:18:37 <gmann> I started this ^^ etherpad to cleanup the non-active repos under governance
15:19:09 <gmann> I added some data also like last relevant commit
15:19:21 <gmann> any objection on any of the repo to start the retirement ?
15:19:50 <spotz> I'm good
15:20:14 <yoctozepto> ++
15:20:30 <gmann> openstack/scientific-wg one is to talk to Scientific SIG first and then take decision, I will reach out to them
15:21:02 <gmann> ok, I will start cleaning those
15:21:32 <gmann> before I move to Open Review
15:21:42 <spotz> I haven't seen any Scientific SiH meeting reminderrs in a while but think they're still about
15:22:00 <gmann> yeah, I will email to chair
15:22:01 <belmoreira> they are still going
15:22:32 <gmann> Y release naming: we have one TC member yet to vote on Y release name
15:22:38 <gmann> today is last day to vote
15:22:54 <yoctozepto> the scientific-wg repo does not look relevant too much anyway
15:22:59 <yoctozepto> they might be good to retire it as well
15:23:03 <yoctozepto> but yeah, needs asking
15:23:13 <gmann> yoctozepto: yeah in case you want to continue or so
15:23:21 <yoctozepto> gmann: and you won't tell us who that late member is?
15:23:27 <yoctozepto> I hope you remembered to vote :-)
15:23:32 <gmann> I do not know until I end the vote
15:23:49 <gmann> CIVS just show the number of voter vs authorized voters
15:23:51 <yoctozepto> oh, tricky
15:23:59 <jungleboyj> I voted this morning.  Have you checked in the last hour or so?
15:24:12 <spotz> Vote vote!!!!
15:24:17 <gmann> yes, just now i refreshed
15:24:22 * yoctozepto remembers morning was 9 hours ago
15:24:31 <jungleboyj> :-)
15:24:37 <jungleboyj> My morning.
15:24:44 * jungleboyj is still in morning.
15:24:47 <yoctozepto> obviously
15:24:54 <yoctozepto> it is either timezone or a good party :-)
15:25:02 <yoctozepto> (or both)
15:25:04 <jungleboyj> Bwah hah ha
15:25:14 <belmoreira> I liked what jungleboyj did with the poll
15:25:48 <jungleboyj> Thanks.  I didn't expect the response I got and unfortunately found out that Survey Monkey holds your info hostage after 40 respondents.
15:25:49 <gmann> yeah, I still like to have community to vote instead of just TC but jungleboyj way is good to get vote from community
15:26:01 <spotz> <e too, wish I'd thougght of it but I'dd just voted when he posted!
15:26:03 <belmoreira> it shows that people are willing to participate
15:26:10 <gmann> yes
15:26:29 <jungleboyj> gmann:  Yeah, wanted to get the community input too and let everyone feel like they could help.  Honestly, I couldn't choose and needed help.
15:26:33 <spotz> Do we maybe want to open voting back up?
15:26:47 <yoctozepto> jungleboyj: what won from the community?
15:26:47 <gmann> I am in favor of that
15:26:51 <spotz> yoda:)
15:27:02 <jungleboyj> spotz:  I would say yes, but it got so contentious.
15:27:12 * spotz rerad the tweet:)
15:27:24 <gmann> ok, Iw ill add topic in next meeting for voting rights to communtiy again
15:27:32 <jungleboyj> https://twitter.com/jungleboyj/status/1405503937470513154
15:27:48 <spotz> Sweet, I like the idea I wasn't sure why it changed
15:27:48 <jungleboyj> So, likely it will be Yak?
15:28:00 <belmoreira> I think this is one of the things that all the community should be involved. I don't remember why it changed
15:28:13 <fungi> the problem with opening voting up "to the community" is you'll need to settle on a mechanism for doing that (deciding who gets to vote, how to let people know to vote, et cetera) whereas holding a poll for a known set of contacts is relatively trivial
15:28:27 <spotz> I honestly don't know if yoda will pass legal but think of the poossibilities. We can have Baby Yoda as rc1:)
15:28:44 <yoctozepto> lol
15:28:50 <belmoreira> fungi true
15:29:10 <gmann> we can find some mechanish on that, let's discuss next
15:29:11 <jungleboyj> spotz:  Yeah, depending on what the final vote is we are likely to have Legalissues.
15:29:12 <gmann> next week
15:29:13 <gmann> for this release, can everyone check if they have voted or not.
15:29:23 <spotz> I did
15:29:29 <jungleboyj> I did.
15:29:36 <fungi> but also, in the end, it's the tc and foundation legal who have to agree on a choice, so it gets contentious when the community favorite winds up getting overridden by tc dictate
15:29:47 <mnaser> i just did
15:30:00 <yoctozepto> oh, so we have all votes cast
15:30:02 <mnaser> (but honestly didn't pick a name because i still don't think i get to name releases)
15:30:06 <gmann> fungi: yeah, we need to change that thingsso that we can avoid ussuri likle situation
15:30:10 <yoctozepto> SHOW US THE RESULTS
15:30:15 <yoctozepto> :D
15:30:16 <jungleboyj> fungi:  Ah, that is right.  I knew the community was upset by something in the process.  It was the fact we had to override.
15:30:20 <gmann> mnaser: ditto, same here
15:30:41 <gmann> dansmith: diablo_rojo ?
15:30:43 <mnaser> so everything is ranked 18 for me
15:30:54 <jungleboyj> OMG, so we don't even have everyone voting.
15:31:12 <gmann> ricolin: ?
15:31:13 <diablo_rojo> I voted.
15:31:16 <jungleboyj> I guess we do need to change the process given that I went to a community vote.
15:31:30 <dansmith> gmann: what are you asking me? I voted.
15:31:41 <gmann> jungleboyj: yeah, I am in favor of that since starting
15:31:43 <gmann> dansmith: ok
15:32:11 <gmann> I think ricolin left then ?
15:32:12 <belmoreira> also voted
15:32:22 <gmann> I will check with him
15:32:30 <ricolin> sorry catching up, double meeting_
15:32:39 <yoctozepto> ricolin: vote for Y name :-)
15:32:45 <ricolin> oh!
15:32:46 <ricolin> voted!
15:32:48 <ricolin> :)
15:32:54 <yoctozepto> oh
15:32:59 <gmann> great, its  vote now
15:32:59 <yoctozepto> then gmann needs to refresh
15:33:05 <gmann> let me end and see result
15:33:11 * yoctozepto can't wait
15:33:19 <gmann> https://civs1.civs.us/cgi-bin/results.pl?id=E_f065453ffd2537cb
15:33:25 * jungleboyj does a drumroll, Christmas Vacation Style.
15:33:40 <yoctozepto> oh noez
15:33:52 <gmann> I also voted 18 for all with same reason mnaser mentioned
15:33:53 <dansmith> ugh, so it's going to be york?
15:34:03 <mnaser> well
15:34:08 <mnaser> we need legal vetting first
15:34:15 <mnaser> so id wait before we go screaming to the twittarz :)
15:34:17 <dansmith> right I assume yoda and yeti will be ruled out
15:34:19 <jungleboyj> Assuming that Yoda and Yeti lose upon legal vetting.
15:34:30 <gmann> as next step i will check the legal things with foundation
15:34:33 <yoctozepto> so it's Yak then
15:34:40 <jungleboyj> And it is a tie between York and Yak.
15:34:56 <jungleboyj> Yak was rated higher in my community vote so I would support that.
15:35:00 <diablo_rojo> Yeah definitely let legal go first.
15:35:07 <jungleboyj> :-)
15:35:12 <ricolin> will see
15:35:19 <diablo_rojo> I had already voted before jungleboyj started his poll or I would have done 18 for all of them too.
15:35:21 <spotz> Yeti should pass legal
15:35:24 <ricolin> I still give my high hope on Yoda:)
15:35:27 <gmann> yeah, this is one part of process and we will get the final name after legal checks
15:35:37 <diablo_rojo> As it was I did 18 for 15 of them and 1 for three pronounceable names.
15:35:37 <jungleboyj> Oh, I am sorry, York isn't tied with Yak
15:35:57 * jungleboyj is glad that 'you' didn't win.
15:36:15 <yoctozepto> ^ that ^
15:36:17 <yoctozepto> :D
15:36:23 <gmann> one more thing which is not in agend but good to discuss "election official onboarding meeting  by diablo_rojo "
15:36:24 <jungleboyj> spotz:  Yeti ... The coolers.
15:36:25 <fungi> i suppose if it winds up being york, we know where to have the next ptg
15:36:25 <dansmith> You should have been disqualified,
15:36:26 <ricolin> `you cycle` sounds strange :)
15:36:33 <yoctozepto> yeah, it's not a noun
15:36:36 <yoctozepto> it's a pronoun
15:36:38 <gmann> diablo_rojo: go ahead
15:36:43 <dansmith> because it would be impossible to distinguish between people saying U release and You release
15:37:12 <jungleboyj> OpenStack is all of us.
15:37:27 <fungi> it's the y'all release down here
15:37:39 <jungleboyj> LOL
15:37:42 <spotz> jungleboyj: Yeah but Rocky the movie, I think therer's enough other uses of the word
15:37:49 <yoctozepto> dansmith: we should call it "Why" as in "Why did you call it <<you>>?"
15:37:54 <diablo_rojo> Oh yeah well I setup a meeting
15:37:56 * dansmith scowls
15:38:03 <diablo_rojo> for the...
15:38:06 <jungleboyj> spotz:  Well, we will see what happens with Legal.
15:38:09 <gmann> ohk moving to   "election official onboarding meeting  by diablo_rojo "
15:38:09 <gmann> 10:36 AM <jungleboyj> Jay Bryant
15:38:11 <diablo_rojo> 29th
15:38:22 <gmann> jungleboyj: sorry, it was copy paste :)
15:38:28 <diablo_rojo> Yes.
15:38:37 <spotz> jungleboyj: I'm just saying it's a possible. Yoda I don't think will pass:(
15:38:38 <gmann> #link http://lists.openstack.org/pipermail/openstack-discuss/2021-June/023060.html
15:38:39 <diablo_rojo> So, for those interested in being election officials.
15:38:43 <diablo_rojo> Please join!
15:38:58 <gmann> who all volutneer to help for next election ?
15:39:12 <jungleboyj> Cool.
15:39:26 <diablo_rojo> I will have to teach people and then hang around in an advisory capacity becuase I think I am up for reelection.
15:39:28 <gmann> diablo_rojo: I think you would not be able to be election official if you are running for TC.
15:39:35 <gmann> ok
15:39:37 <diablo_rojo> gmann, yep, that is correct.
15:39:43 <spotz> I said I'd help
15:39:51 <gmann> we need two member at least right? or one is enough
15:39:52 <fungi> or for ptl
15:39:57 <diablo_rojo> spotz, does that meeting work for you?
15:40:05 <diablo_rojo> we can run a combined election again
15:40:11 <fungi> more generally, if you're running for an office you can't officiate the election you're also running for, as it would be a conflict of interest
15:40:13 <jungleboyj> I offered to help if you guys need me.
15:40:19 <gmann> +1 for combined election
15:40:23 <diablo_rojo> What fungi said :)
15:40:35 <diablo_rojo> jungleboyj, aren't you going to be up for reelection with me?
15:40:44 <fungi> s/can't/shouldn't/ really
15:41:31 <jungleboyj> diablo_rojo:  Yes, but I am not planning on running again at this point in time.
15:41:35 <spotz> diablo_rojo: yeah it looks doable. I'll get it on my work calendarr. Won't say I won't be on the pony:)
15:41:39 <gmann> I will add this to next meeting agenda also to have next election official or we get someone from community
15:41:43 <diablo_rojo> jungleboyj, oh cool then yes please help
15:41:48 <jungleboyj> :-)
15:41:50 <diablo_rojo> gmann, sounds good
15:42:11 <diablo_rojo> jungleboyj, spotz I attached the ical to the email so you should be able to block your calendars with it
15:42:11 <gmann> #action gmann to add election official assignments in next week meeting agenda
15:42:40 <jungleboyj> Yep.  It is on my calendar.  I will attend the meeting.  If there are enough people interested in helping I will leave my options open.
15:42:47 * jungleboyj is all about going with the flow lately.
15:43:13 <spotz> hehe
15:43:17 <gmann> jungleboyj: spotz thanks
15:43:32 <gmann> #topic Open Reviews
15:43:35 <gmann> #link https://review.opendev.org/q/projects:openstack/governance+is:open'
15:43:56 <diablo_rojo> You are all welcome to join to learn about the process even if you don't help this time
15:44:04 <gmann> panko retirement has enough vote but I added OpenStack Puppet PTL to ack this.
15:44:12 <gmann> diablo_rojo: ++
15:44:12 <diablo_rojo> Learning this time doesn't mean you HAVE to do it for the next election
15:44:40 <jungleboyj> diablo_rojo:  My thought exectly.
15:45:00 <yoctozepto> gmann: I'd say puppet has nothing to deploy if panko is retired
15:45:47 <gmann> yoctozepto: yes, but as pocess we need PTL +1 for repo retirement from their project
15:46:24 <yoctozepto> gmann: should mrunge repropose to retire only telemetry's part then and don't worry about puppet-panko?
15:47:23 <gmann> yoctozepto: puppet-panko content is also removed so we can do it together or in separate patch which agfain need PTL +1
15:47:32 <gmann> so I am fine with waiting on this patch itself
15:47:37 <yoctozepto> ack
15:48:21 <gmann> I added them in Reviewer but they have not yet voted. I will ping on IRC also if available
15:48:37 <gmann> that's all form me for today meeitng
15:48:38 <gmann> anything else to discuss?
15:48:47 <yoctozepto> not from me
15:49:01 <jungleboyj> Nothing from me.
15:49:19 <ricolin> diablo_rojo, can you update according https://review.opendev.org/c/openstack/governance-sigs/+/778304/4/sigs.yaml#b163
15:49:21 <spotz> Nada
15:49:33 <ricolin> for the K8s SIG irc
15:50:23 <diablo_rojo> Sure.
15:50:26 <ricolin> nothing else from me
15:50:33 <ricolin> diablo_rojo, thanks:)
15:50:41 <gmann> ok, let's close then
15:50:41 <gmann> thanks all for joining.
15:50:45 <gmann> #endmeeting