15:00:04 <gmann> #startmeeting tc
15:00:04 <opendevmeet> Meeting started Thu Jul  1 15:00:04 2021 UTC and is due to finish in 60 minutes.  The chair is gmann. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:05 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:05 <opendevmeet> The meeting name has been set to 'tc'
15:00:08 <gmann> #topic Roll call
15:00:20 <jungleboyj> o/
15:00:21 <gmann> o/
15:00:23 <mnaser> (kinda here :])
15:00:26 <ricolin> o/
15:00:32 <yoctozepto> o/
15:00:34 <belmoreira> o/
15:00:48 * dansmith is here but not really
15:00:51 * gmann ah remember now its holiday today here :)
15:01:04 <gmann> #link https://wiki.openstack.org/wiki/Meetings/TechnicalCommittee#Agenda_Suggestions
15:01:08 <gmann> this ^^ is today agenda
15:01:32 <gmann> let's start
15:01:33 <gmann> #topic Follow up on past action items
15:02:01 <gmann> no action item from previous meeting
15:02:25 <gmann> #topic Gate health check (dansmith/yoctozepto)
15:02:30 <gmann> any news on gate health
15:02:40 <spotz> o/
15:03:15 <jungleboyj> The Cinder team has a couple of patches for the LVM crashes that are up and have been merged.
15:03:20 <jungleboyj> Continue to work those.
15:03:27 <mnaser> sweet
15:03:40 <gmann> nice
15:03:42 <yoctozepto> I haven't heard complaints recently
15:03:49 <gmann> one I remember is live migration tempest test failure which is fixed now.
15:04:13 <jungleboyj> :-)
15:04:15 <gmann> thanks jungleboyj for updates
15:04:30 <jungleboyj> gmann:  Welcome.
15:04:39 <gmann> anything else on Gate status side?
15:05:16 <gmann> #topic Migration from 'Freenode' to 'OFTC' (gmann)
15:05:24 <diablo_rojo> o/
15:05:30 <gmann> #link https://etherpad.opendev.org/p/openstack-irc-migration-to-oftc
15:05:47 <jungleboyj> Nothing from me.
15:06:04 <gmann> i do not have any progress in this week. I will do next week for remaining project side doc update
15:06:28 <gmann> #topic Governance non-active repos retirement & cleanup
15:06:31 <gmann> #link https://etherpad.opendev.org/p/governance-repos-cleanup
15:06:46 <gmann> all the patches are merged now in this and cleanup is completed
15:06:58 <gmann> I will remove this from next meeting agenda
15:07:11 <jungleboyj> \o/
15:07:22 <gmann> #action gmann to remove Governance non-active repos cleanup topic from agenda
15:08:00 <gmann> if we find any other repo which needs to be merged/cleanup then we can do that later
15:08:07 <gmann> #topic Election official assignments
15:08:19 <gmann> we have three proposed election official now
15:08:29 <gmann> 1. Belmiro: https://review.opendev.org/c/openstack/election/+/798822
15:08:34 <gmann> 2. Amy: https://review.opendev.org/c/openstack/election/+/798907
15:08:42 <gmann> 3. Helena: https://review.opendev.org/c/openstack/election/+/798729
15:08:44 <fungi> huge thanks to the three of you for stepping up!
15:08:59 <gmann> yeah, thanks belmoreira spotz helena
15:09:22 <gmann> to merge these patches we need to merge this gate fix #link https://review.opendev.org/c/openstack/election/+/798916
15:09:30 <spotz> My pleasure:)
15:10:17 <gmann> diablo_rojo: ^^ can you check 798916 ?
15:11:35 <gmann> who is 2nd reviewer in elections repo? I think Ian ?
15:12:10 <gmann> we have spotz belmoreira also added
15:12:22 <gmann> can you check this #link https://review.opendev.org/c/openstack/election/+/798916
15:12:42 <gmann> or fungi ^^
15:12:43 <gmann> https://review.opendev.org/admin/groups/208108b62745877449d8e6fce45f44e3cc013e8b,members
15:13:00 <belmoreira> sure
15:13:09 <gmann> thanks
15:13:09 <spotz> reviewed
15:13:34 <gmann> once this merge then we can recheck on other patches
15:13:40 <spotz> wasn't suree if I should +w yet though
15:13:40 <gmann> and on next election dates #link https://review.opendev.org/c/openstack/election/+/798719
15:13:58 <gmann> yeah me too, may be diablo_rojo added you
15:14:23 <gmann> I thought it will be after election official patch merge, but anyways.
15:14:28 <spotz> She did, but I tend to like 2 +2 if the repo is active
15:14:41 <gmann> yeah
15:14:53 <gmann> I commented on dates for next electrion to macth with our charter
15:15:37 <gmann> and we need to wait until we have Y release name which might be next week as I received information from foundation on trademark check
15:16:11 <diablo_rojo> Double meetings, sorry.
15:16:17 <jungleboyj> gmann:  Any news on the naming?
15:16:23 <diablo_rojo> Yeah I will take a look at the gate fix.
15:16:29 <spotz> I so want to call RC1 Baby Yoda:(
15:16:40 <gmann> jungleboyj: yeah, next week we will get the trademanrk check by foundation
15:17:31 <jungleboyj> gmann:  Ok.  people have been asking.
15:17:35 <gmann> diablo_rojo: fungi belmoreira spotz just a question do we keep only current election official in core goups or is it fine to have previous ofificial also ?
15:17:42 <jungleboyj> spotz:  I think that is unlikely.  :-(
15:17:47 <gmann> jungleboyj: yeah, I am hoping by next week we should be ready
15:17:53 <diablo_rojo> gmann, I have periodically culled the group
15:18:00 <diablo_rojo> I am not aggressive about removing people though
15:18:13 <spotz> jungleboyj: hence the :( I'd be really surprised if we get to use Yoda. I think it'll be Yeti
15:18:36 <spotz> Yezh like Andy was still in there but I had only heard Ian mentioned
15:18:38 <fungi> yeah, i have no need to be in the election officials team in gerrit, as i'm no longer an official
15:18:53 <diablo_rojo> fungi, I can remove you right now.
15:18:54 <fungi> especially if we have several people in it now who can approve any tooling fixes i end up proposing
15:19:00 <gmann> ack, may be we can do once we merge the new election offiicals patches
15:19:00 <fungi> thanks diablo_rojo!
15:19:17 <diablo_rojo> 'free' you from the bonds of election officiating
15:19:24 <gmann> thanks
15:19:25 <gmann> I will remove this topic from agenda for next meeting.
15:19:41 <gmann> anything else on this topic?
15:20:10 <diablo_rojo> fungi is freeeeeeeeeeee
15:20:14 <gmann> #action gmann to remove election assignments topic form agenda
15:20:35 <gmann> diablo_rojo: hehe he never :) free form elections things may be
15:20:37 <diablo_rojo> Current list- spotz andymccr, belmoreira, hspease, ianychoi and myself
15:20:39 <jungleboyj> #freeFungi
15:20:47 <gmann> one more things about election
15:20:51 <diablo_rojo> jungleboyj, LOLOLOLOL
15:21:21 <gmann> L65 in https://etherpad.opendev.org/p/tc-xena-tracker
15:21:24 <spotz> But then I'll be lonely!
15:21:34 <gmann> spotz: belmoreira this is extra step for this election "One extra step here:  CIVS changed its policy on email communication in April 2021. To vote in private CIVS polls, Authorized voters must opt in to email communication from the service via https://civs1.civs.us/cgi-bin/opt_in.pl. We need to add this as a pre-step for the election once electorate are finalized. "
15:21:48 <gmann> that is what I did for TC votes on Y release name
15:21:53 <spotz> Yeah I rermember that from the naming election
15:21:58 <diablo_rojo> Oh nooooo
15:22:32 <fungi> it took effect *immediately* (like a day or two) after we created the last tc/ptl polls
15:22:48 <diablo_rojo> that is lucky.
15:22:48 <gmann> yeah
15:22:53 <fungi> i think it was right after the special tc election actually
15:23:02 <diablo_rojo> Yeah that sounds right
15:23:11 <diablo_rojo> I don't recall doing extra stuff for that special election
15:23:16 <fungi> because i remember running into it when trying to resend a ballot to one voter while the poll was open
15:23:41 <spotz> So can we send a pre-voting opt-in like a week before?
15:23:50 <fungi> but regardless, it means we need to talk about our options yeah
15:23:57 <gmann> spotz: may be
15:23:58 <gmann> k, may be you all can disucss it in election channel on how to do that but this is somehting we should figure out before we send the poll link
15:24:20 <gmann> fungi: +1
15:24:27 <belmoreira> thanks gmann for the heads up
15:24:32 <fungi> like announcing in various places that people who want to vote need to allow civs to e-mail them first
15:24:47 <fungi> or running our own copy of civs somewhere instead
15:25:07 <spotz> I heard civs wasn't supported anymore?
15:25:23 <gmann> yeah, let's discussed on detail after meeting or on election channel ?
15:25:43 <gmann> next topic is
15:25:46 <gmann> #topic let's move to next topic
15:25:49 <gmann> ohh
15:25:55 <ricolin> haha:)
15:26:01 <gmann> #topic Items for next Newsletter
15:26:24 <gmann> we have next month newsletter and need to put 2-3 items for news
15:26:46 <gmann> ricolin: Y release goal is added i previous newsletter right?
15:27:10 <ricolin> gmann, I don't think we do
15:27:22 <gmann> its there
15:27:24 <gmann> #link https://superuser.openstack.org/articles/inside-open-infrastructure-the-latest-from-the-openinfra-foundation-4/
15:27:38 <ricolin> okay
15:27:55 <gmann> what all items we can add ?
15:28:08 <opendevreview> Merged openstack/election master: Add election_results to cycle data  https://review.opendev.org/c/openstack/election/+/798916
15:28:22 <diablo_rojo> We can add the discussion of y goals to the newsletter again
15:28:26 <diablo_rojo> even if it was there before
15:28:57 <ricolin> EOL ocata?
15:29:00 <spotz> Yeah cause the more ideas the better. I like the pain points one alot
15:29:02 <gmann> sure, that will help +1
15:29:15 <gmann> ocata EOl is good info,
15:29:26 <jungleboyj> Would say add news about the naming but sounds like we won't have that in time?
15:29:30 <spotz> I just EOLed Stein in some docs yesterday.
15:29:36 <gmann> jungleboyj: yeah
15:29:41 <gmann> one item I think is adding pre-step for CIVS poll? we should wait until election officials finalize the mechanish of that.
15:29:51 <spotz> Oh good call gmann!
15:30:13 <gmann> so that people can start it early
15:30:15 <spotz> I would say give folks a heads up on the opt-in now and as many times as we can
15:30:24 <gmann> yeah
15:30:38 <spotz> Just a please be aware you willreceive an email in the coming weeks to opt-in
15:30:51 <gmann> spotz: can you add some word and link in etherpad about it ?
15:31:15 <gmann> and  we can also ask 'you can do it in advance also'
15:31:38 <gmann> ok so, 1. ocata EOl ricolin can you add
15:31:46 <ricolin> yes
15:31:48 <gmann> I will add Y goal again
15:31:57 <spotz> yep
15:32:05 <gmann> great thanks
15:32:22 <gmann> #topic Open Reviews
15:32:28 <spotz> the tracker ether?
15:32:45 <gmann> this one https://etherpad.opendev.org/p/newsletter-openstack-news
15:33:34 <spotz> thanks
15:33:39 <gmann> #link https://review.opendev.org/q/projects:openstack/governance+is:open
15:33:47 <gmann> these are open reviews
15:34:36 <gmann> I think all review has erquired vote but please review those if you have not
15:34:56 <gmann> ricolin: thanks for headup for js-openstack-lib retirement
15:35:14 <gmann> there are some comment on governance and project-config patches to address first
15:35:16 <ricolin> gmann, NP, we still need ML from PTL
15:35:26 <gmann> ricolin: +1, thanks.
15:35:28 <ricolin> but everything is there
15:36:09 <gmann> that's all I have for today, anything else we need to discuss ?
15:36:15 <ricolin> yes
15:37:46 <ricolin> Julia have an idea about to allow projects to have a community goal like aiming their/ops most painful issues
15:38:05 <ricolin> #link http://lists.openstack.org/pipermail/openstack-discuss/2021-June/023352.html
15:38:34 <ricolin> would like to hear from all of you
15:38:36 <jungleboyj> Seems like a decent idea.
15:38:46 <gmann> Xena cycle also we had kind of similar? about stability of existing things.
15:39:34 <yoctozepto> I am also in favour
15:39:37 <spotz> I like the pain pooints goal as already mentioned. I added the Inclusive Naming stuff so we can at least officially be planning on what next
15:39:57 <gmann> we have I think two more candidate for Y, tls and RBAC
15:39:58 <ricolin> As pre-selecting step, we might be able to make actions like- ask projects to provide information on what's ops's most painful part
15:40:08 <ricolin> gmann, yes
15:40:09 <gmann> RBAC is also very imoportant for operator point of view
15:40:17 <gmann> ricolin: +1
15:40:36 <gmann> and we can collect the pain points in goal proposal first
15:40:36 <ricolin> gmann, but we said we gonna have 2 Y goals
15:40:47 <ricolin> but right now we're working on is to pre-selecting
15:40:53 <gmann> ricolin: it depends on what all goals and how much work needed
15:40:59 <spotz> I'd second RBAC, we also need to help folks understand why it's important as I bet most folks don't even know about policy.yaml/jsoon
15:41:13 <ricolin> gmann, that's the part I'm wondering
15:41:49 <gmann> so we get the goals proposed in proposed dir and then we can weight on each goal while selecting
15:42:11 <jungleboyj> Makes sense.
15:42:15 <ricolin> +1
15:42:20 <gmann> so let's start proposing/asking to propose as first step
15:42:32 <gmann> I will do for RBAC before next meeting
15:42:33 <fungi> progress on rbac would be nice from the vmt's perspective. we keep getting vulnerability reports opened from people who have created "project admin" roles and don't realize that users in it are full admins of a lot of services
15:42:37 <ricolin> So maybe we make actions like "collect the pain points"?
15:42:51 <gmann> fungi: yeah, good point.
15:43:11 <gmann> ricolin: +1, to projects right?
15:43:11 <fungi> right now the existing rbac half-implementation is an attractive nuisance
15:43:18 <ricolin> gmann, yes
15:43:19 <belmoreira> I like the idea about ops pain points, just wondering if devs have the same perception of pain points as ops. Who will provide the pain points?
15:43:39 <gmann> yes and system admin has its own chanlange on project mapped resources
15:43:49 <jungleboyj> belmoreira:  Probably not, but that is why it would be good to get that feedback.
15:44:12 <gmann> and especially for cross servier dependent resources, like system admin cannot create VM from nova but can create network from neutron
15:45:32 <gmann> maye be we can ask to add pain points in our goal backlog? there we have other pain points also which we plan to make goal
15:46:00 <gmann> #link https://etherpad.opendev.org/p/community-goals
15:46:00 <dansmith> definitely ++ from me for rbac
15:46:03 * dansmith catches up
15:46:03 <ricolin> belmoreira, do raise a good question: where we can ask for feedback first?
15:46:04 <spotz> belmoreira: That might be a good initiative for thhe ops meetuo folks or atleast the channel, a livestream, the user serrver?
15:46:21 <spotz> Sorry if I type fast I don't fix the typos:)
15:46:22 <ricolin> we can ask project teams, and where else?
15:46:47 <spotz> user vervey..
15:46:50 <spotz> grr
15:47:39 <ricolin> gmann, +1
15:47:47 <fungi> user oy vey
15:47:53 <jungleboyj> spotz:  is typing like she just left the dentist.
15:48:04 <yoctozepto> I like verveys
15:48:12 <belmoreira> spotz yes, I think user survey is good
15:48:19 <jungleboyj> belmoreira:  ++
15:48:20 <TheJulia> The verveys feedback has never proven really useful, at least for ironic. Most comments have tended to not be constructive, and the overall process means that that the actual feedback is only after translation and review from the foundation which means we're talking next year if we want to use that as imput
15:48:28 <spotz> I need a new keyboard, thhe Mac keybooards go weird on me after a yearr. This time quicker
15:48:29 <TheJulia> verveys++
15:49:07 <gmann> ok let's collect those pain points from all those channels/projects and add it in https://etherpad.opendev.org/p/community-goals
15:49:29 <fungi> yes, the survey is great for making demographic profiles and statistics, less for identifying what bugs to fix
15:49:31 <gmann> ricolin: can you ask it on ML from projects/ops side ?
15:49:37 <ricolin> yes
15:49:39 <jungleboyj> If nothing else, having a list of perceived pain points is useful.
15:49:41 <gmann> great thanks
15:50:11 <fungi> the ops sig should ideally be a great source of pain points
15:50:11 <gmann> #action ricolin to ask for collecting the ops pain points on openstack-discuss ML
15:50:26 <gmann> yeah, who is chair there?
15:50:58 <gmann> ah
15:51:16 <gmann> let's see if we have anyone coming up with help and then we can form
15:51:40 <belmoreira> fungi the problem is that the participation is not that much
15:51:41 <gmann> #action gmann to propose the RBAC goal
15:52:09 <fungi> belmoreira: yep, a separate problem also worth solving i suppose
15:52:58 <gmann> anything on this topic or any other topic to discuss today?
15:53:04 <TheJulia> I wonder if openinfra.live would be willing to do an general operator roundtable, or maybe join the operators for an hour?
15:53:23 <spotz> That's what I was thinking above, the AMA
15:53:24 <belmoreira> and I'm sure mine pain points will be different from most operators
15:53:30 <gmann> +1
15:53:58 <fungi> TheJulia: add it to https://ideas.openinfra.live/ !
15:54:08 <jungleboyj> ++
15:54:20 <gmann> #link https://openinfrafoundation.formstack.com/forms/openinfralive
15:54:37 <belmoreira> TheJulia ++
15:55:10 <TheJulia> fungi: that url is not accepting connections at this time
15:55:11 <ricolin> belmoreira, what potentially can do is collect pain points and allow project teams to select from
15:55:20 <gmann> TheJulia: #link https://openinfrafoundation.formstack.com/forms/openinfralive
15:56:04 <fungi> TheJulia: i just noticed, bringing it to the attention of the folks who run it
15:57:31 <spotz> We break all the things!
15:57:54 <gmann> :)
15:58:08 <gmann> thanks for all great discusison today and let's work on respective action items for various topic.
15:58:18 <gmann> if nothing else let's close the meeting
15:58:22 <fungi> TheJulia: it's http sorry, https is apparently not implemented there
15:58:24 <gmann> thanks all for joining
15:58:27 <spotz> Thanks gmann!
15:58:29 <gmann> #endmeeting