15:00:04 <gmann> #startmeeting tc
15:00:04 <opendevmeet> Meeting started Thu Sep  9 15:00:04 2021 UTC and is due to finish in 60 minutes.  The chair is gmann. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:04 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:04 <opendevmeet> The meeting name has been set to 'tc'
15:00:07 <diablo_rojo> o/
15:00:08 <gmann> #topic Roll call
15:00:10 <spotz> \o/
15:00:11 <dansmith> o/
15:00:12 <gmann> o/
15:00:17 <belmoreira> o/
15:00:18 <yoctozepto> \o/
15:00:48 <jungleboyj> o/
15:01:10 <gmann> today agenda #link https://wiki.openstack.org/wiki/Meetings/TechnicalCommittee#Agenda_Suggestions
15:01:18 <gmann> let's start
15:01:28 <gmann> #topic Follow up on past action items
15:01:47 <gmann> ricolin to reach out to Adjutant previous PTL and team
15:01:57 <ricolin> o/
15:02:05 <gmann> we have PTL response and confirmation too. thanks ricolin
15:02:16 <gmann> mnaser add two level project accepting criteria in PTG etherpad
15:02:20 <gmann> that is also done,
15:02:41 <gmann> #topic Gate health check (dansmith/yoctozepto)
15:02:52 <dansmith> I've been seeing a lot of nova fail lately,
15:02:52 <gmann> dansmith: yoctozepto go ahead for gate news
15:03:09 <dansmith> which I think is related to a secondary fix to placement after the consumer types thing
15:03:19 <dansmith> I need to follow up and see if that is getting reviewed
15:03:37 <gmann> ok
15:03:39 <yoctozepto> yeah, I have heard about nova having trouble
15:03:43 <dansmith> other than that I don't know of anything burning
15:03:44 <yoctozepto> but nothing else
15:04:13 <fungi> nova is often the canary in openstack's coalmine
15:04:20 <yoctozepto> (consistent reporting ++)
15:04:27 <gmann> there are psycopg2 import error, i saw in many tempest plugins and tempest gate. but all failing plugins are x/ namespace and now excluded from tempest sanity job until they are fixed
15:05:02 <yoctozepto> I wonder if there are current prod deploys on potsgres
15:05:10 <yoctozepto> postgres*
15:05:19 <yoctozepto> I would bet no
15:05:27 <gmann> may be, I have not debugged those yet
15:05:32 <fungi> it would be good to get any of those x/ namespace repos which are abandoned more properly cleaned up, if we have ways to get in touch with their former maintainers to confirm
15:05:41 <yoctozepto> (current meaning ussuri+)
15:06:17 <gmann> sure
15:06:24 <gmann> any other news/udpates?
15:06:38 <gmann> #topic Xena Tracker
15:06:41 <gmann> #link https://etherpad.opendev.org/p/tc-xena-tracker
15:06:43 <opendevreview> Merged openstack/election master: Update README for correct location and close out Yoga election  https://review.opendev.org/c/openstack/election/+/805918
15:06:56 <gmann> let's go through the remaining items in tracker
15:07:27 <gmann> for Audit and finish the previous cycle pending community-wide goal work
15:07:50 <gmann> I pushed all remaining patches for contribution guide and only 3-4 remaining to merge. this is all done
15:08:02 <gmann> Review the tags for usefulness and cleanup.  Based on what left, make a decision on whether to continue the tag framework based or not.
15:08:04 <gmann> yoctozepto: jungleboyj ^^
15:08:22 <jungleboyj> :-)
15:08:23 <yoctozepto> yeah, I have worked on that this week
15:08:23 <gmann> I think we have separate topic on this.
15:08:27 <gmann> great
15:08:28 <yoctozepto> we have
15:08:38 <gmann> let's discuss in that, thakns
15:08:40 <gmann> thanks
15:08:42 <gmann> Getting projects to broadast out/mentor
15:08:43 <jungleboyj> ++
15:08:46 <gmann> spotz: belmoreira ^^
15:08:51 <spotz> I'll work with belmoreira about ours next week
15:09:00 <belmoreira> +1
15:09:08 <gmann> great, thanks
15:09:10 <gmann> Stable core team process change
15:09:12 <gmann> jungleboyj: mnaser ^^
15:09:15 <spotz> I have it all together just need to write it up, get emails, etc
15:09:20 <gmann> spotz: +1
15:09:31 <gmann> spotz: belmoreira please update in etherpad too once you send
15:10:00 <spotz> will do
15:10:11 <gmann> thanks
15:10:53 <gmann> back to 'Stable core team process change'
15:11:01 <gmann> this is important one
15:11:26 <gmann> mnaser: jungleboyj please let me know if something is up or you are planning to
15:11:53 <jungleboyj> mnaser:  Haven't gotten to that one yet.
15:12:58 <gmann> ok, let's check later. I think mnaser mentioned he will push something soon
15:13:02 <gmann> 'Project Health checks'
15:13:05 <gmann> ricolin: belmoreira ^^
15:13:23 <gmann> this is one of the things to remove the TC liaison things.
15:13:24 <jungleboyj> gmann:  Right, he was planning to do something so that is why I hadn't done anything.
15:13:31 <gmann> jungleboyj: ack. thanks
15:14:13 <gmann> but for Yoga, I think we need to continue TC liaison and keep discussing in Yoga PTG or if we cna have project health check framework up.
15:14:34 <belmoreira_> sorry, got disconnected
15:14:40 <ricolin> gmann, sorry didn't got time to work on it last week
15:15:07 <ricolin> will make something next week
15:15:14 <gmann> np, please update etherpad once done.
15:15:19 <ricolin> NP
15:15:41 <gmann> ricolin: belmoreira_ I think if we can have something up before PTG then it will be good to discuss about TC liaison still needed or not
15:15:45 <gmann> thanks
15:16:16 <jungleboyj> Agreed.
15:16:16 <belmoreira_> sure
15:16:25 <gmann> #topic Leaderless projects
15:16:26 <diablo_rojo> Makes sense to me.
15:16:38 <gmann> #link https://etherpad.opendev.org/p/yoga-leaderless
15:16:45 <yoctozepto> \o/ no leaderless projects \o/
15:16:47 <gmann> now PTL election are also closed
15:16:52 <diablo_rojo> Woohoo!
15:16:55 <gmann> and we found all leaders also for leaderless
15:17:20 <yoctozepto> which is good but some cases are rather unhealthy
15:17:21 <spotz> woohoo
15:17:33 <yoctozepto> we will discuss more on quality during ptg
15:17:45 <gmann> yeah, missing deadline cases are something we should discuss and how to improve those
15:17:47 <jungleboyj> \o/
15:17:47 <diablo_rojo> Yeah I am still a little.. worried about zun
15:18:00 <yoctozepto> (tbh, I like adopting the CNCF approach with different maturity levels)
15:18:18 <jungleboyj> Yeah, that is a good topic to discuss further.
15:18:28 <gmann> yeah
15:18:28 <diablo_rojo> For example?
15:18:52 <yoctozepto> diablo_rojo: oh, yes, you were missing from our call, apologies :-)
15:19:00 <gmann> L 78 https://etherpad.opendev.org/p/tc-yoga-ptg
15:19:59 <gmann> let's discuss in PTG which will directly related to these leaderless projects every cycle.
15:20:13 <diablo_rojo> yoctozepto, yeah I was.
15:20:30 <diablo_rojo> And the notes are much harder to read than meeting logs.
15:21:06 <gmann> recording ? :)
15:21:21 <yoctozepto> yeah, the experience was great but the trace was miserable except for the recording
15:21:37 <diablo_rojo> Yeah I havent found the time/attention span to listen to the recording yet.
15:21:45 <gmann> anyways we have separate topic on that, let's discuss that time
15:21:45 <yoctozepto> anyhow, the link from gmann should clarify enough for now
15:21:48 <yoctozepto> ++
15:21:55 <spotz> They were at least semi-complete. For te monthly video RDO call oouor notes are not great
15:22:12 <gmann> anything else on this topic, leaderless projects ?
15:22:24 <diablo_rojo> Nope.
15:22:26 <gmann> #topic New project application: 'Venus
15:22:28 <gmann> #link https://review.opendev.org/c/openstack/governance/+/804824
15:22:52 <gmann> this is good to merge, but i will open it until our meeting in case any one want to comment/vote
15:23:18 <yoctozepto> until which meeting?
15:23:23 <yoctozepto> you mean ptg?
15:23:27 <gmann> this meeting :)
15:23:31 <yoctozepto> haha, ok
15:23:35 <gmann> sorry for unclear
15:23:45 <gmann> #topic Next step on pain points from projects/SIGs/pop-up (ricolin)
15:24:07 <gmann> ricolin: anything to discuss on this  further or we take it in PTG as disucssed ?
15:24:20 <ricolin> I think we should take this to PTG
15:24:27 <gmann> cool.
15:24:43 <ricolin> will collect some feedback before PTG
15:24:47 <gmann> ricolin: so I will remove it from next week meeting agenda ?
15:25:00 <ricolin> gmann, +1
15:25:03 <gmann> sounds good.
15:25:12 <diablo_rojo> That works.
15:25:22 <yoctozepto> sounds good to me as well
15:25:24 <gmann> #action gmann to remove projects pain points from next weekly meeting agenda
15:25:35 <gmann> #topic TC tags analysis
15:25:47 <gmann> #link https://docs.google.com/spreadsheets/d/18GXibtdQnSkIwA7DsBvX9dPwbw9JH76AhhRUknzBb3Q/edit
15:25:51 <gmann> yoctozepto: go ahead
15:26:19 <yoctozepto> so I have finally sat down to this to summarise the current usage of tags
15:26:39 <yoctozepto> the goal is to determine which (if any) are useful and whether we want to continue this framework
15:26:40 <jungleboyj> yoctozepto:  Thank you.  Looks good.
15:27:05 <yoctozepto> jungleboyj: thanks :-)
15:27:18 <yoctozepto> the spreadsheet starts with a simple yes/no table per project
15:27:24 <yoctozepto> there are notes in the other tabs
15:27:29 <gmann> and only 22 projects care of these and rest are not interested or not eligible
15:27:46 <yoctozepto> one point to note this is simplified to projects and not deliverables (while tags are technically per deliverable)
15:27:47 <yoctozepto> yes
15:28:03 <gmann> ok
15:28:24 <yoctozepto> and it does not seem overly clean whether the proper tags are applied
15:28:33 <yoctozepto> also, some seem to overpromise what the tag means
15:28:45 <gmann> yoctozepto: thanks, how we can get their usage data/value too? who use them and if they are valuable for them ?
15:28:45 <yoctozepto> (though this was obviously discovered by accident)
15:28:47 <fungi> right, that distinction becomes rather important for the vulnerability:managed tag, for example... not all deliverables for a given team have vmt oversight
15:29:43 <jungleboyj> Have we used the maintenance-mode tag in recent history?
15:29:46 <gmann> fungi: and those team (not vmt tag) does not have/reported security bugs ?
15:30:25 <diablo_rojo> jungleboyj, seems like not lol
15:30:28 <fungi> gmann: the deliverables without vulnerability:managed are expected to have their vulnerability reports handled directly by the team who maintains that deliverable (though the vmt often helps out)
15:30:39 <gmann> jungleboyj: not sure, hope it is not documentation issue like yoctozepto fixed for standalone tag
15:30:40 <yoctozepto> gmann: hard to tell; I was thinking about just reaching out to the community via the mailing list BUT the usual problem arises - operators don't read it that often but the tags are meant to be for them
15:30:57 <yoctozepto> jungleboyj, gmann, diablo_rojo: it was used
15:30:59 <gmann> fungi: i see.
15:31:02 <yoctozepto> see in legacy projects
15:31:25 <jungleboyj> yoctozepto:  Ok, I thought it was used at one point but it appears we have forgotten about it.
15:31:28 <yoctozepto> gmann: continuing on value: based on my own experience - operators don't even know this thing exists
15:31:36 <diablo_rojo> yoctozepto, but not on current ones?
15:31:48 <yoctozepto> diablo_rojo: nope, 0 as the table says
15:32:09 <yoctozepto> the table is correct except for if my mouse clicked a number away so it could end up in a close-by column :D
15:32:11 <diablo_rojo> yoctozepto, right that's what I recalled. I wonder if it *ever* has been used, or what the last project was.
15:32:11 <gmann> yoctozepto: yeah, may be including it in user survey or ask in PTG ?
15:32:28 <yoctozepto> I already fixed one issue like that; need to learn mouse usage; or rather touchpad
15:32:42 <fungi> what's really fun is that the entire tags concept was started based on feedback from operators, and they were expected to drive a lot of it
15:32:42 <gmann> yoctozepto: jungleboyj we have this topic in PTG also right?
15:32:43 <yoctozepto> diablo_rojo: yeah, I said that project is in legacy
15:32:49 <yoctozepto> forgot the name
15:33:00 <opendevreview> Merged openstack/governance master: Update projects.yaml for Yoga PTLs  https://review.opendev.org/c/openstack/governance/+/807858
15:33:02 <yoctozepto> fungi: yeah, I know the drill
15:33:15 <yoctozepto> gmann: PTG yes we have
15:33:15 <jungleboyj> I also think that people don't even know about this.
15:33:32 <gmann> yoctozepto: let's get the usage data also from operator on ML and we will see if any response on that.
15:33:34 <yoctozepto> gmann: user survey is too slow to get this info I think
15:33:50 <gmann> yoctozepto: agree, I think we might be able to add in next year one
15:33:52 <yoctozepto> ok, then I send a respective mail now that we have some baseline understanding
15:33:58 <diablo_rojo> yoctozepto, oh yeah I missed that sorry. Makes sense.
15:34:15 <dansmith> fungi: but that was "to determine which projects we might want to deploy" or "choose between two alternatives" right?
15:34:23 <gmann> perfect, and we can discuss both data usage/projects-applying it PTG
15:34:37 <dansmith> basically not deploying a project that isn't going to be stable long-term, or manage vulnerabilities, or whatever
15:34:40 <yoctozepto> gmann: there are some quality issues with the tags and I worry posting such a question to the survey might be suggesting they are golden standard
15:34:47 <gmann> #action yoctozepto to send email to openstack-discuss about getting usage data of TC tags
15:34:51 <dansmith> I think the goal was noble, but it's just not really a thing now
15:35:07 <jungleboyj> True.
15:35:14 <yoctozepto> dansmith: yeah, the "market" worked differently
15:35:38 <fungi> dansmith: yes
15:36:10 <gmann> belmoreira_: how about in CERN, do you guys consider/check those ?
15:36:19 <fungi> i would argue the operators interested in using tags to determine whether they wanted to run certain services never followed through
15:36:30 <dansmith> fungi: agree
15:36:35 <jungleboyj> fungi: agree
15:36:39 <yoctozepto> ++
15:36:59 <yoctozepto> ok, so the mail will be mostly a formality I guess :P
15:37:06 <yoctozepto> but will do nonetheless
15:37:07 <belmoreira_> well, honestly tags don't say much to make a decision to run a service
15:37:19 <gmann> yoctozepto: not sure, may be you get answers :)
15:37:25 <fungi> and not to be cynical, but sometimes problems are raised more to serve as an excuse for why something is hard or isn't being done, and solving that problem inconveniently takes away the excuse
15:37:30 <jungleboyj> yoctozepto:  Will be interesting.
15:37:30 <yoctozepto> gmann: you are always such an optimist! :D
15:37:39 <gmann> yoctozepto: heh
15:38:05 <gmann> anyways, let's go with the ML and then we can decide in PTG about it
15:38:15 <gmann> thanks yoctozepto for getting it started
15:38:20 <jungleboyj> ++
15:38:22 <yoctozepto> ok, then action is here and the point can be removed from the agenda
15:38:37 <gmann> anything else on this ? I will keep it for next meeting too at least if any response on ML
15:38:44 <yoctozepto> ah, ok
15:38:48 <yoctozepto> (optimist)
15:38:54 <gmann> yoctozepto: let's keep it in case any more response.
15:38:55 <gmann> :P
15:39:12 <gmann> ok moving next ?
15:39:18 <yoctozepto> I agree
15:39:38 <gmann> #topic TC Video call feedback & plan
15:39:41 <jungleboyj> Onward and Upward
15:40:00 <gmann> we had our first video call last week.
15:40:18 <gmann> It definitely need more improvement
15:40:22 <diablo_rojo> Speaking from the standpoint of someone that missed it... not a fan lol.
15:40:25 <gmann> some feedback are here #link https://etherpad.opendev.org/p/tc-video-meeting-feedback
15:40:50 <jungleboyj> :-)
15:40:53 <gmann> audio and network issue came up but i think we can improve those.
15:41:01 <gmann> i will use headphone next time :)
15:41:14 <jungleboyj> mnaser:  Needs to stay at hotels with better wifi.  ;-)
15:41:30 <spotz> hehe
15:41:35 <gmann> as we discussed, we will continue it until PTG and then we will take call to continue it or not
15:41:55 <fungi> the primary reason google meet was recommended for that, as i understood, was because of its stellar transcription capability. where's the transcript from it?
15:42:01 <gmann> for that, two open question 1. Where we should store the recording ?
15:42:03 <spotz> I don't think it's a bad idea, I think it's a question of whether the transcripts were good enough
15:42:14 <dansmith> fungi: it was posted. it's terrible, but I also think it's the best in class
15:42:28 <spotz> hehe
15:42:31 <fungi> got it. so long as it's useful/usable i guess
15:42:43 <gmann> yeah, not perfect but not so bad too
15:42:59 <yoctozepto> diablo_rojo: xD but I can understand
15:43:10 <gmann> so on recording location, i kept it in my google drive for now but I might not have much space there as i do not have paid plan.
15:43:38 <spotz> gmann: What about in the governance repo?
15:43:39 <jungleboyj> Can you upload it to Youtube?
15:43:41 <yoctozepto> fungi: yeah, it is enough to understand the gist I guess
15:43:59 <diablo_rojo> google meet isn't accessible in china... so it excludes community members that may want to join
15:43:59 <spotz> That's good too, then the logs in repo?
15:44:03 <gmann> jungleboyj: we need to do in foundation channel if we want it on youtube
15:44:32 <jungleboyj> That is where we put all our Cinder meetings ... we have a Cinder channel though.
15:44:43 <gmann> diablo_rojo: yeah but there is no one join TC meeting from china, ricolin can access it as he mentioned/did
15:44:46 <diablo_rojo> jungleboyj, that wasn't hard to setup though
15:45:23 <diablo_rojo> True, there are ways around the firewall gmann but I don't think we should force that on community members.
15:45:25 <gmann> ok, let me check to store in repo
15:45:32 <clarkb> There are varying reports of meetpad accessibility from china too. I suspect that any non blessed conferencing tools have difficulty. Zoom puts servers in china to get the go ahead aiui
15:45:59 <gmann> I heard zoom has same issue like google meet
15:46:15 <ricolin> gmann, yep, it's also consider unstable tools IMO
15:46:30 <diablo_rojo> I don't thing we should add more barriers to accessibility for a part of our community.
15:46:37 <gmann> and it is same for IRC access too
15:46:56 <clarkb> ah ok the thing I found said "Mainland users need to provide a phone number to verify their identity to join the meeting." but that may not be accurate or reflect service viablity
15:47:03 <spotz> ricolin: zoom is considered unstable?
15:47:30 <ricolin> yep, for some company network, can't really have stable zoom access from China
15:47:37 <fungi> from what i understand, zoom is usable in mainland china as long as people in china connect to the zoom servers in china, since the government has access to monitor those directly for discussions they disapprove of
15:47:42 <gmann> diablo_rojo: definitely, that is why we are doing it monthly and trying it until PTG. and then in PTG we will take final call based on feedback
15:47:58 <spotz> So we'rre basically damned if we do or damned if we don't with either option
15:48:01 <ricolin> and all zoom account from China can't create Zoom meeting room, but that's different
15:48:25 <gmann> yeah
15:48:55 <yoctozepto> oh boy
15:49:07 <gmann> ok, so now continuing on google meet, i need someone help having paid account
15:49:28 <gmann> free version does not allow recording/transcript
15:49:41 <clarkb> ricolin: fwiw I/opendev would probably find it useful if we can get more info on whether or not meetpad works for individuals in china
15:50:03 <clarkb> as we haven't had a very concrete response to that it has all been third hand
15:50:21 <fungi> ricolin: also with clarity around whether it's testing from home connections vs work connections
15:50:22 <spotz> I can do it through RedHat, we already. have a 'room' for the Monthly RDO video meeting so the URL is out there
15:50:27 <ricolin> maybe you can ping horace from China? I ping him to test tools too :)
15:50:37 <ricolin> clarkb, ^^^
15:50:42 <jungleboyj> ricolin: ++
15:50:43 <fungi> yeah, we've been getting some help from horace too
15:50:44 <clarkb> yup good idea, he tends to be busy though :)
15:51:03 <gmann> spotz: perfect, thanks. I will get in touch with you for next meeting setup
15:51:04 <clarkb> anyway I don't need to derail the TCs decisions on conferencing
15:51:36 <gmann> clarkb: but that is good if we can get meetpad as better solution :)
15:51:57 <spotz> It's good if we can get the most accessible and useable solutioon:)
15:51:57 <gmann> getting more feedback and then choose better (none is best though) one in PTG
15:52:02 <gmann> yeah
15:52:09 <diablo_rojo> I would feel more comfortable with meetpad than google meet.
15:52:19 <jungleboyj> If you guys have trouble getting Horace to help I know a few people in China who could help.
15:52:20 <fungi> probably our biggest missing feature in meetpad right now is the lack of server-side recording/publishing
15:52:38 <fungi> (jitsi-meet has options for that but we haven't looked into setting them up)
15:53:05 <jungleboyj> I probably could test it myself in fact.  Not sure that doing it through VPN is the best approach though.
15:53:21 <gmann> ok
15:53:56 <gmann> #action gmann to add folder or something to store the meeting recording/transcript in governance repo
15:54:32 <gmann> #action spotz to help in google meet setup for next meeting from RDO account.
15:54:37 <gmann> anything else on this topic ?
15:54:47 <diablo_rojo> Nope.
15:54:57 <gmann> #topic Open Reviews
15:55:00 <gmann> #link https://review.opendev.org/q/projects:openstack/governance+is:open
15:55:10 <spotz> https://meet.google.com/uzo-tfkt-top :)
15:55:19 <gmann> we have lot of open patches, please review if you have not done yet
15:55:42 <gmann> spotz: thanks,
15:55:52 <gmann> that is all from me today, anything else form anyone ?
15:55:56 <gmann> *from
15:56:24 <gmann> one last thing.
15:56:30 <yoctozepto> nothing from me
15:56:35 <diablo_rojo> Nothing from me
15:56:42 <gmann> we have chair and vice chair nomination, please add your if you are interested or vote on them
15:57:04 <gmann> #link https://review.opendev.org/c/openstack/governance/+/807163
15:57:16 <gmann> #link https://review.opendev.org/c/openstack/governance/+/807178
15:57:28 <gmann> ok, thanks all for joining.
15:57:35 <gmann> #endmeeting