15:00:07 <gmann> #startmeeting tc
15:00:07 <opendevmeet> Meeting started Thu Sep 23 15:00:07 2021 UTC and is due to finish in 60 minutes.  The chair is gmann. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:07 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:07 <opendevmeet> The meeting name has been set to 'tc'
15:00:10 <gmann> #topic Roll call
15:00:13 <jungleboyj> o/
15:00:14 <gmann> o/
15:00:31 <dansmith> o/
15:01:26 <ricolin> o/
15:01:33 <spotz_> o/
15:02:06 <gmann> let's wait for 1 more  min for other tc-members
15:02:22 * mnaser is booked in something else but reading
15:03:04 <gmann> #link https://wiki.openstack.org/wiki/Meetings/TechnicalCommittee#Agenda_Suggestions
15:03:05 <yoctozepto> o/
15:03:09 <gmann> today agenda ^^
15:03:11 <diablo_rojo> o/
15:03:19 <gmann> #topic Follow up on past action items
15:03:25 <gmann> no action item from previous meeting
15:03:36 <gmann> #topic Gate health check (dansmith/yoctozepto)
15:03:51 <dansmith> I have not noticed any burning issues lately
15:03:57 <yoctozepto> same here
15:04:05 <dansmith> which is like, amazing
15:04:09 <jungleboyj> Seems that things have been running smoothly.
15:04:19 <jungleboyj> Yeah.  Let's not jinx it.
15:05:01 <gmann> +1, yeah going good in this release. let's hope for same for next 1-2 week too :)
15:05:26 <gmann> #topic TC tags analysis
15:05:29 <gmann> #link https://docs.google.com/spreadsheets/d/18GXibtdQnSkIwA7DsBvX9dPwbw9JH76AhhRUknzBb3Q/edit
15:05:53 <gmann> I have added it a items for next newsletter also #link https://etherpad.opendev.org/p/newsletter-openstack-news
15:06:05 <gmann> feel free to update wording or so
15:06:06 <jungleboyj> ++
15:06:07 <belmoreira> o/ (late)
15:06:25 <gmann> yoctozepto: anything else we need to do on this before PTG discussion ?
15:06:27 <spotz_> +1
15:06:33 <gmann> belmoreira: hi
15:07:39 <jungleboyj> Just updated the wording a bit.  Otherwise looks good.
15:07:47 <gmann> jungleboyj: thanks
15:07:50 <yoctozepto> gmann: nothing I can think of
15:07:54 <jungleboyj> I don't think there is more before the PTG.
15:08:06 <gmann> yoctozepto: ok, I will remove it from next meeting agenda?
15:08:23 <yoctozepto> gmann: ++
15:08:25 <jungleboyj> ++
15:08:30 <gmann> #action gmann to remove 'TC tags analysis' from agenda
15:08:41 <gmann> #topic Project Health checks framework
15:08:49 <gmann> #link https://etherpad.opendev.org/p/health_check
15:08:57 <gmann> #link https://review.opendev.org/c/openstack/governance/+/810037
15:08:59 <opendevreview> Rico Lin proposed openstack/governance master: Add project health check tool  https://review.opendev.org/c/openstack/governance/+/810037
15:09:05 <gmann> thanks ricolin for starting it.
15:09:05 <ricolin> new patch set^^^
15:09:26 <ricolin> It's currently only a tool to pull some status
15:09:30 <belmoreira> thanks ricolin
15:09:42 <diablo_rojo> Still that is a good start ricolin :)
15:09:47 <gmann> we discussed it yesterday and dansmith brought a good point of 'why we're collecting them and what we action to do'
15:09:49 <jungleboyj> Agreed.
15:10:04 <gmann> I added the Purpose and Action item section in etherpad at top
15:10:13 <jungleboyj> That is helpful.
15:10:15 <ricolin> gmann, thx
15:10:45 <diablo_rojo> Agreed- we can pull stats all day long, but it doesnt matter if no one looks/ we aren't actually doing anything with them lol
15:10:52 <gmann> we can go with plan of 1. merge the current tool proposed by ricolin 2. discuss on purpose and action items/labeling the project etc
15:11:06 <gmann> is it fine? or we want to do both together ?
15:11:44 <ricolin> +1 on both
15:12:40 <ricolin> maybe not labeling IMO, but some monthly check will be nice
15:12:47 <spotz_> It makes sense to stage the first or wait
15:13:05 <fungi> yeah, focusing on stats which you expect to actually be useful to inform a decision/action the tc will take is a good way to scope it
15:13:14 <diablo_rojo> Who's job will that be? to do the monthly check?
15:13:24 <gmann> TC members
15:13:33 <diablo_rojo> I feel like if no one is 'assigned' everyone will assume a different TC member will do it?
15:13:41 <jungleboyj> diablo_rojo:  ++
15:13:45 <gmann> I feel if we will not label or so then it is hard to proceed to next step/actionable thing
15:13:48 <dansmith> and is monthly really necessary?
15:14:01 <belmoreira> however, keeping metrics is also important (It can give us a different overview over time)
15:14:01 <gmann> not monthly, I will say twice in a cycle
15:14:04 <diablo_rojo> Yes. I figured TC members would be the ones responsible lol
15:14:11 <diablo_rojo> dansmith, +1
15:14:11 <ricolin> dansmith, or twice a cycle?
15:14:13 <jungleboyj> dansmith:  That does seem excessive.
15:14:16 <ricolin> like gmann said
15:14:29 <gmann> diablo_rojo: yeah we can discuss on assignment like we do for goal, gate checks etc
15:14:37 <jungleboyj> Twice a cycle makes sense.  Middle and end ... ?
15:14:38 <dansmith> twice a cycle seems much better than monthly
15:14:52 <yoctozepto> ++
15:14:55 <ricolin> If you use that tool to run against Sahara or some projects that we have concerns with, it's totally clue there for some of them
15:15:12 <gmann> middle will be more beneficial like we check and take decision so that release/CI&CD things can be saved during release time
15:16:40 <ricolin> agree
15:16:41 <gmann> but to judge the stats we need some threshold to decide so that we can consider that project to be a candidate for next step (removal or help)
15:17:21 <gmann> and threshold depends on type of projects like for lib etc there are always less activities compare to service projects or so
15:18:05 <diablo_rojo> I feel like those thresholds are going to be different depending on the kind of project though.
15:18:24 <diablo_rojo> Cause there are more stable ones that are much more quiet.
15:18:27 <gmann> at for handling the incoming request not how much code they produce. like if very less patch there but they take care of bugs/reviews then it is all good
15:18:28 <spotz_> Different projects might have different thresholds
15:18:28 <jungleboyj> True.  Core projects vs others.
15:18:34 <fungi> libs vs services is a sort of arbitrary split, and there are many factors which can result in higher or lower numbers for those various kinds of activities
15:18:56 <gmann> yeah that is just example
15:20:03 <fungi> where to set a threshold, if you have one at all, should probably be based on long-term analysis of all projects looking for correlations
15:20:45 <jungleboyj> Agreed.  I don't think we have enough information right now that we could create thresholds.
15:20:55 <ricolin> fungi, you mean like compare the data with the one we generated earlier for same project?
15:21:10 <jungleboyj> ++
15:21:37 <fungi> ricolin: look at numbers for projects you consider to be in a healthy state, and projects you consider to be in a risky state, across different historical timeframes
15:22:16 <gmann> we need some category where we can divide the projects stats to be consider as good or not good.
15:22:24 <fungi> but really, analyze all projects, because you're going to need the largest sample size you can muster given there's not really that many projects and your analyses are likely to be rife with statistically insignificant observations
15:23:06 <ricolin> fungi, +1
15:23:13 <gmann> let's start the ''
15:23:38 <gmann> let's start the 'usage and actionable things on what data/threshold or so'
15:24:00 <gmann> in etherpad or so and then we can start replacing it with TC liaison framework
15:24:17 <fungi> i.e. if you set thresholds at all, base them on observations as to how teams are actually working not on assumptions about how you think teams should be working
15:24:27 <spotz_> ++
15:25:09 <gmann> yes, we can map those with the project removal criteria
15:25:24 <gmann> #link https://governance.openstack.org/tc/reference/dropping-projects.html
15:26:30 <gmann> we need to make sure we have a agreed & documented interpretation of stats generated by this tool instead of everyone interpret it differently
15:27:30 <gmann> and meanwhile we can review/merge the current tool which can be extended later also #link https://review.opendev.org/c/openstack/governance/+/810037/
15:27:31 <ricolin> +1, will be nice if we actually got something to documented down
15:27:43 <ricolin> officially
15:27:52 <jungleboyj> ++
15:28:48 <gmann> I will keep it in agenda and everyone add your opinion on etherpad about stats usage/label project etc
15:29:07 <gmann> anything else on topic?
15:29:19 <ricolin> not from me
15:29:31 <gmann> ok, thanks again ricolin
15:29:41 <gmann> #topic Xena Tracker
15:29:44 <gmann> #link https://etherpad.opendev.org/p/tc-xena-tracker
15:30:59 <gmann> we have 5 items to finish (excluding gate health checks we we do every week) and out of them two (tag, goal) are needed to be discussed in PTG
15:31:32 <gmann> and this project health tool which is also in-progress
15:31:39 <gmann> other two items are:
15:31:43 <gmann> 1. Getting projects to broadast out/mentor - https://etherpad.opendev.org/p/tc-spread-the-word
15:31:56 <gmann> we have etherpad now with some data
15:32:30 <spotz_> Need to add words to make that an email then grab addresses and send it
15:32:43 <gmann> spotz_: ok and to add it in project-team-guide?
15:33:08 <spotz_> We could yeah
15:34:08 <gmann> ok, I think we have enough/all places listed there where we can broadcast the things
15:34:36 <spotz_> Yeah and most are established so don’t think they’ll go away
15:34:50 <gmann> spotz_: may be you can start the ML/patch?
15:35:58 <spotz_> Yeah I got drug away working on a conference deck. I’ll slip this in real quick
15:36:07 <gmann> thanks
15:36:15 <gmann> 2. Stable core team process change
15:36:20 <gmann> mnaser: jungleboyj any news on this?
15:36:45 <jungleboyj> Last I heard mnaser was working on something but haven't seen an update.
15:37:02 <gmann> ok
15:37:28 <mnaser> ill just push up what i have now so far, i think i was waiting for it to be a little too perfect
15:37:41 <fungi> that's what the review process is for ;)
15:37:45 <gmann> mnaser: +1, that will be great
15:38:02 <jungleboyj> mnaser:  Awesome.  I will review.  :-)
15:38:15 <gmann> anything else/update on Xena tracking items ?
15:38:58 <gmann> I think we will be able to finish all of them in Xena itself (except few which need final discussion in PTG)
15:39:12 <gmann> good progress everyone and thanks for working on those.
15:39:13 <jungleboyj> That is good.
15:39:17 <gmann> #topic Open Reviews
15:39:29 <gmann> #link https://review.opendev.org/q/projects:openstack/governance+is:open
15:40:02 <gmann> I think we are good here, few project updates are there but waiting for project-config to merge before
15:41:15 <gmann> mnaser: fungi if you can quickly review this project-config #link https://review.opendev.org/c/openstack/project-config/+/808072/1
15:41:32 <gmann> I have one more thing to discuss
15:41:55 <mnaser> done gmann
15:42:01 <gmann> thanks
15:42:21 <gmann> as we have same TC members continuing this term, i have not reset the TC liaison list. which I think we do not need to rest as we are also working on alternate framework to replace it
15:42:25 <gmann> is it fine for all?
15:42:40 <gmann> s/rest/reset
15:42:58 <dansmith> sounds good
15:43:03 <jungleboyj> Makes sense.
15:43:06 <yoctozepto> ++
15:43:33 <gmann> cool, anything else for today ?
15:43:49 <diablo_rojo> We want to do have k8s folks meet at the PTG with us?
15:43:56 <diablo_rojo> I can start coordinating that.
15:44:20 <diablo_rojo> Do we want to let them pick their timeslot from our available times?
15:44:22 <gmann> yeah, we sent email to them and have it in our PTG etherpad too to have a slot for them
15:44:29 <gmann> waiting for their reply
15:44:43 <spotz_> I’ll be at oss next week and at kubecon if we need to reach out to anyone
15:44:48 <diablo_rojo> gmann, hadn't seen the email. I can ask them at their next meeting.
15:45:03 <gmann> yeah, I asked to pick any time they want.
15:45:07 <gmann> diablo_rojo: I kept you in CC
15:45:13 <diablo_rojo> spotz_, I think that any of the k8s steering that are travelling will be at kubecon.
15:45:19 <gmann> diablo_rojo: +1 that will be great, please check
15:45:27 <diablo_rojo> gmann, sounds good. Will do.
15:45:33 <gmann> diablo_rojo: thanks
15:45:54 <gmann> spotz_: diablo_rojo you are traveling to kubecon or virutal ?
15:45:55 <ricolin> thanks diablo_rojo
15:46:09 <opendevreview> Mohammed Naser proposed openstack/governance master: wip: stable core team  https://review.opendev.org/c/openstack/governance/+/810721
15:46:42 <gmann> anything else for meeting today?
15:47:01 <mnaser> i updated the stable core team stuff i had so far, appreciate early reviews and maybe if jungleboyj can help out with the proposed solutions part
15:47:09 <spotz_> I’ll be there
15:47:16 <gmann> mnaser: +1, thanks for that
15:47:18 <gmann> spotz_: i see
15:47:40 <gmann> let's close meeting. thanks everyone for joining.
15:47:43 <gmann> #endmeeting