15:00:17 <gmann> #startmeeting tc
15:00:17 <opendevmeet> Meeting started Thu Dec  9 15:00:17 2021 UTC and is due to finish in 60 minutes.  The chair is gmann. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:17 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:17 <opendevmeet> The meeting name has been set to 'tc'
15:00:17 <yoctozepto> gmann: indeed
15:00:25 <gmann> #topic Roll call
15:00:27 <yoctozepto> o/
15:00:27 <gmann> o/
15:00:47 <spotz> o/
15:01:40 <jungleboyj> o/
15:02:03 <gmann> two members would not be joining as mentioned in absence section
15:02:05 <gmann> Dan Smith on PTO until 2nd Jan
15:02:05 <gmann> Belmiro Moreira <belmoreira> - OpenInfra Live
15:03:25 <ade_lee> o/
15:03:29 <ricolin> o/
15:03:59 <gmann> we have 5 TC now so quorum, let's start
15:04:10 <gmann> #topic Follow up on past action items
15:04:28 <gmann> ricolin_ to schedule adhoc meeting for pain point discussions
15:04:39 <gmann> that is done, we had first meeting yesterday
15:04:41 <gmann> thanks ricolin
15:04:50 <ricolin> NP
15:05:09 <gmann> #topic Gate health check
15:05:19 <gmann> what's the news on gate
15:05:46 <gmann> I have not seen much frequent failure last week
15:07:05 <gmann> I think gate is not loaded much due to dec month may be
15:07:16 <spotz> possib;e
15:07:19 <diablo_rojo> o/
15:07:48 <fungi> we do still max out our test node capacity regularly, but not for the majority of the day
15:08:20 <fungi> backlogs are typically not that long, and we tend to catch up quickly at the moment
15:08:45 <gmann> ok
15:08:58 <yoctozepto> very well
15:09:08 <jungleboyj> That is at least an improvement.
15:09:19 <fungi> some teams, particularly neutron, have been taking a closer look at the percentage of overall utilization their changes represent
15:09:39 <fungi> and working on reducing waste
15:09:47 <gmann> yeah, they had discussed it in this week neutron CI meeting
15:09:55 <gmann> also on e-r query
15:10:09 <ricolin> fungi, devstack-platform-arm64 on check-arm seems to stuck for 25 hr is there anything I can do to unlock it?
15:10:36 <fungi> ricolin: i'll take a look, but we should probably discuss that in #openstack-infra or #opendev
15:11:00 <ricolin> fungi, we can discuss it after meeting
15:11:44 <gmann> also, in QA we are going to discuss about collaboration on openstack-health dashboard with TripleO team. they are working on same dashboard so it will be good to reuse the existing one
15:11:59 <gmann> kopecmartin will add the call details on ML
15:12:15 <gmann> anything else on Gate health ?
15:13:02 <gmann> #topic Pain points discussion meeting updates
15:13:16 <gmann> #link http://lists.openstack.org/pipermail/openstack-discuss/2021-December/026245.html
15:13:18 <gmann> #link https://etherpad.opendev.org/p/pain-point-elimination
15:13:35 <gmann> we had meeting yesterday and ricolin already sent the summary on ML
15:14:09 <gmann> we did check on many projects yesterday mentioned in ML
15:14:42 <fungi> i saw zigo posted a few additions to the ml earlier today as well
15:14:53 <ricolin> yes for Glance
15:15:08 <fungi> and swift
15:15:14 <gmann> yeah, we still have not covered all from etherpad but we can add them in the list
15:15:41 <gmann> from yesterday discussion, we have two action item for TC which we can talk about here
15:16:08 <gmann> I have added those at L47 in #link https://etherpad.opendev.org/p/tc-yoga-tracker
15:16:38 <gmann> 1. Check possibility for OSC as community-wide goals, find champion
15:16:42 <ricolin> #link https://etherpad.opendev.org/p/tc-yoga-tracker#L47
15:16:48 <gmann> thanks
15:17:29 <gmann> Artem volunteered in past to drive this as goal but we need to check again if Artem is ok to do now as per bandwidth or so
15:17:43 <gmann> at least to have goal proposed
15:18:17 <gmann> and after that we will talk about selecting it based on various factor like work needed, proposed targets dates etc
15:19:02 <gmann> ricolin: would you like to check with Artem if not then we can ask other TC members or community member to drive it ?
15:19:10 <ricolin> sure
15:19:18 <gmann> thanks
15:19:41 <gmann> #action ricolin to check with Artem about championing the OSC community-wide goal
15:19:59 <gmann> next AI for TC is 2. Technical guidlines for logging levels with more example or scenarios
15:20:53 <gmann> This will be a good outcome from TC on technical side to provide more detailed guidelines on Log levels. I am going to add it in our Technical guidelines section
15:21:11 <gmann> Please add your name as volunteer if you would like to help on this
15:21:37 <ricolin> The origin discuss is here if anyone interested
15:21:38 <ricolin> #link https://etherpad.opendev.org/p/pain-point-elimination#L265
15:22:07 <gmann> +1
15:22:16 <gmann> moved it to L13 in yoga tracer
15:22:18 <gmann> tracker
15:22:40 <ricolin> #link https://etherpad.opendev.org/p/tc-yoga-tracker#L13
15:23:05 <gmann> and next meeting to continue the main point discussion will be schedule after Mid Jan sometime when most of community/TC members will join after vacations
15:23:57 <gmann> I would like more TC members to join that and help where ever we can. This is one of good help to community if we as TC can solve/help to solve some of the pain points
15:24:02 <spotz> While we're talking about guidelines I -W the directory as there was conflicting reviews on what to use as the placeholder
15:24:55 <gmann> spotz: I was ok to refactor the current one and we do not need placeholder but if you do not want to touch those existing one then we can abandon and wait for first new guidelines to be proposed
15:25:42 <gmann> #link https://review.opendev.org/c/openstack/project-team-guide/+/815921
15:26:52 <spotz> Ok maybe I was just confused:) I made a pllaceholder.rst that duplicated on used in anoother place vs the unified-linits.rst I originally had but then I read Dan as wanting the unified-linits.rst name vs placeholder
15:27:43 <spotz> sorry for all the typos:(
15:29:00 <gmann> spotz: yeah, let's leave the placeholder for unified limit. if you want to setup the directory then we can refactor the existing guidelines into different files like I mentioned in gerrit
15:29:42 <gmann> other option is-  we can just wait for the first guidelines to be proposed with directory structure.
15:31:19 <gmann> spotz: I am ok with any option ^^ you prefer
15:31:36 <gmann> and will review the patch accordingly
15:31:36 <spotz> Ok I'lll giove it another looook
15:31:42 <gmann> thanks
15:31:54 <gmann> moving next if nothing else on pain points discussion ?
15:32:22 <gmann> #Topic Yoga tracker
15:32:24 <gmann> #link https://etherpad.opendev.org/p/tc-yoga-tracker
15:32:34 <gmann> let's iterate over it and see the progress
15:33:05 <gmann> one thing, I am happy that we are moving and doing more technical work in Yoga which is helping community
15:34:05 <gmann> I will writeup the summary on ML what all things we are doing so that it can be easily read instead of going through the each items in tracker etherpad
15:34:19 <jungleboyj> ++
15:34:28 <gmann> 1. Technical Guidelines: - we already talked about it
15:34:54 <gmann> 2. GATE health: this too, this is in every weekly meeting agenda
15:35:02 <gmann> 3. Yoga testing runtime updates
15:35:12 <gmann> #link https://review.opendev.org/c/openstack/governance/+/820195
15:35:23 <gmann> I have pushed the updates we agreed in TC meeting
15:35:40 <gmann> tc-members ^^ need more reviews
15:35:49 <yoctozepto> I'm unsure if I can still vote on that since I modified it
15:36:18 <gmann> yoctozepto: I think you can but I will wait more vote from other TC when i will count
15:36:33 <yoctozepto> ok, let's do it like this then :-)
15:36:37 <gmann> thanks
15:36:43 <gmann> 4. TAG framework removal proposal
15:36:51 <gmann> yoctozepto: any updates on removal proposal ?
15:37:29 <yoctozepto> no, sorry, it just needs to be done; my question is whether we need a resolution commited?
15:38:32 <gmann> yoctozepto: I prefer to spend time on work than writing resolution :) but yes we can write one as this is something we are removing the very old framework
15:38:47 <gmann> just a summary with all links to ML, PTG etc
15:38:57 <yoctozepto> gmann: that's what I thought :-)
15:39:17 <yoctozepto> not sure if this year but I will certainly propose it :-)
15:39:27 <gmann> yoctozepto: no issue, thanks
15:39:30 <gmann> 5. Improvement in project governance
15:39:34 <gmann> diablo_rojo: ^^
15:41:25 <gmann> I have not seen progress but let's check later
15:41:26 <gmann> 6. Release name process change
15:41:42 <gmann> belmiro is not here but I have not seen proposal yet. let's check later
15:41:55 <gmann> 7. Community-wide goals:
15:42:23 <gmann> decoupling is done, and we have two goals ready (selected/active). sent on ML too
15:42:30 <gmann> #link http://lists.openstack.org/pipermail/openstack-discuss/2021-December/026218.html
15:42:42 <gmann> one item left in this is adding the checklist.
15:43:00 <gmann> ricolin: please add link in etherpad whenever you are ready.
15:43:37 <gmann> 8. User Survey Feedback Responses
15:43:39 <gmann> jungleboyj: ^^
15:44:04 <jungleboyj> Have not started on that yet.  Will get that in my queue.
15:44:12 <gmann> thanks.
15:44:16 <gmann> 9. Technical Writing (doc) SIG
15:44:30 <gmann> this is mine, and done. I have marked it  done
15:44:41 <gmann> that is all for Yoga tracker.
15:44:56 <gmann> anything else to discuss  on this?
15:45:08 <spotz> Nope
15:45:23 <gmann> #topic Updates on community-wide goal
15:45:33 <gmann> #link http://lists.openstack.org/pipermail/openstack-discuss/2021-December/026218.html
15:46:04 <gmann> I sent the two active goals to ML so that projects can plan and start working on those
15:46:49 <gmann> RBAC goal is all ready with new direction, thanks to everyone who helped in discussion, review and especially lbragstad
15:47:29 <gmann> Proposed community goal for FIPS compatibility and compliance
15:47:32 <gmann> #link https://review.opendev.org/c/openstack/governance/+/816587
15:47:52 <gmann> ade_lee: is still waiting on more reviews as next step discussed in last meeting
15:48:00 <ade_lee> yup
15:48:31 <gmann> I have not had chance to review it, I will try next week sometime but other TC members please check it.
15:48:38 <gmann> ade_lee: anything else you would like to add?
15:48:58 <ade_lee> work is continuing on this goal, but yeah, just waiting for reviews at this point
15:49:23 <spotz> I was waiting to vote based on the -1 ccomment, is this something that should be addressed before we go much further? Even if just a response
15:49:29 <ade_lee> the timelines may need to be adjusted depending on when the goal is adopted
15:49:44 <ade_lee> spotz, I thought there was a response
15:49:54 <ade_lee> responses from me and fungi
15:49:57 <gmann> yeah, once proposal is ready then timeline can be revisit.
15:50:05 <spotz> ade_lee: see it noow:)
15:50:33 <spotz> reading and willl vote after
15:50:37 <ade_lee> thnaks
15:51:04 <gmann> moving next
15:51:06 <gmann> #topic Adjutant need PTLs and maintainers
15:51:32 <gmann> no updates on this. still waiting on Braden getting permission
15:51:46 <gmann> #topic Open Reviews
15:51:59 <gmann> #link https://review.opendev.org/q/projects:openstack/governance+is:open
15:52:27 <gmann> one is this which we talked already #link https://review.opendev.org/c/openstack/governance/+/820195
15:52:34 <gmann> ricolin: diablo_rojo ^^ if you can vote in this
15:52:52 * ricolin checking
15:53:15 <ricolin> +1ed
15:53:44 <gmann> and on skyline proposal, Team have responded now with the plan which seems good to me, I will check those and review after meeting. other tc-members also can add your vote/feedback #link https://review.opendev.org/c/openstack/governance/+/814037
15:53:47 <gmann> ricolin: thanks
15:54:40 <gmann> approved this #link https://review.opendev.org/c/openstack/governance/+/819856
15:55:03 <gmann> last review which we did not talk is #link https://review.opendev.org/c/openstack/governance/+/810037
15:55:15 <gmann> ricolin has updated it, I will review after meeting.
15:55:46 <gmann> last check: how many members are around for next meeting on 16th Dec. I will be there
15:56:02 <jungleboyj> I will be here next week.
15:56:04 <gmann> based on that we can decide on to cancel it or not
15:56:10 <spotz> I'll be around next week but not the 2 weeks after
15:56:16 <jungleboyj> Same here.
15:56:32 <yoctozepto> 16 is still fine so far
15:57:25 <gmann> ricolin: diablo_rojo ?
15:58:10 <ricolin> I will be around all these weeks:)
15:58:15 <gmann> ok.
15:58:22 <gmann> we have at least 5 members so let's do it on 16th and for 23rd or so we will discussion  in 16th Dec meeting
15:58:40 <gmann> that is all from me today. anything else to discuss ?
15:59:10 <jungleboyj> ++
15:59:35 <gmann> if nothing else, let's close it. thanks all for joining
15:59:40 <gmann> #endmeeting