15:00:06 <gmann> #startmeeting tc
15:00:06 <opendevmeet> Meeting started Thu Dec 16 15:00:06 2021 UTC and is due to finish in 60 minutes.  The chair is gmann. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:06 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:06 <opendevmeet> The meeting name has been set to 'tc'
15:00:14 <gmann> #topic Roll call
15:00:15 <gmann> o/
15:01:01 <gmann> we have 4 members listed in Absence section
15:01:03 <gmann> Dan Smith on PTO until 2nd Jan
15:01:03 <gmann> Radosław Piliszek <yoctozepto> - med appointment (2021-12-16)
15:01:03 <gmann> Jay Bryant <jungleboyj> - illness (2021-12-16)
15:01:03 <gmann> Belmiro Moreira <belmoreira> - PTO
15:01:08 <spotz> o/
15:01:13 <gmann> hoping other 5 are available
15:01:22 <diablo_rojo> o/
15:02:05 <ricolin> o/
15:02:37 <gmann> mnaser: ping, in case you are online
15:04:10 <gmann> we need one more member for quorum but we do not do votes here and this is not the only meeting in month so we are good do do meeting as per process/bylaw
15:04:12 <gmann> let's start
15:04:25 <gmann> #link https://wiki.openstack.org/wiki/Meetings/TechnicalCommittee#Agenda_Suggestions
15:04:28 <gmann> today agenda ^^
15:04:59 <gmann> #topic Follow up on past action items
15:05:27 <gmann> ricolin to check with Artem about championing the OSC community-wide goal
15:05:36 <gmann> ricolin any updates?
15:05:56 <ricolin> didn't got chance to connect with him
15:06:08 <ricolin> will try to ping him later again
15:06:12 <gmann> no prob
15:06:14 <gmann> thanks
15:06:35 <gmann> should we keep it as Action item or track in Yoga tracker itself?
15:07:10 <ricolin> IMO, let's keep it a action item, as didn't finish that action yet
15:07:16 <gmann> sure
15:07:24 <gmann> #action ricolin to check with Artem about championing the OSC community-wide goal
15:07:33 <gmann> #topic Gate health check
15:08:06 <gmann> I have not seen any frequent failure this week
15:08:24 <clarkb> The pypi stale indexes problem has popped up again
15:09:14 <clarkb> With some interesting debugging tactics... To be clear this is a known issue for at least a year. If pypi's CDN cannot get the results it wants from the primary backend it requests them from the backup backend. The backup backend is frequently out of date. Since openstack updates constraints frequently and wants specific new versions of software it often fails
15:09:19 <gmann> this one? The conflict is caused by:
15:09:19 <gmann> 12:26 PM
15:09:19 <gmann> keystone 20.1.0.dev19 depends on PyJWT>=1.6.1
15:09:19 <gmann> 12:26 PM
15:09:19 <gmann> The user requested (constraint) pyjwt===2.3.0
15:09:32 <clarkb> Most pypi users don't notice these problems as they will just install an older version of the software
15:09:40 <gmann> I observed that this two or three times and reported in requirement channel
15:09:43 <clarkb> gmann: yes that sort of error
15:10:00 <gmann> but it is not happening now or is it?
15:10:01 <fungi> also we' had some recent management event backlogs from bulk branch creation and deletion, but as of yesterday that's been fixed
15:10:17 <gmann> yeah, i have not seen that since yesterday
15:10:20 <clarkb> gmann: it happens whenever the pypi CDN has a failure requested data to their primary backend
15:10:27 <fungi> gmann: the pypi issue comes and goes, so it's hard to know whether it's fully subsided
15:10:32 <clarkb> its not a consistent thing as it depends entirely on the solar rays in their datacenters
15:10:52 <gmann> yeah, let's monitor if it happen again or more frequent
15:11:00 <clarkb> Calling it out here in particular due to some of the crazy debugging steps that have been taken. Its a known issue for a long time. if you'd like to bring it up with pypa I think that would be appropriate
15:11:52 <clarkb> Most pypi users won't notice because they don't lock their dependencies to the latest of all deps
15:12:05 <clarkb> OpenStack is sort of at the forefront there I guess based on how we notice and no one else seems to
15:12:50 <gmann> yeah, let's see how frequent it will be and based on that we can discuss to raise it
15:13:46 <gmann> any other issue/observation on gate?
15:14:15 <gmann> zuul config error has some progress but not all project have fixes up #link https://etherpad.opendev.org/p/zuul-config-error-openstack
15:14:27 <clarkb> We were down to 88 errors yesterday. Progress at least
15:14:42 <gmann> yeah
15:14:57 <fungi> ralonsoh brought up earlier today that swift's unit tests seem to have started failing on train in the past few days
15:15:13 <clarkb> fungi: there is a fix for that
15:15:18 <clarkb> it has to do wtih a dns lookup
15:15:23 <fungi> oh, excellent, i'll let him know
15:15:32 <clarkb> https://review.opendev.org/c/openstack/swift/+/821759 I suspect
15:15:54 <gmann> nice
15:16:04 <clarkb> https://review.opendev.org/c/openstack/swift/+/821762 is the train change
15:16:32 <gmann> for unit testing, rpittau adding the py3.10 as non voting in yoga which sounds good as discussed in TC meeting
15:16:34 <gmann> #link https://review.opendev.org/c/openstack/openstack-zuul-jobs/+/821863
15:16:44 <gmann> fungi: clarkb ^^ if you can have a look
15:17:11 <gmann> anything else on gate health?
15:17:52 <gmann> #topic Skyline as an official project
15:18:00 <gmann> #link https://review.opendev.org/c/openstack/governance/+/814037
15:18:11 <gmann> #link http://lists.openstack.org/pipermail/openstack-discuss/2021-December/026206.html
15:18:20 <spotz> I think there was some really good discussion on the ML on this one
15:18:44 <gmann> yeah, those were good points on skyline being consistent with OpenStack way
15:19:06 <gmann> and Tc was waiting for skyline team to respond on gerrit or ML to confirm their plan
15:19:30 <gmann> now they have responded (8 days back) that they will fix all those open points which seems good
15:19:41 <diablo_rojo> Meanwhile they are waiting for us :)
15:20:00 <gmann> I do not think so, we have replied to them since starting right?
15:20:05 <diablo_rojo> I think we only need one more +1 Rollcall Vote to move forward?
15:20:13 <gmann> fungi: has raised those question on ML as well on gerrit too
15:20:45 <fungi> they have gotten concerned because they didn't realize the tc was waiting for them to answer more questions
15:20:53 <diablo_rojo> gmann, they were.
15:21:07 <gmann> humm, I think that was clear in my weekly reports too
15:21:12 <diablo_rojo> Things are cleared up now though and nothing else is blocking so we really should get this merged.
15:21:20 <gmann> but anyways checking gerrit review could be best thing
15:21:28 <diablo_rojo> gmann, but they were not attending these meetings and might not have seen the email.
15:21:38 <gmann> diablo_rojo: review?
15:21:55 <gmann> anyways
15:22:04 <diablo_rojo> gmann, agreed, but as they aren't an openstack project yet and not built within openstack, they are still learning the ways we communicate.
15:22:15 <fungi> yes, i think they're still trying to learn about the openstack community and how to interface with us, and what our expectations are, so they often don't know where to watch for signs that people need their input
15:22:30 <diablo_rojo> Exactly :)
15:22:48 * ricolin just done with review and +1ed
15:22:51 <fungi> so the "long silence" came across as we had forgotten about them
15:22:53 <diablo_rojo> Something they will learn the more they are brought into our family :)
15:22:54 <gmann> I think if there is gerrit application review then they know the gerrit :) anyways
15:23:01 <gmann> one good question is raised in ML whether we should have them to fix those consistent things first and then add it as official project or add them as official project and then help them to fix all.
15:23:37 <diablo_rojo> I don't think those things are blocking. I think they should be added first and then they can fix it before the release.
15:23:40 <gmann> fungi: no, I keep adding that in meeting open review and in my weekly summary email. it is just some miss-communication
15:24:01 <diablo_rojo> They are more than happy to have direction on what to do once they are in.
15:24:11 <gmann> They have confirmed that they will fix all and have those points in their roadmap
15:24:12 <diablo_rojo> gmann, that assumes they know to read the summary emails.
15:24:34 <spotz> Yeah it might be easier especially as any concerns that were tool or package related willl need to get fixed to work
15:24:46 <gmann> diablo_rojo: I think they did in past right. replying there and PTG sumamry
15:24:47 <diablo_rojo> spotz, thats a good point too.
15:24:52 <spotz> Easier to be in first
15:24:56 <gmann> anyways let's not discuss that and check next step
15:25:24 <gmann> I think it as they agree to be in openstack way they are all good to e an offiical project
15:25:25 <fungi> i can understand why they might be hesitant to invest a lot of time in the things we pointed out if there's no clear promise they'll be accepted as an official team once that's done. but also we've said in the past that we don't need functional, releaseable software to be able to form a team, and in fact we'd rather increase the amount of development done within openstack rather than
15:25:26 <diablo_rojo> gmann, possibly, but they might not have seen they were staying on the agenda week over week. And since skyline wasn't being called out in the subject line, they might not have caught it.
15:25:27 <fungi> expecting people to develop outside openstack and request addition afterward
15:25:56 <diablo_rojo> We have the 5 +1 rollcall votes we need now, yes?
15:26:01 <gmann> and we all have to help them to fix all those things
15:26:01 <diablo_rojo> So it can be merged?
15:26:44 <gmann> yeah, It can be. I will open it for today and if no objection then we can merge it tomorrow.
15:27:07 <diablo_rojo> Yes please!
15:27:16 <gmann> and as next step, we have to help them on setup the communication thigns like IRC etc. which i can do. did for venus project also
15:27:30 <gmann> and monitor them to fix those open things in coming time
15:28:28 <gmann> anything else on this topic?
15:28:38 <fungi> reading the charter, it technically doesn't even need a strict majority, it just needs more positive than negative votes and at least one third of the tc participating, as well as 7 days since the last revision was posted, all of which seem to be met
15:29:33 <gmann> one things is we as TC need to be more active in such cases where we might need to reachout to them in personal email or so. so that we fix such communication gap issue where they waited for TC and we waited for them
15:30:13 <gmann> this is something we will take care in future
15:30:35 <diablo_rojo> I can work with getting them to setup on IRC.
15:31:04 <gmann> let's move
15:31:07 <gmann> #topic #topic SIG i18n status check
15:31:11 <gmann> +1
15:31:49 <gmann> this SIG seems having less/no active maintainer
15:31:51 <gmann> Xena translation missing
15:32:00 <clarkb> We also need to migrate tooling
15:32:03 <gmann> #link http://lists.openstack.org/pipermail/openstack-discuss/2021-December/026244.html
15:32:20 <gmann> Translation bug
15:32:23 <gmann> #link https://review.opendev.org/c/openstack/contributor-guide/+/821371
15:32:52 <gmann> ianychoi[m]: is chair of SIG
15:33:15 <gmann> but we have not heard from him on ML. not sure if he is online
15:33:56 <gmann> how  can engage more people in this SIG? assuming transition is still needed
15:34:26 <clarkb> Maybe that is a good place to start? Who is relying on translations and are you able to help ensure the strings continue to be translated?
15:34:53 <fungi> yes, to expand on what clarkb said, we're long overdue to move translation work off zanata (to something like weblate), red hat abandoned the software years ago and we're already working around security vulnerabilities in it which nobody is ever going to fix
15:35:07 <gmann> yeah and we need to reachout to local user group for that so that they know the anwsers and people need it
15:35:33 <spotz> Do we know what languages as well and if all are still needed?
15:35:40 <gmann> and even Xena transition is not done that make it clear we need maitainer
15:36:03 <gmann> spotz: all for Xena #link http://lists.openstack.org/pipermail/openstack-discuss/2021-December/026244.html
15:36:33 <gmann> and ID transition has bug which is proposed for removal to unblock the contributors-gudie gate
15:36:41 <gmann> #link https://review.opendev.org/c/openstack/contributor-guide/+/821371
15:36:46 <clarkb> I know way back when IBM was a big driver for translations but they aren't super involved anymore. But there may be other users/companies/groups that rely on them and they would be good candidates to help drive this along if they exist
15:37:06 <gmann> yeah
15:37:32 <gmann> let me reachout to ianychoi[m] first and what is his position to this SIG and they we can callout the help on ML
15:37:57 <gmann> #action gmann to reach out to ianychoi[m] for SIG i18n status and then call for help on ML
15:38:12 <gmann> anything else on this topic?
15:38:39 <gmann> #topic Adjutant need PTLs and maintainers
15:39:09 <gmann> #link http://lists.openstack.org/pipermail/openstack-discuss/2021-November/025786.html
15:40:00 <gmann> still waiting from Braden response. I reached out in personal email also but still waiting for permission
15:40:06 <gmann> so let's keep it open
15:40:18 <gmann> #topic Open Reviews
15:40:40 <gmann> we have 4 open reviews
15:40:43 <gmann> #link https://review.opendev.org/q/projects:openstack/governance+is:open
15:40:49 <gmann> skyline is all good
15:41:13 <gmann> I will review the project health tool to confirm my comemnts
15:41:38 <ricolin> Retire js-openstack-lib need to wait for Adjutant PTL settled
15:42:24 <gmann> ricolin: ack, can you please add that in comment and WIP until then?
15:42:37 <ricolin> sure
15:42:43 <gmann> thanks
15:42:48 <gmann> and this one need more TC feedback as we discussed in last TC meeting #link https://review.opendev.org/c/openstack/governance/+/816587
15:43:01 <gmann> member present here, please review
15:43:25 <gmann> one last things  on meeting
15:43:43 <gmann> who all will be present for next week meeting on 23rd Dec ?
15:43:51 <spotz> not me:)
15:44:53 <gmann> Dan and Belmiro are on PTO. so 6 TC available ?
15:45:02 <gmann> ricolin: diablo_rojo ?
15:45:04 <ricolin> I'm available for sure
15:45:46 <gmann> I am also available
15:47:18 <gmann> anyways, let me check with other TC members also later and then we can decide to have meeting or cancel
15:47:33 <gmann> that is all from my side, anything else to discuss ?
15:48:23 <gmann> if nothing, let's close the meeting. thanks everyone for joining.
15:48:26 <gmann> #endmeeting