15:00:12 <gmann> #startmeeting tc
15:00:12 <opendevmeet> Meeting started Thu Jan 13 15:00:12 2022 UTC and is due to finish in 60 minutes.  The chair is gmann. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:12 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:12 <opendevmeet> The meeting name has been set to 'tc'
15:00:18 <jungleboyj> o/
15:00:21 <gmann> #topic Roll call
15:00:24 <gmann> o/
15:00:34 <ricolin> o/
15:00:36 <belmoreira> o/
15:01:04 <diablo_rojo> o/
15:01:14 <dansmith> o/
15:02:44 <gmann> we have quorum as required in today meeting, let's start
15:02:46 <gmann> #link https://wiki.openstack.org/wiki/Meetings/TechnicalCommittee#Agenda_Suggestions
15:02:50 <gmann> ^^ today agenda
15:02:59 <gmann> #topic Follow up on past action items
15:03:20 <yoctozepto> o/
15:03:20 <gmann> no action item from previous meeting
15:03:42 <gmann> #topic TC vote on gender-neutral language bylaws change.
15:03:44 <gmann> #link https://lists.openinfra.dev/pipermail/foundation/2021-October/003016.html
15:03:52 <gmann> Need TC official approval for section Appendix 4, "OpenStack Technical Committee Member Policy". In the first paragraph it changes "his or her" to "their".
15:04:20 <gmann> you might have read the above email from wendar
15:04:30 <gmann> this is section which changes need TC approval #link https://openinfra.dev/legal/openstack-technical-committee-member-policy
15:05:07 <gmann> before we start voting about approval, any question?
15:05:14 <diablo_rojo> Nope.
15:05:46 <yoctozepto> easy peasy
15:05:57 <jungleboyj> Pretty clear and easy.
15:05:58 <diablo_rojo> Fairly straight forward.
15:06:14 <yoctozepto> Indeed, no doubt I see.
15:06:16 <fungi> what sort of majority is required for the vote?
15:06:34 <fungi> (simple or 2/3?)
15:06:56 <spotz> o/ sorry I'm late
15:07:05 <gmann> 5 as quorum ?
15:07:36 <gmann> we have 8 TC members here so let's start voting
15:07:48 <gmann> #startvote TC vote on gender-neutral language bylaws changes in section Appendix 4, "OpenStack Technical Committee Member Policy"? Yes, No, Abstain
15:07:48 <opendevmeet> Begin voting on: TC vote on gender-neutral language bylaws changes in section Appendix 4, "OpenStack Technical Committee Member Policy"? Valid vote options are Yes, No, Abstain.
15:07:48 <opendevmeet> Vote using '#vote OPTION'. Only your last vote counts.
15:07:51 <dansmith> we need to vote here instead of in gerrit?
15:08:01 <gmann> #vote Yes
15:08:02 <spotz> #vote yes
15:08:05 <gmann> dansmith: here is fine
15:08:06 <diablo_rojo> #vote yes
15:08:08 <ricolin> #vote yes
15:08:11 <dansmith> #vote yes
15:08:12 <yoctozepto> #vote Yes
15:08:13 <belmoreira> #vote yes
15:08:14 <jungleboyj> #vote yes
15:08:33 <yoctozepto> 8/8/9
15:08:39 <gmann> everyone is yes
15:08:40 <gmann> #showvote
15:08:40 <opendevmeet> Yes (8): dansmith, yoctozepto, belmoreira, ricolin, jungleboyj, spotz, gmann, diablo_rojo
15:08:50 <gmann> thanks everyone
15:08:58 <wendar> thanks all!
15:09:04 <gmann> #endvote
15:09:04 <opendevmeet> Voted on "TC vote on gender-neutral language bylaws changes in section Appendix 4, "OpenStack Technical Committee Member Policy"?" Results are
15:09:04 <opendevmeet> Yes (8): dansmith, yoctozepto, belmoreira, ricolin, jungleboyj, spotz, gmann, diablo_rojo
15:09:17 <fungi> yeah, looks like simple majority is all that was needed, per 9.1(d): "The amendment of Section 4.13 and the OpenStack Technical Committee Member Policy shall require the affirmative vote of the majority of the Board of Directors and the majority of the OpenStack Technical Committee."
15:09:26 <gmann> wendar: anything else on this topic you would like to talk or we need from TC side ?
15:09:45 <wendar> That's it.
15:10:08 <gmann> ok, thanks for joining too
15:10:13 <gmann> let's move to next topic
15:10:16 <gmann> #topic Gate health check
15:10:37 <gmann> any highlights/news on gate.
15:10:40 <jungleboyj> \o/
15:10:51 <dansmith> noting from me on the gate (sadly)
15:11:31 <gmann> there were few devstack changes on failure/backport which are merged
15:11:36 <gmann> one thing is about centos8 EOL
15:11:48 <gmann> #link http://lists.openstack.org/pipermail/openstack-discuss/2022-January/026621.html
15:12:05 <gmann> clarkb: sent ^^ email about that and project need attension
15:12:16 <fungi> yes, we're in the process of excising centos-8 (non-stream) images from our configuration
15:12:32 <gmann> I have pushed job/nodeset removal from devstack victoria/ussuri also as it needs to be done in those stable branches too
15:12:49 <gmann> stable/wallaby and onwards already transitioned to centos-stream
15:12:55 <fungi> everyone's assistance is appreciated in either switching jobs to centos-8-stream nodes or dropping jobs if that doesn't make sense
15:13:02 <gmann> yeah
15:13:38 <gmann> these are devstack patches, please check in case anyone have objection or want to help to add centos-stream job in victoria and ussuri #link https://review.opendev.org/q/I36751569d92fbc5084b8308d423a75318ae7d406
15:14:07 <fungi> some folks (e.g. openstack-helm/loci) had already started to spot problems with centos 8 package repositories and epel, disagreements on version requirements and such, so i don't expect it to remain viable much longer anyway
15:14:19 <gmann> I think there is no objection overall (from any project as far as i read reply in ML thread) on removal of centos8.
15:14:26 <yoctozepto> in kolla we are dropping centos linux 8 hard
15:14:32 <gmann> k
15:14:33 <yoctozepto> hard to object if it's eol anyway
15:14:42 <gmann> frickler: chateaulav Jan end is deadline right? if I read correctly ?
15:14:54 <gmann> clarkb: ^^
15:15:01 <gmann> chateaulav: sorry please ignore the pin
15:15:02 <gmann> ping
15:15:16 <fungi> deadline for gracefully merging fixes, yes
15:15:37 <gmann> cool
15:15:38 <fungi> after that we'll break jobs/configuration for projects if necessary to remove the node definitions
15:15:53 <gmann> sounds good
15:16:26 <gmann> anything else on gate health ?
15:16:54 <gmann> #topic Progress checks on Yoga Tracker
15:16:58 <gmann> #link https://etherpad.opendev.org/p/tc-yoga-tracker
15:17:10 <gmann> Please update if any progress on any of your assigned items
15:17:20 <gmann> I have marked yoga testing runtime as completed
15:17:53 <gmann> yoctozepto need early feedback on tag removal patch #link https://review.opendev.org/c/openstack/governance/+/822900
15:18:04 <gmann> I will review after meeting, sorry to miss this
15:18:22 <diablo_rojo> Tab open!
15:18:26 <yoctozepto> no problem, I understand we are all busy :-)
15:18:28 <yoctozepto> thanks gmann and diablo_rojo
15:19:08 <gmann> other item I think good to do is 'User Survey Feedback Analysis/Responses' so that we can collect any AI/working item we need for Yoga cycle
15:19:15 <gmann> jungleboyj: any plan on that^^
15:19:51 <jungleboyj> Not at the moment.  I need to make time for that.
15:20:05 <jungleboyj> Will put it on my backlog.  :-)
15:20:17 <dansmith> I also know the unified limits thing is pending
15:20:32 <dansmith> just...a lot going on right now :/
15:20:39 <jungleboyj> dansmith:  ++
15:20:58 <gmann> no issue, please take time. and thanks for working on those
15:21:12 <jungleboyj> Sounds good.
15:21:22 <gmann> anything else on any of item from tracker before we start the Z release name thing ?
15:22:10 <gmann> Z Release Cycle Name
15:22:29 <gmann> we are little late on this as release team need to start the Z release schedule or so
15:22:35 <gmann> I have started the process
15:22:44 <spotz> I'm surprised by how many names we have already
15:22:48 <jungleboyj> Thank you for doing that.
15:22:56 <gmann> #link https://review.opendev.org/c/openstack/governance/+/824201
15:22:57 <yoctozepto> spotz: me too, z looks popular
15:22:58 <jungleboyj> spotz: Yeah, I looked at that yesterday and was surprised!
15:22:59 <gmann> please review this
15:23:20 <gmann> #link https://wiki.openstack.org/wiki/Release_Naming/Z_Proposals
15:23:29 <gmann> current proposed name and yes there are lot
15:23:56 <gmann> I was also had concern if we will get only few name with Z but it is opposite :)
15:23:59 <dansmith> there's only one legit name on that list
15:24:02 <dansmith> obviously Zomicron
15:24:05 <gmann> :)
15:24:28 <jungleboyj> Zomicron ?
15:24:36 <yoctozepto> is that a word?
15:24:44 <dansmith> doesn't matter
15:24:49 <fungi> yeah, it's just before zomnomnom in the dictionary
15:24:54 <jungleboyj> Oh, I get it.
15:24:54 <dansmith> lol
15:24:57 <belmoreira> very appropriate
15:25:00 <yoctozepto> xDDD
15:25:13 <jungleboyj> Doot dooot da doo doo
15:25:33 <gmann> as first step, please review the vote schedule #link https://review.opendev.org/c/openstack/governance/+/824201
15:25:36 <spotz> What sort of related question, have we decided to go bacck to A or noot yet?
15:25:55 <jungleboyj> spotz:  I thought we had agreed to do that.
15:25:59 <diablo_rojo> spotz that has always been the plan?
15:25:59 <gmann> and next step is about naming process change which is what we discussed in PTG
15:26:06 <gmann> spotz: yeah we agreed on that
15:26:16 <gmann> L353 in https://etherpad.opendev.org/p/tc-yoga-ptg
15:26:18 <gmann> #link https://etherpad.opendev.org/p/tc-yoga-ptg
15:26:23 <spotz> Just confirming I knew we'd talked about it but couldn't remember if we'd 100% decided
15:26:26 <diablo_rojo> THe only thing that was up for debate was if we were changing cadence when we loop back around
15:26:42 <gmann> belmoreira: has item to propose the process change and A plan
15:26:47 <diablo_rojo> spotz, it was decided when they set the naming scheme way back before our times lol
15:27:04 <gmann> one change for Z we talked is to 'open vote' instead of just 'TC vote'
15:27:22 <belmoreira> gmann yes... time to start to think about it
15:27:28 <gmann> I am wondering if we should keep old process 'TC vote' fore Z and change the process from A cycle ?
15:27:38 <gmann> due to time constraint specially
15:27:42 <spotz> I always thought it was fun voting so I think we should open it back up
15:27:44 <belmoreira> as usual the best would be to get the input from the community
15:27:46 <gmann> belmoreira: thanks
15:27:51 <jungleboyj> spotz:  ++
15:28:01 <jungleboyj> I am happy with that.  It felt weird with just us voting.
15:28:13 <gmann> from Z cycle itself ?
15:28:33 <fungi> in the end the tc ends up deciding whether the community vote is viable, or deciding which selections the community gets to vote on, so the tc is still deciding it
15:28:37 <jungleboyj> gmann:  I am ok waiting for A to make the change, but it would be nice if it were a community vote for Z .
15:28:48 <spotz> +1 jungleboyj
15:28:59 <diablo_rojo> Agreed
15:29:07 <jungleboyj> I know everyone is busy, so don't want to make it harder on people.
15:29:17 <gmann> jungleboyj: yeah that was my hope but we are little late for Z and I do not want to delay it further
15:29:20 <dansmith> yeah, whatever is least effort is best here, IMHO
15:29:22 <dansmith> this is "fun" but not that important
15:29:26 <fungi> also defining "community" is challenging. it'll be fun to see what the next opinion is on how to poll "the community" for a name choice
15:29:55 <spotz> Didn't we goo through that for voting already on the TCC?
15:30:22 <dansmith> if waiting until A is easier, that makes sense to me, but if it's easy to just revert to open right now for Z then just do it
15:30:25 <diablo_rojo> spotz, yes, but this will be at a much larger scale
15:31:01 <diablo_rojo> And it was just the special election?
15:31:18 <gmann> dansmith: we need a another formal-vote and reivew on process change and that is after we push that so it will take time
15:31:33 <dansmith> ah
15:31:37 <dansmith> yeah
15:31:41 <dansmith> makes sense for A then
15:31:51 <gmann> ok, let's continue the same process 'TC vote only' for Z and work on process change for future releases in parallel
15:31:52 <fungi> you can make it a completely open poll, that's fairly easy, but it's roughly the same as asking twitter what we should name the release. in the past we've also tried things like limiting it to the foundation individual members, limiting it to the tc electorate, and so on
15:31:56 <jungleboyj> Works for me.
15:32:11 <dansmith> gmann: ++
15:32:32 <jungleboyj> Twitter result ?  Zoinks !
15:32:32 <belmoreira> gmann +1
15:33:03 <gmann> cool, I will start that once schedule is merged.
15:33:09 <spotz> gmann +1
15:33:15 <jungleboyj> gmann: ++
15:33:18 <ricolin> gmann, +1
15:33:28 <diablo_rojo> Sounds good.
15:33:33 <gmann> let's move to next topic
15:33:37 <gmann> #topic SIG i18n status check
15:33:56 <gmann> ianychoi[m]: has fixed the things and continue to lead this SIG.
15:34:09 <gmann> I think we are ok now and we can drop this topic from agenda now?
15:34:36 <spotz> Sounds good
15:34:39 <gmann> unless anyone has any feedback or so
15:35:32 <gmann> thanks again ianychoi[m] for help
15:35:34 <gmann> #action gmann to remove the SIG i18 topic from meeting agenda
15:35:43 <gmann> #topic Adjutant need PTLs and maintainers
15:35:47 <gmann> no update on this
15:36:12 <yoctozepto> are we waiting indefinitely?
15:37:27 <gmann> humm, Braden said still waiting for permission from company. ands there is no other help offering
15:37:58 <gmann> so I will say let's see for Yoga and if during release or next cycle it is not decided then we think about other option like retirement or so
15:38:23 <fungi> is it still releaseable for yoga?
15:38:42 <gmann> this is time for next FY budget planning for most of company so i understand the waiting on permission things
15:39:18 <gmann> Adrian said he will continue to help until someone will lead so I am hoping yes
15:39:43 <gmann> we will see how it goes
15:39:55 <fungi> just noticing that no changes have merged to the openstack/adjutant repo since october
15:40:33 <diablo_rojo> And they still haven't been a part of a coordinated release.
15:40:50 <fungi> oh, did they never actually reach releasable state anyway?
15:41:09 <diablo_rojo> fungi, no I don't think so.
15:41:09 <gmann> yeah
15:41:18 <fungi> releases.o.o claims adjutant 3.0.0 was included in xena
15:41:37 <fungi> and 2.0.0 in wallaby
15:41:37 <diablo_rojo> I was pretty sure that was empty..
15:41:49 <diablo_rojo> I would have to dig in further though.
15:42:02 <fungi> 1.0.0 in victoria
15:42:07 <gmann> elodilles ^^ feel free to reachout to us for Adjutant release issue if any for Yoga as it facing maintainer issue
15:42:44 <fungi> looks like it's been "released" as part of the coordinated openstack release as far back as ussuri
15:43:30 <fungi> https://releases.openstack.org/ussuri/index.html#ussuri-adjutant
15:43:49 <gmann> k
15:43:56 <gmann> let's wait on this and we will see if any things we need to do in Yoga or ok to wait until next cycle start during PTL appointment process
15:44:09 <gmann> #topic Open Reviews
15:44:12 <gmann> #link https://review.opendev.org/q/projects:openstack/governance+is:open
15:44:23 <diablo_rojo> fungi, I'm either wrong about the not being released or missing something else then. My mistake.
15:44:24 <gmann> we have 8 open review, let's see what all need attension
15:45:42 <gmann> [masakari] Transfer PTL role to suzhengwei #link https://review.opendev.org/c/openstack/governance/+/824509
15:46:05 <gmann> this is ready to vote, thanks yoctozepto for your leading masakari
15:46:19 <yoctozepto> :-)
15:46:46 <diablo_rojo> Yes, thank you for all your hard work!
15:46:54 <jungleboyj> ++
15:47:20 <gmann> other project updates need two project-config change to merge
15:47:23 <gmann> #link https://review.opendev.org/c/openstack/project-config/+/823803 #link https://review.opendev.org/c/openstack/project-config/+/824584
15:47:39 <gmann> fungi: mnaser frickler clarkb ^^ if any of you can review these
15:47:59 <fungi> sure
15:48:06 <gmann> thanks
15:48:37 <gmann> other review are in review i think.
15:49:00 <gmann> that is all from my side for today meeting.
15:49:04 <gmann> anything else to discuss ?
15:49:38 <fungi> we discussed project renames in this week's opendev meeting
15:49:55 <jungleboyj> Nothing from me.
15:50:07 <gmann> fungi: when it is planned ?
15:50:13 <fungi> #link https://meetings.opendev.org/meetings/infra/2022/infra.2022-01-11-19.01.log.html#l-75
15:50:40 <fungi> monday the 2022-01-24 is what we're planning to announce
15:50:55 <gmann> ok, sounds good
15:51:01 <fungi> no specific time decided yet, but probably late utc hours
15:51:16 <gmann> +1
15:51:37 <fungi> so if any other renames/moves are known to be needed, please get them onto the list in our agenda wiki
15:51:46 <gmann> ack
15:52:01 <fungi> #link https://wiki.openstack.org/wiki/Meetings/InfraTeamMeeting#Upcoming_Project_Renames
15:53:12 <gmann> if nothing else, let's close today meeting.
15:53:24 <spotz> Thanks gmann and everyone!
15:53:26 <gmann> thanks all for joining and stay safe.
15:53:31 <gmann> #endmeeting