15:00:10 <gmann> #startmeeting tc
15:00:10 <opendevmeet> Meeting started Thu Feb 10 15:00:10 2022 UTC and is due to finish in 60 minutes.  The chair is gmann. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:10 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:10 <opendevmeet> The meeting name has been set to 'tc'
15:00:16 <gmann> #topic Roll call
15:00:17 <dansmith> belmoreira: you around after the meeting to chat about release cycle?
15:00:18 <gmann> o/
15:00:20 <dansmith> o/
15:00:23 <spotz_> O/
15:00:30 <belmoreira> o/
15:00:47 <belmoreira> dansmith yes, I can stay longer
15:00:51 <dansmith> cool
15:00:54 <jungleboyj> o/
15:01:08 <yoctozepto> o/
15:01:12 <ricolin> o/
15:01:40 <dmendiza[m]> \o
15:01:40 <diablo_rojo_phone> O/
15:02:14 <gmann> #link https://wiki.openstack.org/wiki/Meetings/TechnicalCommittee
15:02:19 <gmann> ^^ agenda for today meeting
15:02:56 <gmann> absent members: Rico Lin (ricolin), Chinese New Year vacation
15:02:58 <gmann> let's start
15:03:09 <gmann> #topic Follow up on past action items
15:03:12 <ricolin> that's a mistake:)
15:03:18 <ricolin> I'm presented:)
15:03:20 <gmann> ricolin: ohk, nice
15:03:32 <gmann> sorry i missed to remove it from there may be
15:03:47 <ricolin> NP
15:04:03 <gmann> no action item to track from previous meeting #link https://meetings.opendev.org/meetings/tc/2022/tc.2022-02-03-15.00.html
15:04:15 <gmann> #topic Gate health check
15:04:32 <gmann> what's news on gate this  week
15:04:49 <dansmith> I've seen some instability this week, I dunno about others
15:05:03 <dansmith> I haven't collected any hard data, but I've seen a lot of 'recheck cinder' type things
15:05:15 <dansmith> I'll try to pay more attention over the next week and see if I can report any patterns
15:05:37 <gmann> ok
15:06:02 <gmann> there is volume detach issue occurring 100% on centos9 stream job
15:06:05 <gmann> #link https://bugs.launchpad.net/nova/+bug/1960346
15:06:59 <gmann> and neutron stable gate got broken due to tempest change which is also fixed now and green
15:07:33 <gmann> and centos8-stream is still unstable and jobs are non voting.
15:07:53 <gmann> *centos8-stream jobs
15:08:36 <yoctozepto> well, without "jobs" it's probably still true ;-)
15:09:10 <fungi> we also restored the centos-8 nodeset temporarily, pointing it at centos-8-stream labels, because the nodeset removal deadlocked cleanup in jobs which relied on it
15:09:33 <yoctozepto> oh my
15:09:59 <gmann> humm
15:10:02 <fungi> though we're looking at a more obvious alternative so that jobs using the centos-8 nodeset will return node_failure results (therefore no risk that they succeed, but still won't block cleanup changes)
15:10:47 <gmann> there are stable branch jobs using the nodeset and we could not remove it from devstack but I will give another try with fixes on stable branches
15:11:06 <spotz_> Fungi could those nodes be told to use stream repos?
15:11:10 <yoctozepto> fungi: that sounds sensible
15:11:18 <fungi> the basic problem is that if you have a job which relies on a nodeset, and that nodeset is no longer defined, you can't merge a change to remove the job or alter its nodeset
15:11:43 <spotz_> Ouch
15:11:56 <yoctozepto> zuul's quirk
15:12:08 <fungi> because zuul expects the initial state it's going to compare the change against to have resolveable configuration
15:12:10 <gmann> yeah, do we have list of how many jobs using it. I know few of the cinder stable/victoria
15:13:14 <fungi> i'm not sure if anyone has put anything together, no
15:13:56 <fungi> i know jrosser was trying to work through a bunch of cleanup for it in openstack-ansible repos
15:13:58 <gmann> k, I will work on devstack side to remvove the node and see how many we can cleanup on that
15:14:09 <gmann> nova side I fixed but still need more to fix
15:15:38 <gmann> anything else on gate?
15:16:06 <gmann> #topic Z Release Cycle Name
15:16:36 <gmann> ranked names are under trademark checks by foundation. may be we should be ready by next week
15:16:55 <yoctozepto> hopefully Zen passes
15:17:03 <jungleboyj> Any feeling for what the result will be?
15:17:12 <gmann> Zombie :)
15:17:30 <belmoreira> :)
15:17:31 <dansmith> heh
15:17:33 * jungleboyj laughs
15:17:38 <spotz_> It has grown on me
15:17:50 <jungleboyj> Zen or Zombie?
15:18:03 <spotz_> Zombie
15:18:09 <yoctozepto> lol
15:18:12 <jungleboyj> :-)
15:18:27 <jungleboyj> Quote of the day 'Zombie is growing on me.'
15:18:46 <spotz_> Hehe
15:18:51 <yoctozepto> on spotz_*
15:19:23 <yoctozepto> anyhow, I guess gmann please continue
15:19:42 <gmann> :)
15:19:46 <gmann> on the release name, belmoreira will you be able to put the new name process up for review what we discussed in last PTG ? or let us know if you need help.
15:20:24 <belmoreira> sure. I think is consensual that we just restart the alphabet. Or someone as a different opinion?
15:21:01 <yoctozepto> tbh, I wanted to switch to years
15:21:05 <fungi> we'll also need to scramble to update the election repo during campaigning, to swap out the z placeholder for whatever name is selected
15:21:07 <dansmith> as opposed to what? start with the klingon alphabet?
15:21:22 <dansmith> oh years
15:21:28 <yoctozepto> yeah
15:21:55 <gmann> 20xx.1 &  20xx.2 ?
15:22:18 <yoctozepto> or with months, like ubuntu
15:22:30 <yoctozepto> both are fine
15:22:39 <dansmith> well, if we go with a tick/tock release cycle,
15:22:53 <dansmith> we could also get more creative with the .1 and .2 so they're meaningful
15:23:00 <dansmith> but yeah, I'm not opposed to years at all
15:23:07 <belmoreira> honestly I like the idea... but we lose the fun of naming the release
15:23:17 <yoctozepto> 2022.duck 2022.yeah
15:23:24 <dansmith> the names all kinda blend together now, and I do love knowing that my 12.04 machine is almost ten years old :D
15:23:32 <belmoreira> or we keep the relase name as well, like ubuntu
15:23:42 <dansmith> yeah
15:23:46 <yoctozepto> belmoreira: yeah
15:24:05 <gmann> I like that <year>.<name> ?
15:24:19 <gmann> or like ubuntu
15:24:25 <diablo_rojo_phone> Yeah that sounds good.
15:24:26 <belmoreira> but in that case we don't need to be attached to the alphabet (following the letters...)
15:24:28 <knikolla> I have to confess I had to google the alphabet to completely remember the order of those last few letters (hi all :)
15:24:29 <gmann> but single name not double
15:24:53 <gmann> knikolla: hi.
15:24:53 <diablo_rojo_phone> knikolla: I often still have to sing the song to myself lol
15:24:58 <belmoreira> gmann :)
15:25:02 <jungleboyj> :-)
15:25:08 <dansmith> gmann: or, make it harder:
15:25:09 <yoctozepto> alphabet song ftw
15:25:17 <dansmith> all names after this have to be a single word with the proper repeated letter
15:25:20 <dansmith> aardvark for example
15:25:23 <dansmith> B will be a challenge
15:25:27 <spotz_> I like names they’re fun
15:25:28 <yoctozepto> lol
15:25:36 <dansmith> Bubble, Bobble
15:25:42 <dansmith> Capuccino
15:25:43 <yoctozepto> yeah, names are fun
15:25:51 <jungleboyj> I don't think we want to remove the name aspect.
15:25:58 <jungleboyj> If we append the year that is fine with me.
15:26:14 <belmoreira> jungleboyj +1
15:26:16 <dansmith> we technically have version numbers now, which I can never remember,
15:26:21 <jungleboyj> Or pre-pend I should say.
15:26:28 <gmann> ok, let's put it for review and then we can discuss more ideas too along with the one we discussed now
15:26:30 <dansmith> so switching to years will likely involve some work by people I imagine
15:26:31 <belmoreira> but do you think we need to follow the alphabet if we have the year?
15:26:51 <yoctozepto> we can forget the alphabet song then
15:27:11 <yoctozepto> let people propose names they feel are current
15:27:14 <yoctozepto> like
15:27:19 <jungleboyj> I personally like keeping the alphabet as it keeps the feeling of progression.
15:27:23 <yoctozepto> OpenStack Covid Edition
15:27:29 <yoctozepto> 2022.10
15:27:47 <spotz_> Are we just going to confuse everyone!
15:28:02 <knikolla> I feel names bring a sense of community with the voting process
15:28:05 <jungleboyj> spotz_:  I think that is a legitimate concern.
15:28:10 <jungleboyj> knikolla:  ++
15:28:14 <yoctozepto> I dunno, the year would be just fine for me
15:28:15 <gmann> knikolla: +1
15:28:17 <dansmith> knikolla: except we don't do it anymore :)
15:28:28 <dansmith> I mean, lately.
15:28:34 <yoctozepto> yeah
15:29:27 <gmann> I like year followed by elected name but yeah let's put those ideas we discussed today and then we can continue discussion in gerrit ?
15:29:40 <yoctozepto> +1
15:30:03 <gmann> and if we go with the voting system then we will change that from TC to community members
15:30:17 <belmoreira> +1
15:30:29 <gmann> belmoreira: is it fine to add action item for you?
15:30:30 <jungleboyj> +1
15:30:43 <belmoreira> gmann sure
15:30:47 <gmann> #action belmoreira to propose the next release naming ideas
15:30:51 <gmann> belmoreira: thanks
15:31:21 <gmann> #topic Z cycle Technical Elections
15:31:39 <gmann> nomination for PTL and TC are open and until 15th Feb
15:32:01 <gmann> #link http://lists.openstack.org/pipermail/openstack-discuss/2022-February/027117.html
15:32:10 <gmann> till now we have only 5 PTL and 1 TC nomination
15:32:30 <gmann> yoctozepto: belmoreira : announced that they are not running TC in next term.
15:32:50 <gmann> thanks again both of you for your contribution.
15:33:18 <gmann> but as you know until this election is over you are in TC term or you re-decide to serve next term too :)
15:33:30 <spotz_> Hehe
15:33:43 <jungleboyj> You can't get away that quickly!
15:33:44 <yoctozepto> TC4life
15:33:58 <gmann> :) +1
15:34:08 <belmoreira> yeah, the farewell is in few weeks :)
15:34:40 <gmann> and I hope ricolin and mnaser will run as their term is also completing this election.
15:35:30 <gmann> but feel free to encourage members for PTL or TC which you know are interested or you think better to have in group
15:35:57 <yoctozepto> I will be around on the mailing list after the farewell as well and you can always send me an email to my primary address :-)
15:36:04 <ricolin> I might not have much time for TC works in the following months, but will see before the Nomination end
15:36:09 <gmann> yoctozepto: +1, cool.
15:36:25 <gmann> ricolin: thanks.
15:36:26 <yoctozepto> what if there are no more nominations though?
15:36:54 <yoctozepto> will you reduce the TC size again?
15:37:10 <gmann> yeah, we will see what to do. either find someone or discuss on reducing the seat again
15:37:26 <ricolin> +1 on encourage new TC to join
15:37:34 <jungleboyj> +1
15:38:23 <gmann> yeah, I think we have lot of technical work to drive in coming cycles so having 9 members in group will be helpful but let's see
15:39:00 <gmann> for more election updates, we will discuss in election channel and update highlights in this channel too
15:39:10 <belmoreira> honestly I don't expect this to be a problem for the TC. Usually people only nominate themselves close to the end of the process
15:39:33 <gmann> yeah, even for PTL also. at the end we see lot of nomination
15:39:43 <spotz_> I did it early so I wouldn’t forget to fit review again
15:39:43 <yoctozepto> even after the end
15:39:49 <jungleboyj> That was what I figured.
15:40:00 <jungleboyj> spotz_:  Good job!  :-)
15:40:07 <gmann> ricolin: just to know till when is the Chinese vacation ?
15:40:08 <spotz_> Hehe
15:40:27 <jungleboyj> gmann:  It officially ended on last Sunday.
15:40:31 <gmann> spotz_: +1
15:40:36 <jungleboyj> Lots of people take the following week off.
15:40:48 <ricolin> gmann, entire last week
15:41:09 <jungleboyj> ++
15:41:09 <gmann> ok so we are good in term of nomination dates. I thought it conflict and many members might miss notification
15:41:21 <ricolin> and give or take few days front or back
15:41:30 <ricolin> yes
15:41:37 <ricolin> definitely okay
15:41:38 <gmann> ricolin: please spread the election nomination in local groups like wechat etc in case
15:41:46 <ricolin> will do
15:41:49 <gmann> in case they missed the ML
15:41:53 <gmann> ricolin: thanks
15:42:10 <gmann> #topic Dropping tags framework - next steps (yoctozepto)
15:42:18 <yoctozepto> yup
15:42:45 <yoctozepto> so, the releases repo needs to be adapted to stop relying on tags
15:42:53 <gmann> part1 is up for review #link https://review.opendev.org/c/openstack/governance/+/822900
15:43:12 <gmann> yoctozepto: and openstack website too.
15:43:28 <yoctozepto> ah, good catch, I forgot, thanks gmann
15:43:37 <gmann> I am not sure I can help on this in this cycle but anyone to help on replacing it for release scripts etc?
15:45:31 <gmann> or yoctozepto can you please check in release channel if release membrs can help here
15:45:31 <yoctozepto> the other thing is new placement of the contentss
15:45:55 <yoctozepto> I will start a thread on the ML
15:46:05 <fungi> if there's a timeframe for this, i can move the vulnerability:managed tag guidelines into the openstack/ossa repo
15:46:41 <yoctozepto> fungi: thanks, that makes sense
15:46:46 <fungi> the vmt relies on that as a means of documenting expectations, but we don't really have any tooling relying on it directly
15:46:59 <gmann> fungi: thanks
15:47:15 <yoctozepto> and then how do we want to track which projects are vmt?
15:47:25 <gmann> fungi: we have few document/process in project team guide too #link https://docs.openstack.org/project-team-guide/vulnerability-management.html
15:47:47 <fungi> yoctozepto: the vmt can just maintain a list in the ossa repo
15:47:57 <gmann> fungi: it is fine whatever way you want to arrange them in one place
15:48:01 <gmann> +1
15:48:03 <yoctozepto> ack, perfect
15:48:17 <fungi> gmann: thanks for bringing that up, i had forgotten it was in there
15:48:53 <gmann> fungi: on timeline, no hard timeline but we planned to finish it before Yoga release(final release).
15:49:04 <fungi> and yeah, whatever makes sense to be on the security.o.o site we'll put in the ossa repo and we can also move some stuff into the project team guide as appropriate
15:49:41 <gmann> sounds good
15:50:22 <yoctozepto> ok, so vmt is solved, only stable (releases) and deprecation policy remain
15:50:36 <yoctozepto> presumably stable goes to releases team
15:50:40 <gmann> yoctozepto: and for standard deprecation tag, we can move in project-team-guide under technical-guidelines (what we planned to make new dir) ?
15:50:57 <yoctozepto> hmm, makes sense
15:51:10 <gmann> yoctozepto: stable also we have in proeject-team-guide #link https://docs.openstack.org/project-team-guide/stable-branches.html
15:51:14 <yoctozepto> and projects are free to follow that
15:51:25 <yoctozepto> gmann: yeah, I mean tracking
15:51:46 <gmann> ohk
15:51:50 <yoctozepto> but maybe it's irrelevant
15:52:05 <yoctozepto> I mean, it was only on the paper anyway
15:52:24 <yoctozepto> (I hope that expression makes sense in English)
15:52:40 <gmann> project/repo having stable branch are supposed to follow it so yeah we do not need to track as list I think
15:53:04 <yoctozepto> ok, so similar to deprecation
15:53:06 <gmann> supposed to follow as per new process
15:53:27 <yoctozepto> any other opinions?
15:54:43 <gmann> IMO, for deprecation also I think same. we will have guidelines and project will follow that as they are doing now. list is not necessary to maintain
15:55:22 <yoctozepto> ok, /me like
15:55:23 <gmann> yeah, any other opinion? especially from users point of view
15:56:13 <opendevreview> Merged openstack/governance master: Add timelines to few of the Chair duties.  https://review.opendev.org/c/openstack/governance/+/828062
15:56:31 <yoctozepto> tough crowd
15:57:01 <yoctozepto> guess it means everyone agrees
15:57:31 <yoctozepto> thanks gmann and fungi for discussion
15:57:40 <gmann> hope so, please push the changes and we can get more feedback there if there is any
15:57:48 <yoctozepto> +1
15:57:57 <gmann> 3 min left let's move next
15:58:14 <gmann> thanks yoctozepto for working on it
15:58:15 <gmann> #Open Reviews
15:58:26 <gmann> 3 open review #link https://review.opendev.org/q/projects:openstack/governance+is:open
15:58:35 <gmann> 1 is in gate to merge
15:58:40 <gmann> please review those
15:58:43 <gmann> one last thing
15:59:09 <gmann> right after this meeting we will have release cadence discussion @ https://meetpad.opendev.org/OpenStackReleasecadence
15:59:13 <gmann> please join  there
15:59:19 <gmann> that is all from my side today ?
15:59:24 * yoctozepto not around for it
15:59:30 <gmann> thanks everyone for joining.
15:59:33 <yoctozepto> thanks gmann for chairing
15:59:36 <gmann> #endmeeting