15:00:45 <gmann> #startmeeting tc
15:00:45 <opendevmeet> Meeting started Thu Jun 30 15:00:45 2022 UTC and is due to finish in 60 minutes.  The chair is gmann. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:45 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:45 <opendevmeet> The meeting name has been set to 'tc'
15:00:58 <gmann> tc-members  meeting time
15:01:02 <gmann> #topic Roll call
15:01:05 <gmann> o/
15:01:07 <slaweq> o/
15:01:08 <dansmith> o/
15:01:09 <dpawlik> o/
15:01:19 <diablo_rojo> o/
15:02:32 <jungleboyj> o/
15:03:10 <jungleboyj> I am not sure about other people but I don't see travel being allowed for me anytime soon.
15:03:33 <spotz> o/
15:03:38 <arne_wiebalck> o/
15:03:45 <gmann> ohk. let's discuss it at the end
15:03:58 <gmann> #link #https://wiki.openstack.org/wiki/Meetings/TechnicalCommittee
15:04:04 <gmann> today ^^ agenda
15:04:12 <gmann> Follow up on past action items
15:04:21 <gmann> gmann to add c9s testing collaboration topic in next meeting agenda and call c9s folks to help it to make stable distro to test in OpenStack
15:04:32 <gmann> I did nto get time to do this, too many things this week.
15:04:48 <gmann> I will re-add it and make sure next call we will discuss it with c9s folks
15:04:51 <gmann> #action gmann to add c9s testing collaboration topic in next meeting agenda and call c9s folks to help it to make stable distro to test in OpenStack
15:04:59 <gmann> slaweq to send the recheck data on ML asking projects doing more bare recheck to start working on it
15:05:20 <gmann> slaweq: sent email #link http://lists.openstack.org/pipermail/openstack-discuss/2022-June/029342.html
15:05:21 <dansmith> done, just in the nick of time ;)
15:05:27 <gmann> +1
15:05:36 <gmann> and we will discuss about recheck things in gate health topic
15:05:48 <gmann> thanks slaweq for sending
15:05:50 <gmann> arne_wiebalck to check with stephen and artem about driving the OSC work as popup team or any other dedicated group way
15:05:53 <slaweq> yw
15:05:54 <gmann> arne_wiebalck: any update ^^
15:06:09 <slaweq> now the data should be accurate (I hope at least)
15:06:32 <slaweq> at least it was good for various patches which I was checking today
15:06:41 <arne_wiebalck> there was no reply yet, I sent the mail
15:07:07 <arne_wiebalck> dansmith & diablo_rojo should have received a copy ... otherwise I did not send it :-/
15:07:28 <dansmith> I received it
15:07:35 <arne_wiebalck> dansmith: thx
15:07:39 <knikolla> o/
15:08:08 <gmann> ok
15:08:11 <diablo_rojo> I saw it @arne_wiebalck !
15:08:14 <gmann> let's wait then
15:08:40 <gmann> arne_wiebalck: should we continue the same action item or you want to proceed in other way like adding separate topic or so?
15:08:50 <gmann> or just track it as part of zed tracker?
15:09:26 <arne_wiebalck> zed tracker is fine I think
15:09:35 <gmann> cool
15:09:42 <arne_wiebalck> I will keep it updated
15:09:50 <gmann> arne_wiebalck: thanks
15:10:12 <gmann> #topic Gate health check
15:10:26 <gmann> any news on gate before we discuss recheck things
15:10:43 <dansmith> I don't have anything specific, but I think ade_lee fixed the fips job problem
15:11:03 <dansmith> the nslookup thing.. the patch merged at least, and I think at least glance has another patch we need to merge for the periodic job
15:11:20 <slaweq> yesterday we saw some rally issue in the neutron gates
15:11:23 <dpawlik> I propose a patch to fix fields in performance.json in Opensearch, so it should provide more information
15:11:51 <slaweq> I'm not sure if other rally jobs are broken also but I guess they can be
15:12:12 <gmann> dpawlik: +1 thanks
15:12:35 <gmann> I also have not seen any frequent failure
15:13:15 <gmann> slaweq: not sure about rally, I hardly see any rally job in the projects I usually push patches
15:13:23 <slaweq> here is bug reported https://bugs.launchpad.net/neutron/+bug/1980055
15:13:34 <slaweq> and patch seems to be in gate now https://review.opendev.org/c/openstack/rally-openstack/+/847879
15:13:55 <gmann> +1
15:14:08 <gmann> Bare 'recheck' state
15:14:17 <gmann> #link https://etherpad.opendev.org/p/recheck-weekly-summary
15:14:24 <gmann> slaweq: go ahead
15:14:32 <gmann> #link http://lists.openstack.org/pipermail/openstack-discuss/2022-June/029342.html
15:14:44 <gmann> if anything you would like to highlight
15:14:49 <slaweq> it seems that there is many "bare" rechecks done in most of the teams
15:15:31 <gmann> yeah, I added to monitor this in QA meeting
15:15:41 <slaweq> I don't think there is anything to highlight there now, I think we should try to share that data with the teams and see in time if that will improve
15:15:48 <gmann> I will add it for tacker and horizon also as it is 100% bare recheck for them
15:16:06 <slaweq> I will be regulary checking and reporting it in neutron team's meeting too
15:16:10 <gmann> +1
15:16:30 <gmann> slaweq:  plan is to post it on ML also every week right?
15:16:50 <gmann> just making sure that is what we decided in last meeting not just only initial email
15:16:59 <slaweq> gmann: I can do that every Thursday, before TC meeting
15:17:13 <jungleboyj> slaweq:  ++
15:17:32 <fungi> i found it interesting that there were only two teams below the 50% mark in the list
15:17:38 <gmann> sounds good, that can help to get attention  from projects
15:17:54 <clarkb> one thing that occured to me from that thread is what we seem to be concerend about is a lack of culture around quality.
15:17:57 <gmann> slaweq: thanks for doing it
15:18:07 <clarkb> I wonder if we shouldn't try and reframe the discussion around that over time (add more metrics etc)
15:18:19 <clarkb> (this is a great start!)
15:18:44 <slaweq> clarkb: I would love to add more metrics, if You have any ideas about such, please let me know
15:18:48 <slaweq> I will be happy to improve all of that
15:18:51 <gmann> yeah, let's see how it goes and if we can build culture of no bare recheck and know the failure firt
15:19:09 <gmann> that can be good first step
15:19:58 <slaweq> ++
15:20:49 <jungleboyj> ++
15:20:58 <spotz> ++
15:21:40 <gmann> anything else on gate health
15:22:01 <gmann> #topic New ELK service dashboard: e-r service
15:22:04 <gmann> #link http://lists.openstack.org/pipermail/openstack-discuss/2022-April/028346.html
15:22:13 <gmann> #link https://opensearch.logs.openstack.org/_dashboards/app/login?nextUrl=%2F_dashboards%2Fapp%2Fdiscover%3Fsecurity_tenant%3Dglobal
15:22:20 <gmann> dpawlik: any updates on this
15:23:14 <dpawlik> gmann: nothing important. Working on pushing container images with "latest" tag to the docker registry
15:23:15 <gmann> this is to merge the rdo and master branch or elastic-recheck repo #link https://review.opendev.org/c/opendev/elastic-recheck/+/847405/
15:23:40 <gmann> dpawlik: thanks,
15:23:49 <dpawlik> added a prometheus exporter to get some metrics to count metrics
15:23:58 <dpawlik> to estimate space on Opensearch
15:24:31 <dpawlik> created the performance- index, soon it will be recreated when https://review.opendev.org/c/openstack/ci-log-processing/+/848218 is merged
15:24:34 <dpawlik> that's all
15:24:59 <gmann> +1
15:25:01 <gmann> dpawlik: as we have good progress in this part, do you want to keep it in TC meeting topic or work/track as part of TaCT SIG?
15:25:15 <dpawlik> about elasticsearch recheck, dasm I guess is working on adding authentication to the Opensearch, but I can be wrong
15:25:45 <dpawlik> we can remove from TC meetings
15:25:45 <clarkb> elastich-recheck shouldn't need more than anonymous access. I don't think those two things are related
15:26:01 <fungi> out of curiosity, why is opensearch authentication needed for elastic-recheck to perform queries?
15:26:17 <clarkb> or maybe you mean e-r needs to be updated to do the "anonymous" RO auth
15:26:21 <dpawlik> clarkb: yeah, but anonymous access in opensearch = disable security plugin
15:26:22 <gmann> sure, I will remove it from next meeting agenda and if you feel anything from TC you need you can ping us here
15:26:30 <fungi> right, to know to use the openstack/openstack login
15:26:39 <fungi> okay, that makes sense, thanks!
15:27:59 <gmann> #topic RBAC community-wide goal
15:28:11 <gmann> #link https://etherpad.opendev.org/p/rbac-zed-ptg#L171
15:28:18 <gmann> #link http://lists.openstack.org/pipermail/openstack-discuss/2022-June/029324.html
15:28:45 <gmann> ^^ we had the policy popup meeting on tuesday and agreed on the direction mentioned in email
15:29:02 <gmann> proposed the same in goal document update #link https://review.opendev.org/c/openstack/governance/+/847418
15:29:25 <dansmith> lots of discussion there, but seems like we're converging on agreement
15:29:28 <gmann> idea is to postponed the 'scope' implementation and finsih project persona first. that is what operator want
15:29:56 <gmann> yeah, please check the review if you are interested to help or get the overall direction
15:30:01 <slaweq> and change "project_admin" into "admin" like it in legacy rules IIUC
15:30:18 <slaweq> *like it is in legacy ...
15:30:23 <gmann> slaweq: yes, good point, overall keep legacy admin same way it was
15:31:09 <fungi> how does that square with the previous discussions to get rid of the word "admin" since it's misleading and has been a consistent source of confusion for users/operators?
15:31:32 <gmann> overall, do the project persona with project reader which is phase 1 first
15:31:57 <dansmith> fungi: those discussions settled on admin being actual admin, and not re-using that for lesser customer-type admins
15:32:10 <dansmith> since we're just keeping the old admin, I think we 're square
15:32:28 <gmann> yeah and for project level admin work, we will have project manager but in phase 3
15:32:29 <fungi> okay, so "admin" will mean global admin, but won't be allowed for project-level role names
15:33:35 <gmann> fungi: project-level role names? you mean no more 'project-admin' and only single admin?
15:33:40 <knikolla> that's what "manager" will be for, IIRC.
15:33:47 <gmann> yeah
15:34:13 <gmann> basicallly admin, project-manager, project-member, project-reader
15:34:31 <fungi> the confusion which has resulted in security mishaps for users so far is creating an "admin" role in a project, and not realizing that users in that role got access outside that project
15:34:40 <gmann> admin here is same thing we have already so no change in that name or its behavior
15:35:09 <gmann> fungi: yeah, project-manager should solve that
15:35:34 <knikolla> keystone has a keystone-doctor CLI that we could use to warn operators if they're unwillingly granting admin on users in more than one project
15:35:39 <knikolla> unwittingly*
15:35:46 <gmann> https://review.opendev.org/c/openstack/governance/+/847418/6/goals/selected/consistent-and-secure-rbac.rst#538
15:35:48 <fungi> that sounds helpful
15:36:02 <gmann> #link https://review.opendev.org/c/openstack/governance/+/847418/6/goals/selected/consistent-and-secure-rbac.rst#538
15:36:41 <gmann> that is all on this and we request to review the proposed direction
15:37:07 <gmann> dansmith: anything else from your side on RBAC?
15:37:11 <dansmith> nope
15:37:18 <gmann> ok
15:37:23 <gmann> #topic Create the Environmental Sustainability SIG
15:37:34 <gmann> #link https://review.opendev.org/c/openstack/governance-sigs/+/845336
15:37:42 <gmann> we discussed it in last meeting also
15:38:03 <diablo_rojo> I haven't seen any new folks pipe up on the review
15:38:08 <diablo_rojo> I will keep pushing on that.
15:38:09 <gmann> I think from review from other member also, it should be openinfra level
15:38:39 <gmann> diablo_rojo: or you are looking for more feedback ?
15:38:45 <knikolla> a good topic to bring with the board then?
15:38:56 <jungleboyj> diablo_rojo:  Yeah, a few people have made comments.
15:39:00 <diablo_rojo> gmann, yes, from the people that are interested in paricipating
15:39:19 <diablo_rojo> jungleboyj, but almost none from the larger list of users and operators from berlin that signed up to participate
15:39:21 <jungleboyj> Ah.  :-)
15:39:29 <diablo_rojo> I am working on getting them setup on Gerrit and IRC
15:39:31 <jungleboyj> Good point.  :-)
15:39:33 <gmann> knikolla: humm i think we as SIG volunteer and TC can decide first, and if we agree to go as board workjng grouo then yes baord can discuss
15:39:33 <spotz> Maybe not the board but reach out to the community managers and leads for visibility for input
15:39:36 <diablo_rojo> so that we can actually collaborate :)
15:39:55 <jungleboyj> diablo_rojo:  Details, details.  ;-)
15:39:58 <gmann> diablo_rojo: TheJulia replied on that i think
15:40:04 <knikolla> makes sense
15:40:06 <diablo_rojo> jungleboyj, the devil is in the details ;)
15:40:11 * diablo_rojo waves from details
15:40:19 * jungleboyj laughs
15:40:37 <diablo_rojo> gmann, yes but there are close to 30 other people I think that also want to be involved that havent spoken up yet
15:40:49 <diablo_rojo> jungleboyj, :)
15:41:17 <diablo_rojo> So at this point, I think we should hold off on anything until they reply on the review.
15:41:19 <gmann> diablo_rojo: I will suggest to hold on the IRC, other infra setup or so until we decide where we will start this effort. l
15:41:22 <diablo_rojo> At least a couple of the,.
15:41:52 <gmann> diablo_rojo: you are assuming all those 30 or even half will be part of this SIG/group ?
15:41:56 <diablo_rojo> gmann, fair. I don't need to setup a channel yet, but they should still get on IRC as we will want to communicate there eventually
15:42:00 <diablo_rojo> gmann, yes I am
15:42:15 <diablo_rojo> I really hope it doesn't come down to just TheJulia and I.
15:42:21 <gmann> +1, good.
15:42:57 <gmann> diablo_rojo: so how you want to proceed, expecting gerrit reply from all 30 seems like difficult to happen.
15:43:45 <gmann> or you want to wait if majority or it reply and then discuss in TC if needed
15:44:10 <gmann> anything ok for me
15:44:12 <knikolla> diablo_rojo: i'm definitely interested, though I see a lot more value that this can bring on a OpenInfra / OpenDev level rather than just OpenStack :)
15:44:31 <diablo_rojo> gmann, I wasn't expecting ALL of them to reply there
15:44:40 <diablo_rojo> If I could get 3-5 even that would be great.
15:44:43 <gmann> knikolla: also please add your feedback in gerrit too
15:44:49 <gmann> sure
15:45:01 <knikolla> (make pizza in the next ops meeting contingent on a review there, haha)
15:45:02 <diablo_rojo> knikolla, I do too! I just think OpenStack is where the most knowledge is and so its a good place to start
15:45:31 <fungi> knikolla: i'm definitely interested in what ways you see the opendev collaboratory as getting involved
15:45:37 <gmann> diablo_rojo: let's wait then and we can add this topic again in TC meeting or i can keep it in agenda if you want
15:45:50 <diablo_rojo> I think we, as a project have a problem with starting too big with too much admin and redtape and process.
15:45:53 <fungi> since we're just consumers of infrastructure, i'm not sure where we fit, but happy to discuss after the meeting
15:46:04 <gmann> knikolla: this review #link https://review.opendev.org/c/openstack/governance-sigs/+/845336
15:46:28 <diablo_rojo> gmann, I can add the topic when we are at a place to discuss here again
15:46:33 <knikolla> fungi: sure, i'm happy to share a few rough ideas
15:46:35 <diablo_rojo> if you want to take it off the agenda for now
15:47:36 <gmann> diablo_rojo: thanks, I will keep it in next week at least and then remove if no progress so that we can add when  it is ready or so
15:47:44 <diablo_rojo> Okay.
15:47:55 <gmann> diablo_rojo: thanks
15:47:58 <gmann> #topic Open Reviews
15:48:05 <gmann> #link https://review.opendev.org/q/projects:openstack/governance+is:open
15:48:40 <gmann> I approved the tact sig patch
15:48:54 <gmann> other than that we have discussed most of them or all
15:49:09 <jungleboyj> \o/
15:49:14 <gmann> except this #link https://review.opendev.org/c/openstack/governance/+/836888
15:49:30 <gmann> jungleboyj: ^^ is it ready to review but still it is WIP
15:49:32 <jungleboyj> Yeah, that is blocked on me finishing that.
15:49:39 <jungleboyj> And looking at the comments.
15:49:46 <gmann> ohk.
15:50:02 <jungleboyj> I will carve out some time on that.
15:50:09 <gmann> jungleboyj: thanks
15:50:21 <gmann> not in agenda but good to point out here
15:51:08 <gmann> as most of you know, in board we are starting the openinfra project interaction on regular basis so that project and board know each other and discuss the updates/issues on regular basis
15:51:51 <gmann> apart from the OpenStack Updates in berlin board meeting, board is starting the next call and there will be more regular call in future
15:52:31 <diablo_rojo> 5th and 12th of July
15:52:32 <gmann> Board is communicating via foundation community manager to all the infra project including OpenStack, and you might have seen the email from fungi #link https://lists.openstack.org/pipermail/openstack-discuss/2022-June/029352.html
15:52:34 <opendevreview> Merged openstack/governance-sigs master: tact-sig: Simplify OpenSearch mention  https://review.opendev.org/c/openstack/governance-sigs/+/847017
15:52:53 <diablo_rojo> Err wait thats something else
15:52:55 <diablo_rojo> I think
15:52:56 <gmann> diablo_rojo: no that is separate call
15:52:58 <diablo_rojo> nvm
15:53:19 <gmann> that is board informal strategic discussion
15:53:40 <gmann> this is direct interaction with OpenStack and board
15:53:52 <gmann> from OpenStack side it can be TC memebrs as well as community members
15:54:11 <fungi> yeah, i picked the middle two weeks of august as options to give us some flexibility and time to coordinate schedules
15:54:14 <gmann> two action item for us:
15:54:27 <gmann> 1. vote on timing #link https://framadate.org/atdFRM8YeUtauSgC
15:54:46 <gmann> 2. add topic in etherpad #link https://etherpad.opendev.org/p/2022-08-board-openstack-sync
15:55:08 <gmann> tc-members: please do and asking the same in community member is already on ML
15:55:21 <fungi> my biggest concern with timing is that july and august are prime vacation/holiday time in europe, but i didn't want to put it off until september
15:55:39 <diablo_rojo> Oh to live in Europe :)
15:55:43 <gmann> I will add this as a separate topic in next week meeting so that we can finish both things to let board send the meeting details
15:55:47 <spotz> hehe
15:55:52 <knikolla> oh yeah, especially first 2 weeks of august.
15:56:02 <fungi> at least focusing on mid-week days we'll hopefully dodge weekend-adjacent holidays
15:56:27 <spotz> +1
15:56:30 <gmann> fungi: sooner is ok and we will continue the next call on regular basis so we may have another one later
15:56:48 <fungi> yes, the idea is to have one of these every few months
15:56:56 <dansmith> with only three votes we're already down to a pretty small window
15:57:04 <slaweq> fungi AFAIK in many countries 15th Aug is also bank holiday
15:57:29 <gmann> not every month exactly but we as Board want to be frequent based on how it goes
15:57:43 <fungi> slaweq: yep, i didn't include the 15th (it's a monday anyway)
15:57:46 <slaweq> e.g. in Red Hat we will also have Friday 12th Aug off (Recharge day) it's "tricky time" I would say
15:57:52 <jungleboyj> He he.  European Summer.  I have one co-worker leaving for 2 weeks.  Another for a month!
15:57:58 <gmann> let's add availability and based the availability we will discuss in next meeting if we want another date than proposed in poll
15:58:09 <slaweq> fungi I know, just saying :)
15:58:18 <fungi> same reason i skipped fridays ;)
15:58:27 <gmann> and from Board side, it will be all the board will attend this, it will be who all are interested will join
15:58:30 <jungleboyj> ++
15:58:49 <gmann> that is all from my side for today meeting. anything else?
15:58:53 <gmann> 2 min left though
15:59:15 <gmann> thanks fungi for sending it on ML
15:59:20 <fungi> yes, the hope is to have some tc members and some board members discuss things (and people taking notes and summarizing to the ml)
15:59:33 <gmann> let's close and reminder that next call will be video call on 7th July
15:59:39 <gmann> fungi: +1
15:59:51 <slaweq> \o
16:00:00 <gmann> thanks everyone for joining
16:00:04 <gmann> #endmeeting