15:00:28 <gmann> #startmeeting tc
15:00:28 <opendevmeet> Meeting started Thu Jul 14 15:00:28 2022 UTC and is due to finish in 60 minutes.  The chair is gmann. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:28 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:28 <opendevmeet> The meeting name has been set to 'tc'
15:00:33 <gmann> #topic Roll call
15:00:33 <spotz[m]> /o
15:00:38 <gmann> o/
15:01:03 <rosmaita> o/
15:01:04 <gmann> slaweq and arne_wiebalck informed about their absence in today meeting
15:01:26 <jungleboyj> I will be out next week, btw.  :-)
15:01:44 <dansmith> o/
15:01:58 <gmann> jungleboyj: ack
15:02:06 <gmann> let's start
15:02:08 <gmann> #link https://wiki.openstack.org/wiki/Meetings/TechnicalCommittee#Next_Meeting
15:02:20 <gmann> today agenda ^^ not much topic so may be it will be quick
15:02:32 <gmann> #topic Follow up on past action items
15:02:43 <gmann> rosmaita to send the email on openstack-discuss and community (local user groups ML) about asking who need translation
15:02:55 <rosmaita> yeah, still working on that
15:02:59 <knikolla> o/
15:03:05 <gmann> rosmaita: ack.
15:03:18 <rosmaita> i have some questions, will wait for open discussion
15:03:31 <gmann> rosmaita: ok sure
15:03:53 <gmann> gmann to ask about Adjutant maintainer on ML and start the next step of retirement or adding it in In-active project list.
15:04:01 <gmann> I sent and we have PTL volutneer also
15:04:02 <gmann> #link https://lists.openstack.org/pipermail/openstack-discuss/2022-July/029514.html
15:04:18 <gmann> #link https://review.opendev.org/c/openstack/governance/+/849606
15:05:01 <rosmaita> \o/
15:05:06 <gmann> please review the PTL nomination patch
15:05:12 <gmann> gmann to remove this(environmental SIG proposal) from agenda and we will check feedback on review or ML
15:05:15 <gmann> that is also done
15:05:36 <gmann> #topic Gate health check
15:05:57 <gmann> one update is about centos stream 9 testing stability
15:06:36 <gmann> centos stream maintainer joined our previous week meeting and we discussed few of the things, I sent the summary of discussion on ML #link https://lists.openstack.org/pipermail/openstack-discuss/2022-July/029468.html
15:07:44 <gmann> let's see if communication improve in both way but it was clear that we both community needs to debug the failure together, expecting centos stream alone doing that is difficult for them as per devstack/tempest and failure debugging knowledge
15:08:13 <gmann> not sure what else we can do on this then triage the failure at openstack side first and then report to them
15:08:47 <gmann> and when to make to voting as new issue can come at any time due to nature of latest version deps in centos stream
15:09:27 <dansmith> I think we just need to keep these periodic
15:09:30 <gmann> keeping it non voting make failure gets ignored and making it voting impact our development progress
15:09:57 <dansmith> unless they're going to change their workflow (which is the point of stream to begin with) I don't see how we can be voting on it
15:10:12 <gmann> yeah
15:10:18 <dansmith> even if they triage and fix bugs very quick, we can't stall pipelines for 24 hours, which is realistically about as fast as it could be
15:10:28 <gmann> I also think periodic is best possible way here
15:10:34 <gmann> true
15:11:07 <rosmaita> does anyone have an understanding of why ubuntu-based jobs are more stable than centos?
15:11:16 <dansmith> because the things they put in are tested
15:11:21 <gmann> in QA office hour and I am sure other projects also, we monitor periodic job results
15:11:21 <dansmith> stream things are not, that's the point
15:11:43 <gmann> yeah stream is kind of testing *next* things
15:11:55 <dansmith> we test on released ubuntu, which means it has been tested
15:12:20 <dansmith> stream is like testing on bare upstream trees for the most part
15:12:48 <jungleboyj> :-(
15:13:25 <rosmaita> i thought it was supposed to be "mostly tested"
15:13:34 <spotz[m]> We can definitely put out an invite but maybe with an idea of what time they’re needed
15:14:25 <dansmith> rosmaita: not that I know of.. at least one situation before came because they were putting things into stream *so* they could test them, not *because* they had tested it
15:14:28 <gmann> rosmaita: texsted at some level but not with all things deps latest version like openstack tested libvirt version
15:15:08 <rosmaita> so realistically, it doesn't seem like a suitable distro to use as the basis for our CI
15:15:09 <gmann> they put libvirt new version but how it will be working with OpenStack or any other usage is not well tested
15:15:11 <dansmith> "tested at some level" meaning it might have passed libvirt project testing, because it landed there
15:15:15 <dansmith> rosmaita: right that's my point
15:15:21 <gmann> yeah
15:15:57 <gmann> in that case we can test it periodic but keep it in our testing runtime so that we have python version testing at least which are compatible to them
15:16:42 <dansmith> right
15:16:47 <gmann> any objection of making it periodic with experimental pipeline(on demand run) ?
15:16:48 <rosmaita> well, periodic would be less waste of resources than having it nonvoting
15:16:53 <gmann> yeah
15:16:59 <rosmaita> but i don't know that anyone will pay attention to it
15:17:02 <dansmith> I also think periodic is less likely to be ignored than non-voting
15:17:04 <gmann> and we will have enough data for failure
15:17:09 <dansmith> nv failures are basically just waste, IMHO
15:17:12 <gmann> dansmith: true
15:17:37 <gmann> rosmaita: in QA we do monitor all periodic job in QA projects weekly basis
15:17:54 <jungleboyj> rosmaita:  That sounds like it might be a better approach then.
15:17:58 <gmann> I think many other project might be doing the same. but checking periodic jobs in weekly meeting is good way
15:18:07 <jungleboyj> ++
15:18:13 <dansmith> I think periodic also has more chance of being statistically stable, so noticing going from 95% pass to 100% fail is easier
15:18:25 <dansmith> n-v jobs failing can be because of the patch not being finished, etc
15:18:53 <gmann> yeah
15:19:03 <rosmaita> this sounds like a good plan to me, then
15:19:21 <jungleboyj> Makes sense to me.
15:19:41 <gmann> cool
15:20:14 <fungi> right, periodic jobs are testing changes which have already merged, so rules out broken changes (unless the changes themselves are suddenly introducing incompatibilities for centos)
15:21:00 <gmann> #agree to make centos stream jobs testing in periodic way but keep it in testing runtime. monitor, debug, and report the failure to centos stream team
15:21:21 <gmann> any other news on gate health ?
15:22:11 <rosmaita> gmann: you can make this change in the zed template?
15:22:49 <gmann> rosmaita: yeah, we can and remove it from non voting also which are in project side mostly
15:23:18 <gmann> we are not stopping testing but testing in a most feasible way
15:23:24 <rosmaita> right
15:23:28 <gmann> so should be ok to do change in zed cycle
15:23:36 <gmann> ok
15:24:09 <gmann> if nothing else, moving to next topic?
15:24:20 <gmann> #topic RBAC community-wide goal
15:24:23 <gmann> #link https://review.opendev.org/c/openstack/governance/+/847418
15:24:37 <gmann> patch is up, thanks dansmith rosmaita for review
15:24:56 <gmann> nothing else on this than other tc-members please review it as we are already late in zed cycle
15:25:16 <gmann> unless there is any question anyone want to discuss here
15:26:26 <gmann> ok moving next
15:26:46 <gmann> #topic Open Reviews
15:26:48 <gmann> #link https://review.opendev.org/q/projects:openstack/governance+is:open
15:27:13 <gmann> this is one patch to review other than we already discussed #link https://review.opendev.org/c/openstack/governance/+/849155
15:27:23 <gmann> adding skyline in emerging technology list
15:27:26 <gmann> that is all
15:27:38 <gmann> rosmaita: please go ahead on i18 SIG things
15:28:28 <rosmaita> oh, ok
15:28:50 <rosmaita> my question is whether anyone has a suggestion for a survey tool that is accessible in china
15:28:57 <rosmaita> or, whether that's not a concern
15:29:19 <rosmaita> i've used wufoo, but the free version is very limited
15:30:19 <gmann> no sure, may be we can ask ricolin about it
15:31:16 <rosmaita> ok, i will email him
15:31:23 <gmann> Open infra day asia might be good place to inform about that survey also. it is schedule on July 22-23. ricolin is one of the organizer of it
15:31:54 <rosmaita> thanks for that suggestion
15:32:15 <gmann> it include most of the group of asia which are/were using translation including this SIG mainatiner ianychoi[m]
15:33:03 <rosmaita> it's helpful to have a deadline
15:34:06 <gmann> may be if some usage data we can get within zed cycle so that in 2023.1 we can take some decision ?
15:35:09 <rosmaita> yep
15:35:53 <gmann> ok, anything else on this topic?
15:36:07 <rosmaita> nope
15:36:19 <gmann> ok, thanks rosmaita for working on it
15:36:27 <gmann> that is all from today meeting.
15:36:29 <rosmaita> np, now i will work faster
15:36:35 <gmann> thanks
15:36:53 <gmann> let's close the meeting. thanks all for joining
15:37:01 <gmann> #endmeeting