15:00:22 <slaweq> #startmeeting tc
15:00:22 <opendevmeet> Meeting started Thu Jul 21 15:00:22 2022 UTC and is due to finish in 60 minutes.  The chair is slaweq. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:22 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:22 <opendevmeet> The meeting name has been set to 'tc'
15:00:32 <slaweq> #topic Roll call
15:00:36 <slaweq> o/
15:00:36 <dansmith> o/
15:00:36 <knikolla> o/
15:01:30 <knikolla> (sorry i've not been that active the past 2 weeks. some unexpected things fell on my plate due to someone leaving)
15:01:59 <slaweq> I think we should wait few more minutes for quorum
15:02:24 <slaweq> gmann told me few days ago that his availability is tentative so he may not be here
15:02:43 <slaweq> but I don't know about others
15:03:16 <rosmaita> o/
15:03:39 <spotz_> o/
15:03:45 <spotz_> I'll be out next week
15:03:46 <slaweq> ok, lets start
15:03:56 <slaweq> agenda for today
15:03:57 <slaweq> #link https://wiki.openstack.org/wiki/Meetings/TechnicalCommittee#Next_Meeting
15:04:01 <diablo_rojo> o/
15:04:22 <slaweq> we don't have any follow up from the last week
15:04:31 <slaweq> so lets go directly to the gate health check
15:04:36 <slaweq> #topic Gate health check
15:05:04 <slaweq> any news about gate?
15:05:12 <dansmith> I don't have anything
15:05:51 <slaweq> regarding bare rechecks, I checked it today again
15:05:57 <slaweq> https://etherpad.opendev.org/p/recheck-weekly-summary
15:06:17 <slaweq> but as gthiemonge pointed in the mail, I need to update my script to check only last rechecks, not all of them
15:06:46 <slaweq> so those numbers still may not reflect properly state of the rechecks in last days as it includes older rechecks too
15:06:50 <rosmaita> so right now, it's a cumulative number?
15:06:55 <rosmaita> what you just said
15:07:13 <slaweq> rosmaita: yes, it takes patches which were updated in last X days but checks all "recheck" comments from them
15:07:27 <slaweq> also older than X days
15:07:27 <rosmaita> gotcha
15:08:21 <slaweq> if there is nothing else related to the gates, lets move on
15:08:26 <slaweq> #topic RBAC community-wide goal
15:08:33 <slaweq> #link https://review.opendev.org/c/openstack/governance/+/847418
15:08:53 <slaweq> I updated it today to address dansmith's and jay's comments
15:09:03 <slaweq> please review once again when You will have time
15:09:15 <dansmith> I saw, will circle back
15:09:15 <rosmaita> ack
15:09:41 <slaweq> thx
15:09:54 <slaweq> anything else regarding S-RBAC topic today?
15:12:39 <slaweq> ok, I guess it means "no" :)
15:12:45 <slaweq> so lets move to the next topic
15:13:10 <slaweq> #topic Question about copyright headers in files
15:13:18 <slaweq> rosmaita: it's your topic :)
15:13:22 <rosmaita> thanks
15:13:32 <rosmaita> to be clear, i am not trying to stir up any trouble
15:13:47 <rosmaita> the context is that there was a question on a gerrit review
15:14:05 <rosmaita> so i googled "openstack copyright statement in files" and got this:
15:14:14 <rosmaita> #link https://wiki.openstack.org/wiki/LegalIssuesFAQ
15:14:30 <rosmaita> as the top hit, so i imagine anyone in a similar situation will find that same page
15:14:45 <rosmaita> but as it's the wiki, it hasn't been updated in a while
15:15:05 <rosmaita> so I was wondering whether it's still accurate? or how i could even ascertain that
15:15:27 <dansmith> fwiw, that mostly lines up with what I've known as openstack's specific policy, which is "not that opinionated"
15:15:48 <dansmith> but typically copyright statements (or copyrights in general) need to be maintained when anything non-trivial is taken from a file
15:16:08 <dansmith> and people tend to add their copyright to the file when they contribute something non-trivial to that file
15:16:15 <rosmaita> it would be helpful to have a statement on the page saying "This is considered accurate as of <date>"
15:16:29 <rosmaita> (and someone would have to occasionally update <date>)
15:16:48 <rosmaita> but i don't know who is in a position to make that assertion
15:17:00 <slaweq> me neighter
15:17:07 <dansmith> is it necessary?
15:17:16 <rosmaita> i think so
15:17:24 <rosmaita> because the wiki is wildly out of date in places
15:17:26 <slaweq> but first question which come to my mind is about ML legal-discuss@lists.openstack.org - is it still valid?
15:17:27 <rosmaita> so you never know
15:17:57 <slaweq> if yes, maybe we should send that question there?
15:18:03 <spotz___> Might go to OIF
15:18:23 <rosmaita> archives end Dec 2019
15:18:36 <rosmaita> but that could just be because no one had any legal issues since then
15:18:52 <rosmaita> ok, i will take an action item to send my question to legal-discuss and see what happens
15:19:08 <slaweq> rosmaita thx
15:19:29 <rosmaita> ok, that's all from me
15:19:36 <slaweq> #action rosmaita to send question about https://wiki.openstack.org/wiki/LegalIssuesFAQ to the legal-discuss ML
15:19:56 <fungi> legal-discuss@lists.openstack.org does still exist, yes
15:20:01 <fungi> it's "very low-volume"
15:20:12 <rosmaita> apparently!
15:20:33 <fungi> also the LegalIssuesFAQ article still represents the current position, at least from the standpoint of the foundation's legal counsel
15:20:51 <fungi> though i've been thinking for a while we should probably move that into the project team guide
15:21:18 <fungi> i've just never found the spare time to do it myself
15:21:27 <rosmaita> i wasn't sure if it was already moved somewhere else, so good to know that's the definitive statement
15:21:58 <rosmaita> instead of sending an email, maybe i should put up a patch to the project-team-guide?
15:22:08 <slaweq> ++
15:22:27 <slaweq> if we have confirmation that it's still valid then IMO it's good idea
15:22:37 <rosmaita> ok, i'll do that and send a message to legal-discuss pointing people to the review
15:22:45 <slaweq> thx
15:22:50 <rosmaita> thanks fungi
15:22:51 <spotz___> ++
15:24:03 <fungi> yw
15:24:10 <slaweq> I think that we can move on to the last topic for today then
15:24:12 <slaweq> #topic Open Reviews
15:24:23 <slaweq> #link https://review.opendev.org/q/projects:openstack/governance+is:open
15:25:13 <slaweq> please review skyline as emerging technology proposal:
15:25:13 <slaweq> #link https://review.opendev.org/c/openstack/governance/+/849155
15:25:39 <slaweq> we already discussed about S-RBAC patch earlier
15:26:12 <slaweq> and other patches requires some work AFAICT
15:26:57 <slaweq> and that's all from me for today
15:27:06 <slaweq> any questions/comments about reviews?
15:27:19 <slaweq> or maybe do You have any other topics to discuss today?
15:28:46 <dansmith> end it!
15:28:50 <rosmaita> nothing from me
15:29:01 <slaweq> ok, thx for attending today
15:29:04 <diablo_rojo> Nothing from me
15:29:13 <slaweq> #endmeeting