15:00:10 <gmann> #startmeeting tc
15:00:10 <opendevmeet> Meeting started Thu Jul 28 15:00:10 2022 UTC and is due to finish in 60 minutes.  The chair is gmann. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:10 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:10 <opendevmeet> The meeting name has been set to 'tc'
15:00:20 <gmann> #topic Roll call
15:00:23 <gmann> o/
15:00:40 <dansmith> o/
15:00:41 <arne_wiebalck> o/
15:00:47 <knikolla> o/
15:01:08 <diablo_rojo_phone> o/
15:01:27 <gmann> In absence section for today meeting: rosmaita (will miss 28 July and 4 August)
15:02:27 <gmann> let's start
15:02:29 <gmann> #link https://wiki.openstack.org/wiki/Meetings/TechnicalCommittee
15:02:35 <gmann> today agenda ^^
15:02:51 <gmann> #topic Follow up on past action items
15:03:02 <gmann> there is one action item from previous meeting
15:03:03 <gmann> rosmaita to send question about https://wiki.openstack.org/wiki/LegalIssuesFAQ to the legal-discuss ML
15:03:20 <jungleboyj> o/
15:03:37 <slaweq> o/
15:04:12 <gmann> I saw brian added legal issue FAQ #link https://review.opendev.org/c/openstack/project-team-guide/+/850675
15:04:24 <gmann> slaweq is there anything else on this action item?
15:04:33 <slaweq> gmann: no
15:04:39 <gmann> cool
15:04:44 <slaweq> that was all AFAIR
15:04:56 <gmann> ok
15:05:00 <gmann> #topic Gate health check
15:05:14 <gmann> any news on gate health before we discuss the recheck data
15:05:22 <dansmith> nothing specific from me,
15:05:33 <dansmith> other than the move to remove stream from the voting jobs, which I think merged
15:05:39 <gmann> I have not monitored the gate much this week
15:05:43 <dansmith> same
15:05:46 <gmann> yeah that is merged
15:06:11 <gmann> Bare 'recheck' state
15:06:14 <gmann> #link https://etherpad.opendev.org/p/recheck-weekly-summary
15:06:18 <gmann> slaweq: go ahead
15:06:18 <slaweq> I sent new data today
15:06:40 <slaweq> and I fixed my script a bit so it just counts comments from the given period of time (7 days in my results)
15:06:42 <gmann> #link https://lists.openstack.org/pipermail/openstack-discuss/2022-July/029757.html
15:07:17 <slaweq> percentage are still pretty high in many projects
15:07:48 <slaweq> I tried to explain in the email about what are "bare" rechecks and what people can do to make less of them
15:07:56 <slaweq> lets see how it will be in the next weeks
15:08:11 <slaweq> if that will not improve, I will probably try to go to some team meetings to talk with people about it
15:08:19 <slaweq> and that's all from me
15:08:33 <gmann> +1, I think ML are helping to get some awareness
15:08:55 <slaweq> definitely
15:09:10 <gmann> thanks slaweq for collecting and sending it on ML
15:09:34 <gmann> anything else on the Gate health?
15:10:15 <slaweq> nothing from me
15:11:34 <gmann> #topic 2023.1 cycle PTG Planning
15:12:13 <gmann> as we know PTG for next cycle is planned as in-person event, we need to check who all are ok to travel and based on that we need to decide if we will have in-person PTG or virtual.
15:12:27 <gmann> many project like QA, Cinder decided to go for virtual PTG
15:13:03 <diablo_rojo> But there are also over a dozen projects signed up
15:13:13 <gmann> we as TC have three option 1. if many members are not traveling then we can conduct the virtual PTG 2. if majority of TC members are traveling then in-person PTG or 3 as hybrid PTG
15:13:13 <diablo_rojo> and we still have about 2 weeks till the team signup deadline
15:13:40 <gmann> sure, per project is project wise decision but we can decide TC PTG
15:14:26 <slaweq> I would like to go there but I don't know yet about if I will be able to
15:14:33 <slaweq> so it's hard to say now
15:14:45 <gmann> rosmaita pinged about if he can attend remotely, I think he is not planning to travel but will confirm from him
15:14:59 <jungleboyj> I would also be remote.
15:15:01 <arne_wiebalck> I will not travel
15:15:23 <jungleboyj> Especially if Cinder is keeping it virtual ...
15:15:29 <knikolla> I should be able to travel
15:15:39 <diablo_rojo> I will be there in person
15:18:12 <jungleboyj> Well that was a showstopper?
15:18:15 <gmann> ok, It seems 3 'not going' 2 'going' and 3 yet to decide/tentative ?
15:18:19 <diablo_rojo> Lol
15:18:22 <jungleboyj> :-)
15:18:24 <diablo_rojo> I have that kind of effect.
15:18:51 <gmann> should I out the poll to tc-members about virtual PTG or in-person ?
15:19:05 <diablo_rojo> I would just start an etherpad
15:19:07 <jungleboyj> gmann:  Probably a good idea.
15:19:08 <dansmith> I am not going
15:19:10 <gmann> and do we want hybrid PTG (in-person + virtual)? I think that will be difficult
15:19:40 <diablo_rojo> Something else to consider is I had been working on getting k8s Steering there in person to meet with us
15:19:51 <diablo_rojo> (they expressed interest at KubeCon EU)
15:20:01 <diablo_rojo> and KubeCon NA is the week after
15:20:46 <gmann> ok
15:21:06 <gmann> let me put poll from current situation it seems 4 members are not traveling at least
15:21:31 <diablo_rojo> I don't have confirmations from any of them yet, but I know there were two or three that were interested.
15:21:41 <gmann> #action gmann to start poll among tc-members whether to do in-person PTG or virutal PTG for TC
15:21:48 <gmann> ack
15:22:17 <TheJulia> Would the TC engage the community in person even if the whole of the TC doe snot meet in person?
15:22:42 <dansmith> snot?
15:22:55 <diablo_rojo> TheJulia: I would say yes? But can you elaborate?
15:22:55 <gmann> did not get?
15:23:11 <fungi> doe snot -> does not
15:23:23 <gmann> if TC decide the virtual PTG then any community member can attend it like any other virtual PTG
15:23:26 <TheJulia> My concern is if the TC does not explicitly meet in person, then there may end up being no reason percieved by some to attend, which begins to degrade reasoning for a PTG in general.
15:23:29 <jungleboyj> I like doe snot better.
15:23:50 <dansmith> TheJulia: are you asking me to travel against my will to be symbolic?
15:23:59 <diablo_rojo> TheJulia: ahhhh yes that makes sense.
15:24:16 <diablo_rojo> dansmith: no she's not- just that the people that do attend in person meet there
15:24:22 <diablo_rojo> which I agree should happen
15:24:28 <gmann> TheJulia: there is some concern from community member on decision on in-person PTG where community was not involved to get feedbck
15:24:32 <TheJulia> dansmith: no, but I'm asking for the TC to be willing to engage. I think we all know not everyone can or will be able to make it, we just can't completely disregard the need for engagement
15:24:47 <diablo_rojo> particularly if we have k8s members attending.
15:24:55 <gmann> engagement can be done virtually also
15:25:01 <diablo_rojo> TheJulia: +2
15:25:11 <TheJulia> gmann: but then are we risking creating two entirely different events?
15:25:13 <gmann> like we were doing now a days
15:25:15 <dansmith> meh, I think having a fraction of the TC meeting there in person "just because" is not very useful
15:25:32 <gmann> TheJulia: that is the risk as many project already decided to go for virtual PTG
15:25:42 <dansmith> if the majority are not going, then fully virtual makes more sense to me, especially since anyone can attend that, whether on-site ornot
15:25:44 <TheJulia> I'm not saying the TC *has* to meet in person there, just that there needs to be some level of engagement
15:26:31 <gmann> agree, but by seeing the situation of travel and so, it is hard to except all engagement in-person.
15:26:35 <dansmith> so some sort of office hours then?
15:26:37 <gmann> *expect
15:26:38 <diablo_rojo> I agree.
15:26:43 <diablo_rojo> dansmith: yeah thats what I was thinking
15:26:50 <TheJulia> dansmith: that is a great idea
15:26:50 <knikolla> But what about Karaoke nights by the piano?
15:27:02 <gmann> yeah, like QA decided to have virtual PTG after checking conflict time with other group in in-person event
15:27:05 <diablo_rojo> gmann: she isn't expecting that every TC member go.
15:27:07 <jungleboyj> dansmith:  Ok.  That makes sense.
15:27:08 <knikolla> I agree that there needs to be some level of engagement, and office hours seems like a good way to go about it.
15:27:08 <TheJulia> knikolla: also a possibility, although some of us... myself included will run from karaoke :)
15:27:30 <diablo_rojo> Just that something in person needs to happen for the folks that decide that they will be there physically.
15:27:53 <TheJulia> ++++++++ ^ $hugenumber
15:28:12 <dansmith> I don't agree that it's necessary, but as long as it's in addition to any sort of meeting (if we decide to be virtual), then meh
15:28:26 <jungleboyj> ++
15:28:39 <gmann> so usual PTG discussion topic virtually where most of TC and community members can attend + in-person members office hour for general engagement ?
15:28:42 <diablo_rojo> Yes it would be in addition I would thing because if we dont have critical mass, we can't have the conversations.
15:29:07 <dansmith> gmann: sounds like that yeah
15:29:11 <diablo_rojo> gmann: depending on the result of the poll to TC members, yes.
15:29:18 <slaweq> diablo_rojo: +1
15:29:35 <diablo_rojo> I dont think we should just decide virtual here and now when not everyone is present.
15:29:39 <gmann> let's wait for the poll
15:29:39 <knikolla> It's a tough balancing act. The informality and organic engagement that in-person brings is almost impossible to recreate virtually, and I don't want to see it disappear.
15:30:13 <TheJulia> knikolla: ++
15:30:15 <diablo_rojo> knikolla: +2, there is a trust and a openness and sense of community that we get from meeting in person that you cannot get from virtual stuff.
15:30:26 <dansmith> but you know what works against that?
15:30:30 <gmann> knikolla: agree but travel for everyone is also difficult things
15:30:34 <dansmith> people who can't travel being excluded from that
15:30:46 <diablo_rojo> I think we have a lot more disagreements and struggle over little details and nitpicking these days because we havent all been able to meet in person, together, as a community in so long.
15:31:10 <TheJulia> Then you create informal engagement to replicate. Coffee time or *whateveR*
15:31:14 <gmann> but I think there are valid reason not to travel
15:31:14 <diablo_rojo> dansmith: which is why we wouldnt do the main PTG discussions at the PTG if we didnt have critical mass
15:31:18 <TheJulia> err, s/eR/er/
15:31:20 <dansmith> diablo_rojo: really? I have the opposite impression.. I feel like we're meeting high-bandwidth virtually much more often than we did before when we would just "meh, punt to ptg"
15:31:42 <knikolla> Someone is going to feel left out in the end, even virtually. It's tough to balance, and I don't have a clear answer.
15:31:51 <diablo_rojo> dansmith: There are a number of teams that still do that- punt to the PTG.
15:31:57 <diablo_rojo> knikolla: cause timezones :)
15:31:58 <gmann> if not PTG discussion in PTG then what is that event for?
15:32:14 <TheJulia> community building
15:32:24 <dansmith> diablo_rojo: sure, I'm just saying overall, I feel like the teams I'm involved with are doing virtual face-to-face meetings much more often now, to resolve tough things
15:32:36 <knikolla> diablo_rojo: not even just timezones. I and a lot of other people struggle to speak up in Zoom meetings because of the inability to have parallel conversations.
15:32:41 <gmann> then we should rename it for better communicating the agenda of the event
15:33:46 <gmann> I do not think anyone against of straying in-person but it seem people cannot travel due to pandemic (which is still there) or any other valid reason are not considered .
15:33:51 <gmann> and that is community member feedback too
15:34:24 <gmann> I feel we should consider the majority and then decide if in-person or virtual PTG as overall
15:34:44 <gmann> at least PTG which is developer/community-mmebers event
15:35:07 <spotz_> Hey all sorry I'm a bit late but I'm finally meeting my team at RH
15:35:35 <gmann> anyways, I will put the poll for this and we will see how it goes and we can continue the discussion in next meeting too.
15:35:49 <gmann> which is for TC PTG things.
15:35:50 <spotz_> Reading back through this there is value in virtual to include more people but at the same time I wouldn't change this week for anything. The connections and the conversations
15:35:55 <jungleboyj> spotz_: Saw that.  That is great!
15:35:59 <gmann> project PTG planning is as per project team.
15:36:57 <gmann> diablo_rojo: may be to get the actual situation, there should be signup for virtual PTG, that way we  can get to know how many projects going for virtual PTG and how many for in-person ?
15:36:58 <diablo_rojo> Building community is secondary to the technical discussions
15:37:02 <diablo_rojo> but just as important.
15:37:33 <TheJulia> Community leadership is also just as important as building and technical agreement.
15:37:34 <gmann> I think currently we are asking only signup for in-person PTG?
15:38:15 <knikolla> TheJulia: ++
15:39:00 <fungi> i don't think a virtual ptg should happen at the same time as an in-person ptg since the time constraints will be vastly different, but having virtual ptg sessions the week before or the week after might make sense
15:39:21 <gmann> yeah it should be planned week before or after
15:39:23 <TheJulia> fungi: ++
15:39:32 <spotz_> ++
15:40:04 <gmann> anything else on PTG?
15:40:09 <fungi> also the flexibility for virtual sessions is much greater, since we're not limited by the number of meeting rooms a particular venue provides, can have sessions at different times of day to accommodate people in other timezones, and so on
15:40:11 <jungleboyj> fungi: Good thinking.
15:40:37 <fungi> so planning isn't as urgent to have done farther in advance
15:40:42 <spotz_> I know from CentOS we're talking having both in-person and virtual events through the year
15:41:43 <gmann> yeah, first we need to get data hw many project are not going in-person and how many going, based on that we can plan virtual one
15:43:00 <gmann> moving next
15:43:06 <gmann> #topic RBAC community-wide goal
15:43:46 <gmann> nothing else to discuss on this except if you want to review the proposed update in goal if not yet done #link https://review.opendev.org/c/openstack/governance/+/847418
15:44:20 <gmann> #topic Open Reviews
15:44:25 <gmann> #link https://review.opendev.org/q/projects:openstack/governance+is:open
15:45:14 <gmann> i checked and most of the open review are in good shape, means voted already or waiting for deps/author action
15:45:33 <gmann> that is all for today meeting from agenda. anything else to discuss ?
15:46:39 <gmann> ok, if nothing else let's close today meeting
15:46:43 <gmann> thanks everyone for joining
15:46:50 <gmann> #endmeeting