15:00:56 <gmann> #startmeeting tc
15:00:56 <opendevmeet> Meeting started Thu Aug 11 15:00:56 2022 UTC and is due to finish in 60 minutes.  The chair is gmann. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:56 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:56 <opendevmeet> The meeting name has been set to 'tc'
15:01:00 <knikolla> o/
15:01:06 <rosmaita> o/
15:01:06 <gmann> #topic Roll call
15:01:08 <gmann> o/
15:01:11 <spotz> o/
15:01:12 <diablo_rojo> o/
15:01:36 <gmann> In absence section:
15:01:38 <gmann> arne_wiebalck (will miss 4 August and 11 August)
15:01:43 <gmann> slaweq (will miss 11 August)
15:01:49 <gmann> Jay Bryant (jungleboyj) -- Will miss 8/11 due to Out of Office
15:01:54 <dansmith> o/
15:02:13 <gmann> let's start
15:02:24 <gmann> #link https://wiki.openstack.org/wiki/Meetings/TechnicalCommittee#Agenda_Suggestions
15:02:27 <gmann> ^^ today agenda
15:02:34 <gmann> #topic Follow up on past action items
15:02:57 <gmann> no action item from previous meeting
15:03:08 <gmann> #topic Gate health check
15:03:21 <gmann> any news on gate health ?
15:03:56 <gmann> I have not noticed any frequent failure this week
15:04:31 <gmann> dansmith: rosmaita did you? or anyone else
15:04:45 <dansmith> nope, haven't noticed any major problems this week
15:05:05 <rosmaita> we got hit by the update to flake8-logging-format, but fixed it
15:05:23 <rosmaita> not sure a lot of people use that extension
15:06:12 <gmann> rosmaita: may be we should pin them in hacking, I remember we faced some flake8 extensions issue in past too
15:06:20 <gmann> but good to know it is fixed
15:07:01 <rosmaita> it just hit the cinder pep8 jobs in most branches
15:07:19 <gmann> ok
15:07:54 <gmann> we can see if any extension is frequently causing failure on updates then we have option to pin it in hacking
15:08:22 <rosmaita> ok
15:08:39 <gmann> bare recheck
15:08:40 <gmann> #link https://etherpad.opendev.org/p/recheck-weekly-summary
15:09:17 <gmann> slaweq is not present today. we can skip it unless anyone else want to discuss someting on it?
15:10:17 <gmann> #topic 2023.1 cycle PTG Planning
15:10:33 <gmann> As we all know that Oct PTG is not virutal.
15:11:08 <fungi> is now virtual
15:11:08 <gmann> there will be some update from diablo_rojo or someone from foundation on team/slot signup things?
15:11:18 <gmann> sorry s/not/now :)
15:11:33 <diablo_rojo> Yes.
15:11:40 <gmann> diablo_rojo: thanks.
15:11:52 <diablo_rojo> Essentially I just updated the survey
15:11:52 <gmann> let's wait for that to start the TC PTG planning
15:11:55 <diablo_rojo> You can use the same link
15:12:02 <diablo_rojo> as before
15:12:11 <diablo_rojo> Deadline is the 26th
15:12:39 <gmann> diablo_rojo: ok, but it will be good to send in on ML as projects also wanted to get more clarity that old team signup is needed or new one will come
15:12:53 <gmann> at least that is what QA team was waiting.
15:13:07 <diablo_rojo> Yes, I plan to do that, but I figured since I was here you can go ahead for TC
15:13:10 <diablo_rojo> and now QA
15:13:33 <gmann> +1, cool
15:14:00 <gmann> #action gmann to fill PTG survey and team signup for TC discussions
15:14:03 <spotz> Yeah I'm not sure I signed up D&I so maybe a mail of who's signed up already?
15:14:37 <diablo_rojo> It is signed up already
15:14:40 <gmann> I think we should ask eveyrone to signup again and ignore the old data as that signup was as per in-person meeting
15:14:44 <diablo_rojo> I think with you as the modderator spotz
15:14:47 <spotz> Sweet thanks:)
15:14:54 <fungi> yeah, the original deadline was tomorrow so i had put off signing up the security and tact sigs because i procrastinate
15:15:04 <fungi> sorry diablo_rojo!
15:15:16 <diablo_rojo> gmann: I contacted all of the people that had signed up already to confirm their signups were still valid. Its been handled.
15:15:26 <gmann> and total attendance in survey or any other answer might be different for virtual PTG
15:15:30 <diablo_rojo> Please just use the same formstack survey to say if the team wants to attend.
15:16:59 <gmann> ok if old data still valid for virtual PTG then ok
15:17:38 <gmann> in yesterday call with Board members, one idea came up to include more operators and ops interaction in PTG.
15:18:32 <gmann> idea is that project should plan a 'operator hours' slot in PTG where we can have operator to discuss about feedback etc.
15:18:47 <gmann> as TC we should encourage projects to schedule 'operator hours' as a separate slot in PTG
15:19:10 <gmann> and those 'operator hours' per project should avoid conflicts among other projects 'operator hours' slot
15:19:17 <diablo_rojo> And that it would be good being coordinated by the TC as an invitation to operators. A show of good faith.
15:19:23 <spotz> Once we have a schedule for that I can send out via OPS Meetup twitter
15:19:33 <gmann> thanks
15:19:49 <diablo_rojo> spotz: that would be super helpful- I think we are a ways from that, but definitely good to keep in mind!
15:20:06 <gmann> once we will have slot booking open, we will send this on ML and to PTL
15:20:56 <gmann> anything else on PTG planning ?
15:21:06 <rosmaita> i think we (or someone) need to propose what slots should be used by projects for operators
15:21:15 <rosmaita> so that we don't all schedule the same time
15:21:20 <spotz> hehe
15:21:27 <gmann> rosmaita: yeah, we need to take care of the conflict
15:21:54 <diablo_rojo> rosmaita: Yeah I guess I am just imagining an etherpad that the TC puts together with a list of slots available each day and the projects signup for them?
15:22:09 <diablo_rojo> That way the TC can keep an eye on it.
15:22:14 <rosmaita> i was thinking that maybe we suggest for the "dirty six" and the other projects that already expressed interest to diablo_rojo have a time they can use if they want
15:22:26 <gmann> how about asking projects to use Monday or Tuesday to use the operators hours ? those are the day most of the projects are not having their project specific slots
15:22:43 <diablo_rojo> LOL
15:22:44 <diablo_rojo> "dirty six"?
15:23:00 <rosmaita> thats what mugsy calls the primary projects
15:23:07 <gmann> any other day Wed to Friday is difficult to avoid conflict
15:24:01 <diablo_rojo> gmann: sure, in that case- since the schedule will be the same as the other virutal PTGS- someone can setup the etherpad right now
15:24:49 <rosmaita> i thought the idea was to use project specific slots so that the operators can meet with the dev team?
15:24:57 <spotz> I might be a little in and out on Monday but then around the rest of the week
15:25:33 <gmann> rosmaita: yes, I mean giving at least one project specific slot on Monday or Tuesday where developers will be there. but if any other day work for project that is all ok
15:26:13 <gmann> anyways let's have slot open and I will put this on ML and also to avoid conflict. and how project book then we can discuss if any conflcit
15:27:28 <gmann> we were pretty good for cross project sessions in virtual PTG so the operator hours can also be arranged in coordinated way. like nova has operator hours at 10 AM wed so neutron can plan it some other time
15:27:34 <dansmith> gmann: we should try to spread things out I think,
15:27:59 <dansmith> so that there's a potential for all those projects to have a non-overlapping ops slot
15:28:11 <rosmaita> dansmith: ++
15:28:18 <diablo_rojo> rosmaita: thats my thought too, but I think gmann wants to push them to the front of the week
15:28:18 <gmann> yeah
15:28:45 <dansmith> maybe in the schedule, we could reserve two slots per day as "for ops" and have projects sign up for one?
15:28:48 <gmann> diablo_rojo: that was one idea but I think if TC can prebooked slot on every day and then project can choose them
15:29:00 <diablo_rojo> I don't really care one way or the other about when they happen- we just need visibility as to when they are going to happen and to avoid collisions
15:29:02 <gmann> dansmith: yeah, indeed
15:29:08 <dansmith> I think specializing days of the week (as we have in the past) is less good,
15:29:18 <dansmith> because it ends up stacking similar things on fewer days
15:29:26 <gmann> sure
15:29:32 <rosmaita> i guess it could work either day, have ops day and each team comes for "nova time', "cinder time" , etc. or spread them out and have "ops time" at nova, "ops time" at cinder, etc
15:29:42 <rosmaita> i mean "work either way"
15:29:53 <diablo_rojo> gmann: but then the schedule will say 'TC' every day and not just the project name?
15:30:04 <dansmith> rosmaita: makes it pretty intense for ops for that day
15:30:14 <dansmith> but maybe they'd prefer that I dunno
15:30:16 <gmann> diablo_rojo: no, we can do what dansmith suggesting 'for ops' and ask project to fill it
15:30:20 <rosmaita> yeah, not sure
15:30:29 <dansmith> and if days are only four hours long, then that makes it pretty small slots for more than a few projects
15:31:02 <diablo_rojo> So the openstack service teams are going to go to the ops space then? and not the other way around?
15:31:13 <gmann> I think reserving 2 slot per day should work. so at least 8-10 slots
15:31:18 <dansmith> gmann: ++
15:31:31 <dansmith> diablo_rojo: I would expect the ops hour for nova to be in nova's "room" no?
15:31:36 <rosmaita> ok, so ops teams would come to the dev team rooms
15:31:42 <dansmith> especially if we're trying to encourage the pattern of ops coming to dev things
15:31:49 <gmann> yeah
15:31:50 <rosmaita> dansmith: ++
15:31:54 <diablo_rojo> dansmith: thats what I was thinking
15:31:54 <knikolla> i think it might be easier to bring the dev teams to the ops room, than bring the ops to the teams room
15:32:02 <TheJulia> maybe going to the ops is better symbol of collaboration
15:32:04 <diablo_rojo> The operators would join the nova team or whomever
15:32:05 <knikolla> considering the ops will have to switch rooms every other hour
15:32:21 <TheJulia> s/is/is a/
15:32:33 <diablo_rojo> knikolla: especially since they arent as used to the whole virtual ptg thing?
15:32:37 <diablo_rojo> Not as practiced anyway
15:32:50 <diablo_rojo> TheJulia: +2
15:32:53 <TheJulia> Yeah, that would be a concern is getting lost and giving up
15:33:07 <gmann> switching room in zoom is not that hard
15:33:16 <dansmith> yeah, I mean.. come on :)
15:33:20 <knikolla> it is an active action
15:33:21 <TheJulia> for someone with the context of doing so every so often
15:33:32 <gmann> knikolla: just one times in a day
15:33:35 <knikolla> going to their room will allow passive participants to also participate
15:33:46 <TheJulia> knikolla++
15:34:12 <diablo_rojo> gmann: but using the bot and discovering the rooms might be a higher barrier to entry then they are familiar with
15:34:15 <gmann> I think for virtual PTG, it is less concern about what room is for what. project also switch room many times
15:34:17 <dansmith> knikolla: same argument works the other way right? ops get exposed to more than just the few devs that are going over to hear the ops?
15:34:18 <diablo_rojo> Since it will effectively be their first virtual PTG
15:34:37 <knikolla> i imagine the dev group is smaller and more tightly knit.
15:34:39 <gmann> diablo_rojo: humm, it is not that hard to learn :)
15:35:04 <diablo_rojo> gmann: its not, but we also have the luxury of having done it several times at this point.
15:35:37 <diablo_rojo> Just being devil's advocate.
15:35:38 <dansmith> I dunno, if we're trying to encourage the ops to feel welcome in dev-centric things in the future (like when we are in person) it seems like inviting them into the dev rooms when the bar is low sets the right tone
15:35:58 <gmann> yeah that is what my impression is.
15:36:08 <fungi> discovering rooms should hopefully not be that hard regardless of virtual or physical, we publish it to a web page anyway
15:36:17 <dansmith> obviously if clicking on a different zoom link is so onerous that it won't happen, then it's not that important, but I thought from the call that we're trying to mechanically connect *and* set the right tone
15:36:18 <knikolla> making them feel as guests vs. them running the show
15:36:23 <dansmith> that they are "part of the team"
15:36:24 <gmann> I think  we are over thinking  for them :)
15:36:32 <diablo_rojo> I do think it would be good to get the operators exposure to as many people in all the teams as possible and the best route, optimizing for that- is to get them into the services rooms
15:36:38 <TheJulia> they don't see the bar as low though, they see it as tight knit and in some cases impervious to their context
15:36:38 <dansmith> knikolla: we discussed on the call them still running the hour, I don't think they need to be in their own room to drive the agenda
15:36:44 <diablo_rojo> gmann: quite possibly
15:36:46 <gmann> they might be saying yes it is all good
15:36:56 <diablo_rojo> TheJulia: +2
15:37:10 <TheJulia> We need to build mutual context, so anything where we expect people to already have context is not easy and is just creating barriers
15:37:15 <dansmith> TheJulia: by a low bar I meant "clicking on a zoom link" versus "fly to a site, walk into a room full of people they don't know"
15:37:38 <diablo_rojo> dansmith: except the in person format is what they are used to, so that is easier for them
15:37:46 <gmann> spotz: can you check with them if switching zoom room once or twice in a day is barrier for them to join PTG ?
15:37:50 <TheJulia> still a room full of people they don't know at the end of the day
15:37:56 <dansmith> diablo_rojo: you really have a low opinion of these people it seems :)
15:38:01 <diablo_rojo> the ptgbot site and having to play a zoom hop game is not anything like what they have done before.
15:38:10 <diablo_rojo> dansmith: not at all
15:38:35 <spotz> gmann Yeah I can't think it would be especially if we're not one on top of the other. If we are I'd think it makes sense to just use one main one
15:38:36 <gmann> we can ping them the zoom link in IRC or in ML and they just join it like any ohter meeting they join
15:38:39 <dansmith> but whatever, the important part is the collab. if "which zoom link I clicked on" defines who's "turf" it is, then we might be in more trouble than I thought
15:38:54 <diablo_rojo> I just have the context of having actually been to meetups before and also having seen new teams come into the virtual PTG and struggle with the PTGbot interface + irc
15:38:56 <gmann> spotz: ok, conflict we will avoid for sure
15:39:10 <knikolla> at least to me, it's more of a psychological barrier. i have avoided going into places where i have no shared context / not know a lot of people. and when i do, i tend not to speak up.
15:39:28 <TheJulia> knikolla: exactly
15:39:30 <diablo_rojo> because if they aren't used to using IRC regularly, the bot, while well documented and clear in my opinion, is not super easy.
15:39:31 <knikolla> i have found that to extend to zoom meetings as well.
15:39:34 <dansmith> knikolla: that's part of the thing we're trying to break down for the future right?
15:39:35 <diablo_rojo> knikolla: +2
15:39:38 <gmann> knikolla: idea is to improve such interaction and knwoing peoplr
15:39:46 <dansmith> ops staying corralled in their own place and then simultaneously feeling left out?
15:40:19 <gmann> we are trying to make PTG for them same as ops meetup, you are a separate entity and separate room/people....
15:40:28 <dansmith> right
15:40:54 <gmann> as spotz mentioned it is not issue for most of them I think we should try to welcome them in developers room and see how it goes
15:40:57 <spotz> They should be welcome and invited everywhere, but if we have back to back meetings it just makes sense to have a set room folks go to. Kinda like in Speed Mentoring it's quicker for a mentor to change tables then all the mentees
15:41:11 <TheJulia> It goes back to what knikolla said. We need to build shared context and trust first
15:41:16 <dansmith> spotz: they wouldn't be back to back though.. two slots per day
15:41:36 <spotz> dansmith: Ahh then yeah they can open a new zoom when the time comes:)
15:42:04 <knikolla> let's ask them what would they prefer.
15:42:11 <gmann> yeah, that way they feel like yes 'we attended developers meeting and it was all easy and good, we will talk more with them'
15:42:13 <TheJulia> knikolla: +2
15:42:16 <dansmith> let's please just move on.. we've argued about who owns which zoom turf for a lot of the meeting.. if its critical that we show up to the ops rooms, then fine. I think it doesn't progress us towards a better situation in the future,
15:42:22 <gmann> ok.
15:42:24 <fungi> also if there are back-to-back nova+ops and nova meetings, but also back-to-back nova+ops and cinder+ops meetings, someone's room-hopping either way
15:42:26 <dansmith> but neither does this conversation :)
15:42:34 <gmann> spotz: can you check with them on ML or someway how they prefer?
15:42:38 <diablo_rojo> So theoretical question: Nova and Cinder are going to meet at the vPTG, how do you decide who goes where?
15:42:52 <rosmaita> the ptls fight it out
15:43:03 <diablo_rojo> rosmaita: I would like to see that
15:43:07 <TheJulia> rosmaita: this is a t-shirt opportunity
15:43:07 <fungi> two teams enter, one team leaves
15:43:07 <dansmith> diablo_rojo: yeah we don't argue
15:43:15 <rosmaita> it usually depends on who is recording
15:43:16 <spotz> gmann Yeah just let me know secifically what the ask is. Changing Zoom rooms, back to back vs non-back to back meetings?
15:43:21 <dansmith> nor do we consider it to be either one's turf when we switch :)
15:43:36 <rosmaita> anyway, we can schedule the times for ops/teams meetings and decide later on where
15:43:37 <TheJulia> fungi: two teams enter the collaboration-atron
15:43:41 <gmann> spotz: I think we are (like any other discussion) interpreting them in all differnet way, and we really need few of them to talk for what they want/like
15:44:02 <spotz> Ok I'll do and email and a twitter poll
15:44:47 <gmann> spotz: basically two option 1. join ops hours in the project PTG room and meet/discuss with developer 2. book ops slot in same room/day and ask developer to come to that room and discuss the things
15:45:06 <dansmith> TBH, I'm less interested in a poll or asking them, because what we're trying to do is draw them out of their shell(s)
15:45:12 <dansmith> you don't ask a hermit if they want to go outside,
15:45:24 <dansmith> you show up outside with ice cream and try to lure them into the sunlight :)
15:45:25 <diablo_rojo> Also, I would like to just point out how much of a struggle organizing anything is because all of our teams are SO different, so, in the future please remember this conversation when something about how things are organized isnt exactly perfect for everyone :)
15:45:38 <diablo_rojo> (getting meta for a moment :) )
15:45:41 <rosmaita> dansmith: that sounds like another t-shirt opportunity
15:45:45 <gmann> dansmith: agree but I am seeing lot of different voice on their behalf so it is good to ask them directly
15:45:52 <spotz> Ice cream!
15:46:07 <gmann> spotz: adding action item for you
15:46:08 <dansmith> see, I just got spotz' attention with ice cream. it works.
15:46:10 <diablo_rojo> dansmith: so thats what we need to do for you? :D
15:46:16 <TheJulia> dansmith: "yes, we'll fix that bug" might work better :)
15:46:24 <TheJulia> At least, virtually :)
15:46:41 <spotz> I think some of the main feedback from Berlin was that just sending 1 OPS wasn't helpful as they're all different in their needs. I think as long as we minimize crossover sessions we'll be ok
15:46:54 <dansmith> TheJulia: yeah, its just as black and white as all these bugs that are straightforward but we don't fix because we're evil right? :)
15:47:08 <gmann> #action spotz to check with operators about what format they want in virtual PTG. options: 1. join ops hours in the project PTG room and meet/discuss with developer 2. book ops slot in same room/day and ask developer to come to that room and discuss the things
15:47:28 <gmann> anything else on PTG things than the ops slot format?
15:47:50 <gmann> based on what spotz finds out, we will discuss and finalize it next meeting
15:48:01 <TheJulia> dansmith: eh... I've always kind of let the harder opinions roll off my shoulders as I've tried to build mutual context.
15:48:21 <TheJulia> dansmith: but that doesn't prevent us from humming "when your evil" in the background...
15:48:23 <diablo_rojo> I would also make sure, spotz, that they know that even if they go to the projects meeting rooms, they can also still have their own dedicated time and space
15:48:40 <TheJulia> diablo_rojo: ++
15:48:42 <spotz> Yeah I'll frame it for the Dev/ops interactions
15:48:45 <gmann> diablo_rojo: yes, and even they can be moderator if they want
15:48:48 <diablo_rojo> Just because they pick option 1, doesn't preculde them from having their own track in addition
15:49:00 <gmann> but joining developers room will improve the interaction to community
15:49:03 <diablo_rojo> gmann: correct.
15:49:12 <diablo_rojo> +2
15:49:26 <spotz> Yep which is why we were hoping ops folks would come for the whole week
15:49:26 <dansmith> spotz: when you poll,
15:49:45 <gmann> spotz: yes
15:49:45 <dansmith> you might say that the developers want more ops interactions *in their project rooms* in general
15:50:02 <spotz> Yep
15:50:14 <gmann> +1
15:50:16 <diablo_rojo> spotz: happy to help with phrasing
15:50:39 <spotz> ok I'll run it by you before posting diablo_rojo most likely later today
15:50:50 <diablo_rojo> spotz: sounds good- I'm around :_)
15:50:52 <diablo_rojo> :)
15:51:12 <gmann> spotz: if you would like, you can add the sentence in etherpad also in case we miss anything ? but up to you
15:51:47 <gmann> let's move to the next topic
15:51:51 <spotz> ok
15:51:55 <gmann> thanks
15:51:57 <gmann> #topic Open Reviews
15:52:05 <gmann> #link https://review.opendev.org/q/projects:openstack/governance+is:open
15:52:32 <gmann> need one more review in the python testing template update #link https://review.opendev.org/c/openstack/governance/+/852463
15:53:38 <gmann> other than that, diablo_rojo any consensus on 'Environmental Sustainability SIG' ? #link https://review.opendev.org/c/openstack/governance-sigs/+/845336
15:53:54 <diablo_rojo> We are moving forward being a foundation level wg
15:54:04 <diablo_rojo> I just need to abandon the patch and put other things in motion
15:54:18 <gmann> diablo_rojo: ok, thanks for the updates.
15:54:21 <fungi> will there be a ptg session?
15:54:24 <diablo_rojo> No problem
15:54:32 <diablo_rojo> fungi: I certainly hope so :)
15:54:37 <fungi> thanks!
15:54:44 <gmann> other than that all other reviews are in good shape, either waiting for author or deps
15:54:59 <rosmaita> also, don't forget this patch that's not in that search:
15:54:59 <rosmaita> #link https://review.opendev.org/c/openstack/project-team-guide/+/850675
15:55:20 <gmann> rosmaita: ack. thanks
15:55:26 <gmann> that is all from agenda today, we have ~5 min left. anything else to discuss ?
15:55:48 <rosmaita> gmann: for https://review.opendev.org/c/openstack/governance/+/852463 , do we do rollcall or code-review on that?
15:55:56 <fungi> rosmaita: i suppose we could approve 850675 but at the moment it's only got +2 votes from foundation staff, which is probably why it hasn't been yet
15:56:08 <rosmaita> oh, ok
15:56:17 <gmann> rosmaita: rollcall is fine
15:56:35 <gmann> I will review the 850675 today
15:57:22 <gmann> fungi: as you are here, please check this project-config change needed for openstack-helm-addons retirement  #link https://review.opendev.org/c/openstack/project-config/+/851857
15:58:03 <gmann> that is all for today, thanks everyone for joining.
15:58:03 <fungi> thanks
15:58:07 <gmann> #endmeeting