15:00:16 <gmann> #startmeeting tc
15:00:16 <opendevmeet> Meeting started Thu Aug 25 15:00:16 2022 UTC and is due to finish in 60 minutes.  The chair is gmann. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:16 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:16 <opendevmeet> The meeting name has been set to 'tc'
15:00:23 <gmann> #topic Roll call
15:00:24 <knikolla> o/
15:00:25 <gmann> o/
15:00:54 <spotz> o/
15:01:20 <rosmaita> o/
15:01:20 <slaweq> o/
15:01:35 <jungleboyj> o/
15:01:43 * slaweq will need to drop in about 30 minutes
15:02:57 <gmann> diablo_rojo_phone: dansmith arne_wiebalck ping, in case you missed the meeting timing
15:02:59 <gmann> let's start
15:03:07 <gmann> #link https://wiki.openstack.org/wiki/Meetings/TechnicalCommittee#Agenda_Suggestions
15:03:13 <dansmith> o/
15:03:14 <gmann> agenda for today meeting ^^
15:03:24 <gmann> #topic Follow up on past action items
15:04:00 <gmann> three action item from previous meeting
15:04:02 <gmann> gmann to fill PTG survey and team signup for TC discussions
15:04:05 <gmann> this is done
15:04:24 <gmann> I did signup and started the etherpad which we can talk in PTG topic
15:04:31 <gmann> spotz to check with operators about what format they want in virtual PTG. options: 1. join ops hours in the project PTG room and meet/discuss with developer 2. book ops slot in same room/day and ask developer to come to that room and discuss the things
15:04:49 <gmann> spotz started that also and we will discuss it in PTG  topic
15:04:55 <gmann> knikolla to make doodle for ops to pick their availability slots during the PTG
15:04:58 <gmann> ditto,
15:05:20 <gmann> we will discuss these in next topic
15:05:22 <gmann> #topic Gate health check
15:05:31 <gmann> any news on gate health ?
15:05:32 <dansmith> seems like a lot of volume failures lately
15:05:38 <gmann> humm
15:05:41 <jungleboyj> :-(
15:05:53 <dansmith> I haven't tracked any of them myself but there've been a bunch of cinder-related rechecks on the things in my circle lately
15:06:01 <dansmith> across multiple projects
15:06:47 <gmann> ok, is it same volume detach things?
15:07:37 <dansmith> I don't think so, these were timeouts, some related to ssh after volume boot and some were timeout attach I think (although maybe it was detach, I dunno)
15:07:50 <dansmith> just maybe keep an eye out for such things
15:07:51 <gmann> ohk
15:08:21 <gmann> I am not paying much attention to gate for couple of weeks.
15:08:43 <arne_wiebalck> o/
15:08:54 <gmann> rosmaita: jungleboyj : do you know something about these, I think these can be trouble one as release is coming up
15:09:08 <rosmaita> nope, have not heard anything
15:09:13 <jungleboyj> Me either.
15:10:02 <gmann> ok, may be we can report bug and then cinder team can track?
15:10:09 <dansmith> https://a5df54d0fb8cc88c3142-52d827903644c869a8c9978f650a04c3.ssl.cf1.rackcdn.com/852608/10/check/tempest-slow-wallaby/994e35a/testr_results.html
15:10:14 <dansmith> this one was a detach
15:11:58 <dansmith> anyway, no need to debug here, let's just keep an eye out
15:12:58 <gmann> ok
15:13:14 <gmann> in this test we do wait for server for ssh-able but  need to dig more
15:13:28 <gmann> any other frequent failure anyone noticed ?
15:14:12 <rosmaita> that particular failure looks like the volume detached and went to 'available'
15:14:40 <gmann> yeah it seems it stuck after unshelve or so
15:14:48 <gmann> anyways next
15:14:51 <gmann> Bare 'recheck' state
15:14:54 <slaweq> I didn't noticed any often failures (we don't run cinder tests in Neutron)
15:14:58 <gmann> #link https://etherpad.opendev.org/p/recheck-weekly-summary
15:15:03 <gmann> slaweq: ok
15:15:08 <gmann> slaweq: ^^ please go ahead
15:15:15 <gmann> on bare recheck
15:15:18 <slaweq> things looks generally good
15:15:34 <slaweq> I didn't had time to go and talk with people from various teams this week
15:15:40 <slaweq> but it's on my todo list
15:15:59 <gmann> no issue
15:16:05 <slaweq> I'm not sure, maybe it was just that was less rechecks last week, but I think that in general things are not bad there
15:16:18 <gmann> slaweq: sorry for asking again, what are notation in 'Projects with most rechecks:' before comma and after ?
15:16:22 <slaweq> many teams are doing rechecks with giving reasons
15:16:33 <slaweq> it's decimal numbers
15:16:36 <gmann> this one https://etherpad.opendev.org/p/recheck-weekly-summary#L8
15:16:37 <gmann> ohk
15:16:46 <slaweq> sorry, I still forget about US notation of it :)
15:16:51 <slaweq> should be dot
15:17:06 <gmann> :), no issue I will remember it
15:17:26 <gmann> thanks slaweq dansmith for monitoring gate and rechecks
15:17:29 <gmann> moving next
15:17:32 <gmann> #topic 2023.1 cycle PTG Planning
15:17:45 <gmann> I did signup the TC for this PTG
15:18:00 <gmann> and started the planning by creating the etherpad and poll
15:18:06 <gmann> first is TC + Leaders interaction sessions
15:18:14 <gmann> #link https://etherpad.opendev.org/p/tc-leaders-interaction-2023-1
15:18:44 <gmann> similar to last couple of PTG, we will continue this interaction session
15:18:52 <diablo_rojo_phone> Sounds good to me.
15:18:58 <slaweq> +1
15:19:07 <jungleboyj> ++
15:19:28 <gmann> I sent email to vote poll and this is link to select the best available slot, please ask it to your known leaders and also vote #link https://framadate.org/zsOqRxfVcmtjaPBC
15:20:01 <gmann> I added Monday and Tuesday as option for slots like we did in last couple of PTG and when most of the leader are available to join
15:20:16 <gmann> next is TC sessions slots
15:20:28 <gmann> #link https://etherpad.opendev.org/p/tc-2023-1-ptg
15:20:43 <gmann> ^^ this is etherpad to collect the topic, please start adding the topic you would like to discuss
15:21:05 <gmann> and to select the slot timing, i created another poll #link https://framadate.org/yi8LNQaph5wrirks
15:21:30 <gmann> please vote your preferred time. hope I covered all the available slots there
15:21:45 <gmann> any question/feedback till now?
15:21:54 <jungleboyj> Thank you for putting that together.
15:22:01 <knikolla> thank you gmann!
15:22:45 <slaweq> ++
15:22:46 <gmann> I think if we select the TC slots first and it will be easy for many of us to select/vote on the project wise slot we wanted to attend
15:23:06 <jungleboyj> gmann:  ++
15:23:09 <jungleboyj> That is helpful.
15:23:26 <gmann> i observed we kind of wait for each other TC to select first or porject and endup having more time conflicts
15:23:46 <jungleboyj> Agreed.
15:23:49 <gmann> please vote so that we can select TC slots first
15:24:00 <gmann> ok next in PTG topic
15:24:14 <gmann> Schedule 'operator hours' as a separate slot in PTG(avoiding conflicts among other projects 'operator hours')
15:24:35 <gmann> #link https://twitter.com/osopsmeetup/status/1561708283492196353
15:24:52 <gmann> spotz: ^^ first your one, you would like to talk about it of when poll will end?
15:25:02 <diablo_rojo_phone> So it's 50/50 ATM looks like
15:25:04 <gmann> * or when
15:25:30 <gmann> diablo_rojo_phone: it was 60 40 before meeting but 55 the first one
15:25:39 <spotz> The most I could put it up for was 1 week, so it'll close on Monday
15:25:51 <gmann> ok
15:26:03 <diablo_rojo_phone> That seems like a reasonable window of time
15:26:10 <spotz> I also retweeted it from my own account and the RDO account
15:26:18 <gmann> great +1
15:26:26 <knikolla> ++, though i was expecting more votes
15:26:58 <gmann> me too as operators/ops meetup members are more active in twitter i think
15:27:25 <gmann> spotz: did we put this on ML openstack-discuss with [operator] tag?
15:27:27 <spotz> I could email out everyone who was on the original list for Berlin, not sure I have everyone we added on
15:27:41 <knikolla> gmann: good insight on ops being more active on twitter, didn't know that.
15:27:50 <spotz> I did not I thought someone else had that action item but I can
15:27:52 <fungi> [ops] is what we've codified in the protect team guide, i thought
15:27:58 <knikolla> i can also post it to the scientific-sig slack
15:28:04 <gmann> spotz: thanks,
15:28:07 <gmann> knikolla: +1 please do
15:28:28 <spotz> knikolla: that's the feedback we've gotten when we asked how you heard about an event
15:28:29 <gmann> #action spotz to add operators hours slot choice in openstack-discuss ML
15:29:09 <gmann> #action knikolla to message the operatos hours slots choice poll  in scientific-sig slack
15:29:11 <jungleboyj> Yeah, the Ops are definitely more active on Twitter it seems.
15:29:41 <fungi> then maybe they're just not around because it's vacation season
15:29:54 <knikolla> spotz: can you also send out the poll with the email  https://doodle.com/meeting/participate/id/bD9kR2yd
15:29:56 <gmann> let's wait for Modnay till poll close and then in next meeting or so we can discuss
15:30:09 <gmann> #link https://doodle.com/meeting/participate/id/bD9kR2yd/vote
15:30:14 * slaweq needs to leave now, will catch up with the meeting logs later
15:30:14 <gmann> knikolla: ^^ please go ahead
15:30:15 <slaweq> o/
15:30:25 <gmann> slaweq: sure, thanks
15:30:30 <gmann> will ping if anything for you
15:30:47 <gmann> knikolla: what this poll is for exactly? to select the slots in deveoper PTG
15:31:01 <gmann> *developer slots
15:31:09 <knikolla> from the discussion last week, we wanted to get an idea for when to schedule ops w devs sessions
15:31:29 <knikolla> ask ops for availability and have devs schedule on those slots
15:31:35 <knikolla> this was my understanding of last week's discussion
15:32:36 <gmann> knikolla: ok so 1. based on spotz poll we will decide either to schedule separate ops slots/day or schedule it in developers slots 2. then based on your doodle poll we will select the exact time according to spotz poll result
15:33:27 <knikolla> yes
15:33:38 <gmann> sounds good, let's wait for monday and in next week meeitng we will have all the data to finalize it
15:33:40 <spotz> mail sent
15:33:47 <gmann> thanks knikolla spotz, anything else on this?
15:33:52 <knikolla> i'm open to better ideas, but we're missing data points on when to schedule things :)
15:34:15 <gmann> true, it will be helpful
15:34:55 <gmann> especially it is first time we are scheduling such slot, in next PTG we will know more people/operators and feedback form this PTG
15:35:23 <gmann> if nothing else on PTG then moving to next topic
15:35:56 <knikolla> ++
15:36:24 <gmann> #topic 2023.1 cycle Technical Election
15:36:52 <gmann> we talked about the election things in R9 week but we are litlte late to start it actully
15:37:16 <jungleboyj> Where does the time go?
15:37:23 <gmann> as we are little 1 week delay from schedule as per TC charter, this is exception to approve the late schedule #link https://review.opendev.org/c/openstack/governance/+/854624
15:37:33 <knikolla> jungleboyj: what even is time?
15:37:43 * jungleboyj laughs
15:37:45 <gmann> please vote on this exception and then we will go with the proposed dates
15:37:48 <gmann> :)
15:37:53 <spotz> Please approve as quick as possible as we're falling farther behind:(
15:38:17 <gmann> and current proposed schedule is #link https://review.opendev.org/c/openstack/election/+/854453
15:38:21 <gmann> please check that too
15:38:27 <knikolla> diablo_rojo_phone: do you have some more gold stars to get people to vote now on and get this merged? :)
15:38:48 <gmann> spotz I just noticed you already started the election nomination on ML even schedule is not merged
15:38:49 <diablo_rojo_phone> Lol of course.
15:39:06 <spotz> I didn't think we'd be having arguments
15:39:08 <diablo_rojo_phone> I'll review today spotz
15:39:25 <gmann> knikolla one more think, can you propose yourself as election official and you will be able to +2
15:39:29 <fungi> worst case, corrections can be sent to the ml if the schedule ends up changing
15:39:31 <spotz> And well time is ticking and we're late...
15:39:34 <diablo_rojo_phone> spotz: lol yep. That happens.. all too frequently.
15:39:39 <gmann> spotz: till it merge we never know
15:39:54 <spotz> Yeah we gave no warning it was starting as is
15:40:09 <gmann> but we do not have choice now and let's not re-announce it on ML whihc can create more confusion
15:40:15 <spotz> <- was not planning on leading this effort
15:40:17 <knikolla> gmann: i will, thanks for letting me know that such an action is required on my part.
15:40:47 <gmann> now one question/comment on using the release name or number in this election
15:41:09 <gmann> as we said we should use number as primary identifier but it seem we need to update election tooling for that
15:41:31 <knikolla> spotz: i'm keeping notes on every command you run and action you do. so hopefully you won't have to keep stepping up with election stuff.
15:41:39 <diablo_rojo_phone> I don't think what we call the election should hold up the show when we are already behind.
15:41:41 <gmann> spotz: knikolla I am ok with using name in folder but if we can add relaease number also in title of page then we can go ahead
15:41:46 <gmann> as rosmaita also commentd
15:42:07 <diablo_rojo_phone> knikolla: if there are any issues with the docs let me know. I wrote them mostly lol. And I'm around to answer questions.
15:42:13 <spotz> knikolla: Thanks, it was more the oh crap we're late:( Other wise we could have gotten this going before or during Devconf
15:42:28 <gmann> spotz: knikolla it will be good to track all the task in etherpad, i did in last election #link https://etherpad.opendev.org/p/TC_PTL_Elections2022
15:42:52 <gmann> that way, it is less chance to miss the dates
15:43:16 <knikolla> diablo_rojo_phone: Thanks! I already a few docs and fixes patches I'll push after the elections to not cause more reviews than necessary.
15:43:40 <diablo_rojo_phone> Oh cool I can review that stuff too.
15:43:48 <rosmaita> so looking at https://review.opendev.org/c/openstack/election/+/854453 ... i take it the dates are fine now, do we care about https://review.opendev.org/c/openstack/election/+/854453/3/configuration.yaml#2 ?
15:44:02 <spotz> I think with just having the new configuration.yaml in the repo the fact that the email scrip barfs is ok
15:44:03 <gmann> yeah, I think we should fixed this at leasrt https://review.opendev.org/c/openstack/election/+/854453/3/configuration.yaml#2
15:44:22 <gmann> spotz: does it break with this comment fix also ^^
15:44:33 <gmann> or for directory name
15:45:04 <knikolla> So the only question to get that merged is whether we want to stick with Antelope or 2023.1? Or have we come to an agreement on that too?
15:45:11 <gmann> knikolla: please do, I fixed a lot last year but scripts and doc needs to be updated especially for combined election
15:45:36 <spotz> I won't know until I try. I don't think with the way directories are made we want to do like I did for the Exception
15:45:47 <gmann> knikolla: I think we should  use 2023.1
15:46:25 <knikolla> ++, but I'm also fine just merging it and renaming after the fact. I don't want to delay this more than the end of this meeting.
15:46:26 <spotz> We did say for community we should use names though and as fungi pointed out it's a bit odd having 2023.1 in October 2022
15:46:32 <gmann> spotz: knikolla ok, can you please check what if using 2023.1 in directory break or in title page and we can go accordingly. we do not need to fix them instead we can go with using name for now
15:46:44 <diablo_rojo_phone> knikolla: +2
15:47:11 <spotz> We did say for community we should use names though and as fungi pointed out it's a bit odd having 2023.1 in October 2022
15:47:15 <gmann> knikolla: ok, that sounds good plan. we can fix it in followup  as holding it more with nomination announced on ML does not sounds good
15:47:19 <knikolla> Anyone opposed to merging as Antelope and having a larger discussion on how to do this next time and if necessary rename previous?
15:47:24 <dansmith> spotz: got a link to where we said that?
15:47:46 <gmann> spotz: we said use number as primary identifier everywhere except relase tool
15:47:56 <dansmith> that's my recollection
15:47:58 <spotz> I thought Marketing and Community were the point of the OIF taking over vs the name.
15:48:04 <gmann> knikolla:  we did discussed and agree on that,
15:48:12 <gmann> spotz: only marketting
15:48:19 <dansmith> we said marketing can continue handling the name,
15:48:25 <dansmith> but that it was just for marketing use, as I recall
15:48:38 <knikolla> "The release number will be used as the primary identifier in the development cycle but the release name will also be used in some places."
15:48:41 <gmann> I recorded where to use name and number in this https://governance.openstack.org/tc/reference/release-naming.html
15:48:46 <knikolla> It provides a loophole for "in some places"
15:48:53 <gmann> and resolution too #link https://governance.openstack.org/tc/resolutions/20220524-release-identification-process.html
15:49:03 <fungi> the argument for using the name for release tooling is that it's in places where we refer to the development cycle in progress rather than the release that's coming. same argument applies for elections for the development cycle term
15:49:15 <dansmith> knikolla: "in some places" was for the marketing materials IMHO :)
15:49:23 <gmann> knikolla: some place is mentioned explicitly as release tool
15:49:31 <gmann> and yes for marketting
15:49:48 <gmann> "Release page/tooling/milestone name: The release team can choose either to continue using the release name or use number for release tooling and milestone name.
15:49:48 <gmann> "
15:50:00 <diablo_rojo_phone> Well it seems like the election tooling is related release tooling enough that there are issues hopping to numbers when we are already behind schedule.
15:50:20 <gmann> anyways let's not re-discuss about release name/number from what we agreed and passed resolution too
15:50:26 <diablo_rojo_phone> I think we should merge ASAP with the name antelope and deal with what needs to happen to convert to numbers for the next election.
15:50:46 <jungleboyj> diablo_rojo_phone: ++
15:50:46 <gmann> spotz: knikolla I am ok to merge the election as it is and we can add 2023.1 later during nomination
15:50:50 <gmann> rosmaita: ^^ ok for you
15:50:55 <rosmaita> yep
15:50:58 <gmann> ok
15:50:58 <spotz> That was my thought too when the objection came up.
15:51:00 <diablo_rojo_phone> Otherwise, anyone that wants to force numbers right now.. welcome to the election team ;)
15:51:01 <fungi> btu yeah, the bigger concern is that we shouldn't delay an already behind schedule election process trying to scramble to update the tooling for name vs number cosmetics
15:51:19 <rosmaita> fungi: ++
15:51:29 <jungleboyj> Agreed.  I don't think the community is really going to care that much.
15:51:31 <fungi> those changes should have all been made and tested long ago when the decision was made, if it were really that important
15:51:40 <knikolla> ++ seems we have agreement
15:52:05 <diablo_rojo_phone> fungi: +2 +W
15:52:16 <gmann> spotz: knikolla +2 on that patch
15:52:16 <diablo_rojo_phone> Right now is not the time to futz with the tooling.
15:52:37 <gmann> knikolla: you can also add yourself as election official and +W
15:52:45 <spotz> Agreed which is why I changed the configuration/yaml to match what the script was looking for
15:53:01 <diablo_rojo_phone> spotz: +2 makes sense to me.
15:53:20 <gmann> I will try to change scripts/doc, did a lot in last couple of election but I think we need to do mroe changed for release number
15:53:35 <gmann> anything else on election?
15:53:42 <knikolla> gmann: can you please point me where to do that? grepping for "official" is not that helpful :)
15:53:50 <diablo_rojo_phone> Given the historic crossover between the release team and the elections team and how that tooling is written, I'm not surprised that it depends on a name and not a number.
15:54:08 <diablo_rojo_phone> knikolla: it'll be in the Gerrit ACLs
15:54:12 <spotz> As a courtesy if you'e not re-running please post to the list, Some folks won't step up otherwise
15:54:27 <diablo_rojo_phone> spotz: good heads up.
15:54:29 <gmann> knikolla: this one https://review.opendev.org/c/openstack/election/+/825009
15:54:34 <diablo_rojo_phone> Err recommendation
15:54:59 <gmann> spotz: knikolla : also do not forget to ping ianychoi[m] he is great help during election and during asia timezone or so
15:55:21 <gmann> he is one of the long term active election official
15:55:30 <knikolla> https://review.opendev.org/admin/groups/208108b62745877449d8e6fce45f44e3cc013e8b,members here?
15:55:38 <knikolla> i don't have the appropriate permissions
15:55:51 <spotz> Yeah, to be honest yesterday afternoon was just a knee jerk realizing we were late and needing to get started
15:55:54 <gmann> knikolla: I can add you there once your patch is merged for official
15:56:12 <diablo_rojo_phone> spotz: thank you for handling things
15:56:16 <diablo_rojo_phone> It's not a fun job.
15:56:21 <gmann> knikolla: you can propose it like this #link https://review.opendev.org/c/openstack/election/+/825009
15:56:28 <fungi> after the election, it would be good to plan a post-mortem discussion covering things like getting earlier reminders added to the release schedule
15:56:35 <gmann> spotz no issue, thanks for doing it
15:56:54 <gmann> ok we are 4 min left in meeting, anything else on election?
15:57:01 <knikolla> gmann: yes, thanks for the example! doing it now.
15:57:06 <frickler> for the PTL election, the mail says "contributed to the corresponding team during the Zed to Antelope timeframe, Sep 17, 2021 00:00 UTC - Aug 31, 2022 00:00 UTC", that should be "Yoga to Zed" iiuc. the timestamps seem right though
15:57:14 <gmann> knikolla: thanks
15:57:27 <spotz> Yeah that was one thing we promised to do after the lst election which we obviously didn't do. I did put reminders on my calendar for the rest of the elction
15:58:02 <spotz> frickler: I wasn't sure on that so that's my bad and we can patch it after it's merged
15:58:06 <gmann> frickler: +1 nice catch.
15:58:11 <fungi> frickler: yes, it should be yoga and zed cycles, the antelope cycle hasn't started yet
15:58:23 <gmann> spotz: let's fix that and i can +2 again
15:58:50 <spotz> Ok hang on
15:59:20 <gmann> ok,will check after fix. mving on
15:59:23 <gmann> #topic Open Reviews
15:59:31 <opendevreview> Amy Marrich proposed openstack/election master: Start the Antelope Elections for PTL and TC  https://review.opendev.org/c/openstack/election/+/854453
15:59:37 <gmann> #link https://review.opendev.org/q/projects:openstack/governance+is:open
15:59:55 <opendevreview> Kristi Nikolla proposed openstack/election master: Add knikolla as election official for 2023.1 / A  https://review.opendev.org/c/openstack/election/+/854647
16:00:14 <gmann> need few more vote on Adjutant PTL https://review.opendev.org/c/openstack/governance/+/849606
16:00:27 <gmann> testing runtime I will update for cs9 things we discussed
16:00:33 <gmann> that is all from today
16:00:39 <gmann> and we are on time too
16:00:53 <gmann> next meeting will be on 1st Sept and video call
16:00:58 <gmann> thanks everyone for joining
16:01:01 <gmann> #endmeeting