15:00:12 <gmann> #startmeeting tc
15:00:12 <opendevmeet> Meeting started Thu Sep 22 15:00:12 2022 UTC and is due to finish in 60 minutes.  The chair is gmann. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:12 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:12 <opendevmeet> The meeting name has been set to 'tc'
15:00:23 <gmann> tc-members meeting time
15:00:26 <dansmith> o/
15:00:26 <noonedeadpunk> o/
15:00:27 <gmann> #topic Roll call
15:00:27 <JayF> o/
15:00:28 <gmann> o/
15:00:44 <rosmaita> o/
15:00:45 <slaweq> o/
15:01:06 <opendevreview> Kristi Nikolla proposed openstack/governance master: Add nomination for chair for Kristi Nikolla  https://review.opendev.org/c/openstack/governance/+/858947
15:01:24 <knikolla> o/
15:02:05 <gmann> jungleboyj: and arne_wiebalck mentioned they will not be present today
15:02:10 <gmann> #link https://wiki.openstack.org/wiki/Meetings/TechnicalCommittee#Agenda_Suggestions
15:02:13 <gmann> today agenda ^^
15:02:45 <gmann> #topic Follow up on past action items
15:02:56 <gmann> None from previous meeting
15:03:12 <gmann> #topic Gate health check
15:03:18 <gmann> any news on gate?
15:03:30 <slaweq> nothing new from me
15:03:43 <slaweq> things are still running pretty good AFAICT
15:04:08 <dansmith> I have no gate info :(
15:04:54 <rosmaita> no news is good news
15:05:04 <rosmaita> if there was bad news, i think we would hear it
15:05:11 <gmann> one update, py3.10 job is becoming voting now with the new template change and few projects might have it failing.
15:05:18 <slaweq> rosmaita++
15:05:31 <gmann> projects need to fix that first like nova did
15:05:41 <spotz__> o/
15:05:42 <gmann> nothing else form me too on gate. going smooth
15:05:59 <gmann> Bare 'recheck' state
15:06:01 <gmann> #link https://etherpad.opendev.org/p/recheck-weekly-summary
15:06:06 <gmann> slaweq: go ahead
15:06:12 <slaweq> things are good
15:06:28 <slaweq> I emailed PTLs of some projects which were constantly on 100% of bare rechecks
15:06:35 <slaweq> but I did it just today morning
15:06:49 <slaweq> so I will need to wait a bit for effects
15:06:56 <slaweq> that's basically all update for today
15:07:08 <gmann> +1, thanks
15:07:21 <noonedeadpunk> I was actually thinking about reaching PTL during previous meeting, but decided not to chime in too much
15:07:26 <noonedeadpunk> so thanks for that!
15:08:26 <gmann> yeah, its good to spread the awareness more and more.
15:08:37 <fungi> be aware that we're dropping support for ansible versions less than 5 in jobs this weekend
15:09:19 <noonedeadpunk> that might be interesting actually
15:09:22 <fungi> i sent a reminder to the ml already, but i expect it to be a no-op for most projects since we switched our default to 5 months ago and told people then this would be happening eventually
15:09:36 <gmann> +1
15:09:54 <fungi> noonedeadpunk: it doesn't affect nested ansible in jobs, just the ansible versions available on the executors for job definitions
15:10:22 <fungi> i think clarkb found a few places tripleo needed to drop some old version pins, but they're looking into that today supposedly
15:10:35 <noonedeadpunk> fungi: yeah I do understand that. I'm jsut wondering what sdk version is there, as if it's from u-c that will conflict with openstack collection
15:10:47 <fungi> codesearch doesn't really turn up anything else overriding it at this point
15:11:27 <noonedeadpunk> or ansible-opsnatck-collection might be needed to pinned somewhere at master if sdk is 0.101 or smth
15:11:42 <fungi> i don't think this would intersect with places where you're installing python packages. the ansible installs are in their own immutable venvs on the executors and you don't get the ability to install things in those
15:11:58 <noonedeadpunk> nah, for osa it doesn't matter at all
15:12:06 <JayF> Sounds like to me the best approach is to push the change and see if anyone screams, then? Shouldn't be a real concern?
15:12:24 <clarkb> right we don't install the openstack collection unless it is part of the `ansible` package install
15:12:29 <clarkb> we do install openstacksdk though
15:12:29 <fungi> well, the change already got approved, but won't take effect until our automated restarts kick in early utc saturday
15:12:37 <gmann> let's wait for this weekend when it happen and see if any fail
15:12:39 <noonedeadpunk> IIRC venvs are not really immutable with zuul 6.0 +?
15:12:51 <noonedeadpunk> anyway agree, let's try out and see
15:12:55 <gmann> yeah
15:13:15 <gmann> anything else on gate health or rechecks
15:13:48 <gmann> #topic Zed cycle tracker checks
15:14:08 <gmann> #link https://etherpad.opendev.org/p/tc-zed-tracker
15:14:22 <gmann> seems like we are left with 5 items to finish
15:14:33 <gmann> Technical guidlines for logging levels with more example or scenarios
15:14:42 <gmann> Drive the OSC as community-wide goals, be or find champion
15:14:54 <gmann> 2021 user survey analysis:
15:15:04 <gmann> Recognize the new contributor work in some way:
15:15:20 <gmann> basically 4 as i18 SIG things we will discussing in PTG
15:15:29 <gmann> please update on those if you have any?
15:15:59 <noonedeadpunk> I can say that for i18 I beleive most important are translations for horizon and it's plugins
15:16:31 <noonedeadpunk> And I did consumed them for public clouds
15:16:54 <rosmaita> does horizon pass through exception messages?
15:16:55 <gmann> yeah but we are still collecting data who all using what all language  translation
15:19:24 <gmann> if no update, moving next
15:19:25 <noonedeadpunk> rosmaita: well, I actually not sure about last 2 releases
15:20:51 <gmann> let's discuss it in PTG based on some data about usage if we can get that
15:20:56 <gmann> #topic 2023.1 cycle PTG Planning
15:21:04 <gmann> TC + Leaders interaction sessions
15:21:13 <gmann> #link https://etherpad.opendev.org/p/tc-leaders-interaction-2023-1
15:21:30 <gmann> ^^ this is etherpad for TC+Leaders session
15:21:55 <gmann> schedule details are in etherpad which is Monday 15-17 UTC
15:22:07 <gmann> TC PTG etherpad
15:22:19 <gmann> #link https://etherpad.opendev.org/p/tc-2023-1-ptg
15:22:57 <gmann> on TC slots, we discussed in last meeting that we want to use Thursday-Friday 15-17 UTC and 17-19 UTC slots
15:23:32 <gmann> JayF: noonedeadpunk: as you were not in the discussion, are those slots ok for you both?
15:23:54 <JayF> Absolutely; we're already planning around it in the (unfortunately, simultaneous) Ironic PTG planning meeting.
15:24:46 <opendevreview> Merged openstack/governance master: Close Antelope Elections  https://review.opendev.org/c/openstack/governance/+/858539
15:24:58 <noonedeadpunk> Should be fine for me
15:24:59 <gmann> ohk, yeah it is difficult to avoid 100% conflict
15:25:08 <spotz__> Yeah Iput the OPS Meetup on Tuesday to avoid the TC and the ops related placeholders
15:25:17 <gmann> spotz__: cool
15:25:18 <JayF> (I don't mean conflicting with Ironic PTG; I mean literally I'm in a PTG planning call while doing this IRC meeting at the same time)
15:25:29 <gmann> ack
15:26:03 <gmann> and for 17-19 UTC slots which are out of PTG schedule. I checked with PTG organizer and diablo_rojo_phone replied on that.
15:26:38 <gmann> it is difficult to update these timing in ptg bot at this stage as it need to upload the new json file resetting everything
15:26:58 <JayF> Do we generally post .ics files for PTG sessions; similar as to for IRC meetings? If not, I suggest someone own sending out calendar invites to ensure there's clarity in scheduling
15:27:11 <JayF> (and I volunteer to do it if folks think it's a good idea)
15:27:21 <gmann> what we can do to publish these slot - update on ML,  infra-event channel and ptg bot as 'next' thing
15:27:38 <knikolla> that's a really good idea on the calendar invite
15:27:42 <slaweq> ++
15:27:44 <gmann> JayF: that is good idea
15:27:58 <JayF> I trust calendar software to make timezone calculations better than me, especially since that's near DST flip time in some juristictions.
15:28:06 <dansmith> yeah ++ for ics files
15:28:23 <knikolla> ice cream sandwich? :)
15:28:26 <fungi> if someone wants to add that to the ptgbot code, we could presumably publish them on ptg.opendev.org
15:28:41 <JayF> Unless we have a standard way of publishing ICS files, I was tempted to implement this with an actual-meeting-invite
15:28:43 <fungi> seems like it would be a pretty straightforward feature
15:28:53 <JayF> I do not want to volunteer to do what fungi suggests without looking at the code myself first :)
15:29:03 <fungi> you, sir, are a wise man
15:29:18 <gmann> sure, ics invite is always helpful
15:29:33 <noonedeadpunk> but I do really like fungi idea
15:29:49 <JayF> ack; I will put down an action for myself to investigate and either do it or come next week with something concrete to propose
15:30:17 <gmann> JayF: thanks
15:30:29 <knikolla> considering there's less(?) than a month for the ptg, let's only do it if it seems really easy
15:30:34 <gmann> so on slots, let's continue on the thursday-friday 15-19 UTC slots for TC and we can spread the 17-19 slots to community in multiple way.
15:30:54 <JayF> knikolla: that's pretty much exactly waht I had in mind, but don't want to punt something based on assumed difficulty, I want to find out for sure it's hard first :D
15:31:22 <rosmaita> i think attaching the ics file to an email saying when the TC will be meeting should be fine for this PTG
15:31:33 <knikolla> ++
15:31:35 <gmann> +1
15:32:04 <JayF> rosmaita: oh, to the mailing list, that's a good idea, and the obvious solution
15:32:11 <gmann> and in next PTG, we can feedback about opening more slots to minimize the conflicts
15:32:16 <JayF> Yeah, lets do that. Easy, simple, and I can duplicate it for Ironic :D
15:32:22 <rosmaita> fungi: or does the mailer scrub attachments?
15:32:26 <gmann> cool
15:32:51 <fungi> rosmaita: it does not, attachments to the ml are fine but may end up getting moderated if the message encoded exceeds 40kb
15:32:52 <gmann> I think ics cal are sent in many emails
15:33:12 <rosmaita> cool, i think ics are pretty small
15:33:23 <JayF> gmann: I'd assume if it's going out with the announcement email; you'll likely send it with the ICS?
15:33:30 <JayF> gmann: just making sure I'm clear about what action is ahead of me :D
15:33:31 <fungi> even if it does trip the limit, i moderate the messages at least daily most of the time
15:33:34 <gmann> let's send on ML then
15:33:59 <fungi> and if you do get it stuck in moderation, feel free to give me a heads up and i'll try to process it sooner
15:34:12 <gmann> JayF: yes, I will post the final slots on ongoing thread and then you can send the ics file on that. is it fine?
15:34:31 <JayF> gmann: ack; that works for me. I'll look for that email
15:34:35 <knikolla> could we also put in on the main ptg page? https://openinfra.dev/ptg/
15:35:33 <gmann> #action JayF to send the ics file on TC PTG ML thread
15:35:40 <gmann> knikolla: you mean ics or TC slots info?
15:36:01 <JayF> knikolla: (if you mean ICS files) that would be what would require the change to ptgbot; we shouldn't IMO upload ics files to that webpage unless we are going to have them for all sessions
15:36:17 <knikolla> meetings that we want to have a wider reach for. tc + community being the primary i can think of.
15:36:54 <knikolla> Perhaps even a link to the mailing list message message is fine :)
15:37:13 <rosmaita> well, we're kind of a special case because we're meeting out of the scheduled times
15:37:35 <gmann> that is difficult as it need fresh json file to upload  but yes we can put this info on ML and in channel
15:37:47 <rosmaita> i think we could link to JayF's posting on the ML in the "next" message for the ptg bog
15:37:49 <opendevreview> Dmitriy Rabotyagov proposed openstack/governance master: [goal] Propose to use Ubuntu 22.04 for CI/CD  https://review.opendev.org/c/openstack/governance/+/858690
15:37:52 <rosmaita> *bot
15:37:58 <gmann> yeah
15:38:08 <JayF> Sounds like there's a lot of interest in getting support for this in ptgbot in the longer-ish term. I'll follow up on that generally, see if I can assess difficulty and find a volunteer :D
15:38:36 <gmann> ok
15:38:45 <gmann> next thing - Schedule 'operator hours'
15:38:59 <gmann> I see 5 projects booked the operator hours
15:39:03 <noonedeadpunk> I haven;t seen much activity unfortunatelly
15:39:12 <gmann> I will send reminder in next week or so for other projects
15:39:20 <slaweq> I talked with lajoskatona about it this week
15:39:25 <gmann> +1
15:39:27 <slaweq> and he was going to book some slot
15:39:36 <slaweq> I didn't check if he did it already
15:39:40 <gmann> please reachout to known projects/PTL to book it if they want
15:40:13 <JayF> There is a little confusion in the PTG meeting I'm in right now for Ironic: are the placeholder meetings, e.g. like the one 1400 UTC on Weds, intended for projects to take ownership of
15:40:17 <JayF> or are those cross-project?
15:40:33 <JayF> **1300 UTC, not 1400
15:41:08 <noonedeadpunk> yeah, you should unschedule slot first
15:41:10 <gmann> JayF: you can book them with new track like ironic-operator-hour and book slot either from placeholder which will help to avoid conflict from other ops sessions or book as per your schedule
15:41:33 <JayF> ack; we want to take that 1300 UTC Wednesday session, we'll book it via that placeholder for Ironic
15:41:56 <gmann> steps are 1. ask to book new track <project>-operator-hours 2. unbook placeholder slot 3. book that slot with new track
15:42:04 <gmann> thanks
15:42:14 <noonedeadpunk> fwiw step 2 was missing from original email
15:42:24 <gmann> yeah, I missed that to mention
15:43:24 <gmann> thought it is part of 3rd one but should have mentioned as separate
15:43:33 <gmann> anything else on PTG things?
15:44:03 <gmann> #topic 2023.1 cycle Technical Election & Leaderless projects
15:44:15 <gmann> election results are merged #link https://review.opendev.org/c/openstack/governance/+/858539
15:44:45 <gmann> first thanks to election official spotz[m] knikolla jungleboyj ianychoi[m] for your help and smooth election
15:45:00 <gmann> and welcome to the returning and new members noonedeadpunk JayF
15:45:08 <JayF> o/ thank you
15:45:19 <knikolla> welcome :)
15:45:25 <slaweq> Welcome :)
15:45:39 <noonedeadpunk> \o/
15:45:41 <noonedeadpunk> thanks
15:46:13 <gmann> also thanks to chandan and jamespage for their nomination
15:47:15 <spotz__> congrats all
15:47:50 <gmann> also we need to select chair for the next term
15:48:05 <gmann> I saw knikolla nomination for that. its great
15:48:20 <gmann> if anyone else also would like to raise hand for chair, please do
15:48:44 <gmann> I will also would like to continue. will raise the nomination today
15:49:23 <gmann> on PTL: we had 9 projects left without nomination and good news we found leaders for all of them
15:49:33 <gmann> #link https://etherpad.opendev.org/p/2023.1-leaderless
15:49:50 <gmann> I will raise their PTL appointment patches and there we can discuss about it
15:49:59 <gmann> anything else on election ?
15:50:15 <rosmaita> that's good news about the leaderless projects
15:50:22 <rosmaita> i mean, not leaderless
15:50:28 <gmann> yeah
15:51:01 <gmann> #topic Meeting time check
15:51:24 <gmann> as we have new members in TC, let's check the weekly meeting time
15:51:32 <JayF> This time is extremely convienient for me.
15:51:40 <gmann> we usually check in PTG but that is 4 meeting far
15:51:45 <rosmaita> JayF: even after the time change?
15:51:57 <JayF> I work 7a-4p most days, PT
15:51:58 <rosmaita> i mean from DST
15:52:05 <JayF> so either side of DST this is in my normal daily working hours
15:52:11 <gmann> cool
15:52:17 <gmann> noonedeadpunk: how about you?
15:52:24 <JayF> (not to say I'm unwilling to go outside of that if needed :D)
15:52:50 <gmann> we can discuss that in PTG especially on daylight things\
15:52:56 <rosmaita> i'm going to have a conflict after the USA time change, i think
15:53:16 <gmann> just want to make sure those 4 meetings time until PTG are ok or not
15:53:16 <noonedeadpunk> current time works for me nicely gmann
15:53:25 <gmann> ok
15:53:36 <rosmaita> oh, ok, should be fine until PTG
15:53:44 <gmann> rosmaita: ack. let's do that daylight check in PTG
15:54:00 <rosmaita> makes sense, sorry for the noise
15:54:08 <gmann> one more update: I have moved to PST timezone (was in CST).
15:54:41 <gmann> #topic Open Reviews
15:54:44 <gmann> #link https://review.opendev.org/q/projects:openstack/governance+is:open
15:55:16 <gmann> please review those when you have time.
15:55:45 <gmann> noonedeadpunk: thanks for volunteering on CI/CD migration goal #link https://review.opendev.org/c/openstack/governance/+/858690
15:56:02 <gmann> that is all for today meeting, anything else anyone would like to discuss ?
15:56:18 <noonedeadpunk> I actually don't know if that's a valid goal given there's already reference in place
15:56:26 <noonedeadpunk> https://governance.openstack.org/tc/reference/runtimes/2023.1.html
15:56:44 <noonedeadpunk> * #link https://governance.openstack.org/tc/reference/runtimes/2023.1.html
15:56:52 <fungi> the goal provides extra visibility to remind projects they'll need to do work to transition
15:57:00 <gmann> noonedeadpunk: that is valid goal. this migration is big task and need lot of testing and coordination
15:57:38 <gmann> testing in advance before we switch base devstack and tox jobs to new version
15:57:40 <noonedeadpunk> but I guess I will bug you gmann on how it was done before if get stuck somewhere
15:57:51 <gmann> noonedeadpunk: sure, will help you on this.
15:58:12 <gmann> anything else ? 2 min left
15:58:21 <JayF> I'll say generally, as a new TC member I'm looking for input and am willing to chat with anyone who wants to chat. If you wanna chat virtually, reach out. If you're in Puget Sound, WA metro area, lets have lunch sometime. I'm going to be dedicating my first bit of time on TC to factfinding/expanding and these chats would feed into that. This goes triple-y so for my
15:58:24 <JayF> co-TC-members.
15:58:39 <spotz__> Just a reminder we need to pull the AUC list before elections next time to include them
15:58:50 <rosmaita> oops
15:59:02 <gmann> ack.
15:59:13 <gmann> 'AC' list
15:59:27 <knikolla> this election cycle had a fair number of lessons learned.
15:59:31 <gmann> anyone can propose to be in AC list and TC can review it
15:59:46 <spotz__> Yeah, and some repos likke governance, meetings, etc don't count apparently
16:00:08 <gmann> knikolla: good, let's collect those in retrospective in PTG. it will be good for new members helping in future
16:00:19 <knikolla> ++, i can work on that.
16:00:34 * noonedeadpunk totally missed all elections mess details
16:00:40 <spotz__> knikolla: Lets do that in election channel to get everyone's comments
16:00:42 <fungi> spotz__: the tc-repos.yaml uses the same schema as sigs-repos.yaml so could be trivially added to the election tooling
16:00:46 <gmann> added it in etherpad in case we forget
16:00:53 <knikolla> spotz__: ++
16:00:54 <gmann> spotz__: +1
16:01:18 <spotz__> fungi: I personally think any patch should count especially as we're now AC vs ATC only for voting
16:01:19 <gmann> ok, thanks all for joining. our next week meeting will be on sept 29
16:01:37 <spotz__> Thanks gmann, everyone
16:01:40 <slaweq> thx gmann for leading it
16:01:44 <slaweq> thx everyone o/
16:01:45 <gmann> spotz__: let's discuss it in PTG
16:01:56 <gmann> spotz__: this is god point
16:01:57 <JayF> o/
16:02:00 <gmann> *good
16:02:05 <gmann> #endmeeting