16:00:09 <gmann> #startmeeting tc
16:00:09 <opendevmeet> Meeting started Wed Nov  9 16:00:09 2022 UTC and is due to finish in 60 minutes.  The chair is gmann. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:09 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:09 <opendevmeet> The meeting name has been set to 'tc'
16:00:16 <gmann> tc-members: meeting time
16:00:16 <jungleboyj> o/
16:00:18 <dansmith> o/
16:00:20 <noonedeadpunk> o/
16:00:21 <gmann> #topic Roll call
16:00:22 <gmann> o/
16:00:29 <knikolla[m]> o/
16:00:31 <arne_wiebalck> o/
16:00:35 <jungleboyj> I am lurking as usual.
16:00:42 <gmann> +1, thanks
16:00:48 <rosmaita> o/
16:01:39 * noonedeadpunk on trip right now so semi-around but will do my best to follow/be active when needed
16:01:56 <gmann> two member informed in Absence section and can not to join today meeting - Slawek Kaplonski (slaweq) - 10.11.2022
16:01:56 <gmann> Jay Faulkner (JayF) - 2022-11-09
16:02:40 <gmann> let's start
16:02:45 <gmann> today agenda #link https://wiki.openstack.org/wiki/Meetings/TechnicalCommittee#Agenda_Suggestions
16:03:04 <gmann> #topic Follow up on past action items
16:03:21 <gmann> gmann to test the meetpad for video call
16:03:44 <gmann> that is done and it did not show up good for recording and we can go with the zoom option.
16:03:46 <noonedeadpunk> well we kind of tested I believe?
16:03:57 <gmann> yes
16:04:06 <noonedeadpunk> yeah. let's go for gaining zoom room
16:04:16 <clarkb> gmann: and to clarify you used recordrtc?
16:04:37 <gmann> I will contact foundation first if they can provide otherwise JayF also volutneer to use his account
16:05:08 <dansmith> clarkb: recordrtc is client-side yeah?
16:05:24 <gmann> clarkb: I think so, it was client side one present in meetup window
16:05:43 <clarkb> gmann: recordrtc is client side. I don't believe it shows up in meetpad direclty
16:05:55 <clarkb> the functionality in meetpad itself is not enabled (server side)
16:06:03 <gmann> I used the button present in meetpad
16:06:14 <noonedeadpunk> clarkb: it does fwiw
16:06:45 <clarkb> ok I'll have to look at it more closely then. Maybe they added client side using recordrtc. Fwiw my suggestions was that you use the browser plugin instead.
16:07:00 <gmann> ok
16:07:37 <gmann> next action item is - JayF to propose the resolution for the TC weekly meeting on IRC or video call
16:07:49 <gmann> he proposed the resolution #link https://review.opendev.org/c/openstack/governance/+/863685
16:08:08 <gmann> if anyone have not looked or reviewed, please do and leave your feedback/vote there
16:08:13 <noonedeadpunk> We can try browser plugin actually.... Nasty thing would be if someone else would be to record, then this knowledge should be transfered, but I do hate idea of using someones personal/corporate account tbh
16:08:56 <dansmith> client-side seems unideal to me, because we lose the recording if that person gets bumped off
16:09:07 <knikolla[m]> that's why i want us to try to get the opendev zoom first for this.
16:09:09 <gmann> foundation account if we get should be ok like we use it for PTG or so
16:09:28 <dansmith> since the recording is important for the transparency aspect, it would be bad to lose that.. using a proper tool with server-side recording seems better to me
16:09:29 <fungi> there is no opendev zoom, not sure what you meant there
16:09:45 <noonedeadpunk> how we handle ptgs?
16:09:50 <rosmaita> fungi: what about the ptg?
16:09:52 <gmann> yeah, recording is needed if we are meeting in video call
16:10:05 <gmann> noonedeadpunk: rosmaita  you mean foundation account
16:10:11 <fungi> rosmaita: those zoom rooms are provided by the foundation staff, not part of opendev
16:10:15 <gmann> yeah
16:10:28 <knikolla[m]> (foundation, not opendev, my mistake :) )
16:10:34 <fungi> but maybe people aren't all that clear on the distinction between the openinfra foundation and the opendev collaboratory
16:10:46 <rosmaita> i will admit that i am not
16:10:56 <gmann> let me check with foundation and update us.
16:11:11 <noonedeadpunk> I'm confused from time to time as welll
16:11:29 <rosmaita> ok, so what we are talking about is the "openinfra foundation zoom account"
16:12:06 <gmann> yes
16:12:16 <gmann> that is what used in PTGs also
16:12:52 <rosmaita> ok, so much as i despise zoom and all it represents, i think that if we use an openinfra foundation zoom account for meeting and recording and auto-transcribing, we are cool
16:12:59 <fungi> except for teams which choose to use other videoconferencing tools for their ptg sessions (opendev's meetpad service, bluejeans, their own zoom accounts, et cetera)
16:13:15 <gmann> yeah
16:13:44 <gmann> rosmaita: sure, i am not sure about auto-transcribing which did not came well in google meet but we can try in zoom too
16:13:46 <fungi> but the foundation event organizers do temporarily provide a set of zoom rooms during the event for teams which want to use those
16:14:08 <fungi> note that they don't keep those zoom rooms indefinitely, they pay for them for a limited period of time
16:14:33 <fungi> so it's not the same as , say, a room you'd use for a recurring meeting
16:14:34 <rosmaita> yeah, the auto-transcribing may be a stretch, but i was in some kind of meeting software recently and it worked pretty well
16:14:50 <gmann> sure, we can try.
16:15:46 <gmann> fungi: ack, let me check if any permanent zoom can be shared with TC. obviously we will not ask to buy/add new one.
16:16:13 <gmann> ok moving one.. those were the two action item. let me add zoom one also
16:16:39 <gmann> #action gmann to check with foundation about zoom pro account if any and can be shared with TC monthly video call
16:16:47 <gmann> #topic Gate health check
16:16:51 <fungi> when diablo_rojo's around, she may have more input on zoom room options (i don't have a zoom account but i know she does)
16:16:51 <gmann> any news on gate?
16:17:00 <gmann> sure
16:18:11 <dansmith> I haven't seen any repeatable gate failures lately
16:18:23 <dansmith> some instability, but never the same thing twice, so.. I guess that's good? :)
16:18:36 <gmann> nice. same here
16:18:41 <gmann> m-1 is approaching next week and as decided we will be switching the devstack/tempest/tox base jobs to Jammy. and given enough time to projects for testing and fix the issue I think it will be good timing to do that.
16:19:04 <gmann> but that time we might see more gate broken if projects have not given much attention to it
16:19:45 <fungi> we had a few jobs start failing after the opendev default nodeset change to jammy
16:19:46 <gmann> any other updates on gate health?
16:20:11 <gmann> fungi: ohk, in openstack? I thought we had openstack base jobs using ndoeset exolicitly
16:20:27 <fungi> most of those were related to bindep.txt files in projects still including python-dev for ubuntu (without limiting to older platforms where python 2.7 was still available)
16:20:42 <fungi> they were mainly one-off job definitions in various openstack projects
16:20:47 <clarkb> fungi: additionally those projects had long ago dropped python2 support but were still listing it as a dependency
16:21:05 <fungi> right, it was basically just cruft they needed to clean up in their bindep files
16:21:09 <clarkb> fungi: so the bug was introduced when python2 was dropped and not caught until ubnutu changed its python2 package name
16:21:15 <gmann> yeah, I observed that in many projects and tempest plugin too
16:21:35 <fungi> some stable branch jobs also started failing because they didn't declare a specific nodeset, but i think most of those have been addressed now
16:21:39 <gmann> that is easy fix though
16:22:30 <gmann> ok
16:23:12 <gmann> we will be getting more failure when devstack and tox based openstack jobs switching but lets see
16:23:25 <gmann> moving to next topic
16:23:29 <gmann> #topic TC chair election process
16:23:57 <gmann> I updated the patch for dir structure and it is ready to re-review #link https://review.opendev.org/c/openstack/governance/+/862772
16:24:23 <gmann> that is all on this unless anyone has anything to discuss then just check in review?
16:25:17 <gmann> #topic TC stop using storyboard?
16:25:20 <gmann> #link https://storyboard.openstack.org/#!/project/923
16:25:54 <rosmaita> i have to admit, i was unaware that the TC used storyboard
16:25:59 <dansmith> hah
16:26:00 <gmann> TC has project in SB which i think not used for couple of years. At least I have not and tracked TC tasks in etherpad tracker which is much easy
16:26:12 <gmann> yeah, I am not surprise if many member not even know about it
16:26:13 <dansmith> so stop using and not replace it with anything? sounds fine to me :)
16:26:33 <gmann> yeah, I do not think we need LP for governance things.
16:26:40 <fungi> doug set it up as central to the cross-project goal tracking process years ago, but the tc changed its process
16:26:43 <gmann> we started storyboard to track the goal work mainly
16:26:52 <noonedeadpunk> I'd vote for stopping using storyboard
16:27:15 <gmann> and many open tasks/story in governance if for goal which never got updated
16:27:24 <jungleboyj> Given that we didn't know we were in storyboard ...
16:27:31 <gmann> so I feel that it is not much use of goal tracked in SB
16:27:43 <arne_wiebalck> jungleboyj: ++
16:28:04 <fungi> to be fair, the tc has already stopped using sb for quite a long time. what can additionally be done is to drop the use-storyboard flag for that repo in project-config and then i'll toggle the project entry in sb to inactive which should hide it from the new task field/searches
16:28:14 <gmann> I cleaned up many story which work was done but SB was not updated
16:28:48 <rosmaita> fungi: that sounds good
16:28:51 <gmann> yeah, we need to clear it and make explicit that TC not using SB
16:29:25 <fungi> also you may need to do some documentation/readme updates in the governance repo itself if it mentions to track stuff there
16:29:36 <fungi> probably worth a git grep in openstack/governance
16:29:39 <jungleboyj> fungi: ++ That sounds like a reasonable plan.
16:29:49 <gmann> we are missing 3 tc-members today, I will keep it open for next week where we can have formal vote on the decision. do not wan to rush as it is not adding any more work on us than it is currently
16:30:08 <dansmith> yeah, very low priority
16:30:12 <gmann> meanwhile I will cleanup the open story too
16:30:33 <gmann> anything else on this topic?
16:30:41 <rosmaita> nope
16:31:07 <gmann> #topic (added late) 'service' role status
16:31:10 <gmann> #link https://review.opendev.org/c/openstack/keystone-specs/+/818616/
16:31:25 <rosmaita> yeah, i was just wondering if there's anything we can do to help this along
16:31:34 <rosmaita> Abhishek has volunteered to do the implementation
16:31:39 <gmann> I have updated the spec with what we discussed in PTG and abhishek volunteer to implement it which is good
16:31:42 <gmann> +1
16:31:48 <rosmaita> so it's mainly a matter of getting the spec approved
16:32:12 <gmann> yeah, I will bring it in keystone meeting too but knikolla[m] if you can also have a look
16:32:17 <knikolla[m]> i'll review that today
16:32:19 <rosmaita> gmann: yes, your updates have been nice
16:32:24 <rosmaita> knikolla[m]: thanks!
16:32:24 <gmann> perfect, thanks knikolla[m]
16:32:45 <knikolla[m]> we're up to 3 active keystone cores finally, so things will move a bit more slowly. (up from 1 earlier this year)
16:32:51 <knikolla[m]> quickly*
16:32:59 <noonedeadpunk> nice
16:33:11 <jungleboyj> \o/
16:33:13 <rosmaita> \o/
16:33:26 <gmann> +1, nice
16:34:09 <gmann> #topic Recurring tasks check
16:34:11 <gmann> Bare 'recheck' state
16:34:33 <gmann> #link https://etherpad.opendev.org/p/recheck-weekly-summary
16:34:55 <dansmith> I assume no update because we're missing slaweq, but I will say I think we've made a positive contribution by focusing on this
16:34:58 <gmann> slaweq is not here today and I did not see this week summary in etherpad so skipping it which is ok
16:35:07 <dansmith> I see far more "recheck because reason" than bare rechecks lately
16:35:21 <gmann> yeah, many projects also conveying it in their weekly meeting or so
16:35:25 <dansmith> hopefully people are actually looking, or at least feeling guilty about lying, but.. I think this was a good effort for us
16:35:28 <dansmith> yes, that goo
16:35:30 <dansmith> *too
16:35:37 <gmann> ++ agree
16:36:06 <gmann> encouraging more people to debug the failure help overall CI?CD
16:36:09 <gmann> CI/CD
16:36:17 <dansmith> yeah
16:36:22 <rosmaita> ++
16:36:31 <dansmith> maybe too hopeful to think this is why the gate is more stable lately, but.. it certainly can't hurt
16:37:18 <gmann> it definitely contributed to the gate stability
16:38:10 <gmann> #topic Open Reviews
16:38:13 <gmann> #link https://review.opendev.org/q/projects:openstack/governance+is:open
16:38:32 <gmann> ^^ open review, let me check if any pending one we have not talked about or ready to review
16:39:10 <gmann> I think most of are already discussed or waiting for depends-on
16:39:31 <gmann> ok, that is all from agenda today and we have ~21 min left. anything else to discuss ?
16:39:50 <rosmaita> i can give a translations update
16:39:58 <gmann> cool please go ahead
16:40:13 <rosmaita> i may have left the impression last week that Weblate would host openstack translations for free
16:40:32 <rosmaita> i met with their community manager earlier this week and that's not the case because we are so big
16:40:45 <rosmaita> they are willing to give us a 50% discount, though
16:41:04 <rosmaita> which would be 1500 euros/year
16:41:08 <gmann> ohk, I was also thinking it was freee
16:41:22 <rosmaita> yeah, i sort of was, too, but i was mistaken
16:41:37 <dansmith> whoa
16:41:42 <jungleboyj> :-(
16:41:50 <gmann> rosmaita: do we know how much volume they can do it for free? if we decrease our translation to minimum required one?
16:42:08 <fungi> the main issue was the 10k string limit, right?
16:42:13 <rosmaita> no, because it's measured in terms of "source strings", not number of translations
16:42:20 <gmann> ohk
16:42:38 <fungi> so we'd have to stop translating some (parts of) projects and docs
16:43:11 <rosmaita> basically something like that
16:43:19 <rosmaita> i didn't ask about that, though
16:43:20 <gmann> yeah and even the number of language
16:43:24 <fungi> but also it's worth discussing with the foundation if we can get the cost of the service covered
16:43:45 <gmann> humm but will it worth to ask foundation about it?
16:43:47 <fungi> the number of languages was in the acceptable range, if i read the response correctly
16:44:06 <rosmaita> yeah, because it's got to be costing us something in terms of running the current zenata infrastructure
16:44:15 <gmann> I feel like anyone need those translation should come and help with tooling and maintenance
16:44:29 <fungi> the main thing the zanata infrastructure is costing us is risk
16:45:08 <rosmaita> yeah, apparently both Fedora and the Document Foundation (Libre Office) have moved from Zenata to Weblate
16:45:39 <fungi> the servers are donated by rackspace currently, and other than maybe rebooting it if it crashes and the risk that we might not be able to easily rebuild it if something happens to it, there's no monetary cost for the zanata server at present (just risk)
16:46:03 <rosmaita> rackspace++
16:46:50 <gmann> I think we should put a question in user survey that translation now onwards need cost and if you are using it are you ok to help there?
16:46:52 <rosmaita> what would be the correct way to approach the Foundation about this?
16:46:57 <gmann> not sure if we have asked it already?
16:47:16 <rosmaita> gmann: we have that in the 2023 survey, but won't have the answers for quite a while
16:47:37 <gmann> rosmaita: but we have to decide first that it is mandatory things for openstack and has to be sponsored by foundation.
16:47:44 <gmann> rosmaita: ok
16:48:00 <jungleboyj> gmann:  That isn't a bad idea.  Would be interesting to see how many people are using translations.
16:48:05 <gmann> I feel like if anyone need it then they should step up for help
16:49:09 <rosmaita> well, we could do a more immediate survey using some open source survey tool to get this info ... if users know how dire the situation is, they may step up
16:49:27 <gmann> yeah that can be helpful
16:49:57 <rosmaita> ok, the holdup last time was a tool accessible worldwide
16:50:22 <rosmaita> anyone have any suggestions?
16:50:34 <fungi> limesurvey.org isn't accessible worldwide?
16:50:50 <rosmaita> dunno, have not tried it
16:50:55 <rosmaita> (checking now)
16:51:14 <gmann> rosmaita: also, did we send email to community ML where many users group are(or used to be) #link http://lists.openstack.org/cgi-bin/mailman/listinfo/community
16:52:00 <fungi> we ran an instance of limesurvey in opendev for years because it gave us the ability to accept sensitive answers without involving a third party, but nobody ever used it so we eventually retired it, but you can also use their public instance
16:52:48 <rosmaita> ok, https://www.comparitech.com/privacy-security-tools/blockedinchina/  says limesurvey.org is OK
16:53:11 <gmann> cool
16:53:49 <gmann> rosmaita: as we need to take some decision on this, please continue with the survey and getting more info. Let me add this as a separate topic for our meeting.
16:53:51 <rosmaita> ok, i will take an action item to hack together something before the next TC meeting that we can all look at
16:53:52 <gmann> it that ok for you?
16:54:00 <gmann> sure
16:54:01 <rosmaita> yes
16:54:36 <gmann> #action rosmaita to continue his research/survey on translation things and update in TC meetings
16:54:42 <gmann> thanks rosmaita for working on this
16:54:50 <rosmaita> np
16:54:58 <gmann> anything else to discuss ?
16:54:59 <fungi> tc-members (and everyone else too!): don't forget there's a videoconference meeting scheduled between the openstack community and members of the openinfra board of directors in one week, wednesday 2022-11-16 at 20:00-21:00 utc
16:55:32 <rosmaita> thanks for the reminder, i had completely forgotten
16:55:32 <fungi> we booked it months ago so people can't say they didn't know far enough in advance ;)
16:55:35 <gmann> ++, it is after out TC meeting
16:55:46 <fungi> it's a few hours after the tc meeting, but yes after
16:55:57 <gmann> are we continuing old ether pad for that or new one?
16:56:09 <fungi> there is a new etherpad for the new discussion
16:56:31 <fungi> it's linked from the old one, but i can find it
16:56:34 <fungi> just a sec
16:56:35 <rosmaita> fungi: any connection info on that meeting yet?
16:56:38 <gmann> can you please paste the link here
16:56:45 <gmann> ok
16:57:21 <rosmaita> fungi: forget my question ... just realized that the calendar invite was one that i made myself
16:58:08 <gmann> this ?  #link https://etherpad.opendev.org/p/2022-11-board-openstack-sync
16:58:42 <gmann> I think so
16:59:15 <fungi> #link https://etherpad.opendev.org/p/2022-11-board-openstack-sync
16:59:29 <fungi> yes, sorry i had to dig it out of the list archive
16:59:45 <gmann> tc-members: feel free to propose the topic you would like to cover in this meeting with Board. we have few topic going on from berlin summit board meeting which we can continue too
16:59:46 <fungi> TheJulia will presumably send connection info in advance
16:59:55 <fungi> we'll add it to the etherpad when it's available
16:59:59 <gmann> cool
17:00:04 <rosmaita> thanks!
17:00:13 <gmann> thanks for reminding it
17:00:23 <gmann> we are on time. let's close the meeting
17:00:31 <gmann> thanks everyone for joining
17:00:35 <rosmaita> bye!
17:00:36 <gmann> #endmeeting